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Visualizing Images
In this chapter . . .

“Displaying images using the default view” on page 216
“Displaying images using the animate view” on page 246
“Displaying images using the cine (movie) view” on page 255
“Displaying images using the lightbox view” on page 256
“Displaying images using the link to another image view” on page 269
“Displaying images using the triplanar view” on page 270
“Displaying images using the triplanar-dual view” on page 277
“Displaying images using the surface plotter view” on page 293
“To view an image dataset in Fly mode” on page 300
“Displaying images using the volume shear view” on page 306
“Displaying images using the volume renderer view” on page 306

Visualization of image datasets is an important aspect of image analysis. 
Researchers must often visualize the orientation, locality, or progression 
(time) of structures in clinical and non-clinical datasets. This chapter 
explains how to use MIPAV to visualize medical images using views.

Views specify the way image datasets are displayed. Views indicate the 
number of images in a dataset that are displayed at one time and whether 
images in a dataset are manually or automatically advanced. 

In the default view, one image is displayed at a time. If a dataset contains 
more than one image, you can manually advance through the image stack. 
The default view can also display 2D through 5D datasets. For image 
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datasets with more than two dimensions, additional views are available: 
animate, cine (movie), lightbox, link to another image, surface plotter, 
surface render, triplanar, and triplanar-dual. The lightbox view displays two 
or more images, or slices, at once. Others—animate and cine—automatically 
advance the images and display them in succession, much like a cinema 
film.

To gain access to views other than the default view, you use the Image > 
Views menu (Figure 105) in the MIPAV window. Figure 1 lists the types of 
views and the number of images each view displays at one time and 
indicates whether images are manually or automatically advanced in the 
view and the number of dimensions an image must have to be displayed in 
the specified view.  For example, you can view an image dataset that has 
three or more dimensions in cine view, which displays only one image at a 
time and advances images in the forward direction only.

View
Number of images 
displayed

Manual or automatic 
image advancement Dimensionality

Default 1 Manual All (2D, 3D, 4D, 5D)

Animate 1 Automatic (forward, 
reverse, continuous 
looping)

Images with more than 
two dimensions (2D)*

Cine (Movie) 1 Automatic (forward) Images with more than 
two dimensions

*MIPAV can display a 4D dataset that overlays a 3D dataset in the views indicated. If the 4D dataset 
has dimensions that differ from the 3D dataset, the 4D dataset is automatically resampled and 
interpolated into the same dimension space as the 3D dataset.

Figure 105.  Types of views as shown on the Image > Views menu 
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Tip: You can display different views of the same dataset on the desktop at the 
same time.

Lightbox All images in the 
dataset

Manual Images with more than 
two dimensions*

Link to 
another 
image

2 Manual Images with more than 
two dimensions*

Surface 
plotter

1 Automatic and Manual Images with more than 
two dimensions*

Surface 
renderer

All images in the 
dataset

Manual 3D images*

Triplanar 2 Manual 3D and 4D images*

Triplanar-dual 2 images loaded 
together

Manual 3D and 4D images*

Volume 
render 
(shear)

In development

Volume 
renderer

In development

View
Number of images 
displayed

Manual or automatic 
image advancement Dimensionality

*MIPAV can display a 4D dataset that overlays a 3D dataset in the views indicated. If the 4D dataset 
has dimensions that differ from the 3D dataset, the 4D dataset is automatically resampled and 
interpolated into the same dimension space as the 3D dataset.

Figure 105.  Types of views as shown on the Image > Views menu  (continued)
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Displaying images using the default view

When you initially open or load an image dataset, it appears in the image 
window showing the default view (Figure 2).

If you display a 2D image dataset, the title bar only displays the name of the 
file and the magnification level only. If you open an image dataset that has 
more than two dimensions, the title bar displays the name of the file, the 
position of the image in the dataset, the total number of images in the 
dataset, and the magnification level.

Datasets with more than two dimensions typically contain many image 
slices. To manually advance through datasets that contain more than one 

image, you can use the image slice slider or , the Decrements image 

slice icon, or , the Increments image slice icons in the MIPAV window 
(Figure 4). You can also use the lightbox view to find and display a 
particular slice in the image dataset in the default view (refer to “Using the 
lightbox view to update the image slice displayed in the default view” on 
page 47).

Figure 106.  Image window showing the default view for a 2D image
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Magnifying and minifying images
In the default view you can magnify or minify, or reduce, displayed images. 
When you display an image, the magnification level is indicated on the title 
bar of the window. For example, M:4.0 indicates that the image was 
magnified by a factor of four times the original size. You can also use the 
magnifying glass to temporarily magnify or reduce a region of the image. 
You can magnify images to 32 times their original size, reduce them to one-
fourth their original size, or restore them to their original size.

Figure 107.  Image window showing (A) a 2D image, or slice, and (B) an image dataset that has 
more than two dimensions. 

Figure 108.  MIPAV window
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In the MIPAV window, there are three methods for 
magnifying or minifying images:

• Automatically using three preset commands on the Image > Zoom 
menu 

• Manually using the Custom command on the Image > Zoom menu, 
which allows you to create other magnification levels

• Automatically using the icons on the image toolbar

To set the magnification level automatically using the 
preset commands

1 Open an image. 

2 Select Image > Zoom.

3 Select one of the following commands on the Zoom menu:

•  0.5X—To reduce the image by one-half of its current size

•  1X—To restore the image to its original size

•  2X—To enlarge the image by twice its original size

The software immediately changes the magnification level of the image.

Figure 109.  Zoom commands on the Image menu
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To set the magnification manually using the Custom 
command

To manually adjust the magnification level to a specific level that is not 
available through the preset commands or the icons on the image toolbar, 
do the following:

1 Open an image.

2 Select Image > Zoom > Custom. The Custom Magnification dialog box 
(Figure 6) opens.

3 Slide the marker in the Magnification slider to the specific level of 
magnification that you want to apply.

4 Select the interpolation method if desired.

Interpolation is the addition of one or more voxels between two other voxels. 
The interpolation mode is particularly important when an image is magnified 
(and voxels are seen more easily). Three interpolation modes are available: 
nearest, bilinear, and cubic (refer to Figure 6 for more information).

5 Click Apply. MIPAV applies the magnification level and interpolation 
mode to the image.
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Magnification Slide the marker left to decrease the 
magnification or right to increase the 
magnification. You can reduce the image 
to one fourth of its current size or 
enlarge it up to 32 times its current size.

Notice that the number below the center 
of the slider changes as you slide the 
marker to indicate the magnification 
level.

Interpolation Select one of the following methods:

Nearest—Short for nearest neighbor. The replicated voxel is assigned the color of 
the closest voxel. This mode yields more accurate results because other modes 
because the original values are retained. However, if applied, the image may have a 
choppy “stair-step” effect. It is also possible that some data may be lost or 
duplicated.

Bilinear—In this mode, the average of the four nearest voxels (to the newly 
interpolated voxel) is weighted. The interpolated voxel is then assigned the 
resulting color. If this mode is applied, the “stair-step” effect is reduced. However, 
because the view of the data is altered, it is not as accurate as the nearest neighbor 
mode.

Cubic—Short for cubic convolution. This mode is similar to the bilinear mode, 
except that the weighted average of the nearest sixteen voxels is used instead of 
the nearest four. If this mode is applied, the stair-step effect is greatly reduced. 
However, because the view of the data is altered, it is not as accurate as the nearest 
neighbor or bilinear modes.

Apply Applies the magnification and interpolation you specified. 

Cancel Disregards any changes that you made in this dialog box and closes this dialog box.

Help Displays online help for this dialog box.

Figure 110.  Custom Magnification dialog box
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To set the magnification automatically using icons on 
the image toolbar

The three magnification icons on the image toolbar work the same way as 
the three preset commands on the Image > Zoom menu do. Do one or more 
of these tasks:

• To magnify an image, click , the Magnify image 2.0x icon. Each 
time you click Magnify, the image doubles in size. As the magnification 
level increases, it may be necessary to manually adjust the size of the 
window so you can see the entire image at one time. Scroll bars appear 
if the image is too big for the window.

• To minify an image, click , the Magnify image 0.5x icon. Each time 
you click this icon the image is reduced to half size.

• To return the image to the original level of magnification, click , the 
Magnify image 1.0x icon.

Tip: These icons appear on other windows beside the MIPAV window, and they 
work in the same way on each window.

WORKING WITH THE MAGNIFYING GLASS

The magnifying glass is much like a traditional, real-world magnifying glass. 
It allows you to view a portion of the image at a specific magnification level. 
You can select the magnification level, which can be anywhere from 1 to 32 
times the original image size. For example, an image may be the original 
size; however, to examine a specific area more closely, you may want to set 
the magnification level of the magnifying glass to 16 times the original size.

Conversely, if an image uses a high-level of magnification, you may want set 
the magnifying glass to a lower magnification level so that you can gain 
perspective on where a section fits with the whole image.
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To use the magnifying glass

1 Open an image.

2 Click , the Magnify Region icon, on the Image toolbar in the MIPAV 
window.

3 Move the cursor to the image. The cursor shape changes to the 
magnifying glass shape, a box outlined in red with the level of 
magnification in the lower left corner (Figure 7). The area inside the box 
is magnified.

You can move the magnifying glass to different places on the image. 
This allows different regions to be magnified without affecting 
magnification level of the entire image. When you want to return to 
normal magnification, click the Default Mode icon.

To adjust magnifying glass settings

1 Do either of the following:

• Select Image > Magnifying Glass Settings. 

• Right-click on the image.

The Magnification Settings dialog box (Figure 8) appears.

Figure 111.  Magnified region
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2 Move the Magnification slider to select the level of magnification. The 
number in bold in the middle of the slider indicates the current level of 
magnification.

3 Specify the size of the magnifying region (box) in the Width text box. 
(The width and the length are the same.) Values are in voxels.

4 Select Display intensity values if you want to see the intensity values of 
the voxels in the magnifying glass (Figure 9). 

5 Click Apply. The new settings are applied to the magnifying glass.

Magnification Specifies the level 
of magnification in 
the magnified 
region. You can 
select a 
magnification from 
1 to 32 times the 
original size of the 
image.

Display 
intensity 
values

Shows the 
intensity values of 
the voxels in four 
areas in the 
magnified region. 
This check box is 
only available for 
magnifications 21 
to 32.

Width Indicates the size of the magnified region in voxels; in 
other words, of the magnifying glass.

Apply Applies the parameters in this dialog box to the 
magnifying glass. 

Close Disregards any changes that you made in this dialog 
box and closes this dialog box.

Help Displays online help for this dialog box.

Figure 112.  Magnification Settings dialog box
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Viewing two images together
When two separate image files are loaded into the same window (for 
directions on how to load an image, refer to Chapter 3, “Getting Started 
Quickly with MIPAV”), the window displays a blending of both images. 
MIPAV refers to the first image file as “Image A” and to the second image 
file as “Image B.” By default, Image A is active and Image B is inactive. To 
change which image is active, simply select, as appropriate, the Image A or 
Image B radio button. 

By default, Image A is active and Image B is inactive. Thus, even if two 
image files are loaded into the same image window, only Image A—which is 
the designation MIPAV assigns to the first image that was opened in the 
window—is displayed.

You can view the inactive image using one of the following methods: 

• Adjust the alphablending value so that you can see the inactive and 
active images simultaneously

• View the part of Image B that is directly under that portion of Image A 

by using , the Window region of Image B icon.

• View portions of the image using the checkerboard tool 

Figure 113.  Magnified region showing intensities
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COMPARING IMAGES USING ALPHABLENDING

Alphablending is a technique that adds transparency information to trans-
lucent objects. It is used to blend what is currently rendered on the display 
(i.e., Image A) with the contents of the frame buffer (i.e., Image B). Each 
colored voxel is assigned an alpha value, which represents transparency. 
The alpha value is used to blend the intensities, voxel by voxel. When two 
images share a window, you can adjust the alphablending settings so that 
you can see a blend of both images and can compare overlapping regions in 
two datasets. See Figure 114.

To use the alphablending tool and Window Region 
tool

1 Open two images.

2 Load the second image into the image window of the first image. The 
Active Image and Alphablending slider appears at the bottom of the 
MIPAV window (Figure 11).

The level of translucency for one image is inversely proportional to the 
other. Thus, if Image A is 75 percent transparent and 25 percent 
opaque; Image B is 75 percent opaque and 25 percent transparent 
(“Alphablending: An Example” on page 20).

Figure 114.  MIPAV window showing the Alphablending slider
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Note: In the MIPAV window, notice that an additional magnifying glass is now 

available: , the Window Region of Image B icon, which you use to view the 
portion of Image B that is directly under that portion of Image A.

3 Move the Active Image and Alphablending slider between the Image A 
and Image B radio buttons.

Alphablending: An Example

For a very clear example of how alphablending 

works, open two images and then apply , the 
Hot Metal LUT icon, to one of the images before 
you load them together. After the images are 
loaded, move the Active Image and 
Alphablending slider from the left to the right. 
The following images show what you see at five 
points of the slider:

(A) The image on the far left shows 100 percent 
of Image A. It does not display a blending of the 
images.

However, for any of the images below, you can 

use the , Window Region of Image B icon, to 
inspect the portion of Image B that lies 
underneath that same portion of Image A.

(B) The next image displays a blending of 75 
percent Image A and 25 percent of Image B. 

Again, use  to see the portion of Image B 
beneath Image A.

(C) The middle image displays 50 percent 
blending of both Image A and Image B. You can 

use  to inspect Image B.

(D) The fourth image displays 75 percent of 
Image B and only 25 percent of Image A. You 

can use  still to inspect Image B.

(E) The final image on the right displays 100 
percent of Image B. Since all of Image B is 

shown, you no longer have a need to use .
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Depending on the direction in which you are moving the slider (that is, 
toward Image A or toward Image B), one image becomes more visible. 
To examine each image in more detail, you can use the magnifying 
glasses.

As you move the slider, the images in the image window are updated 
instantly. If not, release the mouse button to update the image.

Move the slider all the way to the right or to the left depending on which 
image you want to see. For example, to see Image B, move the slider to 
the far right. To see Image A, move the slider (Figure 10) to the far left. 
The closer the slider is to the middle, the more blended are the images.
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To make images active or inactive

1 Open two images.

2 Load the second image into the first image window. The MIPAV window 
expands to include the Active Image and Alphablending slider 
(Figure 115).

3 Notice that Image A is currently the active image.

4 Select Image B in the Active Image and Alphablending slider to make 
Image B the active image.

5 Move the slider to the far right. As you are moving the slider, more of 
Image B appears in the image window. When the slider reaches the far 
right, all of Image B appears in the image window.

6 Click , the Default Mode icon.

If you want to take an action on one of the images—for example, adjusting 
the contrast or running an algorithm—make sure that it is the active image. 
If the inactive image is Image B, you also have the option of using the Image 
B region tool to view portions of the Image B. If the active image is currently 
Image A and you want to view Image B, simply select the Image B radio 
button. To make Image A the active image, select the Image A radio button.

Figure 115.  MIPAV window 
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VIEWING PORTIONS OF IMAGES USING THE 
CHECKERBOARD

The checkerboard tool displays both portions of both images in an alternat-
ing fashion, much like the squares on a checkerboard. A traditional checker-
board has a grid of alternating dark-colored and light-colored squares. 
Portions of Image A appear where the light-colored squares would appear 
on the checkerboard; portions of Image B appear in place of the dark-col-
ored squares. You can adjust the number of rows and columns displayed.

To use the checkerboard tool

1 Open two images.

2 Load the second image into the first image window. The MIPAV window 
expands to include the Active Image and Alphablending slider.Click 

. The Checkerboard Pattern dialog box (Figure 12) appears.

3 Select Use checkerboarding if it is not already selected.
.

4 Adjust the Rows slider to indicate the number of rows that should be in 
the checkerboard pattern.

Use 
checkerboarding

Specifies to use checkerboarding. 

Rows Indicates the number of rows you 
want to display in the checkerboard. 
You can display from 1 to 50 rows.

Columns Indicates the number of columns you 
want to display in the checkerboard. 
You can display from 1 to 50 
columns.

Apply Applies the parameters that you 
specified to the images.

Close Closes this dialog box.

Cancel Disregards any changes you made in this dialog box, closes the dialog box, and 
does not apply checker boarding.

Help Displays online help for this dialog box.

Figure 116.  Checkerboard Pattern dialog box
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5 Click Apply when finished. The checkerboard pattern appears in the 
image window (Figure 13).

When the rows and columns intersect, a grid is created. Adjacent 
squares in the grid alternatively display the active and inactive images.

6 Click Close to close the Checkerboard Pattern dialog box.

Note: If you select another image—that is, an image that is not loaded into the 
same window as Image A and Image B, the Active Image and Alphablending 
slider disappears from the MIPAV window. The slider only appears when the 
selected image window contains two images.

To remove the checkerboard from the image

1 Click . The Checkerboard Pattern dialog box (Figure 12 on page 22) 
appears.

2 Clear Use checkerboarding.

3 Click Apply. MIPAV removes the checkerboard from the image.

4 Click Close.

Figure 117.  Examples of the checkerboard pattern
MIPAV User’s Guide, Volume 1, Basics 230

12/2/08 



M   I   P   A   V
M e d i c a l   I m a g e   P r o c e s s i n g, A n a l y s i s,   &   V i s u a l i z a t i o n

MIPAV User’s Guide, Volume 1, Basics
Changing image brightness and contrast using LUTs
Generally, computer systems have brightness display values written in the 
display hardware. These values are known as the physical color map; they 
are hard coded in your monitor. When you open an image, the image file 
contains data that indicates the intensity of each voxel in the image. These 
data are passed to the physical color map and displayed on the monitor. 
Additionally, MIPAV provides a logical color map, which allows you to 
remap the original intensities to other intensities. Although technically the 
term look-up table (LUT) can be used for the physical and logical color 
maps, in this guide look-up table refers to the logical color map only. You 
can apply predefined, pseudo color or inverse LUTs, or you can manually 
manipulate the transfer function used to map the image data to the LUT. 
The LUT then translates the remapped values so that they can be inter-
preted by the physical color map and displayed on your monitor.

To adjust the look-up table using the Quick LUT 

To adjust the LUT, you open the Look-up Table window to modify the LUT’s 
values and transfer function. However, you can use the Quick LUT icon to 
modify the LUT without opening the Look-up Table window. Quick LUT 
allows you to easily choose the highest and lowest values for the intensity 
levels in a user- defined area. 

To do this, complete the following steps:

1 Open an image.

2 Click  (Quick LUT) in the MIPAV window. 
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3 Move the cursor to the image window and draw a box around an area 
that has the highest and lowest intensities you want the image to 
display. These values are used to remap the image data to the LUT. The 
net effect is increased contrast in the area of interest (Figure 14).

To generate a histogram and look-up table

A histogram is a graphic representation of the intensity level distribution in 
an image or VOI region. It displays the number of voxels at each intensity 
level. The histogram and LUT appear in the Look-up Table window. 

To generate a histogram, and view the LUT, complete the following steps:

1 Open an image. The image appears in an image window.

2 Create a VOI on the image (optional step).

3 Do either of the following:

• Click Look-up Table.

• Select LUT > Histogram –LUT. 

If the image contains a VOI, the Histogram window appears (Figure 15). 
Go to the next step.

Figure 118.  An image before and after applying Quick LUT
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If there are no VOIs on the image, the Look-up Table window 
(Figure 16) appears.

4 Choose one of the following:

• Whole image—To generate a histogram for the whole image 

• VOI region(s)—To generate a histogram for the VOI region of the 
image

5 Click OK. A progress message appears briefly. After a few moments, the 
Look-up Table window appears (Figure 16).

Figure 119.  Histogram dialog box
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File Open LUT—Opens a 
previously saved LUT file. 
LUT files have a .LUT 
extension.

Save LUT—Saves the LUT 
displayed in this window in a 
LUT file.

Open Transfer Functions—
Opens a previously saved 
transfer function. Transfer 
function files have a .FUN 
extension.

Save Transfer Functions—
Saves the transfer function 
displayed in this window to a 
file.

Close LUT—Closes the LUT 
window.

Utilities Change number of colors—
Allows you to change the 
number of colors displayed in 
the image. 

Valid values are 2 to 256.

CT function—Allows you to select a preset LUT that is appropriate for the image 
content. Values are abdomen, head, lung, mediastinum, spine, and vertebrae.

Invert LUT—Creates a negative of the image.

Reset histogram and LUT A—Returns image A to its original values.

Reset histogram and LUT B—Returns image B to its original values. This command is 
only available if two images are open.

LUT toolbar Provides tools that allow you to manipulate the displayed image. Refer to Figure 19.

Update 
(real-time)

Changes the image as you make changes to the LUT, which allows you to see the 
effect of your changes immediately on the image.

Log scale 
(histogram)

Displays the image’s histogram count in log scale along the Y axis.

Interpolate 
image

Displays image using interpolation, which reduces pixilated image to appear more 
smooth.

Caution: Depending on the memory resources of your workstation, interpolation 
can be very lengthy.

Figure 120.  Look-up Table window
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The Look-up Table window consists of three sections: a menu bar, a toolbar, 
and one or more pages containing histograms. A tab appears for each image 
that is opened in the image window. For example, if only one image is in the 
image window, then only the Image A tab appears. If you generated the 
histogram for an image window that contains two images, a tab for Image A 
and a tab for Image B appear. Each of these tabbed pages contain a 
histogram for the applicable image. If you generated the histogram for a 
VOI, the window does not display a tab and only the applicable icons and 
buttons in the toolbar appear.

The toolbar allows you to manipulate the displayed image. You can apply 
pseudocolor LUTs, adjust the image contrast with the transfer function, and 
apply preset window and level settings for CT slices. You can also edit the 
red, blue, green, and alpha channels of a LUT.

look-up table (LUT)—Indicates the intensity of each voxel in the image and, in 
MIPAV, allows you to remap the original intensities to other intensities.

transfer function—Reflects the relationship between the original image 
intensity values and how they are mapped into the LUT. The line in the LUT 
represents the transfer function.

Note: You can generate a histogram for two image datasets that are loaded 
together. In this case, the Look-up Table window (Figure 17) shows two tabs—
one for Image A and one for Image B.

Number of 
colors

Allows you to change the number of colors displayed in the image. 

LUT Displays the image intensities.

Figure 120.  Look-up Table window (continued)
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To update images in real time

When you modify the LUT, be sure to select the Update (real time) check 
box. The image in the image window is then updated in real time. 

Figure 121.  Look-up Table window showing Image A and B histograms
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To change the number of intensities displayed in the 
LUT

You can change the number of intensities displayed in the LUT. To do this, 
do the following:

1 Select Utilities > Change Number of Colors in the LUT window. The 
Change Number of Colors dialog box opens.

2 Type the number of colors you want in the Number of colors box. You 
can specify any whole number between 2 and 256.

3 Select Apply to apply the changes. 

Notice that the Number of colors box in the LUT window now displays 
the number you specified and the histogram changes to display the new 
colors. 

4 Click Close or Cancel to close the dialog box. 

APPLYING PREDEFINED LUTS TO IMAGES

You can use MIPAV’s predefined LUTs to apply pseudocolor, create a 
negative of the image, and apply preset CT window and level settings to an 
image.

To apply pseudocolor LUTs to images

As you examine an image, you may need to observe small changes in 
intensity values or identify the same intensity values in different portions of 
an image. This can be difficult if the image is rendered in grayscale because 
the human eye can only see about 100 shades of gray. However, because 
varied colors are often easier to distinguish, MIPAV allows you to use 
various pseudocolor maps to elucidate objects of interest. Thus, MIPAV 
provides a variety of pseudocolor LUTs. If you apply a pseudocolor LUT, the 
grayscale intensity values are remapped to color intensity values. Note that 

Figure 122.  Change Number of Colors dialog box
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the original image data is not changed; only the displayed image file (hence 
the term pseudocolor).

To apply a pseudocolor LUT, click one of the following icons: 

•  Red LUT

•  Green LUT

•  Blue LUT

•  Gray blue/red LUT

•  Hot metal LUT

•  Spectrum LUT

•  Cool hot LUT

•  Striped LUT

•  Invert LUT

The grayscale intensity values in the image dataset are remapped to color 
intensity values.

To invert intensities

To invert the intensities so that a negative of the dataset appears, click , 
the Invert LUT icon. The Invert LUT icon is in both the Look-up Table 
window (Figure 16 on page 26) and the MIPAV window. Figure 19 on 
page 30 shows the location of this icon in the Look-up Table window.

To apply CT level presets to images

There are six CT window and level presets: abdomen, head, lung, 
mediastinum, spine, and vertebrae. To apply a preset level to the image, 

Figure 123.  LUT toolbar
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complete the following steps: 

1 Click , the CT Preset icon, in the LUT window. The CT Presets dialog 
box appears (Figure 20).

2 Select the desired CT preset. As you select the CT preset option, the 
colors in the image’s histogram or LUT change, and, if you chose to 
update images in real time, the image changes.

3 Click OK to save the change. 

ADJUSTING CONTRAST USING THE TRANSFER 
FUNCTION

The transfer function reflects the relationship between the original image 
intensity values and how they are mapped into the LUT. An example of how 
adjusting the transfer function affects the display of an image appears in 
Figure 16. In this example, the top image is generated by applying the linear 
transfer function (slope = 1) to produce display values that are evenly 
distributed over the range of the LUT (see Figure 125A). This results, in this 
case, in a low-contrast image (see Figure 125B). The contrast of the image 
can be improved by adjusting the transfer function in a manner shown in 
Figure 125A (e.g., changing a low-contrast image into a high-contrast 
image). The image scalar values between –175 and 275 are remapped as a 
function of the modified transfer function and distributed across the full 

Figure 124.  CT Presets dialog box
MIPAV User’s Guide, Volume 1, Basics 239

12/2/08 



M   I   P   A   V
M e d i c a l   I m a g e   P r o c e s s i n g, A n a l y s i s,   &   V i s u a l i z a t i o n

MIPAV User’s Guide, Volume 1, Basics
LUT range. The values above 275 are remapped to white and the values 
below –175 are remapped to black. The effect can be readily seen in 
Figure 125B.

To modify transfer functions

1 Open an image. The image appears in the default image window.

2 Click , the Displays Look-up Table (LUT) icon. The Look-up Table 
dialog box opens.

3 Click the transfer function. A new node may appear.

4 Drag the node to the new location.

You can also adjust the transfer function for the alpha, red, green, and 
blue channels in an image. 

Example: You might want to use these icons to highlight certain intensities in a 
particular color. 

To do this, click the appropriate one of the following icons: 

• , the Edit Alpha icon

• , the Edit Red icon

• , the Edit Green icon

• , the Edit Blue icon

When you click on one of these icons, the transfer function for that 
channel appears on the histogram and a node appears on that transfer 
function. Drag the node to the desired position. To adjust another 
channel, you must click on the icon and drag the node to the appropriate 
position.
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Figure 125.  An image before and after modifying the transfer function
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To save transfer functions

To save a transfer function to a file, complete the following steps:

1 In the Look-up Table dialog box, select File > Save Transfer Functions 
(Figure 126) or press Ctrl+S. The Save dialog box (Figure 127) appears.

2 Type a name to the transfer function in the File Name box. Be sure to 
add the .fun extension to the file name.

3 Click Save. The program saves the transfer function under the name you 
specified.

Figure 126.  Open and Save commands in the File menu

Figure 127.  Save dialog box
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To apply previously saved transfer functions

To open a transfer function file and apply it to an image, complete the 
following steps:

1 Select File > Open Transfer Functions in the Look-up Table window. 
The Open dialog box appears.

2 Select the desired file. LUT files have a .fun extension. 

3 Click Open. The program applies the transfer functions file to the 
current image.

To save LUTs for later use

1 Select File > Save LUT in the Look-up Table window, or press Ctrl S. 
The Save dialog box (Figure 128) appears.

2 Type a name for the LUT in the File Name box. Be sure to add the .lut 
extension to the file name. 

3 Click Save. The program saves the LUT under the name you specified.

To open and apply previously saved LUTs to images

1 Select File > Open LUT in the Look-up Table window, or press Ctrl O. 
The Open dialog box (Figure 25) appears.

2 Select the desired file. LUT files have a .lut extension. 

Figure 128.  Save dialog box 
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3 Click Open. The program applies the LUT settings from the LUT file you 
specified to the current image file.

To open, save, and apply frequently used LUTs

For a LUT that you defined and expect to use frequently, MIPAV provides a 
simple method for saving, opening, and applying it without needing to use 
the commands on the File menu. You use two icons on the toolbar in the 
Look-up Table window:

• , the Save User-Defined LUT icon, allows you to save the LUT.

• , the Open User-Defined LUT icon, provides a very quick way of 
opening and applying the user-defined LUT

Recommendation: Because these icons only apply to one user-defined LUT, 

it is recommended that you select the LUT that is used most frequently.

Figure 129.  Open dialog box
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To reset original LUTs to images

Click , the Grayscale icon in the Look-up Table window (refer to 

Figure 16 and Figure 19). Alternatively, you can click , the Reset LUT icon, 
in the MIPAV window.

To adjust the threshold

1 Open an image. The image appears in the default image window.

2 Click , the Displays Look-up Table (LUT) icon. The Look-up Table 
dialog box opens.

3 Click , the Dual threshold function icon. The Threshold icon becomes 
active and the transfer function of the histogram changes.

4 Select Algorithms > Threshold. The Threshold dialog box (Figure 26) 
opens.

Set lower limits 
between (1.0–
3774.0)

Threshold limit for the 
lowest image intensities.

Set threshold 
between 
(1258.3334–3774.0)

Threshold limit for the 
highest image intensities.

Produce binary image Produces a binary image 
(Boolean).

Set values outside of 
limits to

Specifies the intensity value 
to assign to values outside 
the threshold limits.

New image Shows the results of the 
algorithm in a new image 
window

Replace image Replaces the current active image with the results of the algorithm.

Whole image Applies the algorithm to the whole image.

VOI regions Applies the algorithm to the volumes (regions) delineated by the VOIs.

OK Applies the changes you made in this dialog box and closes the dialog 
box.

Figure 130.  Threshold dialog box
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5 Complete the dialog box.

Note: You can choose to generate a binary image (Boolean) by selecting the 
Produce binary Image check box. Alternatively, you can clear the binary option 
and enter a threshold value. If you still want to generate a Boolean image, select 
the check box again. Note that, if you generate a Boolean image, MIPAV does not 
allow you to reapply the threshold or to generate either a histogram or LUT for a 
Boolean image.

6 Click OK to apply the threshold.

Displaying images using the animate view

If you select the animate view, the software makes a copy of the image 
dataset and loads it into an image window showing the animate view. In 
animate view, like cine view, the software automatically advances through 
the entire image dataset. However, the animate view allows you to adjust 
the speed at which images are advanced. You can specify that images be 
displayed in forward or reverse order. You can also pause or stop the 
sequence.

To view an image dataset in animate view

1 Select Image > Views > Animate in the MIPAV window. The Animate 
Parameters dialog box (Figure 27) appears.

2 Type the scale factor that you want to use in the Scale factor box.

Cancel Disregards any changes you made in this dialog box, closes the dialog 
box, and does not change the threshold.

Help Displays online help for this dialog box.

Figure 130.  Threshold dialog box (continued)
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3 Select one of the three interpolation methods. 

4 Click OK. 

MIPAV transforms the dataset using the scale factor and interpolation 
method you indicated. A progress message (Figure 28) appears while 
the program constructs the animated file. It then loads a copy of the 
dataset in the Animate window.

.   

Scale factor Changes the size of the dataset by the factor 
specified. 

Unlike magnification, the number of voxels used 
to replicate the image may change. For 
example, if you scale a dataset by a factor of 2, 
the image becomes twice the original size, and 
the number of voxels is squared.

Interpolation Determines the intensity of the additional voxels using one of the three following 
methods:

Bilinear—Weighs the average of the four nearest voxels (to the newly interpolated 
voxel). The interpolated voxel is assigned the resulting intensity.

Bspline 3rd order—Weighs the average of the 27 nearest voxels (to the newly 
interpolated voxel).

Bspline 4th order—Weighs the average of the 64 nearest voxels (to the newly 
interpolated voxel).

OK Applies the scale factor and interpolation to the image dataset according to the 
specifications in this dialog box.

Cancel Disregards any changes that you made in this dialog box and closes this dialog box.

Help Displays online help for this dialog box.

Figure 131.  Animate Parameters dialog box

Figure 132.  Animate progress message
MIPAV User’s Guide, Volume 1, Basics 247

12/2/08 



M   I   P   A   V
M e d i c a l   I m a g e   P r o c e s s i n g, A n a l y s i s,   &   V i s u a l i z a t i o n

MIPAV User’s Guide, Volume 1, Basics
File Save Image as .avi—Saves the dataset as an AVI, or digital video, file.

Close Animate—Closes the Animate window.

Options Show Z Slice Numbers—Displays, if selected, the slice number, or the frame 
number, on the lower left side of the image.

 Continuous 
reverse

Steps through all of the images in the dataset continuously in reverse without 
stopping at the speed specified in Desired frames per second.

 Reverse

Steps through all of the images in the dataset once in reverse at the speed 
specified in Desired frames per second. 

 Forward

Steps through all of the images in the dataset once in sequence at the speed 
specified in Desired frames per second. 

 Continuous 
forward

Steps through all of the images in the dataset continuously without stopping at 
the speed specified in Desired Frames per second.

 Backward 
and forward

Steps through all of the images in the dataset in sequence and then in reverse 
continuously without stopping at the speed specified in Desired Frames per 
second. 

Figure 133.  Image window shown in the Animate view
MIPAV User’s Guide, Volume 1, Basics 248

12/2/08 



M   I   P   A   V
M e d i c a l   I m a g e   P r o c e s s i n g, A n a l y s i s,   &   V i s u a l i z a t i o n

MIPAV User’s Guide, Volume 1, Basics
ADJUSTING DATASET DISPLAY

You can magnify or reduce the display of your dataset using the 

magnification icons. Use , the Magnify image 2.0x icon, to enlarge the 
image to twice its current size.

 Pause

Pauses the animation at the frame currently shown. 

 Stop

Halts the animation and redisplays the first image in the dataset. 

 Magnify 
image 2.0X

Magnifies the image by 2. 

 Magnify 
image 0.5x

Magnifies the image by one-half.

 Set 
brightness/
contrast

Specifies the brightness and contrast of the image. When you select this icon, 
the Brightness/Contrast dialog box opens. To change the brightness, slide the 
Brightness slider to the level desired and then click Apply. To change the 
contrast, slide the Contrast slider to the level desired and click Apply.

 Delete 
current slice

Removes the slice currently shown in this window from the image dataset. 

Caution: The program does not allow you to undo slice deletion. Before you 
delete slices, you may want to have a backup of the complete image dataset to 
avoid losing images. 

Frame number Sets the first image slice shown to the frame, or slice, number that you specify. 
Notice that the frame number appears in the box to the right of the slider.

Desired frames 
per second

Specifies how many frames, or slices, should appear in 1 second. The read-only 
box to the right shows the actual number of frames per second your computer 
has achieved. The number of frames per second depends on the amount of 
memory accessible by the computer and CPU time.

Figure 133.  Image window shown in the Animate view (continued)
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ADJUSTING THE BRIGHTNESS AND CONTRAST 
IN IMAGES

To adjust the brightness and contrast in the image, do the following:

1 Click , the Brightness/Contrast icon, in the Animate window. The 
Brightness/Contrast dialog box (Figure 30) opens.

2 Move the Brightness slider to the position you want. Notice that the 
level of brightness changes on the image as you move the slider.

3 Move the Contrast slider to the desired contrast level. The contrast in 
the image changes as you move the slider.

4 Click Apply when you are finished. The image in the Animate window 
reflects the changes in brightness and contrast that you made.

5 Click , the close button at the top right of the dialog box, to close the 
dialog box.

REMOVING SLICES FROM IMAGE DATASETS

In the Animate window, you can also remove slices from the dataset. First, 
you need to find the slice that you want to delete. To find a slice number, do 
either of the following:

Brightness Specifies the level of brightness to apply to the 
image.

Contrast Specifies the level of contrast to apply to the image.

Apply Applies the brightness or contrast you specified to 
the image.

Cancel Disregards any changes that you made in this dialog 
box and closes this dialog box.

Help Displays online help for this dialog box.

Figure 134.  Brightness/Contrast dialog box
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• Select Options > Show Z Slice Numbers, which shows the slice number 
at the lower left of the image (refer to Figure 29 on page 40).

• Move the Frame Number slider to the slice that you want to delete. The 
number appears in the box on the right of the slider.

Once you locate the slice that you want to remove, click , the Delete icon. 
The slice is removed from the dataset.

Caution: The program does not allow you to undo slice deletion. Before you 
delete slices, you may want to have a backup of the complete image dataset 
to avoid losing images.

Figure 135.  In the Animate dialog box, the slice number appears in the 
information box beside the Frame Number slider, and the Desired 
Frames per Second information box shows the actual number of slices 
per second.
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PLAYING A DATASET “FILM”

Using the icons and buttons on the toolbar in the Animate window 
(Figure 29 on page 40), you can produce and play a dataset “film.” To do so, 
complete the following steps:

1 Move the Frame number slider to the slice that you want to see first.

2 Move the Desired frames per second slider to indicate the speed at 
which images should be advanced or reversed.

3 Click the following buttons as appropriate:

• Click , the Forward icon, to advance the image dataset forward 
through all of the images one time (one loop).

• Click , the Reverse icon, to advance the image dataset backward 
through all of the images one time (one loop).

• Click , the Continuous Forward icon, to advance the image dataset 
forward through all of the images multiple times. To stop image 

advancement, you must press , the Pause icon, or , the Stop 
icon.

• Click , the Continuous Reverse icon, to advance the image dataset 
backward through all of the images multiple times. You must press the 

press , the Pause icon, or , the Stop icon, to stop image reversal.

• Click , the Pause icon, to pause the image advancement or reversal.

• Click , the Stop icon, to stop the image advancement or reversal.

Note: As the images advance or reverse, you may notice that the desired frames 
per second and the actual frames per second differ. Although you can type any 
number in the desired frames per second, the actual speed at which the images 
advance depends primarily on your computer's processor speed.
MIPAV User’s Guide, Volume 1, Basics 252

12/2/08 



M   I   P   A   V
M e d i c a l   I m a g e   P r o c e s s i n g, A n a l y s i s,   &   V i s u a l i z a t i o n

MIPAV User’s Guide, Volume 1, Basics
4 Save the animate viewer file by selecting File > Save Image as .avi (AVI, 
or audio video interleaved, is a Microsoft multimedia format). The 
Choose Type of AVI File dialog box (Figure 32) opens.

5 Select a type of file.

6 Click OK. The program runs the animation sequence that you created, 
closes this dialog box, and then displays the Save dialog box.

7 Specify a name for the animation sequence in the File Name box. 

8 Click OK. The dialog box closes and the Choose File Type dialog box 
(Figure 33) opens.

24-bit 
uncompressed 
RGB

An uncompressed RGB file, which uses 8 
bits per color (red, green, blue).

8-bit RLE 
compressed 

A run length encoded (RLE) file that is 
converted to 8 bits and is compressed.

Quicktime movie An Apple format.

Motion JPEG A format that consists of motion JPEGs.

MPEG-4 version 2 Another compression format.

OK Plays back the animated sequence that you created and then displays the 
Save dialog box for you to save the sequence.

Cancel Disregards any changes that you made in this dialog box and closes this 
dialog box.

Help Displays online help for this dialog box.

Figure 136.  Choose Type of AVI File dialog box
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9 Select a file type.

10 Click OK. The Save Range of Slices dialog box (Figure 34) opens.

11 Close the Animate window by either selecting File > Close Animate or 
pressing Ctrl X. The Animate window closes.

Figure 137.  Choose File Type dialog box
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Displaying images using the cine (movie) view

The cine view, like the default view, displays images one at a time in the 
default image window. However, in cine view, the software automatically 
advances the images.

To display a 3D or 4D dataset in this view, select Image > Views > Cine 

Save image to 
separate files

Saves the animation to separate files. 
Selecting this check box makes the 
First file starting number text box and 
the File name number of digits text box 
become active. 

First file 
starting 
number

Indicates which frame, or slice, to 
begin the first file saved. To make this 
box active, you must first select Save 
image to separate files.

File name 
number of 
digits

Specifies how may digits you want used 
for the file name. To make this box 
active, you must first select Save image 
to separate files.

First slice Specifies the first slice that should 
appear in the animation file.

Last slice Specifies the last slice that should 
appear in the animation file.

First time 
period

Specifies the time period of the images that should start the file. This box only 
applies to 4D images.

Last time 
period

Specifies the time period of the images that should end the file. This box only 
applies to 4D images.

Save with 
packed bits 
compression

Indicates that the file should be saved as compressed TIFF files. This check box 
only applies to 4D images.

OK Saves the animation according to the specifications in this dialog box and closes 
the dialog box.

Cancel Disregards any changes that you made in this dialog box and closes this dialog 
box.

Help Displays online help for this dialog box.

Figure 138.  Save Range of Slices dialog box
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(Movie). The images appear sequentially in the default image window. All 
images in the dataset are displayed only once. The cine view does not loop 
images, nor does it show images in reverse order.

Displaying images using the lightbox view

You can use the lightbox view to display datasets that have more than two 
dimensions (2D). Like its real-world counterpart, the lightbox view displays 
several images, or slices, in the dataset at one time in an image window. 
Through the lightbox settings, you can easily control the number of slices 
that appear.

To view an image dataset in lightbox view

1 Open an image dataset that has more than two dimensions. It appears in 
the image window in default view (Figure 35).

2 Select Image > Views > Lightbox in the MIPAV window. The image 
window for the lightbox view appears (Figure 35). The image number, 
or slice number, appears in the lower left corner of each image.

Notice that the image you originally opened in step 1 remains on your 
desktop. So you not only see the image dataset in the lightbox view, but 
you also see the image in the default view. 
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Using the lightbox view to update the image 
slice displayed in the default view

The MIPAV window allows you to step through all of the slices of an image 
dataset shown in the default view one at a time using the Image slice slider, 

, the Decrements image slice icon, and , the Increments image slice 
icon. However, the default view only shows one slice at a time, but the 
lightbox view can show two or more slices at one time depending on the 
lightbox settings (that is, you can control the number of image slices that 
appear in lightbox view; refer to “Adjusting the lightbox view” on page 50).

Suppose it is easier for you to find a particular slice in the dataset by viewing 
several slices at the same time in order to compare them against each other. 
To do so, you would open an image dataset in default view and then display 
the dataset in lightbox view. The lightbox view displays the number of image 
slices that you had already specified. 

At this point your desktop shows both the image dataset in default view and 
the dataset in lightbox view. The lightbox view allows you to quickly look 
through the entire dataset until you locate the correct slice. Once you find it, 
you may want to perform some actions, such as running algorithms, on that 
slice. To update the image in the default view to display the slice you located, 
first select and then right-click the image slice in the lightbox view. The 
default image window now shows the image slice you found.
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Edit Select All—selects all of the slices in 
the dataset.

Select None—deselects all of the 
selected slices.

Invert Selections— deselects 
selected slices and select those that 
were not selected.

Delete—deletes the selected slices 
from the dataset.

Extract—copies the selected slices to 
a separate image window, which you 
can save as a separate dataset.

 

View First Page—displays the first set* of 
slices in the dataset.

Previous Page—displays the 
previous set* of slices in the dataset. 

Next Page—displays the next set* 
of slices in the dataset.

Last Page—displays the last set* of 
slices in the dataset. 

Options Settings—allows you to change settings for the number of rows and 
columns used to display images in the dataset, change the grid size and the 
size of the frame border, change the colors of the borders and frames, and 
the level of magnification.

Save Settings—saves the settings currently set in the Lightbox Settings 
dialog box.

Continuous Update—updates all of the displayed images when you make 
a change to one of the images.

 Default mode

Displays the images according to the standard settings used by MIPAV when 
it is initially installed.

 Magnify region

Magnifies a portion of the image from 1 to 32 times. To change the level of 
magnification or the size of the magnifier, right-click on the image, and the 
Magnification dialog box opens.

 Repaints 
images

Updates the images displayed in the lightbox reflecting the changes made 
to the lightbox settings and to the dataset.

Figure 139.  Image window showing the lightbox view
*The set of slices depends on the number of slices currently being displayed. For example, if four slices are currently 
displayed, then View > Previous Page shows the previous set of four slices. If seven slices are currently displayed, then 
View > Previous Page displays the previous seven slices in the dataset. View > Next Page works similarly. It displays the 
next set of slices in the dataset.
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Adjusting the lightbox view
By default, the lightbox view shows only one column of images. Each image 
in the dataset is surrounded by frame borders and background (Figure 36). 
However, you can adjust the lightbox view so that you can see several 

 Delete selected 
slices

Removes the selected slices from the image dataset. 

 Extract 
selected slices to a 
new image

Makes a copy of the selected slices in the image dataset to a new image 
window. 

 First page

Displays the first set* of slices in the dataset.

 Previous page

Displays the previous set* of slices in the dataset. 

 Next page

Displays the next set* of slices in the dataset.

 Last page

Displays the last set* of slices in the dataset.

 Go to active 
slice

Displays the currently selected slice.

Go to slice Specifies which slice you want to display. Type a number in this box and 
then select Enter to display the slice. The slice then appears in the lightbox 
view.

Image window Displays an individual slice in the dataset. To select a slice, click once on the 
slice. A thin red line appears around the slice inside the border.

Border Outlines each slice. 

Background Provides the grid for the images in the window.

Figure 139.  Image window showing the lightbox view (continued)
*The set of slices depends on the number of slices currently being displayed. For example, if four slices are currently 
displayed, then View > Previous Page shows the previous set of four slices. If seven slices are currently displayed, then 
View > Previous Page displays the previous seven slices in the dataset. View > Next Page works similarly. It displays the 
next set of slices in the dataset.
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columns and rows of images at a time (Figure 36) in a grid. You can also 
adjust the borders and the default magnification level of the images.

To change the grid configuration

1 Select Options > Settings in the image window for the lightbox view. The 
Lightbox Settings dialog box (Figure 140) appears.

2 Select Row.

3 Type the number of rows you want to appear in No. rows.

4 Select Column.

5 Type the number of columns in No. columns.

Row Selects the row settings.

Column Selects the column 
settings.

No. rows Specifies the number of 
rows that should exist in 
the lightbox view.

No. 
columns

Specifies the number of 
columns that should exist 
in the lightbox view.

Grid size Indicates the spacing in 
pixels used for the grid 
size.

Frame 
border 
slice

Indicates the spacing in 
pixels used in the grid.

Backgroun
d color

Allows you to choose the 
color of the background of 
the lightbox. When you 
select this icon, the Pick 
Background Color dialog 
box opens.

Border 
color

Allows you to choose the color of the border that surrounds each image displayed in 
the lightbox. When you select this icon, the Pick Border Color dialog box opens.

Magnificat
ion

Controls the level of magnification. 

Apply Applies the parameters that you specified to the lightbox view.

Figure 140.  Lightbox Settings dialog box
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6 Click Apply. Notice that the number of rows and columns in the lightbox 
view changed to the numbers you specified.

7 Continue to make changes to other lightbox settings. 

8 Click Close to close the Lightbox Settings dialog box. 

9 Click Options > Save Settings to save the settings as the default number 
of rows or columns for the next time you display the lightbox view.

To change the grid size

1 Select Options > Settings in the image window for the lightbox view. The 
Lightbox Settings dialog box (Figure 37) appears.

2 Type a number from 0 to 20 in Grid size (Figure 38). 

Note: On the right of the Grid size text box, Grid spacing shows the current grid 
size.

3 Click Apply. Notice that the grid size in the lightbox view changed to the 
size that you specified.

4 Continue to make changes to other lightbox settings, or click Close to 
close the Lightbox Settings dialog box. The image window for the 
lightbox view appears.

5 Click Options > Save Settings (Figure 39) to save the settings as the grid 
size for the next time you display the lightbox view.

Reset Returns all of the parameters to their default values.

Close Closes this dialog box without making changes to the lightbox view. If you changed 
the parameters in this dialog box, you must first select Apply to put those changes 
into effect.

Help Displays online help for this dialog box.

Figure 140.  Lightbox Settings dialog box (continued)

Figure 141.  Grid size box 
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Figure 142.  Save Settings command on the Options menu in the 
Lightbox Settings dialog box

Figure 143.  Grid and frame border
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To change the border size

1 Select Options > Settings in the image window for the lightbox view. The 
Lightbox Settings dialog box (Figure 37 on page 51) appears.

2 Type a number from 0 to 10 in Frame border size (Figure 41). The unit 
of measurement for the number is in pixels.

3 Click Apply. On the right of Frame border size, Border size changed to 
the size you specified.

4 Continue to make changes to other lightbox settings, or click Close to 
close the Lightbox Settings dialog box. 

5 Click Options > Save Settings to save the settings as the default border 
size for the next time you display the lightbox view.

To change background and border colors

1 Select Options > Settings in the image window containing the lightbox 
view. The Lightbox Settings dialog box (Figure 37 on page 51) appears.

Notice that Background color displays the color of the current grid 
border, and Border Color shows the color of the current frame border.

2 Click the background color bar (Figure 42). 

The Pick Background Color dialog box (Figure 43) opens.

Figure 144.  Frame border size box

Figure 145.  Background color and border color bars 
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This dialog box includes three tabbed pages: 

• Swatches page (Figure 43), which, by default, is always displayed 
first

• HSB page (Figure 43)

• RGB page (Figure 43)

You can change the color of the background on any of these pages
.

3 Select a color from the Swatches, HSB, or RGB page. (For instructions 
on how to select colors, refer to “Manually creating a mask using paint” 
on page 332 in Chapter 6, “Segmenting Images Using Contours and 
Masks”).

Figure 146.  Swatches page in the Pick Background Color dialog box
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4 Click OK to apply the color to the background or border. 

The Pick a Background Color dialog box closes, and the Lightbox 
Settings dialog box appears.

5 Click Apply. 

Notice that the color of the background or border colors in the lightbox 
view changed to the colors you specified.

Figure 147.  HSB page in the Pick Background Color dialog box

Figure 148.  RGB page in the Pick Background Color dialog box
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6 Continue to make changes to other lightbox settings, or click Close to 
close the Lightbox Settings dialog box. 

7  Click Options > Save Settings in the lightbox view to save the settings as 
the default background and border colors for the next time you display 
the lightbox view.

To change the default magnification level for one 
slice in the dataset

1 Click . 

2 Right-click on the image. The Magnification dialog box (Figure 46) 
opens.

3 Change the magnification level by sliding the marker on the 
Magnification slider to the level you want.

4 Select Display intensity values if you would prefer to see the intensity 
values in the magnified region rather than the magnified image.

5 Type a number from 64 to 390 to enlarge or reduce the size of the 
magnified region.

6 Click Apply. The settings specified in the Magnification dialog box take 
effect immediately and only for that one image, or slice.

Figure 149.  Magnification dialog box
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To enlarge or reduce the size of all images 

1 Select Options > Settings in the image window containing the lightbox 
view. The Lightbox Settings dialog box opens (Figure 37 on page 51).

2 Select the level of magnification by moving the slider right or left to the 
appropriate value.

3 Click Apply. Notice that the image magnification changed to the 
magnification you specified.

4 Continue to make changes to other lightbox settings, or click Close to 
close the Lightbox Settings dialog box. 

5 Click Options > Save Settings in the lightbox view to save the settings as 
the default magnification for the next time you display the lightbox 
view. 

Tip: To return to the original settings for the lightbox view, click Reset in the 
Lightbox Settings dialog box.

In the example shown in Figure 47, the researcher changed the original 
lightbox view (Figure 47A) in several ways. The number of rows was 
increased from two to four and the number of images in each row from two 
to three. The frame border color was changed from yellow to gray and the 
grid color from blue to black. Also the magnification level of the images was 
reduced to 38 percent of the original image size. Figure 47B shows the final 
lightbox view.

Repainting (updating) the lightbox
You can simultaneously display the same dataset in different views on your 
desktop. For example, you can display the dataset in default view and in 
lightbox view. If you perform an action on the dataset that is visualized in 
default view, such as contour a structure, you can update the dataset display 
so that the contours also appear in lightbox view. You can do this 
automatically or manually.

To automatically update the dataset in the image 
window

Select Options > Continuous Update in the lightbox view. The dataset is 
refreshed whenever a change occurs in the default image window. 
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Caution: Although this option is convenient, it may slow software 
response time if you are working with a large dataset.

To manually update the dataset in the image window

Click , the Repaint icon, from the toolbar in the lightbox view.

To close the Lightbox window

Click  in the upper right corner of the Lightbox window. A confirmation 
message (Figure 48) appears. To close the window, click Yes and the 
Lightbox window closes. If you change your mind about leaving the lightbox 
view, click No.

.

(A) original lightbox view (image on the left) and (B) changed lightbox view (image on the right)

Figure 150.  Some of the display options available in lightbox view: 
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Displaying images using the link to another 
image view

At times you may want to compare two images slice by slice side by side. 
Linking one image to another allows you to make this type of detailed 
comparison.

To compare images side by side

1 Open the two images you want to compare.

2 Select one of the images. This image becomes known as Image A, and 
the second image becomes known as Image B.

3 Select Image > Views > Link to Another Image. The Image Frame 
Linker dialog box opens.

4 Select the name of the second image, or Image B, in the Image B box.

5 Click Link. MIPAV immediately connects the images.

6 Move the Image slice slider in the MIPAV window. Notice that the 
image slices change on both images so that Image B shows the exact 
same slice as shown on Image A.

Tip: Select Image B, and move the Image slice slider. Although the slices change 
in Image B, they do not change in Image A. The reason is that only Image A 
controls the simultaneous movement of slices for both images. Therefore, when 
you select an image to be Image A, make sure that the image is the one you 
want to control the movement of both images.

Figure 151.  Lightbox Close message
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Displaying images using the triplanar view

The triplanar view allows you to see three orthogonal planes of 3D or 4D 
datasets. The three orthogonal views enhance the visualization of important 
aspects of the anatomy and, in some cases, aids some manual segmentation 
processes.

Displaying image datasets in triplanar view
To view an image dataset in triplanar view, open an image and then select 
Image > View > Triplanar in the MIPAV window. The triplanar view 
(Figure 50 on page 62) appears in an image window.

The image window for the triplanar view includes a File menu, an Options 
menu, a toolbar, and three views of the dataset. The bottom right corner of 
the window displays the currently selected coordinate. Two guidelines 
(cross hairs) also intersect at the selected point. Additionally, the axis 
appears in the upper left corner in each view of the dataset.

You can use icons and buttons on the toolbar to change the magnification 
level, draw a point or line, apply paint, and apply a new intensity values to 
selected voxels in the image.

Image A Indicates the name of the Image A file. This field is a 
read-only field.

Image B Allows you to choose the open image that you want to 
use as Image B.

Link Links the two image files.

Cancel Disregards any changes you made in this dialog box, 
closes the dialog box, and does not link the images.

Help Displays online help for this dialog box.

Figure 152.  Image Frame Linker dialog box 
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Designating new center points for image datasets
You can designate a new center point for the dataset. To do this, complete 
the following steps:

1 Click , the Volume Center icon, to display the center of a volume. The 
cross hairs intersect where the center of the volume has been calculated.

2 Drag the cross hairs to the point that you want to designate as the new 
center.

3 Release the mouse button.

4 Click Apply. The Apply Transformation Matrix dialog box (Figure 51 on 
page 65) opens.

5 Complete the dialog box.

Figure 153.  Image window showing the triplanar view
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File Close frame—Closes this window.

Options Show Axes—Displays the XY (top left), ZY (top right), and ZX (bottom 
left) axes on the images.

Show Cross Hairs—Displays cross-hair lines on the images. When you 
move these lines on one image, it also moves to the corresponding points 
on the other two images. Notice that the Absolute and Position values at 
the bottom right of the screen also change when you move the cross 
hairs.

Show Talairach Grid—Displays a Talairach (stereo tactic) grid on the 
images.

Show Talairach Position—Lists the Talairach position. 

Link to Another TriImage—Links this image to another image in 
triplanar view.

 Traverse image
Aligns two images. 

 Magnify

Magnifies the image. It might be necessary to manually resize the 
window and use scroll bars to view all of the image.

 Minify

Minifies the image (reduces the magnification level).

 Original                          
magnification

Displays image at the original magnification level.

 Volume center

Reassigns a new center to the dataset. The location that you select 
appears in the center of the image window.

 Alignment tool

Allows you to apply a transformation matrix to an image dataset.

 Apply

Applies the rotations and translations made to the image. 

 Point

Draws a point on an image.

 New Contour

Assigns the subsequently drawn contour to a new group. If this icon is 
not selected, all subsequent contours are assigned to the existing group.

Figure 153.  Image window showing the triplanar view (continued)
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 Delete

Deletes a single contour or a group of contours. 

Caution: When you select this icon, the contour is not copied to the 
clipboard. It is permanently deleted.

 Crop Volume

Indicates the volume that should be cropped. 

 Crop

Crops the specified volume.

 Paint Brush

Selects paint brush tool. You can use the paint brush to fill specific voxels 
with color. 

 Eyedropper

Changes the default intensity to the one sampled by the eyedropper. 
Click this icon, then move the pointer to the image. The sampled 
intensity becomes the default intensity.

 Paint Grow

Applies the paint grow segmentation method. This method uses voxel 
aggregation to group voxels into larger regions. The effect is much like a 
fill operation; when you click a voxel, this algorithm is used to determine 
whether adjacent voxels should be filled with the default color or 
intensity.

 Erase

Deletes painted sections of the image. To delete, click the icon and move 
the pointer on painted areas of the image.

 Global Erase

Deletes all paint from the image.

 Small Tip

Used with the paint brush and erase icons. Click this icon to indicate the 
size of the eraser or the paint brush tip. Click this icon to paint or erase 
one voxel each time the mouse button is clicked.

 Medium Tip

Used with the paint brush and erase icons. Click this icon to indicate the 
size of the eraser or the paint brush tip. Click this icon to paint or erase 
16 voxels (4 x 4 square) each time the mouse button is clicked.

 Large Tip

Used with the paint brush and erase icons. Click this icon to indicate the 
size of the eraser or the paint brush tip. Click this icon to paint or erase 
100 voxels (10 x 10 square) each time the mouse button is clicked.

 Paint Intensity

Indicates the intensity value.

 Change Paint 
Color

Changes the color of the paint used. This icon is often used in conjunction 
with the Paint Brush and Paint Grow icons. Click this icon and select the 
desired color from the window that appears.

Figure 153.  Image window showing the triplanar view (continued)
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6 Click Apply. A progress message appears as the image is transformed. In 
a few moments, the new image either appears in a new window or 
replaces the image in the current window depending on your choice. 

7 Select  again. Notice that the image center was moved to the center 
you designated.

 Opacity

Indicates the opacity level of the paint. When this icon is clicked, a 
window appears that allows you to indicate the opacity of the paint: 0 is 
transparent, 1 is opaque. By default the paint is translucent (0.3), which 
allows you to see the original image under the paint.

 Commit

Permanently applies intensity level to the image.

Figure 153.  Image window showing the triplanar view (continued)

Interpolation Determines the intensity of the 
additional voxels using one of the three 
following methods:
Bilinear—Weighs the average of the 
four nearest voxels (to the newly 
interpolated voxel). The interpolated 
voxel is assigned the resulting intensity.

Bspline 3rd order—Weighs the 
average of the 27 nearest voxels (to the 
newly interpolated voxel).

Bspline 4th order—Weighs the 
average of the 64 nearest voxels (to the 
newly interpolated voxel).

New image Indicates where the results of the transformation appear. If you select this option, 
the transformed image appears in a new image window.

Replace image Indicates where the results of the transformation appear. If you select this option, 
the transformed image replaces the current active image. 

Apply Applies the transformation to the image dataset according to the specifications in 
this dialog box.

Cancel Disregards any changes that you made in this dialog box and closes this dialog 
box.

Help Displays online help for this dialog box.

Figure 154.  Apply Transformation dialog box showing choices in the Interpolation list
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Aligning image datasets

You can use , the Alignment Tool icon, to create a new transformation 
matrix for the dataset (refer to Figure 52). 

The following instructions explain how to use the alignment tool:

1 Click . A closed angle, which looks like a line that is slightly thicker 
on one end, appears on each of the three images displayed in triplanar 
view.

2 Click the angle. Arrows appear at the end of each ray. The measurement 
of the angle appears beneath the angle.

Figure 155.  Using the alignment tool in triplanar view
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3 Open the angle. The angle degree indicates the direction and distance to 
rotate the image. You can open the angle with or without constraints. (If 
an angle is opened with constraints, it only opens in 90-degree 
increments.) Do the following:

• To open the angle in 90-degree increments: Position the pointer 
over the shorter ray of the angle. The pointer changes to a cross-hair 
shape. (The cross-hair pointer looks much like a plus sign.) Drag the 
shorter ray to the desired location. The new angle measurement 
appears below the angle.

• To open an angle without constraints: Position the pointer over the 
longer ray of the angle. The pointer changes to a cross-hair shape. 
The cross-hair pointer looks much like a plus sign. Drag the longer 
ray to the desired location. The new angle measurement appears 
below the angle.

4 Click Apply. The Apply Transformation Matrix dialog box (Figure 51 on 
page 65) appears.

5 Complete the dialog box.

6 Click Apply. 

A progress message appears as the image is transformed. In a few 
moments, depending on your choice in the dialog box, the new image 
either appears in a new window or replaces the image in the current 
window.

7 Click , the Traverse Image icon, to return the cursor to normal mode.

Creating, modifying, and deleting point VOIs
You can create, modify, and delete a point VOI. For more information on 
how to do this, see Chapter 7.
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Cropping images
To crop an image, complete the following steps:

1 In an image window that is displaying the image dataset in triplanar 

view, click , the Crop Volume tool. 

2 Draw a rectangle around the area of the image that you want to remain. 
The area outside of the rectangle will be cropped.

3 Click . A confirmation box appears.

4 Click Apply. The cropped area appears in a separate window. 

Changing the intensity
For information on how to change the intensity of a portion of the image, 
refer to “To change the number of intensities displayed in the LUT” on 
page 29 and “To invert intensities” on page 31. In addition, refer to 
“Generating masks” on page 196.

Displaying images using the triplanar-dual view

The triplanar-dual view displays two image datasets (referred to as Image 
A and Image B) and a blended version of both Image A and Image B from 
three orthogonal planes.

To view image datasets using this view

1 Open two 3D or 4D images, which become known as Image A and Image 
B.

2 Load Image B into Image A.

3 Select Image > Views > Triplanar-Dual. The triplanar-dual view appears 
in an image window.
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The image window for the triplanar-dual view is quite similar to the image 
window for the triplanar view. The File and Options menus contain the 
same commands except for one command—the Options menu for the 
triplanar view contains the command Link to Another TriImage. Since the 
triplanar-dual view shows two datasets in the image window and allows you 
to manipulate them together, linking to another image is not necessary. 
Most of the icons and buttons on the toolbars for both views are the same 
with one primary difference: The triplanar-dual view allows you to create 
VOIs on the images; the triplanar view does not.

Like the triplanar view, you can use the icons and buttons on the toolbar to 
change magnification, draw, change colors, change opacity, and apply a new 
intensity to selected voxels in the images.

Figure 156.  Image A, Image B, and Image B loaded into Image A
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Showing and hiding axes, cross hairs, and Talairach 
grid

By default, the triplanar-dual view automatically shows the axes and cross 
hairs on Image A, Image B, and the blended dataset. 

To show or hide axes on images

To hide the axes, select Options > Show Axes (Figure 54). The check mark 
disappears from the check box in front of the command on the menu, and 
the axes disappear from all of the images.

To display the axes on the images again, simply select Options > Show Axes. 
The check mark reappears in the check box in front of the command.

To show or hide cross hairs

Showing or hiding cross hairs works just as showing or hiding axes. To hide 
the cross hairs, select Options > Show Cross Hairs. To show them, select 
Options > Show Cross Hairs again. 

To show or hide the Talairach grid

By default, the Talairach grid does not automatically display on the images 
unless you specifically select it to do so. To show the grid, select Options > 
Show Talairach Grid. The grid appears on all of the images shown in the 
triplanar-dual view. When you want to hide the grid, select Options > Show 
Talairach Grid again.

Creating VOIs on images
You can create point or line VOIs on the images.

Figure 157.  Show Axes command on the Options menu in the Triplanar-
Dual window
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To create point VOIs

1 Click .

2 Click in the image where you want to create a point.

3 Repeat steps 1 and 2 for all other desired points.

To draw line VOIs

1 Click .

2 Click in the image where the line should begin and drag the line to 
where it should end.

The numbers beneath the line indicate the length of the line in 
millimeters.

To change the line VOI, simply click on the VOI and then drag it to 
another position in the image.

Note: You can only create one line VOI per orthogonal plane, although you can 
create a line VOI in each one of the three orthogonal planes.

To delete line VOIs

You cannot delete a line VOI. However, you can remove the display of the 

line VOI on the image. To do so, click . The line VOI disappears.
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File Close Frame—Closes this window.

Options Show Axes—Displays the XY (top left), ZY (top right), and ZX 
(bottom left) axes on the images.

Show Cross Hairs—Displays the cross-hair lines on the images. 
When you move these lines on one image, it also moves to the 
corresponding points all of the other images.

Show Talairach Grid—Displays a Talairach (stereo tactic) grid on 
the images.

 Traverse image

Aligns two images. 

 Magnify image 2.0x
Enlarges the images to twice their current size. It might be 
necessary to manually resize the window and use scroll bars to view 
all of the images.

Figure 158.  Triplanar-Dual window 
MIPAV User’s Guide, Volume 1, Basics 281

12/2/08 



M   I   P   A   V
M e d i c a l   I m a g e   P r o c e s s i n g, A n a l y s i s,   &   V i s u a l i z a t i o n

MIPAV User’s Guide, Volume 1, Basics
 Magnify image 0.5x

Reduces the images to half of their current size.

 Magnify image 1.0x

Restores the images to their original size.

 Draw line VOI

Draw a line VOI.

 Identify center of 
volume

Reassigns a new center to each dataset. The location that you 
select appears in the center of each image.

 Alignment tool

Allows you to apply a transformation matrix to an image dataset.

 Applies rotations and 
translations

Applies the rotations and translations made to the images.

 Add point

Draws a point on an image. This point is only on the image you 
select.

 Initiate new VOI

Indicates that the next VOI is a new VOI rather than a change to 
the currently existing VOI.

 Delete point VOI

Removes the point VOI from the image.

 Identify crop volume

Displays the bounding box, which is outlined in red, on each image.

 Crops image 
delineated by the bounding 
cube

Displays in a separate image window only the area enclosed by the 
bounding box. When you click this icon, the Crop Image dialog box 
opens.

 Draw using a brush
Allows you to draw with a brush on the image.

Figure 158.  Triplanar-Dual window  (continued)
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 Picks up a color from 
the image

Changes the color of the paint used to the color selected on the 
image.

 Fills an area with 
desired color

Allows you to fill an area with color. When you select this icon, the 
Paint Grow dialog box opens.

 Erases a portion of the 
image

Removes the paint from the specific spot that you select.

 Erase all paint

Removes all paint from all of the images.

 Draw using small size

Indicates the size of the paint brush tip. Click this icon to paint one 
voxel each time the mouse button is clicked.

 Draw using medium 
size

Indicates the size of the paint brush tip. Click this icon to paint 16 
voxels (4 x 4 square) each time the mouse button is clicked.

 Draw using large size

Indicates the size of the paint brush tip. Click this icon to pain 100 
voxels (10 x 10 square) each time the mouse button is clicked.

 Change intensity level 
of paint

Allows you to change the intensity value of the paint. When you 
click this icon, the Desired Paint Intensity dialog box opens.

You can specify an intensity between -32,768 and 32,767. After you 
type an intensity level, the icon displays the level you entered.

 Change paint color

Changes the color of the paint used. This icon is often used in 
conjunction with the Draw icons. When you click this icon, the Pick 
Paint Color dialog box opens. After you change the color, this icon 
displays the color.

Figure 158.  Triplanar-Dual window  (continued)
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To delete point VOIs

1 Click the first point on the image aligning the middle of the cursor with 
the center of the point.

2 Click . The point disappears.

3 Repeat the first two steps for every point you want to delete.

 Opacity

Allows you to change the opacity of the paint. When you click this 
icon, the Paint Opacity dialog box opens.

 Changes image 
where painted

Permanently applies the intensity level to the images.

 Undo last region 
paint

Removes paint from the last area to which it was applied.

 Calculate volume of 
paint

Determines the volume, or number of pixels, in the painted area of 
the image.

 Image A
Performs the action only on Image A.

 Image B

Performs the action only on Image B.

 Both
Performs the action on both Image A and Image B.

Figure 158.  Triplanar-Dual window  (continued)
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Aligning the datasets

The Alignment Tool icon, , allows you to create a new transformation 
matrix for the dataset.

1 Click . 

A closed angle appears on each of the images in the triplanar-dual view. 
On Image A, the angle is red; on Image B, it’s yellow; on the blended 
image, the angle is green.

2 Move the cursor to the arrow on the thin line to the right, and align the 
cursor with the end of the arrow. At this time, the cursor should be a red 
cross.

3 Change the size of the angle by dragging the arrow on the thin line up or 
down depending on the type of angle you want to create. The exact 
number of degrees appear on the left below the angle.

4 Release the mouse button when you reach the desired number of 
degrees.

Figure 159.  Closed angle that appears on each of the images
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5 Click on the image or on any other area of the triplanar-dual view. The 
arrows disappear from the angle.

6 Click on the angle again to be able to change the angle again. The arrows 
reappear and you can repeat the previous steps.

Finding the center of image datasets

To find the center of the dataset, click . The center of each image 

dataset, shown as , appears in each image in the triplanar-dual view.

Erasing part or all of drawings
If you used the paint brush to draw on the image, you may at times find a 
need to erase a part of the drawing or the entire drawing.

Caution: Make sure that you want to erase a part of the drawing or the 
entire drawing. There is no undo.

To erase a part of the drawing

1 Select the image that contains the drawing you want to erase. In other 
words, select Image A, Image B, or Both.

2 Click .

Figure 160.  Changing the angle by dragging the arrow on the thin line
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3 Click on the part of the drawing that you want to erase.

4 Repeat step 3 for as long as needed.

To erase all of the drawing

1 Select the image that contains the drawing you want to erase. 
Specifically, select Image A, Image B, or Both.

2 Click . MIPAV removes all of the paint from the image.

Cropping images
MIPAV allows you to extract the crop volume as a separate image, which is 
helpful if you need to work with or use only that portion of the image. The 
first step in cropping images is to identify what portion of the image is in the 
crop volume. Then you need to use the bounding cube for cropping the 
image.

To select the crop volume

1 Click . A red box appears on each image in the triplanar-dual view. 

2 Align the cursor with one of the corner points of the box, and enlarge or 
reduce the size of the box.

3 Repeat the previous step on each corner point as required to enclose the 
portion of the image you want to be included in the cropped image. 

The numbers on the sides of the box indicate the length and width of the 
box in millimeters.

Note: The size of the box changes proportionally on all of the images shown in 
the triplanar-dual view.

4 Release the mouse button when you are finished making changes to the 
box.

To crop images

1 Select one of the following:

• Image A if you want only the cropped area in Image A
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• Image B if you want only the cropped area in Image B

• Both if you want both the cropped area in Image A and the cropped 
area in Image B

2 Click . The Crop Image dialog box appears.

3 Click Apply.

The cropped area in the image you selected appears in a separate image 
window. So, if you selected Image A only or Image B only, one image 
appears. If you selected Both, two image windows appear: one for Image 
A and one for Image B.

After you generate the cropped images, you can run algorithms on the 
images, apply a quick LUT on the images, or use any other image processing 
that’s available in the MIPAV window on them.

Magnifying or minifying images
Like the image toolbar on the MIPAV window, the Triplanar-Dual window 
includes the following magnification icons:

Apply Applies the transformation to the image dataset 
according to the specifications in this dialog box.

Cancel Disregards any changes that you made in this dialog 
box and closes this dialog box.

Help Displays online help for this dialog box.

Figure 161.  Crop Image dialog box

If you selected . . . Then . . .

Image A The cropped area appears in a separate 
window. 

Image B The cropped area appears in a separate 
window.

Both Two small windows—one displaying the 
cropped area of Image A and the other 
displaying the cropped area of Image B—
appear.
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• , the Magnify image 2.0x icon—To magnify images to twice 
their current size

• , the Magnify image 0.5x icon—To reduce images to half their 
current size

• , the Magnify image 1.0x —To restore their original size 

For information on how to use these icons, refer to “magnify or reduce a 
region of the image. You can magnify images to 32 times their original size, 
reduce them to one-fourth their original size, or restore them to their 
original size.” on page 13.

Drawing on images
You draw on images in the triplanar-dual view in the same way as you do in 
the MIPAV window. However, any of the changes you make on the 
triplanar-dual view are also made on the original images.

For example, if you highlight a particular area in the image in the triplanar-
dual view, the same change is made on all of the images in the triplanar-
dual view, but also on the images in the default view.

To change the paint color

Click , the Change Paint Color icon. The Pick Paint Color dialog box 
(Figure 43 on page 54) opens. For instructions on how to use this dialog box 
to change the paint color, refer to “To change background and border 
colors” on page 54.
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To change paint opacity

1 Click . The Paint Opacity dialog box opens.

2 Move the Opacity slider to the level of opaqueness you want. For 
example, to make the paint color more opaque, or solid, move the slider 
to the right. To make the paint color more transparent, move the slider 
to the left. 

3 Click Close when you have finished. The Paint Opacity dialog box 
(Figure 60) closes.

Painting an area on images in the triplanar-dual view affects images in the default image view

Figure 162.  Painting an area on images in the triplanar-dual view 
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To calculate the volume of paint

The software can calculate the volume of a painted area in the number of 
pixels. To do so, do the following:

1 Paint the area of the image in which you are interested.

2 Click  to discover the volume of paint. The software lists the 
number of pixels in each image and the volume in millimeters on the 
Data page of the Output window.

3 Amend and save, as an option, the information on the Data page.

Opacity Indicates the opacity of the 
paint. The further right you 
move the slider, the more 
opaque the paint color. The 
further left you move the 
slider, the more 
transparent the paint color.

Close Closes this dialog box.

Figure 163.  Paint Opacity dialog box

Figure 164.  Output window after calculating the volume of paint
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To fill an area with color

1 Click . The Paint Grow dialog box opens.

2 Complete the dialog box.

3 Click Close.

To erase an area of paint from images

1 Click .

2 Click the area of the paint that you want to remove.

3 Repeat the previous step for each area of paint to be removed.

Cursor position and 
voxel intensity

Indicates the location of the cursor 
and the intensity value at that point

Delta above selected 
voxel intensity

Indicates the range of paint beyond 

Delta below selected 
voxel intensity

Indicates the range of paint 

Unrestricted size Limits the total volume in 3D or 4D 
images or area in 2D images

Maximum size (null) In development.

Unrestricted 
distance

Limits the distance from the seed 
point

Maximum size (null) In development.

Fuzzy connectedness Applies the fuzzy algorithm 

Initial variance from 
selected VOI

In development.

Display fuzzy image In development.

Fuzzy threshold In development.

Close Applies the parameters you 
specified

Cancel Disregards any changes that you 
made in this dialog box and closes 
the dialog box

Help Displays online help for this dialog box

Figure 165.  Paint Grow dialog box
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4 Click  when done to return the cursor to the default state.

To erase all painting from images

Click . MIPAV removes all of the paint from all of the images.

Displaying images using the surface plotter view

The surface plotter view visualizes the intensity levels for a chosen image 
using the height of the image surface. The surface plotter takes a 2D image 
and renders it into a 3D object that is similar to a raised-relief map. Higher 
intensities are peaks and lower intensities are valleys. The colors that the 
surface plotter used are the same as those used in the LUT, and when the 
LUT for the image is updated, so is the LUT for the plotted surface. The 
image itself is also a part of the scene, and it can be slid along, so that the 
peaks of the intensity levels match the image.

Figure 166.  An image open in MIPAV and in the MIPAV Surface Plotter 
default view. At each point of the surface, the height indicates the 
intensity value for that point. 

• The Z slider can be used as a cut off for pixel intensities. The read-only 
box on the right indicates the actual height of the cutoff.

• The image slice slider allows to select the image slice. 
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Surface Plotter window

Menu

File Exit—closes the Surface Plotter window.

Options View Mode— opens the View tab, see “View tab” 

Mouse Recorder— opens the Mouse tab, see “Mouse tab” 

Line Mode—displays the surface plotter image as lines.

Resample— improves the speed of animating of the image by resampling and 
forming the image with fewer triangles.

Display Options—allows you to add a bounding box, change colors of the 
bounding box and background, show an orientation cube, and choose the 
projection type: perspective or orthographic. See also “Box tab” below.

Help
Displays help for this dialog box.

Toolbar

 – opens the Camera tab, see “Camera tab” 

 – opens the Mouse tab, see “Mouse tab” 

 – opens the Box tab, see “Box tab” 

Image area Displays the plotted image. 

Slider tab

Figure 167.  Surface Plotter window
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Z(1-100) Turns on the ability to visualize the pixel intensities. When this box is selected, the 
height slider is available. It shows the height of the intensities in the image. Move 
the slider to the left to show the wider range of intensities: from the lower level to 
the higher level. Move the slider to the right to set up the cutoff and show only the 
higher level intensities. The read-only box on the right indicates the actual height 
of the cutoff.

Image Slice 
slider

Allows to select a particular slice and visualize the pixel intensities for that slice.

View tab

Mode Different view modes offer different opportunities for using the mouse controls.

In Standard mode, you can use left mouse button controls for rotation and the 
ALT+ left mouse button controls combination of keys for zooming, you can also use 
middle mouse button controls for zooming. 

In Fly mode, left, middle and right mouse button controls are available for 
zooming, rotation, and also pitch and roll rotation of the image.

In Pointer mode, you can use the mouse pointer for rotation, translation and 
zooming.

See also “Viewing an image dataset in animate view” on page 298

Slow-fast 
slider

use this slider to adjust the speed of the mouse actions.

Mouse tab

See also: “Recording and playing mouse actions” on page 301, “Saving as AVI” on page 305.

Figure 167.  Surface Plotter window (continued)
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Mouse 
recorder 
controls

View This box displays a list of recorded mouse actions. You can select any of mouse 
actions from the list as a starting point and start playing the movie from that point. 

Go to – directs the viewer to the selected view.

Add current – adds a current view to the sequence of views shown in the View box.

Remove – removes selected view.

Remove All – removes all views.

Camera tab

See also: “Capturing snapshots” on page 303, “Saving as AVI” on page 305.

Figure 167.  Surface Plotter window (continued)
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Mode Auto mode allows the automatic rotation and capturing of the image.

Manual mode allows the manual rotation and capturing of the image.

Capture Press the Camera button to capture the current image view. This option is only 
available if Manual mode is activated. 

Rotation Axis  Use the X, Y, or Z radio buttons to select the rotation axis. This option is only 
available if Auto mode is activated.

Rotation 
Alpha Degree

Enter a value for the rotation angle. By default, it is set to 15 degrees. This option 
is available in both Auto and Manual modes.

Mouse 
button 
controls

Use the mouse button controls to rotate, scale and translate the surface plotter 
view. The mouse button controls are only available in Manual mode.

Start – starts capturing. Only available in Auto mode.

Reset – resets the Surface Plotter view.

Box tab

Figure 167.  Surface Plotter window (continued)
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Viewing an image dataset in animate view
In animate view, like cine view, the software automatically advances 
through the image dataset. However, animate view allows you to adjust the 
speed at which images are advanced using the Slow-Fast slider.

Bounding 
box and 
Background 

Use these options to change the background and bounding box colors and also to 
display the bounding box frame.

Projection 
type

Use the radio buttons to switch between Perspective and Orthographic view.

Texture type TBD.

Figure 167.  Surface Plotter window (continued)
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To view an image dataset in Standard mode

1 Select Image > Views > Surface Plotter in the MIPAV window. The 
Surface Plotter window opens.

2 In the Surface Plotter window, call Options > View Mode to open the 
View tab.

3 Select Standard mode, and then adjust the mouse action speed slider. 

4 Use either the mouse controls, or hold down the left mouse button and 
drag the mouse to the left, right, top, and bottom. This allows you to 
move the image in all directions. 

5 If you release the left mouse button, and then hold it down again while 
you move the mouse, you can turn the image upside down. 

6 Hold down the middle mouse button (or use the mouse controls) and 
push the mouse forward. This makes the image smaller as if it has been 
seen from a distance.

7 Hold down the middle button and push the mouse toward you. This 
enlarges the image so that you can examine it closely. 

You can also use the controls for the middle mouse button.

8 Return to the Slider tab and slide the height slider to determine the 
highest intensity in the image. 

Example: One way of determining the highest intensity in the image is to 
use the mouse to drag the image to its side, enlarge it using the middle 
mouse button and pushing the mouse toward you, and then sliding the 
height marker to the top of the tallest intensity peak. The level of the 
intensity appears in the box to the right of the height slider. 
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To view an image dataset in Fly mode

1 Select Image > Views > Surface Plotter in the MIPAV window. The 
Surface Plotter window opens.

2 In the Surface Plotter window, call Options > View Mode to open the 
View tab.

3 Select Fly mode, and then adjust the mouse action speed slider. See 
Figure 168.

4 Use the left mouse button controls (upper and lower) to drag the image 
up and down. 

5 Use the left mouse button controls (right and left) to rotate the image 
along the X axis. 

6 Use the middle mouse button controls (upper and lower) to rotate the 
image along the Y axis. 

7 Use the middle mouse button controls (right and left) to rotate the 
image along the Z axis. 

8 Use the right mouse button controls (right and left) to zoom in or zoom 
out the image. 

9 Use the right mouse button controls (upper and lower) to translate the 
image. 

You can also use the mouse buttons instead of the mouse button controls.
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Recording and playing mouse actions
Surface plotter allows you to record mouse actions (e.g., rotations, 
translations, and zooming) you performed on the image and create a movie 
from them. This is available via the Mouse tab. When you record mouse 
actions, the software makes a copy of the image dataset and loads it in the 
animate image window. Before starting recording, you can adjust the speed 
at which images are advanced (the View tab). After recording is completed, 
you can specify that images be displayed in forward or reverse order, and 
you can also pause or loop the sequence.

To record the mouse actions:

1 In the Surface Plotter window, go to the Slider tab and adjust the 
intensity height slider.

2 Then call Options > View mode and choose Pointer mode. Use the Slow-
Fast slider to adjust the speed of the mouse actions.

Manipulating of the plotted image in the Surface Plotter window in Fly mode

Figure 168.   Surface Plotter window – Fly mode
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3 Open the Mouse tab (use Options > Mouse Recorder).

4 In the Mouse tab, press the Start Mouse Recording button to start 
recording the mouse actions. The list of actions appears in the View box.

5 To pause recording, press Pause.

6 To stop recording, press Stop.

7 To save the recorded movie as an AVI file, press Save as AVI. See 
Figure 169. See also “Saving as AVI” on page 305.

To play recorded mouse actions:

1 In the Mouse tab, press the Continuously Play Mouse Actions button. 
This starts playing the recorded actions.

2 To stop playing, press Stop.

Figure 169.  Recording and playing the mouse actions
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3 To start playing the movie from a particular mouse action, select that 
action in the View box, and then press the Continuously Play Mouse 
Actions button. The recorded mouse actions will play starting from that 
action. See Figure 169.

To edit recorded mouse actions:

1 In the Mouse tab, select the mouse action(s), and then press Remove. 
this will remove the selected action(s) from the list of recorded actions.

2 To remove all recorded actions and clean up the View box, press 
Remove All. See Figure 169.

See also: “Saving as AVI” on page 305.

Capturing snapshots
Surface Plotter dialog also offers the additional Auto Snapshot tool for 
automatic and manual capturing snapshots, which allows the user to 
reproduce the movements of the image. These snapshots can be worked on 
afterwards as slides or the video can be compiled in AVI format. See “Saving 
as AVI” on page 305.

To run the Auto Snapshot tool, click the Auto Snapshot Screen button on 
the Surface Plotter toolbar. This opens the Camera tab where you can set up 
the tool options and run the tool. For more information, refer to “Auto 
Snapshot tool” .

AUTO SNAPSHOT TOOL

The Auto Snapshot tool can be run in Auto and Manual modes. 

• In Auto mode, the surface plotter image is rotated along the chosen 
axis (X, Y, or Z) using the user defined rotation angle step, and the 
snapshot is taken at each rotation step. The snapshots are displayed in 
the Screen Capture window. See also “To take snapshots in Auto mode” 

• In Manual mode, the surface plotter image is rotated manually (using 
the mouse button controls) using the user defined rotation angle step, 
and the snapshots are also taken manually at each rotation step which 
is interesting for the user. The snapshots are then displayed in the 
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Screen Capture window. See also “To take snapshots in Manual mode” 
on page 304.

To take snapshots in Auto mode

1 In the Surface Plotter window, go to the Slider tab and adjust the 
intensity height slider.

2 Open the Camera tab (use the Auto Snapshot Screen button on the 
Surface Plotter toolbar).

3 In the Camera tab, select Auto mode. This is the default mode for 
capturing snapshots.

4 Then, choose the rotation axis and define the rotation angle. The default 
value for the rotation angle is set to 15 degrees.

5 Press the Start. 

The image starts rotating and the snapshots appear in the Screen Capture 
window. After completing the whole 360 degrees rotating circle, the image 
stops rotating. See also Figure 167.

For more information refer to “Displaying images using the animate view” on 
page 246.

To take snapshots in Manual mode

1 In the Surface Plotter window, go to the Slider tab and adjust the 
intensity height slider.

2 Open the Camera tab (use the Auto Snapshot Screen button on the 
Surface Plotter toolbar).

3 In the Camera tab, select Manual mode.

4 The mouse button controls and Capture Screen icon become active.

5 Then, define the rotation angle. By default, the value for the rotation 
angle is set to 15 degrees.

6 Use the mouse button controls to rotate the image. Note that you can 
rotate the image in any direction.

7 Press the Capture Screen icon each time you want to take a snapshot.
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The snapshots appear one by one in the Screen Capture window. 

You can stop capturing the snapshots at any time by pressing the Reset 
button. See also Figure 167.

SCREEN CAPTURE WINDOW

After you’ve completed capturing snapshots, they appear in the Screen 
Capture window. This window provides you with the tools for further 
editing of the snapshot sequence and saving it as an AVI file. The following 
options are available:

SAVING AS AVI

The Save as AVI or Capture as AVI option saves the sequence of recorded 
mouse actions or captured snapshots as an AVI file. To call the Save as AVI 
option, click the corresponding icon on the Mouse tab. To call the Capture 
as AVI option, click the icon on the Screen Capture window toolbar. The 
follow the steps provided by the dialogs. 

1 Click the Capture to AVI or Save to AVI icon. 

2 In the Choose Type of AVI File dialog, specify the AVI type and JPEG 
quality, press OK. 

3 In the Save Range of Slices dialog that appears next, press OK, then 
enter the file name. 

4 The saved AVI file appears in the MIPAV AVI player.

– Default mode – Select all

– Magnify region – Unselect all

–Delete selected 
slices

– Capture to AVI

Extract selected slices to a new image
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For more information refer to “Displaying images using the animate view” on 
page 246.

Displaying images using the surface renderer 
view

In development.

Displaying images using the volume shear view

In development.

Displaying images using the volume renderer 
view

In development.
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