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Changing Image Datasets Using

MIPAV Utilities   . . .
In this chapter

“Standard tasks provided through commands on the Utilities menu” on 
page 401

“Recording utilities usage with the history feature” on page 404
“4 D tools” on page 405
“Adding image margins” on page 412
“Copying images using the Clone command” on page 414
“Converting image datasets to different data types” on page 414
“Correcting image spacing” on page 423
“Cropping images” on page 431
“Masking (filling) images” on page 434
“Flipping images” on page 436
“Image Calculator” on page 438 and page 451
“Image Math” on page 453
“Inverting the image” on page 457
“Matching images” on page 458
“Maximum Intensity Projection” on page 461
“Adding noise to images” on page 464
“Pad” on page 467
“Quantify Mask” on page 468
“Replacing pixel/voxel value in images” on page 471
“Rotating images” on page 473
“Slice tools” on page 475
“Inserting slices into image datasets” on page 481
“Subtract VOI Background” on page 488
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Standard tasks provided through commands on the 
Utilities menu

MIPAV provides a number of utilities that you can use to perform standard 
image-processing tasks such as converting image datasets to another image 
type, transforming images by copying, cropping, or rotating them, and 
changing image datasets by adding, removing, or reordering slices. To 
perform more complex tasks, MIPAV provides algorithms, which are 
covered in Volume 2 of the User’s Guide. This chapter explores the standard 
tasks.

To access the standard image-processing tasks, you use the commands 
(refer to Table 2) on the Utilities menu in the MIPAV window.

Table 2. Standard tasks provided through commands on the Utilities menu in the MIPAV window

Task Command

Scalar* RGB

2D 3D 4D 2D 3D 4D

4D

“Converting 3D to 4D 
images and vise 
versa” 

Convert 3D to 4D N Y N N Y N

Convert 4D to 3D N N Y N N Y

“Convert 4D to RGB” Convert 4D to RGB N N Y N Y Y

“Extracting 3D subset 
from 4D” 

Extracting 3D 
Subset from 4D

N N Y N N Y

“Removing time 
volumes” 

Remove Time 
Volumes

N N Y N N Y

“Swapping the third 
and fourth 
dimensions” 

Swap DIMS 3 <-> 4 N N Y N N Y

“Adding image 
margins” 

Add Image Margins Y Y Y Y Y Y

Copying images Clone (copy) Y Y Y Y Y Y

*Scalar includes the following image types: boolean, byte, unsigned byte, short, unsigned short, 
integer, long, float, and double.
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Conversion Tools

“Converting image 
datasets to different 
data types” 

Convert Type Y Y Y N N N

“Converting grayscale 
images to RGB 
images” 

Grays to RGB Y Y Y N N N

“Converting RGB 
datasets to grayscale 
datasets” 

RGB to Gray

RGB to Grays

RGB to HSB

N N N Y Y Y

“Correcting image 
spacing” 

Correct Image 
Spacing

N Y Y N N N

“Cropping images” Crop Using 
Parameters

Crop using VOI

Y Y Y Y Y Y

“Masking (filling) 
images” 

Fill Image Y Y N Y Y N

“Flipping images” 

Flip > Horizontal Y Y Y Y Y Y

Flip > Vertical Y Y Y Y Y Y

Flip>In Depth 
(invert slice order)

N Y Y N Y Y

“Image Calculator” Image Calculator Y Y Y Y Y Y

“Image Calculator–
Bulk Images” 

Image Calculator–
Bulk Images

Y Y Y Y Y Y

“Image Math” Image Math Y Y Y Y Y Y

“Inverting the image” Invert Y Y Y Y Y Y

“Matching images” Match Images Y Y N Y Y N

Table 2. Standard tasks provided through commands on the Utilities menu in the MIPAV window 

Task Command

Scalar* RGB

2D 3D 4D 2D 3D 4D

*Scalar includes the following image types: boolean, byte, unsigned byte, short, unsigned short, 
integer, long, float, and double.
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“Adding noise to 
images” 

Noise Y Y N Y Y N

“Pad” Pad Y Y N Y Y N

“Quantify Mask” Quantify Using 
Mask

Quantify Mask(s)

Y Y Y N N N

“Replacing pixel/voxel 
value in images” 

Replace Pixe/Voxel 
Value

Y Y Y Y Y Y

“Rotating images” Rotate -> X axis 
+90

Y Y Y Y Y Y

Rotate -> X axis 
-90

Rotate.> Y axis -90 Y Y Y Y Y Y

Rotate -> Y axis 
+90

Y Y Y Y Y Y

Rotate -> Z axis 
+90

Y Y Y Y Y Y

Rotate -> Z axis 
-90

Y Y Y Y Y Y

Slice Tools

“Concatenating 
images” 

Concatenate Y Y Y Y Y Y

“Extracting slices/
volumes” 

Extract Slices/
Volumes

N Y Y N Y Y

“Insert Missing Slices” Insert Missing 
Slices

N Y Y N Y Y

“Inserting slices into 
image datasets” 

Insert Slice N Y Y N Y Y

Table 2. Standard tasks provided through commands on the Utilities menu in the MIPAV window 

Task Command

Scalar* RGB

2D 3D 4D 2D 3D 4D

*Scalar includes the following image types: boolean, byte, unsigned byte, short, unsigned short, 
integer, long, float, and double.
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Recording utilities usage with the history 
feature

MIPAV provides a way for you to record the actions, whether with 
algorithms or utilities, that you perform on images. You use the MIPAV 
Options dialog box to turn this feature on. Refer to “Saving a history of 
actions on images (TBD)” on page 126 in Chapter 3‚“Getting Started 
Quickly with MIPAV” of this User’s Guide for more information.

“Pad slices to power 
of 2” 

Pad Slices to power 
of 2

N Y Y N N N

“Randomizing image 
(slice) order” 

Randomize Slice 
Order

N Y Y N Y Y

“Removing images 
(slices) from 
datasets” 

Remove Slices N Y Y N Y Y

“Replace blanks with 
averages” 

Replace blanks with 
averages

N Y Y N N N

“Replace Slices” Replace Slices N Y Y N Y Y

“Subtract VOI 
Background” 

Subtract VOI 
background

Y Y Y Y Y Y

Table 2. Standard tasks provided through commands on the Utilities menu in the MIPAV window 

Task Command

Scalar* RGB

2D 3D 4D 2D 3D 4D

*Scalar includes the following image types: boolean, byte, unsigned byte, short, unsigned short, 
integer, long, float, and double.
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4 D tools

Converting 3D to 4D images and vise versa

To convert 3D images to 4D images

1 Open a 3D image or image dataset.

2 Select Utilities > Convert 3D to 4D. The Convert 3D to 4D dialog box 
opens.

3 Do either of the following in the Number of slices in the 3rd dimension, 
Resolutions: 3rd dimension, and Resolutions: 4th dimension boxes:

• Accept the default numbers.

• Enter different numbers.

4 Select in each of the Resolution units: 3rd dimension and Resolutions 
units: 4th dimension lists one of the following: millimeters (the default 
value), unknown, inches, centimeters, angstroms, nanometers, 
micrometers, milliliters, meters, kilometers, miles, nanoseconds, 
microseconds, milliseconds, seconds, minutes, hours, or Hz.

5 Click OK. The program applies all of the specification in this dialog box 
to the image or image dataset. See Figure 221 on page 405.

Number of slices in 
the 3rd dimension

Specifies how many 
slices are in the 3rd 
dimension. The 
default number is 2.

Resolutions:
3rd dimension

Indicates the 
resolution for the third 
dimension. The 
default number is 5.0. 

Resolutions:
4th dimension

Indicates the 
resolution for the 
fourth dimension. The 
default number is 1.0.

Resolution units:
3rd dimension

Indicates the voxel 
resolution in the 3rd 
dimension.

Figure 221.  Convert from 3D to 4D dialog box
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TO CONVERT 4D TO 3D IMAGES

1 Open a 4D image or image dataset.

2 Select Utilities > Convert 4D to 3D.

The program immediately begins processing the image.

EXTRACTING 3D SUBSET FROM 4D

This utility allows you to remove one of the x, y, z, or t dimensions from 4D 
images to produce a 3D image. Refer to Figure 222 on page 408.

To remove an X dimension slice

1 Open a 4D image.

2 Select Utilities >4D Tools> Extract 3D Subset from 4D. The Extract 3D 
Subset dialog box (Figure 222) opens.

3 Select X.

4 Type the index number of the slice you want to extract in the Select 
index from. <N> to <N> box.

5 Click Remove. The program removes the slice you specified from the 
dataset.

Resolution units:
4th dimension

Indicates the voxel resolution of the 4th dimension.

OK Applies the specified parameters to convert a 3D image to a 4D image. 

Cancel Disregards any changes you made in this dialog box, closes the dialog 
box, and does not convert the image.

Help Displays online help for this dialog box.

Figure 221.  Convert from 3D to 4D dialog box (continued)
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To remove a Y dimension slice

1 Open a 4D image.

2 Select Utilities > Extract 3D Subset from 4D. The Extract 3D Subset 
dialog box (Figure 222) opens.

3 Select Y.

4 Type the index number of the slice you want to extract in the Select 
index from <N> to <N> box.

5 Type the index number of the slice you want to extract in the Select 
index from. <N> to <N> box.

6 Click Remove. The program removes the slice you specified from the 
dataset.

To remove a Z dimension slice

1 Open a 4D image.

2 Select Utilities > Extract 3D Subset from 4D. The Extract 3D Subset 
dialog box (Figure 222) opens. 

3 Select Z. 

4 Type the index number of the slice you want to extract in the Select 
index from. <N> to <N> box.

5 Click Remove. The program removes the slice you specified from the 
dataset.

To remove the T dimension

1 Open a 4D image.

2 Select Utilities > Extract 3D Subset from 4D. The Extract 3D Subset 
dialog box (Figure 222) opens.

3 Select T. 

4 Type the index number of the slice you want to extract in the Select 
index from. <N> to <N> box.

5 Click Remove. The program removes the slice you specified from the 
dataset.

.
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Removing time volumes
If an image dataset contains blank images or unusable images, which might 
be caused by patients blinking their eyes during tests, the Remove Time 
Volumes command on the Utility menu in the MIPAV window allows you to 
remove unusable images from the dataset.

To remove time volumes

1 Open an image dataset that contains time volumes.

Note: The Remove Time Volumes command only becomes active for 4D image 
datasets.

2 Use the image slider to look through the dataset one time volume, or 
image, at a time (Figure 223). If you find an unusable volume—one that 
is blank, or totally black, or that contains unusable information—stop 
moving the slider on that volume.

X Specifies that the algorithm 
should remove the X (width) 
dimension.

Y Specifies that the algorithm 
should remove the Y (height, or 
length) dimension.

Z Specifies that the algorithm should remove the Z (depth) dimension.

T Specifies that the T (time) dimension should be removed.

Index from 
<N> to <N>

Specifies the index number of the volume or slice that you want to extract from the 
dataset.

Extract Removes the specified dimension.

Cancel Disregards any changes you made in this dialog box, closes the dialog box, and 
does not remove any dimensions.

Help Displays online help for this dialog box.

Figure 222.  Extract 3D Subset dialog box
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Note: The volume number appears in the title bar of the MIPAV window and 
correlates to the slice indicated by the image slider.

3 Select Utilities > Remove time volumes. The Remove Time Volumes 
dialog box (Figure 282 on page 486) opens.

4 Select the time volume or volumes (slices) that you want to remove in 
the list at the top of the dialog box, or type the number of the slice or 
range of volumes in the Check the time slices to remove box. 

5 Do either of the following:

• Click Select all to remove all of the slices.

• Click Remove to remove the slices you selected. 

A status message appears. Then the MIPAV window refreshes.

6 Use the image slider again, if you’d like, to look through the slices in the 
dataset to verify that the appropriate slices were removed. See 
Figure 223 and Figure 224.

Swapping the third and fourth dimensions
Swapping the third and fourth dimensions refers to how image datasets are 
stored. Datasets may be stored using the following two methods:

• xytz (horizontal, vertical, time, third dimension)

• xyzt (horizontal, vertical, third dimension, time)

Because MIPAV requires that datasets be stored using the xyzt method, it 
provides the Swap Dims 3 <-> 4 command for those users whose datasets 
may be stored using the xytz method.

To swap the third and fourth dimensions

1 Open an image that is stored using the xytz method.

2 Select Utilities>4D Tools>Swap Dims 3 <-> 4. A progress message 
appears briefly while the program changes the storage method of the 
image and replaces the image with one that is stored using the xyzt 
method.
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Figure 223.  Using the image slider to look through an image dataset
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Convert 4D to RGB
This utility converts  4D datasets that have three or less slices (volumes) 
into RGB 3D images, where each slice is represented by one channel – red, 
green or blue.

To convert 4D to 3D images

1 Open a 4D image or image dataset.

2 Select Utilities >4D Tools>Convert 4D to RGB.

3 The Convert 4D to RGB dialog box appears. Complete the dialog box, 
use the list boxes to assign a chosen volume to the corresponding color 
channel. Refer to Figure 225.

4 Press OK. The new 3D RGB image appears in a new image frame. See 
Figure 226.

.

Select all Selects all time 
volumes.

Clear Clears selection.

Remove Removes selected 
slices.

Cancel Disregards any 
changes you made in 
this dialog box, closes 
the dialog box, and 
does not remove the 
time volumes.

Help Displays online help 
for this dialog box.

Figure 224.  The Remove Time Volumes dialog box
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Adding image margins

The Add Image Margins command allows you to add a border of pixels or a 
specific intensity along the edges of an image dataset.

Volume/color channel

Specify the image volume and the 
corresponding color channel. Use the 
list boxes to select Red, Green, and 
Blue channel; or use blank.

Remap data Check this box, if you would like to remap RGB data to 0–255 range.

OK Applies the specified parameters to convert a $D image to a RGB image. 

Cancel Disregards any changes you made in this dialog box and closes the dialog 
box.

Help Displays online help for this dialog box.

Figure 225.  The Convert 4D to RGB dialog box

Figure 226.  The original 4D image and the same image converted to 3D 
RGB
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To add image margins

1 Open an image.

2 Select Utilities > Add Image Margins. The Add Image Borders dialog 
box (Figure 227) opens.

3 Enter the number of pixels to add on the left and right sides of the 
image, the top and bottom, and to the front and back of the image.

4 Enter the intensity value for the margins.

5 Select one of the following destinations:

• New image—The software applies the margins to another instance 
of the dataset in a new image window. 

• Replace image—The software adds the margins to the existing 
instance of the dataset.

6 Click OK. The image margins are applied to the dataset.

Margins 
Around Image

Pixels on the left side: Specifies 
the number of pixels that should 
appear on the left side of the 
image.

Pixels on the right side: 
Specifies the number of pixels 
that should appear on the right 
side of the image.

Pixels on top: Specifies the 
number of pixels that should 
appear on the top of the image.

Pixels on bottom: Specifies the 
number of pixels that should 
appear at the bottom of the 
image.

Slices at the front of image: 
Specifies the number of slices that 
should appear at the front of the 
image.

Slices at the back of image: Specifies the number of slices that should appear 
at the back of the image.

Value for 
margins 

Specifies the intensity of the border around the image. As a default, the intensity 
of the border is the same intensity as that for the image. 

New image Shows the image with the additional or adjusted margins in a new image window.

Figure 227.  Add Image Border dialog box
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Copying images using the Clone command

Suppose you need to copy an image dataset. To do so, you would use the 
Clone command on the Utility menu. This command generates a duplicate 
of the dataset and any information stored on the image, utility, algorithms, 
VOI, and paint layers.

Note: The Clone utility copies VOIs as well as the image, but it does not copy 
LUT information. Although we can observe its effects, it is not stored in an image 
layer. The Clone utility doesn’t work for 4D images!

If two datasets are loaded into one image window, only the active dataset is 
cloned. When the dataset is duplicated, the duplicate dataset appears in its 
own image window.

To copy an image dataset, you simply select Utility > Clone (copy) in the 
MIPAV window. In a moment or two, a duplicate of the dataset appears in a 
new image window.

Converting image datasets to different data 
types

In MIPAV you can convert image datasets to different data types. For 
example, you might want to convert a Boolean type dataset to an integer 
type dataset. MIPAV also allows you to simultaneously alter the input and 
output values. This utility is particularly helpful if you want to apply an 
algorithm to a dataset but cannot do so because the original images are the 
wrong image type.

Replace 
image

Replaces the current active image with the results of the image to which margins 
were added or adjusted.

OK Applies the parameters that you specified to add margins to this image.

Cancel Disregards any changes you made in this dialog box, closes the dialog box, and 
does not add image margins.

Help Displays online help for this dialog box.

Figure 227.  Add Image Border dialog box (continued)
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data type—A set of values from which a variable, constant, function, or 
expression may takes its value. MIPAV automates the following data types: 
Boolean, signed byte, unsigned byte, signed short, unsigned short, integer, long, 
float, double, and color 24.

CONVERT TYPE

To convert a dataset to a different image type

1 Select Utilities >Conversion Tools > Convert type. The Convert Image 
Type dialog box (Figure 228) opens.

2 Select the desired image type in the Image Type group.

3 Indicate the start and end input ranges in the Range of input values 
group.

4 Indicate the start and end output ranges in the Range of output values 
group.

5 Specify either Little endian or Big endian in the Endianess group.

6 Click OK. The dataset is converted to the new image type.

Figure 228.  Convert Image Type dialog box
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Image Type Specifies the data type. Select one of the following: 

Boolean Indicates whether a condition if true or false.

Byte Primitive 8-bit data type. Valid values range from -127 
to 128.

Unsigned byte Primitive 8-bit data type. Unsigned byte is a variation 
of the integer data type. The unsigned byte data type 
signifies that valid values must fall within a specified 
range of positive whole number values. Valid values 
range from 0 to 255. Negative values are not valid, 
hence the term unsigned byte.

Short Primitive 16-bit data type. Short is a variation of the 
integer data type. Short accommodates values that are 
whole numbers. Valid values range from 0 to +32,768.

Unsigned short Primitive 16-bit data type. Unsigned short is a variation 
of the integer data type. The unsigned short data type 
signifies that valid values must fall within a specified 
range of positive whole number values. Valid values 
range from 0 to 65,535. Note that negative values are 
not valid, hence the term unsigned byte.

Integer Primitive 32-bit data type. Integer is sometimes 
abbreviated as int. Integer accommodates values that 
are whole numbers. Valid values range from 
-2,147,483,648 to +2,147,483,648.

Unsigned integer Primitive 32-bit data type.

Long Primitive 64-bit data type. Long is a variation of the 
integer data type. Long accommodates values that are 
whole numbers. Valid values range from 
-9,223,372,036,854,775,808 to 
+9,223,372,036,854,775,808.

Float Primitive 32-bit data type. Float is a floating point data 
type that accommodates decimal values, up to 6 or 7 
significant digits of accuracy. Valid values can range 
from -3.4 x 1038 to 3.4 x 1038.

Double Primitive 64-bit data type. Double is a floating point 
data type that accommodates decimal values, up to 14 
or 15 significant digits of accuracy. Valid values can 
range from -1.7 x 10308 to 1.7 x 10308.

Destination New image Shows the converted dataset in a new image window. 

Replace image Replaces the current active dataset with the converted 
dataset.

Figure 228.  Convert Image Type dialog box (continued)
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CONVERTING GRAYSCALE IMAGES TO RGB 
IMAGES

You can convert grayscale image datasets to RGB. RGB images have three 
channels (red, green, and blue) that contain image data.If you open two 
datasets in one image window, you can create a composite image that 
contains a mixture of the red, green, and blue channels.

Range of input 
values

Use entire image 
range

Converts all intensity values to the result image range 
when converting the image to a different type.

Use user-defined 
range

Converts only the intensity values in the user-defined 
range when converting the image to a different type.

Start input range Specifies the intensity value at the beginning of the 
input range. The default value is the image minimum.

End input range Specifies the intensity value at the end of the input 
range.

Range of 
output values

Starting range Specifies the intensity value at the beginning of the 
output range. The default value is the image minimum.

Ending range Specifies the intensity value at the end of the output 
range.

Process each 
slice 
independently 
(2.5D)

Converts each image slice independently as if it was a separate image. This 
options works for 2.5D images.

Endianess Data organization strategy. Refers to the way computer processors store data in 
memory.

Little endian Stores the least significant byte (LSB) first.

Big endian Stores the most significant byte (MSB) first.

OK Applies the parameters that you specified to convert the dataset.

Cancel Disregards any changes you made in this dialog box, closes the dialog box, and 
does not convert the dataset.

Help Displays online help for this dialog box.

Figure 228.  Convert Image Type dialog box (continued)
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To convert grayscale images to RGB images

1 Open an image.

2 Select Utilities >Conversion Tools> Grays -> RGB. The Concatenate -> 
RGB dialog box opens.

3 Select the image to which you want to apply the red channel in the 
Image (red) list. If you loaded two images into the image window, two 
file names should appear.

4 Do the same for the Image (green) list and the Image (blue) list.

5 Indicate whether you want to remap to current intensity values to the 
full standard 0–255 RGB values.

Note: Generally, each color is defined as one of the 256 intensities. If you remap 
the grayscale intensities and select Remap data, the system defines the 
intensities as one of the 256 values. If one or all of the input images have values 
that exceed 255 and you do not select Remap data, then data truncates to 255 
since a color channel can only represent values 0–255.

6 Click OK. A status message appears. When filtering is complete, the new 
RGB image appears in a separate image window.

Image (red) Identifies the image to be added 
to the red channel of the resulting 
image.

Image 
(green)

Identifies the image to be added 
to the green channel of the 
resulting image.

Image (blue) Identifies the image to be added 
to the blue channel of the 
resulting image.

Remap data 
(0-255)

Indicates, when selected, that 
you want image intensities to be 
remapped to values 0-255, which 
is the standard for RGB images. 

Destination

New image Sends the output to a new image frame.

Replace 
image

Replaces the existing image.

Figure 229.  Concatenate -> RGB dialog box
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CONVERTING RGB DATASETS TO GRAYSCALE 
DATASETS

On the Utilities > Conversion Tools menu in the MIPAV window, the RGB 
conversion utility offers both a manual and an automatic method of 
converting RGB datasets to grayscale RGB images.

• Manual conversion—In the manual method of conversion, you 
select Utilities >Conversion Tools > RGB -> Gray to display the RGB -> 
Gray dialog box (Figure 230). The dialog box provides three weighting 
methods:Equal weights—This method assigns equal weights to each of 
the three color channels. When you select this option, you can also 
select the Only average RGB values greater than check box and 
specify a threshold value. For example, if you specify a threshold value 
of 50, the program ignores any pixel in that channel that contains a 
value over 50.

• Computer graphics weights—This method assigns the weights to 
each channel that are typically used to display computer graphics.

• User-specified weights—In this method, you enter the specific 
weights for each color channel.

• Automatic conversion—If, instead, you select Utilities > 
>Conversion Tools > RGB -> Grays, the program automatically 
converts the RGB image to three grayscale images: one each for the 
red, blue, and green channels.

Note: You can only specify a threshold when you choose to use the equal 
weights method of conversion.

OK Applies the parameters that you specified to create an RGB image. 

Cancel Disregards any changes you made in this dialog box, closes the dialog box, and 
does not create an RGB image.

Help Displays online help for this dialog box.

Figure 229.  Concatenate -> RGB dialog box (continued)
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RGB datasets have four channels: red, green, blue, and alpha. When you 
convert RGB datasets to grayscale. RGB images, the intensities are 
combined to form a single grayscale value. 

For example:

Where, 

N = New grayscale pixel

R = Red channel

G = Green channel

B = Blue channel

RW = Weight assigned to the red channel

GW = Weight assigned to the green channel

BW = Weight assigned to the blue channel

N R RW G GW B BW×+×+×=

Equal weights Assigns the same 
weight (0.3333) to 
each channel in the 
image. When you 
select this option, the 
Only average RGB 
values great than 
becomes available.

Computer 
graphics

Assigns the weighting 
factors typically used 
in computer graphics 
to each channel in the 
image: 

• Red, 0.299
• Green, 0.587
• Blue, 0.114

User specified Specifies a weight that you determine for each channel. When you select this 
check box, you must type a specific weight for each channel in the Red, Green, 
and Blue boxes.

Red Specifies the weight assigned to the red channel in the image. You can only specify 
a weight in this box if you selected the User specified option.

Figure 230.  RGB -> Gray dialog box
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To manually convert RGB datasets to grayscale

1 Select Utilities > RGB > RGB -> Gray: The RGB -> Gray dialog box 
(Figure 230) opens. 

2 Select one of the following weighting methods: equal weights, computer 
graphics, or user specified.

• If you selected Equal Weights, decide whether to apply a threshold 
to the RGB channels. If you want to apply a threshold, select Only 
average RGB values greater than and enter the threshold value. 
Then go to the next step.

• If you selected Computer graphics or User specified, go to the next 
step.

3 Click OK. A status message appears. In a few moments, the image is 
replaced by the new grayscale dataset.

Green Specifies the weight assigned to the green channel in the image. You can only 
specify a weight in this box if you selected the User specified option.

Blue Specifies the weight assigned to the blue channel in the image. You can only 
specify a weight in this box if you selected the User specified option.

Only average 
RGB values 
greater than

Excludes any voxel in the image over the threshold value that you specify in this 
box. This check box is only available when you select the Equal Weights option.

New Image Sends the output to a new image frame.

Replace 
Image

Replaces the existing image.

OK Applies the parameters that you specified to create a grayscale image. 

Cancel Disregards any changes you made in this dialog box, closes the dialog box, and 
does not create a grayscale image.

Help Displays online help for this dialog box.

Figure 230.  RGB -> Gray dialog box (continued)
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To automatically convert RGB datasets to grayscale 
image

Select Utilities > RGB > RGB -> Grays. The program briefly displays a 
status message during the conversion and then generates three new 
grayscale datasets, one for each channel.

A B

C D

E

A – the original image

B – the image converted to 
grayscale using Equal Weights

C – the image converted to 
grayscale using Computer Graphics

D – the image converted to 
grayscale using the User Specified 
RGB weight factors (0.33 for each 
channel)

E – the image converted to 
grayscale using combined options 
– Equal Weights and average 
values greater than 50

Figure 231.  Manually converting RGB datasets to grayscale
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Correcting image spacing

The Correct Image Spacing command on the Utilities menu corrects images 
in which slice thickness and slice spacing are unequal, which may distort 
images. To understand how this problem can occur, the following section 
presents some background information.

UNDERSTANDING CONTIGUOUS PLANES’ 
EFFECT ON IMAGE SCANNING

Image scanning is usually done in contiguous planes. For example, if the 
first slice is centered at position 5.0 and the slices are 2 mm thick, the 

A B

C D

Figure 232.  Example of three grayscale datasets generated 
automatically from an RGB dataset. Here, A is an original RGB image, B 
– gray red channel image, C – gray green channel image, and D –gray 
blue channel image.
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second slice is centered at 7.0. In such a case, the slice thickness, 2, and the 
slice spacing, 2, are equal. There are, however, two scenarios when the slice 
spacing does not equal the slice thickness:

• Slice spacing is less than the slice thickness—In this case, 
although the images are, for example, 2 mm thick, they are spaced only 
1 mm apart (Figure 233). This scenario arises when the ZIP x 2 feature 
is used during MRI scanning, which enables the acquisition of slices 
only 1 mm apart but uses signals from a 2-mm slab to increase the 
signal-to-noise ratio.

• Slice spacing is greater than the slice thickness—This scenario 
(Figure 233), which is more common than the first, occurs when the 
operator chooses to acquire images at intervals greater than the slice 
thickness (i.e., there is a gap between successive image slices) in order 
to cover a deeper field of view.

MIPAV assumes that successive images are contiguous. So, for example, if 
users chose the triplanar view to display an image that had slice spacing 
larger than slice thickness, the image would appear shortened in the out-of-
plane direction. The Correct Image Spacing utility corrects both situations 
in which the slice thickness and spacing are not equal. Once the correction 
is applied, the slice thickness and slice spacing for the given image dataset 
are the same.

UNDERSTANDING HOW MIPAV SOLVES THE 
IMAGE SPACING PROBLEM

When the spacing between slices is less than the slice thickness, the Correct 
Image Spacing utility assigns the slice spacing to the slice thickness (refer to 
Figure 233 on page 427 for triplanar views before and after correction). 
When the slice spacing is larger than the slice thickness (refer to Figure 233 
on page 427 for triplanar views before and after correction), the utility 
inserts blank slices between the existing images. 

Since all slices within an image volume must have the same slice thickness, 
in many cases more than one slice must be inserted and the original images 
must be repeated so that a new value can be found for the slice thickness 
that fits evenly into the original slice spacing. Since there are an infinite 
number of combinations of slice spacing and thickness, not all could be 
handled. Table 3 displays the most common combinations and the 
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algorithms MIPAV uses for handling them.

T = Original slice thickness

S = Original space between slices

G = Gap = S - T

M = Number of original images

O = Original image set origin

N = New slice thickness

To use the Correct Image Spacing utility, DICOM images must first be saved 
in XML format. The following DICOM tags (Figure 233 on page 427) are 
used:

• (0018, 0050) Slice Thickness

• (0018, 0088) Spacing Between Slices

You can also find this information listed in the Essential Image Information 
section of the image header (Figure 233 on page 427) as Pixel resolution 2 
(i.e., slice thickness) and Slice Spacing.

To view image attributes

1 Open an image.

2 Select Image > Attributes > View Header. The Header dialog box 
(Figure 233) opens.

3 Find the tags under Essential Image Information to find the values for 
Pixel resolution 2 and Slice Spacing, or find the values of the DICOM 
tags Slice Thickness and Spacing Between Slices.
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.

Table 3. Solutions for correct image spacing

Case

New slice 
thickness

(N)

Number 
of images 
in new set 
for each 
original 
image

Number 
of blanks 
inserted 
for each 
original 
image

Total 
images in 
set now

New image 
set origin 

 

 and 

 and 

 and 2

 and 

 and 

 and 

else don't handle, give message

Legend: 

T = Original slice thickness

S = Original space between slices

G = Gap = S - T

M = Number of original 
images

O = Original image set origin

N = New slice thickness
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Figure 233.  Views of the Header dialog box showing the tags listed under (A) Essential Image 
Information and (B) the DICOM tags in a later section of the header  
MIPAV User’s Guide, Volume 1, Basics 427

12/2/08 



M   I   P   A   V
M e d i c a l   I m a g e   P r o c e s s i n g, A n a l y s i s,   &   V i s u a l i z a t i o n

MIPAV User’s Guide, Volume 1, Basics
To save DICOM images as XML files

The Correct Image Spacing utility works only on XML files.

1 Open the DICOM image.

2 Select File > Save Image as in the MIPAV window. The Open dialog box 
appears.

3 Type the name for the file including the XML extension in File Name.

4 The Select DICOM tags to convert to XML dialog box opens.

5 In the left dialog box window, select tags which you would like to 
convert to XML. Use the CTRL+right mouse button combination of keys 
to select multiple tags. Then, use the arrows to move selected tags to the 
right window. See Figure 234 for more information.

6 Press Save to save the file.

Figure 234.  Saving a DICOM image as an XML file
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To save other images as XML files

The Correct Image Spacing utility works only on XML files.

1 Open the image that has spacing problems if you have not already done 
so.

2 Select File > Save Image as in the MIPAV window. The Open dialog box 
appears.

3 Type the name for the file including the XML extension in File Name.

4 Select Medical, which includes XML files, in Files of Type.

5 Click OK. The Save Range of Slices dialog box appears. Complete the 
dialog box and press OK. See Figure 235.

6 The program saves the image as an XML file.

General Options

Save image 
slices to 
separate files

If checked, allows to save the 
image slices as separate files.   
The slices will be saved as files 
with the file name contains the 
name of the original image 
followed by the slice number 
specified by a user, e.g. 
patientX001. Here patientX 
is the name of the original image 
and 001 is the number of the 
slice. Refer to “Understanding 
contiguous planes’ effect on image 
scanning” on page 423.

First File 
Starting Number

File Name 
Number of Digits

Set the start counter number and 
how many digits will appear in the 
counter number. 

Choose Range of Slices to Save

First Slice Specify the number of the first slice.

Last Slice Specify the number of the last slice.

Choose Range of Time Periods to Save

First Time period Specify the first time period.

Figure 235.  The Save Range of Slices dialog box options
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To correct image spacing

1 Open the image that contains spacing problems. 

Tip: To determine whether images contain spacing problems, remember to view 
them using the triplanar view or to view the header file.

2 Save the image as an XML file.

3 Select Utility > Correct Image Spacing. 

If the image file does have spacing problems, then the program runs the 
utility. 

If the image spacing is correct, the program displays a message 
indicating that the spacing is correct.

Last Time Period Specify the last time period.

TIFF options

Save with 
packed bit 
compression

Packed bit compression uses a single control byte to indicate how the next byte 
or series of bytes will be used. The high bit in the control byte indicates if the 
following byte or bytes should be a used as a series or should be used as 
individual bytes. The remaining 7 bits indicate the number of bytes that are 
indicated in the control byte.

OK Applies the changes you made in this dialog box, saves the image as a range of 
slices, and closes the dialog box.

Cancel Disregards any changes you made in this dialog box, closes the dialog box, and 
does not save the image as a range of slices.

Help Displays online help for this dialog box.

Figure 235.  The Save Range of Slices dialog box options (continued)
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Cropping images

You can use the Crop command on the Utilities menu to trim an image so 
that only the selected portion of the image remains. 

To crop an image using a VOI

1 Open an image.

2 Draw one or more VOI contours on the image on the area that you want 
to remain in the image. When the utility is run, the area inside the 
contours remains and the areas outside the contour are discarded from 
the new dataset.

3 Select the VOI or one or more of the contours. 

4 Select Utilities > Crop. The Crop dialog box (Figure 237) appears.

5 Type the number of pixels that you want to use for the border size in 
Border size box. Specify a number from 0 to 50.

Figure 236.  Contouring the area that should remain in the cropped image
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6 Select either the New image or the Replace image check box to indicate 
whether the program should display the cropped image in a new image 
window or replace the original image with the cropped image.

7 Click OK. After a moment, the new image appears.

Border size of VOI: 

Border size (0 - 50)

Indicates the width of a strip of voxels that surround (border) the 
contours. When you crop an image, the area inside the contours and the 
border remain. All other voxels are trimmed from the image.

Coordinates of VOI Displays the coordinates for the X, Y, and Z axes of the VOI.

New image Shows the cropped image in a new image window. 

Replace image Replaces the current active image with the cropped image.

OK Applies the parameters that you specified to crop the image.

Cancel Disregards any changes you made in this dialog box, closes the dialog 
box, and does not crop the image.

Help Displays online help for this dialog box.

Figure 237.  The Crop dialog box options
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To crop an image using parameters

1 Open an image.

2 Call Utilities>Crop>Using parameters.

3 The Crop Boundary Pixels dialog box appears, see Figure .

4 Select either the New image or the Replace image check box to indicate 
whether the program should display the cropped image in a new image 
window or replace the original image with the cropped image.

5 Complete the dialog box.

6 Click OK. After a moment, the new image appears.

Pixels 
around 
image

Specify the number of pixels 
which should be cropped. 

For 3D images also specify the 
number of slices at the front 
and at the back of the image.

Select 
destinat
ion

New Image – shows the 
cropped image in a new image 
window. 

Replace Image – replaces the 
current active image with the 
cropped image.

OK Applies the parameters that you specified to crop the image.

Cancel Disregards any changes you made in this dialog box, closes the dialog box, and does 
not crop the image.

Help Displays online help for this dialog box.

Figure 238.  The Crop Boundary Pixels dialog box options
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Masking (filling) images

Masks allow you to remove portions of images and display only those 
portions as separate image files. For example, you may only be interested in 
a section of an image and only want to display and work with that section.

To create a mask, you first, need to create one or more VOIs on the image. 
Depending on the type of mask you want to create, the VOIs should do 
either of the following:

• Enclose the image areas you want to preserve

• Enclose the image areas you do not want to preserve

If the VOIs indicate the areas of the image that should be deleted from the 
image, you need to create an interior mask and specify the number of pixels 
the program should use to hide the image inside the VOIs, or interior 
(Figure 239-B).

To preserve the image inside the VOIs, however, you need to create an 
exterior mask. An exterior mask fills the image outside of the VOIs with the 
number of pixels you specify. This filling hides the portions of the image 
outside the VOIs, or exterior (Figure 239-C).

A B

Figure 239.  An original image (A), interior mask (B) and exterior mask (C)
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To create an interior mask

1 Open an image.

2 Create one or more VOIs that enclose the portions of the image that 
interest you.

3 Select Utilities > Fill. The Fill dialog box (Figure 240) opens.

4 Type the number of pixels to fill the interior of the VOIs.

5 Select Interior fill. 

6 Select either New Image or Replace Image depending on which you 
prefer.

7 Click OK. The program either displays a new image or replaces the 
current image with an image that hides the portions of the image that 
are inside the VOIs (Figure -B). 

To create an exterior mask

1 Open an image.

2 Create one or more VOIs that enclose the portions of the image that 
interest you.

3 Select Utilities > Fill. The Mask dialog box (Figure 240) opens.

4 Type the number of pixels to fill the interior of the VOIs.

5 Select Exterior fill.

6 Select either New Image or Replace Image depending on which you 
prefer.

7 Click OK. The program either displays a new image or replaces the 
current image with an image that hides the exterior of the image outside 
the VOIs (Figure -C).
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Flipping images 

MIPAV allows you to flip images either horizontally, or vertically, or invert 
the order of slices in the image dataset. The last option is available via the 
Utilities>Flip Image> In Depth menu (refer to page 437 for more 
information).

To flip an image, 

1 Call Utilities > Flip > Horizontal, Vertical of In Depth. 

2 Then, complete the dialog box that appears, and press OK. 

3 After a few moments, the flopped image replaces the original image in 
the same image window. For dialog box options, refer to Figure 241. 

Parameters Specifies the value in pixels to 
fill the VOI.

Interior fill Applies the value to the interior 
of the VOI.

Exterior fill Applies the value to the exterior 
of the VOI.

New image Shows the cropped image in a 
new image window. 

Replace image Replaces the current active 
image with the cropped image.

OK Applies the parameters that you specified to mask the image.

Cancel Disregards any changes you made in this dialog box, closes the dialog box, 
and does not mask the image.

Help Displays online help for this dialog box.

Figure 240.  The Fill Image dialog box
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To invert the order of images in datasets

1 Open an image that contains slices.

2 Select Utilities > Flip> Flip in Depth.

A status message appears and indicates that the software is reordering 
the slices in the dataset. In a moment or two the MIPAV window 
refreshes, and the image window in which the original dataset appeared 
displays the reordered slices.

Options Flip all VOIs – flips 
an image along with 
all VOIs.

Flip Axis Vertical (X Axis) – 
flips the image 
vertically;

Horizontal (Y Axis) – 
flips the image 
horizontally;

Depth (Z Axis) – flips 
the image about the 
Z axis.

OK Applies the parameters that you specified to flip the image.

Cancel Disregards any changes you made in this dialog box, closes the dialog box, and does 
not flip the image.

Help Displays online help for this dialog box.

Figure 241.  The Flip Image dialog box options

A B C

Figure 242.  An original image (A), image flipped horizontally (B), and then vertically (C)
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Image Calculator

This algorithm adds, subtracts, multiplies, and divides, etc. the pixel values 
of one image by the pixel values of another image. In addition, two images 
can be ANDed, ORed or XORed together. Also, more advanced operator 
expressions can be entered in the dialog text field. 

Background
Image Calculator performs arithmetic and logical operations between two 
images selected from popup menus. 

The commands in the main Image Calculator dialog box take the pixel 
values of Image A, and then add, subtract, multiply, etc. them to the pixel 
values of Image B. For 2D and 3D images the specified operation is 
performed on all image slices. Refer to Figure 255.

The advanced dialog options (refer to page 449) allow performing advanced 
math operations on both images and also performing math operations on 
the selected image using the specified constant, e.g. Image A*C, where C is a 
constant.

CLIP MODE

When clip mode is selected and the result value is greater than the maxi-
mum value of Image A's data type, the value is clamped at the maximum 
value of Image A's data type. When clip mode is selected and the result 
value is less than the minimum value of Image A's data type, then the value 
is clamped at the minimum value of Image A's data type. See Figure 255.

PROMOTION MODE

When the Promote Destination Image Type mode is selected and the result 
value is not within the legal range of Image A data type, then the result 
image type is promoted from the default of the Image A data type to a new 
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data type with a data type range capable of expressing the minimum and 
maximum values. 

Promotion sequence:

• Boolean is promoted to byte, byte is promoted to unsigned byte, 
unsigned byte is promoted to short, short is promoted to unsigned 
short, unsigned short is promoted to integer, integer is promoted to 
unsigned integer, unsigned integer is promoted to long, long is 
promoted to float, and float is promoted to double. Double is not 
promoted.

• Color with 3 bytes is promoted to color with 3 unsigned shorts, and 
color with 3 unsigned shorts is promoted to color with 3 floats. Color 
with 3 floats is not promoted.

• Complex is promoted to double complex. 

• Double complex is not promoted. 

IMAGE TYPES

You can apply Image Calculator to all 2D and 3D color and grayscale 
images. Image A and Image B must have the same number of dimensions 
and the length of every dimension in Image A must equal the length of the 
same dimension in Image B.   Also, both Image A and Image B must be color 
images, or both Image A and Image B must be black and white images. The 
Image Calculator will not accept one black and white Image And one color 
image. There are no other restrictions on data type. 

Image calculator options

ADD

Adds the pixel values of Image A to the pixel values of Image B. Basically, 
this operation adds the colors of the overlay to the background causing the 
two images ether overflow, or saturate. However, if the added colors excess 
the color limits, the color will be capped (or clamped) and the result will not 
necessarily be as you expect. 
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AND

Does AND of the Image A and the specified Image B. For each pixel in 
Image A, the Image A pixel value is set to zero, if either the Image A pixel 
value equals zero, or corresponding Image B pixel value equals zero. 
Otherwise, the Image A pixel value is left unchanged. 

AVERAGE

Average of two images is calculated as (Image A + Image B)/2.

Image A sample point 
(255.0,0.0,255.0)

Image B (0.0,12.0,255.0) Result= Image A + Image B 
(255.0,12.0,255.0)

Figure 243.  Adding Image A and Image B

Image A Image B Result=(Image A AND 
Image B)

Figure 244.  ANDing images
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MAXIMUM

RGB values for pixels in the Image A and the corresponding RGB values for 
the Image B are compared, and then replaced with the greater RGB values. 
As shown in Figure 246 below, for a chosen point, it took MAX R=12.0 from 
Image B, MAX G=30.0 from Image A, and MAX B=243.0 from Image A.

MINIMUM

RGB values for pixels in the Image A and the corresponding RGB values for 
the Image B are compared, and then replaced with the minimum RGB 
values. As shown in Figure 247 below, for a chosen point, it took MIN 

Image A Image B (Image A+Image B)/2

Figure 245.  Averaging images

Image A, for the 
selected point RGB is 
(0.0, 30.0, 243.0)

Image B, RGB (12.0, 
0.0, 44.0)

Result=MAX (Image A, 
Image B), RGB (12.0, 
30.0, 243.0)

Figure 246.  Maximum (Image A; Image B)
MIPAV User’s Guide, Volume 1, Basics 441

12/2/08 



M   I   P   A   V
M e d i c a l   I m a g e   P r o c e s s i n g, A n a l y s i s,   &   V i s u a l i z a t i o n

MIPAV User’s Guide, Volume 1, Basics
R=0.0 from Image A, MIN G=00.0 from Image B, and MIN B=44.0 from 
Image B.

MULTIPLY

Multiplies the Image A pixel values by the Image B pixel values. In clip 
mode, for RGB images with byte values, results greater than 255 are set to 
255. This method works very well if one image (either A, or B) is basically 
black or gray, or just has a light background, see Figure 248. If both images 
are color images, then you may get strange results. This technique is also 
perfect for overlaying line drawings, diagrams or images on an image with 
very light white or colored background. See also “clip mode” on page 438.

Image A, for the 
selected point RGB is 
(0.0, 30.0, 243.0)

Image B, RGB (12.0, 
0.0, 44.0)

Result=MIN (Image A; 
Image B), RGB (0.0, 
0.0, 44.0)

Figure 247.  Minimum(Image A; Image B)

Image A Image B Image A*Image B

Figure 248.  Multiply(Image A; Image B)
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DIFFERENCE

The difference operation is a sequence of two operations. First, a subtrac-
tion operation is performed. Then, the absolute value of the result of the 
subtraction operation is taken. The variation between the colors black and 
white difference will produce a maximum result of white. However, any col-
ors which are the same will produce black. You can use this function to see 
where images are similar and where they differ.

DIVIDE

Divides the pixel values of Image A by the specified Image B. A positive 
number divided by zero could yield either the maximum positive value, or 
positive infinity. A negative number divided by zero could yield either the 
maximum negative value or negative infinity. Zero divided by zero could 
yield either zero or not a number.

Image A Image B |Image A-Image B|

Figure 249.  Difference (Image A; Image B)
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OR

If the pixel value from a chosen pixel in Image A equals zero, then the result 
pixel value is set equal to the corresponding Image B pixel value. Otherwise, 
the result pixel value is the same as for the Image A (i.e. stays unchanged).

• Result=Image B, if Image A=0;

• otherwise, Result=Image A.

XOR

It overlays two images together, but then clears the area that is overlapped 
back to transparency. If both Image A and Image B pixel values are nonzero, 
then the result image is set to zero. If both Image A and Image B pixel values 

Image A Image B Image A/Image B

Figure 250.  Dividing images

Image A Image B (Image A OR Image B)

Figure 251.  OR(Image A; Image B)
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are zero, then the result image remains zero. If only one of Image A and 
Image B is nonzero, then the result retains or assumes the nonzero value.

SUBTRACT

Subtracts the pixel values of Image B from the corresponding pixel values of 
Image A. 

1.2 

Image A Image B (Image A XOR Image B)

Figure 252.  XOR(Image A; Image B)

Image A Image B Image A-Image B

Figure 253.  Subtract(Image A; Image B)
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Advanced math options

ABS

Generates the absolute value of the active image or selection. 

EXP

Applies the function f(p) = exp(p) to each pixel (p) in the image or selection. 
For RGB images, this function is applied to all three color channels.

LN

Applies the function f(p) = ln(p) to each pixel (p) of the image or selection. 
For RGB images, this function is applied to all three color channels.

LOG

Applies the function f(p) = log(p) to each pixel (p) in the image or selection. 
For RGB images, this function is applied to all three color channels.

POW

The function pow (x,y) produces a value of x raised to the power of y, e.g., 
pow(2,3) gives 8. For RGB images, this function is applied to all three color 
channels. In clip mode, for RGB images with byte values, results greater 
than 255 are set to 255. In promote destination image mode, the image will 
be promoted to ARGB_USHORT and capable of storing color values of up 
to 65535.
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SIN, COS, TAN

Apply the functions sin(p), cos(p), and tan(p) to each pixel (p) of the image 
or selection. For RGB images, the chosen function is applied to all three 
color channels.

Applying the Image Calculator to images
To run this algorithm, complete the following steps:

1 Open at least two images. The images must have the same dimensions.

2 Select Utilities >Image Calculator. The dialog box opens. See 
Figure 255.

3 Use the Operator list box to select the math operator (Add, AND, 
Average, etc.).

4 Use the Image B list box to select Image B.

5 Check the Clip option if you want to clamp result data to the bounds of 
the input image type. Check the Promote option to promote image type 
so that the range of the result fits into the new image type. Refer to “clip 
mode” on page 438 and “promotion mode” on page 438.

6 Click OK. The algorithm begins to run.

Image A f(p)=pow(Image A;3)

Figure 254.  Image A after applying f(p)=pow(Image A;3). The function 
was applied for all three color channels. The result values greater than 
255, as for the B channel, were set to 255
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7 Depending on whether you selected New Image or Replace Image A, the 
result appears in a new window or replaces the image to which the 
algorithm was applied.

Image A
Image A.

Operator
Select the math 
operator from the list.

Image B
Select Image B from 
the list.

Clip

Select this option if 
you want the result 
image to be clamped 
at the maximum 
(minimum) value of 
Image A data type. 

See also “clip mode” 
on page 438.

Promote 
destination 
image type

When this mode is selected and the result value is out of the legal range 
of Image A data type, then the result image type is promoted to a new 
data type with a data type range capable of expressing the minimum and 
maximum values. See also “promotion mode” on page 438.

Destination

New image
The result image will open in a new image frame.

Replace 
image

The result image will replace Image A.

OK
Applies the algorithm according to the specifications in this dialog box. 

Advanced
Calls the Enter Advanced Operator dialog box.

Cancel
Disregards any changes that you made in this dialog box and closes it.

Help
Displays online help for this dialog box.

Figure 255.  The Image Calculator dialog box options
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ADVANCED IMAGE CALCULATOR OPTIONS

To use advanced options provided by the Image Calculator dialog box, 
complete the following steps:

1 Open at least two images. The images must have the same dimensions.

2 Select Utilities >Image Calculator. The dialog box opens.

3 Use the Image B list box to select Image B.

4 Check the Clip option if you want to clamp result data to the bounds of 
the input image type. Check the Promote option to promote image type 
so that the range of the result fits into the new image type. 

5 Use the Advanced button to call the advanced options. The Enter 
Advanced Operator dialog box appears.

6 Use the dialog box options to perform any of the standard operations for 
which you would normally use a handheld calculator. Advanced opera-
tor performs on the images basic arithmetic, such as addition and sub-
traction, as well as functions found on a scientific calculator, such as 
logarithms and exponent. 

Note:  that in this dialog box you can combine images and constants in one 
math operation.

7 Click OK. The algorithm begins to run.

8 Depending on whether you selected New image or Replace Image A, the 
result appears in a new window or replaces the Image A to which the 
algorithm was applied.
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Enter Advanced Operator dialog box 

REFERENCES

The parsing of the advanced operator expression is largely based on the file Func.java by 
Leen Ammeraal. The Func.java file appears at ftp://ftp.expa.fnt.hvu.nl/pub/ammeraal and 
http://home.wxs.nl/~ammeraal

It is also contained in Chapter 8 of Computer Graphics for Java Programmers by Leen 
Ammeraal, Copyright 1998 by John Wiley & Sons Ltd.

A= [file 
name]

Image A.

B=[file 
name]

Image B.

All available math functions can be 
entered in the Advanced operator text 
box manually or using the 
corresponding buttons.

Numbers also can be entered in the 
Advanced Operator text box manually or 
using the calculator buttons.

Backspace

Uses the same function as the Backspace button in the handlend calculator.

CE

Uses the same function as the CE button in the handlend calculator.

OK

Applies the algorithm according to the specifications in this dialog box. 

Cancel Disregards any changes that you made in this dialog box and 
closes it.

Help Displays online help for this dialog box.

Figure 256.  The Enter Advanced Operator dialog box options
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Image Calculator–Bulk Images

As for now, the Image Calculator–Bulk Images utility adds the pixel values 
of selected images. Basically, this operation adds the colors of the overlay to 
the background causing the two images ether overflow, or saturate. How-
ever, if the added colors excess the color limits, the color might be capped 
(or clamped) and the result might  not necessarily be as you expect. See also 
Image Calculator, “clip mode” and “promotion mode” on page 438.

Image 1 Image 2

Image 3 Image 4

Image 5 Result

Figure 257.  Adding images using the Image Calculator–Bulk Images 
utility
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IMAGE TYPES

You can apply Image Calculator–Bulk Images to all 2D and 3D color and 
grayscale images. Images must have the same number of dimensions and 
the length of every dimension in each image must be the same.   Also, all 
images must be color images, or grayscale images. There are no other 
restrictions on data type. 

Applying the Image Calculator – Bulk Images
To run the utility, complete the following steps:

1 Open images which you would like to add. The images must have the 
same dimensions.

2 Select Utilities >Image Calculator–Bulk Images. The dialog box opens. 
See Figure 258.

3 The list of images appears in the Images window.

4 If you want to remove a certain image(s), select it, and then press 
Remove.

5 If you want to add images to the list press Browse, and then select the 
image(s) from your disk.

6 Check the Clip option, if you want to clamp result data to the bounds of 
the input image type. Check the Promote option to promote image type 
so that the range of the result fits into the new image type. Refer to “clip 
mode” on page 438 and “promotion mode” on page 438.

7 Click OK. The algorithm begins to run. And the result image appears in 
a new image frame.
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Image Math

Algorithm that adds, subtracts, multiplies, or divides an image by some user 
specified value. In addition, the square root, absolute value, or log of an 
image can be calculated. If the new image exceeds the range that can be 
stored in an image of that type, the data is either clipped and stored in the 
original image or a new image of a type (int, float...) that can store the range 
of new data is generated.

See also: ‘‘Image Calculator’’, Sections ‘‘clip mode’’ and ‘‘promotion mode’’ 
on page 438.

IMAGE TYPES

You can apply Image Calculator to all 2D and 3D grayscale images. And here 
is the difference between Image Math and Image Calculator (refer to “Image 
Calculator” on page 438). The last one you can ally to all types of images 2D, 
3D, 4D color and grayscale.

Figure 258.  Image Calculator–Bulk Images dialog box
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Applying the Image Math to images
To run this algorithm, complete the following steps:

1 Open an image of interest.

2 Select Utilities >Image Math. The dialog box opens. See Figure 259.

3 Use the Operator list box to select the math operator (Absolute value, 
Add, Average, etc.).

4 Use the Value text box to enter a numerical value.

5 Select the Clip option if you want to clamp result data to the bounds of 
the input image type. Select the Promote option to promote image type 
so that the range of the result fits into the new image type. Select the 
Convert to Float option to convert the result into float image type.

6 Click OK. The algorithm begins to run.

7 Depending on whether you selected New Image or Replace Image, the 
result appears in a new window or replaces the image to which the 
algorithm was applied. See also Figure 259.

Value

Enter the numerical 
value here. Note that 
the text box become 
available after you 
select the math 
operator.

Operator
Select the math 
operator from the list.

Clip

Select this option if 
you want the result 
image to be clamped 
at the maximum 
(minimum) value of 
the original image 
data type. 

See also “clip mode” on page 438.

Figure 259.  The Image Math dialog box options
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Promote 
image type

When this mode is selected and the result value is out of the legal range 
of the original image data type, then the result image type is promoted to 
a new data type with a data type range capable of expressing the 
minimum and maximum values. See also “promotion mode” on 
page 438.

Convert to 
float

When this mode is selected and the result value is out of the legal range 
of the original image data type, then the result image type is converted 
to float data type.

Destination

New image
The result image will open in a new image frame.

Replace 
image

The result image will replace the original image.

Process

Whole 
image

The algorithm applies to the selected VOI(s) region.

VOI region
The algorithm applies to the whole image.

OK
Applies the algorithm according to the specifications in this dialog box. 

Advanced
Calls the Enter Advanced Operator dialog box.

Cancel
Disregards any changes that you made in this dialog box and closes it.

Help
Displays online help for this dialog box.

Figure 259.  The Image Math dialog box options (continued)
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EXAMPLES OF USING IMAGE MATH

Original Absolute value

Add 100 Average

Constant Divide by 100

Figure 260.  Applying Image Math to images
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Inverting the image

The Utilities>Invert command inverts the colors of the image, creating a 
photo-negative effect. There are no options for this effect. Simply select New 
Image to send the inverted image to a new image frame or Replace Image to 
overwrite the file with your changes, or click Cancel to discard the changes 
and leave the image as-is.

Log Multiply by 5

Square Square root

Subtract 5 Sum

Figure 260.  Applying Image Math to images (continued)
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Matching images

The Match Images command on the Utilities menu assists in any 
comparison of two images. To use this utility, you need to first open two 
images: image A, which has the desired characteristics, and image B, whose 
characteristics need to match those of Image A. The Match Images dialog 
box presents the following four ways in which you can match the images:

• Match image orientation—Rotates Image B so that its orientation 
is the same as the orientation of image A.

• Match resolutions—Subsamples the image for each dimension with 
lower resolution (i.e., larger pixel size) so that both images have the 
same resolution. To ensure that the fields of view remain the same, the 
program adds extra pixels to the image.

• Match origins—Adds margins to one of the images for each 
dimension if the origins (i.e., the starting location) of the two images 
are not the same. The program also adds pixels to the left, top, or front 
of the image.

• Match image dimensions—Adds pixels to the right, bottom, or 
back of either image so that they have the same dimensions.

You can select one or more of these choices in the dialog box. Before actually 
performing any selected comparison, MIPAV first checks to see whether the 
images do not already match in that regard. If they do, the given match is 
not performed.

Figure 261.  The Invert Image dialog box
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To match image orientation

1 Open two images.

2 Select Utilities > Match images. The Match Images dialog box 
(Figure 262) opens.

3 Select one of the open images as image A, and select the other image as 
image B.

4 Select Match image orientations (based on imaging orientation).

5 Select any or all of the other check boxes to also, if desired, match image 
resolutions, origins, or dimensions.

6 Click OK. If the orientations of the images differ, the program changes 
the orientation of Image B to match that of Image A.

To match image resolutions

1 Open two images.

2 Select Utilities > Match images. The Match Images dialog box 
(Figure 262) opens.

3 Select one of the open images as image A, and select the other image as 
image B.

4 Select Match image orientations (based on imaging orientation).

5 Select any or all of the other check boxes to also, if desired, match image 
resolutions, origins, or dimensions.

6 Click OK. If the resolutions of the images differ, the program changes 
the resolution of Image B to match that of image A.

To match image origins

1 Open two images.

2 Select Utilities > Match images. The Match Images dialog box 
(Figure 262) opens.

3 Select one of the open images as image A, and select the other image as 
image B.

4 Select Match image origins (by adding margins where necessary).
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5 Select any or all of the other check boxes to also, if desired, match image 
orientations, resolutions, or dimensions.

6 Click OK. If the origins of the images differ, the program changes the 
origin of Image B to match that of image A.

To match image dimensions

1 Open two images.

2 Select Utilities > Match images. The Match Images dialog box 
(Figure 262) opens.

3 Select one of the open images as image A, and select the other image as 
image B.

4 Select Match image dimensions.

5 Select any or all of the other check boxes to also, if desired, match image 
orientations, resolutions, or origins.

6 Click OK. If the dimensions of the images differ, the program changes 
the dimension of Image B to match that of image A.

Image A Specifies the image that contains the orientation, resolution, 
origins, or dimensions with which Image B needs to match.

Image B Specifies the image on which to perform the image matching.

Match image orientations 
(based on imaging 
orientation)

Applies the image orientations (based on image orientation) used 
in Image A to Image B.

Match image resolutions, 
axis by axis (subsampling 
image with lower resolution)

Matches the image resolutions in Image A to Image B. Note that 
this subsamples Image A with a lower resolution if necessary.

Figure 262.  Match Images dialog box
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Maximum Intensity Projection

Maximum Intensity Projection (MIP) is a volume rendering technique for 
3D images that projects in the visualization plane the voxels with maximum 
intensity that fall in the way of parallel rays traced from the viewpoint to the 
plane of projection. At each pixel the highest data value encountered along 
the corresponding viewing ray is determined. 

MIP exploits the fact, that within MRI data sets the intensity values of vas-
cular structures are higher than the intensity values of the surrounding tis-
sue. By depicting the maximum intensity value seen through each pixel, the 
structure of the vessels contained in the image can be captured. 

The method provides a very good understanding of the structures defined 
by high signal intensities. It also helps to avoid the problem with occluding 
structures, which can block visualization of thin inner parts.

Background
A MIP algorithm accepts a single grayscale 3D image and generates three 
2D images representing the maximum intensities in x, y, and z directions. 

Let I be an input grayscale 3D image of size (m*n* l). Let X, Y, and Z be the 
output 2D images representing the maximum intensities in x, y, and z direc-
tions.

X is a 2D image of size (y* z) formed by viewing along the x-axis and select-
ing the highest intensities in the y–z plane. Y image is of size (x*z) formed 

Match image origins (by 
adding margins where 
necessary)

Matches the image origins used in Image A to Image B. Note that, 
if necessary, this adds margins to Image B.

Match image dimensions Applies the image dimensions used in Image A to Image B.

OK Applies the parameters that you specified to add margins to this 
image.

Cancel Disregards any changes you made in this dialog box, closes the 
dialog box, and does not perform image matching.

Help Displays online help for this dialog box.

Figure 262.  Match Images dialog box (continued)
MIPAV User’s Guide, Volume 1, Basics 461

12/2/08 



M   I   P   A   V
M e d i c a l   I m a g e   P r o c e s s i n g, A n a l y s i s,   &   V i s u a l i z a t i o n

MIPAV User’s Guide, Volume 1, Basics
by viewing along the y-axis and selecting highest intensities in the x–z 
plane. Similarly, Z image is formed by viewing along the Z axis and selecting 
highest intensities in the x–y plane and is of size   (x * y). 

Note: The MIP algorithm allows to set the minimum and maximum thresholds on 
the image before computation which aids in enhancing MIP visualization in 
certain cases. 

IMAGE TYPES

This algorithm works with 3D grayscale images (all image types except 
complex). By default, the result images are of type float. 

SPECIAL NOTES

The origin of the result images is at the top left corner and the original 
resolutions of the 3D image in all directions are preserved. 

Applying the Maximum Intensity Projection
To run the method, 

1 Open an image of interest.

2 Select Utilities > Maximum intensity projection (MIP). 

3 The Maximum Intensity Projection dialog box appears. 

4 Complete the dialog box. You might choose to fill out two input fields – 
Threshold Minimum and Threshold Maximum; or just use the default 
values. These fields are initially populated with the minimum and 
maximum intensities of the image.

5 Click OK.
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The algorithm begins to run, and a pop-up window appears with the status. 
The following message appears: Computing Maximum Intensity Projec-
tion. When the algorithm has finished to run, the pop-up window closes and 
the three 2D images appear in three different windows. See Figure 264.

Figure 263.  The Maximum Intensity Projection dialog box. The input 
fields are initially populated with the maximum and minimum intensities 
of the image

Figure 264.  The original image (A) and three 2D result images; x–
projection (X), y–projection (Y), and z–projection (Z)
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Adding noise to images

Adding noise to images allows you to test the robustness and performance 
of an algorithm in the presence of known amounts of noise. When you select 
Utilities > Noise, the program clamps either Gaussian or Uniform noise to 
the lowest or highest value in the source image type.

For example, for a byte image, if the intensity of the source pixel is 120 and 
noise is 15, then intensity + noise = 135. This value (135) would be clamped to 
the maximum pixel value for a byte image (127).

This class relies heavily on the Java Random class and is used to generate a 
stream of pseudorandom numbers. The class uses a 48-bit seed, which is 
modified using a linear congruency formula (refer to Donald Knuth, The Art 
of Computer Programming, Volume 2, Section 3.2.1.).

To add noise to images

1 Open an image on which you want to test the effectiveness of an 
algorithm.

2 Select Utilities > Noise in the MIPAV window. The program displays the 
Additive Noise dialog box (Figure 265).

3 Type the level of noise that you want to add to the image in the Noise 
level box. You can specify a value from 10 to 32,768.

Noise level (0-32768) Specifies the level of noise to 
add to the image. 

The default value is 10.

Noise Type

Gaussian Adds Gaussian noise to the 
image.

Uniform Adds Uniform noise to the 
image.

Destination

New image Shows the cropped image in a new image window. 

Replace image Replaces the current active image with the cropped image.

Figure 265.  Additive Noise dialog box
MIPAV User’s Guide, Volume 1, Basics 464

12/2/08 



M   I   P   A   V
M e d i c a l   I m a g e   P r o c e s s i n g, A n a l y s i s,   &   V i s u a l i z a t i o n

MIPAV User’s Guide, Volume 1, Basics
4 Type the level of noise that you want to add to the image in the Noise 
level box. You can specify a value from 10 to 32,768.

5 Select either of the following:

• Gaussian—To add Gaussian noise to the image

• Uniform—To add Uniform noise to the image

6 Select either of the following:

• New image—To generate the resulting image in a new image window

• Replace image—To replace the current image with the resulting image

7 Click OK. The program adds the Gaussian or Uniform noise to the image 
and displays either a new image or replaces the current image with the 
one to which noise was added.

8 Now, select the algorithm in the Algorithms menu to test its 
effectiveness on the image.

Example

In the following example (Figure 266), the original image appears at the top 
of the figure. The next row shows the image on the left that results from 
adding Uniform noise of 1000. To its right is the image after running the 
Median algorithm. The image on the left on the last row results from adding 
Gaussian noise of 1000 to the original image. Running the Median 
algorithm on that image produces the image on its right. In this example, 
the Median algorithm performs better on an image containing Gaussian 
noise.

OK Applies the parameters that you specified for adding noise to this image.

Cancel Disregards any changes you made in this dialog box, closes the dialog 
box, and does not add noise to this image.

Help Displays online help for this dialog box.

Figure 265.  Additive Noise dialog box (continued)
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.

A

A is an original image

B is the image after 
applying Uniform noise 
(1000)

C is the image B after 
applying the Median filter

D is the image after adding 
Gaussian noise (1000)

F is the image D after 
running the Median filter on 
it

B C

E F

Figure 266.  Examples of adding a noise to an image, and then 
using it to test an algorithm’s effectiveness in removing the noise
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Pad

The Pad command on the Utilities menu allows to pad images with certain 
values specified by the user. 

To use the Pad utility

1 Open an image of interest.

2 Call Utilities>Pad.

3 The Pad Image dialog box appears. Enter the number of pixels to be 
padded on the left side, right side, top and bottom. If the image is a 3D 
image, you can also add a number slices to the front or back of the 
image. 

4 Specify the intensity value for padded pixels.

5 Click OK. Depending on the selected option – New Image or Replace 
Image – the padded image appears either in a new image frame or 
replaces the original image.

Pixels Around Image

Pixels on the left side Specify the number of pixels 
to add to the left side of the 
image. 

Pixels on the right 
side

Specify the number of pixels 
to add to the right side of the 
image.

Pixels on top Specify the number of pixels 
to add to the top of the 
image.

Pixels on bottom Specify the number of pixels 
to add to the bottom of the 
image.

Slides at the front of 
image

Specify the number of slices to add to the front of the image.

Slides at the back of 
image

Specify the number of slices to add to the back of the image.

Pad value Specify the intensity value for the added pixels.

Figure 267.  The Pad Image dialog box
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Quantify Mask

There are two algorithms Quantify Mask(s) and Quantify Using Mask that 
calculate Center of Mass, area (in resolutions), and number of pixels for a 
selected mask(s). The algorithms work with Boolean, byte, unsigned byte, 
and short masks.

Destination

New image Shows the padded image in a new image window. 

Replace image Replaces the current active image with the padded image.

OK Applies the padding values that you specified to the image.

Cancel Disregards any changes you made in this dialog box and closes the dialog 
box.

Help Displays online help for this dialog box.

Figure 267.  The Pad Image dialog box (continued)

Figure 268.  The original image (on your left) and the image padded to 
(10;10;10;10). The intensity value for padded pixels is set to 200

Identify Image Mask file

Choose Press to select an image mask 
from your hard drive.

OK Applies the Quantify masks(s) 
or Quantify Using Mask 
algorithms to the image(s).

Figure 269.  The Quantify dialog box
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To apply the Quantify Mask(s) algorithm:

1 Open an image of interest.

2 Create a mask as described in Chapter 8, “Generating masks”.

3 Save the mask as Boolean, byte, unsigned byte, or short. 

4 Alternatively, you can open the mask file from the disk using the 
Quantify dialog box options.

Note: the algorithm doesn’t work for paint masks.

5 Call Utilities>Quantify> Quantify Mask(s).

6 The algorithm begins to run and the data appear in the Output window. 
See Figure 270.

7 Later, you can save the data using the File>Save Images option provided 
by the Output window.

Cancel Disregards any changes you made in this dialog box and closes the dialog 
box.

Help Displays online help for this dialog box.

Figure 269.  The Quantify dialog box
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To apply the Quantify Using Mask algorithm:

1 Open an image of interest.

2 Create the image mask as described in Chapter 8, “Generating masks”.

3 Alternatively, you can open the mask file from the disk.

4 Call Utilities>Quantify> Quantify Using Mask.

5 The algorithm begins to run and the data appear in the Output window. 
See Figure 271.

6 Later, you can save the data using the File>Save Images option provided 
by the Output window.

Note: the algorithm works with Boolean, byte, unsigned byte, and short masks, 
but it doesn’t work with paint masks.

Figure 270.  The Quantify Mask(s) algorithm
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Replacing pixel/voxel value in images

You can replace the values of pixels or voxels in images by using the Replace 
pixel/voxel values command on the Utilities menu. Suppose, for example, 
that you have a set of images that contain not a number (NaN) values. To be 
able to use MIPAV algorithms on those images, you first need to replace 
those not a number values. The Replace pixel/voxel value command 
provides an easy way to replace those values or any pixel or voxel values.

To replace pixel or voxel value in images

1 Open the image whose pixels or voxels you want to change.

2 Select Utilities > Replace pixel/voxel values. 

The Replace Pixel/Voxel Value dialog box (Figure 272) opens.

Figure 271.  The Quantify Using Mask algorithm
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3 Do one of the following:

a Select User defined value and type the value that you want to replace 
in the text box

b Select Presets and then select one of the following in the list box:

• NaN—Not a number

• —Positive infinity

• —Negative infinity

4 Do one of the following:

• Accept the default value in Replace with.

• Type another value in the text box.

5 Select one of the following:

• New image—To create a new image in its own image window using 
the replaced value

User-defined 
value

Specifies the value that you 
want to replace in the image.

Presets NaN—Not a number.

—Positive infinity.

—Negative infinity.

Replace with Accept the default value or type 
another value.

New image Shows in a new image window 
the image in which the value 
was replaced.

Replace 
image

Replaces the current image with the image in which the value was replaced.

OK Applies the parameters that you specified to subsample the image.

Cancel Disregards any changes you made in this dialog box, closes the dialog box, and 
does not subsample the image.

Help Displays online help for this dialog box.

Figure 272.  Replace Pixel/Voxel Value dialog box
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• Replace image—To overwrite the original image in the original 
image window with an image using the replaced value

6 Click OK. The image with the replaced value appears in either a new 
window or in the original image window.

Rotating images

You can rotate images about the x, y, and z axes. For example, suppose that 
you opened the following image:

To rotate images

1 Select Utilities > Rotate in the MIPAV window.

2 Select one of the following:

• X Axis +90: To rotate the image about the x axis by +90 degrees.

• X Axis -90: To rotate the image about the x axis by -90 degrees.

• Y Axis +90: To rotate the image about the y axis by +90 degrees.

• Y Axis -90: To rotate the image about the y axis by -90 degrees.

• Z Axis +90: To rotate the image about the z axis by +90 degrees.

• Z Axis -90: To rotate the image about the z axis by -90 degrees.

A status message appears. When rotation is complete, the status window 
closes, and MIPAV replaces the original image in the image window with 
the rotated image.

Figure 273.  Original image to be rotated
MIPAV User’s Guide, Volume 1, Basics 473

12/2/08 



M   I   P   A   V
M e d i c a l   I m a g e   P r o c e s s i n g, A n a l y s i s,   &   V i s u a l i z a t i o n

MIPAV User’s Guide, Volume 1, Basics
Figure 274.  Rotation

Figure 275.  Examples of rotating images

This figure shows the image in Figure 273 at the six different types of x, y, and z 
rotation.
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Slice tools

Concatenating images
The Concatenate command on the Utilities menu provides you with a way to 
append, or add, two datasets together.

To concatenate image datasets

1 Open the two datasets that you want to join.

2 Select the dataset to which you want to append the other dataset.

3 Select Utilities > Concatenate. The Concatenate Images dialog box 
(Figure 276) opens.

4 Note that the dataset you selected appears in read-only form in the box 
labeled Image A.

5 Select Image B, which is the name of the dataset that you want to add to 
the end of Image A.

6 Select the dimensionality that you want for the resulting dataset by 
selecting either 3D or 4D.

Note: If both datasets contain the same number of slices, you can select either 
3D or 4D. If the datasets contain a different number of slices, you can only select 
3D.

7 Click OK. The program adds the Image B dataset to the end of the Image 
A dataset and displays the resulting dataset in a new image window.
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To verify that the datasets are joined

1 Select the new dataset that resulted from concatenating the Image A and 
Image B datasets.

2 Notice the following on the MIPAV window:

• If you selected 3D as the dimensionality of the resulting dataset in 
the Concatenate Images dialog box, the image slice slider 
(Figure 277 upper part) lists twice as many slices as either the Image 
A and Image B datasets.

• If you selected 4D as the dimensionality of the resulting dataset, a 
time slice slider (Figure 277 lover part) appears beneath the image 
slice slider and the image slice slider lists the same number of slices 
as the Image A and Image B datasets.

Image A Specifies the name of the dataset 
to which to append Image B. This 
dataset is the one you selected 
before using the Concatenate 
command.

Image B Specifies the name of the dataset 
that you want to append to the 
Image A dataset.

3D Indicates that the dataset that 
results from appending Image B 
to Image A is three dimensional.

4D Indicates that the dataset that 
results from appending Image B 
to Image A is four dimensional.

OK Applies the changes you made in this dialog box and closes the dialog box.

Cancel Disregards any changes you made in this dialog box, closes the dialog box, and 
does not append Image B to Image A.

Help Displays online help for this dialog box.

Figure 276.  Concatenate Images dialog box
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Figure 277.  The MIPAV window after concatenating datasets to generate 3D (upper) 
or 4D (lover) datasets
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Extracting slices/volumes
The Extract Slices/Volume utility makes copies of the slices or volumes you 
select and displays them in separate image windows. Unlike the Remove 
Slices utility, the original image dataset is untouched.

There are several ways to select slices or volumes. You can select all slices; 
only specific slices; only the even-numbered slices; only the odd-numbered 
slices; or one or more ranges of slices.

To extract slices or volumes from image datasets

1 Select Utilities > Slice Tools>Extract Slices/Volumes. The Extract 
Slices/Volumes dialog box opens.

2 Use the image slider in the MIPAV window to locate slices that you want 
to extract.

3 Decide whether to remove:

• All of the slices—Click Select all. Check marks appear in all of the 
image slice check boxes.

• One or more slices—Select the specific check boxes for the image 
slices. Check marks appear in only the check boxes you selected.

• One or more ranges of slices—Select Specify range of slices, and 
then type the slice numbers or ranges of slice numbers in Enter slice 
numbers and/or slice ranges box. 

• All even-numbered slices—Click Check even. Check marks appear in 
only those check boxes for even-numbered slices, such as 2, 4, 6, and 
so on.

• All odd-numbered slices—Click Check odd. Check marks appear in 
only those check boxes for odd-numbered slices, such as 1, 3, 5, and 
so on.

Tip: Use the image slider on the MIPAV window to look at specific slices to decide 
which slices to remove.

4 Click Extract. A status message appears. Then the MIPAV window 
refreshes and the slices you selected appear in new image windows. 
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Check the slices 
to extract

Indicates the slices that you 
want to extract from the 
dataset. You can scroll 
through the list to select one 
or more slices.

Select all Selects all of the slices in the 
dataset to extract.

Clear Clears all of the slices that are 
currently selected.

Check even Selects all of the even-
numbered slices to extract.

Check odd Selects all of the odd-
numbered slices to extract.

Specify range of 
slices

Indicates that you want to 
extract one or more specific 
slices or a range of slices 
from the dataset. 

If you select this check box, you must specify the slices or ranges of slices you 
want to extract in the Slice number and/or range of slices box below. 

Enter slice 
numbers and/or 
slice ranges

Indicates the slices and range of slices that you want to extract. This box only 
becomes available after you select Specify range of slices.

Extract Makes copies of the slices/volumes you selected and displays them in separate 
image windows.

Cancel Disregards any changes that you made in this dialog box and closes the dialog 
box.

Help Displays online help for this dialog box.

Figure 278.  Extract Slices/Volumes dialog box
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Insert Missing Slices
The Insert Missing Slices utility insert slices into the image dataset. There 
are several ways insert a slice into the image dataset. You can select 
Average, or Blank, or Original. 

• If Average is selected, the inserted slice is set equal to the mean of the 
two surrounding slices, unless it is a new first of last slice. A new first 
or last slice preserves the usual slice spacing.

• If Blank is selected, the slice with all pixel zero is inserted.

• If the Original option is used, a 2D image of the same dimensions is 
inserted.

IMAGE TYPES

The algorithm works with 3D and 4D, grayscale, black and white, and color 
images. It preserves the image type when inserts slices, e.g. grayscale into 
grayscale images, color into color.

APPLYING INSERT MISSING SLICES

To insert a slice to an image dataset

1 Select Utilities > Slice tools>Insert Missing Slices. The Insert Missing 
Slices dialog box opens.

2 The dialog box appears displaying a note at the top of window that 
indicates how many slices are missing.

3 Now, you have to choose the method for slice insertion: Average, Blank, 
or Original.

4 Select the destination. Choose New image if you want the image with 
inserted slices appear in a new image frame; choose Replace image to 
replace the original image.

5 Click OK to proceed. 
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Inserting slices into image datasets
When you change an image dataset, you are inserting or removing slices in 
the dataset or changing their order.

You can use the Insert Slice command on the Utilities menu to insert a slice 
into an image dataset. Although you cannot insert a slice from another file, 
you can insert either a blank slice or a new slice that is an average of two 
adjacent slices in the dataset.

To insert slices into image datasets

1 Select Utilities Slice Tools> Insert Slice. The Insert Slice dialog box 
appears.

2 Enter the number of the new slice position in the Insert before slice (1-
124) or enter 125 for new last slice box.

Insert before 
slice (1-n) or 
enter n+1 for 
new last slice

Specifies the position of the 
new slice.

Average Inserts a slice that is the 
average the adjacent slices.

Copy previous 
adjacent

Insert a slice that is a copy of 
the preceding slice.

Copy next 
adjacent

Inserts a slice that is a copy 
of the following slice.

Blank Inserts a blank slice.

Original Inserts an image from the original dataset. 

OK Applies the parameters that you specified to insert the slice in the image dataset. 

Cancel Disregards any changes you made in this dialog box, closes the dialog box, and 
does not insert the slice into the image dataset.

Help Displays online help for this dialog box.

Figure 279.  The Insert Missing Slice dialog box options
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3 Select either the Average or Blank radio button. If you select Average, 
MIPAV analyzes the slices immediately before and after the new slice in 
the dataset. The software then generates an intermediary composite by 
morphing the two slices. This composite becomes the new slice. If you 
select Blank, MIPAV inserts a blank slice in the dataset.

4 Click OK. MIPAV inserts the new slice into the dataset and opens the 
new dataset in a new image window.

Insert before 
slice (1-124) 
or enter 125 
for new last 
slice

Specifies the position of the 
new slice.

Average Inserts a slice that is the 
average the adjacent slices.

Copy previous 
adjacent

Insert a slice that is a copy of 
the preceding slice.

Copy next 
adjacent

Inserts a slice that is a copy 
of the following slice.

Blank Inserts a blank slice.

Original Inserts an image from the original dataset. 

OK Applies the parameters that you specified to insert the slice in the image dataset. 

Cancel Disregards any changes you made in this dialog box, closes the dialog box, and 
does not insert the slice into the image dataset.

Help Displays online help for this dialog box.

Figure 280.  The Insert Slice dialog box options
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Pad slices to power of 2

The utility pads an image with blank slices to an even power of 2 (e.g. 22k). 
Depending on the selected option (Pad to Front, Pad to Back, or Pad to Half 
Front and Back), all slices can be inserted in front, in back, or half the slices 
in front and half the slices in back. 

IMAGE TYPES

The algorithm works with 3D and 4D, grayscale, black and white, and color 
images. It preserves the image type when inserts slices.

APPLYING THE PAD TO POWER OF 2 UTILITY

To pad the image dataset to power of 2

1 Select Utilities > Slice tools>Pad to Power of 2. The Padding Images 
dialog box opens.

2 The dialog box window appears indicating how many slices should be 
added to the image.

3 Choose the method for slice insertion: Pad to Front, Pad to Back, or Pad 
to Half Front and Half Back.

4 Select the destination. Choose New Image if you want the image with 
inserted slices appear in a new image frame; choose Replace Image to 
replace the original image.

5 Click Pad to proceed. 
MIPAV User’s Guide, Volume 1, Basics 483

12/2/08 



M   I   P   A   V
M e d i c a l   I m a g e   P r o c e s s i n g, A n a l y s i s,   &   V i s u a l i z a t i o n

MIPAV User’s Guide, Volume 1, Basics
Randomizing image (slice) order
To randomize the order of slices in the image dataset, do the following:

1 Open an image that contains slices.

2 Write the slice numbers on a piece of paper.

3 Select Utilities > Slice Tools>Randomize Slice Order. 

4 The MIPAV window refreshes and, depending on your selection, the 
new dataset appears in the same image window as the original dataset.

The new randomized slice ordering appears as a table in the Output 
window.

Pad to Front Inserts slices before the first 
slice of the image.

Pad to Back Inserts slices after the last 
slice of the image.

Copy previous 
adjacent

Insert a slice that is a copy of 
the preceding slice.

Destination

Pad to half 
front and half 
back

Inserts half of the slices 
before the first slice of the 
image and half after the last 
slice.

New Image Opens the modified image in a new image frame.

Replace 
image

Replaces the existing image. 

Pad Applies the parameters that you specified to insert the slices in the image dataset. 

Cancel Disregards any changes you made in this dialog box, closes the dialog box, and 
does not insert the slice into the image dataset.

Help Displays online help for this dialog box.

Figure 281.  The Padding Images dialog box options
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Removing images (slices) from datasets
MIPAV allows you to remove one, several, or all slices from an image 
dataset. In addition, you can specify one or more ranges of slices to remove, 
or slice removal can include only the even-numbered or only the odd-
numbered slices.

To remove slices from datasets

1 Select Utilities > Remove slices. The Remove Slices dialog box opens.

2 Use the image slider in the MIPAV window to locate slices that you want 
to remove.

3 Decide whether to remove:

• One or more slices

• Most of the slices

• One or more ranges of slices

• All even-numbered slices

• All odd-numbered slices

Tip: Use the image slider on the MIPAV window to look at specific slices to decide 
which slices to remove.

4 Select one of the following:

• New image—If the new image dataset should appear in its own image 
window

• Replace image—If the dataset should overwrite the original dataset 
and appear in the original image window

5  Select Remove. A status message appears. Then the MIPAV window 
refreshes and, depending on your selection, the new dataset appears in 
either a new image window or in the same image window as the original 
dataset.
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Replace blanks with averages
The algorithm replaces blank slices with slices that carry average pixel 
values calculated from the neighbor slices. The algorithm, first, counts the 

Slices Indicates the slices that you want 
to remove from the dataset. You 
can scroll through the list to 
select one or more slices.

Select all Selects all of the slices in the 
dataset.

Clear Clears all of the slices that are 
currently selected.

Check even Selects all of the even-numbered 
slices.

Check odd Selects all of the odd-numbered 
slices.

Specify range 
of slices

Indicates that you want to 
remove one or more slices or a 
range of slices from the dataset. 

If you select this check box, you 
must specify the slices or ranges 
of slices you want to remove. in 
the Slice number or range of 
slices box below. 

Replace slices If you select that option, the removed slices would be replaced using the 
average method.

New image Shows the results of the slice removal in a new image window.

Replace image Replaces the current active dataset with the dataset resulting from the slice 
removal in the same image window.

Remove Removes the slices that you indicated in this dialog box. 

Cancel Disregards any changes that you made in this dialog box and closes the dialog 
box.

Help Displays online help for this dialog box.

Figure 282.  Remove Slices dialog box
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number of consecutive blank slices, and then does the following:

1 If the consecutive slices are at the beginning of the image, the all 
replaced with the first nonblank slice.

2 If the consecutive slices are at the end of the image, they all replaced 
with the last nonblank slice.

3 If the consecutive slices are somewhere in the middle, they replaced by 
the weighted sum of the surrounded nonblank slices.

Example: for a single blank slice, the pixel values are replaced by the 
averages of two surrounding slices. For two consecutive blank slices, the pixel 
values for the first slice are calculated as (2/3 * bottomNonBlank + 1/3 * 
topNonBlank); and for the second blank slice, the pixel values are calculated 
as (1/3 * bottomNonBlank + 2/3 * topNonBlank).

To run the algorithm, call Utilities >Slice Tools> Replace Blanks with 
Averages.

IMAGE TYPES

The algorithm is only applicable for 3D, grayscale images.

Replace Slices
For 3D and 4D images, the algorithm allows to replace image slices with 
some other slices (2D) chosen by a user.

TO APPLY THE REPLACE SLICES ALGORITHM,

1 Open an image of interest (3D or 4D).

2 Move the image slider so that it shows the slice that you wish to replace.

3 Open the 2D image that you would like to put in place of the chosen 
slice.

4 Call Utilities>Slice Tools>Replace Slices.
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5 In the dialog box that appears, indicate the slice number that you would 
like to replace.

6 Press OK. The algorithm replaces the selected slice with the chosen 2D 
image. See Figure 283.

IMAGE TYPES

The algorithm is applicable for both grayscale and color 3D images. The 
image that you use to replace the slice must be 2D.Note that the type of the 
original image and the image that you use to replace the slice must be the 
same. E.g. you cannot replace the grayscale slice with the color image.

Subtract VOI Background

The Subtract VOI Background algorithm subtracts the mean or median 
value of a VOI from the image. If only one contour is present, that contour is 
used whether or not it is selected. If multiple contours are present, at least 
one contour must be selected, and only selected contours are used. 

A B

Figure 283.  The Replace Slice dialog box (at the top), the original image 
(A), and the image (B) that was used to replace the slice 2 of the 
original image
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Note: that under MIPAV all selected contours must belong to the same VOI.

IMAGE TYPES

The algorithm is applicable for any 2D, 3D, 4D, color and grayscale images. 
If the new image exceeds the range that can be stored in an image of that 
type, the data is either clipped and stored in the original image (Clip mode). 
Or a new image of a type (int, float...) that can store the range of new data is 
generated (Promote Image Type mode). 

For color images, the dialog box currently disables promotion for color 
because MIPAV cannot handle negative color values.

Recommendation: To learn more about Clip and Promotion modes, see also 

“clip mode” on page 438 and “promotion mode” on page 438.

Applying the algorithm
To apply the Subtract VOI Background algorithm do the following:

1 Call Utilities>Subtract VOI Background.

2 In the dialog box that appears, select either Median or Mean.

3 Specify the clip mode.And specify where you want the new image to 
appear – in the new image frame or in the same frame, replacing the old 
image.

4 Click OK. The algorithm begins to run and the new image appears in the 
chosen destination.
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Average type

Mean Uses mean values to 
calculate average VOI 
background.

Median Uses median values to 
calculate average VOI 
background.

Clip Select this option if you want the result image to be clamped at the maximum 
(minimum) value of Image A data type. See also “clip mode” on page 438.

Promote When this mode is selected and the result value is out of the legal range of Image 
A data type, then the result image type is promoted to a new data type with a 
data type range capable of expressing the minimum and maximum values. See 
also “promotion mode” on page 438.

New Image Opens the modified image in a new image frame.

Replace 
image

Replaces the existing image. 

OK Runs the algorithm. 

Cancel Disregards any changes you made in this dialog box and closes the dialog box.

Help Displays online help for this dialog box.

Figure 284.  The Subtract VOI Background dialog box options
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