Segmenting Images Usjng Contour
nd Mask

E—

In this chapter

“Using contours to segment a VOI” on page 308
“Generating masks” on page 331

“Converting VOI contours to masks” on page 350
“Converting masks to VOI contours and paints” on page 351
“Advanced Paint and Power Paint tools” on page 352

Segmentation is the process of identifying selected regions of images as
members of a common group. Physicians routinely segment structures in
medical images to facilitate the treatment of patients. The quantification of
important attributes, such as the volume of various tissue types, enables
researchers to better understand, diagnose, monitor, and treat neurobehav-
ioral disorders.

MIPAYV provides several segmentation tools that allow you to delineate a
volume of interest (VOI). You can indicate a VOI by drawing a contour or by
creating a mask. You can also calculate predefined statistics on the indi-
cated VOL.

For more information, refer to the MIPAV web site: {http://mipav.cit.nih.gov/
documentation/HTML%20Algorithms/MIPAV_Segmentation.html}.
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Note: Once a VOI is segmented, you can also apply an algorithm to the volume
bound by the contours. MIPAV provides a number of algorithms, such as
Gaussian blur, Laplacian, threshold, and watershed. These algorithms and others
are addressed in detail in volume 2 of the User’s Guide.

Understanding contours and masks

Before you indicate a volume of interest, it is helpful to determine whether
to delineate the VOI by drawing a contour around a structure or to generate
a mask.

A contour is an array of points. If the contour is a closed polygon, the area
inside defines the VOI. Contours are scalar and can be grouped to form a
single multicontoured VOI. Contours are particularly useful if you want to
save a VOI that covers a large area because the resulting file is generally
smaller than a comparable mask file.

A mask is a filter that selectively includes or excludes certain values. You
can create a mask that includes the VOI areas and excludes all other areas.
Masks are particularly helpful if you use other image analysis programs that
require you to supply a mask. Masks can also be used to indicate a complex
area of interest. MIPAV allows you to generate binary and short image type
masks. Also, you can manually create masks using paint tools.

Using contours to segment a VOI

A VOI can consist of a single contour or several contoured structures that
are assigned to a group. You can automatically, manually, or interactively
draw contours on any image that is shown in the default view. You can
modify the shape and size of a contour and trim anchor points.

Once contours are drawn and modified, you can copy them to other slices in
the dataset or save them to a separate file for future use. The three overall
tasks involved in using contours to segment a VOI are:

¢ Drawing contours (“Drawing contours” on page 309)
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¢ Modifying contours (“Modifying contours” on page 318)

e Grouping and ordering contours (“Grouping and ordering contours”
on page 323)

Drawing contours

You can draw contours using three different methods: manual, interactive,
or automatic. With the manual method, you use the mouse to draw a con-
tour. This method provides the greatest amount of freedom: you can choose
one of MIPAV’s predefined shapes or create a freehand shape. However, the
manual method can be time consuming, particularly if the structure to be
contoured is intricate. With the interactive method, you must also manually
contour the structure. However, in this case the manually drawn contour
need not be precise because you then apply an algorithm that generates a
new contour based on both the manually drawn contour and the structure.
With the automatic method, MIPAV generates contours as you move the
mouse over different structures. The automatic method is generally accu-
rate and quick; however, it does not provide the freedom of the manual
method.

Recommendation. If you are unsure about which contour method to use, it
is recommended that you try the automatic method first.

CONTOURING STRUCTURES AUTOMATICALLY

In this method, you move the mouse pointer over a structure. MIPAYV first
analyzes the intensity values and then contours what it perceives to the
contour boundary.

Complete the following steps:

1 Select VOI > New VOI > Levelset in the MIPAV window.
2 Move the mouse pointer to the image.

The pointer changes to the cross-hair shape. As you move the pointer,
MIPAV determines the level of intensity of the pixel under the cross-
hair pointer and uses the results from the Levelset algorithm to
determine the probable boundary of the structure. Having determined
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the probable boundary, MIPAV generates a contour (Figure 170).
Continue to move the pointer until the structure you wish to outline is
contoured.

3 Click the contour to apply it to the structure. See Figure 170.

— Figure 170. Automatically
B sh_3703_12 9nem:1.0 (2B generated contour.

You can now do the following:
e Draw an additional contour
e Modify the contour

e Reassign an existing contour to
a different group

e Order the contours

e Delete the contour

CONTOURING STRUCTURES MANUALLY

You can contour structures in images by selecting one of MIPAV’s
predefined shapes, such as a point, straight line, 2D or 3D rectangle, 2D
ellipse, interslice VOI, etc. Alternatively, you can use the polygon and
polyline tools to draw freehand shapes. For more information about VOIs
available in MIPAV, refer to Figure 171.

- Point VOI - Interslice Polyline

BKibrain 62/124 M:1.0

Kibrain 52/124 M:1.0

Figure 171. VOIs available in MIPAV
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7 _ Line vor

Bibrain 71/124 M:1.0

O _ Rectangular VOI

Bibrain 71/124 M:1.0

a8 Polygon/Polyline VOI

Bibrain 71/124 M:1.0

4 _ Protractor tool
Bibrain 71/124 M:1.0

- Levelset VOI

Bibrain 71/124 M:1.0

Figure 171. VOIs available in MIPAV (continued)
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ju] _ Live wire VOI O -3p rectangular VOI
Kibrain 56/124 M:1.0
Figure 171. VOIs available in MIPAV (continued)
This section explains how to draw the following;:
e Point VOIs
e VOIs with a straight line
e 2D rectangular VOIs
¢ 3D rectangular VOIs
¢ Ellipsoidal VOIs
¢ Polyline (segmented line) and closed polygon VOIs
Tip: Before you begin, decide whether you want to draw more than one of the
same contour in succession. If you do, hold down the Shift key as you select the
contour button and draw the contours.
To draw point VOIs
— Draw Point VOI
1 Click the Draw Point VOI button, in the MIPAV window.
2 Move the pointer to the image.
3 Click the area where you want the point to appear. A numbered point
appears on the image.
Note: For some algorithms, the sequence in which you draw the points is
important (refer to Volume 2 of the User’s Guide).
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To create VOIs with a straight line

[ _ Draw Line VOI
1 Click the Draw line VOI icon.
2 Click the area on the image where you want the line to begin.

3 Drag the pointer to the place where you want the line to end. As you
drag the pointer, the line lengthens.

4 Release the mouse button. The line VOI appears on the image in red.

To create 2D rectangular VOIs

D' _ Draw Rectangular VOI
1 Click the Draw Rectangle VOI icon.

2 Click the area on the image where you want a corner of the rectangle to
appear.

3 Drag the pointer. As you drag the pointer, the rectangle changes in size.

4 Release the mouse button when the rectangle is the desired size.

Note: When you create a 2D rectangular VOI, the rectangles appear on only one
slice in the dataset.

To create 3D rectangular VOIs

@ _ Draw 3D Rectangular VOI
1 Click the 3D rectangular VOI icon.

2 Click the area on the image where you want a corner of the rectangle to
appear.

3 Drag the pointer. As you drag the pointer, the rectangle changes in size.

4 Release the mouse button when the rectangle is the desired size.

Note: Unlike 2D rectangular VOIs, 3D rectangular VOIs appear on all slices in
the dataset.
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To create ellipsoidal VOIs

© _ Draw Ellipsoid VOI
1 Click the Draw Ellipse VOI icon.

2 Click the area of the image where you want an edge of the ellipse to
appear.

3 Drag the pointer. As you drag the pointer, the ellipse changes in size.
4 Release the mouse button when the ellipse is the desired size

(Figure 171).

To create polyline (segmented line) VOIs or closed
polygon VOIs

£ _ Draw Polygon/Polyline VOI
1 Click the Draw Polygon/Polyline VOI icon.
2 Click the area of the image where the polyline VOI should begin.

3 Decide whether to draw either a straight or freehand line segment. Do
one of the following:

e To draw a straight line segment

e Make sure that you have released the mouse button. Move the
pointer to the place where you want the segment to end. A straight
line, which extends from the starting place to your pointer tip,
appears. Click the mouse button to anchor the line segment.

e To draw a freehand line segment

¢ Drag the mouse button and move the pointer to the place on the
image where you want the segment to end. A line, which matches
your mouse movements, extends from the starting place to your
pointer tip. Click the mouse button to anchor the line segment.

4 Repeat drawing straight line segments or freehand lines until you finish
drawing all of the segments needed to contour the structure.

5 Decide whether to create a polyline VOI or a closed polygon VOI:
e Polyline VOI: Go to the next step.

MIPAV User’s Guide, Volume 1, Basics 314
12/2/08



MIPAV User’s Guide, Volume 1, Basics

aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa

e Closed polygon VOI: Click the first anchor point to connect the last
line segment to the first, thus forming a closed polygon. Then go to the
next step.

6 Click the Default icon, to return the pointer to the default mode.

7 Double-click the mouse button to complete the polyline VOI.

Tip: Depending on which is more comfortable, you can switch between
drawing straight line segments or drawing freehand lines at any time.

Tip: To draw multiple VOI, hold Shift while pressing the corresponding VOI
icon.

CONTOURING STRUCTURES INTERACTIVELY

In the interactive method, you first manually draw a contour that provides a
general indication of the location and shape of the structure. You then select
an algorithm that analyzes the manually drawn contour and generates a
new one that more closely outlines the structure.

To use the interactive method to contour structures,
complete the following steps:

1 Draw a contour using one of the manual methods detailed in
“Contouring structures manually” on page 310. The contour need not be
precise, but it should indicate the general location and shape of the
structure you want to delineate.

2 Select the contour. White anchor points appear on the contour outline.
3 Select one of the following in the MIPAV window:

e VOI > Evolve Boundary 2D > Active Contour. This algorithm
determines the structure's boundary more quickly than the 2D
Spline Active Contour algorithm. It is also more sensitive to noise
present in the image. MIPAV applies a gradient magnitude filter to
determine the structure's boundary. When complete, the MIPAV-
generated contour appears around the structure.

e VOI > Evolve Boundary 2D > Active GVF. The Evolve Boundary
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dialog box uses a special type of active contours, or snakes to find
the object boundaries. GVF or the gradient vector flow snake, which
is used to calculate VOI boundaries, begins with the calculation of a
GVF field of forces by applying generalized diffusion equations to
both components of the gradient of an image edge map. Here, GVF
fields, are dense vector fields derived from images by minimizing a
certain energy functional in a variational framework. The minimiza-
tion is achieved by solving a pair of decoupled linear partial differen-
tial equations that diffuses the gradient vectors of a gray-level or
binary edge map computed from the image. See also Figure 172.

e VOI > Evolve Boundary 2D > Spline active contour. This algorithm
determines the structure's boundary less quickly than the Active
Contour algorithm, however it is less sensitive to noise. This
algorithm fits a spline to the data. When complete, the MIPAV-
generated contour appears around the structure.

e VOI > Evolve Boundary 2D > Spline GVF. This is the combination
of the GVF force with the B-spline snake. B-spline snakes have
several characteristics which make them well suitable for describing
VOI boundary as well as snake evolution: the B-spline implicitly
incorporates contour smoothness and avoids the ad hoc tension and
rigidity parameters of the traditional GVF snake and also fewer
sample points are required to implement contour evolution for the
B-spline.

BKLocked: brain 56,124 M:1.0 [_Ta[=] Kibrain 56/124 M:1.0

A B

Figure 172. An initial VOI (A) and VOI after applying the Evolve
Boundary > Active Contour algorithm with the default parameters (B)
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Propagate to adjacent slices - B et 300

propagates boundaries to [] Display GVF image

adjacent slices. P
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for 3D images version is a 2.5D R el L

dimensional algorithm where

the resultant contour in a slice Cell Tracking
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slice and is used as an initializa-

tion to the evolution in the new
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Replace original contour - if O

checked, replaces the original

VOI.

0K H Cancel || Help

Maximum GVF field iterations — enter a desired number of GVF iterations here.
LU LN D) Evolve iterations — enter a max number of iterations needed to generate a

new VOI boundary.

Display GVF image; if this box is checked, the GVF image appears in a new

image frame.
Parameters GVFk is a positive constant controlling the smoothness of the resulting VOI.

Smoothness corresponds to the balance between internal and external
forces. The internal force constrains the snake to be smooth while the
external guides the snake to seek desirable image properties, such as
edges.

Slice by slice processing - if checked, this activates evolving boundary slice
by slice.

Figure 173. The Evolve Boundary dialog box
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Cell Tracking Cell Tracking - if checked, this box activates the cell tracking algorithm;
Expected Cell Radius (in pixels) — a user-defined cell radius
Size Constraint and Shape Constraint factors are contributed towards the
shape and size of the snake in order to make it circular with a user-defined
cell radius.
Implicit Resampling Constraint factor minimizes the number of points along
the snake curve, thus they maintain an equal distance.
Cell Dilation - if checked, allows dilation
Cell dilation factor is multiple of the cell radius
Initial Cell Velocity in pixels (X,Y)

OK Applies the parameters that you specified.

Close Disregards any changes that you made in this dialog box and closes the
dialog box.

Help Displays online help for this dialog box.

Figure 173. The Evolve Boundary dialog box (continued)

Modifying contours

Once contours are drawn, you can reposition, resize, or reshape them. You
can also trim anchor points.

REPOSITIONING CONTOURS

You can reposition a single contour or a group of contours. Follow the
instructions below.

To reposition a single contour

Select the contour and drag it to the new location.

To reposition a group of contours

1 Hold down the Shift key as you click one of the contours in the group.
All of the other contours in the group are also selected.

2 Continue to hold down the Shift key as you drag the contour group to
the new location.
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RESIZING CONTOURS

You cannot collectively resize a group that consists of multiple contours;
each contour must be resized individually. Except for point VOIs, you can
resize any contour shape. For lines, only the length can be changed; the
width cannot. To resize lines, go to “To resize contours”.

Before you can resize them, all contour shapes except lines must be
surrounded by a bounding box. See also the following section “To turn the
bounding box on”.

To turn the bounding box on
1 Do either of the following:

¢ Select the contour and then select VOI > Properties in the MIPAV
window.

¢ Right-click the contour. A menu appears. Select Properties.
The VOI Statistics dialog box opens. See also Figure 196 on page 361.
2 Select Show contour bounding box.
3 Change, if you want, any of the other information in the dialog box.
4 Click Apply.

5 Click Cancel to close the dialog box.

To turn the bounding box off

1 Do one of the following:
¢ Right-click the contour. Select Properties from the pop-up menu.

e Left-click the contour. Select Properties from the VOI menu in the
MIPAV window.

The VOI Statistics dialog box appears. See also Figure 174.
2 (Clear Show Contour Bounding Box.
3 Click Apply.

4 Click Cancel to close the window.
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To resize contours

1 Select the contour. The bounding box appears (Figure 174) around the

shape. (For rectangle contours, the bounding box and rectangle legs
may overlap.)

2 Click Cancel to close the window.

LXE genormcorpZ_cor_256x256x32 13731 M:2.0 [nlE3 I
K] vo1 Properties/Statistics - 32426946 [<]
VOIproperties Statistics to calculate:
-
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Figure 174. A VOI bounding box and the VOI Properties dialog box

3 Do one of the following:

e To resize lines: Click an edge or corner of the shape. Drag until the
shape is the desired size.

e To size other shapes: Click one of the bounding box handles. Drag
the handle until the shape is the desired size.

4 Choose whether to continue showing the bounding box.

Note: If you want to reposition or add an anchor point, turn the bounding box
option off.
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RESHAPING A CONTOUR

You reshape the contour by adding or repositioning anchor points.
Instructions for adding and repositioning anchor points follow.

To add anchor points

1 Click the contour to select it. The anchor points become visible.

2 Click the place where you want to add the new anchor point. The new
anchor point appears.

To reposition anchor points

You can reposition a single anchor point at a time. If you need to redraw a
portion of the contour, MIPAV allows you to reposition several contiguous
anchor points with one motion of the mouse.

1 Select the contour. The anchor points become visible.

2 Position the pointer over the anchor point or points that you want to
reposition. The pointer changes to the shape of a hand with the index
finger extended.

3 Do either of the following:

e To reposition a single anchor point: Drag the anchor point to the
new location.

e To reposition several anchor points: Hold down the Alt key as you
drag the anchor points in the counterclockwise direction to their
new locations.

RETRACING A VOI CONTOUR

To retrace a VOI contour do the following (see Figure 175):
1 Select an existing VOI;
2 Hold the ALT key and use the mouse to pick up a point on the VOI;

3 While holding both the ALT key and left mouse button, move the mouse
clockwise to redraw the VOI,;
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4 Stop moving when you reach the last point which you would like to

redraw.

Figure 175. Retracing a VOI contour

TRIMMING VOI ANCHOR POINTS

MIPAV can automatically trim anchor points from the contour. In the
trimming process, unnecessary anchor points are pruned. For example, if
three anchor points are on the same line, the middle anchor point is deleted.
Since only two anchor points are needed to indicate a line, the middle
anchor point is extraneous. The trim parameter defines what is meant by
the same line. Setting this value to zero causes only unnecessary anchor
points on a straight 180-degree line to be pruned. Setting a higher value
prunes all but the sharpest corners of the contour.

To trim anchor points

1 Select the contour you want to trim.

2 Select VOI > Trim Parameter in the MIPAV window. The VOI Trim
Parameter dialog box (Figure 176) opens.

3 Move the slider to the desired number.
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Trim parameter

Specifies the number of anchor points

:
you want the software to trim from the Tm . =
contour. =0

Setting this value to zero causes only 0o 0.3 20
unnecessary anchor points on a straight [v] Tritm adjacent points.
180-degree line to be pruned. Setting a

higher value prunes all but the sharpest ‘ Apply H Close

corners of the contour.

Trim adjacent
points

Trims points that are adjacent.

Apply Applies the parameters that you specified.

Close Disregards any changes that you made in this dialog box and closes the
dialog box.

Help Displays online help for this dialog box.

Figure 176. VOI trim parameter dialog box

4 Click Apply. The software removes all unnecessary anchor points.

5 Click Close to close the dialog box.

Grouping and ordering contours

By default, when you draw multiple VOIs they appear grouped in a single
group, and therefore all colored in the same color. To ungroup VOIs, select
one VOI from the group, and then call VOI>VOI Grouping>Group VOIs.
This will ungroup VOIs and they appear in the image in different colors. To
group VOIs, select the VOIs which you would like to group (use Ctrl+Shift+
right mouse combination of keys for multiple selection), and then call
VOI>VOI Grouping>Group VOIs. This will group selected VOIs and they all
appear in the image colored in the same color.

GROUPING CONTOURS

A group may consist of one or more contours. A contour is assigned to only
one group. When a contour is initially drawn or generated, MIPAV assigns it
to a default group. MIPAV also assigns default group properties, such as
color and name. Each contour inherits the properties of its assigned group.
At any time, you can change the properties of a group or its members
(contours).
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To change the group with which a contour is
affiliated

1 Right-click the contour you wish to modify.
2 Select Properties. The VOI Statistics dialog box opens. See Figure 36.

The name of the VOI appears in the Name of VOI text box. A colored box
appears beside the text box.

To change group properties

1 Select the colored box on the VOI Statistics dialog box. The Pick VOI
Color dialog box opens.

2 Click OK to apply the color to the grid/border. The Pick VOI color dialog
box closes.

3 Click OK.

e To change the name of the VOI, modify the name in the text box next
to the Name of VOI colored box.

¢ To adjust the opacity, move the slider in the Opacity panel. The
number in the center indicates the current value; 0 is transparent
and 1 is opaque.

SPLITTING VOI CONTOURS

A VOI can be divided into two or more contours using the Split VOI Contour
icon. Any contour that is initially drawn or generated can be spitted into two
contours using that tool. For result VOIs, MIPAV assigns default VOI
properties, such as color and name. By default, the result VOIs have the
following names: firstVOI and secondVOI.

Each result contour inherits the properties of its parent VOI. However, at
any time, you can change the properties of result contours using the
standard MIPAYV tools (see “Contouring structures manually” ).

To split a VOI
1 Select the VOI.

2 Click the Split VOI Contour icon on the VOI toolbar, the mouse cursor

3 ”»

changes to “+”.
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3 In the image, use the mouse to draw the line splitting the VOI into two.

4 In the Split VOI dialog box that appears, specify if you want to split the
VOI in all slices or only in the active slice. Press Split.

The result VOIs appears in the image, see Figure 177.

Figure 177. Splitting a VOI: (a) the initial VOI and (b) the two result
contours

ORDERING CONTOURS

If two or more contours overlap, MIPAV organizes them so that they appear
one on top of the other, much like a stack of papers on a desk. This is often
not readily apparent because, by default, when contours are drawn, they are
transparent and only the outlines are visible. Thus, if two contours overlap,
all parts of each contour, except the areas where the outlines overlap, can be
seen.

To fill contours
1 Right-click the contour.
2 Select Properties. The VOI Statistics dialog box opens. See also
Figure 196 on page 361.
3 Clear the Boundary or Blended check box to remove the check mark,
then click Apply.

4 Close the VOI Statistics dialog box. The contour is filled with the default
paint color. To change the paint color, refer to “Manually creating a
mask using paint” on page 332.
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To arrange contours

1 Click the contour to be reordered. See Figure 178.

2 Select the Contour Order context menu. Then select one of the following
commands:

e Bring to Front: Moves the contour in front of all of the other
contours.

e Send to Back: Moves the contour behind all other contours.

e Bring Forward: Moves the contour forward one position. For
example, if you select this command and the contour is the third
contour in a stack of five contours, the contour is moved to the
second position in the stack.

e Send Backward: Moves the contour backward one position. For
example, if the contour is the third contour in a stack of five
contours, the contour is moved to the fourth position in the stack.

The software reorders the contours according to the command.

lzj genormcorp2_cor_256x256132 13/31 M:2.0

Bring Contour to Front

Send Contour to Back

Bring Contour Forward

Send Contour Backward

Figure 178. Arranging the VOIs
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SMOOTH VOI

To smooth a VOI, select it first, and then call VOI > Smooth VOI. The
Smooth VOI dialog box opens. This dialog sets the parameters and then
calls the algorithm for smoothing the VOI. In the dialog box, you can specify
the following;:

e Whether or not to remove the original selected VOI,;
e Whether or not to apply trimming to remove nearly collinear points;

¢ A number of interpolation points.

In 2D images all selected curves of a selected VOI are smoothed. In 3D
images all selected curves in all slices of a selected VOI are smoothed. The
original Z-slice information is only used so that the default number of
interpolated points comes from a contour in a Z-slice.

If the original VOI was not removed, the new VOI has a new color. If the
original VOI was removed, the new VOI has the same color as the original
VOI had.

Replace Original If selected, this option allows a new 5
ne
Contour smoothed VOI to replace the original )
VOL. YOI Options
[ ] Beplace Original Contour
Trim Collinear If selected, it allows to trim points that [] Trira Collinear points

Points

are adjacent.

Algorithm parameters
Number of Enter the number of interpolation points Hucber of ntexpolation points 35 |
Interpolation that will used to calculate a new
Points smoothed VOI. LS H e H il ‘

OK Applies the parameters that you specified.

Close Disregards any changes that you made in this dialog box and closes the
dialog box.

Help Displays online help for this dialog box.

Figure 179. Smooth VOI dialog box
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ALLow VOI HOLES (XOR)

This option (if turned on) allows to preserve holes in VOIs when converting
them to masks (see “Converting VOI contours to masks”), see Figure 180.

DA MIPAY: 20072_6 5/10 M:2.0
File |¥OI | LUT  Algorithms  Utilities  Plugins  Serips  Image  Toolbars  Help

k| Newvor DAUOR|E QEllY s re oy D@

VoI 3 = L = S — s

EE ﬁ. Open | 3 Xiz0072_61 5/10M:1.0 M=l E3 Xjz0072_61 5/10M:1.0 !EIB{ ,!] ,! | Ly | H | . |
Save VOI »

Script ract®

Edit YOI 3

N fe oog - [

& E Select VOI » 2 888 = .
S | VOI grouping 4
»

0 VOI order N
Contour order 13

Iernory usage: 610 [ 793M a':."_,
YOI conversion 3
Mask conversion 3
Paint conversion 3
@ Allow YOI holes (SOR)

Figure 180. The Allow VOI holes (XOR) option is turned on
The algorithm uses the XOR operation, for more information, refer to
“Morphology”.

Copying, cutting, and pasting VOIs
You can undo, cut, copy, and paste a VOI within the image, to another slice

in the image dataset, or to another image dataset.

To undo a VOI
1 Select the VOI.
2 Select Edit > Undo VOI in the MIPAV window. The software removes
the VOI from the image.

To cut a VOI
1 Select the VOI.

2 Select Edit > Cut VOI in the MIPAV window. The software copies the
VOI to the clipboard and deletes it from the window.
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Tip: You can also remove a VOI by pressing the Del key after selecting the
VOI.

To copy and paste a VOI
1 Select the VOI.
2 Select VOI> Edit VOI> Copy VOL. It is copied to the clipboard.
3 NOw, do one of the following:
e Navigate to another slice using the Image Slice Slider.
e Or open another image dataset.

4 Select VOI > Edit VOI > Paste VOI. The program copies the VOI from
the clipboard and pastes it into the image.

You can only copy and paste a single, not multiple, VOIs into another slice using
the Paste command. Also, note that the software pastes a copied VOI into the
image at exactly the place from which it was copied.

To propagate multiple VOIs to the next or previous
slice in the dataset

4 _ pPropagate Both Sides; ¥ — Propagate Left; % — Propagate Right;
1 Select all of the VOIs that you want to copy.
2 Do one of the following:
e Click the Propagate VOI up icon, to copy the VOI to the next slice.

e Click the Propagate VOI down icon, to copy the VOI to the previous
slice.

¢ Click the Propagate VOI to all slices icon, to copy it to every image in
the dataset.

Deleting VOIs

You can easily delete a VOI or one of its contours.

MIPAV User’s Guide, Volume 1, Basics 329
12/2/08



MIPAV User’s Guide, Volume 1, Basics

aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa

To delete a VOI
1 Select the VOI or one of its contours.

To delete a VOI that consists of many contours, hold down the Shift key
and then click one of the contours in the VOI group.

2 Do one of the following:
e Right-click on the VOI, and then select Edit > Delete.
e Select Edit > Delete VOI in the MIPAV window.

The software removes the VOI or contour.

Saving and opening VOI files

You can save a VOI to a text file. This file can then be opened and applied to
the same dataset or a different one, or it can be manipulated using a word
processor.

To save a single VOI as a text file

1 Select a contour or a VOI.
e To select a contour, click on it.

e To select a VOI, hold down the Shift key and select a contour. All
contours that are part of the VOI are selected.

2 Do either of the following:

e If you want the software to automatically name the file, select VOI >
Save VOI in the MIPAV window. The software saves the file with
an. XML extension.

¢ If you want to assign the file name, select VOI > Save VOI as. The Save
as dialog box appears.

a Type the name of the VOI file in the File Name box. Be sure to use
either the VOI extension or the XML extension.

b Click Save. The software saves the file under the specified name.

To save multiple VOIs
Do either of the following:
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¢ To allow the software to automatically name the file, select VOI > Save
All VOIs.

e To assign a file name to the file, select VOI > Save All VOIs as.

a Type the name of the VOI file in the File Name box. Be sure to use
either the VOI extension or the XML extension.

b Click Save. The software saves the file under the specified name.

To open saved VOI files

1 Select the image window of the dataset to which you want to apply the
VOL.

2 Select VOI > Open VOI in the MIPAV window. The Open dialog box
appears.

3 Select the file or files and then click Open. The VOI or VOIs appear in
the image window.

Note: If you make a change to the VOI and want to make a change to the file,
select VOI > Save VOI in the MIPAV window. The changes are saved to the VOI
file.

Generating masks

A mask is a filter that selectively includes or excludes certain values. You
can create a mask that includes the VOI areas and excludes all other areas.
Masks are particularly helpful if you use other applications to further
analyze images because those programs may require that you supply a
mask. An example of a mask appears in Figure 181.

You can create masks using a variety of methods:

Use paint tools to manually create a mask, refer to page 332

Use Paint Grow Segmentation tool, refer to page 344

Use binary or short mask utilities, refer to page 347

Use the Advanced Paint tool, refer to page 352

Use the Power Paint tool, refer to page 353
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MIPAV also provides algorithms that you can use to generate masks. These
algorithms are addressed in volume 2 of the User’s Guide.

ssh_3703_11 918 M:1.0 [ (5] [l 52sh_3703_11 9nsm1.0 [C)EK)

(A) A painted region on an image (B) The resulting mask

Figure 181. Image with (A) a painted region and (B) the resulting mask

Manually creating a mask using paint

You can manually create a mask using the tools on the Paint toolbar, which
is located in the MIPAV window. To create the mask, you first select the
intensity level of the paint, along with the paint color and opacity value.
Next, you paint on the image using the paint brush. You can adjust the size
of the paint brush tip. When complete, you then commit the paint by
choosing one of the following icons:

X _ Masks Inside the Painted Area
¥ _ Masks Outside the Painted Area
When you click one of these icons, it applies the intensity permanently to

the image. You can then choose to save the image.

If the Paint toolbar does not appear in the MIPAV window, select Toolbars.
The Toolbar menu lists four commands: VOI Toolbar, Paint Toolbar,
Scripting Toolbar, and Image Toolbar. If a toolbar command has a check
mark next to it, the toolbar is displayed; otherwise, it is hidden. To display
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the Paint toolbar, select Paint Toolbar. See also “MIPAYV toolbars” on
page 71.

MANUALLY GENERATING A MASK INCLUDES
THE FOLLOWING FOUR STEPS:

Step 1, Selecting the paint intensity level

Step 2, Selecting a paint color

Step 3, Adjusting the opacity level of the paint

Step 4, Applying the paint

STEP 1, SELECTING THE PAINT INTENSITY
LEVEL

The first step in manually creating a mask is to select the intensity level of
the masked area.You can select the intensity level by using the eyedropper

tool to select an intensity value that is already present in an image or by
typing a specific intensity value in the Desired Paint Intensity dialog box.

To select the intensity level using the Eyedropper
tool

Z _ Eyedropper

The allows you to copy an intensity level that is already present in the
image. To use this tool, complete the following steps:

1 Click the Eyedropper icon, on the paint toolbar in the MIPAV window.

2 Click the area of the image that has the intensity level you want to copy.
The intensity shown at the bottom of the MIPAV window changes to the
intensity level in the part of the image you've selected.
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Example: Initially, the intensity level button shows a zero on the button.
However, when you click an area of the image, it displays the number that is
associated with that part of the image, such as 250.

You can enter a specific intensity level value in the Desired Paint Intensity
window. To do this, complete the following steps:

1 Click the Intensity button.

Note: If you changed the intensity level using the eyedropper or this button
previously in your current MIPAV session, the number on the Intensity button
would have changed from 0 to the number representing that earlier intensity
level.

The Desired Paint Intensity dialog box opens.

2 Notice that the minimum and maximum intensity values appear in
parentheses. These values depend on the image type, or data type, of the
image.

Q,the

Tip: You can look at the exact intensity levels in the image using
Magnify region icon.

Intensity Specifies the intensity, or strength, of the paint.

_ _ _ . ¥4 Desired Paint Intensity FST|
Apply Applies the intensity that you specified to the

image. Intensity (-32762 - 32767): [

Cancel Disregards any changes that you made in this Apply H Cancel |
dialog box and closes the dialog box.

Help Displays online help for this dialog box.

Figure 182. Desired Paint Intensity dialog box
3 Type the desired level of intensity.

4 Click Apply to apply the intensity level to the paint. Note that the
number on the Intensity button changes to the number you entered.

5 Click & or Cancel to close the dialog box.
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STEP 2, SELECTING A PAINT COLOR

ﬂ — Change Paint Color

After you select the intensity level, the next step is selecting the paint color.
The program applies this color to the image so that you can easily see where
you applied the new intensity. When you commit the changes to the image,
the grayscale intensity level that you indicated in step 1 is permanently
applied to the image.

To select a color, use the Change Paint Color icon, to display the Pick Paint
Color dialog box (Figure 184). This dialog box includes three tabbed pages:
Swatches page, which is always displayed first; the HSB page; and the RGB
page. You can select a color on any of the pages.

To select a color from one of the 310 color swatches

1 Click the Change Paint Color icon. The Pick Paint Color dialog box
(Figure 183) opens.

2 Stay on the Swatches page, or, if you moved to HSB or RGB pages, click
Swatches to return to the Swatches page.

3 Click the desired color in the larger grid. The color appears in the Recent
color grid on the right.

4 Click Close when done. The Pick Paint Color dialog box closes. The color
you selected becomes the current paint color.

To select a color using the HSB model

1 Click the Change Paint Color icon. The Pick Paint Color dialog box
opens.

2 Click HSB. The HSB page appears (Figure 184B).

3 Specify a color by entering specific numbers for the hue, saturation, and
brightness values, or select the color from the color graphic.

¢ Enter specific values into the H, S, and B boxes:
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Type the hue value in H. The hue can be any number from o to
359. The numbers correspond to the degree numbers on the color
square (Figure 185). For example, to specify a shade of blue, enter
a number from 255 to 270. The slider automatically moves the
correct hue on the color strip.

Type the saturation value in S. The level of saturation can be
anywhere from o (gray) to 100 (full-strength hue). When you type
a value into this box, a circle appears in the color square around
the color with the specified saturation level. Colors to the left of
the color graphic are circled if the saturation level is high. Lower
saturated colors are found to the left of the color graphic.

Type the brightness value in B. The level of brightness can be
anywhere from o (dark) to 100 (light). In the color graphic, a
circle appears around the color with the specified brightness level.
Colors near the top of the color graphic are circled if the
saturation level is high. Darker colors are found near the bottom
of the color graphic.

¢ Select the hue, saturation, and brightness on the color square or

color strip:

Drag the slider to select the desired hue from the color strip.

Select the shade you wish to use in the color square.

4 Click Close when done. The Pick Paint Color dialog box closes. The color
you selected becomes the current paint color.
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PICK PAINT COLOR DIALOG BOX OPTIONS
Pick paint color g]
| Swatches | HSB | RGB | .
Color grid

Color grid Shows the available colors. Select one of these colors and it appears in the Recent grid
on the right.

Recent grid Indicates colors that you have recently selected from the color grid on the left. MIPAV
uses the last color that you selected from the color grid and that appears in this grid
as the color of the background in the lightbox view once you select OK.

OK Applies the parameters that you specified to crop the image.

Cancel Disregards any changes you made in this dialog box, closes the dialog box, and does
not crop the image.

Reset Returns the color settings to their previous values.

Help Displays online help for this dialog box.

Figure 183. Swatches page in the Pick Paint Color dialog box
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Pick paint color

Color square

|Color strip

| ok || cancel || Reset

Color square Specifies a specific color to be used as the background color.

Color strip Specifies a specific color to be used as the background color.

Specifies the number representing the hue of the color.

Specifies the number representing the saturation of the color.

Specifies the number representing the brightness of the color.

Specifies the number for the color used for the red channel.

Specifies the number for the color used for the green channel.

W o8 ®®0

Specifies the number for the color used for the blue channel.

OK Applies the parameters that you specified to crop the image.

Cancel Disregards any changes you made in this dialog box, closes the dialog box, and
does not crop the image.

Reset Returns the color settings to their previous values.

Help Displays online help for this dialog box.

Figure 184. The HSB page in the Pick Paint Color dialog box
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To select a color using the RGB model

1 Click the Change Paint Color icon. The Pick Paint Color dialog box
opens.

2 Click RGB. The RGB page (Figure 184C) appears.

3 Specify the numbers for the three components (red, green, and blue), or
use the sliders to select a color.

4 Click Close when done. The Pick Paint Color dialog box closes. The color
you selected becomes the current paint color.

Using the Hue, Saturation, and Brightness Color Model

The HSB color model defines colors by a
combination of their hue, saturation, and
brightness.

The hue is the wavelength of light transmitted
through or reflected from an object. The hue is
more commonly known as color (such as
magenta or green).

Below is the Munsell color wheel. A color strip,
which is derived from the color wheel, appears
as well. Hues are represented by the degrees in
the color wheel. (Since colors are graduated, the
degrees in the figure are approximations and not
necessarily absolute values.

For example, yellow is approximately 45
degrees; 50 degrees is a different shade of
yellow.

Primary colors (red, yellow, and blue) combine to
create secondary colors (magenta, cyan, and
green).Tertiary colors, such as orange, are also
represented on the color wheel.

The color strip is simply a different
representation of the color wheel. Degrees and
corresponding hues were added to the figure.

Saturation is the strength or purity of the hue. To
lessen the saturation, gray is added to the color.
Thus, if pure orange is 70 percent saturated, the
hue is a mixture of orange (70 percent) and gray
(30 percent).

Brightness is the relative darkness and lightness
of a color; 0% brightness is black; 100%
brightness is white.

Figure 185. Munsell color wheel (left) and color strip (right)
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Figure 185. Munsell color wheel (left) and color strip (right)
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MIPAYV
Pick border. color g|
{ Bwatches | HSB | RGB
Red : O| 56—
L1} 85 170 255
Green } D| 255',—j
a5 170 255
Blue i | 2552
L1} 85 170 255
| ok || cancel || Reset |
Red slider and Specifies the number representing the red channel. Either use the slider, or select
list box the number in the list box.
Green slider Specifies the number representing the green channel. Either use the slider, or
and list box select the number in the list box.
Blue slider Specifies the number representing the blue channel. Either use the slider, or select
and list box the number in the list box.
OK Applies the parameters that you specified to crop the image.
Cancel Disregards any changes you made in this dialog box, closes the dialog box, and
does not crop the image.
Reset Returns the color settings to their previous values.
Help Displays online help for this dialog box.

Figure 186. RGB page in the Pick Paint Color dialog box

STEP 3, ADJUST THE OPACITY LEVEL OF THE
PAINT

You can further refine the appearance of the paint selecting its opacity level.
Opacity levels can range from 0.0 (transparent) to 1.0 (opaque).
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To change the opacity level
F_ Change Opacity of Paint

1 Click the Change Opacity of Paint icon on the Paint toolbar. The Paint
Opacity window appears (Figure 187).

2 Drag the slider to the desired level of opacity. The current level appears
in the bold print underneath the slider.

3 Click Close to apply the opacity level. The opacity level on the image
changes according to your specifications.

Opacity Specifies the degree of
transparency. To make the 5% Paint Opacity
color more transparent,
move the slider to left. To
make it more opaque, move
the slider to the right.
Close Closes this dialog box.
Figure 187. Paint Opacity dialog box
STEP 4, APPLY PAINT
Having selected the intensity level, paint color, and opacity level, you are
now ready to paint on the image with the paintbrush.
¢ _ Draw Using a Brush
To paint on the image

(/@ ze o DD 6| Y HEOFO 2R

1 Click the Draw Using a Brush icon, on the Paint toolbar in the MIPAV
window.

2 Specify the size of the paintbrush tip.

3 Click and drag the mouse button to paint on the drawing. You can select
one pixel at a time, or drag the mouse button to draw paint strokes on
the image.
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MIPAY
Tip: You may need to use the magnification buttons to adjust the
magnification level of the image.
If you make a mistake, you can erase or undo the painted area.
To erase paint from a specific area
¢ — Erases Paint
1 Click the Erase icon.
2 Select the size of the eraser tip.
3 Use the mouse to begin erasing. You can select one pixel at a time, or
you can drag the mouse.
Tip: When erasing the paint, it may be easier to magnify the size of the image
using the magnification icons.
To resume painting, click the Draw Using a Brush icon.
To erase all paint
O — Erase All Paint
% — Undo
1 Do one of the following as appropriate:
¢ Click the Erase all paint icon, which removes all paint from the
image.
¢ Click the Undo last region paint icon, which allows you to undo the
last paint stroke.
2 Click the Default Mode icon, when you have finished painting the image.
STEP 5, COMMIT
When you visualize a dataset in MIPAV, a composite of several layers
appears in the default image window. The image layer contains the original
image. The next two layers contain the results of applied utilities,
algorithms, and paint. The fourth layer contains VOI contour information.
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When you click the commit icons. e.g. the Masks Inside Painted Area icon or
Masks Outside Painted Area icon, the paint and utility/algorithm layers are
merged with the image layer and saved as a new file.

To commit changes, select one of the following commit icons:

¥ _ the Masks Inside Painted Area icon. This tool shows the image without
the area you painted (Figure 188-C).

¥ _ the Masks Outside Painted Area icon. This tool removes the painted
area from the image and shows only the removed area (Figure 188-B).

The software redraws the dataset with the intensity levels indicated on the
image. You may need to adjust the lookup table (LUT) to see the image more
clearly, as it has been dome for the image shown in Figure 188-C. Instructions
for adjusting the LUT appear in Chapter 5, “Visualizing Images.”

Ebrain 62/124 M:1.0 Ebrain 62/124 M:1.0 Ebrain 62/124 M:1.0

a b C

Figure 188. The painted region (a) and the mask produced using the Mask the Outside Painted
Area tool (b) and Mask the Inside Painted Area tool (c). Here, arrows point to the painted region.

Creating a mask using the Paint Grow Segmentation
method

You can create a mask using the paint grow segmentation method, which
uses voxel aggregation to group voxels into larger regions. You begin by
selecting a voxel to serve as the seed point, or starting point. The software
applies paint color to all voxels touching the seed point that fall within the
intensity range that you specify.
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Note: You cannot apply the paint grow segmentation method to RGB images.

TO CREATE A MASK USING THE PAINT GROW
TOOL

® _ Fill an Area with Desired Color

1 Click the Fill an Area with Desired Color icon. The Paint Grow dialog
box appears (Figure 189).

2 Select the seed point, which is used as a starting point for the paint grow
operation. To do this, move the pointer to the image. As you move the
cursor, the location and intensity of the voxel under the pointer tip
appears in the Cursor position and voxel intensity text box. Click the
voxel you want to designate as the seed point.

3 Adjust the delta values and parameters.

4 Click Apply when complete to begin the paint grow method. The Paint
Grow dialog box closes.

To correct the mask

If the results are not what you want, do the following:

1 Click the Paint Grow button. The Paint Grow dialog box appears.

2 Select the seed point, which is used as a starting point for the paint grow
operation. To do this, move the pointer to the image. As you move the
cursor, the location and intensity of the voxel under the pointer tip
appears in the Cursor position and voxel intensity text box. Click the
voxel you want to designate as the seed point.

3 Adjust the delta values and parameters.

4 Click Apply when complete to begin the paint grow method. The Paint
Grow dialog box closes.
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If the results are not what you want, do either of the
following:

¢ Click the Undo last region paint icon, and start again.
e Click the Erase icon, or click, the Erase all paint icon, to erase all

paint.

To commit the mask

Click one of the following commit buttons:

X _ the Masks Inside Painted Area icon.
»_ the Masks Outside Painted Area icon.

PAINT GROW DIALOG BOX OPTIONS

Cursor position

and voxel intensity intensity of the pixel under the mouse (St Bmeshold | Fuzey connectodness |

Indicates the coordinates and

pointer tip. This pixel is the seed
point.

Delta above

Once a seed point has been selected,

Cursor position and voxel intensity

Delta ahove selecied voxel intensity

selected voxel MIPAV uses this value to determine > oo |
intensity whether to fill adjacent voxels with 00 00 00
color. The voxels that are filled must Delta helow selected voxel intensity
have intensity levels that fall within (A oo |

the range of the seed point intensity
minus the lower delta value and the
upper delta value. For example, if
seed point has an intensity of 100.0,
and the Delta Above Selected Pixel
Intensity value is 10 and the Delta
Below Selected Pixel Intensity value
is 15, MIPAV color-fills adjacent
voxels whose intensities range from
85.0 to 110.0.

Delta below
selected voxel
intensity

Once a seed point is, MIPAV uses this
value to determine whether to fill
adjacent voxels with color. The voxels
that are filled must have intensity
levels that fall within the range of the
seed point intensity minus the lower

delta value and the upper delta value.

oo oo oo

Set maximum slider values

Parameters
Unrestricted size

Unrestricted distance

O
[] Wary deltas with region growth

Close ‘ ‘ Help

Figure 189. Paint Grow dialog box
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Parameters:
Unrestricted size
Maximum size

Unrestricted
distance

Maximum distance

Constrains the growth of the paint grow operation. Select the Unrestricted
size and Unrestricted distance check boxes to allow the paint grow
operation to be applied without restraint. If the Unrestricted size check box
is not selected, type the maximum size (in cubic meters) of the paint grow
region in the text box. If the Unrestricted distance check box is not
selected, type the maximum distance from the original seed point in the text
box.

Fuzzy connectedness

Fuzzy
connectedness

Check tis box to use the fuzzy connectedness coefficient instead of static
threshold. Here, Fuzzy connectedness represents the idea of connection or
“hanging-togetherness” of image elements in an object by assigning a
strength of connectedness to every possible path between every possible
pair of image elements.

A fuzzy connected object is defined with a fuzzy threshold or the strength of
connectedness.

Initial variance Uses the initial intensity values from
from selected VOI the selected region of interest (VOI). [hﬁc pweshold_|Fuzzy — 1l
Fuzzy conneciedness
Display fuzzy Displays the result image in a F:zzycmctemﬁ
image separate frame. [ e et GG
[[] Display fuzzy iraage
Fuzzy threshold

is a threshold on the strength of Fuzzy threshold
connectedness of image elements. :

0o 0.6 10

Close Closes this dialog box.

Cancel Disregards any changes that you
made in this dialog box and closes
the dialog box.

Help Displays online help for this dialog

box.

Close ‘ | Help

Figure 189. Paint Grow dialog box (continued)

EXAMPLES OF USING THE PAINT GROW TOOL

Here, is a step-by-step guide for selecting a region(s) of interest using the
Paint Grow tool options. In this example we will use an image of the human
eye and we will try to segment the blood vessels located on the retina.
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First, make sure to adjust the contrast of your image so that the different
tissues appear visually distinctive. For images with more than 8 bits per voxel
you may want to use the various LUT available in MIPAV.

To segment blood vessels using the static threshold

1

2

6

Open the Paint Grow dialog box.

Watch the paint region growing.

Use the mouse cursor to select the point on the image (on a blood vessel)
which has the desired intensity value.

Use the Change Paint Color option to select the color (other than red)
which will be used for painting.

On the Static Threshold tab, adjust the intensity thresholds so that the
tissue you want to preserve is highlighted.

Check the Unrestricted size and Unrestricted distance options. This will
allow the paint grow operation to be applied without restriction.

For example, when selecting the blood vessels, the image might look like the
panel A for grayscale images or panel B for images after applying Blue LUT
in the Figure 190 below.

A - the painted region
appears in red (which is
the default color)

Cuzsor position and vexel intensity

Delta shove selected voxel intensity
" [26.02
1] 1210 2420

Delta bebow selecied voxel indensity
2 e

= 5334 |

on 1210 2420
Set maximum slider vahees
Set 2430

Parameders

[#] Unzestricted size

(] Uneestricted distance

[ Vary deites with rgion: growth:

Clase

B - the painted region
appears in green, because
we selected it as a color
contrast to LUT colors

Figure 190. The Paint Grow tool was used to locate the blood vessels on the grayscale image (A)

first, and then on the same image after applying the Blue LUT (B).
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To segment blood vessels using the Fuzzy
Connectedness option

1

2

Open an image of interest.

You might consider to delineate a VOI on a region of the image which is
of your interest, first. This is optional.

Open the Paint Grow dialog box, and then open the Fuzzy
Connectedness tab.

Check the Fuzzy Connectedness check box to activate the tool.

Check the Initial variance from selected VOI box (optional).

4 Check the Display fuzzy image option to view the result in a new

frame.

Use the mouse cursor to select the point on the image (on a blood vessel)
which has the desired intensity value.

6 Adjust the Fuzzy thresholds so that the tissue you want to preserve is

highlighted.

7 Watch the paint region appeared in a new frame.

For example, when selecting the blood vessels, the image might look like the
panel A or panel B for images in the Figure 191 below.

& Paint Grow

Static threshold | Fuzzy conneciedness |

Fuzzy connectedmess
[¥] Puzzy comentedness
(1] Trdtzal variznice from selected WO
[¥] Display Puzzyr tmags
Fuzzy threshold

v
on 0.3 1
Clese:
a — the painted region b —-the painted region also C
appears in red appears in a new frame
Figure 191. The Fuzzy Connectedness option.
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Converting VOI contours to masks

You can convert a contoured VOI to a binary, short, or paint mask using the
options found in the VOI menu in the MIPAV window.

To convert a contoured VOI to a binary mask

In a binary mask, the value 1 is assigned to the area inside the VOI; 0 is
assigned to the area outside the VOI. Thus, typically, the area that
represents the VOI is white, while the area outside the VOI is black.

1 Select VOI > Mask > VOI(s) to Binary Mask. The binary mask
appears in a separate image window.

2 Save the image (optional).

To convert a contoured VOI to a short mask

In a short mask, the values 1 to 65,535 are assigned to the area inside the
VOI; o is assigned to the area outside the VOI. Thus, typically, the area that
represents the VOI is several shades of gray and the area outside is black.

1 Select VOI > Mask > VOI(s) to short mask option. The short mask
appears in a separate image window.

2 Save the image (optional).

To convert a contoured VOI to a paint mask

1 Contour the VOI. For instructions on how to contour VOIs, refer to
“Using contours to segment a VOI” on page 308.

2 Select the color, opacity, and intensity level of the paint.

3 Select VOI > Mask > VOI(s) to Paint Mask. The contours are filled
with the default paint color.

4 Delete the contours by right-clicking the VOI and selecting Edit >
Delete.

5 Save the image (optional).

MIPAV User’s Guide, Volume 1, Basics 350
12/2/08



MIPAV User’s Guide, Volume 1, Basics

aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa

Converting masks to VOI contours and paints

To convert a mask to an image with VOIs

1 Create a paint mask. For information on how to do this, refer to
“Generating masks” on page 331.

2 Select the VOI > Mask conversion > Mask-> VOI.

Contours replace the painted areas.

To convert a mask to an image with paint(s)

1 Open an image of interest.

2 Create a mask. For information on how to do this, refer to “Generating
masks” on page 331. Alternatively, you can load the previously saved
mask into the image frame using the File > Load image B > From frame
menu.

3 Select the VOI > Mask conversion > Mask-> Paint.

Paints replace the masked areas.

b

Figure 192. Converting a VOI to, a mask and then to a paint: (a) -the
initial VOI, (b) - the mask created from the VOI, and (c) - the paint
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Advanced Paint and Power Paint tools

Paint masks are a way of marking specific parts of an image. For example, a
mask could define the specific region in a patient brain scan or location of
kidney in a healthy adult. Masks could have multiple uses: for work with
neurological patients, masks can help map the location and extent of an
injury or some abnormality; in addition, masks can be used to understand
the role of a specific area of the healthy brain when applied to functional
brain images (e.g. fMRI). In MIPAV, masks are created by mapping the
regions on each 2D slice of a 3D volume using a brush tool. This section
describes how a user can map 2D and 3D regions of interest or create paint
masks in a few simple steps using the Advanced Paint and Power Paint
tools.

@ —Load Advanced Paint Tools

¥ _Load Power Paint Tools

Advanced paint

This tool has been designed to provide labeled masks to associate with
structures to delineate, and to perform as seamless as possible the switch
between paint and masks.
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Power Paint tool

The Power Paint tool has three options

¢ Object processing, to delete entire regions of paint, and fill any hole (in
2D or 3D images, with any specified connectivity)

e Morphology, to erode or dilate the paint mask (in 3D, 2.5D, and 2D
images)

e Import/Export, to quickly transform paint to VOIs or masks

The Power Paint tool works either on the original image or its triplanar
viewer.

TO RUN THE ADVANCED PAINT TOOL,

1

2

3
4
5

9

Open an image of interest.

Go to the image slice that you want to edit.

On the Paint toolbar, click the Load Advanced Paint Tools icon;
This opens the Multiple Paint Tools dialog box.

Here, use the dialog box options to create a one or multiple paint masks
(paints). For dialog box options, refer to Figure 193 on page 354.

Draw the paint mask by dragging the mouse cursor around the region of
interest.

If you make a mistake, press the Erase Paint from Current Frame icon
located on the Paint toolbar. This will erase your mask from the current
slice only.

Repeat steps 5—7 until you have drawn the mask on the region of
interest on all of the slices.

Choose Save masks.

10 Open the next image you wish to view. Repeat until you have collected

region of interest information for all of the images you want to process.
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MIPAYV
MULTIPLE PAINT TOOLS DIALOG BOX
OPTIONS
Paint mask palette Advanced Paint uses a color palette 57 -
that contains a limited number of AT
colors and each color is described | - . "
explicitly in the palette. The palette P P - .
colors themselves are the same as 5 1 1 12
MIPAV uses for stripped LUT. By 13 1 15 16
default, a value from 1 to 24 assigned i3 i 2 £
to each palette button identifies il Z 2 2
which of the colors in the palette to Options
use. When you click any Paint Mask Murberofrasks: |4 |6 | Resize
Palette button, e.g. the button 1, Load lahels Save lahels
both - the button and the paint brush T SO——
- appear highlighted with the color N— —
assigned to that button. This might - Em i
remind you of painting by numbers. AT ek
Shoer label text Use shortouts
Options Collapse masks/paint Autosave mask
Number of masks By default, the Paint Mask Palette | :
shows 24 buttons which represent 24 L H R
predefined colors (from 1 to 24). And
these 24 colors can be applied to 24
masks.
You can change the number of displayed colors by changing the size of the
color button. In order to do that, simply enter desired numbers in the
Number of Masks control, and then press Resize. For example,
Options
smbeotrte b Ty will display 4*6=24 palette buttons
Options
udmetnas Dk kil il display 4*8=32 palette buttons
Changing a mask You can change the number assigned
number to the palette button or the mask B e
number by right clicking on the R o -
palette button. This opens the s s 7 s
Change Mask Number dialog box. In s 1 u 1
the dialog box, enter the mask 1 4 1 18
number which you would like to L 18 L 2
assign to the mask, and then press £ = = 2
Change. The mask with the new 2 change Mask Number [X]
number appears in the same place on Changs Mask Nuber from 2to < ||

the Paint Mask Palette.

Figure 193. The Multiple Paint dialog box options
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Show Label text

Expands the dialog box so that it
shows paint colors and corresponding Options
labels. Himber of masks: [+ 6 | Resize
Load labels Sawe lahels
You can edit the label text (by Lot masks ——
default, all labels are marked as Import from YOLs Exgort o YOls
“Label n” where n is a number of a i ped kil
. Show label text Clollapse masks/paint
color) and also select which labels to o
e hatheys

save.

Label List Use to lock the paint
And you can also lock the paint, so (] e L)
that it cannot be overwritten by the e L &
Paint to Mask operation. e U]

Save masks

This option allows to save a paint mask(s) to a file. It is useful to give the
paint mask the name that is similar to the image file name (e.g. if the image
file is x.img, then choose for the mask the name like x*.xml).

Load masks

Loads the saved mask(s) from a file.

Import from VOIs

Creates mask(s) from VOI(s) delineated on the image.

Export to VOIs

Exports mask(s) to VOI.

Hide paint

Hides the current paint.

Hide masks

Hides masks.

Collapse mask/
paint

This button allows you to quickly change a mask to a paint and vise versa.

Use shortcuts

This option activates hot keys which you can use to quickly access the dialog
box options. The hot keys are as follows:

e Numbers from 1 to 9 can be used to switch between the first 9 paint
masks

e Use t to show the label text

e Use c to show or hide the current paint

e Use v to hide or display mask(s) painted on the image

e Use s to save the mask(s)

Autosave mask

If activated, this option automatically saves (every 5 minutes) an active paint
in the file named active_mask_autosave.xml; this file is stored in the
image catalogue. It also saves all paints (masks) that you painted on the
image in the multipaint_mask_autosave.xml file; this file is also stored in
in the image catalogue.This allows you to preserve all paints and masks that
you put onto the image.

Note that a paint become a mask automatically as soon as you choose
another paint color in the Palette.

Close

Closes the dialog box.

Figure 193. The Multiple Paint dialog box options (continued)
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Help Displays the help for the dialog box.

Figure 193. The Multiple Paint dialog box options (continued)

Tip: You can paint over any pre-existing mask without changing the base
mask if you choose another color number on the palette, and save it as a
separate mask.

TO RUN THE POWER PAINT TOOL,

1 Open an image of interest.

2 For 3D images, use the Image Slice Slider to display the slice that you
want to edit.

3 On the Paint toolbar, click the Load Power Paint Tools icon.
4 This opens the Paint Power Tools dialog box.

5 Draw the paint mask by dragging the mouse cursor around the region of
interest.

6 If you make a mistake, press the Erase Paint from Current Frame icon
located on the Paint toolbar; or use the Erosion button. This will erase
your mask from the current slice only.

7 Complete the Paint Power Tools dialog box options.
8 Repeat steps 5—7 until you have drawn all the masks that you need;
9 Choose Save masks.

10 Open the next image you wish to view. Repeat until you have collected
region of interest information for all of the images you want to process.

PAINT POWER TOOLS DIALOG BOX OPTIONS

Object processing

Figure 194. The Paint Power Tools dialog box
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The object processing can be done for 2D and 3D images. To specify the type of the image, use the
corresponding radio button.

Grow Region option can be used to grow paint inside a region of interest (e.g., VOI) of a mask. This tool
works similar to the usual region growing tool, but it uses only one intensity value and the specified
connectivity.

Fill Background - allows to fill the background.

Fill All Background -TBD. Ohjesibocessing
2D 3D
Remove object - removes a selected object. | Grow Region |® o
Remove All Objects — removes a selected object. | Fill Background | O ®
Connectivity - TBD. | Fill A1l Background | o ®
Threshold specifies the upper and lover threshold for the image | RemeObet O ®
intensities to paint on. By default, you can paint everywhere, | Rexacve Al Objects | o ®
but if you move the sliders further in, you can see that any new . =
paint you add will not affect the lowest or highest image '
intensities. ] Threshold
Morphology Morphology operations include ero- -
sion and dilation. Dilation causes
objects to dilate or grow in size; ero- Morphology
sion causes objects to shrink. The | e ||3D |-|
amount and the way that they grow | e ||3D |v|
or shrink depend upon the choice of o
the structuring element (ball, dia- Element: =
mond, or cube) which you can select Seale (zare) 50
from the Element list box. You must | F—
also specify the dimensionality of the - .
morphological operation - 3D, 2D or -
2.5D. [v] Auto save : u
Import / Export
Erosion and 3D, 2.5D, 2D, triplanar, 25D(XY), Paint to VOI YOI to Paint
dilation options gbs(?(%Z), 2.5D(YZ),2D(XY), 2D(XZ), S S ———
| s shortkeys
Element Choose among a ball, diamond, and
cube, ' '

Scale (mm)

TBD.

Undo last Undoes the last operation.
Misc. Auto Save - allows auto saving every specified time period.
Import/Export

Paint to VOI

Transforms a paint to a VOI.

VOI to Paint

Transforms a VOI to paint.

Figure 194. The Paint Power Tools dialog box (continued)
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MIPAYV

Paint to Mask transforms a paint to mask

Mask to Paint transforms a mask back to paint

Use short-keys Allows using short-keys. The short-keys are g for grow, f for fill, r for

remove, d for dilate, and e for erode.

Figure 194. The Paint Power Tools dialog box (continued)
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