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Getting Started Quickly with

MIPAV
In this  section. . .

“Starting MIPAV” on page 59
“Managing memory resources” on page 60
“Opening and loading image files” on page 63
“Selecting views” on page 75
“Adjusting magnification” on page 78
“Improving contrast, adding color, etc.” on page 82
“Comparing images using alphablending” on page 90
“Creating new images” on page 91
“Delineating volumes of interest (VOIs)” on page 94
“Annotating images with text” on page 98
“Calculating VOI statistics” on page 100
“Modifying image resolutions” on page 109
“Generating graphs (intensity profiles)” on page 109
“Saving and printing images” on page 112
“Customizing MIPAV” on page 118
“Quitting MIPAV” on page 134

This chapter provides information to help you get started quickly using 
MIPAV. It explains basic tasks, such as starting and ending the program, 
opening and loading images, creating new images, and saving and printing 
images. In addition, it discusses how to create volumes of interest (VOIs), 
how to compare images using alphablending, and how to customize the 
program.
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Starting MIPAV

Starting MIPAV differs depending on your platform. To begin a MIPAV 
session, do the following:

Both the main Medical Image Processing, Analysis, & Visualization 
(MIPAV) window and the Output window (Figure 5) appear on your 
desktop. You can access most of MIPAV’s features from the main menu bar.

If your platform is . . . Then . . .

Windows 95, 98, 2000, 
NT, XP

Select Start > Programs > mipav > mipav.

Linux Open a shell. Go to the directory where you 
downloaded the installer. At the prompt, type 
sh ./installMIPAV.bin. 

Mac Operating System 
(OSX)

Unzip the installer (StuffIt expander may 
open automatically). Double-click the installer 
icon on your desktop.

Unix OS (Sun Solaris, 
OS/2 Warp, and others

In a shell tool, command tool, or terminal 
window, go to the directory where you 
installed MIPAV. At the prompt, type 
./mipav.

The Output window menu options

Figure 5.  MIPAV–Main and Output windows
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After starting MIPAV, you can open and load image files, create new 
images, access DICOM images, customize MIPAV, and end the session.

Managing memory resources

MIPAV requires at least 35 Mb of random access memory (RAM). 
Additional memory is needed to correctly display image files and to quantify 
the data. To determine the amount of additional memory needed, multiply 
the size of the image file that you want to display by 10. Thus, if an image file 
is 2 Mb, you must allocate an additional 20 Mb of RAM (in addition to the 
base of 35 Mb) for it to display correctly. Because memory requirements 

File Save Messages—Saves all of the messages displayed on the currently open 
page (e.g., Global Data page, Data page, or Debug page). When you select 
this command, the Save dialog box opens.

Add tab— Adds a new tab to the Output window. When you select this 
option, the Add Tab dialog box opens. In this dialog box, enter the name for 
the new tab and press OK.

Edit Clear messages—Clears all of the messages that are displayed on the 
currently open page. Be sure that you want to use this command. There is 
no undo!

Copy—Copies the selected text on the currently open page.

Cut—Removes the selected text from the currently open page.

Select All—Selects all of the text on the currently open page.

The Output window toolbar

Save Results Saves all of the messages displayed on the currently open page. When you 
select this command, the Save dialog box opens.

Copy Copies the selected text on the currently open page.

Paste Pastes copied text into the currently open page at the cursor point.

Cut Removes the selected text from the currently open page.

Remove selected 
tab

Removes selected tab from the output window.

The Output window default tabs

Data tab Displays messages that apply to the currently active image.

Debug tab Displays debugging information for the currently selected image.

Figure 5.  MIPAV–Main and Output windows (continued)
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fluctuate depending on the size and number of image files open, it may be 
necessary to allocate additional memory during a session. 

Allocating memory in MIPAV
When you run MIPAV for the first time you must specify the amount of 
memory that you would like to allocate, so that MIPAV can take the full 
advantage of the memory resources available in your machine.

1 Select Help > Memory allocation in the MIPAV window. The Change 
JavaRuntime Memory Allocation dialog box opens. See Figure 6.

2 Change the maximum heap size number so that it reflects the maximum 
amount of memory that should be allocated. 

In a Microsoft Windows system, you can specify a maximum to 1.2 or 1.3 Gb. If 
additional memory is needed, MIPAV allocates it until the memory reaches the 
maximum heap size that you specify.

3 Click OK to close the dialog box.

You must restart of MIPAV for the changes to take effect. To exit MIPAV, 
select File > Exit. Then, restart the software.

TO ALLOCATE ADDITIONAL MEMORY

The first step is to view how much memory is currently being used and to 
free needlessly reserved memory. Then, if necessary, you may need to 
allocate additional memory.

Figure 6.  Change Java-Runtime Memory Allocation dialog box 
MIPAV User’s Guide, Volume 1, Basics 61

12/2/08 



M   I   P   A   V
M e d i c a l   I m a g e   P r o c e s s i n g, A n a l y s i s,   &   V i s u a l i z a t i o n

MIPAV User’s Guide, Volume 1, Basics
To determine how much memory is currently being 
used by MIPAV

1 Select Help > Memory Usage in the MIPAV window. The Memory 
Monitor dialog box appears (Figure 7). 

When MIPAV performs a function, such as visualizing an image file, it 
uses memory. When the function completes (i.e., the visualized image 
closed), you can manually free the memory so it can be used for another 
function.

The Memory Monitor dialog box shows how much memory is allocated 
and how much memory has been used. The vertical bar on the right of 
the window displays a pictorial representation of the ratio of allocated 
memory or amount of memory used. The chart shows the memory usage 
for the past 3 minutes and 45 seconds. The chart is updated every 
second.

If you want to constantly monitor your memory resources, you can leave 
the Memory Monitor dialog box open on your desktop. Otherwise, close 
it. 

2 Click Free memory to free memory.

If you need more memory, you can allocate virtual memory or disk swap 
space if there is free space on your hard drive. For instructions on how to do 
this, refer to the documentation for your system. If you cannot assign more 
virtual memory or disk swap space, you may need to install additional 
memory.

To manually free the memory

As Java-based programs run, they often leave old variables, objects, or con-
structors in memory. For instance, if you delineate a VOI, the coordinates of 

Figure 7.  Memory Monitor dialog box
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the contours may remain in memory even after you close the image. Java 
provides a method called the garbage collector (or memory recycling) that 
automatically freeing objects that are no longer referenced by the program 
and clears all unnecessarily reserved memory. Generally, the software does 
this automatically when free memory becomes very limited. However, you 
can run the garbage collector at any time to free memory by clicking the 
Memory Usage button. Refer to Figure 8.

To allocate additional memory, 

Repeat the steps described in “Allocating memory in MIPAV” on page 61.

Opening and loading image files

MIPAV displays images in windows, or frames, that you can move or 
arrange around the desktop (Figure 9). You can display as many image 
datasets as needed as long as your computer has enough allocated memory.

Note: The amount of memory required depends on the number of image 
datasets that are open and the size of each image file. For more information, 
refer to “Managing memory resources” on page 60.

You can either open or load an image file. When you open an image file, 
MIPAV displays the image in a new image window. Loading an image file 
imports the file into an image window in which another image file is open. 
In other words, two image files share a common image window.

Figure 8.  Running the garbage collector to free the memory in MIPAV
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UNDERSTANDING IMAGE WINDOWS

An image window (Figure 9) consists of a title bar and an image itself. 

You can move an image window around your desktop by clicking the title 
bar and dragging the window to a new location.

Sometimes, depending on the view, a toolbar or menu bar also appears in 
the image window. For example, the image window using the light box view 
contains a toolbar and menu bar. See also “Displaying images using the 
lightbox view” on page 76.

IMAGE A AND IMAGE B

In MIPAV, the first image opened in an image window (see “Understanding 
image windows” ) is referred to as Image A. When you load, or import, a 
second image in the same window, MIPAV refers to the second image as 
Image B. 

The title bar displays:

• the image file name, e.g. “3DHead”;

• the number of the current slice and 
the total number of slices in the dataset, 
e.g. 62/124;

• the magnification level, e.g. M:1.0.

The number of the current slice is also 
shown in the lower left corner of the 
image.

Figure 9.  An image window
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Supported formats
You can use MIPAV to open or load files of a variety of medical and generic 
graphics and multimedia file formats. Table 1 lists the format, extension, 
and whether MIPAV can read or write files of a particular format. The 
extension, which is the last few characters of a file name including the 
period, indicates the file format. For example, in the file name DOE255.ima, 
the extension .ima indicates that the file is stored in DICOM format. In the 
table, the Read column indicates that MIPAV can display image files of a 
particular format. When a file is read, it is stored in main memory so that 
MIPAV can access it. The Write column means that MIPAV can copy the 
data from the memory to a storage destination, such as your hard disk. In 
this context, write is synonymous with save. 

For more information on file formats, the list  of supported formats and other 
information, refer to Appendix C: “Supported formats” Table 1 on page 628.
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IMAGE BROWSER

Opening image files
The Open Image A from disk menu allows you to open an image which 
is stored on your hard drive (or network drive).

You can select the image formats 
to display using the File > Open 
Image(A) > Image Browser menu. 
This opens the Choose Image 
Filter dialog box. In this dialog 
box, use the check boxes to select 
the image types which you would 
like to use in MIPAV.

Select All Selects all 
image types.

Clear Removes selection.

OK Applies the image type selection to MIPAV.

Cancel Disregards any changes you made in this dialog 
box and closes the dialog box.

Figure 10.  Choose Image Filter dialog box
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The Open Image A menu (Figure 11) provides you with additional options 
such as to open a single image file, or image sequence, or Leica series 
images – the images that were taken on a Leica microscope. You can also 
call Create Blank Image to create a blank image (refer to “Creating new 
images” on page 91).

To open an image file or multifiles 

An option on the Open Image dialog box (Figure 11), which appears after 
you select File > Open Image(A), is Open as multifile. This option lets 
you open the image as a multifile. 

Multifiles are image datasets that are composed of multiple files.

1 Select File > Open Image(A) from disk. The Open Image dialog box 
(Figure 12) opens.

2 Navigate to the directory where the file is stored. 

3 Select an image file.

4 To open the image file as a multifile, select the Open as multifile box.

The name of the image appears in File Name.

Figure 11.  FIle > Open menu 
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If you can’t find the image, 

check the files types listed in Files of Type (showing in Figure 12) near the 
bottom of the dialog box. If the file type you are looking for does not appear 
in Files of Type, select All Files or All.

To form a 4D dataset in Analyze format, 

use Open as multifile to open a series of individual 3D Analyze, 
formatted, consecutively ordered images.For example, you can use Open as 
multifile to open an array of TIFF,  JPEG,  BMP, etc., files if their file names 
meet the following format: foo_001.tiff, foo_002.tiff, foo_003, etc. where 
foo is the name of the file.

MIPAV window
After the first image is opened, the MIPAV window changes. It includes 
more menus, the title bar displays more information, and tool bars appear. 
Because the MIPAV window is context sensitive, it displays or hides 
commands on the menus depending on the characteristics of the image file 
that is opened. If you opened a dataset file that contains more than one 
image, an image slice slider also appears. Refer to Figure 13.

Figure 12.  Open as Multifile option
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If you prefer for MIPAV to use the style of Open and Save dialog boxes that 
are used by the operating system (e.g., Microsoft Windows, Unix, or Apple) 
on your computer, read the section on “Using platform-specific Open and 
Save dialog boxes” on page 124.

Loading image files
When you load an image file, MIPAV imports it into an existing image 
window. The loaded image shares the same window with another image file. 
Loading a file allows you to compare two datasets. 

To load an image file

1 Open the first image by selecting File > Open Image(A) from disk. The 
image appears in an image window. 

2 Select the title bar of the image window (in this case, the image that you 
just opened) in which you want to load another image. 

3 Select one of the following: 

• File > Load Image (B) > From Frame to load another image 
dataset from an already opened image dataset;

• File > Load Image (B) > From File to load another image 
dataset;

Figure 13.  Expanded MIPAV window showing toolbars, image slider, and more menus after the 
first image is opened. See also “MIPAV toolbars” on page 71 
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• File > Load Image (B) > Create a Blank Image to create a 
blank image.

4 If you chose Image (B) from File, the Open dialog box appears, see 
Figure 12. Select the image file you want to load, and click OK.

If MIPAV does not recognize the type of file based on its extension, the 
Choose Image Filter dialog box opens (see also “Image Browser” on 
page 66). Here, select the file type and click OK.

As the image file is loading, a pop-up window appears with the status. 
When the image file finishes loading, it appears in the image window. At 
this point, take note of several changes:

• MIPAV pseudo-color was applied to the images in the image frame. 
The pseudo-color indicates that two images are loaded in the same 
image frame.

• In the MIPAV window, the Active Image and Alphablending slider 
appears. The slider allows you to control which image is displayed in 
the foreground of the window. The image in the foreground is the 
active image. You can adjust the translucency of the alpha channels 
in each image using the technique.

5 If you chose Image (B) from Frame, the Load Image onto <file name> 
(Figure 14) opens. Select one of the images in Set as Image (B), and then 
click OK. The image is loaded onto the first image file.

Note: The abbreviations (A) or (B) appear after some commands. (A), which is 
the abbreviation for “Image A,” indicates that the option is applied to the first 
image opened in an image window. (B), which is the abbreviation for “Image B,” 
indicates that the option is applied to second image loaded in the image window. 
For example, if you select Close Image (B), MIPAV closes the second image 
(Image B) that was loaded in the image window.
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Note: MIPAV recognizes files types by the file extension. For example, if you 
select an image named “Smith.tiff”, MIPAV tries to open the file as a TIFF file. If 
that image is actually a JPEG file and mistakenly has the TIFF extension, MIPAV 
fails to open the file.

MIPAV toolbars

After you open an image in MIPAV and the MIPAV window expands to 
display all of its menus and toolbars, such as

• VOI toolbar. Volume of interest toolbar (Figure 15). The VOI toolbar 
contains tools that help you in selecting the specific area of interest on 
the image.

Figure 14.  After loading an Image B, the Active Image and 
Alphablending slider appears in the main MIPAV window. The slider 
allows you to control which image is displayed in the foreground of the 
window
MIPAV User’s Guide, Volume 1, Basics 71

12/2/08 



M   I   P   A   V
M e d i c a l   I m a g e   P r o c e s s i n g, A n a l y s i s,   &   V i s u a l i z a t i o n

MIPAV User’s Guide, Volume 1, Basics
• Paint toolbar. The Paint toolbar (Figure 16) includes tools that allow 
you to add, adjust, or remove colors and color intensity, erase paint, 
and adjust the opacity level of the paint.

• Scripting toolbar. The Scripting toolbar allows you to locate and run 
previously recorded scripts, or macros, that contain two or more 
algorithms on images. See Figure 17.

• Image toolbar. The Image toolbar includes tools for opening, 
printing, saving, maximizing, and minimizing an image; converting an 
image from gray scale to color or from color to gray scale; and adding 
to and removing slices from an image or changing their order; and 
rotating, cropping, and flipping an image. See Figure 18.

By default, the MIPAV window displays only the VOI and Image toolbars. 

Icon Name Icon Name Icon Name

Default Mode Protractor tool Change VOI color

Annotation Tool Draw rectangle 
VOI

Undo

Draw a point VOI Draw polyline VOI Cut VOI

Draw inter-slice 
polyline

Levelset VOI Copy VOI

Draw line VOI Draw 3D 
rectangular VOI Paste contour

Propagate VOI 
down

Propagate both 
sides Propagate VOI up

Split VOI contour Live wire VOI   View VOI properties

Quick AND VOI 
mask operation

Quick NOT VOI 
operation

Figure 15.  VOI Toolbar

Icon Name Icon Name Icon Name

Add a blank mask Fill an area with 
color Paint brush editor

Open a mask from 
a file

Erase a paint Change paint color

Figure 16.  Paint Toolbar
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Save the current 
mask

Erase a paint from 
a current frame

Change opacity of 
the paint

AND mask 
operation Erase all paints

Display a border 
around painted 
areas

Draw using a 
brush

Propagate the 
paint to the 
previous slice

Masks the inside of 
the painted area

Load advanced 
brush tools

Propagate the 
paint both sides

Masks the outside 
of the painted area

Pick up a color 
from an image

Propagate the 
paint to the next 
slice

Undo

 

Calculate volume Load power paint 
tools

Figure 16.  Paint Toolbar

Icon Name Icon Name

Open the Scripts 
Home catalogue

Refresh the Scripts 
Home catalogue

Show the current 
script to run

Run the script from 
Current Scripts

Start recording the 
script

Figure 17.  Scripting Toolbar

Icon Name Icon Name Icon Name

Open image, 
CTRL+F

Adjust window and 
level

Decrement image 
slice

Save image, 
CTRL+S Quick LUT

Increment image 
slice

Print image Reset LUT Link images

Capture image to 
TIFF file Invert LUT Zoom in

View header, 
CTRL+H Gray LUT Zoom out

Edit attributes, 
CTRL+E Hot metal LUT Magnify region

Figure 18.  Image Toolbar
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Displaying MIPAV Toolbars
The Toolbars menu contains check boxes for each of the four toolbars: 
Image, Paint, Scripting, and VOI. Use these check boxes to select which 
toolbars should appear. See Figure 19.

By marking or clearing these check boxes, you can choose which toolbars to 
display and which to hide. For example, suppose you just started MIPAV a 
moment ago. You then open an image. The MIPAV window expands in size 
and displays its full complement of menus. Although it displays the VOI, 
Scripting, and Image toolbars, you want to work with the Paint toolbar as 
well as the Image toolbars. However, you don’t need to use the VOI and 
Scripting toolbars. The next section explains how to hide and show toolbars.

Display Lookup 
table

Open user-defined 
LUT

Window region of 
Image B

CT preset function Save LUT
Checker board

Magnify 1:1 Tri-planar view
Volume Tri-planar 
view

  Volume Renderer   GPU based volume     
renderer

  GPU rendering

View light box Flip horizontally Flip vertically

 Multi histogram   
rendering

Figure 18.  Image Toolbar (continued)

Figure 19.  Toolbars menu
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TO HIDE THE VOI AND SCRIPTING TOOLBARS 
AND DISPLAY THE PAINT TOOLBAR

1 Select Toolbars > VOI to hide the VOI toolbar. MIPAV removes the 
check mark from the check box and removes the VOI toolbar from the 
MIPAV window.

2 Select Toolbars > Scripting to hide the Scripting toolbar. MIPAV 
removes the check mark from the check box and removes the Scripting 
toolbar from the MIPAV window.

3 Select Toolbars > Paint to display the Paint toolbar. The program marks 
the check box and displays the Paint toolbar in the MIPAV window. 

Because the Image toolbar is already displayed, you do not need to do 
anything.

Selecting views

A view refers to the way an image file is displayed. A view indicates how 
many images are shown at one time and whether images are advanced 
manually or automatically. Depending on the view, the size and shape of the 
image window in which an image is displayed can vary. MIPAV allows you 
to display images using the following views: 

This section explains how to display image files in the default, lightbox, and 
cine view. To learn how to display image files in other views, refer to 
Chapter 6 in the MIPAV User’s Guide.

Icon View Icon View

Default Surface plotter

Animate Volume renderer

Cine (movie) Tri-planar

Lightbox Tri-planar dual

Link to another 
image

Volume Tri-planar 
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Displaying images using the default view
In the default view, MIPAV displays the images in a dataset one at a time in 
an image window (Figure 20). This window can display datasets of any 
dimension.

Displaying images using the lightbox view
The lightbox view is similar to the default view, except that all images in the 
dataset appear in one window at the same time (Figure 21).

To display images in the lightbox view

1 Open an image file. The image appears in an image window.

2 Select the image window. Do one of the following in the MIPAV window:

• Click the View Light Box icon;

• Select Image > Views > Light box.

The image now appears in a lightbox view.

3 Select Options > Settings in the lightbox view window to adjust the size 
and shape of the window. The Lightbox Settings dialog box (Figure 21) 
opens.

4 In the dialog box, indicate the number of rows and columns, the grid 
size, frame border size, color settings, and the magnification. For more 
information on these attributes, see the MIPAV User’s Guide, 
“Visualizing Images” , “Adjusting the lightbox view” .

Figure 20.  Images open in the default image windows 
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5 Click Close when complete. The image appears in the lightbox view, see 
Figure 21.

To magnify a portion of the image in the lightbox, 

click Magnify Region and move the pointer to the image section to be 
magnified. Click Default Mode when finished.

Double-clicking an image in the lightbox view updates the 2D image frame 
for that image.

Displaying images using the cine view
When you view an image file in cine view, MIPAV automatically advances 
images one frame at a time. The effect is much like a film loop. 

To display images in cine view

1 Open an image file. The image appears in the default image window.

2 Select Image > Views > Cine (Movie). The images in the image window 
are advanced automatically.

Figure 21.   An image shown in the lightbox view and the Lightbox 
Settings dialog box
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Adjusting magnification

MIPAV allows you to magnify images from ¼ to 32 times the size of the 
original image. Using the magnification tools, you can magnify or minify the 
entire image or just a portion of the image. Much like a traditional magnify-
ing glass, the magnification box can also minify—or reduce the level of mag-
nification—a portion of the image.

Changing the magnification level
This section explains how to change the magnification level of the image 
using the icons on the Image toolbar in the MIPAV window.

 To learn how to adjust the magnification level using the Image toolbar, 
refer to

• “Magnifying images” on page 78

• “Reducing the magnification level” on page 78

• “Restoring the original level of magnification” on page 79

• “Magnifying regions within images” on page 79

To learn how to set the magnification level using the other methods, see 
volume 1 of the MIPAV User’s Guide.

MAGNIFYING IMAGES

 To magnify an image, click the Magnify Image icon, and then click the 
image. Each time you click the Magnify Image icon and click the image, the 
image doubles in size. If an image is too large for the current window size, 
scroll bars appear, and you may need to manually adjust the size of the 
window.

REDUCING THE MAGNIFICATION LEVEL

 To reduce the magnification level of an image, click Minify Image. Each 
time you click the Minify Image icon, MIPAV reduces the magnification 
level of the image by half.
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RESTORING THE ORIGINAL LEVEL OF 
MAGNIFICATION

 To return the image to its original size or original level of magnification, 
click Original Magnification.

MAGNIFYING REGIONS WITHIN IMAGES

 The Magnify Region icon allows you to view a square portion, or region, 
of the image at a specific magnification level. If you have loaded two 
images into the same image window, the Window Region of Image B icon 
appears on the toolbar. Use this icon to view a region on the second image, 
or Image B.

To use the Magnify Region icon

1 Open an image.

2 Click Magnify Region and move it over the image. 

As you move the mouse over the image, the Magnify Region icon 
displays a magnified square region in the image in a red box. The 
number at the left corner of the square is the magnification level. See 
also Figure 23.

To change the size of the magnified region

You can change the size of the magnifying region to allow you to view larger 
or smaller regions of the image.

1 Right-click on the image while displaying a magnified region. The 
Magnification dialog box (Figure 22) opens.

2 Type either a higher number for a larger region or a lower number for a 
smaller region in the Width box. Valid values range from 64.0 to 198.0.

3 Click Apply. The size of the magnified region, or square, either increases 
or decreases in size.

Changing the magnification level of the magnified region works similarly to 
changing the size of the magnified region.
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Figure 22.  Magnification dialog box options

Tip: To review or compare a magnified region of the image with the same region 
at its original magnification, press Shift. To return to the Magnified view, release 
the key.

Magnification Move the Magnification 
slide to the right to 
increase the magnifica-
tion level or to the left 
to decrease the magnifi-
cation level

Display 
intensity 
values

When you slide the 
Magnification slider right 
past a certain point, this 
check box becomes 
active.

Size Type either a higher number for a larger region or a 
lower number for a smaller region in the Width box. 
Valid values range from 64.0 to 198.0.

Apply Applies the changes.

Close Closes the dialog box.

A–the magnified region 
size is set to 75; the 
magnification level 4 is 
shown in the magnified 
region.

B –the magnified region 
size is set to 130; the 
magnification level 4 is 
shown in the magnified 
region.

C– the magnified region 
size is set to 130; the 
magnification level 8 is 
shown in the magnified 
region.

Figure 23.  The larger size magnifying glass such as shown in B and C allows to inspect a larger 
region of the image 
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To change the magnification level

1 Right-click on the image while displaying a magnified region. The 
Magnification dialog box (Figure 22) opens.

2 Complete the dialog box, and then press Apply.

3 The magnification level shown in the magnified region changes to the 
level you specified.

SHOWING INTENSITY VALUES THROUGH THE 
MAGNIFICATION GLASS

The Display intensity values check box on the Magnification dialog box 
allows you to display the intensity values within a magnified region of the 
image. See Figure 22.

To show the intensity values

1 Right-click on the image while displaying a magnified region. The 
Magnification dialog box (Figure 22) appears.

2 Select the Display intensity values check box. 

If the check box is not available, or dimmed (as it is in Figure 22), 
increase the magnification by sliding the magnification slider to the 
right until the check box is active. See Figure 24.

3 Move the mouse over the image. The intensity values appear within the 
magnified region (Figure 24).

Figure 24.  An image window displaying intensity values for a magnified 
region in the image 
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Tip: If you hold down the middle mouse button, MIPAV writes the intensities 
by position within the image to the Data page of the Output window. You can 
then save these messages and print them.

Improving contrast, adding color, etc.

This section explains how to improve image contrast, add color to images, 
and create negative images by applying a quick lookup table (LUT), generat-
ing and modifying a histogram, applying pseudo-color LUTs, and creating 
negative images by inverting their color.

histogram— is a representation of a frequency distribution by means of 
rectangles whose widths represent class intervals and whose areas are 
proportional to the corresponding frequencies.

lookup table (LUT)— maps the frequency distribution in a histogram to 
pseudo-color values.

Improving contrast on images quickly
MIPAV provides the following quick ways to improve the contrast on 
images:

• Using the Quick LUT icon

• Using the right mouse button

• Using the Adjust Window and Level icon

USING THE QUICK LUT ICON

 An easy way to improve the contrast in an image is by using the Quick 
LUT icon, which is located on the image toolbar in the expanded MIPAV 
window. 
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To use the Quick LUT icon

1 Open an image file. The image appears in an image window. If an image 
was not previously open, the initial MIPAV window expands to include 
all of the menus.

2 Select the image window.

3 Click Quick LUT.

4 Hold down the left mouse key and draw a rectangle on a portion of the 
image.

5 Release the left mouse key. Based on the amount of dark and light in the 
portion of the image that you selected, MIPAV changes the contrast in 
the image.

Repeat steps 3 through 5 as often as you wish to further improve image 
contrast. When you are satisfied with the contrast, save the image.

USING THE RIGHT MOUSE BUTTON

The right mouse button provides you with a very simple way of changing 
image contrast. To do so, open an image and then hold down the right 
mouse button and drag it around the screen. The cursor changes from a red 
cross to one that is shown in Figure 26. To restore an image to its original 
appearance, refer to “Restoring images to their original appearance” on 
page 85.

Figure 25.  Images before and after applying the Quick LUT icon 
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 ADJUST WINDOW AND LEVEL 

 The Adjust Window and Level icon on the Image toolbar provides 
another way to change the contrast of images. 

To adjust image contrast

1  Open an image file. The image appears in an image window. 

2 Click Adjust Window and Level. The Level & Window dialog box 
appears.

Figure 26.  Changing image contrast 
using the right mouse button 

When you drag the cursor up and down or 
across the image, the image may become 
darker and gradually disappear or become 
lighter in appearance. 

At some points you may be able to create a 
negative of the image.

Figure 27.  The Level and 
Window dialog box

Move each slider up or down 
to change the contrast of 
the image. The changes are 
immediately effective in the 
image.
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3 In the dialog box, move each slider up or down to change the contrast of 
the image. The changes are immediately effective in the image. Click 
Close when done.

RESTORING IMAGES TO THEIR ORIGINAL 
APPEARANCE

 To return to the original appearance of the image, click Reset LUT. 

 In addition, you can click the Gray icon to restore the image to 
grayscale if you have changed it or added colors.

Improving contrast by generating and modifying 
histograms

 To generate a histogram of an image, you can use the Lookup Table icon 
or call LUT > Histogram LUT. To obtain a histogram summary, which is in 
the tabular form, use the Algorithms > Histogram Tools > Histogram 
Summary command.

To generate a histogram for an image

1 Open an image. The image appears in an image window.

2 Do either of the following: click Lookup Table icon or select LUT > 
Histogram–LUT. For images that do not contain VOIs, the Lookup 
Table window opens. 

3 For images that contain VOIs, the Histogram dialog box appears. In the 
dialog box, select either Whole image or VOI region(s).

4 Click OK. A progress message appears. After a few moments, the 
Lookup Table window (Figure 29) opens.
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Definition: Lookup table (LUT) indicates the intensity of each voxel in the 
image and, in MIPAV, allows you to remap the original intensities to other 
intensities.

transfer function reflects the relationship between the original image intensity 
values and how they are mapped into the LUT. The line in the LUT represents the 
transfer function.

 To change back to the original grayscale intensities, click Gray LUT in 
the MIPAV window.

A B

Figure 28.  The Lookup Table window (A) and Histogram dialog box (B)
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File Open LUT—Opens a previously 
saved LUT file. LUT files have an. 
LUT extension.

Save LUT—Saves the LUT 
displayed in this window in a LUT 
file.

Open user defined LUT— opens a 
file with the user defined LUT.

Save user defined LUT— saves a 
user defined LUT.

Open Transfer Functions—Opens 
a previously saved transfer 
function. Transfer function files 
have a .FUN extension.

Save Transfer Functions—Saves 
the transfer function displayed in 
this window to a file.

Close LUT—Closes the LUT 
window.

Utilities Change number of colors—Allows 
you to change the number of 
colors displayed in the image. 
Valid values are 2 to 256.

CT function—Allows you to select 
a preset LUT that is appropriate 
for the image content. Values are 
abdomen, head, lung, 
mediastinum, spine, and 
vertebrae.

Invert LUT—Creates a negative of the image.

Reset transfer function—resets the chosen LUT back to Gray LUT.

Reset histogram and LUT A—Returns image A to its original values.

Reset histogram and LUT B—Returns image B to its original values. This 
command is only available if two images are open.

LUT toolbar
 – Gray LUT;  – Red LUT;  – Green LUT; – Blue LUT;  – Cool-Hot 

LUT;  – Gray/Blue/Red LUT; – Hot Metal LUT; – Spectrum LUT; – Skin 

LUT; – Bone LUT; – Stripped LUT; – Invert LUT.

Figure 29.  Lookup Table dialog box
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Functions 
toolbar – Transfer function; – Reset Transfer function; – Even Distributed 

Transfer function; – Dual Trashed function; – Dual Inverse Trashed function; 

– CT preset function; – Edit Alpha function; – Edit Red LUT; – Edit 

Green function; – Edit Blue function; – Open user Defined LUT; – Save 

User Defined LUT; – Generate LUT.

Update (real-
time)

Changes the image as you make changes to the LUT, which allows you to see the 
effect of your changes immediately on the image.

Log scale 
(histogram)

Displays the image’s histogram count in log scale along the Y axis.

Interpolate 
image

Displays image using interpolation, which reduces pixilated image to appear more 
smooth.

Caution: Depending on the memory resources of your workstation, interpolation 
can be very lengthy.

0 to 1 LUT 
adjustment

Appears only for in the ImageB 
tab when two images are loaded 
in the same image frame.It 
processes the image for contrast 
as follows: for contrast <0, it uses 
a linear function to calculate the 
entire contrast look-up-table; for 
contrast 0, the contrast look-up-
table is an identity table, and for 
contrast greater than 0, a linear 
function is used to calculate the 
linear region and for regions near 
min and max, the nonlinear 
function y=xn is used. .

Number of 
colors

Allows you to change the number of colors displayed in the image. 

LUT Displays the image intensities.

Upper threshold

Lower threshold

Fill value

The threshold options is a tool for setting thresholds for a gray level of the image 
in order to segment the image into an object and a background. This tool does 
applys a pceudo color (spesified in the Fill Value parameter) to the image, to show 
the pixels selected by the threshold setting, that is, those pixels with values equal 
to and between the thresholds.

Figure 29.  Lookup Table dialog box (continued)
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Applying color to images using predefined LUTs
MIPAV provides a variety of pseudo-color LUTs. When a pseudo-color LUT 
is applied to an image, the grayscale intensities are remapped to the pseudo-
color intensity values. 

To apply a pseudo-color LUT

1 Open an image. 

2 Select the image window.

3 Click Displays Lookup Table icon to call the Lookup Table dialog box.

4 In the dialog box that appears, select one of the LUTs on the LUT 
toolbar.

5 Check the Update (real-time) box.
 

6  MIPAV immediately applies the LUT to the image.

 To change back to the original grayscale intensities, click Gray LUT in 
the MIPAV window.

Creating negatives of images

 The invert LUT icon creates a negative of an image. 

To create a negative image

1 Select the image window of the image you want to invert.

2 Click Invert LUT.

Based on the 256-step color values scale, MIPAV assigns the inverse value 
to each pixel of the image (refer to Figure 30). 

Using interpolation to smooth images
If you are zooming in on a portion of an image and want to reduce the 
appearance of pixilations in the image, make sure to select the Interpolate 
image check box. Interpolation smooths the pixilation. 
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Tips: You may wish to apply a LUT to the image or adjust the histogram of 
the image first before applying creating the negative.The Invert LUT icon is a 
toggle. To change the image back to its previous appearance, simply select 
Invert LUT again. To change the image back to its original appearance, select 
Reset LUT.

Note: Invert LUT appears on two different windows: in the Image toolbar in 
the MIPAV window (select Toolbars > Image toolbar to display the toolbar) 
and in the LUT toolbar in the Lookup Table window. 

Comparing images using alphablending

Alphablending is a technique that adds transparency information to 
translucent objects. When two images share the same window such as when 
you loading the image, you can adjust the alphablending settings so that 
you can see a blend of both images and can compare overlapping regions in 
two datasets. See also “Loading image files” on page 69.

To use the alphablending function

1 Open the first image, then load the second image in the same window.

2 Adjust the alphablending slider at the bottom of the MIPAV window.

3 Move the slider to select the best ratio for the datasets of interest. 

Figure 30.  Image before and after inversion
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The level of translucency for one image is inversely proportional to the 
other. Thus, if image A is 75 percent transparent (25 percent opaque), 
then image B is 75 percent opaque (25 percent transparent).

Creating new images

To create a new image file

1 Do one of the following: 

• If an image file is not already open, select File > Open Image(A) > 
Create Blank Image.

• If an image file is already open, select File > Load Image (B)> Create 
Blank Image. The Raw dialog box (Figure 32) appears.

2 In the dialog box, select the image type. 

3 Select the units of measure for each dimension. 

4 Enter the header offset and byte ordering information.

5 Click OK. A blank image (Figure 32) appears in an image window.

6 Use the paint and VOI tools to create an image.

7 Click File > Save image as. The Save dialog box opens.

Figure 31.  MIPAV window showing the alphablending slider at the bottom of the window
MIPAV User’s Guide, Volume 1, Basics 91

12/2/08 



M   I   P   A   V
M e d i c a l   I m a g e   P r o c e s s i n g, A n a l y s i s,   &   V i s u a l i z a t i o n

MIPAV User’s Guide, Volume 1, Basics
8 Type the name of the file in File Name, and select the file type in Files of 
type.

9 Click OK. MIPAV saves the image under the file type you selected.

Image type Synonymous with data type. The image type determines the number of intensities 
that can be represented in an image. For example, a Boolean image can display two 
intensities: 1 and 0. 

• Boolean—1 bit per pixel (1 on, 0 off)
• Unsigned byte—1 byte per pixel (0, 255)
• Unsigned short—2 bytes per pixel (0, 65535)
• Unsigned integer—4 bytes per pixel (0, 232 -1)
• Float—4 bytes per pixel (-3.4E38, 3.4E38)
• ARGB—3 bytes per pixel, plus 1 byte; 8 bits per color channel (alpha, red, green, 

and blue)
• Byte—1 byte per pixel (-128, 127)
• Short—2 bytes per pixel (-32768, 32767)
• Integer—4 bytes per pixel (-231, 231-1)
• Long—8 bytes per pixel (-9.22E18, 9.22E18)
• Double—8 bytes per pixel (-1.8E308, 1.8E308)
• ARGB U short—2 bytes per color channel and 2 bytes for alpha channel

Figure 32.  Raw dialog box
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Dimensions 
and 
resolutions

Degree of manifolding of a quantity such as space or time. Two-dimensional datasets 
are composed of one image (the two dimensions are length and width). Generally, 
three-dimensional datasets are composed of more than one image. The third 
dimension is generally space. The fourth dimension is generally time. (Either time or 
space can be the third or fourth dimensions.) Zeros in the text boxes indicate that 
the dimension is not represented in the image. For example, if the text boxes for the 
first and second dimensions are filled, and the rest of the text boxes are filled with a 
zero, the image only has two dimensions. 

Dimensions

• 1st—Width (along x axis)
• 2nd—Length (along y axis)
• 3rd—Depth (along z axis)
• 4th—Time (along t axis)
• 5th—Fifth dimension

Resolutions

Size of pixel or voxel per dimensions 1 through 5.

Units of 
measure

Indicates the unit of measurement for each of the applicable dimensions.

Header 
offset

Indicates the size of the space reserved at the beginning of the file where specific 
types of information is kept. This space, which is called the header, precedes the 
image data. If you know the length of the header, type it in this box. When MIPAV 
accesses the file, it skips the header offset and begins to read the image data. Note 
that not all image file formats have a header.

Big endian Indicates whether image data is stored in the big endian format. If not, the image 
data is stored in the little endian format. Endianess refers to the byte ordering of the 
data. Some computers order the data with the least significant byte (LSB) first 
followed by the most significant byte (MSB). This byte order is referred as little 
endian or Intel byte ordering. Machines that use little-endian byte ordering are 
VAXes, Intel x86, and Pentium. The reverse is MSB and then LSB, which is referred 
as big endian or Motorola byte ordering. Machines that use big-endian byte ordering 
are IBM System 3D, RISC, and a Motorola 680x0. MIPAV is biendian; it supports both 
big- and little-endian byte-ordering formats.

OK Applies the parameters that you specified and creates a blank image.

Cancel Disregards any changes you made in this dialog box, closes the dialog box, and does 
not create a blank image.

Help Displays online help for this dialog box.TBD.

Figure 32.  Raw dialog box
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Delineating volumes of interest (VOIs) 

MIPAV provides tools that allow you to automatically, semiautomatically, 
and manually identify and modify volumes of interest (VOIs). 

volume of interest—the portion of the image in the dataset on which you want 
to focus. It may be either one slice or multiple slices throughout the dataset.

Each VOI can be formed from multiple contours in a single slice or multiple 
slices. Once an object is segmented and defined by a VOI, statistics of the 
volume can be calculated.

MIPAV supports over 32,000 unique VOIs on a single dataset. Additionally, 
you can move or delete nodes on the VOI and add new points. VOI types 
include:

• Point, which is created by using 

• 2D line

• Rectangular

• 3D rectangular

• 2D elliptical

• Polygonal

• 3D polygonal

• Interactive level-set

Generating contour VOIs using predefined shapes
MIPAV includes icons of predefined shapes, such as points, lines, ellipses, 
or rectangles, that you can use to create VOIs. These icons are on the VOI 
toolbar.

To generate contour VOIs using the predefined 
shapes

1 Select one of the contour icons from the VOI toolbar in the expanded 
MIPAV window. See also Figure 15.

2 Move the pointer to the image window. The pointer changes to a cross-
hair shape. Do one of the following:
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• Points, levelset: Position the cursor on the area where the point or 
levelset should be drawn. Click the mouse button.

• Straight lines, rectangles (2D and 3D), ellipsoids: Position 
the cursor on the area where the contour should begin. 

Click the mouse button. 

While holding down the mouse button, drag the cursor until the 
contour is the desired size.

• Polylines, polygons: Position the cursor over the area where the 
contour should begin. 

Click the mouse button. A point appears. Alternate between moving 
the mouse and selecting the mouse button to outline the VOI. 

To complete a polyline, double-click the mouse button. To complete 
a polygon, connect the first and last nodes.

Tip: To draw the same shape several times in succession, hold down the Shift 
key while you select the applicable icon from the VOI toolbar and draw.

Adding and moving boundary points on VOIs
No matter which method chosen to delineate a VOI, you can add points and 
change the boundaries of the VOI. For example, suppose you created a VOI 
on an image with the Rectangle VOI icon. If you notice that a part of the 
image that should be included in the VOI is not included, the boundary of 
the rectangle needs to be adjusted to include the missing portion of the 
image. 

To add a point and change the boundary of the VOI

1  Select the VOI. Notice that white points appear at the corners of the 
VOI and a small cross appears in the middle of the VOI.

2  Place the cursor on the portion of the VOI you want to adjust. The 
cursor changes from a cross to.

3 Click once. A white point appears on the line.

4 Select the point and drag it to include the missing part of the image.
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Tip: Circular VOIs are composed of a continuous series of points around the 
diameter of the circle. You only need to select one of those points and drag it to 
enlarge the circle.

Figure 33.  Adding a point and adjusting the boundary of a rectangular VOI
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Automatically adjusting contour boundaries
After a contour is drawn, it might be necessary to adjust the boundaries so it 
more closely matches the VOI region. 

To adjust contours

1 Click a contour. The nodes become visible. 

2 Select VOI > Evolve boundary 2D >Active Contour. The Evolve 
Boundary dialog box opens.

3 Modify the information in the window if necessary. 

4 Click OK.

A new contour, that more closely outlines the VOI, appears on the 
image. The old contour also remains.

 To delete an old contour, select the contour, and then select Cut 
Selected Contour, or press the Del key on the keyboard.

Scale of the 
Gaussian

Enter values for X,Y, and Z 
directions which will be used 
to correct blurring. The 
default value is 2.0

Resolution 
options

If this box is checked, the 
algorithm uses the image 
resolution to normalize the Z 
scale. 

Evolve 
Boundary

Single slice – the VOI 
boundary will be evolved 
only for the current slice;

Propagate to Adjacent Slices 
– the VOI will be propagated 
to adjacent slices;

Replace Original Contour – 
the original VOI will be 
replaced with the new one.

Figure 34.  Evolve Boundary dialog box
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Annotating images with text

 Another icon on the VOI toolbar is the Annotation tool icon, which you 
can use to place text directly on an image at any position on the image. You 
can use any font family, or typeface, that is installed on your computer to 
display the text.

To annotate images with text

1 Open an image.

2 Click the Annotation tool icon. The Annotation dialog box (Figure 35 on 
page 99) opens.

3 Click the image on which you want the text to appear. The image 
becomes the active image.

4 Select the font family and style (bold or italic). To select a regular font 
style, simply specify the font family.

5 Type the font size of type in the pt. box.

6 Press Enter. The Annotation dialog box either enlarges or reduces in 
size depending on the type size you chose (see “Previewing Font 
Selection” on page 100 below).

7 Click Color to select the color of the text. The color of the type in the Text 
box changes to the color you have chosen.

Algorithm 
parameters

Move Boundary – depending on the selected option, the VOI will be moved in 1) 
any direction, 2) only inward, 3) only outward.

Boundary Iterations– specify the number of iterations needed to calculate the 
new boundary.

Smoothness– enter the number from 0.5 to 2.4 to specify smoothness.

OK Applies the algorithm according to the specifications in this dialog box. 

Cancel Disregards any changes that you made in this dialog box and closes it.

Help TBD.

Figure 34.  Evolve Boundary dialog box (continued)
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8 Select “Enter text here” and type the text that you want to display on the 
image in the Text box.

9 Click OK. The text appears near the top of the image.

10 Click the text and drag it to any position on the image.

Font options Font—Specifies the font 
family, or typeface, for 
the text. When you select 
another typeface, “Enter 
text here” appears in that 
typeface.

Bold—Specifies that the 
type style should be bold.

Italic—Specifies that the 
type style should be italic.

Pt. (point) size—
Specifies the point size of 
the typeface.

Color—Specifies the 
color of the text. When 
you click this box, the 
Pick VOI Color dialog box 
opens.

Text Displays the text that should appear on the image.

Marker options The arrow marker appears if you check the Use Arrow Marker box.

OK Applies the parameters that you specified and places the text on the image, which 
you can move to any position on the image.

Cancel Disregards any changes you made in this dialog box, closes the dialog box, and 
does not place text on the image.

Help Displays online help for this dialog box.

Figure 35.  Annotation dialog box
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To edit the text 

1 Double-click the added text on an image. The Annotation dialog box 
opens.

2 Make any changes you want to the text, font family, font style, and color.

3 Click OK. The changes you made to the text should appear on the image.

To delete the text

1 Select the added text on an image.

2 Press Del. MIPAV removes the text from the image.

To restore the text to the image, select Edit > Undo VOI. The text reappears 
on the image.

Calculating VOI statistics

Once a VOI is drawn, you can calculate the number of voxels in the VOI, the 
volume, and area. You can also calculate the average and standard deviation 
of the voxel intensity and the center of mass. For 2D images, you can 
calculate the principal axis and the eccentricity. MIPAV provides two 
methods for you to obtain VOI statistics:

Previewing Font Selection
The Annotation dialog box allows you to preview the font family, style, size, and color of the 
text before you click OK and add the text to the image.
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• By using VOI properties—This method is fast and simple and provides 
statistics for the entire VOI. Although it allows you to save the results 
in a text file, that is an additional step. However, using this method, 
you can type additional information directly onto the Data page with 
the statistics.

• By using the Statistics Generator—Using this method, you can obtain 
statistics on the entire VOI, on a single slice of the VOI, or by contour 
and slice. The Statistics Generator also automatically saves the results 
in either a tab-delimited file or an XML file of your choosing. In 
addition, it displays statistics in a tabular format.

Note: MIPAV can calculate statistics for only one VOI at a time. In addition, 
MIPAV calculates the volume and area in a VOI using image pixel (voxel) 
resolutions.

Using VOI properties

To calculate VOI statistics

1 Select the desired VOI in the image window.

2 Select VOI > Properties in the MIPAV window. The VOI Statistics dialog 
box appears.

3 Select the statistics to be calculated in Statistics to Calculate. Click 
Calculate. The VOI Statistics dialog box remains on the desktop. In a few 
moments, statistical data appears on the Data page in the Output 
window.

4 To close the dialog box, click Cancel in the VOI Statistics dialog box 
when complete.

5 To add information to the statistics, just type it in into the statistics on 
the Data page.

6 To remove the data, select them first, and then click the Cut icon or 
select Edit > Cut to cut the selected data. MIPAV removes the selected 
text from the Output window and copies it to the clipboard for use in 
other applications.
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7 Select the data that you want to copy, and then click Copy or select Edit 
> Copy to copy the data to another location in the window or to another 
application (such as a word processor).

8 Click Save or select File > Save messages to save the data and any 
comments you’ve added to a text file.

9 Click Clear Messages or select Edit > Clear Messages to clear the 
window.

VOI Properties

Name of VOI Shows the name of VOI.

Thickness of 
VOI 

Shows the number which 
represents how many 
slices has a selected VOI.

Color of VOI Shows the color that was 
used to outline the VOI.

Show 
contour 
bounding 
box

Highlights the VOI and, 
when you select the VOI, 
displays a box that 
encompasses all of the 
VOI's borders and lists the 
measurements and 
position of each boundary. 

Use additive 
polarity for 
VOI 

If selected, put VOI 
names, such as 
“polygon1” to indicate VOI 
location.

Include for 
processing

This option is very helpful 
if you have a set of VOIs 
delineated on your image 
and want to use some of 
them for masking. See 
“Using the Include for 
Processing option” .

Show VOI 
name 

If selected, shows the 
name of the chosen VOI. 
E.g. “polygon1.” 

Figure 36.  VOI Statistics dialog box
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.

Using the Include for Processing option

The Include for Processing option is very helpful if you have a set of VOIs 
delineated on your image and want to use some of them for masking. In that 
case, select the VOI(s) of interest, then activate the Include for Processing 
option, and after that, call one of the mask tools, e.g. the Quick AND VOI 
mask operation. The tool will apply on the selected VOI(s). In case when the 
Include for Processing option has not been activated, then the Quick AND 
VOI mask operation will apply on the whole image and darken it. See 
Figure 37 (a) and (b).

Display VOI 
shading 

Shades the area inside a chosen VOI. 

When this option is selected, the Opacity slider becomes also available, so you can 
regulate the opacity of the shaded area. 

Statistics to calculate

Provides a list of statistics. 
Select the statistics that 
you want to include in the 
report. 

Select all Selects all of the statistics 
listed in the Statistics to 
calculate list.

Clear Clears all of the check 
boxes that you selected in 
the Statistics to calculate 
list.

VOI Tree Displays all VOIs delineated on the image in an hierarchical view. 

Tree options Frame follows VOI selection - if this option is selected, the current selected VOI 
appears in a frame in the VOI tree. 

Exclude intensity range Allows you to select specific intensity ranges that 
you want to exclude from the calculation.

Watershed seed value (0-32K) Indicates the basin value used when running the 
Watershed algorithm on images. 

Apply Applies the changes you made in this dialog box and leaves the dialog box open for 
you to make further changes. 

Cancel Disregards any changes you made in this dialog box, closes the dialog box, and 
does not run a statistics report. 

Calculate Calculates the statistics requested in this dialog box and displays them in the Data 
page of the Output window. 

Figure 36.  VOI Statistics dialog box (continued)
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Using the Statistics Generator
If you plan either to use a database or spreadsheet to keep track of VOI 
statistics or to obtain them in an XML format, use the Statistics Generator. 
As mentioned earlier, the Statistics Generator can provide statistics on an 
entire VOI(s) or a particular slice or by contour and slice.

Using the Statistics Generator involves three tasks:

• Selecting VOI and save options, refer to page 105

• Selecting statistics options, see page 106

Figure 37.  Using the Include for processing option for the Quick AND 
VOI mask operation. (a) The Include for Processing option is activated 
and (b) the Include for Processing option is disabled.
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• Reviewing the statistics, see page 107

SELECTING VOI AND SAVE OPTIONS

The first task is to select the VOIs on which you want to obtain statistics and 
select the file in which the resulting statistics should be saved.

To Calculate Statistics on VOI Groups 

1 Delineate or select the VOI(s) on the image.

2 Select VOI > Statistics Generator in the MIPAV window. The Calculate 
Statistics on VOI Groups window appears (Figure 38). This window 
displays all of the VOIs on the image in the VOI group list on the left.

3 Select the VOI on which you want to obtain statistics.

4 Press Send Selection Right. The name of the VOI appears in the VOI 
group list on the right.

5 Use Browse to choose a file name in the VOI Statistic File Destination 
box.

Figure 38.  Calculate Statistics on VOI Groups window
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6 Select either one of the two formats in the Output Format group: Tab 
delimited or XML.

7 Click Statistics Options. The Statistics Options page opens.

8 Proceed to the next task: Selecting statistics options.

SELECTING STATISTICS OPTIONS

The Statistics Options page (Figure 39) provides a list of statistics from 
which you can select and the options to obtain statistics by slice, by contour 
and slice, or by the total VOI.

To select statistics to perform on VOIs

1 Do either of the following in the Statistics to calculate group:

• Select one or more of the listed types of statistics.

• Click Select all to obtain all of the statistic types.

2 Select one of the following options in the Statistics options group:

• By contour & slice

Figure 39.  Statistics Options page
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• By slice only

• By total VOI (the default selection)

3 Select Show all totals if you want to record the totals for each type of 
statistic.

4 Click Calculate.

5 Select Logging. The Logging page (Figure 40) appears.

6 Proceed to the next task: ‘‘Reviewing the statistics’’.

REVIEWING THE STATISTICS

The Logging page (Figure 40) displays the statistics in tabular form. 
Whether or not you chose a type of statistic on the Statistics Options page, 
the table includes a heading for each type. Blanks cells in the table indicate 
that you did not choose to obtain that particular type of statistics.

Each time you calculate the statistics for a VOI the Statistics Generator adds 
another row of statistics to the table. Note that the first column in the table 
lists the name of the VOI and, if appropriate, the slice and contour numbers. 
Also, you can change the width of each of the columns in the table by drag-
ging the line between the columns in the heading.

You can include and review the statistics file in a database or in a spread-
sheet program by double-clicking on the file name in Windows Explorer 
window and, in the Open with dialog box, selecting the application in which 
you want to open the file.

Figure 40.  The Logging page in the Calculate Statistics on VOI Groups window
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When the number of rows in the table exceeds the length of the Logging 
page, scroll bars appear on the right side of the table to allow you to scroll 
from the beginning or to the end of the table. 

If at any time you want to clear, or erase, all of the rows of the table, select 
Options > Clear log window. The complete table disappears from the Log-
ging page, which is now totally gray.

Overwriting statistics files
If you previously ran the Statistics Generator and obtained statistics, after 
you click Calculate a message appears stating that a statistics file already 
exists. It asks whether to overwrite the file or to cancel the action. 

If you not want to overwrite the file, click Cancel. The following warning 
message appears. 

Return to the VOI selection page and choose another file name in the VOI 
statistic file destination box. Then click Calculate to obtain the new set of 
statistics. The Statistics Generator calculates the statistics and saves them 
in the file that you indicated. The statistics appear on the Logging page.

If it’s all right to overwrite the file, click Overwrite. The Statistics Generator 
calculates the statistics and overwrites the previously recorded statistics 
file. 

Tip: If you always want the Statistics Generator to overwrite the file, either 
select Options > Overwrite file automatically or press Alt+O.

Go to the next task: ‘‘Reviewing the statistics’’. 
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Modifying image resolutions

To modify the image resolution

1 Open an image.

2 Select Image > Attributes > Edit attributes in the MIPAV window. The 
Image Attributes dialog box opens. SeeFigure 41.

3 Click Resolutions. The Resolution page appears.

4 Modify the resolutions.

5 Click Apply. 

6 Click OK or Close when complete. The window closes.

Generating graphs (intensity profiles)

MIPAV can generate a graph of the intensity values of a region bound by a 
VOI. You can then save this graph or intensity profile, to a file for future 
reference. 

Figure 41.  The Resolutions tab of the Image Attributes dialog box; the 
Unit of Resolutions list box shows different units available in MIPAV
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Generating new graphs
You can generate an intensity profile for any VOI. 

To generate a graph of a VOI

1 Select a VOI in an image window.

2 Use the right mouse button to call the context menu, then select one of 
the following:

• Graph > Boundary Intensity

• Graph > Total Intensity

• Graph > Average Intensity

• Graph > Total Intensity with Threshold

• Graph > Average Intensity with Threshold

The chosen Intensity Graph window appears. Each function on the 
graph represents the intensity levels within each channel. Refer to 
Figure 42.

3 Close the graph by either selecting File > Close graph or pressing 
CTRL+X.

Boundary Intensity Total Intensity

Average Intensity Total Intensity with Threshold Average Intensity with 
Threshold

Figure 42.  The Intensity graphs
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SAVING GRAPHS TO A FILE

To save a graph

1 Select File > Save graph in the Intensity Graph window or press Ctrl S.

The Save dialog box appears. See Figure 43.
 

2 Type a name for the graph in File name.

3 Make sure that Graphs (.plt) appears in Files of type. Refer to Figure 43.

4 Click Save. MIPAV saves the file under a specified name.

PRINTING GRAPHS

To print graphs 

1 Select File > Print graph in the Intensity Graph window. The Print 
dialog box appears.

2 In the dialog box, select the printer and adjust the print options if 
necessary.

3 Click OK to print the graph or image on your default printer.

Figure 43.  Saving and printing intensity graphs
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Saving and printing images

This section explains how to save images to the same format (as when 
opened) or in a different format. It also shows how to print images. In 
addition, it explains how to save an image as a TIFF file. 

Saving images to the same format

To save an image file in the same format (as when 
opened)

1 Do one of the following in the MIPAV window:

• Click the Save Image icon or use the Ctrl+S combination of keys.

• Select File > Save Image.

The Save dialog box appears (Figure 44).

2 In the dialog box, type the name of the file in File name and click Save.

Note: If you prefer for MIPAV to use the style of Open and Save dialog boxes 
that are used by the operating system (e.g., Microsoft Windows, Unix, or Apple) 
on your computer, read the section on “Using platform-specific Open and Save 
dialog boxes” on page 124.

Figure 44.  Save dialog box 
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Capturing images as TIFF(RGB) files
MIPAV allows you to capture entire images or portions of images as RGB 
TIFF files. 

1 Select File > Capture image to TIFF(RGB) in the MIPAV window. The 
Capture Screen dialog box opens. See Figure 45.

2 To capture only a portion of the image:

• Select Region, then draw a rectangle with the mouse around the 
region in the image you want to save. Click OK. The Save dialog box 
opens. Type the name of the file in File Name, and select the TIFF 
type of file. Click Save. The region is saved under the specified file 
name.

3 To capture the entire image:

• Select Window, then click OK. The Save dialog box opens. Follow 
the instructions provided by the dialog box to save the image in TIFF 
format.

To display the region in a separate window rather than save it, select 
Display in Window Instead of Save. The selected region appears in a 
separate window.

To display the image in a separate window rather than save it, select 
Display in Window Instead of Save. The entire image appears in a 
separate window.

Figure 45.  Capturing images or image regions
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Saving images as 
MIPAV uses the file extension to save image into various formats. Thus, 
saving an image with the extension of TIFF  causes the image to be saved as 
a TIFF image. Saving an image with the extension of IMG causes the image 
to be saved as an Analyze image. See Table 1 for file extensions supported by 
MIPAV. 

TO SAVE IMAGES AS RGB TIFF FILES

1 Select File > Save as in the MIPAV window.

The Save Image as dialog box appears.

2 Type the name of the image in File name. Make sure you add .tiff as the 
extension.

3 Click Save. MIPAV saves the file as a TIFF file under the name you 
specified.

TO SAVE IMAGES TO MINC FORMAT

1 Select File > Save As.The Save Image as dialog box appears. See 
Figure 44.

2 Type the name of the file in File name. Make sure you add .mnc as the 
extension.

3 The Attributes to Save dialog box appears. See Figure 47.

4 Complete the text boxes with the appropriate information. Note that the 
x, y, and z values differ from DICOM.

5 Click Save. MIPAV saves the image to MINC format.
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SAVING IMAGES TO XML FORMAT

To record a history of actions that were performed on images, you should 
save the images to XML format. When you save images to XML format, 
MIPAV creates two files for each image: a RAW file, which contains image 
data, and an XML file. The XML file includes image attributes, such as 

Image 
orientation

Specify the image orientation 
here if need. Note that, often 
the proper value is already 
entered in the dialog box.

Then use the appropriate list 
boxes to specify the X, Y and 
Z axis orientation.

L/R Start – TBD

L/R Space – TBD

P/A Start – TBD

P/A Space – TBD

I/S Start – TBD

I/S Space – TBD

OK Saves the selected image based on your choices in this dialog box.

Cancel Disregards changes you made in this dialog box and closes the dialog box.

Figure 46.  MINC Attributes to Save dialog box

Figure 47.  The MINC Attributes to Save dialog box and comparison of 
MINC and DICOM image orientation
MIPAV User’s Guide, Volume 1, Basics 115

12/2/08 



M   I   P   A   V
M e d i c a l   I m a g e   P r o c e s s i n g, A n a l y s i s,   &   V i s u a l i z a t i o n

MIPAV User’s Guide, Volume 1, Basics
action history. You can view the attributes of an image by selecting Image > 
Attributes > Edit Attributes or by viewing the .xml file using a text editor or 
an internet browser. For more information on recording a history of 
actions, refer to “Saving a history of actions on images (TBD)” on page 126.

To save images to XML format

1 Select File > Save as.

The Save Image as dialog box opens.

2 Accept the name currently in File name or type a new name. Make sure 
you add .xml as the extension.

3 Click Save.

MIPAV saves the file under the name and extension you specified and 
begins, from this point on, recording a history of actions performed on 
the image.

SAVING IMAGES TO ANOTHER FORMAT OR 
RENAMING IMAGES

To save images to format different from the original 
file

1 Select File > Save as.The Save Image as dialog box appears (Figure 48). 

2 Type the new name in File name. To save the file in a different format, 
change the file extension. A list of extensions appears in Table 1 on 
page 628.

3 Click Save. MIPAV saves the file under the name and extension you 
specified.

To rename images

1 Select File > Save as. The Save Image as dialog appears (Figure 48).

2 Type the new name in File name. Either keep the extension already 
specified or change it to another file type. A list of extensions appears in 
Table 1 on page 628.
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3 Click Save. MIPAV saves the file under the name and extension you 
specified.

Printing Images
MIPAV offers the following printing command File > Capture and Print 
Image. This command calls the Print dialog box. Using this dialog you can 
set up a printer (to do it press the Properties button) or a file for printing 
(using the Print to File option), select the print copies and print range (all 
pages, current page, or selected pages).

To print an image with its current options:

Choose File > Capture and Print Image, and click OK.

To set printer and page setup options:

1 Choose File > Capture and Print Image.

2 Select an installed printer from the pop-up list at the top of the dialog 
box.

3  Set additional options, such as paper size and layout, as desired. The 
available options depend on your printer, print drivers, and operating 
system.

Figure 48.  Save Image as dialog box
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Customizing MIPAV

You can set the following MIPAV configuration options:

• “Showing or hiding the splash screen on start-up” on page 118

• “Using platform-specific Open and Save dialog boxes” on page 124

• “Debugging MIPAV” on page 126

• “Saving a history of actions on images (TBD)” on page 126

• “Choosing the default file types to display or save” on page 129

• “Adding shortcuts” on page 132

• “Developing and using plug-in programs” on page 134

Showing or hiding the splash screen on start-up
The splash screen is the window that first appears briefly when you start 
MIPAV. It appears immediately before the MIPAV window and the Output 
window open. The splash screen displays the name of the program and the 
MIPAV logo.

By default, MIPAV always displays the splash screen on start-up unless you 
decide to hide it. To do so, you need to change the option in the MIPAV 
Options dialog box.

TO HIDE THE SPLASH SCREEN OR PREVENT IT 
FROM APPEARING ON START-UP

1 Select Help > Program Options. The MIPAV Options dialog box 
(Figure 50) opens.

2 Clear the Display Splash Screen box.

3 Click Close. 

After you quit MIPAV and then start it again, the splash screen doesn’t 
appear.
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TO SHOW THE SPLASH SCREEN

After hiding the splash screen, you may later decide to display it.

1 Select Help > Program Options. The MIPAV Options dialog box 
(Figure 50) opens.

2 Mark Display splash screen. A check mark appears in the check box.

3 Click Apply, and then click Close.

After you quit MIPAV and then start it again, the splash screen appears.

Display Splash 
screen

Displays the MIPAV opening 
splash screen, or title screen, 
when MIPAV is started. By 
default, this check box is 
clear.

Use platform-style 
File dialog boxes

Uses the style of Open and 
Save dialog boxes that are 
provided with the operating 
system of your computer, 
rather than the MIPAV style. 
For more information, refer 
to “Using platform-specific 
Open and Save dialog boxes” 
on page 124. By default, this 
check box is clear.

Show Scripting 
toolbar

Shows the Scripting toolbar, 
which you can use to create 
and run scripts, in the MIPAV 
window. By default, this 
check box is clear.

Show Paint toolbar Shows the Paint toolbar, which allows you to paint directly on images. By 
default, this check box is clear.

Show Paint border Shows a border around the painted area. By default, this check box is 
clear.

Snap paint cursor to 
pixels

Causes the paint cursor to snap to the nearest pixel.

Figure 49.  The Display page in the MIPAV Options dialog
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Recently used image 
list

Specifies the number of recently displayed images that appear near the 
bottom of the File menu on the MIPAV window. To open a recently 
displayed image, simply select the image on the File menu.

The number of images that can be displayed can be from 2 to 9. By 
default, the number of images displayed on the File menu is 4.

Crosshair cursor 
color

Specifies the color of the crosshair cursor. You can choose from several 
colors and styles. By default, the color is set to “Default.”

Active image border 
color

Specifies the color of the border around images. When you click on this 
box, the Pick Active Color dialog box, which allows you to select a different 
color, opens.

By default, the color is red.

VOI draw color Allows you to choose the color that is used to draw VOIs. After you finish 
drawing VOIs, the completed VOIs appear in the Starting VOI color.

Starting VOI color Allows you to select the initial color for completed VOIs. That is, when you 
draw VOIs, they appear in the color chosen for VOI draw color; the 
completely drawn VOIs appear in the color you selected for this field.

Apply Saves and immediately applies all of the selected parameters in this dialog 
box.

Cancel Disregards any changes you made in this dialog box, closes the dialog box, 
and does not save the specified options.

Help Displays online help for this dialog box

Figure 49.  The Display page in the MIPAV Options dialog
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Prompt 
overwrite on 
save

Displays a prompt, or message, when 
you save a file under the same name 
as an already existing file. The 
message indicates that saving the file 
under the same name as an existing 
file overwrites the file.

Save all on 
save

Saves the active image and all VOIs 
presently displayed on the image so 
that the next time you open the image 
MIPAV opens the image and VOIs. The 
VOIs are saved in a subdirectory of the 
directory in which the image is stored.

 By default, this check box is clear.

Save dialog 
settings

Saves the settings you specified on 
algorithm dialog boxes so that the next 
time you use the algorithms, your 
specific settings override the default 
settings.

By default, this check box is clear.

Save XML 
header with 
Analyze 
images

Saves an XML header for an Analyze image when the image is saved. If you choose 
this option, the image has two headers: the normal header and an XML header. 
Both point to the image file.

By default, this check box is clear.

Save 
thumbnails 
for XML files

Saves a thumbnail image in the XML header, allowing you to view the thumbnails in 
the image browser

Compress 
image in zip 
format when 
saved as 
XML

Compresses images in a zip format when they are saved in XML format. When an 
image is saved in XML format, MIPAV produces a RAW file that describes the image 
and an XML file that includes image attributes. When you select this check box, 
MIPAV compresses only the RAW file, which compensates for the size of the RAW 
file.

By default, this check box is clear.

Default 
frame rate 
for Save-
image-as 
AVI

Specifies the default frame rate in frames per second for images that are saved as 
AVI.

By default, this check box is clear. If you select this option, the default frame rate is 
10.0.

File filter 
default

Specifies the types of files that should be shown in the Files of type box in the Open 
Image and Save Image as dialog boxes. Refer to “Choosing the default file types to 
display or save” on page 129 for more information. 

Apply Saves and immediately applies all of the selected parameters in this dialog box.

Figure 50.  The File page in the MIPAV Options dialog box
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Cancel Disregards any changes you made in this dialog box, closes the dialog box, and 
does not save the specified options.

Help Displays online help for this dialog box

Figure 50.  The File page in the MIPAV Options dialog box (continued)

Save dialog 
settings

Saves the active dialog box 
settings in a log file.

Global data 
provenance

Keeps a global record of all 
of the actions—algorithms 
and utilities—performed on 
images. The history may be 
viewed in the MIPAV 
system data provenance 
dialog box.

By default, this check box is 
clear.

Image level 
data 
provenance

Keeps a record of all of the actions—algorithms and utilities—performed on images. 
The history may be viewed in the Image data provenance dialog box while the 
actions are performed, or in the XML file when an image is saved to an XML file.

By default, this check box is clear.

LAX/
Preferences 
memory 
check

Enables MIPAV developers to debug the program. If you experience problems with 
the program, you may be asked to select this check box.

Recommendation: Do not select this check box unless otherwise instructed by 
MIPAV development. By default, this check box is clear.

Check on 
closing 
frame?

Adds messages to confirm deletions of images. By default, this check box is clear. 

Log errors 
to:

Allows you to select the file in which MIPAV records any errors that occur. By default 
MIPAV logs errors to C:\Program Files\mipav\mipav.log unless the name and path of 
the log file was changed during installation.

Debug 
levels: 
Minor

Records only minor error messages in mipav.log.

Figure 51.  The Other page in the MIPAV Options dialog box  
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Figure 52.  The SRB tab

Debug 
levels: 
Algorithm

Records only error messages with algorithms in mipav.log.

Debug 
levels: 
FileIO

Records only FileIO (file input and output) error messages in mipav.log.

Debug 
levels: 
Comms

Records only error messages involving communications in mipav.log.

Debug 
levels: 
Scripts

Records all error messages in mipav.log.

Apply Saves and immediately applies all of the selected parameters in this dialog box.

Cancel Disregards any changes you made in this dialog box, closes the dialog box, and does 
not save the specified options.

Help Displays online help for this dialog box.

Figure 51.  The Other page in the MIPAV Options dialog box (continued) 

Jargon 
version: 

A version of Jargon API library, which 
should be used to communicate to the 
SRB server. Select one from the list;

Transfer 
Mode

Parallel or sequential specifies the file 
transfer protocol. There are SRB 
parallel transfer protocol and SRB 
sequential transfer protocol available;

Temporary 
Directory

Is your local directory, where you keep 
your files which need to be transferred 
FROM or TO the SRB server.

See also “Connecting to SRB BIRN” .

Apply Saves and immediately applies all of the selected parameters in this dialog box.

Cancel Disregards any changes you made in this dialog box, closes the dialog box, and 
does not save the specified options.

Help Displays online help for this dialog box.
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Using platform-specific Open and Save dialog boxes
By default, MIPAV uses its own version of Open and Save dialog boxes, 
which provide you with the ability to assign aliases, or shortcuts, to fre-
quently used images. Aliases make it easy to locate images, a feature that 
may be attractive if you work with the same images for a period of time. 
However, you may prefer instead to use the style of Open and Save dialog 
boxes that are provided with the operating system of your computer. To do 
so, you need to select the Use platform-style File dialog boxes check box in 
the MIPAV Options dialog box. See Figure 53 on page 125.

If this check box is selected and your computer is running Microsoft Win-
dows, MIPAV displays the Windows style of Open and Save dialog boxes. If 
you use a Sun terminal, when this check box is selected, MIPAV displays the 
standard Unix-style Open and Save dialog boxes. On Apple MacIntosh com-
puters, MIPAV displays dialog boxes that are standard with that operating 
system.

To use platform-specific dialog boxes

1 Select Help > Program Options. The MIPAV Options dialog box opens. 
See Figure 53 on page 125.

2 Mark Use Platform-Style File Dialog Boxes. A check mark appears 
in the check box.

3 Click Apply, then click Close. The dialog box closes.
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Figure 53.  MIPAV Options dialog box showing Use platform-style File 
dialog boxes check box
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Debugging MIPAV
You can track debugging information and error messages generated by 
MIPAV during a session by placing it in debug mode. If errors occur during 
the session, the program displays any error messages in the Output window 
on the Debug page. By default, the debug mode is off when you start the 
program.

Recommendation: The debugging information is primarily intended for 

MIPAV developers and not for users. The best course for a user is to leave the 

debug mode Off unless a MIPAV developer asks for he/she to turn it on.

For more information about MIPAV debug mode, please refer to 
“Troubleshooting” , “Placing MIPAV in debug mode” on page 595.

Saving a history of actions on images (TBD)
MIPAV allows you to keep a history of all of the actions—the algorithms and 
utilities—that you perform on images. The history includes the specific 
parameters that were set for the action. In addition, if you save the images 
as XML, the history of actions and their parameters appears in the dataset 
attributes section near the beginning of the MIPAV header file (the XML 
file). Each action appears between the <HISTORY> and </HISTORY> tags.

By default, MIPAV does not record a history of actions unless you 
specifically select the Record history check box in the MIPAV Options > 
Other dialog box. TBD.

To record a history of actions taken on images TBD

1 Select Help > Program Options in the MIPAV window. The MIPAV 
Options dialog box appears.

2 Mark Record history. A check mark appears in the check box.

3 Click Apply. From this point on, MIPAV records the actions performed 
on all images until you clear the Record history check box.

Refer to Figure 54 and “To view the history of actions recorded in the XML 
file TBD” on page 128.
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To view the history of actions as they are performed

The History page in the Image Attributes dialog box allows you to view the 
list of actions immediately after they are performed. 

The following example illustrates how to do this:

1 Make sure that the Record History check box was selected in the MIPAV 
Options dialog box.

2 Open a sample image.

3 Select Image > Attributes > Edit attributes. The Image Attributes dialog 
box opens.

4 Select History. The History page appears.

5 Click the image to make it the active window.

6 Select Utilities > Flip > Horizontal. The image is flipped horizontally, 
and the words “Flip(Y_AXIS)” appear on the History page in the Image 
Attributes dialog box.

7 Perform other actions on the image, such as algorithms or other 
utilities. Note that these actions appear on the History page.

You can type directly onto the History page of the Image Attributes dialog 
box, letting you add comments to the history, which you can save and print.
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To view the history of actions recorded in the XML 
file TBD

1 Save the sample image as an XML file by selecting File > Save Image as. 
The Save Image as dialog box opens.

2 Select the directory where you want to save the file in the Save in box.

3 Type the name of the file—use “SampleImage” as the file name—and 
type an “.xml” file extension in the File Name box so that the complete 
file name is “SampleImage.xml.”

4 Click Save.

5 Open Windows Explorer by right-clicking on Start and then selecting 
Explore. The Windows Explorer window opens.

6 Navigate to the directory where you stored the XML file. This directory 
should have two files named “SampleImage”: “SampleImage.raw” and 
“SampleImage.xml.” 

7 Double-click “SampleImage.xml.” An internet browser page, such as 
Internet Explorer or Mozilla, appears displaying an XML page.

Under What Circumstances Do Actions Fail to 
Appear on the History Page?

If MIPAV is fully operational, actions performed on an image always appear 
on the History page of the Image Attributes dialog box and in the XML file 
for that image. However, it’s important to know whether the actions were 
performed on the original image or on the replacement image.

Several algorithms and utilities offer a choice of either 
generating a new image (New image check box) or 
replacing the original image (Replace image check 
box). If you choose New image and want to see the 
actions performed on that image, you must select 
Image > Attributes > Edit Attributes to open an Image 

Attributes dialog box for the new image. If, however, you select Replace 
image, the History page on the Image Attributes dialog box for the original 
image displays the actions.

To illustrate this point, open a sample image; select Image > Attributes > 
Edit Attributes to display the Image Attributes dialog box; and select 
History to display the History page. Perform an action such as Utilities > 
Image Margins, mark New image in the dialog box, and then click OK. 
Notice that the action does not appear on the History page. Click on the 
new image; select Image > Attributes > Edit Attributes; and select History. 
The History page shows the AddImageMargins action for the new image.
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Notice that, immediately after the <Dataset-attributes> tag, the 
following line appears: 

<History>Flip(Y_AXIS)</History>

Each action that you perform on the image appears between its own 
<History> and </History> tags. See also Figure 54.

Choosing the default file types to display or save
When you using MIPAV, chances are that you are working with the same 
type of files every day or perhaps for a certain period of time. For example, 
suppose you normally work with medical files (files whose extensions are 
.dcm, .xml, .ima, .img, .mnc, .sig, .head, etc.). In this situation, when 
opening or saving images, you want to see only the medical files, not other 
file types. One of the ways of customizing MIPAV is the ability to show only 
specific types of files by default.

The File Filter Default box on the MIPAV Options dialog box allows you to 
choose which types of files should be shown in the Files of type box in the 
Open Image and Save Image as dialog boxes.

Figure 54.  The Record History check box is located in the MIPAV Options dialog box > Other tab. 
Actions recorded are shown in the header of open XML file. TBD
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To choose the default file types to display or save

1 Select Help > MIPAV Options. The MIPAV Options dialog box opens.

2 Click File. The File page appears.

3 Click File filter default. The Choose File Filter dialog box appears.

4 Select one of the file filters. You can choose one of the following 
collections of file types:

• All (*.*)

• AVI (*.avi)

• Class files (*.class)

• FreeSurfer (*.asc)

• General (*.gif, *.jpeg, *.jpg, *.pict, *.psd, *.tif, *.tiff)

• Graphs (*.plt)

• Look-up tables files (*.lut)

• Matrix files (*.mtx, *.mat)

• Medical (*.dcm, *.xml, *.ima, *,img, *.mnc, *.sig, *.head)

• Microscopy (*.avi, *.ics, *.lsm, *.pic, *.stk, *.tif, *.tiff, *.xml)

• Misc. (*.avi, *.bmp, *.pcx, *.png, *.tga, *.xbm, *. xpm)

• Optical (*.avi, *.bmp, *.img, *.jpg, *.pict, *.psd, *.tif, *.tiff, *.xml)

• Project (*.xml)

• Script files (*.sct)

• Surface files (*.sur, *.wrl)

• Transfer function files (*.fun)

• VOI files (*.voi)

• Nonlinear transformation files (*.nlt)

• User Defined

5 Click OK. The Choose File Type dialog box closes and the file type you 
chose appears on the File filter default button.

6 Click Apply in the MIPAV Options dialog box. This change takes effect 
immediately.

See Figure 54 on page 129.
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To verify that the filters you chose are used as the 
default filters

1 Select File > Open > Image(A). The Open Image dialog box appears. The 
Files of type box should show the filters you chose.

2 Select File > Save Image as. The Save Image as dialog box opens with 
the Files of type box listing the file filters you chose.

Figure 55.  The File Filter Default button is located on File toolbar of the 
MIPAV Options dialog box. The Choose File Filter dialog box appears 
when you press that button
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Adding shortcuts
MIPAV allows you to create shortcuts using the Ctrl, Alt, and Shift keys plus 
the alphanumeric key of your choice. Shortcuts provide a quick way for you 
to perform a command on a menu or a command on one of the toolbars. 

Example: Suppose you frequently clone images. Rather than taking the time to 
select Utilities > Clone, you may find it easier and faster to simply press Ctrl +C, 
the keys you assigned to the shortcut.

To add shortcut keys

1 Select Help > Shortcut editor. The Shortcuts dialog box opens.

2 Click Add. The New Shortcut dialog box opens. See Figure 57–1.

3 Select Ctrl, Alt, or Shift or any combination of these check boxes. You 
can select only one of these check boxes, or you can select any combina-
tion of these check boxes. Valid selections can include only Ctrl, only Alt, 
or only Shift, or you can select Ctrl and Alt, Ctrl and Shift, Alt and Shift, 
or all three of the check boxes. See Figure 57–2.

4 Type an alphanumeric character in Character, and then press OK.

Figure 56.  Setting up the Medical file filter as a default filter. The Save As dialog box offers only 
Medical file types as types to save
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5 A message appears directing you to select a command on a menu or in a 
toolbar. See Figure 57–3. Press OK again. The message disappears.

6 Select a toolbar icon or select a command on a menu in the MIPAV 
window to which you want to assign this shortcut. A message appears 
indicating that the shortcut was successfully created. See Figure 57–4.

7 Click OK. The message disappears, and the shortcut appears on the 
Shortcuts dialog box.

To remove shortcut keys

1 Select Help > Shortcut editor. The Shortcuts dialog box opens.

2 Select the shortcut you want to delete.

3 Click Remove. MIPAV removes the shortcut, and the shortcut 
disappears from the list of shortcuts in the Shortcuts dialog box.

Note: Make sure you want to delete the shortcut. You cannot undo the deletion. 

Figure 57.  Creating a new shortcut. Steps 1–4 are explained in the text 
above
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Developing and using plug-in programs
A plug-in program allows you to add customized functionality to MIPAV. 
Before you create a plug-in, you should have a strong understanding of the 
underlying structure of MIPAV’s software design and data structure. 
Because plug-ins are written in Java, you should also have a basic under-
standing of that programming language. After you create the plug-in, you 
must then install it. Once it is installed, you can access it from the Plug-Ins 
menu in the main MIPAV window. Plug-ins are addressed in Chapter 12, 
“Developing Plug-in Programs”, in the MIPAV User’s Guide.

Quitting MIPAV

To end a MIPAV session 

1 Select File > Exit-MIPAV. The MIPAV-Exit dialog box appears asking if 
you really want to exit the program. See Figure 58.

2 Click Yes to end the session.

 You can also exit MIPAV by clicking on Close at the top right of the 
MIPAV window.

Figure 58.   MIPAV Exit Confirmation dialog box 
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