Analyizing Images

E—

In this chapter . . .

“Calculating statistics for contoured VOIs” on page 337
“Calculating statistics on VOI groups” on page 342
“Calculating the volume of masks” on page 352
“Generating graphs” on page 354

You can use MIPAYV to generate statistics on contoured volume of interest
(VOI) regions and to calculate the volume of painted pixels and voxels. You
can also use MIPAV'’s algorithms to perform more sophisticated image
analysis. For information about algorithms, refer to volume 2 of this User’s
Guide.

Calculating statistics for contoured VOIs

Once you have contoured structures, you can generate statistics on the VOI.

To select the type of statistics to calculate

1 Open an image.

2 Contour a VOI. An example of a contoured VOI appears in Figure 185A.
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3 Select the VOL.
4 Do one of the following:
e Select VOI > Properties.

e Right-click inside the VOI, which automatically selects it. Then
select Properties on the menu (Figure 185B).

The VOI Statistics dialog box (Figure 186) opens.

5 Choose the types of statistics that you want the program to calculate by
selecting the appropriate check boxes in the Statistics to calculate group.

Refer to Figure 186 for information on each statistic you can select.

Figure 185. Contoured VOI
6 Click Calculate.

7 Select the Output window.
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processing

MI1TPAYV

Name of Indicates the color of the

VOI VOI outlines and the
name of the VOI. To use
this to group two
contours, refer to Chapter
7 for more details.

Show Indicates whether to

bounding show the bounding box. If

box this check box is selected,
the bounding box appears
around the VOI.

Use TBD.

Additive

polarity for

VOI

Include for Indicates whether to

include the VOI in the
processing when running
an algorithm. If selected,
the VOI is included.

Boundary
or blended

Indicates whether the
contour is filled with color
(blended) or transparent
(only the boundary
appears). If selected, the
VOl is filled with color.

Opacity

Indicates whether a VOI
that is filled with color is
transparent, translucent,
and opaque: O is
transparent, and 1 is
opaque.

Statistics to
calculate

#. of voxels—Indicates
the number of voxels,
including voxels that span
frames in an image stack,
that are enclosed in the
VOI.

Figure 186. VOI Statistics dialog box
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Volume—Measures the amount of space occupied by a 3D VOI. To calculate the
volume, the software multiplies the number of pixels by the resolution of each
dimension
Area—Measures the surface of the VOI. To calculate the area, the software multiples
the number of pixels by the resolutions of the x and y dimensions
Perimeter - measures a perimeter of VOI
Min. Intensity — shows the min voxel intestacy
Max. Intensity — shows the max voxel intensity
Average voxel intensity—Calculates the average intensity of the voxels in the VOI
by adding the intensity of all voxels in the VOI and dividing the result by the sum of
the voxels
Std. dev. of voxel intensity—Calculates the standard deviation of the intensity of
the voxels in the VOI
Center of mass—Indicates the point at which the whole mass of the VOI is
concentrated. It is calculated as the sum of all x coordinates divided by the number
of points and the sum of all y coordinates divided by the number of points
Principal axis (only 2D)—Calculates the principal axis for 2D images only
Eccentricity (only 2D)—Describes the geometric shape of the VOI as an ellipse,
with O indicating a circle and 1 indicating a straight line
Major axis length — calculates the length of the major axis for an elliptical VOI
Minor axis length — calculates the length of the minor axis for an elliptical VOI
Select all Selects all of the statistical measures in Statistics to calculate.
Clear Clears all of the statistical measures in Statistics to calculate.
Exclude Excludes a specific range of intensity values, which you specify in the Range boxes,
intensity in the calculation. When this check box is selected, the Range boxes become
range available.
Range Specifies a particular range of intensities to exclude from the calculations. These
boxes become available only when the Exclude intensity range check box is selected.
Watershed seed value (0-32K) Indicates the watershed seed value.
Apply Applies the changes you made to this dialog box.
Cancel Disregards any changes you made in this dialog box and closes the dialog box.
Calculate Runs all selected statistics according to the specifications in this dialog box.
Help Displays online help for this dialog box.

Figure 186. VOI Statistics dialog box (continued)
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To view the statistics
1 Select the Output window.

2 Select the Data tab on the Output window to view the information. The
Data page of the Output window (Figure 187) appears showing the
results of the calculations.

To save the statistics

1 Select File > Save Messages in the Output window.

The Save dialog box opens.

2 Specify a name for the messages file and select a location for storing it.

3 Click Save. The software saves the file and places it in the specified
location.

So, for example, you could add a description of when the statistics were

V Tip: MIPAV provides you with the ability to type directly onto the Data page.
calculated or any other such meaningful information (Figure 187).

Figure 187. Data page in the Output window showing statistics
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Calculating statistics on VOI groups

The Statistics Generator command on the VOI menu in the MIPAV window
opens the Calculate Statistics on VOI Groups window, which allows you to
obtain statistics on one VOI or on multiple grouped VOIs. You can save the
statistics to a tab-delimited file, which can then be incorporated into a
database.

The Calculate Statistics on VOI Groups window includes three pages:

* VOI Selection page—On this page you can select the VOIs on which to
calculate the statistics. It also allows you to name and save the logging
file at the path you choose.

e Statistics Options page—This page provides a choice of the types of
statistics that may be calculated as well as the conditions under which
they may be run.

e Logging page—This page provides the results of the statistics in a
tabular form. Depending on the number of VOIs included in the
calculation, the results may include one or more lines of text.
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The VOI group list on the /
right is blank until you
move the group on the left
to this list.
VOI groups list—left Lists all of the VOIs found on the image.
VOI groups list—right Lists the VOIs on which you plan to calculate statistics.
; Moves all of the VOIs that appear in the VOI groups list on the right to the
. send all left VOI groups list on the left.
Moves the selected VOI that appears in the VOI groups list on the right to
g : the VOI list on the left
Send selection groups list on the left.
left
Deletes the selected VOI in either the VOI groups list on the left or the
Delete selection VOI groups list on the right.
Moves the selected VOI in the VOI groups list on the left to the VOI groups
Send selection list on the right on which you plan to calculate statistics.
right

Moves all of the VOIs, whether they are selected or not, in the VOI groups
Send all right list on the left to the VOI groups list on the right on which you plan to
calculate statistics.

Figure 188. VOI Selection page in Calculate Statistics on VOI groups window
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VOI statistics file Specifies the file path, file name, and file extension to which you want to

destination save the file.

Browse Allows you to navigate to the directory on your workstation or attached
disks where you want to store the file.

Tab-delimited Saves the statistics in a comma-separated tab-delimited file. The
extension for this file is .TABLE.

XML In development.

Calculate Runs all statistics that are selected on the Statistics Options page
according to the options specified.

Close Closes this window.

Help Displays online help for this window.

Figure 188. VOI Selection page in Calculate Statistics on VOI groups window

To calculate statistics on VOlIs

1 Open an image.

2 Delineate one or more VOIs on the image (Figure 189).
3 Select one of the VOIs by clicking it.

4 Hold down the Shift key and select the next VOI.

5

Continue holding down the Shift key and selecting VOIs until all of the
VOIs to be included in the calculation are selected.

(o))

Select VOI > Group VOls.

7 Select VOI > Statistics Generator. The Calculate Statistics on VOI
Groups window opens showing the VOI Selection page.
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Figure 189. Joined VOls

8 Select joinedVOIl.voi, which appears in the left VOI groups list.

9 Click , the Send selection right button. The group appears on the
right VOI groups list (Figure 190).

10 Do one of the following:

* Accept the default path and file name for the logging file, where the
statistics are stored, in VOI statistics file destination.

e Update the path and file name for the logging file.
11 Select the format of the logging file in Output format.

12 Select Statistics Options. The Statistics Options page (Figure 191)
appears.

13 Select the statistics you want to include in the calculation in the
Statistics to calculate list by doing one of the following:

e Click on the individual check boxes for each specific statistic.

e Click Select all to run all of the statistics.
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Tip: If you, for example, clicked Select all and then decide that you don’t
want the software to calculate all of the statistics, it may be faster to click
Clear to remove the check marks from all of the check boxes. You can then
select only the statistics you want to calculate.

Figure 190. Sending the joined VOIs to the VOI group list on the right

14 Select one of the following options in the Statistics options group:

e By contour & slice
e By slice only
e By total VOI

15 Select Show all totals if appropriate.

16 Click Calculate. The Logging page (Figure 192) appears with the results
of the statistics you selected.

17 Click Close when finished to close the Calculate Statistics on VOI
Groups window.
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Statistics to calculate No. of voxels—Indicates the number of voxels—including voxels that
span frames in an image stack—enclosed in the VOI.

Volume—Measures the amount of space occupied by a 3D VOI. To
calculate the volume, the software multiplies the number of pixels by the
resolution of each dimension.

Area—Measures the surface of the VOI. To calculate the area, the
software multiples the number of pixels by the resolutions of the x and y
dimensions.

Average voxel intensity—Calculates the average intensity of the voxels
in the VOI by adding the intensity of all voxels in the VOI and dividing the
result by the sum of the voxels.

Std. dev. of voxel intensity—Calculates the standard deviation of the
intensity of the voxels in the VOI.

Center of mass—Indicates the point at which the whole mass of the VOI
is concentrated. It is calculated as the sum of all x coordinates divided by
the number of points and the sum of all y coordinates divided by the
number of points.

Figure 191. Statistics Option page in Calculate Statistics on VOI Groups
window
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Principal axis (only 2D)—Calculates the principal axis for 2D images
only.

Eccentricity (only 2D)—Describes the geometric shape of the VOI as an
ellipse, with O indicating a circle and 1 indicating a straight line.

Statistics options

By contour & slice—Runs the selected statistics on both the contour and
slice.

By slice only—Runs the selected statistics on only the slice.

By total VOI—Runs the selected statistics on the entire VOI.

Show all totals—Specifies to display all of the totals for

Pixel exclusion

Exclude pixels from calculation—Indicates to exclude the pixels in the
Pixel range boxes from the calculation. When you select this check box,
the Exclude pixels button and the Pixel range boxes become available.

Exclude pixels—Indicates to exclude the pixels between, above, below,
or outside the range shown in the Pixel range boxes.

Pixel range—Lists a specific range of pixels between, above, below, or
outside that should be excluded in the calculations.

Select all Selects all of the statistics listed in the Statistics to calculate group.

Clear Clears all of the statistics listed in the Statistics to calculate group.

Calculate Runs all statistics that are selected on the Statistics Options page
according to the options specified.

Close Closes this window.

Help Displays online help for this window.

Figure 191. Statistics Option page in Calculate Statistics on VOI Groups

window

To exclude a range of pixels from the calculations

When you run statistics on VOIs in an image but want to exclude a specific
range of pixels from the calculations, make sure that you do the following:

1

Select Exclude pixels from calculation on the Statistics Options page in
the Calculate Statistics on VOI Groups window. The Exclude pixels list
and the Pixels range boxes become available.

2 Select Between, Above, Below, or Outside in the Exclude pixels list.

Type a range of pixels in the Pixel range boxes.
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4 Continue to select statistics and other options for the calculation.
5 Click Calculate.
Statistics table Lists all of the statistics that were calculated according to the selected
statistics and the options specified on the Statistics Options page.
Calculate Runs all statistics that are selected according to the options specified on
the Statistics Options page.
Close Closes the window.
Help Displays online help for this window.

Figure 192. Logging page in the Calculate Statistics on VOI Groups window
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To save the calculations to a specific file

By default, the software saves the results of the calculations to the following
path and file name:

c:\Documents and Settings\[username]\voistatistics.table

However, you can easily change the file name by typing over the default file
name in the VOI statistic file destination box on the VOI Selection page in
the Calculate Statistics on VOI Groups window. To change the path, type
over the current path, or click Browse to select another path.

To use the calculations in a database application

Saving the statistics in a tab-delimited file allows you to import them into a
database application.

1 Make sure—before running the calculations—that you select the Tab-
delimited check box on the VOI Selection page in the Calculate Statistics
on VOI Groups window.

2 Change the path and file name, if necessary, in the VOI Statistics File
Destination box on the VOI Selection page.

3 Click Calculate. The resulting statistics appear on the Logging page and
in the file you specified.

To rearrange the columns in the logging table

You can adjust the order in which the columns in the logging table appear as
well as their width. To change the order, simply click on the title of a column
and drag the column to the new position. To make a column wider, click on
the line between it and the next column and drag it to the desired width.

To compare statistics

If you calculate statistics on an image more than once in a MIPAV session,
the Logging page shows the previously run calculations for the VOIs in that
image. For example, suppose you calculate statistics on the VOIs in an
image and then save the image and close it. Later, you reopen the image and
decide to run additional statistics on the previous VOIs or on any new VOlIs.
As long as you did not exit MIPAV and are therefore in the same session, the
Logging page in the Calculate Statistics on VOI Groups window still displays
the results of the statistics you previously ran on the VOIs in the image.
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When you perform additional calculations on the same or new VOIs on that
image or on VOIs in another image, the results of those calculations appear
below the earlier run statistics. This allows you to compare the results of
both.

To clear, or delete, all of the statistics on the Logging
page

When you no longer need the statistics on the Logging page or after you
saved them to afile, you can clear, or delete, all of the statistics on the
Logging page. To do so, do one of the following:

e Select Options > Clear logging page in the Calculate Statistics on VOI
Groups window.

e Press Alt C.
e Select Clear on the Statistics Options page.

The software deletes all of the statistics on the Logging page.

To overwrite logging files automatically

If you ran calculations previously in your current MIPAV session and then
select Calculate in the Calculate Statistics on VOI Groups window, the File
Exists message appears asking whether to overwrite the previously saved
logging file or cancel the action. If you select Overwrite, the software
replaces the previously saved file with the new statistics. Selecting Cancel
means that MIPAV does not perform any calculations.

Figure 193. File Exists message
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standard procedure for handling statistics files. That is, do you need to keep
them for historical purposes? Do you need to keep statistics on individual
images in separate files? If so, you may want to assign unique names to the
statistics file for each image. If not, you may want to simply overwrite the
statistics file each time you calculate statistics of VOI groups.

V Recommendation: It is recommended that you decide in advance on a

If you do not want to keep the statistics in separate files, it may become
tiring to always receive and need to respond to the File Exists message. To
this end, the software offers an option for always overwriting the logging
files. To use this option, simply select Options > Overwrite File
Automatically (Figure 194) in the Calculate Statistics on VOI Groups
window.

Options |
Clear Log Window AltC
¥ Overwrite file automatically Alt0

Figure 194. Overwrite file automatically command on the Options menu

V Tip: To turn the overwrite command on, press Alt O on the keyboard. To turn it
off, press Alt O again.

Calculating the volume of masks

You can calculate the volume of painted voxels, or mask, in an image and
view the information about the volume on the Data page of the Output
window.

To calculate the volume of masks
1 Open an image, and paint the voxels in a desired area of the image.
2 Follow the instructions for manually creating a mask in “Generating

masks” on page 312 in Chapter 8, “Segmenting Images Using
Contours and Masks.”
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3 Do not commit the paint, which permanently merges the paint layer
with the image layer.

4 Click , the Calculate Volume of Paint icon, in the Paint toolbar.

The region grow information (how many voxels or pixels are painted)
and the volume of all painted voxels appear on the Data page of the
Output window (Figure 195).

To view the information

1 Select the Output window.

2 Select the Data tab on the Output window to view the information. The
Data page of the Output window (Figure 195) appears.

Figure 195. Data page in the Output window (left) listing the region
grow and volume information from the painted voxels in the image

(right)

Remember: You can type directly onto the Data page if you want to record
such information as the date and time the calculations were run.
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To save the information

1 Select File > Save Messages in the Output window.

Figure 196. Save messages command on File menu
in the Output window

The Save dialog box opens.
2 Specify a name for the messages file and select a location for storing it.

3 Click Save. The software saves the file and places it in the specified
location.

Generating graphs

MIPAYV allows you to generate intensity profiles, or contour VOI graphs, for
VOI contours. For delineated VOIs, you can generate 2D, 3D, or 4D
intensity graphs. You can also generate a 3D intensity graph at a specific
point across all slices in a dataset. For information on how to contour a VOI,
refer to Chapter 8, “Segmenting Images Using Contours and Masks.”

Generating contour VOI graphs

Contour VOI graphs display the intensity values of the selected contour’s
boundary in the Contour VOI Graph window (Figure 197). You can generate
either 2D or 3D contour VOI graphs.

To generate 2D contour VOI graphs

1 Open an image.

2 Delineate a 2D VOI on the image using one of the 2D icons in the

MIPAV window: 2. € or
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File Open Graph—Opens a PLT file that contains graph data. When you select this
command or press Ctrl O on the keyboard, the Open Graph Data dialog box appears.

Save Graph—Saves the graph data in a PLT file. When you select this command or
when you press Ctrl S on the keyboard, the Save dialog box opens.

Print Graph—Allows you to print the graph. When you select this command or press
Ctrl P, the Print dialog box opens.

Close Graph—~Closes the Intensity Graph window. To close the window, you can also
press Ctrl X on the keyboard.

Edit Delete Function—Allows you to delete a specific function. However, you cannot delete
a function if it is the only function displayed in the window.

Copy Function—Copies a function that is currently displayed in the window.

Paste Function—Pastes a previously copied function into the window. The pasted
function has a different color than the first function displayed in the window.

Views Modify Graph Features—Allows you to customize the appearance of the graph.

Reset Range to Default—[TBD]

Reset Graph to Original—[TBD].

Help Help Topics—Displays online help topics.

Figure 197. Contour VOI Graph window
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3 Select the VOI.
As an option, copy the VOI to other slices in the dataset by selecting VOI
> Propagate and one of the following commands:
e To Next Slice
e To Previous Slice
e To All Slices
4 Do one of the following:
e Select VOI > Graph > Boundary Intensity in the MIPAV window.
e Right click on the VOI and then select Graph > Boundary Intensity.
The Contour VOI Graph window (Figure 197) opens.
To generate 3D contour VOI graphs
1 Open an image.
2 Delineate a VOI on the image using = , the 3D rectangular VOl icon, in
the MIPAV window.
3 Select the VOI.
As an option, copy the VOI to other slices in the dataset by selecting VOI
> Propagate and one of the following commands:
e To Next Slice
e To Previous Slice
e To All Slices
4 Do one of the following:
e Select VOI > Graph > Boundary Intensity in the MIPAV window.
e Right-click on the VOI and then select Graph > Boundary Intensity.
The Contour VOI Graph window (Figure 197) opens. This window
displays a graph of the intensity values of the selected contour’s
boundary.
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Generating intensity graphs

Intensity profiles, or graphs, present information on the intensity values of
the VOI region in an image. The intensity graph appears in the Intensity
Graph window (Figure 198).

To generate 2D intensity graphs
1 Open an image.

2 Delineate a 2D VOI on the image using one of the 2D icons in the

MIPAV window: = € or

3 Select the VOI.

As an option, copy the VOI to other slices in the dataset by selecting VOI
> Propagate and one of the following commands:

e To Next Slice
e To Previous Slice
e To All Slices

4 Do one of the following:

e Select VOI > Graph in the MIPAV window and either of the
following:

e 2.5D Total Intensity—To generate a graph of the sum of the
intensity values of the VOI region.

e 2.5D Average Intensity—To generate a graph of the average of the
intensity values of the VOI region.

* Right-click on the VOI and then select Graph and one of the
following commands:

e 2.5D Total Intensity—To generate a graph of the sum of the
intensity values of the area delineated by the VOI per slice.

e 2.5D Average Intensity—To generate a graph of the average of the
intensity values of the VOI region.

e 2.5D Total Intensity with Threshold—TBD.
e 2.5D Average Intensity with Threshold—TBD.
The Intensity Graph window (Figure 198) opens.
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File

Open Graph—Opens
a PLT file that contains
graph data.

When you select this
command or press
Ctrl O on the
keyboard, the Open
Graph Data dialog box
appears.

Save Graph—Saves
the graph data in a
PLT file.

When you select this
command or when
you press Ctrl S on
the keyboard, the
Save dialog box
opens.

Print Graph—Allows you to print the graph. When you select this command or press

Ctrl P, the Print dialog box opens.

Close Graph—Closes the Intensity Graph window. To close the window, you can also

press Ctrl X on the keyboard.

Edit

Delete Function—Allows you to delete the function that you select. However, you cannot

delete a function if it is the only function displayed in the window.

Paste Function—Pastes a previously copied function into the window. The pasted
function has a different color than the first function displayed in the window.

Views

Modify Graph Features—Allows you to customize the appearance of the graph.

Reset Range to Default—TBD.

Reset Graph to Original—TBD.

Help

Help Topics—Displays online help topics.

Figure 198.

Intensity Graph window
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To generate 3D intensity graphs of all slices in a
dataset at a specific point
1 Open an image.
2 Draw a point VOI on the image (Figure 199).
3 Select the VOI.
4 Do one of the following:
e Select ,the Propagate VOI to all slices icon.
e Select VOI > Propagate > To All Slices.
e Right-click on the VOI, then select Propagate > To All Slices
(Figure 199).
5 Right-click on the VOI and select Show VOI Graph (Figure 199).
The Intensity Graph window (Figure 198 on page 358) opens.
Figure 199. Point VOI
To generate 3D intensity graphs of specific areas
1 Open an image.
2 Delineate a VOI on the image using o , the 3D rectangular VOI icon, in
the MIPAV window.
3 Select the VOI.
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4 Do one of the following:

a Select VOI > Graph and either of the following in the MIPAV
window:

2.5D Total Intensity—To generate a graph of the sum of the
intensity values of the area delineated by the VOI per slice.

2.5D Average Intensity—To generate a graph of the average of the
intensity values of the VOI region.

b Right-click the VOI, and then select Graph and one of the following
commands in the MIPAV window:

2.5D Total Intensity—To generate a graph of the sum of the
intensity values of the area delineated by the VOI per slice.

2.5D Average Intensity—To generate a graph of the average of the
intensity values of the VOI region.

2.5D Total Intensity with Threshold—TBD.
2.5D Average Intensity with Threshold—TBD.

The Intensity Graph window (Figure 198 on page 358) opens.

CUSTOMIZING THE APPEARANCE OF GRAPHS

You can adjust the appearance of graphs to interpret the information more
clearly or easily. To customize graphs, you use the Modify Graph dialog box
(Figure 200 on page 361), which is accessible through Views > Modify
Graph Features in both the Contour VOI window (Figure 197 on page 355)
and the Intensity Graph window (Figure 200 on page 361). The Modify
Graph dialog box includes the following four tabbed pages:

e Graph page (refer to Figure 200 on page 361), which allows you to
show or hide the gridlines and tick marks, change the number of
gridlines and background color of the graph, change the labels on the
graph, and change the range values.

e Legends page (refer to Figure 208 on page 371), which lets you
determine whether a legend should appear on the graph and allows
you to assign a specific name to each function.
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e Functions page (refer to Figure 210 on page 373), which allows you to
change the appearance of the functions in the graph.
e Fitted Functions page (refer to Figure 212 on page 377), which allows
you to modify the functions.
Gridlines Displays, if
visible selected, gridlines
on the graph in the
Intensity Graph
window.
Minor tick Displays, if
marks selected, the tick
visible marks on the X and

Y axes of the graph
in the Intensity
Graph window.

Number of

Indicates the

X-axis number of gridlines
gridlines that appear on the
X axis of the graph.
The default number
of gridlines is 4.
You can specify
from 1 to 50
gridlines.
Number of Indicates the number of gridlines that display on the Y axis of the graph. The default
Y-axis number of gridlines is 4. You can specify from 1 to 50 gridlines.
gridlines
Title Specifies the name of the graph. By default, the name is Intensity Graph. However,

you can replace this name with any name you choose.

X axis label

Specifies the name that appears for the X axis. By default, the name is Position on
curve (mm).

Y axis label

Specifies the name that appears for the Y axis. By default, the name is Intensity.

Change
background
color

Allows you to choose the color of the background of the graph. When you select this
icon, the Pick Background Color dialog box opens. By default, the background color
for graphs is light gray (the HSB values are O hue, O saturation, and 100 brightness
and the RGB values are 255 red, green, and blue.

Auto shrink
range

TBD.

Figure 200. The Graph page of the Modify Graph dialog box
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Min. for TBD. The default minimum range is 207,437.0. If you specify another range, it must

range be less than the default range.

Max for TBD. The default maximum range is 595,910.0. If you specify another range, it must

range be more than the default range.

Reset Erases the current minimum and maximum ranges and replaces the values with the

default default minimum and maximum ranges.

range

Apply Applies the changes you made in this dialog box.

Cancel Disregards any changes you made in this dialog box, closes the dialog box, and does
not change the threshold.

Help Displays online help for this dialog box.

Figure 200. The Graph page of the Modify Graph dialog box (continued)

To display or hide the points, or tick marks, on
graphs

1 Open an image.
2 Delineate a VOI on the image.

3 Generate an intensity profile (refer to “Generating graphs” on
page 354). Either the Contour VOI Graph window (Figure 197 on
page 355) or the Intensity Graph window (Figure 198 on page 358)
opens.

4 Select Views > Modify Graph Features in either the Contour VOI Graph
window or the Intensity Graph window. The Graph page of the Modify
Graph dialog box (Figure 200 on page 361) appears.

5 Do one of the following:

e |If you want to make the points appear on the graph, select Minor
tick marks visible. A check mark appears in the check box.

e |If you want to make the points invisible, clear Minor tick marks
visible.
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6 Click Apply.

e If you selected Minor tick marks visible, the tick marks along the X
and Y axes in the graph appear.

e |If you cleared Minor tick marks visible, the tick marks disappear
from the graph.

7 Do one of the following:

e Click  to close the Modify Graph dialog box.

e Keep the Modify Graph dialog box open to continue modifying the
graph.

To display or hide the gridlines on graphs
1 Open an image.
2 Delineate a VOI on the image.

3 Generate an intensity profile (refer to “Generating graphs” on
page 354). Either the Contour VOI Graph window (Figure 197 on
page 355) or the Intensity Graph window (Figure 198 on page 358)
opens.

4 Select Views > Modify Graph Features in either Contour VOI Graph
window or the Intensity Graph window. The Graph page of the Modify
Graph dialog box (Figure 200 on page 361) appears.

5 Do one of the following:

e To make the gridlines appear on the graph, select, if not already
selected, Gridlines visible. A check mark appears in the check box.

e To make the gridlines disappear from the graph, clear Gridlines
visible. The check box is empty.
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Figure 201. Displaying or hiding the gridlines and tick marks on the
graph

6 Click Apply.

e If you selected Gridlines visible, horizontal and vertical gridlines
appear in the graph.

e If you cleared the check box, the gridlines disappear from the graph.

7 Do one of the following:

e Click  toclose the Modify Graph dialog box.

e Keep the Modify Graph dialog box open to continue modifying the
graph.

To change the number of gridlines in graphs

1 Select Views > Modify Graph Features in either the Contour VOI Graph
window (Figure 197 on page 355) or the Intensity Graph window
(Figure 198 on page 358). The Graph page of the Modify Graph dialog
box (Figure 200 on page 361) appears.

2 Change the number of X-axis gridlines in Number of X-axis gridlines
(Figure 202) by specifying a value from 1 to 50. The default number of
gridlines is 4.

3 Change the number of Y-axis gridlines in Number of Y-axis gridlines
(Figure 202) by specifying a value from 1 to 50. The default number of
gridlines is 4.
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4 Muraber of X-Azis Gridlines
4 Muraber of ¥-Axs Gridlines

Figure 202. Number of X-axis and Y-axis gridlines

4 Click Apply.

The number of horizontal and vertical gridlines that you specified
appear in the graph in the Intensity Graph window.

Tip: If you specify many gridlines, to see the gridlines more clearly, resize the
Modify Graph dialog box.

5 Do one of the following:

e Click toclose the Modify Graph dialog box.

e Keep the Modify Graph dialog box open to continue modifying the
graph.

To change the graph title and labels on the X and Y
axes

1 Open an image.
2 Delineate a VOI on the image.

3 Generate an intensity profile (refer to “Generating graphs” on
page 354). Either the Contour VOI Graph window (Figure 197 on
page 355) or the Intensity Graph window (Figure 198 on page 358)
opens.

4 Select Views > Modify Graph Features in Contour VOI Graph window or
the Intensity Graph window. The Graph page of the Modify Graph
dialog box (Figure 200 on page 361) appears.

5 Type the new title and axes labels in Title, X-axis label, and Y-axis label
boxes (Figure 203).
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Intensity Graph | Title
Type a new title or axes
labels in these boxas on
the Graph page in the Pogition on Curve (ram) | XLz [abel
Modify Graph dialog box
Intensity ‘ ¥-fixis Label

Figure 203. Title, X-axis label, and Y-axis label boxes in the Modify
Graph dialog box

6 Click Apply.

The new title appears number of horizontal and vertical gridlines that
you specified now appear in the graph (Figure 204).

Tip: If you specify many gridlines, you might want to resize the Modify Graph
dialog box to see the gridlines more clearly.

7 Do one of the following:

e Click  to close the Modify Graph dialog box.

* Keep the Modify Graph dialog box open to continue modifying the
graph.
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Figure 204. Changed title and axes labels in the Intensity Graph
window

To change the background color of graphs
1 Open an image.
2 Delineate a VOI on the image.

3 Generate an intensity profile (refer to “Generating graphs” on
page 354). Either the Contour VOI Graph window (Figure 197 on
page 355) or the Intensity Graph window (Figure 198 on page 358)
opens.

4 Select Views > Modify Graph Features in either the Contour VOI Graph
window or the Intensity Graph window. The Graph page of the Modify
Graph dialog box (Figure 200 on page 361) appears.

5 Select Change background color (Figure 205).

D Change Backaround Color

Figure 205. Change background color button

The Pick Background Color dialog box (Figure 206) opens.
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Figure 206. Pick Background Color dialog box

6 Select a color from one of the three pages in this dialog box. Refer to “To
change background and border colors” on page 255 for information on
how to select a color. Refer to “To change background and border
colors” for information on how to select a color.

7 Click OK to apply the color to the graph background. The Pick
Background Color dialog box closes, and the graph background
(Figure 207) changes to the color you selected.
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Figure 207. Changed background color for the graph
To reset graphs to their original background colors
To return either the intensity graph or the contour VOI graph back to its
default colors, select Views > Reset Graph to Original or press Ctrl Z in
either the Contour VOI Graph window or Intensity Graph window as
appropriate.
CHANGING THE LEGENDS FOR FUNCTIONS
The Legend page controls whether a legend appears on the contour VOI
graph or intensity graph and allows you to assign a specific name to each
function. By default, the legend does not appear on the graph; however,
when you choose so, the legend appears in the upper right corner of the
graph.
To display or hide legends
1 Open an image.
2 Delineate a VOI on the image.
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3 Generate an intensity profile (refer to “Generating graphs” on
page 354). Either the Contour VOI Graph window (Figure 197 on
page 355) or the Intensity Graph window (Figure 198 on page 358)
opens.

4 Select Views > Modify Graph Features in either the Contour VOI Graph
window or the Intensity Graph window. The Modify Graph dialog box
(Figure 200 on page 361) appears.

5 Select the Legend tab. The Legend page (Figure 208) appears.
6 Do one of the following:

e To display the legend on the graph, select Show legend. A check
mark appears in the check box.

e To hide the legend, clear Show legend. The check mark disappears
from the check box.
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7 Click Apply.

e If you selected Show legend, the legend appears in the upper right of
the graph (Figure 209).

e If you cleared Show legend, the legend disappears from the graph.
8 Do one of the following:

e Click  to close the Modify Graph dialog box.

e Keep the Modify Graph dialog box open to continue modifying the
graph.

Show Displays, if selected, the

legend legend on the upper right
side on the graph in
either the contour VOI
graph or the Intensity
Graph window.

Function Specifies the name of the

N name function. By default, the
name is Function 1, but
you can replace this
name with any name you
choose.

This page allows you to
specify up to five function
names as long as those
functions exist.

Apply Applies the parameters
that you specified.

Cancel Disregards any changes that you made in this dialog box and closes the dialog box.

Help Displays online help for this dialog box.

Figure 208. Legend page of the Modify Graph dialog box
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CHANGING THE APPEARANCE OF FUNCTIONS
The Functions page in the Modify Graph dialog box allows you to display or
hide the points on functions, display or hide from one to five functions, and
change the color of functions.
Points Displays, if selected, all
visible of the points on the
functions.
Function Displays, if selected,
N visible function N on the graph.
You can display from one
to five functions.
This dialog box allows
you to select only those
functions that exist.
Otherwise, they are
dimmed.
Change Allows you to choose the
function color to use for displaying
N color function N (listed on the
left). When you select
this icon, the Pick
Background Color dialog
box opens.
Apply Applies the parameters that you specified.
Cancel Disregards any changes that you made in this dialog box and closes the dialog box.
Help Displays online help for this dialog box.
Figure 210. Functions page in the Modify Graph window

To display or hide the points on functions

1 Open an image.

2 Delineate a VOI on the image.

3 Generate an intensity profile (refer to “Generating graphs” on

page 354).

Either the Contour VOI Graph window (Figure 197 on page 355) or the
Intensity Graph window (Figure 198 on page 358) opens.
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4 Select Views > Modify Graph Features in either the Contour VOI Graph
window or the Intensity Graph window.
The Modify Graph dialog box (Figure 200 on page 361) opens.
5 Select the Functions tab. The Functions page (Figure 210) appears.
e To display the points, select Points visible. A check mark appears in
the check box.
e To make the points invisible, clear Points visible. The check mark
disappears from the check box.
6 Click Apply.
e |If you selected Points visible, the points appear on the functions
(Figure 211).
e |If you cleared Points visible, the points disappear from the function.
7 Do one of the following:
e Click  to close the Modify Graph dialog box.
* Keep the Modify Graph dialog box open to continue modifying the
graph.
Figure 211. Points on a function whose color changed from red to blue
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To display or hide functions
1 Open an image.
2 Delineate a VOI on the image.
3 Generate an intensity profile (refer to “Generating graphs” on
page 354).
Either the Contour VOI Graph window (Figure 197 on page 355) or the
Intensity Graph window (Figure 198 on page 358) opens.
4 Select Views > Modify Graph Features in either the Contour VOI Graph
window or the Intensity Graph window.
The Modify Graph dialog box (Figure 200 on page 361) opens.
5 Select the Functions tab. The Functions page (Figure 210) appears.
6 Do one of the following:
e To display the function, select Function N visible. A check mark
appears in the check box.
e To remove the function from the graph, clear Function N visible.
The check mark disappears from the check box.
7 Click Apply.
e If you selected Function N visible, the function appears on the
graph.
e If you cleared Function N visible, the function disappears from the
graph.
8 Do one of the following:
e Click  to close the Modify Graph dialog box.
e Keep the Modify Graph dialog box open to continue modifying the
graph.
To change the color of functions
1 Open an image.
2 Delineate a VOI on the image.
3 Generate an intensity profile (refer to “Generating graphs” on
page 354).
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Either the Contour VOI Graph window (Figure 197 on page 355) or the
Intensity Graph window (Figure 198 on page 358) opens.

4 Select Views > Modify Graph Features in either the Contour VOI Graph
window or the Intensity Graph window.

The Modify Graph dialog box (Figure 200 on page 361) opens.
5 Select the Functions tab. The Functions page (Figure 210) appears.
6 Do one of the following:

e To change the color of the function, select Change Function N color.
A check mark appears in the check box.

e To keep the color the same, clear Change Function N color. The
check mark disappears from the check box.

7 Click Apply.

e |If you selected Change Function N color, the function appears in the
new color.

e If you cleared Change Function N color, the color of the function
remains the current color.

8 Do one of the following:

e Click  to close the Modify Graph dialog box.

e Keep the Modify Graph dialog box open to continue modifying the
graph.

To reset functions to their original colors

To return the functions on either the intensity graph or the contour VOI
graph back to their default colors, select Views > Reset Graph to Original or
press Ctrl Z in the Intensity Graph window or the Contour VOI Graph
window as appropriate.
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MODIFYING FUNCTIONS ON GRAPHS
[TBD]

Fit linear TBD

Fit TBD

exponential

None TBD

Fitted TBD

function N

visible

Apply Applies the parameters that you specified.

Cancel Disregards any changes that you made in this dialog box and closes the dialog

box.
Help Displays online help for this dialog box.

Figure 212. Fitted Functions page in the Modify Graph dialog box

Opening, saving, printing, and closing graphs

The File menu in the Contour VOI Graph window and the Intensity Graph
window allows you to open, save, print, and close graphs.
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Figure 213. File menu in the graph windows showing the Open Graph,
Save Graph, Print Graph, and Close Graph commands

To open previously saved graphs

1 Select File > Open Graph in either the Contour VOI Graph window or
the Intensity Graph window, or press Ctrl C. The Open dialog box
appears.

2 Navigate to the directory where the graph was stored.
3 Type or select the file name in File name.

4 Click Open. The graph opens.

To save contour VOI graphs or intensity graphs

1 Select File > Save Graph in either the Contour VOI Graph window or the
Intensity Graph window, or press Ctrl S. The Save Graph dialog box
(Figure 214) opens.

2 Navigate to the directory where the graph was saved.
3 Type or select the file name in File name. Use .PLT for the extension.

4 Click Save. The graph is saved in the specified directory.
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Figure 214. Save dialog box: saving contour VOI graphs
or intensity graphs

To print contour VOI graphs or intensity graphs

1 Select File > Print Graph in the Contour VOI graph window or Intensity
Graph window, or press Ctrl P.

The Print dialog box opens.
2 Select the printer and number of copies you want to print.
3 Click OK.

The printer prints the graph.

To close graphs

Select File > Close Graph in either the Contour VOI Graph window or in the
Intensity Graph window, or press Ctrl X. The graph closes.

v Tip: You can also select to close the graph window.
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