Visualizing Images

Visualization of image datasets is an important aspect of image analysis.
Researchers must often visualize the orientation, locality, or progression
(time) of structures in clinical and nonclinical datasets. This chapter
explains how to use MIPAYV to visualize medical images using views.

Views specify the way image datasets are displayed. Views indicate the
number of images in a dataset that are displayed at one time and whether
images in a dataset are manually or automatically advanced.

In the default view, one image is displayed at a time. If a dataset contains
more than one image, you can manually advance through the image stack.
The default view can also display 2D through 5D datasets. For image
datasets with more than two dimensions, additional views are available:
animate, cine (movie), lightbox, link to another image, surface plotter,
surface render, triplanar, and triplanar-dual. The lightbox view displays two
or more images, or slices, at once. Others—animate and cine—automatically
advance the images and display them in succession, much like a cinema
film.

To gain access to views other than the default view, you use the Image >
Views menu (Figure 121) in the MIPAV window. Figure 1 lists the types of
views and the number of images each view displays at one time and
indicates whether images are manually or automatically advanced in the
view and the number of dimensions an image must have to be displayed in
the specified view.
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For example, you can view an image dataset that has three or more
dimensions in cine view, which displays only one image at a time and
advances images in the forward direction only.

Image Toohars Help
Views » Animate
Atirihutes 4 ine (Movie
The Volurme Render (Shear) and !{ S )
Volume Render views are currently Zoom » Light Box
in production. = £
m“fﬁng Glass Settmgs Link 1o Another lm;nge To make this command
- | available, you need to load a
h-;k I-[is'tngram -LUT Surface Plotier 3D or 4D image into another.
\ TR Surface Render

Triplanar /
\. Volume Render (Shear)

Yolume Render
Number of images Manual or automatic
View displayed image advancement Dimensionality
Default 1 Manual All (2D, 3D, 4D, 5D)
Animate 1 Automatic (forward, Images with more than
reverse, continuous two dimensions (2D)*
looping)
Cine (Movie) 1 Automatic (forward) Images with more than
two dimensions
Lightbox All images in the Manual Images with more than
dataset two dimensions*
Link to_ 2 Manual Images with more than
another two dimensions*
image
Surface 1 Manual Images with more than
plotter two dimensions*

*MIPAV can display a 4D dataset that overlays a 3D dataset in the views indicated. If the 4D dataset
has dimensions that differ from the 3D dataset, the 4D dataset is automatically resampled and
interpolated into the same dimension space as the 3D dataset.

Figure 121. Types of views as shown on the Image > Views menu
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Toolhars Help
Animate
Atirihutes » ine (Movie
The Volurme Render (Shear) and “ S )
Volume Render views are currently Zoom k I‘g]lt Box
in production. ; - E:
Mﬂgllﬂ’ﬂg Glass Setﬂngp Link to Another [-m To make this command
2 available, you need to load a
‘\h‘ Histogram - LUT Surface Plotier 3D or 4D image into another,
DMQM Overlay et ire Hiomder /
e Triplanar
Triplanar - Dual
. Volume Render (Shear)
Volume Render
Number of images Manual or automatic
View displayed image advancement Dimensionality
Surface All images in the Manual 3D images™*
renderer dataset
Triplanar 2 Manual 3D and 4D images™
TIriplanar-dual 2 images loaded Manual 3D and 4D images™
together

*MIPAV can display a 4D dataset that overlays a 3D dataset in the views indicated. If the 4D dataset
has dimensions that differ from the 3D dataset, the 4D dataset is automatically resampled and
interpolated into the same dimension space as the 3D dataset.

Figure 121. Types of views as shown on the Image > Views menu (continued)

Tip: You can display different views of the same dataset on the desktop at the
same time.
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Displaying images using the default view

When you initially open or load an image dataset, it appears in the image
window showing the default view (Figure 2).

If you display a 2D image dataset, the title bar only displays the name of the
file and the magnification level only. If you open an image dataset that has
more than two dimensions, the title bar displays the name of the file, the
position of the image in the dataset, the total number of images in the
dataset, and the magnification level.

¥4 1 62/124 M:1.0

The title bar
displays the
number of the
current image that
is displayed and the
total number of
images in the
dataset.

The magnification
levelis shown at the
end of the title bar.

Figure 122. Image window showing the default view for a 2D image

Datasets with more than two dimensions typically contain many image
slices. To manually advance through datasets that contain more than one

image, you can use the image slice slider or .

»

, the Decrements image

slice icon, or , the Increments image slice icons in the MIPAV window
(Figure 4). You can also use the lightbox view to find and display a
particular slice in the image dataset in the default view (refer to “Using the
lightbox view to update the image slice displayed in the default view” on
page 47).
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The title bar for a 2D
image shows only:
* The name of the file
* Magnification level

Slice number

(A} A 2D image

sgsh 3703 1 nsmro [CEE

The title bar for a 3D image
dataset shows:

* The name of the file

* The number of slices

+ Magnification level

Slice number

(B} A 3D image dataset

Figure 123. Image window showing (A) a 2D image, or slice, and (B) an image dataset that has
more than two dimensions.

Magnifying and minifying images

In the default view you can magnify or minify, or reduce, displayed images.
When you display an image, the magnification level is indicated on the title
bar of the window. For example, M:4.0 indicates that the image was
magnified by a factor of four times the original size. You can also use the
magnifying glass to temporarily magnify or reduce a region of the image.
You can magnify images to 32 times their original size, reduce them to one-
fourth their original size, or restore them to their original size.

Select Taolbars to choose which
| toolbars appear.
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DX Sh 3703 1 9B M:1.0
File Edit VOI LUT Algorithms Utilities Plugins Image Toolhars Help
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Figure 124. MIPAV window showing image slice slider and slice buttons and lightbox icon
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In the MIPAV window, there are three methods for magnifying or minifying
images:
e Automatically using three preset commands on the Image > Zoom
menu
e Manually using the Custom command on the Image > Zoom menu,
which allows you to create other magnification levels
e Automatically using the icons on the image toolbar
To set the magnification level automatically using the
preset commands
1 Open an image.
2 Select Image > Zoom.
3 Select one of the following commands on the Zoom menu:
. I 0.5X—To reduce the image by one-half of its current size
- B 1X—To restore the image to its original size
. A 2X—To enlarge the image by twice its original size
The software immediately changes the magnification level of the image.
Image Toolhars Help
Vi : There are four
e Zoom commands.
«»
i g ¢ o
Zoom A, 05X
Magnifying Glass Setiings
}'L 1] 1x
. Histogram - LUT
B
I Show DICOM Overlay Cuatani
Figure 125. Zoom commands on the Image menu
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To set the magnification manually using the Custom
command

To manually adjust the magnification level to a specific level that is not
available through the preset commands or the icons on the image toolbar,
do the following:

1 Open an image.

2 Select Image > Zoom > Custom. The Custom Magnification dialog box
(Figure 6) opens.

3 Slide the marker in the Magnification slider to the specific level of
magnification that you want to apply.

4 Select the interpolation method if desired.

The interpolation mode is particularly important when an image is magnified
(and voxels are seen more easily). Three interpolation modes are available:
nearest, bilinear, and cubic (refer to Figure 6 for more information).

v Interpolation is the addition of one or more voxels between two other voxels.

5 Click Apply. MIPAYV applies the magnification level and interpolation
mode to the image.
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Magnification Slide the marker left to decrease the
magnification or right to increase the =
magpnification. You can reduce the image RRRTI UL B
to one fourth of its current size or Magnification | [ Intexpolation
enlarge it up to 32 times its current size. ‘ @ &) Neatest
Notice that the number below the center 6 i e
of the slider changes as you slide the | ’ b
marker to indicate the magnification '
level. ‘ Apply ‘ ‘ Close

Interpolation Select one of the following methods:
Nearest—Short for nearest neighbor. The replicated voxel is assigned the color of
the closest voxel. This mode yields more accurate results because other modes
because the original values are retained. However, if applied, the image may have a
choppy “stair-step” effect. It is also possible that some data may be lost or
duplicated.
Bilinear—In this mode, the average of the four nearest voxels (to the newly
interpolated voxel) is weighted. The interpolated voxel is then assigned the
resulting color. If this mode is applied, the “stair-step” effect is reduced. However,
because the view of the data is altered, it is not as accurate as the nearest neighbor
mode.
Cubic—Short for cubic convolution. This mode is similar to the bilinear mode,
except that the weighted average of the nearest sixteen voxels is used instead of
the nearest four. If this mode is applied, the stair-step effect is greatly reduced.
However, because the view of the data is altered, it is not as accurate as the nearest
neighbor or bilinear modes.

Apply Applies the magnification and interpolation you specified.

Cancel Disregards any changes that you made in this dialog box and closes this dialog box.

Help Displays online help for this dialog box.

Figure 126. Custom Magnification dialog box
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To set the magnification automatically using icons on
the image toolbar

The three magnification icons on the image toolbar work the same way as
the three preset commands on the Image > Zoom menu do. Do one or more
of these tasks:

e To magnify an image, click i , the Magnify image 2.0x icon. Each
time you click Magnify, the image doubles in size. As the magnification
level increases, it may be necessary to manually adjust the size of the
window so you can see the entire image at one time. Scroll bars appear
if the image is too big for the window.

e To minify an image, click i , the Magnify image 0.5x icon. Each time
you click this icon the image is reduced to half size.

e To return the image to the original level of magnification, click H , the
Magnify image 1.0x icon.

Tip: These icons appear on other windows beside the MIPAV window, and they
work in the same way on each window.

WORKING WITH THE MAGNIFYING GLASS

The magnifying glass is much like a traditional, real-world magnifying glass.
It allows you to view a portion of the image at a specific magnification level.
You can select the magnification level, which can be anywhere from 1 to 32
times the original image size. For example, an image may be the original

size; however, to examine a specific area more closely, you may want to set
the magnification level of the magnifying glass to 16 times the original size.

Conversely, if an image uses a high-level of magnification, you may want set
the magnifying glass to a lower magnification level so that you can gain
perspective on where a section fits with the whole image.
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To use the magnifying glass

1 Open an image.

2 Click % , the Magnify Region icon, on the Image toolbar in the MIPAV
window.

3 Move the cursor to the image. The cursor shape changes to the
magnifying glass shape, a box outlined in red with the level of

magnification in the lower left corner (Figure 7). The area inside the box
is magnified.

The magnification level
appears in the lower
left corner of the

magnified region. The magnified region,

outlined in red, can
magnify the image
from Y to 32 times
the original size.

Figure 127. Magnified region

You can move the magnifying glass to different places on the image.
This allows different regions to be magnified without affecting
magnification level of the entire image. When you want to return to

. . L .
normal magnification, click , the Default Mode icon.

To adjust magnifying glass settings
1 Do either of the following:
» Select Image > Magnifying Glass Settings.
* Right-click on the image.

The Magnification Settings dialog box (Figure 8) appears.
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Magnification Specifies the level
of magnification in Hon sl
the magnified Magnification slider
region. You can
select a
magnification from Ems e
1 to 32 times the i} =
original size of the
- 10 40 320
Image. OB G
Display Shows the [ Size
intensity intensity values of ‘Widfh: 61
values the voxels in four
areas in the ‘ amy || cme |
magnified region.
This check box is
only available for
magnifications 21
to 32.
Width Indicates the size of the magnified region in voxels; in
other words, of the magnifying glass.
Apply Applies the parameters in this dialog box to the
magnifying glass.
Close Disregards any changes that you made in this dialog
box and closes this dialog box.
Help Displays online help for this dialog box.
Figure 128. Magnification Settings dialog box
2 Move the Magnification slider to select the level of magnification. The
number in bold in the middle of the slider indicates the current level of
magnification.
3 Specify the size of the magnifying region (box) in the Width text box.
(The width and the length are the same.) Values are in voxels.
4 Select Display intensity values if you want to see the intensity values of
the voxels in the magnifying glass (Figure 9).
5 Click Apply. The new settings are applied to the magnifying glass.
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When you select Display
Intensity values on the
Magnification Settings
dialog box, the magnified
region shows the intensity
values for four areas in the
region,

Figure 129. Magnified region showing intensities

Viewing two images together

When two separate image files are loaded into the same window (for
directions on how to load an image, refer to Chapter 3, “Getting Started
Quickly with MIPAV”), the window displays a blending of both images.
MIPAYV refers to the first image file as “Image A” and to the second image
file as “Image B.” By default, Image A is active and Image B is inactive. To
change which image is active, simply select, as appropriate, the Image A or
Image B radio button.

By default, Image A is active and Image B is inactive. Thus, even if two
image files are loaded into the same image window, only Image A—which is
the designation MIPAYV assigns to the first image that was opened in the
window—is displayed.

You can view the inactive image using one of the following methods:

e Adjust the alphablending value so that you can see the inactive and
active images simultaneously

e View the part of Image B that is directly under that portion of Image A

by using ) , the Window region of Image B icon.

e View portions of the image using the checkerboard tool
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Figure 130. MIPAV window showing Image A and Image B slider

COMPARING IMAGES USING ALPHABLENDING

Alphablending is a technique that adds transparency information to
translucent objects. It is used to blend what is currently rendered on the
display (i.e., Image A) with the contents of the frame buffer (i.e., Image B).
Each colored voxel is assigned an alpha value, which represents
transparency. The alpha value is used to blend the intensities, voxel by
voxel. When two images share a window, you can adjust the alphablending
settings so that you can see a blend of both images and can compare
overlapping regions in two datasets.

To use the alphablending tool and Window Region
tool

1 Open two images.

2 Load the second image into the image window of the first image. The

Active Image and Alphablending slider appears at the bottom of the
MIPAV window (Figure 11).
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The level of translucency for one image is inversely proportional to the
other. Thus, if Image A is 75 percent transparent and 25 percent
opaque; Image B is 75 percent opaque and 25 percent transparent
(“Alphablending: An Example” on page 20).

% Note: In the MIPAV window, notice that an additional magnifying glass is now

available: * , the Window Region of Image B icon, which you use to view the
portion of Image B that is directly under that portion of Image A.

3 Move the Active Image and Alphablending slider between the Image A
and Image B radio buttons.
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For a very clear example of how alphablending

works, open two images and then apply i , the
Hot Metal LUT icon, to one of the images before
you load them together. After the images are
loaded, move the Active Image and
Alphablending slider from the left to the right.
The following images show what you see at five
points of the slider:

(A) The image on the far left shows 100 percent
of Image A. It does not display a blending of the
images.

However, for any of the images below, you can
use the Q , Window Region of Image B icon, to

inspect the portion of Image B that lies
underneath that same portion of Image A.

(A) Image A

=]

S55h_31703_1_clene 9N

(C) 0.50A/B

(D)o.75B

%ish_3703_1_clone 91... [2 [BK

Alphablending: An Example

(B) The next image displays a blending of 75
percent Image A and 25 percent of Image B.

Again, use ] to see the portion of Image B
beneath Image A.

(C) The middle image displays 50 percent
blending of both Image A and Image B. You can

&

(D) The fourth image displays 75 percent of
Image B and only 25 percent of Image A. You

LN

(E) The final image on the right displays 100
percent of Image B. Since all of Image B is

-}

use to inspect Image B.

can use

still to inspect Image B.

shown, you no longer have a need to use

This figure is best viewed in the PDF version of this chapter.

¥<sh_3703_1_clone 911... [C |[B)K)

(E} Image B
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Depending on the direction in which you are moving the slider (that is,
toward Image A or toward Image B), one image becomes more visible.

To examine each image in more detail, you can use the magnifying
glasses.

As you move the slider, the images in the image window are updated
instantly. If not, release the mouse button to update the image.

Move the slider all the way to the right or to the left depending on which
image you want to see. For example, to see Image B, move the slider to
the far right. To see Image A, move the slider (Figure 10) to the far left.
The closer the slider is to the middle, the more blended are the images.

WA MIPAY: LO_10637 _4 614124 M:1.0

Filo Edit YOI LUT Algorithms Utilities Plugins Image TooDars Help

EE«J & E o) () fm i m'_. S 4 D@ | @ o Adjust alphablending slider

to select best ratio for the

oo ([len o B W W
Scripts Hm,.[ersntScnpt: S
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datasets of interest.
<

X 34Y:55 Intensity: 1.0 Relalive poeition: R: 82,125 5. 67537 P22

n g
Image slice
=
r 5} |
1 62 124
Active Image and Alpha Blonding
® Image A (. Image B
e ) 1
Irnagn & 0754 05AB 0.758 Iroage B

Figure 131. MIPAV window showing Active image and
alphablending slider

To make images active or inactive

1 Open two images.

2 Load the second image into the first image window. The MIPAV window
expands to include the Active Image and Alphablending slider

(Figure 10).

3 Notice that Image A is currently the active image.
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4

4 Select Image B in the Active Image and Alphablending slider to make
Image B the active image.

5 Move the slider to the far right. As you are moving the slider, more of
Image B appears in the image window. When the slider reaches the far
right, all of Image B appears in the image window.

Ly

6 Click , the Default Mode icon.

If you want to take an action on one of the images—for example, adjusting
the contrast or running an algorithm—make sure that it is the active image.
If the inactive image is Image B, you also have the option of using the Image
B region tool to view portions of the Image B. If the active image is currently
Image A and you want to view Image B, simply select the Image B radio
button. To make Image A the active image, select the Image A radio button.

VIEWING PORTIONS OF IMAGES USING THE
CHECKERBOARD

The checkerboard tool displays both portions of both images in an
alternating fashion, much like the squares on a checkerboard. A traditional
checkerboard has a grid of alternating dark-colored and light-colored
squares. Portions of Image A appear where the light-colored squares would
appear on the checkerboard; portions of Image B appear in place of the
dark-colored squares. You can adjust the number of rows and columns
displayed.

To use the checkerboard tool

1 Open two images.

2 Load the second image into the first image window. The MIPAV window
expands to include the Active Image and Alphablending slider.

Note: If you select another image—that is, an image that is not loaded into the
same window as Image A and Image B, the Active Image and Alphablending
slider disappears from the MIPAV window. The slider only appears when the
selected image window contains two images.
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3 Click # . The Checkerboard Pattern dialog box (Figure 12) appears.
Use Specifies to use checkerboarding.
checkerboarding -
KX Checker Board Pattern
Rows Indicates the number of rows you [ Parameters
want to display in the checkerboard. [¥] Use Checker Boarding
You can display from 1 to 50 rows. @ g
Rows 1
Columns Indicates the number of columns you 1 50 -
want to display in the checkerboard. (57 .
You can display from 1 to 50 il ; ok
columns.
Apply Applies the parameters that you ‘ Apply H Close || Cancel
specified to the images.
Close Closes this dialog box.
Cancel Disregards any changes you made in this dialog box, closes the dialog box, and
does not apply checker boarding.

Help Displays online help for this dialog box.

Figure 132. Checkerboard Pattern dialog box

4 Select Use checkerboarding if it is not already selected.

5 Adjust the Rows slider to indicate the number of rows that should be in

the checkerboard pattern.

Click Apply when finished. The checkerboard pattern appears in the
image window (Figure 13).

When the rows and columns intersect, a grid is created. Adjacent
squares in the grid alternatively display the active and inactive images.

Click Close to close the Checkerboard Pattern dialog box.

To remove the checkerboard from the image

Click #
appears.

. The Checkerboard Pattern dialog box (Figure 12 on page 22)

2 Clear Use checkerboarding.

3 Click Apply. MIPAV removes the checkerboard from the image.

4 Click Close.
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(A) Example of 5 rows and 5 (B) Example of 10 rows and 10
columns columns

Figure 133. Examples of the checkerboard pattern applied to
two loaded images

Changing image brightness and contrast using LUTs

Generally, computer systems have brightness display values written in the
display hardware. These values are known as the physical color map; they
are hard coded in your monitor.

When you open an image, the image file contains data that indicates the
intensity of each voxel in the image. These data are passed to the physical
color map and displayed on the monitor. Additionally, MIPAV provides a
logical color map, which allows you to remap the original intensities to
other intensities. Although technically the term look-up table (LUT) can be
used for the physical and logical color maps, in this guide look-up table
refers to the logical color map only. You can apply predefined, pseudocolor
or inverse LUTs, or you can manually manipulate the transfer function used
to map the image data to the LUT. The LUT then translates the remapped
values so that they can be interpreted by the physical color map and
displayed on your monitor.

To adjust the look-up table using the Quick LUT

Generally, to adjust the LUT, you open the Look-up Table window to modify
the LUT’s values and transfer function. However, you can use the Quick
LUT icon to modify the LUT without opening the Look-up Table window.
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Quick LUT allows you to easily choose the highest and lowest values for the
intensity levels in a user- defined area. To do this, complete the following
steps:

1 Open an image.

2 Click ' (Quick LUT) in the MIPAV window.

3 Move the cursor to the image window and draw a box around an area
that has the highest and lowest intensities you want the image to
display. These values are used to remap the image data to the LUT. The
net effect is increased contrast in the area of interest (Figure 14).

dsh_3703_13 snsm:1.0 [C)E)K #4sh_3703_13 9n8m:1.0 [2]B]K] ¥ish_3703_13 9nem:.0 [C)[E)K]

(A} Image before applying Quick LUT (B) Using the Quick LUT icon, draw a {C} Image after applying Quick LUT
box on the image with the highest
and lowest intensities desired

Figure 134. An image before and after applying Quick LUT

To generate a histogram and look-up table

A histogram is a graphic representation of the intensity level distribution in
an image or VOI region. It displays the number of voxels at each intensity
level. The histogram and LUT appear in the Look-up Table window.

To generate a histogram, and view the LUT, complete the following steps:

1 Open an image. The image appears in an image window.
2 Create a VOI on the image (optional step).

3 Do either of the following:
e Click Look-up Table.
e Select LUT > Histogram - LUT.
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If the image contains a VOI, the Histogram window appears (Figure 15).
Go to the next step.

e
i Histogram

x|

-

®) [Whole image

3 VOI regions)

OK ‘ ‘ Cancel

Figure 135. Histogram dialog box
If there are no VOIs on the image, the Look-up Table window
(Figure 16) appears.

4 Choose one of the following:

* Whole image—To generate a histogram for the whole image

» VOI region(s)—To generate a histogram for the VOI region of the
image

5 Click OK. A progress message appears briefly. After a few moments, the
Look-up Table window appears (Figure 16).
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File

Open LUT—Opens a
previously saved LUT file.
LUT files have a .LUT
extension.

Save LUT—Saves the LUT
displayed in this window in a
LUT file.

I Lookup Table: LO_10637 _4
File Utilities

FEEEEEDI NEER NCEC
NYmD?% | AHNEE B E

Fe il I
Il Update (eal-time). Nuber of colors: |-
¥ Log scele (Histogram).  LUT:

[ Tuterpolate image

Open Transfer Functions—
Opens a previously saved

transfer function. Transfer
function files have a .FUN

extension.

A 255- v 2034437
Save Transfer Functions—

Saves the transfer function
displayed in this window to a
file.

C
Close LUT—Closes the LUT e
window. Transfer function | ¢
Utilities Change number of colors— 20
Allows you to change the
: : -6
number of colors displayed in B
the image. 0 13{91:
. 2609
Valid values are 2 to 256. Riiags Eadaeit
CT function—Allows you to select a preset LUT that is appropriate for the image
content. Values are abdomen, head, lung, mediastinum, spine, and vertebrae.
Invert LUT—Creates a negative of the image.
Reset histogram and LUT A—Returns image A to its original values.
Reset histogram and LUT B—Returns image B to its original values. This command is
only available if two images are open.
LUT toolbar Provides tools that allow you to manipulate the displayed image. Refer to Figure 19.
Update Changes the image as you make changes to the LUT, which allows you to see the

(real-time)

effect of your changes immediately on the image.

Log scale
(histogram)

Displays the image’s histogram count in log scale along the Y axis.

Interpolate
image

Displays image using interpolation, which reduces pixillated image to appear more
smooth.

Caution: Depending on the memory resources of your workstation, interpolation
can be very lengthy.

Figure 136. Look-up Table window
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Number of Allows you to change the number of colors displayed in the image.
colors
LUT Displays the image intensities.

Figure 136. Look-up Table window (continued)

The Look-up Table window consists of three sections: a menu bar, a toolbar,
and one or more pages containing histograms. A tab appears for each image
that is opened in the image window. For example, if only one image is in the
image window, then only the Image A tab appears. If you generated the
histogram for an image window that contains two images, a tab for Image A
and a tab for Image B appear. Each of these tabbed pages contain a
histogram for the applicable image. If you generated the histogram for a
VOI, the window does not display a tab and only the applicable icons and
buttons in the toolbar appear.

The toolbar allows you to manipulate the displayed image. You can apply
pseudocolor LUTSs, adjust the image contrast with the transfer function, and
apply preset window and level settings for CT slices. You can also edit the
red, blue, green, and alpha channels of a LUT.

P look-up table (LUT)—Indicates the intensity of each voxel in the image and, in
MIPAV, allows you to remap the original intensities to other intensities.

transfer function—Reflects the relationship between the original image
intensity values and how they are mapped into the LUT. The line in the LUT
represents the transfer function.

Note: You can generate a histogram for two image datasets that are loaded
together. In this case, the Look-up Table window (Figure 17) shows two tabs—

one for Image A and one for Image B.
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| Logkup Table; PA_22943 31
File Uiilities
IEEENINERE NG
DEm? | AHEE B E
Cimages |[ImageB |
[¥#] Updlate (real-time). Number of colors:
[¥] Log scale (Histogram),  LUT:
[ nterpolate image
Figure 137. Look-up Table window showing Image A and B histograms
To update images in real time
When you modify the LUT, be sure to select the Update (real time) check
box. The image in the image window is then updated in real time.
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To change the number of intensities displayed in the
LUT

You can change the number of intensities displayed in the LUT. To do this,
do the following:

1 Select Utilities > Change Number of Colors in the LUT window. The
Change Number of Colors dialog box opens.

R ner el Specify any whole
R number betwesn 2
and 256,

Figure 138. Change Number of Colors dialog box

2 Type the number of colors you want in the Number of colors box. You
can specify any whole number between 2 and 256.

3 Select Apply to apply the changes.

Notice that the Number of colors box in the LUT window now displays
the number you specified and the histogram changes to display the new
colors.

4 Click Close or Cancel to close the dialog box.

APPLYING PREDEFINED LUTS TO IMAGES

You can use MIPAV’s predefined LUTSs to apply pseudocolor, create a
negative of the image, and apply preset CT window and level settings to an
image.

To apply pseudocolor LUTs to images

As you examine an image, you may need to observe small changes in
intensity values or identify the same intensity values in different portions of
an image. This can be difficult if the image is rendered in grayscale because
the human eye can only see about 100 shades of gray. However, because
varied colors are often easier to distinguish, MIPAV allows you to use
various pseudocolor maps to elucidate objects of interest. Thus, MIPAV
provides a variety of pseudocolor LUTs. If you apply a pseudocolor LUT, the
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grayscale intensity values are remapped to color intensity values. Note that
the original image data is not changed; only the displayed image file (hence
the term pseudocolor).

Gray Blue/Red

Spectrum LUT
Red LUT Blue LUT P

Skin LUT
Green LUT Hot metal Cool hot Invert LUT

Striped LUT

Gray LUT

y b »

| ©
g

¥

-,
~,

\4 W=V
F BN
HE B
L S

CTpreset | Editred \ .. blue

EE N
%
A

m &
A A

» > | <

vﬁ?;-

"‘ﬁ

Transfer Save user defined

Reset transfer Edit alpha Edit green

Open user defined
Dual threshold

Figure 139. LUT toolbar

To apply a pseudocolor LUT, click one of the following icons:

B ReqLuT

B Green LUT
B Blue LUT

El Gray blue/red LUT

i Hot metal LUT

W Spectrum LUT

B coolhot LUT

B striped LUT

. € Invert LUT

The grayscale intensity values in the image dataset are remapped to color
intensity values.
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To invert intensities
To invert the intensities so that a negative of the dataset appears, click € ,
the Invert LUT icon. The Invert LUT icon is in both the Look-up Table
window (Figure 16 on page 26) and the MIPAV window. Figure 19 on
page 30 shows the location of this icon in the Look-up Table window.
To apply CT level presets to images
There are six CT window and level presets: abdomen, head, lung,
mediastinum, spine, and vertebrae. To apply a preset level to the image,
complete the following steps:
(==}
1 Click *", the CT Preset icon, in the LUT window. The CT Presets dialog
box appears (Figure 20).
L CT Presets
- CT presets(level, window)
1 Abdomen (50, 250
) Head (30, 130
3 Lung £-550, 2000
) Wlediastinmuz (50, 450)
(1 Spine (40, 300}
. (2 Vertebrae (330, 2300)
OK H Cancel
Figure 140. CT Presets dialog box
2 Select the desired CT preset. As you select the CT preset option, the
colors in the image’s histogram or LUT change, and, if you chose to
update images in real time, the image changes.
3 Click OK to save the change.
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ADJUSTING CONTRAST USING THE TRANSFER
FUNCTION

The transfer function reflects the relationship between the original image
intensity values and how they are mapped into the LUT. An example of how
adjusting the transfer function affects the display of an image appears in
Figure 16. In this example, the top image is generated by applying the linear
transfer function (slope = 1) to produce display values that are evenly
distributed over the range of the LUT (see Figure 141A). This results, in this
case, in a low-contrast image (see Figure 141B). The contrast of the image
can be improved by adjusting the transfer function in a manner shown in
Figure 141A (e.g., changing a low-contrast image into a high-contrast
image). The image scalar values between —175 and 275 are remapped as a
function of the modified transfer function and distributed across the full
LUT range. The values above 275 are remapped to white and the values
below —175 are remapped to black. The effect can be readily seen in

Figure 141B.

To modify transfer functions
1 Open an image. The image appears in the default image window.
2 Click ., the Displays Look-up Table (LUT) icon. The Look-up Table
dialog box opens.
3 Click the transfer function. A new node may appear.
4 Drag the node to the new location.

You can also adjust the transfer function for the alpha, red, green, and
blue channels in an image.

Example: You might want to use these icons to highlight certain intensities in a
% particular color.

To do this, click the appropriate one of the following icons:
. A , the Edit Alpha icon

. B , the Edit Red icon
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. -, the Edit Green icon

. n, the Edit Blue icon

When you click on one of these icons, the transfer function for that
channel appears on the histogram and a hode appears on that transfer
function. Drag the node to the desired position. To adjust another

channel, you must click on the icon and drag the node to the appropriate
position.
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S kidney 11/21 M:1.0 =]

¥dkidney 11721 M:1.0 EBX

(B} The image after changing the

(A} The original image before changing
transfer function

the transfer function

L Lookup Table: kidney E| =) E'

I Lookup Table: kidney

I EEEENI NN NG| (FEEEERENIBRE NG
DPmD® AHEE & E NOm?% AHEBE B E

Imaged | ImageA |
v Update (real-time) Number of colors; ¥ Updste (real-time). Number of colors:
¥l Log scals (Histogrm).  LUT: Vi Logscale (Histogram).  LUT:
(] Tnterpalate image (1 Interpolate image
310611 5 310611
C c
L] L]
L u L u
5 = 57
1 L §
| “ [ 24
L 3
L2 2
3 i L
9715 6280 1450
4833 1450 2472
Image Intensities

Image Intensities

(C) The original transfer function (D) The modified transfer function

Figure 141. An image before and after modifying the transfer function
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To save transfer functions

To save a transfer function to a file, complete the following steps:

1 Select File > Save Transfer Functions (Figure 142) in the Look-up Table

window, or press Ctrl S. The Save dialog box (Figure 143) appears.

]
[ Open LUT k0
To save a LUT, select the m Save LUT Chil-5

Save Transfer Functions

command. E Open User Defined LUT i

* B Swve Transfor Functions
Close LUT Ctikx

Figure 142. Open and Save commands in the File menu

2 Type a name to the transfer function in the File Name box. Be sure to

add the .fun extension to the file name.

Sovele | HIONEY - [=[a[c| B

Remember to type
“fun”at the end of
the file name.

L

FileMame:  KidneyL LT fur| i
Files of Type: | Transfer Function Files (*fun) & 5

|

| smwm |

Figure 143. Save dialog box

3 Click Save. The program saves the transfer function under the name you

specified.
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To apply previously saved transfer functions

To open a transfer function file and apply it to an image, complete the
following steps:

1 Select File > Open Transfer Functions in the Look-up Table window.
The Open dialog box appears.

2 Select the desired file. LUT files have a .fun extension.

3 Click Open. The program applies the transfer functions file to the
current image.

To save LUTs for later use

1 Select File > Save LUT in the Look-up Table window, or press Ctrl S.
The Save dialog box (Figure 144) appears.

saveln | Cucom v [l (e (ol 8]

2
Il‘_'l CORONAL SER
dicom_sauittals

I SHANLEY_ROBERT _

File Mame: [kiéneyL UT lul
Files of Type: | Look-Up-Table Files (*ut) v

| saw || concol |

Figure 144. Save dialog box

2 Type a name for the LUT in the File Name box. Be sure to add the .lut
extension to the file name.

3 Click Save. The program saves the LUT under the name you specified.

To open and apply previously saved LUTs to images

1 Select File > Open LUT in the Look-up Table window, or press Ctrl O.
The Open dialog box (Figure 25) appears.

2 Select the desired file. LUT files have a .lut extension.
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3 Click Open. The program applies the LUT settings from the LUT file you
specified to the current image file.

I Open @
Lookin: | Cimages MRS
[} 1500023_1_i_jinbut

[ 1500923_1_r_jbaut [y cropaa
[} anateacpedut
[} anat+acpe 1t
[y anat+orig.u [} genormeorp2 1.t

[} brain.ut [ GradientMagnitudeHead ut
ET

[0} tunc+ orig.ut
D penarmcorpiut

- I [

File Name: [anateacnct lut

Files of Type: ;!.amrmms(‘hl) ot

D cardiacedges.jut
|
|

| oven || concel |

Figure 145. Open dialog box

To open, save, and apply frequently used LUTs

For a LUT that you defined and expect to use frequently, MIPAV provides a
simple method for saving, opening, and applying it without needing to use
the commands on the File menu. You use two icons on the toolbar in the
Look-up Table window:

- E , the Save User-Defined LUT icon, allows you to save the LUT.

- E , the Open User-Defined LUT icon, provides a very quick way of
opening and applying the user-defined LUT

Recommendation: Because these icons only apply to one user-defined LUT,
it is recommended that you select the LUT that is used most frequently.
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To reset original LUTs to images

Click E , the Grayscale icon in the Look-up Table window (refer to

Figure 16 and Figure 19). Alternatively, you can click IR, the Reset LUT icon,
in the MIPAV window.

To adjust the threshold
1 Open an image. The image appears in the default image window.

2 Click . the Displays Look-up Table (LUT) icon. The Look-up Table
dialog box opens.

3 Click BE | the Dual threshold function icon. The Threshold icon becomes
active and the transfer function of the histogram changes.

4 Select Algorithms > Threshold. The Threshold dialog box (Figure 26)
opens.

Set lower limits
between (1.0—
3774.0)

Threshold limit for the
lowest image intensities.

4 Threshold .

Set threshold
between
(1258.3334—-3774.0)

~Thresholds -

Set lower lveat between { 1.0- 2600, [27.0
Set upper Lt between { 87.0- 2600 ). (1740

Threshold limit for the
highest image intensities.

[w] Produce binary image

Produce binary image

Produces a binary image ”Setvalu.es ontgide of limits to:
(Boolean) . [ Destination

~Threshold

Set values outside of
limits to

Specifies the intensity value '8 N e ® Whale image

to assign to values outside | Sy S50 e
the threshold limits.

0K | | Cancel

New image

Shows the results of the
algorithm in a new image
window

Replace image

Replaces the current active image with the results of the algorithm.

Whole image

Applies the algorithm to the whole image.

VOI regions

Applies the algorithm to the volumes (regions) delineated by the VOlIs.

OK

Applies the changes you made in this dialog box and closes the dialog
box.

Figure 146. Threshold dialog box
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Cancel Disregards any changes you made in this dialog box, closes the dialog
box, and does not change the threshold.

Help Displays online help for this dialog box.

Figure 146. Threshold dialog box (continued)

5 Complete the dialog box.

Note: You can choose to generate a binary image (Boolean) by selecting the
Produce binary Image check box. Alternatively, you can clear the binary option
and enter a threshold value. If you still want to generate a Boolean image, select
the check box again. Note that, if you generate a Boolean image, MIPAV does not

allow you to reapply the threshold or to generate either a histogram or LUT for a
Boolean image.

6 Click OK to apply the threshold.

Displaying images using the animate view

If you select the animate view, the software makes a copy of the image
dataset and loads it into an image window showing the animate view. In
animate view, like cine view, the software automatically advances through
the entire image dataset. However, the animate view allows you to adjust
the speed at which images are advanced. You can specify that images be
displayed in forward or reverse order. You can also pause or stop the
sequence.

To view an image dataset in animate view

1 Select Image > Views > Animate in the MIPAV window. The Animate
Parameters dialog box (Figure 27) appears.

2 Type the scale factor that you want to use in the Scale factor box.
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Scale factor

Changes the size of the dataset by the factor
specified.

e
& Animate Parameters

Unlike magnification, the number of voxels used
to replicate the image may change. For .

example, if you scale a dataset by a factor of 2, |Scalle et Lo
the image becomes twice the original size, and | Interpalation: Bilinear i
the number of voxels is squared.

I'Scale paramens

Interpolation

Determines the intensity of the additional voxels using one of the three following
methods:

Bilinear—Weighs the average of the four nearest voxels (to the newly interpolated
voxel). The interpolated voxel is assigned the resulting intensity.

Bspline 3rd order—Weighs the average of the 27 nearest voxels (to the newly
interpolated voxel).

Bspline 4th order—Weighs the average of the 64 nearest voxels (to the newly
interpolated voxel).

OK Applies the scale factor and interpolation to the image dataset according to the
specifications in this dialog box.

Cancel Disregards any changes that you made in this dialog box and closes this dialog box.

Help Displays online help for this dialog box.

Figure 147. Animate Parameters dialog box

3 Select one of the three interpolation methods.
4 Click OK.

MIPAYV transforms the dataset using the scale factor and interpolation
method you indicated. A progress message (Figure 28) appears while
the program constructs the animated file. It then loads a copy of the
dataset in the Animate window.

52 brain 50% M[=1/E3]

Constructing animation structure...

[ | 5009

Figure 148. Animate progress message
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The slice number also
. appeats in this read-
¥4 brain M:1.0 only box,
File Options
(=20 [ RS @ & | | X
Frama mumber (1 - 134)
Diesized frames pex second. 50
The slice number, or
frame number, appears
on the lower left side of
the image. If you select
Options = Show Z Slice
Numbers.
File Save Image as .avi—Saves the dataset as an AVI, or digital video, file.
Close Animate—Closes the Animate window.
Options Show Z Slice Numbers—Displays, if selected, the slice number, or the frame

number, on the lower left side of the image.

Continuous

Steps through all of the images in the dataset continuously in reverse without
stopping at the speed specified in Desired frames per second.

reverse
Steps through all of the images in the dataset once in reverse at the speed
EleniErae specified in Desired frames per second.
Steps through all of the images in the dataset once in sequence at the speed
Forward specified in Desired frames per second.
Steps through all of the images in the dataset continuously without stopping at
= Eari G the speed specified in Desired Frames per second.
forward
Steps through all of the images in the dataset in sequence and then in reverse
T continuously without stopping at the speed specified in Desired Frames per

and forward

second.

Figure 149. Image window shown in the Animate view
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Pauses the animation at the frame currently shown.

Pause
Halts the animation and redisplays the first image in the dataset.

Stop
Magnifies the image by 2.

Magnify
image 2.0X

Magnifies the image by one-half.

Magnify

Specifies the brightness and contrast of the image. When you select this icon,

i Set the Brightness/Contrast dialog box opens. To change the brightness, slide the
brightness/ Brightness slider to the level desired and then click Apply. To change the
contrast contrast, slide the Contrast slider to the level desired and click Apply.

x Removes the slice currently shown in this window from the image dataset.

" Delete

current slice

Caution: The program does not allow you to undo slice deletion. Before you
delete slices, you may want to have a backup of the complete image dataset to
avoid losing images.

Frame number

Sets the first image slice shown to the frame, or slice, number that you specify.
Notice that the frame number appears in the box to the right of the slider.

Desired frames
per second

Specifies how many frames, or slices, should appear in 1 second. The read-only
box to the right shows the actual number of frames per second your computer
has achieved. The number of frames per second depends on the amount of
memory accessible by the computer and CPU time.

Figure 149.

Image window shown in the Animate view (continued)

ADJUSTING DATASET DISPLAY

You can magnify or reduce the display of your dataset using the

magnification icons. Use
image to twice its current size.

, the Magnify image 2.0x icon, to enlarge the
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ADJUSTING THE BRIGHTNESS AND CONTRAST

IN IMAGES

To adjust the brightness and contrast in the image, do the following:

1 Click s , the Brightness/Contrast icon, in the Animate window. The
Brightness/Contrast dialog box (Figure 30) opens.

2 Move the Brightness slider to the position you want. Notice that the
level of brightness changes on the image as you move the slider.

3 Move the Contrast slider to the desired contrast level. The contrast in

the image changes as you move the slider.

4 Click Apply when you are finished. The image in the Animate window
reflects the changes in brightness and contrast that you made.

5 Click Eﬁ, the close button at the top right of the dialog box, to close the

dialog box.

Brightness

Specifies the level of brightness to apply to the
image.

Contrast

Specifies the level of contrast to apply to the image.

Apply

Applies the brightness or contrast you specified to
the image.

Cancel

Disregards any changes that you made in this dialog
box and closes this dialog box.

Help

Displays online help for this dialog box.

[’;‘] Brightness/Contrast

[ Brighiness -

235 L]

235 |

- Conirast—

X

Figure 150. Brightness/Contrast dialog box

REMOVING SLICES FROM IMAGE DATASETS

In the Animate window, you can also remove slices from the dataset. First,
you need to find the slice that you want to delete. To find a slice number, do

either of the following:
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e Select Options > Show Z Slice Numbers, which shows the slice number
at the lower left of the image (refer to Figure 29 on page 40).

e Move the Frame Number slider to the slice that you want to delete. The
number appears in the box on the right of the slider.

The slice nurmber appears in the
read-only box to the right of the
Frame number slider.

Frare rureber (1 - 18)

Desired frames per second: 50 0 U4

1 50 EI/
This read-only box shows the actual
number of frames per second.

Figure 151. Slice number in the read-only box beside the Frame Number
slider in the Animate window

Once you locate the slice that you want to remove, click x , the Delete icon.
The slice is removed from the dataset.

Caution: The program does not allow you to undo slice deletion. Before
you delete slices, you may want to have a backup of the complete image
dataset to avoid losing images.

PLAYING A DATASET “FILM”

Using the icons and buttons on the toolbar in the Animate window
(Figure 29 on page 40), you can produce and play a dataset “film.” To do so,
complete the following steps:

1 Move the Frame number slider to the slice that you want to see first.

2 Move the Desired frames per second slider to indicate the speed at
which images should be advanced or reversed.

3 Click the following buttons as appropriate:
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Click < , the Forward icon, to advance the image dataset forward
through all of the images one time (one loop).

Click = , the Reverse icon, to advance the image dataset backward
through all of the images one time (one loop).

Click » , the Continuous Forward icon, to advance the image dataset
forward through all of the images multiple times. To stop image

advancement, you must press "' the Pause icon, or E , the Stop
icon.

Click @ , the Continuous Reverse icon, to advance the image dataset
backward through all of the images multiple times. You must press the

press "' the Pause icon, or : , the Stop icon, to stop image reversal.

. ] . .
Click , the Pause icon, to pause the image advancement or reversal.

Click " , the Stop icon, to stop the image advancement or reversal.

per second and the actual frames per second differ. Although you can type any

% Note: As the images advance or reverse, you may notice that the desired frames

number in the desired frames per second, the actual speed at which the images
advance depends primarily on your computer's processor speed.

4

Save the animate viewer file by selecting File > Save Image as .avi (AVI,
or audio video interleaved, is a Microsoft multimedia format). The
Choose Type of AVI File dialog box (Figure 32) opens.

5 Select a type of file.

6 Click OK. The program runs the animation sequence that you created,

closes this dialog box, and then displays the Save dialog box.
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24-bit An uncompressed RGB file, which uses 8

uncompressed bits per color (red, green, blue). = =

RGB P P ( 9 ) %4 Choose type of AVI file

~Write file as

8-bit RLE A run length encoded (RLE) file that is | 24 bit uncompressed RGB ¥ |

compressed converted to 8 bits and is compressed. M-JPEG quality (0.1 - 1.0): |

Quicktime movie An Apple format. OK

Motion JPEG A format that consists of motion JPEGs.

Mpeg-4 version 2 Another compression format.

OK Plays back the animated sequence that you created and then displays the
Save dialog box for you to save the sequence.

Cancel Disregards any changes that you made in this dialog box and closes this
dialog box.

Help Displays online help for this dialog box.

Figure 152. Choose Type of AVI File dialog box

7 Specify a name for the animation sequence in the File Name box.

8 Click OK. The dialog box closes and the Choose File Type dialog box
(Figure 33) opens.

=¥ 3
kA Choose File Type

ety

AFNI {.brik, .head)
Analyze {img)
AV (.avi)

Biorad {.pic)

BMP {.bmp)
Bruker (.brk)
Cheshire {.imc}
COR (.info)
DICOM {.dcm, .ima)
FITS (fits)

GE Genesis (.sig)
GIF {.gif)

Interfile {.hdr)
JPEG (ipey, jpo)
LSM (.Ism)

4

Figure 153. Choose File Type dialog box
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9 Select afile type.

10 Click OK. The Save Range of Slices dialog box (Figure 34) opens.

11 Close the Animate window by either selecting File > Close Animate or
pressing Ctrl X. The Animate window closes.

Save image to
separate files

Saves the animation to separate files.
Selecting this check box makes the
First file starting number text box and
the File name number of digits text box
become active.

Save range of slices

X

~General Options

[7] Save irage to separate files

First file Indicates which frame, or slice, to
starting begin the first file saved. To make this
number box active, you must first select Save T N S
image to separate files. '
First Slice 1
File name Specifies how may digits you want used I 4
number of for the file name. To make this box
digits active, you must first select Save image ~Choose Range of Time Periods to Save
to separate files. e
First slice Specifies the first slice that should
appear in the animation file. IFF Options
Last slice Specifies the last slice that should ,
appear in the animation file.
0K ‘ ‘ Cancel
First time Specifies the time period of the images that should start the file. This box only
period applies to 4D images.
Last time Specifies the time period of the images that should end the file. This box only
period applies to 4D images.
Save with Indicates that the file should be saved as compressed TIFF files. This check box
packed bits only applies to 4D images.

compression

OK Saves the animation according to the specifications in this dialog box and closes
the dialog box.

Cancel Disregards any changes that you made in this dialog box and closes this dialog
box.
Help Displays online help for this dialog box.

Figure 154. Save Range of Slices dialog box
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Displaying images using the cine (movie) view

The cine view, like the default view, displays images one at a time in the
default image window. However, in cine view, the software automatically
advances the images.

To display a 3D or 4D dataset in this view, select Image > Views > Cine
(Movie). The images appear sequentially in the default image window. All
images in the dataset are displayed only once. The cine view does not loop
images, nor does it show images in reverse order.

Displaying images using the lightbox view

You can use the lightbox view to display datasets that have more than two
dimensions (2D). Like its real-world counterpart, the lightbox view displays
several images, or slices, in the dataset at one time in an image window.
Through the lightbox settings, you can easily control the number of slices
that appear.

To view an image dataset in lightbox view

1 Open an image dataset that has more than two dimensions. It appears in
the image window in default view (Figure 35).

2 Select Image > Views > Lightbox in the MIPAV window. The image
window for the lightbox view appears (Figure 35). The image number,
or slice number, appears in the lower left corner of each image.

Notice that the image you originally opened in step 1 remains on your
desktop. So you not only see the image dataset in the lightbox view, but
you also see the image in the default view.
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Using the lightbox view to update the image
slice displayed in the default view

The MIPAV window allows you to step through all of the slices of an image
dataset shown in the default view one at a time using the Image slice slider,

. , the Decrements image slice icon, and » , the Increments image slice
icon. However, the default view only shows one slice at a time, but the
lightbox view can show two or more slices at one time depending on the
lightbox settings (that is, you can control the number of image slices that
appear in lightbox view; refer to “Adjusting the lightbox view” on page 50).

Suppose it is easier for you to find a particular slice in the dataset by viewing
several slices at the same time in order to compare them against each other.
To do so, you would open an image dataset in default view and then display
the dataset in lightbox view. The lightbox view displays the number of image
slices that you had already specified.

At this point your desktop shows both the image dataset in default view and
the dataset in lightbox view. The lightbox view allows you to quickly look
through the entire dataset until you locate the correct slice. Once you find it,
you may want to perform some actions, such as running algorithms, on that
slice. To update the image in the default view to display the slice you located,
first select and then right-click the image slice in the lightbox view. The
default image window now shows the image slice you found.
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Edit Select All—Selects all of the slices in
the dataset.

%910 10637 _4 w88 [C|ER

Edit View Options

Ha w | >

Select None—Deselects all of the
selected slices.

Invert Selections—TBD.

|. . . .{ﬁﬁaulﬁm ;:

Delete—Deletes the selected slices
from the dataset.

Extract—Copies the selected slices
to a separate image window, which
you can save as a separate dataset.

View First Page—Displays the first set* of
slices in the dataset.

Previous Page—Displays the
previous set* of slices in the dataset.

Next Page—Displays the next set*
of slices in the dataset.

Last Page—Displays the last set* of
slices in the dataset.

Options Settings—Allows you to change
settings for the number of rows and

columns used to display images in

the dataset, change the grid size and
the size of the frame border, change
the colors of the borders and frames,
and the level of magnification.

The lightbox view in this example
shows only one column with two
rows of images. However, you can
easily change the number of columns
and rows in the Lightbox Settings
dialog box. So,in the lightbox view,

you can see multiple slices of the
image dataset at one time, which
helps in comparing slices orin finding
a particular slice.

Save Settings—Saves the settings
currently set in the Lightbox Settings
dialog box.

Continuous Update—Updates all of
the displayed images when you make
a change to one of the images.

Displays the images according to the standard settings used by MIPAV when

Default mode it is initially installed.

& Magnifies a portion of the image from 1 to 32 times. To change the level of
. . magnification or the size of the magnifier, right-click on the image, and the
M
ALY (EEIEn Magnification dialog box opens.

Figure 155. Image window showing the lightbox view

*The set of slices depends on the number of slices currently being displayed. For example, if four slices are currently
displayed, then View > Previous Page shows the previous set of four slices. If seven slices are currently displayed, then
View > Previous Page displays the previous seven slices in the dataset. View > Next Page works similarly. It displays the
next set of slices in the dataset.
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Updates the images displayed in the lightbox reflecting the changes made
. to the lightbox settings and to the dataset.
Repaints
images

Removes the selected slices from the image dataset.

* Delete selected
slices

Makes a copy of the selected slices in the image dataset to a new image

Extract window.

selected slices to a
new image

Displays the first set* of slices in the dataset.

S
First page

Displays the previous set* of slices in the dataset.

Previous page

Displays the next set* of slices in the dataset.

Next page

Displays the last set* of slices in the dataset.

Last page

Displays the currently selected slice.
BEE
ooog

Go to active

slice

Go to slice Specifies which slice you want to display. Type a number in this box and
then select Enter to display the slice. The slice then appears in the lightbox
view.

Image window Displays an individual slice in the dataset. To select a slice, click once on the
slice. A thin red line appears around the slice inside the border.

Border Outlines each slice.

Background Provides the grid for the images in the window.

Figure 155. Image window showing the lightbox view (continued)

*The set of slices depends on the number of slices currently being displayed. For example, if four slices are currently
displayed, then View > Previous Page shows the previous set of four slices. If seven slices are currently displayed, then
View > Previous Page displays the previous seven slices in the dataset. View > Next Page works similarly. It displays the
next set of slices in the dataset.
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Adjusting the lightbox view

By default, the lightbox view shows only one column of images. Each image
in the dataset is surrounded by frame borders and background (Figure 36).
However, you can adjust the lightbox view so that you can see several
columns and rows of images at a time (Figure 36) in a grid. You can also
adjust the borders and the default magnification level of the images.

To change the grid configuration

1 Select Options > Settings in the image window for the lightbox view. The
Lightbox Settings dialog box (Figure 37) appears.

» jonescardiac M:0.BB

Edit View Options

k Q’ E > B Border color |

& & B » Bowdie:| |

In this example, the grid
is 3 by 3.

Figure 156. Lightbox view after increasing the number of rows and
columns that appear in the window
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2 Select Row.
3 Type the number of rows you want to appear in No. rows.
4 Select Column.
5 Type the number of columns in No. columns.
Row Selects the row settings.
Column Selects the column settings. ¥4 Lightbox Settings
[ Lighthox layout settings
No. rows Specifies the number of rows that  Rowfcolumn
should exist in the lightbox view. i Row # Column
No. columns Specifies the number of columns Mo.Rews: I | Mo Colwus: 2 |
that should exist in the lightbox  Grid size
view. s | Gridspaing=3
Grid size Indicates the spacing in pixels [ e stz _
used for the grid size. BB |Bomersie=3
[ Color settings
Frame border slice Indicates the spacing in pixels Barkgrowd color: P
used in the grid. | Border color: | E—"]
i Magnification
Background color Allows you to choose the color of = .
the background of t'he:' lightbox. e e o
When you select this icon, the ==
Pick Background Color dialog box ‘ Apply H Reset H Close

opens.

Border color

Allows you to choose the color of the border that surrounds each image
displayed in the lightbox. When you select this icon, the Pick Border Color
dialog box opens.

Magnification

Controls the level of magnification.

Apply Applies the parameters that you specified to the lightbox view.

Reset Returns all of the parameters to their default values.

Close Closes this dialog box without making changes to the lightbox view. If you
changed the parameters in this dialog box, you must first select Apply to put
those changes into effect.

Help Displays online help for this dialog box.

Figure 157. Lightbox Settings dialog box

6 Click Apply. Notice that the number of rows and columns in the lightbox
view changed to the numbers you specified.
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7 Continue to make changes to other lightbox settings.
8 Click Close to close the Lightbox Settings dialog box.
9 Click Options > Save Settings to save the settings as the default number

of rows or columns for the next time you display the lightbox view.

To change the grid size

1 Select Options > Settings in the image window for the lightbox view. The
Lightbox Settings dialog box (Figure 37) appears.

2 Type a number from 0 to 20 in Grid size (Figure 38).

% Note: On the right of the Grid size text box, Grid spacing shows the current grid
size.

[ Grid size

|15 Grid spacing = 5

Figure 158. Grid size box

3 Click Apply. Notice that the grid size in the lightbox view changed to the
size that you specified.

4 Continue to make changes to other lightbox settings, or click Close to
close the Lightbox Settings dialog box. The image window for the
lightbox view appears.

5 Click Options > Save Settings (Figure 39) to save the settings as the grid
size for the next time you display the lightbox view.
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w | To keep the changes you
made to the settings,
Seﬂings / select Options > Save
= Settings.
[J Continuous update
Figure 159. Save Settings command on the Options menu in the
Lightbox Settings dialog box
In this lighthox view, the blue
lines are the grid.
[ & B | B cowsiice:
The light lines surrounding the
grid are the border.
Figure 160. Grid and frame border
To change the border size
1 Select Options > Settings in the image window for the lightbox view. The
Lightbox Settings dialog box (Figure 37 on page 51) appears.
2 Type a number from O to 10 in Frame border size (Figure 41). The unit
of measurement for the number is in pixels.
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Frame honler size

IE Border siza = 3

Figure 161. Frame border size box

3 Click Apply. On the right of Frame border size, Border size changed to
the size you specified.

4 Continue to make changes to other lightbox settings, or click Close to
close the Lightbox Settings dialog box.

5 Click Options > Save Settings to save the settings as the default border
size for the next time you display the lightbox view.

To change background and border colors

1 Select Options > Settings in the image window containing the lightbox
view. The Lightbox Settings dialog box (Figure 37 on page 51) appears.

Notice that Background color displays the color of the current grid
border, and Border Color shows the color of the current frame border.

2 Click the background color bar (Figure 42).
The Pick Background Color dialog box (Figure 43) opens.

Select the bars to
change the background
and border colors,

Color settings
Background color: _
Border color: =l

Figure 162. Background color and border color bars
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This dialog box includes three tabbed pages:

» Swatches page (Figure 43), which, by default, is always displayed
first

» HSB page (Figure 43)

* RGB page (Figure 43)

You can change the color of the background on any of these pages

Pick background color

Recent:
[

| ok || cancel || Reset |

Figure 163. Swatches page in the Pick Background Color dialog box

3 Select a color from the Swatches, HSB, or RGB page. (For instructions
on how to select colors, refer to “Manually creating a mask using paint”
on page 279 in Chapter 6, “Segmenting Images Using Contours and
Masks™).
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Figure 164. HSB page in the Pick Background Color dialog box

4 Click OK to apply the color to the background or border.
The Pick a Background Color dialog box closes, and the Lightbox

Pick background color

| ok || cancel || Reset |

Settings dialog box appears.

5 Click Apply.

Notice that the color of the background or border colors in the lightbox

view changed to the colors you specified.

Figure 165. RGB page in the Pick Background Color dialog box

Pick border. color

g
Red | i { i | i | 255
o 85 170 255
Green | I I | 255',—j
1] 85 170 265
Blue O| 255
0 85 170 255
| ok || cancel || Reset |
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6 Continue to make changes to other lightbox settings, or click Close to
close the Lightbox Settings dialog box.

7 Click Options > Save Settings in the lightbox view to save the settings as
the default background and border colors for the next time you display
the lightbox view.

To change the default magnification level for one
slice in the dataset

1 Click & .

2 Right-click on the image. The Magnification dialog box (Figure 46)
opens.

3 Change the magnification level by sliding the marker on the
Magnification slider to the level you want.

4 Select Display intensity values if you would prefer to see the intensity
values in the magnified region rather than the magnified image.

Slide the marker to the E;E LO_10637 _4 Extract1
right or to theIEf.r.to ]
:E&:‘I‘Jr:ft the magnlflcat‘lgl-““‘ M {feation— A

ﬂ . To enlarge or reduce the size

of the magnified region,
1.0 4.0 320 specify a value from 64 to 390
B b, (ST deraiter wealiee in Width.
AN sie
Select this check box to d
view the intensity values Width: ]1 29 k[
in the magnified region.
Apply || Close |
Figure 166. Magnification dialog box

5 Type a number from 64 to 390 to enlarge or reduce the size of the
magnified region.

6 Click Apply. The settings specified in the Magnification dialog box take
effect immediately and only for that one image, or slice.
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To enlarge or reduce the size of all images

1 Select Options > Settings in the image window containing the lightbox
view. The Lightbox Settings dialog box opens (Figure 37 on page 51).

2 Select the level of magnification by moving the slider right or left to the
appropriate value.

3 Click Apply. Notice that the image magnification changed to the
magnification you specified.

4 Continue to make changes to other lightbox settings, or click Close to
close the Lightbox Settings dialog box.

5 Click Options > Save Settings in the lightbox view to save the settings as
the default magnification for the next time you display the lightbox
view.

Tip: To return to the original settings for the lightbox view, click Reset in the
Lightbox Settings dialog box.

In the example shown in Figure 47, the researcher changed the original
lightbox view (Figure 47A) in several ways. The number of rows was
increased from two to four and the number of images in each row from two
to three. The frame border color was changed from yellow to gray and the
grid color from blue to black. Also the magnification level of the images was
reduced to 38 percent of the original image size. Figure 47B shows the final
lightbox view.

Repainting (updating) the lightbox

You can simultaneously display the same dataset in different views on your
desktop. For example, you can display the dataset in default view and in
lightbox view. If you perform an action on the dataset that is visualized in
default view, such as contour a structure, you can update the dataset display
so that the contours also appear in lightbox view. You can do this
automatically or manually.

To automatically update the dataset in the image
window

Select Options > Continuous Update in the lightbox view. The dataset is
refreshed whenever a change occurs in the default image window.
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Caution: Although this option is convenient, it may slow software
response time if you are working with a large dataset.

To manually update the dataset in the image window

Click ¥ , the Repaint icon, from the toolbar in the lightbox view.

To close the Lightbox window

Click E in the upper right corner of the Lightbox window. A confirmation
message (Figure 48) appears. To close the window, click Yes and the
Lightbox window closes. If you change your mind about leaving the lightbox
view, click No.
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S kidney_aug15_sers M:1.0

Gl View Optians .
% kidney_augl5_serS M:0,57

AW B Edlt View Optioms

@ o W el lf'&m B

[ & b B B co o siice:

- -

(A} Original lightbox view (above)

(B) Changed lightbox view (right) L=

Figure 167. Some of the display options available in lightbox view:
(A) original lightbox view (image on the left) and (B) changed lightbox view (image on the
right).

Light Box close

Do you really want to close the Light Box?

ves || Mo

Figure 168. Lightbox Close message
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Displaying images using the link to another
image view
At times you may want to compare two images slice by slice side by side.

Linking one image to another allows you to make this type of detailed
comparison.

To compare images side by side

1 Open the two images you want to compare.

2 Select one of the images. This image becomes known as Image A, and
the second image becomes known as Image B.

3 Select Image > Views > Link to Another Image. The Image Frame
Linker dialog box opens.

4 Select the name of the second image, or Image B, in the Image B box.
5 Click Link. MIPAV immediately connects the images.

6 Move the Image slice slider in the MIPAV window. Notice that the
image slices change on both images so that Image B shows the exact
same slice as shown on Image A.

in Image B, they do not change in Image A. The reason is that only Image A
controls the simultaneous movement of slices for both images. Therefore, when
you select an image to be Image A, make sure that the image is the one you
want to control the movement of both images.

V Tip: Select Image B, and move the Image slice slider. Although the slices change

Image A Indicates the name of the Image A file. This field is a
read-only field.

4 Image Frame Linker
Image B Allows you to choose the open image that you want to Link fo:
use as Image B.

Image &: LO 10637 41 clone

Link Links the two image files. Image B: |LO 10637 41 w

Cancel Disregards any changes you made in this dialog box, ‘ e H o ‘
closes the dialog box, and does not link the images.
Help Displays online help for this dialog box.
Figure 169. Image Frame Linker dialog box
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Displaying images using the triplanar view

The triplanar view allows you to see three orthogonal planes of 3D or 4D
datasets. The three orthogonal views enhance the visualization of important
aspects of the anatomy and, in some cases, aids some manual segmentation
processes.

Displaying image datasets in triplanar view

To view an image dataset in triplanar view, open an image and then select
Image > View > Triplanar in the MIPAV window. The triplanar view
(Figure 50 on page 62) appears in an image window.

The image window for the triplanar view includes a File menu, an Options
menu, a toolbar, and three views of the dataset. The bottom right corner of
the window displays the currently selected coordinate. Two guidelines
(cross hairs) also intersect at the selected point. Additionally, the axis
appears in the upper left corner in each view of the dataset.

You can use icons and buttons on the toolbar to change the magnification
level, draw a point or line, apply paint, and apply a new intensity values to
selected voxels in the image.

Designating new center points for image datasets

You can designate a new center point for the dataset. To do this, complete
the following steps:

AT

1 Click * , the Volume Center icon, to display the center of a volume. The
cross hairs intersect where the center of the volume has been calculated.

2 Drag the cross hairs to the point that you want to designate as the new
center.

3 Release the mouse button.

4 Click Apply. The Apply Transformation Matrix dialog box (Figure 51 on
page 65) opens.

5 Complete the dialog box.
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¥{1L0_10637 4 M:1.0
File Options

g| 2 K | A| FL wy | 5 X Crop | ACPC  Tahairach
l 2w @ [ | 0 -‘n|n0pmity|(:omﬁt|'-";-‘ﬂ

Ahsolute

X127 R: 0.038
¥:al F: 2.800
£ 127 I: 0.900
File Close frame——Closes this window.

Figure 170. Image window showing the triplanar view

MIPAYV User’s Guide, Volume 1, Basics 228
9/20/04



Chapter 6, Visualizing Images

N PAN/

Necicet Inage Frecess oAty s &M= atizztion

Options Show Axes—Displays the XY (top left), ZY (top right), and ZX (bottom
left) axes on the images.

Show Cross Hairs—Displays cross-hair lines on the images. When you
move these lines on one image, it also moves to the corresponding points
on the other two images. Notice that the Absolute and Position values at
the bottom right of the screen also change when you move the cross
hairs.

Show Talairach Grid—Displays a Talairach (stereo tactic) grid on the
images.

Show Talairach Position—Lists the Talairach position.

Link to Another Trilmage—Links this image to another image in
triplanar view.

Aligns two images.
Traverse image

Magnifies the image. It might be necessary to manually resize the
28 Magnify window and use scroll bars to view all of the image.

Minifies the image (reduces the magnification level).

Minify

I Displays image at the original magnification level.
. Original
magnification

Reassigns a new center to the dataset. The location that you select
appears in the center of the image window.

C-PT

Volume center

Allows you to apply a transformation matrix to an image dataset.

Alignment tool

Applies the rotations and translations made to the image.

Ty
Apply

or Draws a point on an image.

Point

Assigns the subsequently drawn contour to a new group. If this icon is

HEL not selected, all subsequent contours are assigned to the existin roup.
New Contour ’ “ g g group

Deletes a single contour or a group of contours.

e
Delete Caution: When you select this icon, the contour is not copied to the

clipboard. It is permanently deleted.

Figure 170. Image window showing the triplanar view (continued)
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Indicates the volume that should be cropped.
Crop Volume

Crops the specified volume.
Crop

Crop
Selects paint brush tool. You can use the paint brush to fill specific voxels
~ Paint Brush with color.
Changes the default intensity to the one sampled by the eyedropper.
E Click this icon, then move the pointer to the image. The sampled
yedropper

intensity becomes the default intensity.

Applies the paint grow segmentation method. This method uses voxel
aggregation to group voxels into larger regions. The effect is much like a
fill operation; when you click a voxel, this algorithm is used to determine
whether adjacent voxels should be filled with the default color or
intensity.

—— Paint Grow

Deletes painted sections of the image. To delete, click the icon and move

Frese the pointer on painted areas of the image.

Deletes all paint from the image.
Global Erase

Used with the paint brush and erase icons. Click this icon to indicate the
size of the eraser or the paint brush tip. Click this icon to paint or erase

Small Tip . . .
one voxel each time the mouse button is clicked.
Used with the paint brush and erase icons. Click this icon to indicate the
" Medium Tip size of the eraser or the paint brush tip. Click this icon to paint or erase
16 voxels (4 x 4 square) each time the mouse button is clicked.
Used with the paint brush and erase icons. Click this icon to indicate the
Large Tip size of the eraser or the paint brush tip. Click this icon to paint or erase

100 voxels (10 x 10 square) each time the mouse button is clicked.

Indicates the intensity value.

Paint Intensity

Changes the color of the paint used. This icon is often used in conjunction
with the Paint Brush and Paint Grow icons. Click this icon and select the

. Change Paint desired color from the window that appears.

Color

Indicates the opacity level of the paint. When this icon is clicked, a

AL Opacity window appears that allows you to indicate the opacity of the paint: O is
transparent, 1 is opaque. By default the paint is translucent (0.3), which
allows you to see the original image under the paint.

Figure 170. Image window showing the triplanar view (continued)
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Permanently applies intensity level to the image.
Commit A
Commit

Figure 170. Image window showing the triplanar view (continued)

6 Click Apply. A progress message appears as the image is transformed. In
a fewmoments, the new image either appears in a new window or
replaces the image in the current window depending on your choice.

AT

7 Select **  again. Notice that the image center was moved to the center
you designated.

Interpolation Determines the intensity of the
additional voxels using one of the three
following methods:

[P;] Apply transformation matrix

. . [ Interpolation
Bilinear—Weighs the average of the Interpolation] Telinear '|
four nearest voxels (to the newly ! — |
interpolated voxel). The interpolated ”D"’ﬁm‘i"“ﬁspmﬂé s :
voxel is assigned the resulting intensity. ] PIew 20585, line dth order
Bspline 3rd order—Weighs the . v
average of the 27 nearest voxels (to the | ‘
newly interpolated voxel). Amly ‘ St
Bspline 4th order—Weighs the
average of the 64 nearest voxels (to the
newly interpolated voxel).
New image Indicates where the results of the transformation appear. If you select this option,

the transformed image appears in a new image window.

Replace image Indicates where the results of the transformation appear. If you select this option,
the transformed image replaces the current active image.

Apply Applies the transformation to the image dataset according to the specifications in
this dialog box.

Cancel Disregards any changes that you made in this dialog box and closes this dialog
box.
Help Displays online help for this dialog box.

Figure 171. Apply Transformation dialog box showing choices in the Interpolation list
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Aligning image datasets

You can use & , the Alignment Tool icon, to create a new transformation
matrix for the dataset (refer to Figure 52).

The following instructions explain how to use the alignment tool:

1 Click & . A closed angle, which looks like a line that is slightly thicker

on one end, appears on each of the three images displayed in triplanar
view.

2 Click the angle. Arrows appear at the end of each ray. The measurement
of the angle appears beneath the angle.

e willinems_roberi_7002017_5970_8 Mi1.0

o a 1A ;"f.?:; Moty | T ey K Cop | ACPC  Talaleh

After you click the
alignment tool,a line

thatis thicker on one
Msalute Pawition

i e end aPpears c_m all
Vi P2 0000 three images in the
Edl S M5 triplanar view.

Figure 172. Using the alignment tool in triplanar view
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3 Open the angle. The angle degree indicates the direction and distance to
rotate the image. You can open the angle with or without constraints. (If
an angle is opened with constraints, it only opens in 90-degree
increments.) Do the following:

» To open the angle in 90-degree increments: Position the pointer
over the shorter ray of the angle. The pointer changes to a cross-hair
shape. (The cross-hair pointer looks much like a plus sign.) Drag the
shorter ray to the desired location. The new angle measurement
appears below the angle.

» Toopen an angle without constraints: Position the pointer over the
longer ray of the angle. The pointer changes to a cross-hair shape.
The cross-hair pointer looks much like a plus sign. Drag the longer
ray to the desired location. The new angle measurement appears
below the angle.

4 Click Apply. The Apply Transformation Matrix dialog box (Figure 51 on
page 65) appears.

5 Complete the dialog box.
6 Click Apply.

A progress message appears as the image is transformed. In a few
moments, depending on your choice in the dialog box, the new image
either appears in a new window or replaces the image in the current
window.

7 Click + , the Traverse Image icon, to return the cursor to normal mode.

Creating, modifying, and deleting point VOIs

You can create, modify, and delete a point VOI. For more information on
how to do this, see Chapter 7.
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Cropping images
To crop an image, complete the following steps:

1 In animage window that is displaying the image dataset in triplanar

view, click , the Crop Volume tool.

2 Draw a rectangle around the area of the image that you want to remain.
The area outside of the rectangle will be cropped.

3 Click “® . A confirmation box appears.

4 Click Apply. The cropped area appears in a separate window.

Changing the intensity

For information on how to change the intensity of a portion of the image,
refer to “To change the number of intensities displayed in the LUT” on
page 29 and “To invert intensities” on page 31. In addition, refer to
“Generating masks” on page 196 in Chapter 6.

Displaying images using the triplanar-dual view

The triplanar-dual view displays two image datasets (referred to as Image
A and Image B) and a blended version of both Image A and Image B from
three orthogonal planes.

To view image datasets using this view

1 Open two 3D or 4D images, which become known as Image A and Image
B.

2 Load Image B into Image A.

3 Select Image > Views > Triplanar-Dual. The triplanar-dual view appears
in an image window.
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L] " rer
*.¢ anat+acpc... Q@@ ¥4 anat+acpc... b4 anat+acpc ... Q@@

Image A Image B Image B loaded into Image A

Figure 173. Image A, Image B, and Image B loaded into Image A

The image window for the triplanar-dual view is quite similar to the image
window for the triplanar view. The File and Options menus contain the
same commands except for one command—the Options menu for the
triplanar view contains the command Link to Another Trilmage. Since the
triplanar-dual view shows two datasets in the image window and allows you
to manipulate them together, linking to another image is not necessary.
Most of the icons and buttons on the toolbars for both views are the same
with one primary difference: The triplanar-dual view allows you to create
VOlIs on the images; the triplanar view does not.

Like the triplanar view, you can use the icons and buttons on the toolbar to
change magnification, draw, change colors, change opacity, and apply a new
intensity to selected voxels in the images.
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Showing and hiding axes, cross hairs, and Talairach

grid
By default, the triplanar-dual view automatically shows the axes and cross
hairs on Image A, Image B, and the blended dataset.
To show or hide axes on images
To hide the axes, select Options > Show Axes (Figure 54). The check mark
disappears from the check box in front of the command on the menu, and
the axes disappear from all of the images.
Show Axes and e —
Show Cross hairs w
are selected by — 1 : I
default.To hide | 1#1 Show Axes | Jesnonhe Tlowach il
hem, r g
e i ¥ Show Crosshairs |
" Show Talairach Grid &
Figure 174. Show Axes command on the Options menu in the Triplanar-
Dual window
To display the cross hairs on the images again, simply select Options >
Show Axes. The check mark reappears in the check box in front of the
command.
To show or hide cross hairs
Showing or hiding cross hairs works just as showing or hiding axes. To hide
the cross hairs, select Options > Show Cross Hairs. To show them, select
Options > Show Cross Hairs again.
To show or hide the Talairach grid
By default, the Talairach grid does not automatically display on the images
unless you specifically select it to do so. To show the grid, select Options >
Show Talairach Grid. The grid appears on all of the images shown in the
triplanar-dual view. When you want to hide the grid, select Options > Show
Talairach Grid again.
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Creating VOIs on images

You can create point or line VOIs on the images.

To create point VOIs

FT

1 Click *
2 Click in the image where you want to create a point.

3 Repeat steps 1 and 2 for all other desired points.

To draw line VOlIs
1 Click L] .

2 Click in the image where the line should begin and drag the line to
where it should end.

The numbers beneath the line indicate the length of the line in
millimeters.

To change the line VOI, simply click on the VOI and then drag it to
another position in the image.

Note: You can only create one line VOI per orthogonal plane, although you can
create a line VOI in each one of the three orthogonal planes.

To delete line VOIs

You cannot delete a line VOI. However, you can remove the display of the

+

line VOI on the image. To do so, click . The line VOI disappears.
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5 anat-acpc Mi1.0
A T4 o K Cop
- T
e B
This row shows
Image A.
This row shows
Image B.
This row shows
a blend of
both Image A
and Image B.
File Close Frame—Closes this window.
Options Show Axes—Displays the XY (top left), ZY (top right), and ZX
(bottom left) axes on the images.
Show Cross Hairs—Displays the cross-hair lines on the images.
When you move these lines on one image, it also moves to the
corresponding points all of the other images.
Show Talairach Grid—Displays a Talairach (stereo tactic) grid on
the images.
Aligns two images.
+

Traverse image

Magnify image 2.0x

Enlarges the images to twice their current size. It might be
necessary to manually resize the window and use scroll bars to view
all of the images.

Figure 175. Triplanar-Dual window
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Magnify image 0.5x

Reduces the images to half of their current size.

Il
Magnify image 1.0x

Restores the images to their original size.

Draw line VOI

Draw a line VOI.

-PT
Identify center of
volume

Reassigns a new center to each dataset. The location that you
select appears in the center of each image.

o

Alignment tool

Allows you to apply a transformation matrix to an image dataset.

Apply . .
Applies rotations and
translations

Applies the rotations and translations made to the images.

FT
*

Add point

Draws a point on an image. This point is only on the image you
select.

MY Initiate new VOI

Indicates that the next VOI is a new VOI rather than a change to
the currently existing VOI.

Delete point VOI

Removes the point VOI from the image.

Identify crop volume

Displays the bounding box, which is outlined in red, on each image.

Crops image
delineated by the bounding
cube

Displays in a separate image window only the area enclosed by the
bounding box. When you click this icon, the Crop Image dialog box
opens.

¥4 Crop image

Image will he cropped io size of hounding hox.

Apply ‘ ‘ Cancel ‘

7

Draw using a brush

Allows you to draw with a brush on the image.

Figure 175. Triplanar-Dual window (continued)
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Changes the color of the paint used to the color selected on the

— Picks up a color from image.

the image

Allows you to fill an area with color. When you select this icon, the

Fills an area with Paint Grow dialog box opens.

desired color

Removes the paint from the specific spot that you select.
&
Erases a portion of the

image

Removes all paint from all of the images.
Erase all paint

Indicates the size of the paint brush tip. Click this icon to paint one

Draw using small size voxel each time the mouse button is clicked.

Indicates the size of the paint brush tip. Click this icon to paint 16

= . R
Draw using medium voxels (4 x 4 square) each time the mouse button is clicked.

size

Indicates the size of the paint brush tip. Click this icon to pain 100

= - .
Draw using large size voxels (10 x 10 square) each time the mouse button is clicked.

Allows you to change the intensity value of the paint. When you

Change intensity level click this icon, the Desired Paint Intensity dialog box opens.

of paint
X Desired Paint Intensity g]
Intensity (-32762 - 32767): [
‘ Apply | ‘ Cancel |

You can specify an intensity between -32,768 and 32,767. After you

type an intensity level, the icon displays the level you entered.

Changes the color of the paint used. This icon is often used in
n conjunction with the Draw icons. When you click this icon, the Pick

== Change paint color
g9e P Paint Color dialog box opens. After you change the color, this icon

displays the color.

Figure 175. Triplanar-Dual window (continued)
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. Allows you to change the opacity of the paint. When you click this
sl Opacity icon, the Paint Opacity dialog box opens.

4 Paint Opacity

Permanently applies the intensity level to the images.

Commit
Changes image
where painted

2 Removes paint from the last area to which it was applied.
Undo last region
paint
E Determines the volume, or number of pixels, in the painted area of
Calculate volume of the image.
paint
S Performs the action only on Image A.
"2 Image A
Performs the action only on Image B.
o Inoage B
Image B
Performs the action on both Image A and Image B.
DBtk Both

Figure 175. Triplanar-Dual window (continued)

To delete point VOIs

1 Click the first point on the image aligning the middle of the cursor with
the center of the point.

2 Click g . The point disappears.

3 Repeat the first two steps for every point you want to delete.
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Aligning the datasets

The Alignment Tool icon, £

matrix for the dataset.

, allows you to create a new transformation

1 Click % .

A closed angle appears on each of the images in the triplanar-dual view.
On Image A, the angle is red; on Image B, it's yellow; on the blended
image, the angle is green.

2 Move the cursor to the arrow on the thin line to the right, and align the
cursor with the end of the arrow. At this time, the cursor should be a red
Cross.

Arrows at the end of the
two lines in the closed
angle.

Degrees of the angle appear
under the left side of the
angle.

Figure 176. Closed angle that appears on each of the images

3 Change the size of the angle by dragging the arrow on the thin line up or
down depending on the type of angle you want to create. The exact
number of degrees appear on the left below the angle.

4 Release the mouse button when you reach the desired number of
degrees.
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1 Center the cursoron
the arrow at the end of
the thin line.

2 Drag the arrow to change the
rotation of the image.

Figure 177. Changing the angle by dragging the arrow on the thin line

5 Click on the image or on any other area of the triplanar-dual view. The
arrows disappear from the angle.

6 Click on the angle again to be able to change the angle again. The arrows
reappear and you can repeat the previous steps.

Finding the center of image datasets

C-PT

To find the center of the dataset, click = © . The center of each image

&

dataset, shown as " , appears in each image in the triplanar-dual view.

Erasing part or all of drawings

If you used the paint brush to draw on the image, you may at times find a
need to erase a part of the drawing or the entire drawing.

Y

‘ Caution: Make sure that you want to erase a part of the drawing or the
entire drawing. There is no undo.
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To erase a part of the drawing

1 Select the image that contains the drawing you want to erase. In other
words, select Image A, Image B, or Both.

2 Click <
3 Click on the part of the drawing that you want to erase.

4 Repeat step 3 for as long as needed.

To erase all of the drawing

1 Select the image that contains the drawing you want to erase.
Specifically, select Image A, Image B, or Both.

2 Click N . MIPAV removes all of the paint from the image.

Cropping images

MIPAYV allows you to extract the crop volume as a separate image, which is
helpful if you need to work with or use only that portion of the image. The
first step in cropping images is to identify what portion of the image is in the
crop volume. Then you need to use the bounding cube for cropping the
image.

To select the crop volume

1 Click . A red box appears on each image in the triplanar-dual view.

2 Align the cursor with one of the corner points of the box, and enlarge or
reduce the size of the box.

3 Repeat the previous step on each corner point as required to enclose the
portion of the image you want to be included in the cropped image.

The numbers on the sides of the box indicate the length and width of the
box in millimeters.

Note: The size of the box changes proportionally on all of the images shown in
the triplanar-dual view.
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4 Release the mouse button when you are finished making changes to the
box.

To crop images
1 Select one of the following:
* Image A if you want only the cropped area in Image A
» Image B if you want only the cropped area in Image B

» Both if you want both the cropped area in Image A and the cropped
areain Image B

2 Click ™ . The Crop Image dialog box appears.

Apply Applies the transformation to the image dataset
according to the specifications in this dialog box.

Fr

L’é] Crop image
Cancel Disregards any changes that you made in this dialog tagewill e croppet in-siae vikiurking hex

box and closes this dialog box.

Apply ‘ ‘ Cancel ‘

Help Displays online help for this dialog box.

Figure 178. Crop Image dialog box

3 Click Apply.

The cropped area in the image you selected appears in a separate image
window. So, if you selected Image A only or Image B only, one image
appears. If you selected Both, two image windows appear: one for Image
A and one for Image B.

If you selected . . . Then . ..

Image A The cropped area appears in a separate
window.

Image B The cropped area appears in a separate
window.

Both Two small windows—one displaying the

cropped area of Image A and the other
displaying the cropped area of Image B—
appear.

After you generate the cropped images, you can run algorithms on the
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images, apply a quick LUT on the images, or use any other image processing
that’s available in the MIPAV window on them.

Magnifying or minifying images

Like the image toolbar on the MIPAV window, the Triplanar-Dual window
includes the following magnification icons:

. & , the Magnify image 2.0x icon—To magnify images to twice

their current size
- , the Magnify image 0.5x icon—To reduce images to half their
current size

- B , the Magnify image 1.0x —To restore their original size
For information on how to use these icons, refer to “magnify or reduce a
region of the image. You can magnify images to 32 times their original size,
reduce them to one-fourth their original size, or restore them to their
original size.” on page 13.

Drawing on images

You draw on images in the triplanar-dual view in the same way as you do in
the MIPAV window. However, any of the changes you make on the
triplanar-dual view are also made on the original images.

For example, if you highlight a particular area in the image in the triplanar-
dual view, the same change is made on all of the images in the triplanar-
dual view, but also on the images in the default view.

To change the paint color

Click n , the Change Paint Color icon. The Pick Paint Color dialog box
(Figure 43 on page 54) opens. For instructions on how to use this dialog box
to change the paint color, refer to “To change background and border
colors” on page 54.
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¥ anatiacpe M:1.0

By (A) The painted area may show
up on nat anly the images in
the triplanar-dual view
illustrated here, but also an the

images in the default image
view (below).

(B) Painted
area shown in
the default
image view

Figure 179. Painting an area on images in the triplanar-dual view affects
images in the default image view

To change paint opacity

1 Click e . The Paint Opacity dialog box opens.

2 Move the Opacity slider to the level of opaqueness you want. For
example, to make the paint color more opaque, or solid, move the slider
to the right. To make the paint color more transparent, move the slider
to the left.

3 Click Close when you have finished. The Paint Opacity dialog box
(Figure 60) closes.
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Opacity Indicates the opacity of the
paint. The further right you
move the slider, the more
opagque the paint color. The Opacity
further left you move the
slider, the more 0 0.3 1

transparent the paint color.
p p Close

Close Closes this dialog box.

F
I

b Paint Opacity

Figure 180. Paint Opacity dialog box

To calculate the volume of paint

The software can calulate the volume of a painted area in the number of
pixels. To do so, do the following:

1 Paint the area of the image in which you are interested.

2 Click == to discover the volume of paint. The software lists the
number of pixels in each image and the volume in millimeters on the
Data page of the Output window.

3 Amend and save, as an option, the information on the Data page.

b Output: anat+acpc E|[EJE|

File Edit

B> % |

Irnage & region govw: pixels = 1532 solume = 1582.0 o3
Irnage B region grow: pixels =0 volure = 0.0 mun™3

Figure 181. Output window after calculating the volume of paint
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To fill an area with color

1 Click ® . The Paint Grow dialog box opens.

2 Complete the dialog box.
3 Click Close.

Cursor position and
voxel intensity

Indicates the location of the cursor
and the intensity value at that point

Delta above selected
voxel intensity

Indicates the range of paint beyond

Delta below selected
voxel intensity

Indicates the range of paint

Unrestricted size

Limits the total volume in 3D or 4D
images or area in 2D images

Maximum size (null)

In development.

Unrestricted
distance

Limits the distance from the seed
point

Maximum size (null)

In development.

Fuzzy connectedness

Applies the fuzzy algorithm

Initial variance from
selected VOI

In development.

Display fuzzy image

In development.

[’;‘] Paint Grow

i‘Cu.rsnr]msitionandwxelhtensity"

~Delta ahove selecied voxel intensity

& " 100
|00 286710 5340
~Delta helow selected voxel intensity- ]
|00 2670 5340
~Parameters

[w] Uneestricted size

[#] Unrestricted distance

T

~Fuzzy conn

[C] Fuzzy conmectedress

Fuzzy threshold

Fuzzy threshold In development. >
|

Close Applies the parameters you '

specified - || S, ‘
Cancel Disregards any changes that you

made in this dialog box and closes

the dialog box
Help Displays online help for this dialog box

Figure 182. Paint Grow dialog box

1 Click

To erase an area of paint from images

2 Click the area of the paint that you want to remove.

3 Repeat the previous step for each area of paint to be removed.
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4 Click when done to return the cursor to the default state.

To erase all painting from images

Click - . MIPAYV removes all of the paint from all of the images.

Displaying images using the surface plotter view

The surface plotter view illustrates the intensity levels according to height.
In other words, the higher the intensity, the higher the height of the plotted
image. The lower the intensity, the shorter the height of the plotted image.

If you select the animate view, the software makes a copy of the image
dataset and loads it in the animate image window. In animate view, like cine
view, the software automatically advances through the image dataset.
However, animate view allows you to adjust the speed at which images are
advanced. You can specify that images be displayed in forward or reverse
order. You can also pause or loop the sequence.

To view an image dataset in animate view

1 Select Image > Views > Surface Plotter in the MIPAV window. The
Height Surface window (Figure 63) opens.

2 Hold down the left mouse button and drag the mouse to the left, right,
top, and bottom. This allows you to move the image in all directions. If
you release the mouse button and then hold it down again while you
move, you can turn the image upside down.
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File Exit—Closes the Height Surface
window.

el

Options View Mode—In development. 24 Height surface
File Options

Mouse Recorder—In ,
development. vl Z(1-100)
1

Line Mode—Displays the image
as lines.

Resample—Improves the speed
in animating the image by forming
the image with fewer triangles.

Display Options—Allows you to
add a bounding box, change colors
of the bounding box and
background, show an orientation
cube, and choose the projection
type: perspective or orthographic.

Time (2) Turns on the ability to calculate the height of the intensities. When this item is
selected, the height slider is available. By default, this check box is selected.

Height slider Shows the height of the intensities in the image. Slide the marker to the left to
show lower level intensities. Slide the marker to the right to increase the level of
intensities. The read-only box on the right indicates the actual height of the
marker.

Image area Displays the plotted image.

Figure 183. Height Surface window

3 Hold down the middle button on the mouse and push the mouse
forward. This makes the image smaller as if seen from a distance
(Figure 64A).

4 Hold down the middle button and push the mouse toward you enlarges
the image so that you can examine it closely (Figure 64B).

5 Slide the marker on the height slider to determine the highest intensity
in the image (Figure 64B).
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Chapter 6, Visualizing Images

(X} Height surface
File Options

Example: One way of determining the highest intensity in the image is to use
the mouse to drag the image to its side, enlarge it using the middle mouse
button and pushing the mouse toward you, and then sliding the height marker to
the top of the tallest intensity. The level of the intensity appears in the box to the
right of the height slider.

54 Height surface
File Options

r

vl Z(1-100) :

(A} Image seen from a distance

[¥ Z1-100)
1

(B) Measuring the intensity height

Figure 184. Manipulating the plotted image in the Height Surface window
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Displaying images using the surface renderer
view

In development.

Displaying images using the volume shear view

In development.

Displaying images using the volume renderer
view

In development.
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