Changing Image Ddgtasets Using
MIPAYV Utilities

MIPAYV provides a number of utilities that you can use to perform standard
image-processing tasks such as converting image datasets to another image
type, transforming images by copying, cropping, or rotating them, and
changing image datasets by adding, removing, or reordering slices. To
perform more complex tasks, MIPAV provides algorithms, which are
covered in volume 2 of the User’s Guide. This chapter explores the standard
tasks.

To access the standard image-processing tasks, you use the commands
(refer to Table 4) on the Utilities menu in the MIPAV window.

Table 4. Standard tasks provided through commands on the Utilities menu in the MIPAV window

Scalar*> RGB
Task Command 2D 3D 4D 2D 3D 4D
Adding image Add Image Margins Y Y Y Y Y Y
margins
Copying images Clone (copy) Y Y Y Y Y Y
Concatenating Concatenate Y Y Y Y Y Y
datasets

*Scalar includes the following image types: Boolean, byte, unsigned byte, short, unsigned short,
integer, long, float, and double.
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Table 4. Standard tasks provided through commands on the Utilities menu in the MIPAV window

9/20/04

Scalar* RGB

Task Command 2D 3D 4D 2D 3D 4D
Converting datasets Convert Type Y Y Y N N N
to a different image
type
Converting 3D to 4D Convert 3D to 4D N Y N N Y N
Converting 4D to 3D Convert 4D to 3D N N Y N N Y
Correcting image Correct Image N Y Y N N N
spacing Spacing
Cropping images Crop Y Y Y Y Y Y
Removing 3D Extract 3D Subset N N Y N N Y
information from 4D from 4D
dataset
Flipping images Flip > Horizontal Y Y Y Y Y Y
horizontally
Flipping images Flip > Vertical Y Y Y Y Y Y
vertically
Converting datasets Grays -> RGB Y Y Y N N N
from grayscale to
RGB
Adding slices to Insert Slice N Y Y N Y Y
datasets
Inverting the order Inverse Slice Order N Y Y N Y Y
of slices in datasets
Masking images Mask Y Y N Y Y N
Matching images Match Images Y Y N Y Y N
Adding noise to Noise Y Y N Y Y N
images
Randomizing the Randomize Slice N Y Y N Y Y
order of slices Order
*Scalar includes the following image types: Boolean, byte, unsigned byte, short, unsigned short,
integer, long, float, and double.
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Table 4. Standard tasks provided through commands on the Utilities menu in the MIPAV window

Scalar* RGB

Task Command 2D 3D 4D 2D 3D 4D

Rotating images Rotate -> X axis +90 Y Y Y Y Y Y
Rotate -> X axis -90 Y Y Y Y Y Y
Rotate -> Y axis +90 Y Y Y Y Y Y
Rotate -> Y axis -90 Y Y Y Y Y Y
Rotate -> Z axis +90 Y Y Y Y Y Y
Rotate -> Z axis -90 Y Y Y Y Y Y

Removing slices from Remove Slices N Y Y N Y Y

datasets

Removing time slices Remove time slices N N Y N N Y

from datasets

Manually converting RGB -> Gray N N N Y Y Y

datasets from RGB

to grayscale

Automatically RGB -> Grays N N N Y Y Y

converting datasets

from RGB to

grayscale

Subsampling images Subsample Y Y N Y Y N

Swapping the third Swap DIMS 3 <-> 14 N N Y N N Y

and fourth

dimensions

*Scalar includes the following image types: Boolean, byte, unsigned byte, short, unsigned short,
integer, long, float, and double.

Keeping a log of utilities applied to image
datasets

Before applying any of the utilities, you may want to place MIPAV in log
mode. When placed in log modes, MIPAV automatically tracks the utilities
applied to datasets during the current session. When the session ends,
MIPAYV clears the log.
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The Output window displays the log on the Log page. Log entries generally,

but not always, display the name of the utility and its parameters and
whether the utility was applied successfully. If it was not applied

successfully, error messges may also appear in the log. MIPAV maintains a

separate log for each dataset.

To place MIPAV in log mode

1 Select Help > Program Options. The MIPAV Options dialog box

(Figure 236) opens.

Note: For more information about the MIPAV Options dialog box, refer to

“Customizing MIPAV” on page 79.

2 Select the Log mode check box.

2 MIPAY. Options

| Global settings
[ Display Splash screen

[w] Show Scripting toolhar

[##] Save all on save

[ Save thurdbnails for XML files

[_] Use platform-style Fils dialogboxes.

[¥] Log mode

[¥] Check rmeraory options in start-up (LA fils azainst preferences
[T Check on closing frave?

[C] Redirert errors to log:

Drebugging output:

HY|

Recently nsed image list:

File filter default: Class Files (* class)

Crosshair eursor color:

.

Kctive image border color;, —

‘ Apply | | Cancel

Figure 236. MIPAV Options dialog box showing Log mode selected

3 Click Apply.

4 Click Close (the button at the top right of the dialog box). The MIPAV

Options dialog box closes.
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From this point on unless you clear the Log Mode check box on the
MIPAY Options dialog box, the Log page of the Output window tracks
and displays the utilities applied to images.

Tip: You can type directly onto the Log page of the Output window, letting you
add comments to the log, which you can save and print as needed.

To turn the log mode off

1 Select Help > Program Options. The MIPAV Options dialog box opens.

2 Clear the Log mode check box. The check mark disappears from the
check box.

3 Click Apply.
4 Click Close. The MIPAV Options dialog box closes.

Adding image margins

The Add Image Margins command allows you to add a border of pixels or a
specific intensity along the edges of an image dataset.

To add image margins

1 Open an image.

2 Select Utilities > Add Image Margins. The Add Image Borders dialog
box (Figure 237) opens.

3 Enter the number of pixels to add on the left and right sides of the
image, the top and bottom, and to the front and back of the image.

4 Enter the intensity value for the margins.
5 Select one of the following destinations:

» New image—The software applies the margins to another instance
of the dataset in a new image window.

* Replace image—The software adds the margins to the existing
instance of the dataset.

6 Click OK. The image margins are applied to the dataset.
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N PAA/
Margins Pixels on the left side: Specifies
Around Image the number of pixels that should "
. ¥4 Add Image Border
appear on the left side of the .
image. . i
Pivelz on the left side: i}
Pixels on the right side: Piels on the right side: a
Specifies the number of pixels Helontn 0
that should appear on the right R 0
side of the image. Slices at the front of image: |0
Slhices at the back of mage: |0
Pixels on the top: Specifies the i _
number of pixels that shquld Rl o s e ,107‘
appear on the top of the image. e
helec tinati
Pixels on the bottom: Specifies & New Inoge
the number of pixels that should -
appear at the bottom of the Replace lrage
image.
OK H Canrel H Help
Slices at the front of image:
Specifies the number of slices that
should appear at the front of the
image.
Slices at the back of image: Specifies the number of slices that should appear
at the back of the image.
Value for Specifies the intensity of the border around the image. As a default, the intensity
margins of the border is the same intensity as that for the image.
(image
minimum is
default)
New image Shows the image with the additional or adjusted margins in a new image window.
Replace Replaces the current active image with the results of the image to which margins
image were added or adjusted.
OK Applies the parameters that you specified to add margins to this image.
Cancel Disregards any changes you made in this dialog box, closes the dialog box, and
does not add image margins.
Help Displays online help for this dialog box.

Figure 237. Add Image Border dialog box
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Copying images using the Clone command

Yy

Suppose you need to copy an image dataset. To do so, you would use the
Clone command on the Utility menu. This command generates a duplicate
of the dataset and any information stored on the image, utility, algorithms,
VOI, and paint layers.

Note: The Clone utility copies VOIs as well as the image, but it does not copy
LUT information. Although we can observe its effects, it is not stored in an image
layer.

If two datasets are loaded into one image window, only the active dataset is
cloned. When the dataset is duplicated, the duplicate dataset appears in its
own image window.

To copy an image dataset, you simply select Utility > Clone (copy) in the
MIPAV window. In a moment or two, a duplicate of the dataset appears in a
new image window.

Concatenating images

The Concatenate command on the Utilities menu provides you with a way to
append, or add, two datasets together.

To concatenate image datasets
1 Open the two datasets that you want to join.
2 Select the dataset to which you want to append the other dataset.

3 Select Utilities > Concatenate. The Concatenate Images dialog box
(Figure 238) opens.

4 Note that the dataset you selected appears in read-only form in the box
labeled Image A.

5 Select Image B, which is the name of the dataset that you want to add to
the end of Image A.
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N PAA/
6 Select the dimensionality that you want for the resulting dataset by
selecting either 3D or 4D.
Note: If both datasets contain the same number of slices, you can select either
3D or 4D. If the datasets contain a different number of slices, you can only select
3D.
7 Click OK. The program adds the Image B dataset to the end of the Image
A dataset and displays the resulting dataset in a new image window.
Image A Specifies the name of the dataset
to which to append Image B. This
dataset is the one you selected 4 Concatenate Images
before using the Concatenate InazeB apvended fo Inaged
command. i
Trnage &: pos24 hefore corSp
Image B Specifies the name of the dataset T B |_Pmiﬁu1124 ~|
that you want to append to the
Image A dataset. -Dimensionality of Result
. = 3D
3D Indicates that the dataset that
results from appending Image B
to Image A is three dimensional.
4D Indicates that the dataset that ok | ‘ cantel || Help
results from appending Image B
to Image A is four dimensional.
OK Applies the changes you made in this dialog box and closes the dialog box.
Cancel Disregards any changes you made in this dialog box, closes the dialog box, and
does not append Image B to Image A.
Help Displays online help for this dialog box.
Figure 238. Concatenate Images dialog box
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To verify that the datasets are joined

1 Select the new dataset that resulted from concatenating the Image A and
Image B datasets.

2 Notice the following on the MIPAV window:

» If you selected 3D as the dimensionality of the resulting dataset in
the Concatenate Images dialog box, the image slice slider
(Figure 239A) lists twice as many slices as either the Image A and
Image B datasets.

» If you selected 4D as the dimensionality of the resulting dataset, a
time slice slider (Figure 239B) appears beneath the image slice
slider and the image slice slider lists the same number of slices as
the Image A and Image B datasets.

W< MIPAY: Sh_3703_1_clone_concat 10/36 M:1.0 FEK
File Elit VOI LUT Algorithms Utilities Pluglns Image Toolbars Help

B ¢fBz0000¢vowll © s @ | o
Scripts Home..| Current Script: =~ > @

PEHS LEFEREORE e» aaqa=@n FERED s
Image slice
e O
1 12 3
X130V 145 Infenaity: 2320
(A} After concatenating datasets that contain the same number of slices to generate a 3D dataset
() one 0 P 0 ] () B () -
File Edit VOI LUT Algorithms Utilies Plaghs Image Toobars Help
|H FRAZOoonevowll © s na | o
Scripts &l CurremtScript = =~ b @ Time slice slider
PEHS LEFROBRE ¢» aag=<@mn B2 s
Image slice
1 9 18
: 0
1 2
X 163Y:24 Intensity. 10

(B) After concatenating datasets with an unequal number of slices to generate a 4D dataset

Figure 239. The MIPAV window after concatenating datasets to generate 3D or 4D datasets
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Converting image datasets to different data

types

In MIPAV you can convert image datasets to different data types. For
example, you might want to convert a Boolean type dataset to an integer
type dataset. MIPAV also allows you to simultaneously alter the input and
output values. This utility is particularly helpful if you want to apply an
algorithm to a dataset but cannot do so because the original images are the
wrong image type.

data type—A set of values from which a variable, constant, function, or
expression may takes its value. MIPAV automates the following data types:
Boolean, signed byte, unsigned byte, signed short, unsigned short, integer, long,
float, double, and color 24.

To convert a dataset to a different image type

1 Select Utilities > Convert type. The Convert Image Type dialog box
(Figure 240) opens.

2 Select the desired image type in the Image Type group.

3 Indicate the start and end input ranges in the Range of input values
group.

4 Indicate the start and end output ranges in the Range of output values
group.

5 Specify either Little endian or Big endian in the Endianess group.

6 Click OK. The dataset is converted to the new image type.
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¥4 Convert image type
~Image Type ~Destination
(@) New irage
o ?é.'DUIe‘.’.lT: i) Replace irage
O Byte ~Range of input values
) Unsigred Byte (@) Use entire image rangs. () Use user defined range.
@ Short e P ¥ ]
(! Tnsigned Short
(3 Integer ~Range of output values
() Unsigned Integer | | Starting range (32768 to 327673, 1024
i Ending range {-32762 to 32767). 307
(20 Float ~Endianess
) Double (@) Little endian
i) Big endian
OK | ‘ Cancel | ‘ Help
Image Type Specifies the data type. Select one of the following:
Boolean Indicates whether a condition if true or false.
Byte Primitive 8-bit data type. Valid values range from -127

to 128.

Unsigned byte

Primitive 8-bit data type. Unsigned byte is a variation
of the integer data type. The unsigned byte data type
signifies that valid values must fall within a specified
range of positive whole number values. Valid values
range from O to 255. Negative values are not valid,
hence the term unsigned byte.

Figure 240. Convert Image Type dialog box
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Short

Primitive 16-bit data type. Short is a variation of the
integer data type. Short accommodates values that are
whole numbers. Valid values range from 0 to +32,768.

Unsigned short

Primitive 16-bit data type. Unsigned short is a variation
of the integer data type. The unsigned short data type
signifies that valid values must fall within a specified
range of positive whole number values. Valid values
range from O to 65,535. Note that negative values are
not valid, hence the term unsigned byte.

Integer

Primitive 32-bit data type. Integer is sometimes
abbreviated as int. Integer accommodates values that
are whole numbers. Valid values range from
-2,147,483,648 to +2,147,483,648.

Unsigned integer

Primitive 32-bit data type.

Long

Primitive 64-bit data type. Long is a variation of the
integer data type. Long accommodates values that are
whole numbers. Valid values range from
-9,223,372,036,854,775,808 to
+9,223,372,036,854,775,808.

Float

Primitive 32-bit data type. Float is a floating point data
type that accommodates decimal values, up to 6 or 7
significant digits of accuracy. Valid values can range

from -3.4 x 1038 to 3.4 x 1038,

Double

Primitive 64-bit data type. Double is a floating point
data type that accommodates decimal values, up to 14
or 15 significant digits of accuracy. Valid values can

range from -1.7 x 103%%8 to 1.7 x 103%8,

Destination

New image

Shows the converted dataset in a new image window.

Replace image

Replaces the current active dataset with the converted
dataset.

Range of input
values

Use entire image
range

Converts all intensity values to the result image range
when converting the image to a different type.

Use user-defined
range

Converts only the intensity values in the user-defined
range when converting the image to a different type.

Start input range

Specifies the intensity value at the beginning of the
input range. The default value is the image minimum.

End input range

Specifies the intensity value at the end of the input
range.

Figure 240. Convert Image Type dialog box (continued)
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Range of
output values

Starting range Specifies the intensity value at the beginning of the

output range. The default value is the image minimum.

Ending range Specifies the intensity value at the end of the output

range.

Endianess

Data organization strategy. Refers to the way computer processors store data in
memory.

Little endian Stores the least significant byte (LSB) first.

Big endian Stores the most significant byte (MSB) first.

OK

Applies the parameters that you specified to convert the dataset.

Cancel

Disregards any changes you made in this dialog box, closes the dialog box, and
does not convert the dataset.

Help

Displays online help for this dialog box.

Figure 240. Convert Image Type dialog box (continued)

Converting 3D to 4D images or 4D to 3D images

To convert 3D images to 4D images

1
2

Open a 3D image or image dataset.

Select Utilities > Convert 3D to 4D. The Convert 3D to 4D dialog box
opens.

Do either of the following in the Number of slices in the 3rd dimension,
Resolutions: 3rd dimension, and Resolutions: 4th dimension boxes:

» Accept the default numbers.
» Enter different numbers.

Select in each of the Resolution units: 3rd dimension and Resolutions
units: 4th dimension lists one of the following: millimeters (the default
value), unknown, inches, centimeters, angstroms, nanometers,
micrometers, milliliters, meters, kilometers, miles, nanoseconds,
microseconds, milliseconds, seconds, minutes, hours, or Hz.

Click OK. The program applies all of the specification in this dialog box
to the image or image dataset.
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Number of slices in Specifies how many
the 3rd dimension slices are in the 3rd =
dimension. The ¥4 Convert from 3D to 4D
default number is 2. P TamEiers
- - Humber of slices in the 3rd dimension |4 |
Resolutions: Indicates the
3rd dimension resolution for the third - Resolutions
dimension. The e dlirn. 50
default number is 5.0. dth dim. L0
; - ~Resolution uni
Resolutions: Indicates the s"_ ution wniis
4th dimension resolution for the i MILTIMETERS =
fourth dimension. The rd dirn. MILLISECONDS >
default number is 1.0.
0K H Cancel H Help
Resolution units: Indicates the voxel
3rd dimension resolution in the 3rd
dimension.
Resolution units: Indicates the voxel resolution of the 4th dimension.
4th dimension
OK Applies the specified parameters to convert a 3D image to a 4D image.
Cancel Disregards any changes you made in this dialog box, closes the dialog
box, and does not convert the image.
Help Displays online help for this dialog box.

Figure 241. Convert from 3D to 4D dialog box

To convert 4D to 3D images

1 Open a 4D image or image dataset.
2 Select Utilities > Convert 4D to 3D.

The program immediately begins processing the image.

Correcting image spacing

The Correct Image Spacing command on the Utilities menu corrects images
in which slice thickness and slice spacing are unequal, which may distort
images. To understand how this problem can occur, the following section
presents some background information.
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UNDERSTANDING THE EFFECT OF CONTIGUOUS
PLANES ON IMAGE SCANNING

Image scanning is usually done in contiguous planes. For example, if the
first slice is centered at position 5.0 and the slices are 2 mm thick, the
second slice is centered at 7.0. In such a case, the slice thickness, 2, and the
slice spacing, 2, are equal. There are, however, two scenarios when the slice
spacing does not equal the slice thickness:

e Slice spacing is less than the slice thickness—In this case,
although the images are, for example, 2 mm thick, they are spaced only
1 mm apart (Figure 242). This scenario arises when the ZIP x 2 feature
is used during MRI scanning, which enables the acquisition of slices
only 1 mm apart but uses signals from a 2-mm slab to increase the
signal-to-noise ratio.

e Slice spacing is greater than the slice thickness—This scenario
(Figure 242), which is more common than the first, occurs when the
operator chooses to acquire images at intervals greater than the slice
thickness (i.e., there is a gap between successive image slices) in order
to cover a deeper field of view.

MIPAYV assumes that successive images are contiguous. So, for example, if
users chose the triplanar view to display an image that had slice spacing
larger than slice thickness, the image would appear shortened in the out-of-
plane direction. The Correct Image Spacing utility corrects both situations
in which the slice thickness and spacing are not equal. Once the correction
is applied, the slice thickness and slice spacing for the given image dataset
are the same.

UNDERSTANDING HOW MIPAYV SOLVES THIS
PROBLEM

When the spacing between slices is less than the slice thickness, the Correct
Image Spacing utility assigns the slice spacing to the slice thickness (refer to
Figure 242 on page 355 for triplanar views before and after correction).
When the slice spacing is larger than the slice thickness (refer to Figure 242
on page 355 for triplanar views before and after correction), the utility
inserts blank slices between the existing images.
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Since all slices within an image volume must have the same slice thickness,
in many cases more than one slice must be inserted and the original images
must be repeated so that a new value can be found for the slice thickness
that fits evenly into the original slice spacing. Since there are an infinite
number of combinations of slice spacing and thickness, not all could be
handled. Table 5 displays the most common combinations and the
algorithms MIPAV uses for handling them.

T = Original slice thickness

S = Original space between slices

G=Gap=S-T

M = Number of original images

O = Original image set origin

N = New slice thickness
To use the Correct Image Spacing utility, DICOM images must first be saved
in XML format. The following DICOM tags (Figure 242 on page 355) are
used:

e (0018, 0050) Slice Thickness
e (0018, 0088) Spacing Between Slices

You can also find this information listed in the Essential Image Information
section of the image header (Figure 242 on page 355) as Pixel resolution 2
(i.e., slice thickness) and Slice Spacing.
To view image attributes

1 Open an image.

2 Select Image > Attributes > View Header. The Header dialog box
(Figure 242) opens.

3 Find the tags under Essential Image Information to find the values for
Pixel resolution 2 and Slice Spacing, or find the values of the DICOM
tags Slice Thickness and Spacing Between Slices.
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Table 5. Solutions for correct image spacing

Number Number
of images of blanks New image
New slice in new set inserted set origin
thickness fo_r gach fo_r gach Total . T N
original original images in (O -=+ —)
Case (N) image image set now 2 2
T=S T 1 0 M 0]
S<T S 1 0 M 0]
G>0 and T 1 1'9 (1+9)-M O—I+Q\D
G T T 2 2
=modl = 0
T
G>0 and G 1.1 1 (1_'_1) M O—I+@
T dl = 0 G 2 2
Gmo
G>0 and T 2 G
an 1 2.= (2+29)M (N)
G _ 2 T T o T, 2
(2-?)modl—0 5T
G>0 and G T 2
an > 2= (2+2-2)-m (9)
2 G G 2
(Z-I)modl—o o-1.+222
G N 2
G>0 and T 3 G
e I 3.8 (3+3.9).|v| (N)
3 T T 3
(3-§)mod1—0 o-1.+2
T N 2
G>0 and G T 3
an c 3.1 (3+3.1) - u )
T 3 G G T,\3
(3-—)mod1:0 O-<+22=
G
else don't handle, give message
Legend:
T = Original slice thickness G=Gap=S-T O = Original image set origin
S = Original space between slices M = Number of original N = New slice thickness
images
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(A) Tags listed under the
Essential Image Information
(left)

before_corrSpCorrSpe: 5

o
[258

1256

110

|Short

1.0 The image header in A lists Pixel

I 86.0 resolution 2 (i.e., slice thickness)

|Sagittal and Slice Spacing, The DICOM

|Anterior to Posterior tags shown in B are Slice Thick-
Axis Y Orlentation ;SuPBIlDI 10 Inferior ness and Spacing Between Slices.

Axis Z Orientation
Pixel resolution 0
Ivel resalution 1

|Leftto Right
11171876 Millime
11 171076 Millirme
9.0 Millimeters
9.0 Millimaters

T TR

ters

[152.8
Start origin 2 444
Endianess |Lite Endian

| 1.0000 0.0000 0.0000 00000
| 0,0000 1.0000 00000 0.0000
| 0.0000 0.0000 1.0000 00000
| 0.0000 0.0000 O

{B) DICOM tags appear in a later
section of the header (below)

¥4 Info; Sh_3703_1: 9

IModality |Magnetic Resona TG ' Vs
Subject Information Jo1e,0000)  [Acquisiion Group Lens 1502 A
Name | (0018,0015)  |Body Pan Examined [FIU PURFLE RESEA
il |Beanning Sequence \8E
Subject Name I 18,002 ;Sauu ence Yarant NONE o
Subject 1D | (0016,0022)  [Scan ¢ [SAT_GEMS, VE_GEMS , PFF , 5P
Race | (0018,0023) | i o 20
Diagnosis | : -
t |Blice Thickness 5.000000
Date of Birth |0000-01-01 THepation Time -:strrrtrurrtvtrJ
Helght (] ho Time 8.000000
1 Number of Averages 11.000000
‘Q’Bight 'Ej " limaging Frequency 636817220,00000
ex |\Unknown aged Nucleus H1
Body Part | ho Number(s) K
Scan Attributes |Spacing Between Slices |6.500000
Name | [Echo Train Length 0
Equipment Model Name | (0018,0093)  Percent Sampling 100.000000
Scan D (0018,0094)  Percent Phase Field of View 1100.0600000 =
Protacal ' Showr Privaie i Il TRiaEs
Scan Date 10006-01-01 | | el ek | e
Add Set J [ Edit tag ‘ ] Remove Parame tex I ‘ Close J

Figure 242. Views of the Header dialog box showing the tags listed under (A) Essential Image
Information and (B) the DICOM tags in a later section of the header.
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To save images as XML files
The Correct Image Spacing utility works only on XML files.
1 Open the image that has spacing problems if you have not already done
So.
2 Select File > Save Image as in the MIPAV window. The Open dialog box
appears.
3 Type the name for the file including the XML extension in File Name.
4 Select Medical, which includes XML files, in Files of Type. The Choose
File Type dialog box (Figure 243) opens.
¥4 Choose File Type
NIFTI (img) =
PCX (.pcx)
PICT {.pict)
PNG (.pnog)
PSD (.psd)
Quicktime (at, mov) ek
Raw (.raw) /' types to find XML
SPM {.spm) (xml).
STK (.stk)
TGA {.tna)
TIFF (.tif, tiff)
VOI (v0i)
XBM (.xbm)
(] ML cxmiy
XPM (.xpm) -
0K Cancel
Figure 243. Choose File Type dialog box
5 Scroll down and select XML.
6 Click OK. The program saves the image as an XML file.
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To correct image spacing

1 Open the image that contains spacing problems.

Tip: To determine whether images contain spacing problems, remember to view
them using the triplanar view or to view the header file.

2 Save the image as an XML file.
3 Select Utility > Correct Image Spacing.

If the image file does have spacing problems, then the program runs the
utility.

If the image spacing is correct, the program displays a message
(Figure 244) indicating that the spacing is correct.

Slice spacing equals slice thickness. Mo need for correction.

Figure 244. Message received when image spacing is already correct

Cropping images

You can use the Crop command on the Utilities menu to trim an image so
that only the selected portion of the image remains.

To crop an image

1 Open an image.

2 Draw one or more contours on the image on the area that you want to
remain in the image. When the utility is run, the area inside the

contours remains and the areas outside the contour are discarded from
the new dataset.

MIPAYV User’s Guide, Volume 1, Basics 357
9/20/04



Chapter 9, Changing Image Datasets Using MIPAV Utilities

N PAN/

Necicet Inage Frecess oAty s &M= atizztion

LX) Opthamalogist M:1.0 [__”'E| &I The yellow bounding box—which
— ctually does NOT appear on the
image—encloses both contours
and represents the area in the
image that remains after the
image is cropped.

[> Contours

(A} This picture shows two selected contours: a red rectangular (B) The cropped image formed from the
one and a red circular contour. outermost points in the two contours.

Figure 245. Contouring the area that should remain in the cropped image

3 Select the VOI or one or more of the contours.
4 Select Utilities > Crop. The Crop dialog box (Figure 246) appears.

5 Type the number of pixels that you want to use for the border size in
Border size box. Specify a number from O to 50.

6 Select either the New image or the Replace image check box to indicate
whether the program should display the cropped image in a new image
window or replace the original image with the cropped image.

7 Click OK. After a moment, the new image appears.
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- Border size of VOI
Border size (0 - 50) pixels

- Coordinates of YOI
Fruin (pizels) |

Hnin (rorm)
Width (piels) |

Zaein (piels [

Zirnin {1z
Depth (pixels) I

- Destination
) Hew iriage
i Replace image

Border size of VOI:
Border size (O - 50)

Indicates the width of a strip of voxels that surround (border) the

contours. When you crop an image, the area inside the contours and the

border remain. All other voxels are trimmed from the image.

Coordinates of VOI

Displays the coordinates for the X, Y, and Z axes of the VOI.

New image

Shows the cropped image in a new image window.

Replace image

Replaces the current active image with the cropped image.

OK Applies the parameters that you specified to crop the image.

Cancel Disregards any changes you made in this dialog box, closes the dialog
box, and does not crop the image.

Help Displays online help for this dialog box.

Figure 246. Crop dialog box
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Removing 3D subset from 4D

This utility allows you to remove one of the x, y, z, or t dimensions from 4D
images to produce a 3D image.

To remove an X dimension slice
1 Open a 4D image.

2 Select Utilities > Extract 3D Subset from 4D. The Extract 3D Subset
dialog box (Figure 247) opens.

3 Select X.

4 Type the index number of the slice you want to extract in the Select
index from. <N> to <N> box.

5 Click Remove. The program removes the slice you specified from the
dataset.

To remove a Y dimension slice
1 Open a 4D image.

2 Select Utilities > Extract 3D Subset from 4D. The Extract 3D Subset
dialog box (Figure 247) opens.

3 Select .

4 Type the index number of the slice you want to extract in the Select
index from. <N> to <N> box.

5 Type the index number of the slice you want to extract in the Select
index from. <N> to <N> box.

6 Click Remove. The program removes the slice you specified from the
dataset.

To remove a Z dimension slice
1 Open a 4D image.

2 Select Utilities > Extract 3D Subset from 4D. The Extract 3D Subset
dialog box (Figure 247) opens.
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3 Select Z.

4 Type the index number of the slice you want to extract in the Select
index from. <N> to <N> box.

5 Click Remove. The program removes the slice you specified from the
dataset.

To remove the T dimension

1 Open a 4D image.

2 Select Utilities > Extract 3D Subset from 4D. The Extract 3D Subset
dialog box (Figure 247) opens.

3 SelectT.

4 Type the index number of the slice you want to extract in the Select
index from. <N> to <N> box.

5 Click Remove. The program removes the slice you specified from the
dataset.

Specifies that the algorithm
should remove the X (width)
dimension. 4 Extract 3D subset @

Specifies that the algorithm
should remove the Y (height, or Ox Oy ®z OT

[~ Select removed dimension

length) dimension. 1 Select index froma 1 1o 6

Specifies that the algorithm
should remove the Z (depth)
dimension.

‘ Remove ‘ ‘ Cancel ‘ ‘ Help

Specifies that the T (time)
dimension should be removed.

Index from
<N> to <N>

Specifies the index number of the volume or slice that you want to extract from the
dataset.

Remove Removes the specified dimension.

Cancel Disregards any changes you made in this dialog box, closes the dialog box, and
does not remove any dimensions.

Help Displays online help for this dialog box.

Figure 247. Extract 3D Subset dialog box
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Flipping images horizontally or vertically

MIPAYV allows you to flip images either horizontally or vertically. To flip an
image, select either Utilities > Flip > Horizontal or Utilities > Flip >
Vertical. After a few moments, the flopped image replaces the original
image in the same image window.

BEAA_61 e2n24m1.0  [CE)EK I an_61 621124 W10

(B} Image flipped horizontally (C) Image flipped vertically

saa_e 1111111111 e2... [CE]K)

(A} Original image

- L i
A ...- 1
>

Figure 248. Original image and image flipped horizontally and vertically
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Converting grayscale images to RGB images

You can convert grayscale image datasets to RGB. RGB images have three
channels (red, green, and blue) that contain image data.lf you open two
datasets in one image window, you can create a composite image that
contains a mixture of the red, green, and blue channels.

To convert grayscale images to RGB images

1 Open an image.

2 Select Utilities > Grays -> RGB. The Concatenate -> RGB dialog box
opens.

3 Select the image to which you want to apply the red channel in the
Image (red) list. If you loaded two images into the image window, two
file names should appear.

4 Do the same for the Image (green) list and the Image (blue) list.

5 Indicate whether you want to remap to current intensity values to the
full standard 0—255 RGB values.

the grayscale intensities and select Remap data, the system defines the
intensities as one of the 256 values. If one or all of the input images have values
that exceed 255 and you do not select Remap data, then data truncates to 255
since a color channel can only represent values 0—255.

% Note: Generally, each color is defined as one of the 256 intensities. If you remap

6 Click OK. A status message appears. When filtering is complete, the new
RGB image appears in a separate image window.
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Image (red)

Identifies the image to be added
to the red channel of the resulting

image. ¥4 Concatenate -> RGB
oes . [ Images

Image Identifies the image to be added ‘
(green) to the green channel of the [fruser et i hd

resulting image. ilmage {gree) blank x

| Troage (bl blark -

Image (blue) Identifies the image to be added V] Rernap data (0.255)

to the blue channel of the -

resulting image. ‘ oK H ool || Help
Remap data Indicates, when selected, that

(0-255) you want image intensities to be
remapped to values 0-255, which
is the standard for RGB images.

OK Applies the parameters that you specified to create an RGB image.

Cancel Disregards any changes you made in this dialog box, closes the dialog box, and
does not create an RGB image.

Help Displays online help for this dialog box.

Figure 249. Concatenate -> RGB dialog box

Inserting slices into image datasets

When you change an image dataset, you are inserting or removing slices in
the dataset or changing their order.

You can use the Insert Slice command on the Utilities menu to insert a slice
into an image dataset. Although you cannot insert a slice from another file,
you can insert either a blank slice or a new slice that is an average of two
adjacent slices in the dataset.

To insert slices into image datasets

1 Select Utilities > Insert Slice. The Insert Slice dialog box appears.

2 Enter the number of the new slice position in the Insert before slice (1-
124) or enter 125 for new last slice box.
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3 Select either the Average or Blank radio button. If you select Average,
MIPAYV analyzes the slices immediately before and after the new slice in
the dataset. The software then generates an intermediary composite by
morphing the two slices. This composite becomes the new slice. If you
select Blank, MIPAYV inserts a blank slice in the dataset.

4 Click OK. MIPAYV inserts the new slice into the dataset and opens the
new dataset in a new image window.

Insert before
slice (1-124)
or enter 125
for new last
slice

Specifies the position of the
new slice.

L :
X4 Insert slice

Insert slice

Average

_ _ Insert before slice #(1-1243 or enter 125 for newr last shice
Inserts a slice that is the

average the adjacent slices. @ Average

Copy previous

i i (21 Copy previous adjacent
Insert a slice that is a copy of

adjacent the preceding slice. (. Copy next adjavent
7 Blank
Copy next Inserts a slice that is a copy B
adjacent of the following slice. iG]
Blank Inserts a blank slice. - || P H Help
Original Inserts an image from the
original dataset.
OK Applies the parameters that you specified to insert the slice in the image dataset.
Cancel Disregards any changes you made in this dialog box, closes the dialog box, and
does not insert the slice into the image dataset.
Help Displays online help for this dialog box.

Figure 250. Insert Slice dialog box
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Inverting the order of images (slices) in
datasets

As its name implies, the Inverse Slice Order command on the Utilities menu
reverses the order of the slices in a dataset.

To invert the order of images in datasets

1 Open an image that contains slices.

2 Use the image slider in the MIPAV window to locate slices that you want
to inverse.

3 Select Utilities > Inverse Slice Order.

A status message appears and indicates that the software is reordering
the slices in the dataset. In a moment or two the MIPAV window
refreshes, and the image window in which the original dataset appeared
displays the reordered slices.

Masking images

Masks allow you to remove portions of images and display only those
portions as separate image files. For example, you may only be interested in
a section of an image and only want to display and work with that section.

To create a mask, you first need to create one or more VOIs on the image.
Depending on the type of mask you want to create, the VOIs should do
either of the following:

e Enclose the image areas you want to preserve
e Enclose the image areas you do not want to preserve

If the VOIs indicate the areas of the image that should be deleted from the
image, you need to create an interior mask and specify the number of pixels
the program should use to hide the image inside the VOIs, or interior
(Figure 251B).

To preserve the image inside the VOIs, however, you need to create an
exterior mask. An exterior mask fills the image outside of the VOIs with the
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number of pixels you specify. This filling hides the portions of the image
outside the VOIs, or exterior (Figure 251C).
'.' pos?4_before_cerrSp 3., ':]EH
EEX
(B) Interior fill mask IC Exterior fill mask

Figure 251. Interior and exterior masks
To create an interior mask

1 Open an image.

2 Create one or more VOlIs that enclose the portions of the image that

interest you.

3 Select Utilities > Mask. The Mask dialog box (Figure 252) opens.

4 Type the number of pixels to fill the interior of the VOls.

5 Select Interior fill.
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6 Select either New Image or Replace Image depending on which you
prefer.

7 Click OK. The program either displays a new image or replaces the
current image with an image that hides the portions of the image that
are inside the VOIs (Figure 251B).

To create an exterior mask

1 Open an image.

2 Create one or more VOlIs that enclose the portions of the image that
interest you.

3 Select Utilities > Mask. The Mask dialog box (Figure 252) opens.

4 Type the number of pixels to fill the interior of the VOls.

5 Select Exterior fill.

6 Select either New Image or Replace Image depending on which you
prefer.

7 Click OK. The program either displays a new image or replaces the
current image with an image that hides the exterior of the image outside
the VOIs (Figure 251C).

Parameters Specifies the value in pixels to
fill the VOI.
4 Mask image
Interior fill Applies the value to the interior [ Parameters
of the VOI. ] Falue used to fill FOI(s)
®) Interior fill
Exterior fill Applies the value to the exterior ) Exterior il
of the VOI. '
[ Destination
New image Shows the cropped image in a @) New imaze
new image window. ) Replace image
Replace image Replaces the current active ‘ OK H Cancel H Help

image with the cropped image.

OK Applies the parameters that you specified to mask the image.

Cancel Disregards any changes you made in this dialog box, closes the dialog box,
and does not mask the image.

Help Displays online help for this dialog box.

Figure 252. Mask Image dialog box
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Matching images

The Match Images command on the Utilities menu assists in any
comparison of two images. To use this utility, you need to first open two
images: image A, which has the desired characteristics, and image B, whose
characteristics need to match those of Image A. The Match Images dialog
box presents the following four ways in which you can match the images:

* Match image orientation—Rotates Image B so that its orientation
is the same as the orientation of image A.

e Match resolutions—Subsamples the image for each dimension with
lower resolution (i.e., larger pixel size) so that both images have the
same resolution. To ensure that the fields of view remain the same, the
program adds extra pixels to the image.

e Match origins—Adds margins to one of the images for each
dimension if the origins (i.e., the starting location) of the two images
are not the same. The program also adds pixels to the left, top, or front
of the image.

e Match image dimensions—Adds pixels to the right, bottom, or
back of either image so that they have the same dimensions.

You can select one or more of these choices in the dialog box. Before actually
performing any selected comparison, MIPAYV first checks to see whether the
images do not already match in that regard. If they do, the given match is
not performed.

To match image orientation

1 Open two images.

2 Select Utilities > Match images. The Match Images dialog box
(Figure 253) opens.

3 Select one of the open images as image A, and select the other image as
image B.

4 Select Match image orientations (based on imaging orientation).
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5 Select any or all of the other check boxes to also, if desired, match image
resolutions, origins, or dimensions.
6 Click OK. If the orientations of the images differ, the program changes
the orientation of Image B to match that of image A.
To match image resolutions
1 Open two images.
2 Select Utilities > Match images. The Match Images dialog box
(Figure 253) opens.
3 Select one of the open images as image A, and select the other image as
image B.
4 Select Match image orientations (based on imaging orientation).
5 Select any or all of the other check boxes to also, if desired, match image
resolutions, origins, or dimensions.
6 Click OK. If the resolutions of the images differ, the program changes
the resolution of Image B to match that of image A.
To match image origins
1 Open two images.
2 Select Utilities > Match images. The Match Images dialog box
(Figure 253) opens.
3 Select one of the open images as image A, and select the other image as
image B.
4 Select Match image origins (by adding margins where necessary).
5 Select any or all of the other check boxes to also, if desired, match image
orientations, resolutions, or dimensions.
6 Click OK. If the origins of the images differ, the program changes the
origin of Image B to match that of image A.
To match image dimensions
1 Open two images.
2 Select Utilities > Match images. The Match Images dialog box
(Figure 253) opens.
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3 Select one of the open images as image A, and select the other image as
image B.

4 Select Match image dimensions.

5 Select any or all of the other check boxes to also, if desired, match image
orientations, resolutions, or origins.

6 Click OK. If the dimensions of the images differ, the program changes
the dimension of Image B to match that of image A.

Troage &:

Ireage B

";‘] Match Images

L

Match image features:

[¥] Match image orientations (based on imaging orientation)
[¥i Match image resolutions, axis by axis (by subsampling image with lower resolution)
[v] Match image origins (by adding margins where necessary)

[v] Match image dimensions

Lo_10677_4 -

EERY |

Image A

Specifies the image that contains the orientation, resolution,
origins, or dimensions with which Image B needs to match.

Image B

Specifies the image on which to perform the image matching.

Match image orientations
(based on imaging
orientation)

Applies the image orientations (based on image orientation) used
in Image A to Image B.

Match image resolutions,
axis by axis (subsampling
image with lower resolution)

Matches the image resolutions in Image A to Image B. Note that
this subsamples Image A with a lower resolution if necessary.

Match image origins (by
adding margins where
necessary)

Matches the image origins used in Image A to Image B. Note that,
if necessary, this adds margins to Image B.

Match image dimensions

Applies the image dimensions used in Image A to Image B.

OK

Applies the parameters that you specified to add margins to this
image.

Figure 253. Match Images dialog box
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Cancel Disregards any changes you made in this dialog box, closes the
dialog box, and does not perform image matching.
Help Displays online help for this dialog box.

Figure 253. Match Images dialog box (continued)

Adding noise to images

Adding noise to images allows you to test the robustness and performance
of an algorithm in the presence of known amounts of noise. When you select
Utilities > Noise, the program clamps either Gaussian or uniform noise to
the lowest or highest value in the source image type..

This class relies heavily on the Java Random class and is used to generate a
stream of pseudorandom numbers. The class uses a 48-bit seed, which is
modified using a linear congruential formula (refer to Donald Knuth, The
Art of Computer Programming, Volume 2, Section 3.2.1.).

To add noise to images

1 Open an image on which you want to test the effectiveness of an
algorithm.

2 Select Utilities > Noise in the MIPAV window. The program displays the
Additive Noise dialog box (Figure 254).

3 Type the level of noise that you want to add to the image in the Noise
level box. You can specify a value from 10 to 32,768.

Noise level (0-32768) Specifies the level of noise to
add to the image. =
r.4, Additive noise
The default value is 10. vaze(i}= Inae (L muise.
- ; ; Moise level (0- 327623 1500 |
Gaussian Adds Gaussian or uniform e
noise to the image. 'Nm Tipe ST
. . . ) CGangsian (@ New irage
Uniform Adds Uniform noise to the
image_ ) Uniform (1 Replace image
New image Shows the cropped image in a | OK H Cancel H Help
new image window.
Figure 254. Additive Noise dialog box
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Replace image

Replaces the current active image with the cropped image.

OK Applies the parameters that you specified for adding noise to this image.

Cancel Disregards any changes you made in this dialog box, closes the dialog
box, and does not add noise to this image.

Help Displays online help for this dialog box.

Figure 254. Additive Noise dialog box (continued)

4 Type the level of noise that you want to add to the image in the Noise
level box. You can specify a value from 10 to 32,768.

5 Select either of the following:
e Gaussian—To add Gaussian noise to the image
e Uniform—To add Uniform noise to the image
6 Select either of the following:
* New image—To generate the resulting image in a new image window
e Replace image—To replace the current image with the resulting image

7 Click OK. The program adds the Gaussian or Uniform noise to the image

and displays either a new image or replaces the current image with the
one to which noise was added.

8 Select the algorithm in the Algorithms menu to test its effectiveness on
the image.

Example. In the following example (Figure 255), the original image appears at
the top of the figure. The next row shows the image on the left that results from
adding Gaussian noise of 100. To its right is the image after running the Median
algorithm. The image on the left on the last row results from adding Uniform
noise of 100 to the orginal image. Running the Median algorithm on that image
produces the image on its right. In this example, the Median algorithm performs
better on an image containing Gaussian noise.
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»¢ pos74_before_corrSp 3 =]l

{A) Original image

L-", Position?4_noise 5M10 ..-_ |‘ﬁ|r§

ry - s @ Fr
L% Position24_noise_media... [= FE.‘Q

(B} Image with additive Gaussian (C} Image B after running the Median
noise of 100 algorithm

Position24_noisel 5110 ':rE'g r.% Position?4 _noisel_med L EK

.

(E) Image D after running the Median
algorithm

(D) Image with additive Uniform
noise of 100

Figure 255. Examples of adding noise to an image and using it to test an
algorithm’s effectiveness in removing the noise
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Randomizing image (slice) order
To randomize the order of slices in the image dataset, do the following:

1 Open an image that contains slices.

2 Use the image slider in the MIPAV window to locate slices that you want
to remove.

3 Write the slice numbers on a piece of paper.

4 Select Utilities > Randomize Slice Order. A status message appears, and
the system arbitrarily reorganizes the slices.

A status message appears. Then the MIPAV window refreshes and,
depending on your selection, the new dataset appears in either a new
image window or in the same image window as the original dataset.

Rotating images

You can rotate images about the x, y, and z axes. For example, suppose that
you opened the following image:

S _s 1 2. [C)EK

Original image

Figure 256. Original image to be rotated
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To rotate images
1 Select Utilities > Rotate in the MIPAV window.
2 Select one of the following:

e X Axis +90: To rotate the image about the x axis by +90 degrees.

X Axis -90: To rotate the image about the x axis by -90 degrees.

Y Axis +90: To rotate the image about the y axis by +90 degrees.

Y Axis -90: To rotate the image about the y axis by -90 degrees.

Z Axis +90: To rotate the image about the z axis by +90 degrees.

Z Axis -90: To rotate the image about the z axis by -90 degrees.

£ axis is into the screen o %

L The plus signs indicate that
the rotation is in the positive
direction.

Figure 257. Rotation

A status message appears. When rotation is complete, the status window
closes, and MIPAYV replaces the original image in the image window with
the rotated image.
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(E) Z axis at +90 degrees (F) Z axis at -90 degrees
Figure 258. Examples of rotated images
This figure shows the image in Figure 256 at the six different types of x, y, and z
rotation.
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Removing images (slices) from datasets

MIPAV allows you to remove one, several, or all slices from an image
dataset. In addition, you can specify one or more ranges of slices to remove,
or slice removal can include only the even-numbered or only the odd-
numbered slices.

To remove slices from datasets

1 Select Utilities > Remove slices. The Remove Slices dialog box opens.

2 Use the image slider in the MIPAV window to locate slices that you want
to remove.

3 Decide whether to remove:

e One or more slices

Most of the slices

One or more ranges of slices
All even-numbered slices
All odd-numbered slices

Tip: Use the image slider on the MIPAV window to look at specific slices to decide
which slices to remove.

4 Select one of the following:

e New image—If the new image dataset should appear in its own image
window

* Replace image—If the dataset should overwrite the original dataset
and appear in the original image window

5 Select Remove. A status message appears. Then the MIPAV window
refreshes and, depending on your selection, the new dataset appears in
either a new image window or in the same image window as the original
dataset.
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: : [ Image slice 1 =]
Select all Selects all of the slices in the ) 22
] Image slice 2
dataset. )
1 Image slice 3
Clear Clears all of the slices that are [l Image slice 4 =
currently selected.
Select all Clear
Check even Selects all of the even-numbered Check even Check odd
slices. “Range of slices

Check odd

[ Speci fslic
Selects all of the odd-numbered Spmfymge”es

Specify range
of slices

slices. =
Indicates that you want to '.'D finati
remove one or more slices or a i
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range of slices from the dataset.

) Replace image

If you select this check box, you
must specify the slices or ranges w H e H Help

of slices you want to remove. in
the Slice number or range of
slices box below.

Slice number or
range of slices

Indicates the specific slices and range of slices that you want to remove.

New image

Shows the results of the slice removal in a new image window.

Replace image

Replaces the current active dataset with the dataset resulting from the slice
removal in the same image window.

Remove Removes the slices that you indicated in this dialog box.

Cancel Disregards any changes that you made in this dialog box and closes the dialog
box.

Help Displays online help for this dialog box.

Figure 259. Remove Slices dialog box
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Removing time volumes

If an image dataset contains blank images or unusable images, which might
be caused by patients blinking their eyes during tests, the Remove Time
Volumes command on the Utility menu in the MIPAV window allows you to
remove unusable images from the dataset.

To remove time volumes

1 Open an image dataset that contains time volumes.

Note: The Remove Time Volumes command only becomes active for 4D image
datasets.

2 Use the image slider to look through the dataset one time volume, or
image, at a time (Figure 260). If you find an unusable volume—one that
is blank, or totally black, or that contains unusable information—stop
moving the slider on that volume.

Note: The volume number appears in the title bar of the MIPAV window and
correlates to the slice indicated by the image slider.

3 Select Utilities > Remove time volumes. The Remove Time Volumes
dialog box (Figure 259 on page 379) opens.

4 Select the volume or volumes that you want to remove in the list at the
top of the dialog box, or type the number of the slice or range of volumes
in the Check the time slices to remove group box.
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5 Do either of the following:
* Click Select all to remove all of the slices.
» Click Remove to remove the slices you selected.
A status message appears. Then the MIPAV window refreshes.

6 Use the image slider again, if you'd like, to look through the slices in the
dataset to verify that the appropriate slices were removed.

Image slice and total
| number of slicesin the
image

A blank slice like this |
one may be one that [
you want to remove.
Note that this slice

Figure 260. Using the image slider to look through an image dataset
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Converting RGB datasets to grayscale datasets

On the Utilities menu in the MIPAV window, the RGB conversion utility
offers both a manual and an automatic method of converting RGB datasets
to grayscale RGB images.

* Manual conversion—In the manual method of conversion, you
select Utilities > RGB > RGB -> Gray to display the RGB -> Gray dialog
box (Figure 262). The dialog box provides three weighting methods:

» Equal weights—This method assigns equal weights to each of the
three color channels. When you select this option, you can also select
the Only average RGB values greater than check box and specify a
threshold value. For example, if you specify a threshold value of 50,
the program ignores any pixel in that channel that contains a value
over 50.

Note: You can only specify a threshold when you choose to use the equal
weights method of conversion.

» Computer graphics weights—This method assigns the weights to
each channel that are typically used to display computer graphics.

» User-specified weights—In this method, you enter the specific
weights for each color channel.

e Automatic conversion—If, instead, you select Utilities > RGB >
RGB -> Grays, the program automatically converts the RGB image to
three grayscale images: one each for the red, blue, and green channels.
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Figure 261. The Utilities > RGB menu

RGB datasets have four channels: red, green, and blue. When you convert
RGB datasets to grayscale. RGB images, the intensities are combined to
form a single grayscale value. For example::

N=RxRW+GxGW+BxBW

where

N = New grayscale pixel

R = Red channel

G = Green channel

B = Blue channel

RIW = Weight assigned to the red channel
GIV = Weight assigned to the green channel
BIV = Weight assigned to the blue channel
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Equal weights

Assigns the same
weight (0.3333) to
each channel in the
image. When you
select this option, the
Only average RGB
values great than
becomes available.

¥4 RGB -> Gray

“Weighting method
® Bl weights
(2} Computer graphics
i) Wser specifisd

Computer
graphics

Assigns the weighting
factors typically used
in computer graphics
to each channel in the
image:

~RGE weight factors

[Z] Only average RO R values greater than

* Red, 0.299
* Green, 0.587
* Blue, 0.114

OK ‘ ‘ Cancel ‘ ‘ Help

User specified

Specifies a weight that you determine for each channel. When you select this
check box, you must type a specific weight for each channel in the Red, Green,
and Blue boxes.

Red Specifies the weight assigned to the red channel in the image. You can only specify
a weight in this box if you selected the User specified option.

Green Specifies the weight assigned to the green channel in the image. You can only
specify a weight in this box if you selected the User specified option.

Blue Specifies the weight assigned to the blue channel in the image. You can only

specify a weight in this box if you selected the User specified option.

Only average
RGB values
greater than

Excludes any voxel in the image over the threshold value that you specify in this
box. This check box is only available when you select the Equal Weights option.

OK Applies the parameters that you specified to create a grayscale image.

Cancel Disregards any changes you made in this dialog box, closes the dialog box, and
does not create a grayscale image.

Help Displays online help for this dialog box.

Figure 262. RGB -> Gray dialog box
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To manually convert RGB datasets to grayscale
1 Select Utilities > RGB > RGB -> Gray: The RGB -> Gray dialog box
(Figure 262) opens.
2 Select one of the following weighting methods: equal weights, computer
graphics, or user specified.

» If you selected Equal Weights, decide whether to apply a threshold
to the RGB channels. If you want to apply a threshold, select Only
average RGB values greater than and enter the threshold value.

Then go to the next step.
 If you selected Computer graphics or User specified, go to the next
step.

3 Click OK. A status message appears. In a few moments, the image is
replaced by the new grayscale dataset.
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(A) Original RGB image
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(B) Image converted to grayscale using equal [C} Image converted to grayscale using equal
weights welghts and a threshold of 50

¥ ph10662 M:0.5 YA ph10661 M:0.5

(D) Image converted to grayscale using (E) Image converted to grayscale using
computer graphics weights user-specified weights

Figure 263. Manually converting RGB datasets to grayscale

To automatically convert RGB datasets to grayscale
image

Select Utilities > RGB > RGB -> Grays. The program briefly displays a
status message during the conversion and then generates three new
grayscale datasets, one for each channel.
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(A) Original calorimage (B) Gray red channel image
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(C) Gray green channel image (D) Gray blue channel image

Figure 264. Example of three grayscale datasets generated
automatically from an RGB dataset

Subsampling images

The subsample utility in MIPAV allows you to reduce an image in size by a
factor of 2, 4, or 8 times. Each pixel of the subsampled image is a Gaussian-
weighted average of the original image’s 8 neighboring pixels for 2D images
or 26 neighboring voxels for 3D images. For example, subsampling a 3D
image with the x, y, and z dimensions of 256 x 256 x 32, respectively, by a
factor of 2 produces a new image with x, y, and z dimensions of 128 x 128 x
16, respectively.
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To subsample images
1 Open an image (Figure 265).

2 Select Utilities > Subsample. The Subsample dialog box (Figure 266)
opens.

¥4 920 13 M:0.5

Figure 265. Original image before subsampling

3 Select one of the following:
e Subsample by 2
* Subsample by 4
» Subsample by 8
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Subsample by 2

Subsamples each
image dimension by a
factor of 2.

E’;‘] Subsample

Subsample by 4

Subsamples each
image dimension by a
factor of 4.

New Size-
® Subeample by 2
) Subsampls by 4

Subsample by 8

Subsamples each
image dimension by a
factor of 8.

(1 Subsaraple by &
[Z] Process each slice independently (250

0K | ‘ Cancel | ‘

Help

Process each slice

Filters each slice of the dataset independently of adjacent slices.

independently

(2.5D)

OK Applies the parameters that you specified to subsample the image.

Cancel Disregards any changes you made in this dialog box, closes the dialog box,
and does not subsample the image.

Help Displays online help for this dialog box.

Figure 266. Subsample dialog box

v

independently (2.5D) check box.

4 Select, as an option for 2.5D images only, the Process each slice

Tip:

If you are not working with 2.5D images, the Process each slice
independently (2.5D) check box does not appear in the Subsample dialog box.

the subsampled image in a new image window.

5 Click OK. A status message appears briefly while the program generates
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(C) Image subsampled by 8

A} Image subsampled by 2

Figure 267. An image subsampled by 2, by 4, and then by 8

Swapping the third and fourth dimensions

Swapping the third and fourth dimensions refers to how image datasets are
stored. Datasets may be stored using the following two methods:

e xytz (horizontal, vertical, time, third dimension)
e xyzt (horizontal, vertical, third dimension, time)

Because MIPAYV requires that datasets be stored using the xyzt method, it
provides the Swap Dims 3 <-> 4 command for those users whose datasets
may be stored using the xytz method.
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To swap the third and fourth dimensions

1 Open an image that is stored using the xytz method.

2 Select Utilities > Swap Dims 3 <-> 4. A progress message (Figure 268)
appears briefly while the program changes the storage method of the
image and replaces the image with one that is stored using the xyzt
method.

X anat+acpc111 46% |-Z]|E| [El

Swapping Dimensions 3-4 ...

[ | 4544

Bl

Figure 268. Progress message for swapping the third and fourth
dimension
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