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3 Getting Started Quickly with MIPAV
This chapter provides information to help you get started quickly using 
MIPAV. 

• “Starting MIPAV” on page 18

• “Opening and loading image files” on page 20

• “Selecting views” on page 29

• “Adjusting magnification” on page 34

• “Improving contrast, adding color, and creating negative images” on 
page 41

• “Comparing images using alphablending” on page 51

• “Creating new images” on page 52

• “Delineating volumes of interest (VOIs)” on page 55

• “Calculating VOI statistics” on page 60

• “Modifying image resolutions” on page 70                                                                                                                                                                       

• “Printing images or graphs” on page 75                                                                                                                 

• “Saving images” on page 76

• “Customizing MIPAV” on page 79

• “Managing memory resources” on page 88
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• “Developing and using plug-in programs” on page 91

• “Quitting MIPAV” on page 91

Starting MIPAV

Starting MIPAV differs depending on your platform. To begin a MIPAV 
session, do the following:

Both the Medical Image Processing, Analysis & Visualization (MIPAV) 
window (Figure 6) and the Output window (Figure 7) appear on your 
desktop. You can access most of MIPAV’s features from the menu bar in the 
MIPAV window.

If your platform is . . . Then . . .

Windows 95, 98, 2000, 
NT, XP

Select Start > Programs > mipav > mipav.

Linux Open a shell. Go to the directory where you 
downloaded the installer. At the prompt, type 
sh ./installMIPAV.bin. 

Mac Operating System 
(OSX)

Unzip the installer (StuffIt expander may 
open automatically). Double-click the installer 
icon on your desktop.

Unix OS (Sun Solaris, 
OS/2 Warp, and others

In a shell tool, command tool, or terminal 
window, go to the directory where you 
installed MIPAV. At the prompt, type 
./mipav.
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After starting MIPAV, you can open and load image files, create new 
images, access DICOM images, customize MIPAV, and end the session.

Figure 6.  The MIPAV window that appears after starting the program

Figure 7.  Output window
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Opening and loading image files

The first step in image visualization is displaying the image file. MIPAV 
displays images in windows that you can move around the desktop 
(Figure 8). You can display as many image datasets as needed as long as 
your computer has enough allocated memory. The amount of memory 
required depends on the number of image datasets that are open and the 
size of each image file. For more information, see “Managing memory 
resources” on page 88.

You can either open or load an image file. When you open an image file, 
MIPAV displays the image in a new image window. Loading an image file 
imports the file into an image window in which another image file is open. 
In other words, two image files share a common image window.

Tip: If you need to compare two images that reside in different datasets, do 
the following:

1 Open the first image file. The image appears in a new image window.

2 Load the next image file. The image appears in the same image window as 
the first image file.
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Note: Only two images can occupy an image window. If you load a third image, 
it overwrites Image B.

You can use MIPAV to open or load files of a variety of medical and generic 
graphic and multimedia file formats. Table 1 lists the format, 

extension, and whether MIPAV can read or write files of a particular format. 
The extension, which is the last few characters of a file name including the 
period, indicates the file format. In the file name DOE255.ima, the 

Figure 8.  Desktop showing the MIPAV window, the Output window, and multiple image windows
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extension .ima indicates that the file is stored in DICOM format. In the 
table, the Read column indicates that MIPAV can display image files of a 
particular format. When a file is read, it is stored in main memory so that 
MIPAV can access it. The Write column means that MIPAV can copy the 
data from the memory to a storage destination, such as your hard disk. In 
this context, write is synonymous with save. For more information on file 
formats, refer to Chapter 4 in the MIPAV User’s Guide.

Table 1. File formats 

Manufacturer or 
Application Extensions Read Write

Adobe Photoshop PSD Y Y

AFNI HEAD, BRIK Y Y

Analyze IMG Y Y

Audio Video Interleave AVI Y Y

BIORAD PIC Y N

Bruker 2dseq Y N

Cheshire IMG or IMC Y Y

DICOM DCM, IMA Y Y

FITS FTS Y N

FreeSurfer image COR Y N

FreeSurfer surface (ASCII file) ASC Y N

GE – Genesis 5X and LX SIG Y N

Graphics Interchange File GIF Y N

ICS (Integrated Collection 
System)  

ICS Y N

Interfile HDR Y N

Joint Photographics Experts 
Group 

JPEG,JPG Y Y

Laser Scanning Microscope 
(Zeiss) 

LSM Y Y

Macintosh PICT PICT Y Y
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Medical Image Network 
Common Data Form including 
ROIs

MNC Y Y

MICRO-CAT LOG Y N

Microsoft Windows Bitmap BMP, DIB Y Y

Medical Research Council 
(MRC)

MRC Y Y

PC Paintbrush PCX, DCX, PCC Y Y

Portable Network Graphic PNG Y Y

QuickTime--Apple QT, MOV Y Y

RAW RAW Y Y

Siemens – Magnetom Vision IMA Y N

Sun Raster RS, RAS Y Y

Tag Image File Format TIFF Y Y

Truevision Graphics Adapter TGA, VST, VDA, 
ICB, TPIC

Y Y

X BitMap XBM Y Y

X PixMap XPM Y Y

Table 1. File formats  (continued)

Manufacturer or 
Application Extensions Read Write
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Opening image files
You can open a single image file or multifiles. Multifiles are image datasets 
that are composed of multiple files. 

To open an image file

1 Do one of the following in the MIPAV window:

• Opening other types of image files: Select File > Open > Image.

• Opening a multifile: Select File > Open > Multifile.

Tip: To form a 4D dataset in Analyze format, use the Multifile command to open 
a series of individual 3D Analyze, formatted, consecutively ordered images. 

For example, you can use the Multifile command to open an array of .tiff, 
.jpeg, .bmp, etc., files if their file names meet the following format: 

foo_001.tiff, foo_002.tiff, foo_003, etc.

where foo is the name of the file.

The Open Image dialog box (Figure 9) opens.

Note: If an image file is already open on your desktop, the commands on the 
File menu vary slightly. Select Open > Multifile(A) to open an image dataset that 
consists of multiple files. Select Open > Image(A) to open a single image file.

2 Navigate to the directory where the file is stored.

3 Select the type of file in the Files of type list (shown in Figure 9).
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4 Select the file. The name appears in File name.

5 Click Open. While the file is opening, a status message appears. Then 
the status window closes, and MIPAV displays the image in a new image 
window (Figure 10).

Figure 9.  Open Image dialog box showing shortcuts

Figure 10.  An image displayed in an image window
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Note: After the first image is opened, the MIPAV window changes. It includes 
more menus, the title bar displays more information, and toolbars appear. 
Because the MIPAV window is context sensitive, it displays or hides commands 
on the menus depending on the characteristics of the image file that is opened. 
If you opened a dataset file that contains more than one image, a slider also 
appears.

Note: If you prefer for MIPAV to use the style of Open and Save dialog boxes 
that are used by the operating system (e.g., Microsoft Windows, Unix, or Apple) 
on your computer, read the section on “Using platform-specific Open and Save 
dialog boxes” on page 81.

Loading image files
You can either open or load image files. When you open an image file, 
MIPAV displays the image, by itself, in a new image window. When you 
load an image file, MIPAV imports it into an existing image window. The 

Figure 11.  Expanded MIPAV window showing toolbars, image slider, 
and more menus after the first image is opened
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loaded image shares the same window with another image file. Loading a 
file allows you to compare two datasets. 

In MIPAV, the first image opened in an image window is referred to as 
Image A. When you load, or import, a second image in the window, MIPAV 
refers to the second image as Image B. 

To load an image file

1 Open the first image by selecting File > Open > Image(A) or 
File > Open > Multifile(A). The image appears in an image window. 

2 Select the title bar of the image window (in this case, the image that you 
just opened) in which you want to load another image. 

3 Select any of the following: 

• File > Load > Image(B) from Frame—To load another image dataset 
from an already opened image dataset to another opened image 
dataset

• File > Load > Image(B) from File—To load another image dataset

• File > Load > Multifile(B)—To load a multifile image dataset

Tip: You can use this option to load a series of individual 3D Analyze formatted, 
consecutively ordered images to form a 4D dataset in Analyze format.)

Note: The abbreviations (A) or (B) appear after some commands. (A), which is 
the abbreviation for "Image A," indicates that the option is applied to the first 
image opened in an Image window. (B), which is the abbreviation for "Image B," 
indicates that the option is applied to second image loaded in an Image window. 
For example, if you select Close Image (B), MIPAV closes the second image 
(Image B) that was loaded in the image window.

The Open window appears. 

4 Select the image file you want to load. 

5 Click OK.

If MIPAV does not recognize the type of file based on its extension, the 
Choose File Type dialog box opens. Select the file type and click OK.
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.

Note: MIPAV recognizes files types by the file extension. For example, if you 
select an image named Smith.tiff, MIPAV tries to open the file as a tiff file. If that 
image is actually a .jpg file and mistakenly has the .tiff extension, MIPAV cannot 
open the file.

As the image file is loading, a pop-up window appears with the status. 
When the image file finishes loading, it appears in the image window. At 
this point, take note of several changes:

• MIPAV pseudo-color was applied to the images in the image 
window. The pseudo-color indicates that two images are in the 
window.

• In the MIPAV window, the Active Image and Alphablending slider 
appears. The slider allows you to control which image is displayed in 
the foreground of the window. The image in the foreground is the 
active image. You can adjust the translucency of the alpha channels 
in each image using the technique.

Figure 12.  Choose File Type dialog box
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Selecting views

A view refers to the way an image file is displayed. A view indicates how 
many images are shown at one time and whether images are advanced 
manually or automatically. Depending on the view, the size and shape of the 
image window in which an image is displayed can vary.

MIPAV allows you to display images using the following views: 

• Default (explained in this section)

• Animate

• Cine (movie)  (explained in this section)

• Lightbox  (explained in this section)

• Link to another image 

• Surface plotter

• Surface render

• Triplanar 

• Triplanar—dual

• Volume render (shear)

• Volume render

Note: This section explains how to display image files in default, lightbox, and 
cine views. To learn how to display image files in other views, see Chapter 6 in 
the MIPAV User’s Guide.
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Understanding image windows
An image window (Figure 13) consists of a title bar that displays the name 
of the image file and the magnification level. If there is more than one image 
in the dataset, the title bar displays the number of the current image that is 
displayed and the total number of images in the dataset.

Moving images
You can move an image window around your desktop by clicking the title 
bar and dragging the window to a new location. Sometimes, depending on 
the view, a toolbar or menu bar also appears in the image window. For 
example, the image window using the light box view contains a toolbar and 
menu bar.

Displaying images using the default view
In the default view, MIPAV displays the images in a dataset one at a time in 
an image window (Figure 14). This window can display datasets of any 
dimension.

Figure 13.  An image window
MIPAV User’s Guide, Volume 1, Basics 30

9/20/04 



M   I   P   A   V
M e d i c a l   I m a g e   P r o c e s s i n g, A n a l y s i s,   &   V i s u a l i z a t i o n

Chapter 3,  Getting Started Quickly with MIPAV
Displaying images using the lightbox view
The lightbox view is similar to the default view, except that all images in the 
dataset appear in one window at the same time (Figure 15).

To display images in the lightbox view

1 Open an image file. The image appears in an image window.

2 Select the image window. Do one of the following in the MIPAV window:

• Click Lightbox .

• Select Image > Views > Lightbox.

The image now appears in a lightbox view.

Tip: To magnify a portion of the image, click Magnification Region  and move 

the pointer to the image section to be magnified. Click Default Mode  when 
finished.

Figure 14.  An image in an image window (default view)
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3 Select Options > Settings in the lightbox view window to adjust the size 
and shape of the window. 

The Lightbox Settings dialog box (Figure 16) opens.

4 Indicate the number of rows and columns, the grid size, frame border 
size, color settings, and the magnification. For more information on 
these attributes, see volume 1 of the MIPAV User’s Guide.

5 Click Close when complete.

Figure 15.  An image dataset shown in a lightbox view
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Tip: Double-clicking an image in the lightbox view updates the 2D image frame 
to that image.

Displaying images using the cine view
When you view an image file in cine view, MIPAV automatically advances 
images one frame at a time. The effect is much like a film loop. 

To display images in cine view

1 Open an image file. The image appears in the default image window.

2 Select Image > Views >  Cine (Movie). The images in the image 
window are advanced automatically.

Figure 16.  Lightbox Settings dialog box
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Adjusting magnification

MIPAV allows you to magnify images from ¼ to 32 times the size of the 
original image. Using the magnification tools, you can magnify or minify the 
entire image or just a portion of the image. The magnification box is much 
like a traditional magnifying glass, except it can also minify, or reduce the 
level of magnification, a portion of the image. 

This section explains how to change the magnification level of the image 
using the icons on the image toolbar (Figure 17) in the MIPAV window.

 

To learn how to set the magnification level using the other methods, see 
volume 1 of the MIPAV User’s Guide. 

To adjust the magnification level using the image toolbar in the MIPAV 
window, you can use the following:

• Magnify Image icon 

• Minify Image icon 

• Magnify Region icon 

• Original Magnification icon 

Magnifying images

To magnify an image, click Magnify Image . Each time you click the 
Magnify Image icon, the image doubles in size. If an image is too large for 

Figure 17.  Magnification icons are located on the image toolbar
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the current window size, scroll bars appear, and you may need to manually 
adjust the size of the window.

Reducing the magnification level

To reduce the magnification level of an image, click Minify Image . Each 
time you click the Minify Image icon, MIPAV reduces the magnification 
level of the image by half.

Figure 18.  Original image and magnified image achieved from click the Magnify Image icon once
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.

Restoring the original level of magnification
To return the image to its original size or original level of magnification, 

click Original Magnification .

Magnifying regions within images

The Magnify Region icon  allows you to view a square portion, or region, 
of the image at a specific magnification level. 

Note: If you have loaded two images into the same image window, the Window 

Region of Image B icon appears on the toolbar. Use this icon to view a region 
on the second image, or image B.

To use the Magnify Region icon

1 Open an image.

2 Click Magnify Region  and move it over the image. 

Figure 19.  Minified images that result from using the Minify Image icon
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As you move the mouse over the image, the Magnify Region icon 
displays a magnified square region in the image in a red box. The 
number at the left corner of the square is the magnification level.

To change the size of the magnified region

You can change the size of the magnifying region to allow you to view larger 
or smaller regions of the image.

1 Right-click on the image while displaying a magnified region. The 
Magnify dialog box appears.

2 Type either a higher number for a larger region or a lower number for a 
smaller region in the Width box. Valid values range from 64.0 to 198.0.

3 Select Apply. The size of the magnified region, or square, either 
increases or decreases in size.

Figure 20.  Magnified square region on an image

Figure 21.  Magnification dialog box
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INCREASING AND DECREASING THE 
MAGNIFICATION LEVEL

Changing the magnification level of the magnified region works similarly to 
changing the size of the magnified region. 

Figure 22.  Magnifying glass at different sizes
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To change the magnification level

1 Right-click on the image while displaying a magnified region. The 
Magnify dialog box (Figure 23) appears.

2 Slide the Magnification slider (Figure 23) to the right to increase the 
magnification level or to the left to decrease the magnification level.

Note: When you slide the Magnification slider right past a certain point, the 
Display intensity values check box becomes active.

3 Select Apply. 

Tip: To review or compare a magnified region of the image with the same region 
at its original magnification, press Shift. Release the key when to return to the 
magnified view.

The magnification level shown in the magnified region changes to the 
level you specified.

Figure 23.  Magnification slider on the Magnification dialog box
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SHOWING INTENSITY VALUES THROUGH THE 
MAGNIFICATION GLASS

The Display intensity values check box on the Magnify dialog box allows you 
to display the intensity values within a magnified region of the image. 

To show the intensity values

1 Right-click on the image while displaying a magnified region. The 
Magnify dialog box appears.

2 Select the Display intensity values check box. 

If the check box is not available, or dimmed (as it is in Figure 21), 
increase the magnification by sliding the magnification slider to the 
right until the check box is active (refer to Figure 23).

3 Move the mouse over the image. The intensity values appear within the 
magnified region (Figure 25).

Figure 24.  Two different magnification levels in the same magnified 
region
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Tip: If you hold down the middle mouse button, MIPAV writes the intensities 
by position within the image to the Data page of the Output window. You can 
then save these messages and print them.

Improving contrast, adding color, and creating 
negative images

This section explains how to improve the image contrast, add color to 
images, and create negative images by applying a quick lookup table (LUT), 
generating and modifying a histogram, applying pseudo-color LUTs, and 
creating negative images by inverting their color.

histogram—A histogram is a representation of a frequency distribution by 
means of rectangles whose widths represent class intervals and whose areas are 
proportional to the corresponding frequencies.

lookup table (LUT)—A lookup table maps the frequency distribution in a 
histogram to pseudo-color values.

For more information, including how to create a customized LUT, see 
volume 1 of the MIPAV User’s Guide.

Figure 25.  An image window displaying intensity values for a magnified 
region in the image
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Improving contrast on images quickly
MIPAV provides the following quick ways to improve the contrast on 
images:

• Using the Quick LUT icon

• Using the right mouse button

• Using the Adjust Window and Level icon

USING THE QUICK LUT ICON

An easy way to improve the contrast in an image is by using the Quick LUT 

icon , which is located on the image toolbar in the expanded MIPAV 
window (Figure 26). 

To use this icon, you first need to open an image to display the expanded 
MIPAV window. 

To use the Quick LUT icon

1 Open an image file. The image appears in an image window. If an image 
was not previously open, the initial MIPAV window expands to include 
all of the menus.

2 Select the image window.

3 Click Quick LUT .

4 Hold down the left mouse key and draw a rectangle on a portion of the 
image.

5 Release the left mouse key. Based on the amount of dark and light in the 
portion of the image that you selected, MIPAV changes the contrast in 
the image.

Figure 26.  Quick LUT icon on the image toolbar
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Repeat steps 3 through 5 as often as you wish to further improve image 
contrast. When you are satisfied with the contrast, save the image.

USING THE RIGHT MOUSE BUTTON

The right mouse button provides you with a very simple way of changing 
image contrast. To do so, open an image and then hold down the right 
mouse button and drag it around the screen. The cursor changes from a red 

cross to .

When you drag the cursor up and down or across the image, the image may 
become darker and gradually disappear or become lighter in appearance. At 
some points you may be able to create a negative of the image.

USING THE ADJUST WINDOW AND LEVEL 
ICON

The Adjust Window and Level icon  on the Image toolbar provides 
another way to change the contrast of images. 

Figure 27.  Images before and after applying the Quick LUT icon
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To adjust image contrast

1 Open an image file. The image appears in an image window. If an image 
was not previously open, the initial MIPAV window expands to include 
all of the menus.

2 Click Adjust Window and Level .

The Level & Window dialog box (Figure 28) appears.

3 Move each slider up or down to change the contrast of the image. The 
changes are immediately effective in the image.

4 Click Close when you are finished.

Restoring images to their original appearance

To return to the original appearance of the image, click Reset LUT , 
which is also located on the image toolbar. In addition, you can click the 

Figure 28.  Level & Window dialog box
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Gray icon  to restore the image to grayscale if you have changed or added 
colors.Improving contrast by generating and modifying histograms

A histogram is a graphic representation of the intensity level distribution in 
an image or VOI region. It displays the number of voxels at each intensity 
level. To generate a histogram of an image, you can use either the Lookup 

Table icon  on the image toolbar or the LUT menu in the MIPAV window.

To generate a histogram for an image

1 Open an image. The image appears in an image window.

2 Do either of the following:

• Click Lookup Table icon .

• Select LUT > Histogram - LUT.

Figure 29.  LUT menu in the MIPAV window
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The Histogram dialog box (Figure 30) appears.

3 Select either Whole image or VOI region(s).

4 Click OK. A progress message (Figure 31) appears.
 

After a few moments, the Lookup Table window (Figure 32) opens.

lookup table (LUT)—Indicates the intensity of each voxel in the image and, in 
MIPAV, allows you to remap the original intensities to other intensities.

transfer function—Reflects the relationship between the original image 
intensity values and how they are mapped into the LUT. The line in the LUT 
represents the transfer function.

Figure 30.  Histogram dialog box

Figure 31.  Progress message that appears when the program is 
calculating the histogram
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File Open LUT—Opens a previously saved LUT file. LUT files have an .LUT 
extension.

Save LUT—Saves the LUT displayed in this window in a LUT file.

Open Transfer Functions—Opens a previously saved transfer function. 
Transfer function files have a .FUN extension.

Save Transfer Functions—Saves the transfer function displayed in this 
window to a file.

Close LUT—Closes the LUT window.

Figure 32.  Lookup Table window
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Applying color to images using predefined LUT
MIPAV provides a variety of pseudo-color LUTs. When a pseudo-color LUT 
is applied to an image, the grayscale intensities are remapped to the pseudo-
color intensity values. The LUT toolbar appears in Figure 33.

To apply a pseudo-color LUT

1 Open an image. The image appears in the image window.

2 Select the image window.

Utilities Change number of colors—Allows you to change the number of colors 
displayed in the image. Valid values are 2 to 256.

CT function—Allows you to select a preset LUT that is appropriate for the 
image content. Values are abdomen, head, lung, mediastinum, spine, and 
vertebrae.

Invert LUT—Creates a negative of the image.

Reset histogram and LUT A—Returns image A to its original values.

Reset histogram and LUT B—Returns image B to its original values. This 
command is only available if two images are open.

LUT toolbar See Figure 33

Update (real-time) Changes the image as you make changes to the LUT, which allows you to 
see the effect of your changes immediately on the image.

Log scale (histogram) Displays the image’s histogram count in log scale along the Y axis.

Interpolate image Displays image using interpolation, which reduces pixillated image to 
appear more smooth.

Caution: Depending on the memory resources of your workstation, 
interpolation can be very lengthy.

Number of colors Allows you to change the number of colors displayed in the image. 

LUT Displays the image intensities.

Figure 32.  Lookup Table window (continued)

Using interpolation to smooth images
If you are zooming in on a portion of an image and want to reduce the 
appearance of pixilations in the image, make sure to select the Interpolate 
image check box. Interpolation smooths the pixilation. 
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3 Select one of the LUTs on the LUT toolbar (Figure 33) in the Lookup 
Table window.

 

4 Do either of the following:
• To update the view of the image immediately, select Update (real-

time). 
• If you do not want to update the view of the image, click Close. The 

Lookup Table window closes, and MIPAV applies the LUT to the 
image.

Tip: To change back to the original grayscale intensities, click Gray LUT  in the 
MIPAV window.

Figure 33.  LUT toolbar
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Creating negatives of images
The invert LUT icon creates a negative of an image. 

To create a negative image

1 Select the image window of the image you want to invert.

Tip: You may wish to apply an LUT to the image or adjust the histogram of 
the image first before applying creating the negative.

2 Click Invert LUT .

Note: Invert LUT  appears on two different windows: in the Image toolbar in 
the MIPAV window (select Toolbars > Image toolbar to display the toolbar) and in 
the LUT toolbar in the Lookup Table window. 

Based on the 256-step color values scale, MIPAV assigns the inverse value 
to each pixel (refer to Figure 34). 

Tip: The Invert LUT icon  is a toggle. To change the image back to its 
previous appearance, simply select Invert LUT  again. To change the image 
back to its original appearance, select Reset LUT .

Figure 34.  Image before and after inversion
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Comparing images using alphablending

Alphablending is a technique that adds transparency information to 
translucent objects. When two images share a window, you can adjust the 
alphablending settings so that you can see a blend of both images and can 
compare overlapping regions in two datasets. 

To use the alphablending function

1 Select an image window that has two images.

2 Adjust the alphablending slider at the bottom of the MIPAV window.

3 Move the slider to select the best ratio for the datasets of interest. 

The level of translucency for one image is inversely proportional to the 
other. Thus, if image A is 75 percent transparent (25 percent opaque), 
then image B is 75 percent opaque (25 percent transparent).

Figure 35.  MIPAV window showing the alphablending slider at the bottom of the window
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Creating new images

To create a new image file

1 Do one of the following: 

• If an image file is not already open, select File > Create Blank 
Image(B).

• If an image file is already open, select File > Open > Create Blank 
Image(A). 

The Raw dialog box (Figure 36) appears.

2 Select the image type. 

3 Select the units of measure for each dimension. 

4 Enter the header offset and byte ordering information.

Figure 36.  Raw dialog box
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Image type Synonymous with data type. The image type determines the number of intensities 
that can be represented in an image. For example, a Boolean image can display two 
intensities: 1 and 0. 

• Boolean—1 bit per pixel (1 on, 0 off)
• Unsigned byte—1 byte per pixel (0, 255)
• Unsigned short—2 bytes per pixel (0, 65535)
• Unsigned integer—4 bytes per pixel (0, 232 -1)
• Float—4 bytes per pixel (-3.4E38, 3.4E38)
• ARGB—3 bytes per pixel, plus 1 byte; 8 bits per color channel (alpha, red, green, 

and blue)
• Byte—1 byte per pixel (-128, 127)
• Short—2 bytes per pixel (-32768, 32767)
• Integer—4 bytes per pixel (-231, 231-1)
• Long—8 bytes per pixel (-9.22E18, 9.22E18)
• Double—8 bytes per pixel (-1.8E308, 1.8E308)
• ARGB U short—2 bytes per color channel and 2 bytes for alpha channel

Dimensions 
and 
resolutions

Degree of manifoldness of a quantity such as space or time. Two-dimensional 
datasets are composed of one image (the two dimensions are length and width). 
Generally, three-dimensional datasets are composed of more than one image. The 
third dimension is generally space. The fourth dimension is generally time. (Either 
time or space can be the third or fourth dimensions.) Zeros in the text boxes indicate 
that the dimension is not represented in the image. For example, if the text boxes for 
the first and second dimensions are filled, and the rest of the text boxes are filled 
with a zero, the image only has two dimensions. 

Dimensions

• 1st—Width (along x axis)
• 2nd—Length (along y axis)
• 3rd—Depth (along z axis)
• 4th—Time (along t axis)
• 5th—Fifth dimension

Resolutions

Size of pixel or voxel per dimensions 1 through 5.

Units of 
measure

Indicates the unit of measurement for each of the applicable dimensions.

Header 
offset

Indicates the size of the space reserved at the beginning of the file where specific 
types of information is kept. This space, which is called the header, precedes the 
image data. If you know the length of the header, type it in this box. When MIPAV 
accesses the file, it skips the header offset and begins to read the image data. Note 
that not all image file formats have a header.

Figure 36.  Raw dialog box (continued)
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5 Click OK. A blank image (Figure 37) appears in an image window.

6  Use the paint and VOI tools to create an image.

7 Click File > Save image as. The Save dialog box opens.

8 Type the name of the file in File Name, and select the file type in Files of 
type.

9 Click OK. MIPAV saves the image under the file type you selected.

Big endian Indicates whether image data is stored in the big endian format. If not, the image 
data is stored in the little endian format. Endianness refers to the byte ordering of 
the data. Some computers order the data with the least significant byte (LSB) first 
followed by the most significant byte (MSB). This byte order is referred as little 
endian or Intel byte ordering. Machines that use little-endian byte ordering are 
VAXes, Intel x86, and Pentium. The reverse is MSB and then LSB, which is referred 
as big endian or Motorola byte ordering. Machines that use big-endian byte ordering 
are IBM System 3D, RISC, and a Motorola 680x0. MIPAV is biendian; it supports both 
big- and little-endian byte-ordering formats.

OK Applies the parameters that you specified and creates a blank image.

Cancel Disregards any changes you made in this dialog box, closes the dialog box, and does 
not create a blank image.

Help Displays online help for this dialog box.

Figure 36.  Raw dialog box (continued)

Figure 37.  Blank image
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Delineating volumes of interest (VOIs) 

MIPAV provides tools that allow you to automatically, semiautomatically, 
and manually identify and modify volumes of interest (VOIs). 

volume of interest—The portion of the image in the dataset on which you want 
to focus. It may be either one slice or multiple slices throughout the dataset.

Each VOI can be formed from multiple contours in a single slice or multiple 
slices. Once an object is segmented and defined by a VOI, statistics of the 
volume can be calculated.

MIPAV supports over 32,000 unique VOIs on a single dataset. Additionally, 
you can move or delete nodes on the VOI and add new points. VOI types 
include:

• Point, which is created by using 

• 2D line

• Rectangular

• 3D rectangular

• 2D elliptical

• Polygonal

• 3D polygonal

• Interactive level-set
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Generating contour VOIs using predefined shapes
MIPAV includes icons of predefined shapes, such as points, lines, ellipses, 
or rectangles, that you can use to create VOIs. These icons are on the VOI 
toolbar. 

To generate contour VOIs using the predefined 
shapes

1 Select one of the contour icons from the VOI toolbar in the expanded 
MIPAV window (Figure 38).

2 Move the pointer to the image window. The pointer changes to a cross-
hair shape. Do one of the following:

• Points, levelset: Position the cursor on the area where the point or 
levelset should be drawn. Click the mouse button.

• Straight lines, rectangles (2D and 3D), ellipsoids: Position 
the cursor on the area where the contour should begin. 

Click the mouse button. 

While holding down the mouse button, drag the cursor until the contour is 
the desired size.

• Polylines, polygons: Position the cursor over the area where the 
contour should begin. 

Click the mouse button. A point appears. 

Figure 38.  Contour icons on the VOI toolbar
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Alternate between moving the mouse and selecting the mouse button to 
outline the VOI. 

To complete a polyline, double-click the mouse button. To complete a 
polygon, connect the first and last nodes.

Tip: To draw the same shape several times in succession, hold down the Shift 
key while you select the applicable icon from the VOI toolbar and draw.

Adding and moving boundary points on VOIs
No matter which method you choose to delineate a VOI, you can add points 
and change the boundaries of the VOI. For example, suppose you created a 

VOI on an image with the Rectangle VOI icon . If you notice that a part 
of the image that should be included in the VOI isn’t, the boundary of the 
rectangle needs to be adjusted to include the missing portion of the image. 

To add a point and change the boundary of the VOI

1 Select the VOI. Notice that white points appear at the corners of the VOI 
and a small cross appears in the middle of the VOI.

2 Place the cursor on the portion of the VOI you want to adjust. The cursor 

changes from a cross  to .

3 Click once. A white point appears on the line.

4 Select the point and drag it to include the missing part of the image.

Tip: Circular VOIs are composed of a continuous series of points around the 
diameter of the circle. You only need to select one of those points and drag it to 
enlarge the circle.
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Figure 39.  Adding a point and adjusting the boundary of a rectangular VOI
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Automatically adjusting contour boundaries
After a contour is drawn, it might be necessary to adjust the boundaries so it 
more closely matches the VOI region. 

To adjust contours

1 Click a contour. The nodes become visible. 

2 Select VOI > Evolve boundary 2D >Active contour. The Evolve 
Boundary dialog box opens (Figure 40).

3 Modify the information in the window if necessary. 

4 Click OK.

A new contour, that more closely outlines the VOI, appears on the 
image. The old contour also remains.

Tip: To delete the old contour, select it and select Cut Selected Contour , or 
press the Del key on the keyboard.

Figure 40.  Evolve Boundary dialog box
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Calculating VOI statistics

Once a VOI is drawn, you can calculate the number of voxels in the VOI, the 
volume, and area. You can also calculate the average and standard deviation 
of the voxel intensity and the center of mass. For 2D images, you can 
calculate the principal axis and the eccentricity. 

MIPAV provides two methods for you to obtain VOI statistics:

• By using VOI properties—This method is fast and simple and provides 
statistics for the entire VOI. Although it allows you to save the results 
in a text file, that is an additional step. However, using this method, 
you can type additional information directly onto the Data page with 
the statistics.

• By using the Statistics Generator—Using this method, you can obtain 
statistics on the entire VOI, on a single slice of the VOI, or by contour 
and slice. The Statistics Generator also automatically saves the results 
in either a tab-delimited file or an XML file of your choosing. In 
addition, it displays statistics in a tabular format.

Note: MIPAV can calculate statistics for only one VOI at a time. In addition, 
MIPAV calculates the volume and area in a VOI using image pixel (voxel) 
resolutions.

Using VOI properties

To calculate VOI statistics

1 Delineate a VOI on an image.

2 Select the desired VOI in the image window.

3 Select VOI > Properties in the MIPAV window. The VOI Statistics dialog 
box appears (Figure 41).

4 Select the statistics to be calculated in Statistics to Calculate. 

5 Click Calculate.

6 Select the statistics to be calculated in Statistics to Calculate. 

7 Click Calculate. 
MIPAV User’s Guide, Volume 1, Basics 60

9/20/04 



M   I   P   A   V
M e d i c a l   I m a g e   P r o c e s s i n g, A n a l y s i s,   &   V i s u a l i z a t i o n

Chapter 3,  Getting Started Quickly with MIPAV
The VOI Statistics dialog box remains on the desktop. In a few 
moments, statistical data appears on the Data page in the Output 
window. 

Name of VOI Shows the name of the VOI.

Show contour 
bounding box

Highlights the VOI and, when you select the VOI, displays a box that 
encompasses all of the VOI’s borders and lists the measurements and position 
of each boundary.

Additive or 
subtractive

Not implemented at this time.

Include for 
processing

Not implemented at this time.

Figure 41.  VOI Statistics dialog box
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8 Click the Data tab in the Output window to view the results. The Data 
page in the Output window (Figure 42) appears.

9 Do one or a combination of the following if desired:

Boundary or 
blended

Smooths the image inside the VOI.

Statistics to 
calculate

Provides a list of statistics. Select the statistics that you want to include in the 
report. 

Select all Selects all of the statistics listed in the Statistics to calculate list.

Clear Clears all of the check boxes that you selected in the Statistics to calculate list.

Exclude 
intensity range

Allows you to select specific intensity ranges in the Range boxes that you want 
to exclude from the calculation. 

Watershed seed 
value (0-32K) 

Indicates the basin value used when running the Watershed algorithm on 
images.

Apply Applies the changes you made in this dialog box and leaves the dialog box open 
for you to make further changes.

Cancel Disregards any changes you made in this dialog box, closes the dialog box, and 
does not run a statistics report.

Calculate Calculates the statistics requested in this dialog box and displays them in the 
Data page of the Output window. 

Figure 41.  VOI Statistics dialog box (continued)

Figure 42.  Output window showing statistics
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• Add information to the statistics by typing the information directly 
into the statistics on the Data page.

• Select the data that you want to remove, and then click Cut  or 
select Edit > Cut (Figure 43) to cut the selected data. MIPAV 
removes the selected text from the Output window and copies it to 
the clipboard for use in other applications.

• Select the data that you want to copy, and then click Copy  or 
select Edit > Copy to copy the data to another location in the window 
or to another application (such as a word-processing program).

• Click Save  or select File > Save (Figure 44) messages (Figure 44) 
to save the data and any comments you’ve added to a text file.

Figure 43.  Edit menu on the Output window
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. 

• Click Clear Messages  or select Edit > Clear Messages to clear the 
window.

10 Click Cancel in the VOI Statistics dialog box when complete to close the 
dialog box.

Using the Statistics Generator
If you plan either to use a database or spreadsheet to keep track of VOI 
statistics or to obtain them in an XML format, use the Statistics Generator. 
As mentioned earlier, the Statistics Generator can provide statistics on an 
entire VOI or a particular slice or by contour and slice.

Using the Statistics Generator includes three tasks:

• Selecting VOI and save options

• Selecting statistics options

• Reviewing the statistics

SELECTING VOI AND SAVE OPTIONS

The first task is to select the VOIs on which you want to obtain statistics and 
select the file in which the resulting statistics should be saved.

Figure 44.  Save messages command on File menu in the Output window
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To select VOIs

1 Delineate a VOI on an image.

2 Select the VOI in the image window. 

3 Select VOI > Statistics Generator in the MIPAV window. The Calculate 
Statistics on VOI Groups window appears (Figure 45).

This window displays all of the VOIs on the image in the VOI group list 
on the left.

4 Select the VOI on which you want to obtain statistics in the VOI group 
list.

5 Select Send selection right . The name of the VOI appears in the VOI 
group list on the right.

6 Use Browse to choose a file name in the VOI Statistic File Destination 
box.

Figure 45.  Calculate Statistics on VOI Groups window
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7 Select either of the two formats in the Output Format group: 

• Tab delimited
• XML

8 Click Statistics Options. The Statistics Options page opens.

9 Proceed to the next task: Selecting statistics options.

SELECTING STATISTICS OPTIONS

The Statistics Options page (Figure 46) provides a list of statistics from 
which you can select and the options to obtain statistics by slice, by contour 
and slice, or by the total VOI.

To select statistics to perform on VOIs

1 Do either of the following in the Statistics to calculate group:

• Select one or more of the listed types of statistics.
• Click Select all to obtain all of the statistic types.

2 Select one of the following options in the Statistics options group:

• By contour & slice
• By slice only
• By total VOI (the default selection)

3 Select Show all totals if you want to record the totals for each type of 
statistic.

4 Click Calculate.

5 Select Logging. The Logging page (Figure 47) appears.

6 Proceed to the next task: ‘‘Reviewing the statistics’’.
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Figure 46.  Statistics Options page

1 Select either:

• One or more 
statistics

• Select all
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REVIEWING THE STATISTICS

The Logging page (Figure 47) displays the statistics in tabular form. 
Whether or not you chose a type of statistic on the Statistics Options page, 

Overwriting statistics files
If you previously ran the Statistics Generator and obtained statistics, after 
you click Calculate a message appears stating that a statistics file already 
exists. It asks whether to overwrite the file or to cancel the action.

If you not want to overwrite the file, click Cancel. The following warning 
message appears. 

Return to the VOI selection page and choose another file name in the VOI 
statistic file destination box. Then click Calculate to obtain the new set of 
statistics. The Statistics Generator calculates the statistics and saves them 
in the file that you indicated. The statistics appear on the Logging page.

If it’s all right to overwrite the file, click Overwrite. The Statistics Generator 
calculates the statistics and overwrites the previously recorded statistics 
file.

Tip: If you always want the Statistics Generator to overwrite the file, either 
select Options > Overwrite file automatically or press Alt O.

Go to the next task: ‘‘Reviewing the statistics’’.
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the table includes a heading for each type. Blanks cells in the table indicate 
that you did not choose to obtain that particular type of statistics.

Each time you calculate the statistics for a VOI the Statistics Generator adds 
another row of statistics to the table. Note that the first column in the table 
lists the name of the VOI and, if appropriate, the slice and contour numbers. 
Also, you can change the width of each of the columns in the table by 
dragging the line between the columns in the heading.

You can include and review the statistics file in a database or in a 
spreadsheet program by double-clicking on the file name in Windows 
Explorer window and, in the Open with dialog box, selecting the application 
in which you want to open the file.

When the number of rows in the table exceeds the length of the Logging 
page, scroll bars appear on the right side of the table to allow you to scroll 
from the beginning or to the end of the table. 

Figure 47.  The Logging page in the Calculate Statistics on VOI Groups window
MIPAV User’s Guide, Volume 1, Basics 69

9/20/04 



M   I   P   A   V
M e d i c a l   I m a g e   P r o c e s s i n g, A n a l y s i s,   &   V i s u a l i z a t i o n

Chapter 3,  Getting Started Quickly with MIPAV
If at any time you want to clear, or erase, all of the rows of the table, select 
Options > Clear log window (Figure 48). The complete table disappears 
from the Logging page, which is now totally gray.

Modifying image resolutions

To modify the resolutions in an image

1 Open an image.

2 Select Image > Attributes > Edit attributes in the MIPAV window. The 
Image Attributes dialog box (Figure 49) opens.

3 Click Resolutions. The Resolution page (Figure 50) appears.

4 Modify the resolutions.

Figure 48.  Options menu showing the Clear Log Window command

Figure 49.  Image Attributions dialog box
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5 Click Apply. 

6 Click OK or Close when complete. The window closes.

Generating graphs (intensity profiles)

MIPAV can generate a graph of the intensity values of a region bound by a 
VOI. You can then save this graph, or intensity profile, to a file for future 
reference. 

Generating new graphs
You can generate an intensity profile for any VOI. 

To generate a graph of a VOI

1 Select a VOI in an image window.

2 In the MIPAV window, select one of the following:
 

• VOI > Graph > Boundary intensity
• VOI > Graph > 2.5D total intensity
• VOI > Graph > 2.5D average intensity

Figure 50.  Resolutions page in the Image Attributes dialog box
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Tip: You can also select these same commands by right-clicking inside the VOI in 
the image window and selecting Graph and the appropriate command 
(Figure 51).

Either the Contour VOI Graph window (Figure 52) or the Intensity Graph 
window (Figure 53) appears.

Each function on the graph represents the intensity levels within each channel.

3 Close the graph by either selecting File > Close graph or pressing Ctrl X.

Figure 51.  Right-clicking on selected VOI
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.

Figure 52.  Contour VOI Graph window

Figure 53.  Intensity Graph window
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Saving graphs to a file

To save a graph

1 Select File > Save graph in the Intensity Graph window (Figure 53) or 
the Contour VOI Graph window (Figure 53), or press Ctrl S. 

The Save dialog box (Figure 54) appears.
 

2 Type a name for the graph in File name. 

3 Make sure that Graphs (.plt) appears in Files of type.

4 Click Save. MIPAV saves the file under the specified name.

Figure 54.  Save dialog box
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Printing images or graphs

To print images and graphs 

1 Do one of the following:

• Click Print  in the MIPAV window.

• Select File > Print image in the MIPAV window.

• Select File > Print graph in the Graph window. 

The Print dialog box (Figure 55) appears. 

2 Adjust the print options if necessary.

3 Click OK to print the graph or image on your default printer.

Figure 55.  Print dialog box
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Saving images

This section explains how to save images in the same format (as when 
opened) or in a different one. It also explains how to save an image as a 
TIFF file.

Note: If you prefer for MIPAV to use the style of Open and Save dialog boxes 
that are used by the operating system (e.g., Microsoft Windows, Unix, or Apple) 
on your computer, read the section on “Using platform-specific Open and Save 
dialog boxes” on page 81.

Saving images in the same format

To save an image file in the same format (as when 
opened)

1 Do one of the following in the MIPAV window:
• Click Save Image.
• Select File > Save Image.

The Save dialog box appears (Figure 56).

Figure 56.  Save dialog box
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2 Type the name of the file in File name. 

3 Click Save.

Saving images as RGB TIFF files
An image can be saved as an RGB TIFF file. 

To save images as RGB TIFF files

1 Select File > Save as in the MIPAV window.

The Save dialog box (Figure 56) appears.

2 Type the name of the image in File name. Make sure you add .tiff as the 
extension.

3 Click Save. MIPAV saves the file as a TIFF file under the name you 
specified.

Saving images to MINC format

To save images to MINC format

1 Select File > Save As.

The Save dialog box (Figure 56) appears. 

2 Type the name of the file. Make sure the extension is .mnc.

Note: MIPAV uses the file extension to save image into various formats. Thus 
saving an image with the extension of .tiff causes the image to be saved as a 
TIFF  image. Saving an image with the extension of .img causes the image to be 
saved as a Analyze image. See Table 1 for file extensions supported by MIPAV. 

The Attributes to Save dialog box (Figure 57) appears. 

3 Complete the text boxes with the appropriate information. Note that the 
x, y, and z values differ from DICOM.

4 Click OK to save the file.
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Figure 57.  Attributes to Save (MINC) dialog box

Figure 58.  Comparison of MINC and DICOM image orientation
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Saving images to another format or renaming images

To save images to a different format from the 
original file or to rename images

1 Select File > Save as. 

The Save dialog box (Figure 56) appears. 

2 Type the new name in File name. To save the file in a different format, 
change the file extension. A list of extensions appears in Table 1 on 
page 22.

3 Click Save. MIPAV saves the file under the name and extension you 
specified.

Customizing MIPAV

You can set the following MIPAV configuration options:

• Show or hide splash screen 

• Using platform-specific Open and Save dialog boxes

• Show or hide toolbars

• Place MIPAV in log mode

• Place MIPAV in debug mode

• Manage memory resources

• Develop and use plug-in programs

Showing or hiding the splash screen on MIPAV start-
up

The splash screen is the window that first appears briefly when you start 
MIPAV. It appears immediately before the MIPAV window and the Output 
window open. The splash screen displays the name of the program and the 
MIPAV logo.

By default, MIPAV always displays the splash screen on start-up unless you 
decide to hide it. To do so, you need to change the option in the MIPAV 
Options dialog box.
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To hide the splash screen or prevent it from 
appearing on start-up 

1 Select File > Help > MIPAV Options. The MIPAV Options dialog box 
(Figure 59) opens.

2 Clear the Display Splash Screen check box.

3 Click Apply. 

4 Click Close. The MIPAV Options dialog box closes. The next time you 
start MIPAV, the splash screen does not appear.

To show the splash screen

After hiding the splash screen, you may later decide to display it.

1 Select File > Help > MIPAV Options. The MIPAV Options dialog box 
(Figure 59) opens.

2 Mark the Display Splash Screen check box.

Figure 59.  MIPAV Options dialog box
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3 Click Apply. 

4 Click Close. 

After you quit MIPAV and then start it again, the splash screen appears.

Using platform-specific Open and Save dialog boxes
By default, MIPAV uses its own version of Open and Save dialog boxes, 
which provide you with the ability to assign aliases, or shortcuts, to 
frequently used images. Aliases make it easy to locate images, a feature that 
may be attractive if you work with the same images for a period of time. 
However, you may prefer instead to use the style of Open and Save dialog 
boxes that are provided with the operating system of your computer. To do 
so, you need to select the Use platform-style File dialog boxes check box in 
the MIPAV Options dialog box (Figure 60).

If this check box is selected and your computer is running Microsoft 
Windows, MIPAV displays the Windows style of Open and Save dialog 
boxes. If you use a Sun terminal, when this check box is selected, MIPAV 
displays the standard Unix-style Open and Save dialog boxes. On Apple 
MacIntosh computers, MIPAV displays dialog boxes that are standard with 
that operating system.

To use platform-specific dialog boxes

1 Select File > Help > MIPAV Options. The MIPAV Options dialog box 
opens.

2 Select the Use platform-style File dialog boxes check box.

3 Click Apply.

4 Click Close. The dialog box closes.
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Showing and hiding toolbars
After you open an image in MIPAV and the MIPAV window expands to 
display all of its menus, you can decide which toolbars should appear. By 
default, the window displays the VOI, Scripting, and Image toolbars.

The Toolbars menu contains check boxes for each of the four toolbars:

• VOI toolbar. Volume of interest toolbar (Figure 61). The VOI toolbar 
contains tools that help you in selecting the specific area of interest on 
the image.

• Paint. The Paint toolbar (Figure 62) includes tools that allow you to 
add, adjust, or remove colors and color intensity, erase paint, and 
adjust the opacity level of the paint.

Figure 60.  MIPAV Options dialog box
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• Scripting. The Scripting toolbar allows you to locate and run 
previously recorded scripts, or macros, that contain two or more 
algorithms on images.

• Image. The Image toolbar (Figure 64) includes tools for opening, 
printing, saving, maximizing, and minimizing an image; converting an 
image from gray scale to color or from color to gray scale; and adding 
to and removing slices from an image or changing their order; and 
rotating, cropping, and flipping an image.

Figure 61.  VOI toolbar

Figure 62.  Paint toolbar
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By marking or clearing these check boxes, you can choose which toolbars to 
display and which to hide. For example, suppose you just started MIPAV a 
moment ago. You then open an image. The MIPAV window expanded in 
size and displayed its full complement of menus. Although it displays the 
VOI, Scripting, and Image toolbars, you want to work with the Paint toolbar 
as well as the Image toolbars. However, you don’t need to use the VOI and 
Scripting toolbars.

Figure 63.  Scripting toolbar 

Figure 64.  Image toolbar
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To hide the VOI and Scripting toolbars and display 
the Paint toolbar

1 Select Toolbars > VOI to hide the VOI toolbar. MIPAV removes the 
check mark from the check box and removes the VOI toolbar from the 
MIPAV window.

2 Select Toolbars > Scripting to hide the Scripting toolbar. MIPAV 
removes the check mark from the check box and removes the Scripting 
toolbar from the MIPAV window.

3 Select Toolbars > Paint to display the Paint toolbar. The program marks 
the check box and displays the Paint toolbar in the MIPAV window. 

Because the Image toolbar is already displayed, you do not need to do 
anything.

Turning the log mode on or off
MIPAV provides a log mode that records the algorithms applied to an 
image. The log records the algorithms applied, the parameters entered, and 
whether the algorithm completed successfully. By default, the log mode is 
on when you first start MIPAV.

To turn the log mode on

Because the log mode is on by default in MIPAV, the only reason for turning 
it on is if you previously turned it off. 

1 Select Help > MIPAV Options. The MIPAV Options dialog box 
(Figure 59) opens. Note that the check box for Log mode is blank.

2 Select Log mode. A check mark appears in the check box.

Figure 65.  Toolbars menu in the MIPAV window
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3 Click Apply. 

4 Click Close. When the Log mode is on, the log trail appears in the 
Output window (Figure 66) whenever you use an algorithm on an 
image.

To turn the log mode off

1 Select Help > MIPAV Options. The MIPAV Options dialog box 
(Figure 59) opens. 

2 Notice that a check mark appears in the Log mode check box.

3 Select Log mode. The check mark disappears, and the check box is 
blank.

4 Click Apply. 

5 Click Close.

Until you turn the log mode on again, the log trail does not appear in the 
Output window.

Placing or removing MIPAV from debug mode
You can track debugging information and error messages generated by 
MIPAV during a session by placing it in debug mode. If errors occur during 

Figure 66.  Output window showing the Log page
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the session, the program displays any error messages in the Output window 
on the Debug page. By default, the debug mode is off when you start the 
program.

Recommendation: The debugging information is primarily intended for 

MIPAV developers and not for users. The best course for users is to leave the 

debug mode Off.

PLACING MIPAV IN DEBUG MODE

To turn the log mode on

1 Select Help > MIPAV Options. The MIPAV Options dialog box 
(Figure 59) opens. Note that the initial value for Debugging output is 
Off.

2 Select the arrow in Debugging output to display the list of debugging 
modes and then select one of the five levels of severity for the debug 
mode. 

Note: The five debugging levels correlate to the amount of debugging 
information provided on the Debug page and the amount of computer memory 
used. Level 1 provides the least amount of debugging information, and level 5 
provides highest level of the debugging information. 

3 Click Apply.

4 Click Close. From this point on, MIPAV places debugging data on the 
Debug page in the Output window
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To turn the log mode off (remove MIPAV from debug 
mode)

1 Select Help > MIPAV Options. The MIPAV Options dialog box 
(Figure 59) opens. Note that the value for Debugging output may be 1, 2, 
3, 4, 5, or Off.

2 Select the arrow in Debugging output to display the list of options. 
Select Off. 

3 Click Apply.

4 Click Close.

When the debug mode is off, no error messages display on the Debug page 
in the Output window.

Managing memory resourcesMIPAV requires at least 35 Mb of random access memory (RAM). 
Additional memory is needed to correctly display image files and to quantify 
the data. To determine the amount of additional memory needed, multiply 
the size of the image file that you want to display by 10. Thus, if an image file 
is 2 Mb, you must allocate an additional 20 Mb of RAM (in addition to the 
base of 35 Mb) for it to display correctly. Because memory requirements 
fluctuate depending on the size and number of image files open, it may be 
necessary to allocate more memory during a session. 

Figure 67.  Output window showing the Debug page 
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As Java-based programs run, they often leave old variables, objects, or 
constructors in memory. For instance, if you delineate a VOI, the 
coordinates of the contours may remain in memory even after you close the 
image. Java provides a method called the garbage collector that clears all 
unnecessarily reserved memory. Generally, the software does this 
automatically when free memory becomes very limited. However, you can 
run the garbage collector at any time to free memory by clicking on the Free 
Memory button.

The first step is to view how much memory is currently being used and to 
free unnecessarily reserved memory. Then, if necessary, you may need to 
allocate additional memory.

To determine how much memory is currently being 
used by MIPAV

1 Select Help > Memory Usage in the MIPAV window. The Memory 
Monitor dialog box appears (Figure 68). 

When MIPAV performs a function, such as visualizing an image file, it 
uses memory. When the function completes (i.e., the visualized image 
closed), you manually free the memory so it can be used for another 
function.

The Memory Monitor dialog box shows how much memory is allocated 
and how much memory has been used. The vertical bar on the right of 
the window displays a pictorial representation of the ratio of allocated 
memory or amount of memory used. The chart shows the memory usage 
for the past 3 minutes and 45 seconds. The chart is updated every 
second.

If you want to constantly monitor your memory resources, you can leave 
the Memory Monitor dialog box open on your desktop. Otherwise, close 
it by clicking Close. 

2 Click Free memory to free memory.
MIPAV User’s Guide, Volume 1, Basics 89

9/20/04 



M   I   P   A   V
M e d i c a l   I m a g e   P r o c e s s i n g, A n a l y s i s,   &   V i s u a l i z a t i o n

Chapter 3,  Getting Started Quickly with MIPAV
To allocate more memory

If you need to need more memory, you can allocate virtual memory or disk 
swap space if there is free space on your hard drive. For instructions on how 
to do this, refer to the documentation for your system. If you cannot assign 
more virtual memory or disk swap space, you may need to install additional 
memory.

If more than 100 Mb of physical memory, virtual memory, or disk swap 
space were allocated, then you must indicate the amount so that MIPAV can 
take full advantage of the additional memory. 

1 Select Help > Memory allocation in the MIPAV window. The Change 
Java.Runtime Memory Allocation dialog box (Figure 69) opens.

2 Change the maximum heap size number so that is reflects the maximum 
amount of memory that should be allocated. 

In a Microsoft Windows system, you can specify a maximum to 1.2 or 1.3 
Gb.  If additional memory is needed, MIPAV allocates it until the 
memory reaches the maximum heap size that you specify.

3 Click OK to close the dialog box.

Figure 68.  Memory Monitor dialog box
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Note: You must restart of MIPAV for the changes to take effect. To do this, select 
File > Exit - MIPAV in the MIPAV window to quit MIPAV. Then, restart MIPAV.

Developing and using plug-in programs
A plug-in program allows you to add customized functionality to MIPAV. 
Before you create a plug-in, you should have a strong understanding of the 
underlying structure of MIPAV’s software design and data structure. 
Because plug-ins are written in Java, you should also have a basic 
understanding of that programming language. After you create the plug-in, 
you must then install it. Once it is installed, you can access it from the Plug-
Ins menu in the MIPAV window. Plug-ins are addressed in Chapter 11 in the 
MIPAV User’s Guide.

Quitting MIPAV

To end a MIPAV session 

1 Select File > Exit-MIPAV. The MIPAV-Exit dialog box (Figure 70) 
appears asking if you really want to exit the program. 

2 Click Yes to end the session.

Figure 69.  Change Java-Runtime Memory Allocation dialog box
MIPAV User’s Guide, Volume 1, Basics 91

9/20/04 



M   I   P   A   V
M e d i c a l   I m a g e   P r o c e s s i n g, A n a l y s i s,   &   V i s u a l i z a t i o n

Chapter 3,  Getting Started Quickly with MIPAV
Tip: You can also exit MIPAV by clicking on Close  at the top right of the MIPAV 
window.

Figure 70.  Exit Confirmation dialog box
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