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Preface
The purpose of the MIPAV software program is to allow medical researchers 
to extract quantitative information from image datasets of various medical 
image modalities.

Scope of this guide

The primary purpose of the MIPAV User's Guide is to provide medical 
researchers the information they need to use the MIPAV software program. 

A secondary goal is to give researchers the information needed to extend, if 
desired, the software’s capabilities through the development of new 
functions in plug-in applications via use of the software’s application 
program interface (API).

Who should use this guide

Medical researchers, medical technicians, and other people who are 
involved in analyzing medical images or maintaining and supporting the 
equipment used to produce images form the audience for the User’s Guide.
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Skills you need to perform tasks in MIPAV

Depending on the platform—Windows, MacIntosh, or Unix—that is running 
your workstation, it is recommended that you are familiar with installing 
and using software programs for that platform.

If you plan to create plug-in applications for MIPAV to add new 
functionality, you must have software programming skills and be familiar 
with Java.

How this guide is organized

The MIPAV User’s Guide is divided into two volumes: 

• Volume 1, Basics, explains how to use the basic features and functions 
of MIPAV and how to incorporate plug-in applications.

• Volume 2, Algorithms, presents detailed information about the 
purpose, background, and function of the algorithms packaged with 
MIPAV and gives instructions for using them.

Volume 1, Basics
The MIPAV User’s Guide, Volume 1, Basics, includes the following:

• Chapter 1, “Introducing MIPAV,” presents an overview of the MIPAV 
software program.

• Chapter 2, “Installing MIPAV,” explains how to install, remove, and 
upgrade the MIPAV software program. It also explains how to 
subscribe to the MIPAV mail list and how to search the MIPAV archive.

• Chapter 3, “Getting Started Quickly with MIPAV,” explains how to use 
MIPAV to perform common functions, such as opening an image file, 
saving the file, and printing a log file. 

• Chapter 4, “Understanding Image Basics,” lists the file formats 
supported by MIPAV and provides background information on image 
file formats. It also provides information on how to view and adjust 
image file attributes.
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• Chapter 5, “Working with DICOM Images,” explains how to access 
DICOM databases, perform queries, and retrieve image files. In 
addition, it explains how to send files to a database.

• Chapter 6, “Visualizing Images,” provides instruction on how to 
customize the way image files are displayed, how to magnify and 
minify images, how to view images together, how to view a portion of 
the image, and how to change image brightness and contrast by 
generating histograms and adjusting color look-up tables (LUTs). 

• Chapter 7, “Segmenting Images Using Contours and Masks,” explains 
how to create, group, rearrange, and modify volumes of interest 
(VOIs); how to create masks; and how to use paint to further identify 
VOIs.

• Chapter 8, “Analyzing Images,” discusses how to calculate statistics for 
VOIs and masks and how to generate intensity profiles, or graphs, for 
images.

• Chapter 9, “Changing Image Datasets Using MIPAV Utilities,” explains 
how to use the utilities included in the software.

• Chapter 10, “Developing Plug-in Programs,” explains how to 
incorporate plug-in programs into MIPAV.

• Appendix A, “DICOM Conformance Statement,” provides a copy of the 
formal DICOM Conformance Statement, which specifies MIPAV’s 
service classes, information objects, communications protocols, and 
media storage application profiles.

• Appendix B, “Technical Information,” provides examples of files 
MIPAV system files (such as the preference file) and explains how the 
user can interpret them; provides limited instruction on how to modify 
specific files. Also explains how to use the debug mode.

• Appendix C, “Toolbar Buttons,” displays the buttons on the Image, 
Paint, and VOI toolbars and provides a short description of the 
function of each button.

• Appendix D, “Reference,” provides a list of references that can be used 
to learn more about MIPAV functions.

The guide also includes a glossary of terms and acronyms.
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Volume 2, Algorithms
Volume 2, Algorithms, includes two chapters:

• Chapter 1, “MIPAV Algorithms Overview,” which discusses the tools 
and application programming interface provided with MIPAV

• Chapter 2, “Using MIPAV Algorithms,” provides detailed information 
about the algorithms packaged in MIPAV

In addition, the book includes the glossary of terms and acronyms.

Where to find more information

Both volumes 1 and 2 of the MIPAV User’s Guide are available as Acrobat 
PDF files, which you can view, download, and print. You can either print 
each volume, or you can print individual chapters separately. For PDFs of 
this guide, go to the MIPAV web site:

http://mipav.cit.nih.gov/guide.htm
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Conventions used in this guide

This guide uses the following conventions:

Both volumes of the MIPAV User’s Guide include special information that 
briefly highlights particular features or functions or that provide 
clarification. Based on the type of information they convey, these notes are 
labeled “note,” “tip,” “example,” “recommendation,” “remember,” 
“reference,” “caution,” and “disclaimer.” The following examples indicate 
how these notes appear and the type of information they include.

Note: Notes provide additional information that is related to the subject at hand. 
They tend to be “by the way” types of information or asides.

Tip: Tip paragraphs point out application shortcuts or briefly describe special 
features of the software.

This convention . . . Stands for . . .

Italics Names of books, guides, or manuals as 
references

New terms or emphasis

Names of executable files

Bold User input

Names of programming commands

All caps File types, such as TIFF, GIF, or JPG 

Upper- and lowercase Names of keys

name@address.com E-mail address format

Hyperlink An internet link (position the cursor on this 
word and click the left mouse button)* 

Monospace Code sample, including keywords and variables 
within text and as separate paragraphs, and 
user-defined program elements within text

*All figure and table citations, such as Figure 1 or Table 1, are hyperlinks although they 
are not underscored. Clicking the citation displays the appropriate figure or table.
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Example: An example paragraph provides an example of a task or incident in 
which something of note could occur.

Recommendation: Paragraphs that are labeled “Recommendation” suggest 

methods of good practice or advice.

Definition: The definitions of specific words or phrases of note appear in 
“definition” paragraphs. 

Remember: Notes labeled “Remember” present information that was 
previously discussed and that is pertinent in the current topic.

Reference: A reference note highlights one or more references that contain 
information on the current topic.

Caution: A paragraph labeled “Caution,” alerts you to be very careful 
about avoiding some action that could harm your equipment or data.

Disclaimer: A disclaimer indicates the possible limitations or 
ramifications of a topic.
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1 Introducing MIPAV
Imaging is essential to medical research and clinical practice. Biologists 
study cells and generate three-dimensional (3D) confocal microscopy 
datasets; virologists generate 3D reconstructions of viruses from 
micrographs. Radiologists identify and quantify tumors from Magnetic 
Resonance Imaging (MRI) and Computed Tomography (CT) scans. 
Neuroscientists detect regional metabolic brain activity from Positron 
Emission Tomography (PET) and functional MRI (fMRI) scans. Analysis of 
these diverse image datasets require sophisticated quantification and 
visualization tools. Until recently, 3D visualization and quantitative analysis 
of an image dataset could only be performed on expensive UNIX 
workstations with customized software. Because of technological 
advancements, medical image visualization and analysis can now be 
performed on an inexpensive desktop computer that is equipped with the 
appropriate software applications.

This User’s Guide explains how to use one of these software applications: 
Medical Image Processing, Analysis, and Visualization (MIPAV). 
Researchers use MIPAV to extract quantitative information from image 
datasets of various medical image modalities. The MIPAV application can 
run on virtually any platform, including Microsoft Windows, Solaris, and 
the Macintosh Operating System (OS). 

This chapter provides information on the characteristics of the product:

• Platform independence

• Supported image types
MIPAV User’s Guide, Volume 1, Basics 1
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• Ability to visualize image datasets of two or more dimensions

• Volume of interest (VOI) segmentation and analysis methods

• Ability to accommodate customized user-created plug-ins

Platform independence

Much research at NIH requires the segmentation, quantification, and 
visualization of 2D, 3D, and 4D image datasets. Researchers analyze images 
of varied imaging modalities, such as microscopy, microarray data, X-ray, 
CT, MRI, fMRI, and PET. Factors such as personal preference, data 
requirements, software limitations, and precedent have led to a 
heterogeneous distribution of computer platforms, among which are 
personal computers executing Windows or Linux, Macintoshes, and 
workstations by SGI, Sun Microsystems, or Hewlett-Packard. To analyze an 
image dataset, researchers may use several software applications. If each 
software application is platform specific, researchers may need access to 
several platforms to analyze a single image dataset. This often reduces 
efficiency while simultaneously increasing lab costs. MIPAV has been 
designed to help researchers increase efficiency and reduce costs by 
providing them with a flexible tool that can operate on virtually any 
platform. Researchers can use MIPAV by itself or in concert with other 
image processing and visualization tools.

The MIPAV application is platform independent because it is written in 
Java, which is an object-oriented, interpreted, programming language that 
was developed by Sun Microsystems. Java source code is compiled into the 
bytecode, which is machine-level code that is compiled specifically for the 
Java Virtual Machine (VM). There are versions of the Java VM for different 
platforms. The same program (bytecode) can run on any of those versions. 
If researchers run a Java program on a Windows 2000 platform, the 
bytecode is interpreted by the Java VM that has been specifically designed 
for the Windows 2000 platform. If the same program is run on a Solaris 
platform; the bytecode is then interpreted by the Java VM that was 
specifically designed for the Solaris platform. 

Note: The correct version of the Java VM can be downloaded from the MIPAV 
web site along with the MIPAV installation program.
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Supported image types

Before image dataset analysis and quantification can be performed, an 
application must be able to read and write image datasets in industry-
standard formats. Conformance to accepted standards, such as DICOM, 
ensures compatibility with present and future applications and medical 
equipment. This protects researchers’ investment in hardware and provides 
flexibility in reaching their goals.

MIPAV supports over 20 different industry-standard image formats 
including: DICOM, TIFF, Analyze, and RAW (a complete list appears in 
Chapter 4 of this document). MIPAV reads and writes images in both big 
and little endian formats.

Visualization of images

The visualization of datasets with two or more dimensions is an important 
aspect of image dataset analysis and research. The ability to visualize the 
orientation, locality, or progression (time) of structures in clinical and 
nonclinical datasets can be vital to researchers. Confocal microscopy, CT, 
and MRI are examples of imaging modalities that are comprised of multiple 
adjacent cross-sectional image datasets that can be combined to form a 3D 
volume dataset. MIPAV allows researchers to visualize datasets using a 
variety of presentation formats, including lightbox, triplanar, cine, and 
animate. Once researchers display the image dataset, they can adjust the 
lookup table (LUT), apply prepackaged pseudo-color LUTs to highlight 
structures of interest, control the magnification level, adjust the transfer 
function, and more. 

Volume of interest (VOI) segmentation and 
analysis

Another significant research activity is the quantification of data from 
image datasets. Although the visualization of image data is important, the 
actual quantification of the data is typically required to evaluate the 
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9/20/04 



M   I   P   A   V
M e d i c a l   I m a g e   P r o c e s s i n g, A n a l y s i s,   &   V i s u a l i z a t i o n

Chapter 1,  Introducing MIPAV
researchers' hypothesis. Researchers must be able to identify regions-of-
interest (ROIs) and/or volumes-of-interest (VOIs).

Note: An ROI is used in the context of 2D image datasets. VOI usually describes 
the analysis of volume data for datasets with more than two dimensions. This 
document uses the term VOI to represent both ROI and VOI.

Image segmentation is the process of identifying connected regions of 
images as members of a common group. In the medical field, physicians 
must routinely identify (i.e., segment) structures in medical image datasets 
to facilitate the treatment of patients. For example, many researchers who 
study the brain are interested in the segmentation of gray matter, white 
matter, and cerebrospinal fluid in MR images. The quantification of 
important attributes, such as volume, of various tissue types enables 
researchers to better understand, diagnose, monitor, and treat 
neurobehavioral disorders.

There are a multitude of image dataset segmentation methods; the choice of 
segmentation algorithm depends on the image data type and task. 
Automatic segmentation methods are desirable because they require little 
user interaction, which is subject to operator error and subjectivity. 
However, in practice automatic methods sometimes fail and require manual 
VOI correction (adjustment of the boundary that identifies the region). 
Thus, in MIPAV, researchers have the choice to automatically, 
semiautomatically, and manually segment VOIs. Contours can be manually 
edited, grouped, and copied to other slices in the dataset. MIPAV also offers 
a variety of mask-generation methods. Researchers can manually paint a 
mask or use one of several algorithms. 

MIPAV also allows researchers to perform statistical calculations on 
masked and contoured VOIs. Statistical results can be saved to an ASCII 
text file and imported to another program, as needed.

Extensibility with Java plug-ins

A typical analysis and visualization application can be designed to meet a 
broad range of researcher requirements. Many components of image 
dataset processing, analysis, and visualization techniques are general and 
can be applied to many types of data. However, many datasets also require 
MIPAV User’s Guide, Volume 1, Basics 4
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unique functionality to meet special requirements. MIPAV allows 
researchers, who have the programming resources, to add a customized 
Java plug-in to the application. To program a plug-in, researchers must 
have a strong understanding of the underlying structure of the application’s 
software design.

Note: This User’s Guide presents information on how to add and remove plug-
ins from the MIPAV application. It also indicates the statements that must be 
included in the source code to allow the plug-in to interface properly with MIPAV. 
However, in-depth information is not included in this guide. If you need more 
information, check the MIPAV web site http://mipav.cit.nih.gov for the e-mail 
address for technical support (Figure 1).

Figure 1.  MIPAV home page
MIPAV User’s Guide, Volume 1, Basics 5
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Sampling of MIPAV’s features

MIPAV provides ready-made, general-purpose tools that meet the majority 
of requirements of many researchers. Researchers can use MIPAV to 
perform a variety of tasks. The following list shows a sampling of the tasks 
that researchers can performed with the program. These tasks and others 
are addressed in volumes 1 and 2 of this User's Guide.

• Visualize files and create new image dataset files

• View and modify the attributes of an image dataset, including DICOM 
and VOI information

• Adjust the display of an image dataset file and adjust magnification 
settings

• View DICOM overlays and protect patient privacy using the anonymize 
feature

• Send and receive image dataset files to and from databases via 
DICOM-compliant servers 

• Contour VOIs using manual, semi-automatic, and automatic methods

• Generate graphs and calculate statistics on VOIs

• Generate and adjust histograms and LUTs using customized or preset 
options

• Run sophisticated, predefined algorithms, and generate logs

• Blend two image datasets and adjust opacity levels of the alpha 
channels so overlapping areas can be studied

• Create new plug-ins to further customize the analysis of data

• Save transformation, LUT, and VOI data, and apply them to other 
image datasets

• Print image dataset files, intensity profiles, statistical data, algorithmic 
logs, and debugging log data

• Create black and white, grayscale, and pseudo-color masks
MIPAV User’s Guide, Volume 1, Basics 6
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2 Installing MIPAV
Because MIPAV is Java-based, it can run on many different platforms, such 
as Windows (XP, NT, 95, 98, and 2000), Solaris, Linux, UNIX, Macintosh, 
and SGI workstation. This chapter explains:

• System requirements (“Understanding the system requirements” on 
page 8)

• How to download the MIPAV installation file and install the MIPAV 
software (“Installing MIPAV” on page 9)

• How to subscribe to the MIPAV mailing list and search the archives 
(“Subscribing to the MIPAV mailing list and searching the archive” on 
page 11)

• How to view the list of enhancements made to the current version of 
MIPAV (“Viewing a list of enhancements and corrections made to 
MIPAV” on page 14)

• How to upgrade MIPAV (“Upgrading MIPAV” on page 15)

• How to remove MIPAV from your workstation (“Removing MIPAV” on 
page 15)
MIPAV User’s Guide, Volume 1, Basics 7
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Understanding the system requirements

MIPAV runs optimally on a system with:

• Pentium III 400-megahertz (MHz) processor—Although 
MIPAV can run on a computer with a slower processor speed, for peak 
performance a processor that is equivalent to or faster than Pentium 
III 400 MHz is recommended.

• At least 100 Megabytes (MB) of a combination of random 
access memory (RAM) and virtual memory 
(recommended)—Minimally, MIPAV requires a base of 35 MB of 
RAM. However, when you open an image file, MIPAV requires 
additional memory to correctly display the file and quantify data. By 
default, MIPAV allocates 100 MB of a combination of RAM and virtual 
memory. However, your own memory requirements may differ. 

To more precisely determine the amount of memory that you need, 
estimate the number of files you generally have open at one time. Next, 
add the sizes of the files together and multiply the result by 10. 

Example: During a typical MIPAV session, you might generally compare and 
contrast three image files. The estimated file sizes may be 2 MB, 4.5 MB, and 6 
MB. The calculation would be: 10(2 + 8.5 + 10) + 35 = 240. Thus, in this 
scenario, you need 240 MB of a combination of RAM and virtual memory to run 
MIPAV and visualize the three image files. Note that for DICOM datasets you 
must add all of the files in the dataset, even if you only work with one or two 
images.

Note: If you need to allocate more than 100MB of memory, after you install 
MIPAV you need to adjust the memory allocation settings. Instructions are found 
in Chapter 3.

• A minimum of 25 MB free hard disk space plus additional 
image file storage space—MIPAV software components require 25 
MB of hard disk space for storage. If you plan to store image files on 
your hard disk, you need to allocate more space.
MIPAV User’s Guide, Volume 1, Basics 8
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Installing MIPAV

Installing MIPAV consists of downloading the MIPAV installation file from 
the MIPAV web site and saving it to your hard drive. Next, you run the 
installation program to install MIPAV on your computer's hard drive.

To begin the installation process, complete the following steps:

1 Enter the following address in your web browser: 

http://mipav.cit.nih.gov/

The Medical Image Processing, Analysis, & Visualization (MIPAV) web 
page opens (Figure 2).

2 Click the Download link. The Downloading MIPAV page (Figure 3) 
opens. 

 

Figure 2.  Medical Image Processing, Analysis, and Visualization (MIPAV) home page
MIPAV User’s Guide, Volume 1, Basics 9

9/20/04 



M   I   P   A   V
M e d i c a l   I m a g e   P r o c e s s i n g, A n a l y s i s,   &   V i s u a l i z a t i o n

Chapter 2,  Installing MIPAV
3 Type your name, e-mail address, and physical mail address in the spaces 
provided, and indicate the institute or center with which you are 
affiliated. 

Note: You must provide this information before you are allowed to download the 
program.

4 Scroll down the page to locate and read the installation instructions 
provided for installing MIPAV on your workstation’s platform.

5 Click the appropriate platform link—Windows, Linux, Solaris, 
Macintosh, or Other (refer to Figure 3). The File Download dialog box  
opens.

Figure 3.  Downloading page
MIPAV User’s Guide, Volume 1, Basics 10
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6 Click Save to the save the program to your workstation’s hard disk.

7 Follow the installation instructions for your workstation’s platform 
(Figure 3) to install MIPAV.

Subscribing to the MIPAV mailing list and 
searching the archive

You can subscribe to the MIPAV mailing list to receive information about 
MIPAV software updates and other MIPAV-related announcements. The 
MIPAV mailing list is housed on LISTSERV at NIH. LISTSERV is an e-mail-
based server that manages the subscriptions and archives for mailing lists 
generated by NIH organizations.

To get help on using NIH LISTSERV

1 Enter the following address in your internet browser:

http://list.nih.gov

The NIH LISTSERV web page (Figure 4) opens.

2 Select the For General Users link near the bottom of the screen. Five 
new links appear.

3 Select any of the links for information on that subject.
MIPAV User’s Guide, Volume 1, Basics 11
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To join the MIPAV mailing list

1 Go to the NIH LISTSERV web page (refer to Figure 4).

2 Select Browse. The List of Lists page (Figure 5) opens.

3 Select M. The M section of the list opens.

4 Scroll down to find the MIPAV mailing list.

5 Select the MIPAV link. The Archives of MIPAV page opens.

6 Select the Join or leave the list, or update options link. The Join or Leave 
the List, or Update Options page opens.

Figure 4.  NIH LISTSERV page
MIPAV User’s Guide, Volume 1, Basics 12
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7 Complete the information in the page.

8 Click Join the List. 

To unsubscribe to the MIPAV mailing list

1 Go to the Archives of MIPAV page.

2 Select Join or leave the list, or update options.

3 Click Leave the List.

Figure 5.  How to subscribe to the MIPAV mailing list
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Viewing a list of enhancements and corrections 
made to MIPAV

The version number of the most current version of MIPAV, along with a list 
of enhancements and corrections made to that version, appears on the 
MIPAV web site. 

To view MIPAV news

1 Go to the MIPAV web site on your web browser: 

http://mipav.cit.nih.gov/ 

The Medical Image Processing, Analysis, & Visualization (MIPAV) web 
page opens (refer to Figure 2 on page 9).

2 Select the What’s New link. The MIPAV News page opens.

This page lists the enhancements and corrections made to the most 
recent version of MIPAV.

To view a list of cumulative changes to MIPAV

1 Select the cumulative list of changes link at the foot of the MIPAV News 
page. The MIPAV Version History page opens. 

2 Read the lists of enhancements and corrections made to not only the 
most recent version but to all previous versions of MIPAV.
MIPAV User’s Guide, Volume 1, Basics 14
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Upgrading MIPAV

Generally, when a new version of MIPAV is available, a message is sent to 
the MIPAV mailing list. You can also find the latest version number if you 
go to the MIPAV web site and select the Download link.

To upgrade MIPAV

1 Save the following information:

• Hosts table information. You must reenter this information when 
you reinstall MIPAV (refer to Chapter 5).

• List of plug-in programs. You must reinstall all plug-in programs 
when you reinstall MIPAV (refer to Chapter 10).

2 Remove the existing copy of the software.

3 Download the installation file for the new version.

4 Install the new version of the software.

Removing MIPAV

When MIPAV is removed, all of the originally installed software 
components are removed from your hard drive. Note that files and folders 
that were created after installation, such as image dataset files and plug-ins, 
are not removed. 

To remove MIPAV

1 Navigate to the directory where the MIPAV software is installed. If you 
are not sure of the location:

a Start MIPAV (refer to Chapter 2, “Quick Start”).

b Select Help > About Java in the MIPAV window. The About Java 
window opens.

c Note the User Directory. The installation directory is the same as 
User Directory.

2 In the User Directory, navigate to the UninstallerData subdirectory.
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3 Run the MIPAV uninstallation file. File names appear in Table 2-1. The 
About to Uninstall window opens.

4 Click Uninstall to begin the process. The Component Removal Status 
window opens.

Components are removed from the system. When finished, the 
Uninstall Complete window opens.

5 Click Exit to close the window.

Note: If a component was not removed, you can use the standard file deletion 
procedures for your platform to manually remove it. By default, all of MIPAV’s 
components are stored in the directory where MIPAV was installed.
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3 Getting Started Quickly with MIPAV
This chapter provides information to help you get started quickly using 
MIPAV. 

• “Starting MIPAV” on page 18

• “Opening and loading image files” on page 20

• “Selecting views” on page 29

• “Adjusting magnification” on page 34

• “Improving contrast, adding color, and creating negative images” on 
page 41

• “Comparing images using alphablending” on page 51

• “Creating new images” on page 52

• “Delineating volumes of interest (VOIs)” on page 55

• “Calculating VOI statistics” on page 60

• “Modifying image resolutions” on page 70                                                                                                                                                                       

• “Printing images or graphs” on page 75                                                                                                                 

• “Saving images” on page 76

• “Customizing MIPAV” on page 79

• “Managing memory resources” on page 88
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• “Developing and using plug-in programs” on page 91

• “Quitting MIPAV” on page 91

Starting MIPAV

Starting MIPAV differs depending on your platform. To begin a MIPAV 
session, do the following:

Both the Medical Image Processing, Analysis & Visualization (MIPAV) 
window (Figure 6) and the Output window (Figure 7) appear on your 
desktop. You can access most of MIPAV’s features from the menu bar in the 
MIPAV window.

If your platform is . . . Then . . .

Windows 95, 98, 2000, 
NT, XP

Select Start > Programs > mipav > mipav.

Linux Open a shell. Go to the directory where you 
downloaded the installer. At the prompt, type 
sh ./installMIPAV.bin. 

Mac Operating System 
(OSX)

Unzip the installer (StuffIt expander may 
open automatically). Double-click the installer 
icon on your desktop.

Unix OS (Sun Solaris, 
OS/2 Warp, and others

In a shell tool, command tool, or terminal 
window, go to the directory where you 
installed MIPAV. At the prompt, type 
./mipav.
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After starting MIPAV, you can open and load image files, create new 
images, access DICOM images, customize MIPAV, and end the session.

Figure 6.  The MIPAV window that appears after starting the program

Figure 7.  Output window
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Opening and loading image files

The first step in image visualization is displaying the image file. MIPAV 
displays images in windows that you can move around the desktop 
(Figure 8). You can display as many image datasets as needed as long as 
your computer has enough allocated memory. The amount of memory 
required depends on the number of image datasets that are open and the 
size of each image file. For more information, see “Managing memory 
resources” on page 88.

You can either open or load an image file. When you open an image file, 
MIPAV displays the image in a new image window. Loading an image file 
imports the file into an image window in which another image file is open. 
In other words, two image files share a common image window.

Tip: If you need to compare two images that reside in different datasets, do 
the following:

1 Open the first image file. The image appears in a new image window.

2 Load the next image file. The image appears in the same image window as 
the first image file.
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Note: Only two images can occupy an image window. If you load a third image, 
it overwrites Image B.

You can use MIPAV to open or load files of a variety of medical and generic 
graphic and multimedia file formats. Table 1 lists the format, 

extension, and whether MIPAV can read or write files of a particular format. 
The extension, which is the last few characters of a file name including the 
period, indicates the file format. In the file name DOE255.ima, the 

Figure 8.  Desktop showing the MIPAV window, the Output window, and multiple image windows
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extension .ima indicates that the file is stored in DICOM format. In the 
table, the Read column indicates that MIPAV can display image files of a 
particular format. When a file is read, it is stored in main memory so that 
MIPAV can access it. The Write column means that MIPAV can copy the 
data from the memory to a storage destination, such as your hard disk. In 
this context, write is synonymous with save. For more information on file 
formats, refer to Chapter 4 in the MIPAV User’s Guide.

Table 1. File formats 

Manufacturer or 
Application Extensions Read Write

Adobe Photoshop PSD Y Y

AFNI HEAD, BRIK Y Y

Analyze IMG Y Y

Audio Video Interleave AVI Y Y

BIORAD PIC Y N

Bruker 2dseq Y N

Cheshire IMG or IMC Y Y

DICOM DCM, IMA Y Y

FITS FTS Y N

FreeSurfer image COR Y N

FreeSurfer surface (ASCII file) ASC Y N

GE – Genesis 5X and LX SIG Y N

Graphics Interchange File GIF Y N

ICS (Integrated Collection 
System)  

ICS Y N

Interfile HDR Y N

Joint Photographics Experts 
Group 

JPEG,JPG Y Y

Laser Scanning Microscope 
(Zeiss) 

LSM Y Y

Macintosh PICT PICT Y Y
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Medical Image Network 
Common Data Form including 
ROIs

MNC Y Y

MICRO-CAT LOG Y N

Microsoft Windows Bitmap BMP, DIB Y Y

Medical Research Council 
(MRC)

MRC Y Y

PC Paintbrush PCX, DCX, PCC Y Y

Portable Network Graphic PNG Y Y

QuickTime--Apple QT, MOV Y Y

RAW RAW Y Y

Siemens – Magnetom Vision IMA Y N

Sun Raster RS, RAS Y Y

Tag Image File Format TIFF Y Y

Truevision Graphics Adapter TGA, VST, VDA, 
ICB, TPIC

Y Y

X BitMap XBM Y Y

X PixMap XPM Y Y

Table 1. File formats  (continued)

Manufacturer or 
Application Extensions Read Write
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Opening image files
You can open a single image file or multifiles. Multifiles are image datasets 
that are composed of multiple files. 

To open an image file

1 Do one of the following in the MIPAV window:

• Opening other types of image files: Select File > Open > Image.

• Opening a multifile: Select File > Open > Multifile.

Tip: To form a 4D dataset in Analyze format, use the Multifile command to open 
a series of individual 3D Analyze, formatted, consecutively ordered images. 

For example, you can use the Multifile command to open an array of .tiff, 
.jpeg, .bmp, etc., files if their file names meet the following format: 

foo_001.tiff, foo_002.tiff, foo_003, etc.

where foo is the name of the file.

The Open Image dialog box (Figure 9) opens.

Note: If an image file is already open on your desktop, the commands on the 
File menu vary slightly. Select Open > Multifile(A) to open an image dataset that 
consists of multiple files. Select Open > Image(A) to open a single image file.

2 Navigate to the directory where the file is stored.

3 Select the type of file in the Files of type list (shown in Figure 9).
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4 Select the file. The name appears in File name.

5 Click Open. While the file is opening, a status message appears. Then 
the status window closes, and MIPAV displays the image in a new image 
window (Figure 10).

Figure 9.  Open Image dialog box showing shortcuts

Figure 10.  An image displayed in an image window
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Note: After the first image is opened, the MIPAV window changes. It includes 
more menus, the title bar displays more information, and toolbars appear. 
Because the MIPAV window is context sensitive, it displays or hides commands 
on the menus depending on the characteristics of the image file that is opened. 
If you opened a dataset file that contains more than one image, a slider also 
appears.

Note: If you prefer for MIPAV to use the style of Open and Save dialog boxes 
that are used by the operating system (e.g., Microsoft Windows, Unix, or Apple) 
on your computer, read the section on “Using platform-specific Open and Save 
dialog boxes” on page 81.

Loading image files
You can either open or load image files. When you open an image file, 
MIPAV displays the image, by itself, in a new image window. When you 
load an image file, MIPAV imports it into an existing image window. The 

Figure 11.  Expanded MIPAV window showing toolbars, image slider, 
and more menus after the first image is opened
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loaded image shares the same window with another image file. Loading a 
file allows you to compare two datasets. 

In MIPAV, the first image opened in an image window is referred to as 
Image A. When you load, or import, a second image in the window, MIPAV 
refers to the second image as Image B. 

To load an image file

1 Open the first image by selecting File > Open > Image(A) or 
File > Open > Multifile(A). The image appears in an image window. 

2 Select the title bar of the image window (in this case, the image that you 
just opened) in which you want to load another image. 

3 Select any of the following: 

• File > Load > Image(B) from Frame—To load another image dataset 
from an already opened image dataset to another opened image 
dataset

• File > Load > Image(B) from File—To load another image dataset

• File > Load > Multifile(B)—To load a multifile image dataset

Tip: You can use this option to load a series of individual 3D Analyze formatted, 
consecutively ordered images to form a 4D dataset in Analyze format.)

Note: The abbreviations (A) or (B) appear after some commands. (A), which is 
the abbreviation for "Image A," indicates that the option is applied to the first 
image opened in an Image window. (B), which is the abbreviation for "Image B," 
indicates that the option is applied to second image loaded in an Image window. 
For example, if you select Close Image (B), MIPAV closes the second image 
(Image B) that was loaded in the image window.

The Open window appears. 

4 Select the image file you want to load. 

5 Click OK.

If MIPAV does not recognize the type of file based on its extension, the 
Choose File Type dialog box opens. Select the file type and click OK.
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.

Note: MIPAV recognizes files types by the file extension. For example, if you 
select an image named Smith.tiff, MIPAV tries to open the file as a tiff file. If that 
image is actually a .jpg file and mistakenly has the .tiff extension, MIPAV cannot 
open the file.

As the image file is loading, a pop-up window appears with the status. 
When the image file finishes loading, it appears in the image window. At 
this point, take note of several changes:

• MIPAV pseudo-color was applied to the images in the image 
window. The pseudo-color indicates that two images are in the 
window.

• In the MIPAV window, the Active Image and Alphablending slider 
appears. The slider allows you to control which image is displayed in 
the foreground of the window. The image in the foreground is the 
active image. You can adjust the translucency of the alpha channels 
in each image using the technique.

Figure 12.  Choose File Type dialog box
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Selecting views

A view refers to the way an image file is displayed. A view indicates how 
many images are shown at one time and whether images are advanced 
manually or automatically. Depending on the view, the size and shape of the 
image window in which an image is displayed can vary.

MIPAV allows you to display images using the following views: 

• Default (explained in this section)

• Animate

• Cine (movie)  (explained in this section)

• Lightbox  (explained in this section)

• Link to another image 

• Surface plotter

• Surface render

• Triplanar 

• Triplanar—dual

• Volume render (shear)

• Volume render

Note: This section explains how to display image files in default, lightbox, and 
cine views. To learn how to display image files in other views, see Chapter 6 in 
the MIPAV User’s Guide.
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Understanding image windows
An image window (Figure 13) consists of a title bar that displays the name 
of the image file and the magnification level. If there is more than one image 
in the dataset, the title bar displays the number of the current image that is 
displayed and the total number of images in the dataset.

Moving images
You can move an image window around your desktop by clicking the title 
bar and dragging the window to a new location. Sometimes, depending on 
the view, a toolbar or menu bar also appears in the image window. For 
example, the image window using the light box view contains a toolbar and 
menu bar.

Displaying images using the default view
In the default view, MIPAV displays the images in a dataset one at a time in 
an image window (Figure 14). This window can display datasets of any 
dimension.

Figure 13.  An image window
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Displaying images using the lightbox view
The lightbox view is similar to the default view, except that all images in the 
dataset appear in one window at the same time (Figure 15).

To display images in the lightbox view

1 Open an image file. The image appears in an image window.

2 Select the image window. Do one of the following in the MIPAV window:

• Click Lightbox .

• Select Image > Views > Lightbox.

The image now appears in a lightbox view.

Tip: To magnify a portion of the image, click Magnification Region  and move 

the pointer to the image section to be magnified. Click Default Mode  when 
finished.

Figure 14.  An image in an image window (default view)
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3 Select Options > Settings in the lightbox view window to adjust the size 
and shape of the window. 

The Lightbox Settings dialog box (Figure 16) opens.

4 Indicate the number of rows and columns, the grid size, frame border 
size, color settings, and the magnification. For more information on 
these attributes, see volume 1 of the MIPAV User’s Guide.

5 Click Close when complete.

Figure 15.  An image dataset shown in a lightbox view
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Tip: Double-clicking an image in the lightbox view updates the 2D image frame 
to that image.

Displaying images using the cine view
When you view an image file in cine view, MIPAV automatically advances 
images one frame at a time. The effect is much like a film loop. 

To display images in cine view

1 Open an image file. The image appears in the default image window.

2 Select Image > Views >  Cine (Movie). The images in the image 
window are advanced automatically.

Figure 16.  Lightbox Settings dialog box
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Adjusting magnification

MIPAV allows you to magnify images from ¼ to 32 times the size of the 
original image. Using the magnification tools, you can magnify or minify the 
entire image or just a portion of the image. The magnification box is much 
like a traditional magnifying glass, except it can also minify, or reduce the 
level of magnification, a portion of the image. 

This section explains how to change the magnification level of the image 
using the icons on the image toolbar (Figure 17) in the MIPAV window.

 

To learn how to set the magnification level using the other methods, see 
volume 1 of the MIPAV User’s Guide. 

To adjust the magnification level using the image toolbar in the MIPAV 
window, you can use the following:

• Magnify Image icon 

• Minify Image icon 

• Magnify Region icon 

• Original Magnification icon 

Magnifying images

To magnify an image, click Magnify Image . Each time you click the 
Magnify Image icon, the image doubles in size. If an image is too large for 

Figure 17.  Magnification icons are located on the image toolbar
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the current window size, scroll bars appear, and you may need to manually 
adjust the size of the window.

Reducing the magnification level

To reduce the magnification level of an image, click Minify Image . Each 
time you click the Minify Image icon, MIPAV reduces the magnification 
level of the image by half.

Figure 18.  Original image and magnified image achieved from click the Magnify Image icon once
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.

Restoring the original level of magnification
To return the image to its original size or original level of magnification, 

click Original Magnification .

Magnifying regions within images

The Magnify Region icon  allows you to view a square portion, or region, 
of the image at a specific magnification level. 

Note: If you have loaded two images into the same image window, the Window 

Region of Image B icon appears on the toolbar. Use this icon to view a region 
on the second image, or image B.

To use the Magnify Region icon

1 Open an image.

2 Click Magnify Region  and move it over the image. 

Figure 19.  Minified images that result from using the Minify Image icon
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As you move the mouse over the image, the Magnify Region icon 
displays a magnified square region in the image in a red box. The 
number at the left corner of the square is the magnification level.

To change the size of the magnified region

You can change the size of the magnifying region to allow you to view larger 
or smaller regions of the image.

1 Right-click on the image while displaying a magnified region. The 
Magnify dialog box appears.

2 Type either a higher number for a larger region or a lower number for a 
smaller region in the Width box. Valid values range from 64.0 to 198.0.

3 Select Apply. The size of the magnified region, or square, either 
increases or decreases in size.

Figure 20.  Magnified square region on an image

Figure 21.  Magnification dialog box
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INCREASING AND DECREASING THE 
MAGNIFICATION LEVEL

Changing the magnification level of the magnified region works similarly to 
changing the size of the magnified region. 

Figure 22.  Magnifying glass at different sizes
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To change the magnification level

1 Right-click on the image while displaying a magnified region. The 
Magnify dialog box (Figure 23) appears.

2 Slide the Magnification slider (Figure 23) to the right to increase the 
magnification level or to the left to decrease the magnification level.

Note: When you slide the Magnification slider right past a certain point, the 
Display intensity values check box becomes active.

3 Select Apply. 

Tip: To review or compare a magnified region of the image with the same region 
at its original magnification, press Shift. Release the key when to return to the 
magnified view.

The magnification level shown in the magnified region changes to the 
level you specified.

Figure 23.  Magnification slider on the Magnification dialog box
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SHOWING INTENSITY VALUES THROUGH THE 
MAGNIFICATION GLASS

The Display intensity values check box on the Magnify dialog box allows you 
to display the intensity values within a magnified region of the image. 

To show the intensity values

1 Right-click on the image while displaying a magnified region. The 
Magnify dialog box appears.

2 Select the Display intensity values check box. 

If the check box is not available, or dimmed (as it is in Figure 21), 
increase the magnification by sliding the magnification slider to the 
right until the check box is active (refer to Figure 23).

3 Move the mouse over the image. The intensity values appear within the 
magnified region (Figure 25).

Figure 24.  Two different magnification levels in the same magnified 
region
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Tip: If you hold down the middle mouse button, MIPAV writes the intensities 
by position within the image to the Data page of the Output window. You can 
then save these messages and print them.

Improving contrast, adding color, and creating 
negative images

This section explains how to improve the image contrast, add color to 
images, and create negative images by applying a quick lookup table (LUT), 
generating and modifying a histogram, applying pseudo-color LUTs, and 
creating negative images by inverting their color.

histogram—A histogram is a representation of a frequency distribution by 
means of rectangles whose widths represent class intervals and whose areas are 
proportional to the corresponding frequencies.

lookup table (LUT)—A lookup table maps the frequency distribution in a 
histogram to pseudo-color values.

For more information, including how to create a customized LUT, see 
volume 1 of the MIPAV User’s Guide.

Figure 25.  An image window displaying intensity values for a magnified 
region in the image
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Improving contrast on images quickly
MIPAV provides the following quick ways to improve the contrast on 
images:

• Using the Quick LUT icon

• Using the right mouse button

• Using the Adjust Window and Level icon

USING THE QUICK LUT ICON

An easy way to improve the contrast in an image is by using the Quick LUT 

icon , which is located on the image toolbar in the expanded MIPAV 
window (Figure 26). 

To use this icon, you first need to open an image to display the expanded 
MIPAV window. 

To use the Quick LUT icon

1 Open an image file. The image appears in an image window. If an image 
was not previously open, the initial MIPAV window expands to include 
all of the menus.

2 Select the image window.

3 Click Quick LUT .

4 Hold down the left mouse key and draw a rectangle on a portion of the 
image.

5 Release the left mouse key. Based on the amount of dark and light in the 
portion of the image that you selected, MIPAV changes the contrast in 
the image.

Figure 26.  Quick LUT icon on the image toolbar
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Repeat steps 3 through 5 as often as you wish to further improve image 
contrast. When you are satisfied with the contrast, save the image.

USING THE RIGHT MOUSE BUTTON

The right mouse button provides you with a very simple way of changing 
image contrast. To do so, open an image and then hold down the right 
mouse button and drag it around the screen. The cursor changes from a red 

cross to .

When you drag the cursor up and down or across the image, the image may 
become darker and gradually disappear or become lighter in appearance. At 
some points you may be able to create a negative of the image.

USING THE ADJUST WINDOW AND LEVEL 
ICON

The Adjust Window and Level icon  on the Image toolbar provides 
another way to change the contrast of images. 

Figure 27.  Images before and after applying the Quick LUT icon
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To adjust image contrast

1 Open an image file. The image appears in an image window. If an image 
was not previously open, the initial MIPAV window expands to include 
all of the menus.

2 Click Adjust Window and Level .

The Level & Window dialog box (Figure 28) appears.

3 Move each slider up or down to change the contrast of the image. The 
changes are immediately effective in the image.

4 Click Close when you are finished.

Restoring images to their original appearance

To return to the original appearance of the image, click Reset LUT , 
which is also located on the image toolbar. In addition, you can click the 

Figure 28.  Level & Window dialog box
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Gray icon  to restore the image to grayscale if you have changed or added 
colors.Improving contrast by generating and modifying histograms

A histogram is a graphic representation of the intensity level distribution in 
an image or VOI region. It displays the number of voxels at each intensity 
level. To generate a histogram of an image, you can use either the Lookup 

Table icon  on the image toolbar or the LUT menu in the MIPAV window.

To generate a histogram for an image

1 Open an image. The image appears in an image window.

2 Do either of the following:

• Click Lookup Table icon .

• Select LUT > Histogram - LUT.

Figure 29.  LUT menu in the MIPAV window
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The Histogram dialog box (Figure 30) appears.

3 Select either Whole image or VOI region(s).

4 Click OK. A progress message (Figure 31) appears.
 

After a few moments, the Lookup Table window (Figure 32) opens.

lookup table (LUT)—Indicates the intensity of each voxel in the image and, in 
MIPAV, allows you to remap the original intensities to other intensities.

transfer function—Reflects the relationship between the original image 
intensity values and how they are mapped into the LUT. The line in the LUT 
represents the transfer function.

Figure 30.  Histogram dialog box

Figure 31.  Progress message that appears when the program is 
calculating the histogram
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File Open LUT—Opens a previously saved LUT file. LUT files have an .LUT 
extension.

Save LUT—Saves the LUT displayed in this window in a LUT file.

Open Transfer Functions—Opens a previously saved transfer function. 
Transfer function files have a .FUN extension.

Save Transfer Functions—Saves the transfer function displayed in this 
window to a file.

Close LUT—Closes the LUT window.

Figure 32.  Lookup Table window
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Applying color to images using predefined LUT
MIPAV provides a variety of pseudo-color LUTs. When a pseudo-color LUT 
is applied to an image, the grayscale intensities are remapped to the pseudo-
color intensity values. The LUT toolbar appears in Figure 33.

To apply a pseudo-color LUT

1 Open an image. The image appears in the image window.

2 Select the image window.

Utilities Change number of colors—Allows you to change the number of colors 
displayed in the image. Valid values are 2 to 256.

CT function—Allows you to select a preset LUT that is appropriate for the 
image content. Values are abdomen, head, lung, mediastinum, spine, and 
vertebrae.

Invert LUT—Creates a negative of the image.

Reset histogram and LUT A—Returns image A to its original values.

Reset histogram and LUT B—Returns image B to its original values. This 
command is only available if two images are open.

LUT toolbar See Figure 33

Update (real-time) Changes the image as you make changes to the LUT, which allows you to 
see the effect of your changes immediately on the image.

Log scale (histogram) Displays the image’s histogram count in log scale along the Y axis.

Interpolate image Displays image using interpolation, which reduces pixillated image to 
appear more smooth.

Caution: Depending on the memory resources of your workstation, 
interpolation can be very lengthy.

Number of colors Allows you to change the number of colors displayed in the image. 

LUT Displays the image intensities.

Figure 32.  Lookup Table window (continued)

Using interpolation to smooth images
If you are zooming in on a portion of an image and want to reduce the 
appearance of pixilations in the image, make sure to select the Interpolate 
image check box. Interpolation smooths the pixilation. 
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3 Select one of the LUTs on the LUT toolbar (Figure 33) in the Lookup 
Table window.

 

4 Do either of the following:
• To update the view of the image immediately, select Update (real-

time). 
• If you do not want to update the view of the image, click Close. The 

Lookup Table window closes, and MIPAV applies the LUT to the 
image.

Tip: To change back to the original grayscale intensities, click Gray LUT  in the 
MIPAV window.

Figure 33.  LUT toolbar
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Creating negatives of images
The invert LUT icon creates a negative of an image. 

To create a negative image

1 Select the image window of the image you want to invert.

Tip: You may wish to apply an LUT to the image or adjust the histogram of 
the image first before applying creating the negative.

2 Click Invert LUT .

Note: Invert LUT  appears on two different windows: in the Image toolbar in 
the MIPAV window (select Toolbars > Image toolbar to display the toolbar) and in 
the LUT toolbar in the Lookup Table window. 

Based on the 256-step color values scale, MIPAV assigns the inverse value 
to each pixel (refer to Figure 34). 

Tip: The Invert LUT icon  is a toggle. To change the image back to its 
previous appearance, simply select Invert LUT  again. To change the image 
back to its original appearance, select Reset LUT .

Figure 34.  Image before and after inversion
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Comparing images using alphablending

Alphablending is a technique that adds transparency information to 
translucent objects. When two images share a window, you can adjust the 
alphablending settings so that you can see a blend of both images and can 
compare overlapping regions in two datasets. 

To use the alphablending function

1 Select an image window that has two images.

2 Adjust the alphablending slider at the bottom of the MIPAV window.

3 Move the slider to select the best ratio for the datasets of interest. 

The level of translucency for one image is inversely proportional to the 
other. Thus, if image A is 75 percent transparent (25 percent opaque), 
then image B is 75 percent opaque (25 percent transparent).

Figure 35.  MIPAV window showing the alphablending slider at the bottom of the window
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Creating new images

To create a new image file

1 Do one of the following: 

• If an image file is not already open, select File > Create Blank 
Image(B).

• If an image file is already open, select File > Open > Create Blank 
Image(A). 

The Raw dialog box (Figure 36) appears.

2 Select the image type. 

3 Select the units of measure for each dimension. 

4 Enter the header offset and byte ordering information.

Figure 36.  Raw dialog box
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Image type Synonymous with data type. The image type determines the number of intensities 
that can be represented in an image. For example, a Boolean image can display two 
intensities: 1 and 0. 

• Boolean—1 bit per pixel (1 on, 0 off)
• Unsigned byte—1 byte per pixel (0, 255)
• Unsigned short—2 bytes per pixel (0, 65535)
• Unsigned integer—4 bytes per pixel (0, 232 -1)
• Float—4 bytes per pixel (-3.4E38, 3.4E38)
• ARGB—3 bytes per pixel, plus 1 byte; 8 bits per color channel (alpha, red, green, 

and blue)
• Byte—1 byte per pixel (-128, 127)
• Short—2 bytes per pixel (-32768, 32767)
• Integer—4 bytes per pixel (-231, 231-1)
• Long—8 bytes per pixel (-9.22E18, 9.22E18)
• Double—8 bytes per pixel (-1.8E308, 1.8E308)
• ARGB U short—2 bytes per color channel and 2 bytes for alpha channel

Dimensions 
and 
resolutions

Degree of manifoldness of a quantity such as space or time. Two-dimensional 
datasets are composed of one image (the two dimensions are length and width). 
Generally, three-dimensional datasets are composed of more than one image. The 
third dimension is generally space. The fourth dimension is generally time. (Either 
time or space can be the third or fourth dimensions.) Zeros in the text boxes indicate 
that the dimension is not represented in the image. For example, if the text boxes for 
the first and second dimensions are filled, and the rest of the text boxes are filled 
with a zero, the image only has two dimensions. 

Dimensions

• 1st—Width (along x axis)
• 2nd—Length (along y axis)
• 3rd—Depth (along z axis)
• 4th—Time (along t axis)
• 5th—Fifth dimension

Resolutions

Size of pixel or voxel per dimensions 1 through 5.

Units of 
measure

Indicates the unit of measurement for each of the applicable dimensions.

Header 
offset

Indicates the size of the space reserved at the beginning of the file where specific 
types of information is kept. This space, which is called the header, precedes the 
image data. If you know the length of the header, type it in this box. When MIPAV 
accesses the file, it skips the header offset and begins to read the image data. Note 
that not all image file formats have a header.

Figure 36.  Raw dialog box (continued)
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5 Click OK. A blank image (Figure 37) appears in an image window.

6  Use the paint and VOI tools to create an image.

7 Click File > Save image as. The Save dialog box opens.

8 Type the name of the file in File Name, and select the file type in Files of 
type.

9 Click OK. MIPAV saves the image under the file type you selected.

Big endian Indicates whether image data is stored in the big endian format. If not, the image 
data is stored in the little endian format. Endianness refers to the byte ordering of 
the data. Some computers order the data with the least significant byte (LSB) first 
followed by the most significant byte (MSB). This byte order is referred as little 
endian or Intel byte ordering. Machines that use little-endian byte ordering are 
VAXes, Intel x86, and Pentium. The reverse is MSB and then LSB, which is referred 
as big endian or Motorola byte ordering. Machines that use big-endian byte ordering 
are IBM System 3D, RISC, and a Motorola 680x0. MIPAV is biendian; it supports both 
big- and little-endian byte-ordering formats.

OK Applies the parameters that you specified and creates a blank image.

Cancel Disregards any changes you made in this dialog box, closes the dialog box, and does 
not create a blank image.

Help Displays online help for this dialog box.

Figure 36.  Raw dialog box (continued)

Figure 37.  Blank image
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Delineating volumes of interest (VOIs) 

MIPAV provides tools that allow you to automatically, semiautomatically, 
and manually identify and modify volumes of interest (VOIs). 

volume of interest—The portion of the image in the dataset on which you want 
to focus. It may be either one slice or multiple slices throughout the dataset.

Each VOI can be formed from multiple contours in a single slice or multiple 
slices. Once an object is segmented and defined by a VOI, statistics of the 
volume can be calculated.

MIPAV supports over 32,000 unique VOIs on a single dataset. Additionally, 
you can move or delete nodes on the VOI and add new points. VOI types 
include:

• Point, which is created by using 

• 2D line

• Rectangular

• 3D rectangular

• 2D elliptical

• Polygonal

• 3D polygonal

• Interactive level-set
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Generating contour VOIs using predefined shapes
MIPAV includes icons of predefined shapes, such as points, lines, ellipses, 
or rectangles, that you can use to create VOIs. These icons are on the VOI 
toolbar. 

To generate contour VOIs using the predefined 
shapes

1 Select one of the contour icons from the VOI toolbar in the expanded 
MIPAV window (Figure 38).

2 Move the pointer to the image window. The pointer changes to a cross-
hair shape. Do one of the following:

• Points, levelset: Position the cursor on the area where the point or 
levelset should be drawn. Click the mouse button.

• Straight lines, rectangles (2D and 3D), ellipsoids: Position 
the cursor on the area where the contour should begin. 

Click the mouse button. 

While holding down the mouse button, drag the cursor until the contour is 
the desired size.

• Polylines, polygons: Position the cursor over the area where the 
contour should begin. 

Click the mouse button. A point appears. 

Figure 38.  Contour icons on the VOI toolbar
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Alternate between moving the mouse and selecting the mouse button to 
outline the VOI. 

To complete a polyline, double-click the mouse button. To complete a 
polygon, connect the first and last nodes.

Tip: To draw the same shape several times in succession, hold down the Shift 
key while you select the applicable icon from the VOI toolbar and draw.

Adding and moving boundary points on VOIs
No matter which method you choose to delineate a VOI, you can add points 
and change the boundaries of the VOI. For example, suppose you created a 

VOI on an image with the Rectangle VOI icon . If you notice that a part 
of the image that should be included in the VOI isn’t, the boundary of the 
rectangle needs to be adjusted to include the missing portion of the image. 

To add a point and change the boundary of the VOI

1 Select the VOI. Notice that white points appear at the corners of the VOI 
and a small cross appears in the middle of the VOI.

2 Place the cursor on the portion of the VOI you want to adjust. The cursor 

changes from a cross  to .

3 Click once. A white point appears on the line.

4 Select the point and drag it to include the missing part of the image.

Tip: Circular VOIs are composed of a continuous series of points around the 
diameter of the circle. You only need to select one of those points and drag it to 
enlarge the circle.
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Figure 39.  Adding a point and adjusting the boundary of a rectangular VOI
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Automatically adjusting contour boundaries
After a contour is drawn, it might be necessary to adjust the boundaries so it 
more closely matches the VOI region. 

To adjust contours

1 Click a contour. The nodes become visible. 

2 Select VOI > Evolve boundary 2D >Active contour. The Evolve 
Boundary dialog box opens (Figure 40).

3 Modify the information in the window if necessary. 

4 Click OK.

A new contour, that more closely outlines the VOI, appears on the 
image. The old contour also remains.

Tip: To delete the old contour, select it and select Cut Selected Contour , or 
press the Del key on the keyboard.

Figure 40.  Evolve Boundary dialog box
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Calculating VOI statistics

Once a VOI is drawn, you can calculate the number of voxels in the VOI, the 
volume, and area. You can also calculate the average and standard deviation 
of the voxel intensity and the center of mass. For 2D images, you can 
calculate the principal axis and the eccentricity. 

MIPAV provides two methods for you to obtain VOI statistics:

• By using VOI properties—This method is fast and simple and provides 
statistics for the entire VOI. Although it allows you to save the results 
in a text file, that is an additional step. However, using this method, 
you can type additional information directly onto the Data page with 
the statistics.

• By using the Statistics Generator—Using this method, you can obtain 
statistics on the entire VOI, on a single slice of the VOI, or by contour 
and slice. The Statistics Generator also automatically saves the results 
in either a tab-delimited file or an XML file of your choosing. In 
addition, it displays statistics in a tabular format.

Note: MIPAV can calculate statistics for only one VOI at a time. In addition, 
MIPAV calculates the volume and area in a VOI using image pixel (voxel) 
resolutions.

Using VOI properties

To calculate VOI statistics

1 Delineate a VOI on an image.

2 Select the desired VOI in the image window.

3 Select VOI > Properties in the MIPAV window. The VOI Statistics dialog 
box appears (Figure 41).

4 Select the statistics to be calculated in Statistics to Calculate. 

5 Click Calculate.

6 Select the statistics to be calculated in Statistics to Calculate. 

7 Click Calculate. 
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The VOI Statistics dialog box remains on the desktop. In a few 
moments, statistical data appears on the Data page in the Output 
window. 

Name of VOI Shows the name of the VOI.

Show contour 
bounding box

Highlights the VOI and, when you select the VOI, displays a box that 
encompasses all of the VOI’s borders and lists the measurements and position 
of each boundary.

Additive or 
subtractive

Not implemented at this time.

Include for 
processing

Not implemented at this time.

Figure 41.  VOI Statistics dialog box
MIPAV User’s Guide, Volume 1, Basics 61

9/20/04 



M   I   P   A   V
M e d i c a l   I m a g e   P r o c e s s i n g, A n a l y s i s,   &   V i s u a l i z a t i o n

Chapter 3,  Getting Started Quickly with MIPAV
8 Click the Data tab in the Output window to view the results. The Data 
page in the Output window (Figure 42) appears.

9 Do one or a combination of the following if desired:

Boundary or 
blended

Smooths the image inside the VOI.

Statistics to 
calculate

Provides a list of statistics. Select the statistics that you want to include in the 
report. 

Select all Selects all of the statistics listed in the Statistics to calculate list.

Clear Clears all of the check boxes that you selected in the Statistics to calculate list.

Exclude 
intensity range

Allows you to select specific intensity ranges in the Range boxes that you want 
to exclude from the calculation. 

Watershed seed 
value (0-32K) 

Indicates the basin value used when running the Watershed algorithm on 
images.

Apply Applies the changes you made in this dialog box and leaves the dialog box open 
for you to make further changes.

Cancel Disregards any changes you made in this dialog box, closes the dialog box, and 
does not run a statistics report.

Calculate Calculates the statistics requested in this dialog box and displays them in the 
Data page of the Output window. 

Figure 41.  VOI Statistics dialog box (continued)

Figure 42.  Output window showing statistics
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• Add information to the statistics by typing the information directly 
into the statistics on the Data page.

• Select the data that you want to remove, and then click Cut  or 
select Edit > Cut (Figure 43) to cut the selected data. MIPAV 
removes the selected text from the Output window and copies it to 
the clipboard for use in other applications.

• Select the data that you want to copy, and then click Copy  or 
select Edit > Copy to copy the data to another location in the window 
or to another application (such as a word-processing program).

• Click Save  or select File > Save (Figure 44) messages (Figure 44) 
to save the data and any comments you’ve added to a text file.

Figure 43.  Edit menu on the Output window
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. 

• Click Clear Messages  or select Edit > Clear Messages to clear the 
window.

10 Click Cancel in the VOI Statistics dialog box when complete to close the 
dialog box.

Using the Statistics Generator
If you plan either to use a database or spreadsheet to keep track of VOI 
statistics or to obtain them in an XML format, use the Statistics Generator. 
As mentioned earlier, the Statistics Generator can provide statistics on an 
entire VOI or a particular slice or by contour and slice.

Using the Statistics Generator includes three tasks:

• Selecting VOI and save options

• Selecting statistics options

• Reviewing the statistics

SELECTING VOI AND SAVE OPTIONS

The first task is to select the VOIs on which you want to obtain statistics and 
select the file in which the resulting statistics should be saved.

Figure 44.  Save messages command on File menu in the Output window
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To select VOIs

1 Delineate a VOI on an image.

2 Select the VOI in the image window. 

3 Select VOI > Statistics Generator in the MIPAV window. The Calculate 
Statistics on VOI Groups window appears (Figure 45).

This window displays all of the VOIs on the image in the VOI group list 
on the left.

4 Select the VOI on which you want to obtain statistics in the VOI group 
list.

5 Select Send selection right . The name of the VOI appears in the VOI 
group list on the right.

6 Use Browse to choose a file name in the VOI Statistic File Destination 
box.

Figure 45.  Calculate Statistics on VOI Groups window
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7 Select either of the two formats in the Output Format group: 

• Tab delimited
• XML

8 Click Statistics Options. The Statistics Options page opens.

9 Proceed to the next task: Selecting statistics options.

SELECTING STATISTICS OPTIONS

The Statistics Options page (Figure 46) provides a list of statistics from 
which you can select and the options to obtain statistics by slice, by contour 
and slice, or by the total VOI.

To select statistics to perform on VOIs

1 Do either of the following in the Statistics to calculate group:

• Select one or more of the listed types of statistics.
• Click Select all to obtain all of the statistic types.

2 Select one of the following options in the Statistics options group:

• By contour & slice
• By slice only
• By total VOI (the default selection)

3 Select Show all totals if you want to record the totals for each type of 
statistic.

4 Click Calculate.

5 Select Logging. The Logging page (Figure 47) appears.

6 Proceed to the next task: ‘‘Reviewing the statistics’’.
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Figure 46.  Statistics Options page

1 Select either:

• One or more 
statistics

• Select all
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REVIEWING THE STATISTICS

The Logging page (Figure 47) displays the statistics in tabular form. 
Whether or not you chose a type of statistic on the Statistics Options page, 

Overwriting statistics files
If you previously ran the Statistics Generator and obtained statistics, after 
you click Calculate a message appears stating that a statistics file already 
exists. It asks whether to overwrite the file or to cancel the action.

If you not want to overwrite the file, click Cancel. The following warning 
message appears. 

Return to the VOI selection page and choose another file name in the VOI 
statistic file destination box. Then click Calculate to obtain the new set of 
statistics. The Statistics Generator calculates the statistics and saves them 
in the file that you indicated. The statistics appear on the Logging page.

If it’s all right to overwrite the file, click Overwrite. The Statistics Generator 
calculates the statistics and overwrites the previously recorded statistics 
file.

Tip: If you always want the Statistics Generator to overwrite the file, either 
select Options > Overwrite file automatically or press Alt O.

Go to the next task: ‘‘Reviewing the statistics’’.
MIPAV User’s Guide, Volume 1, Basics 68

9/20/04 



M   I   P   A   V
M e d i c a l   I m a g e   P r o c e s s i n g, A n a l y s i s,   &   V i s u a l i z a t i o n

Chapter 3,  Getting Started Quickly with MIPAV
the table includes a heading for each type. Blanks cells in the table indicate 
that you did not choose to obtain that particular type of statistics.

Each time you calculate the statistics for a VOI the Statistics Generator adds 
another row of statistics to the table. Note that the first column in the table 
lists the name of the VOI and, if appropriate, the slice and contour numbers. 
Also, you can change the width of each of the columns in the table by 
dragging the line between the columns in the heading.

You can include and review the statistics file in a database or in a 
spreadsheet program by double-clicking on the file name in Windows 
Explorer window and, in the Open with dialog box, selecting the application 
in which you want to open the file.

When the number of rows in the table exceeds the length of the Logging 
page, scroll bars appear on the right side of the table to allow you to scroll 
from the beginning or to the end of the table. 

Figure 47.  The Logging page in the Calculate Statistics on VOI Groups window
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If at any time you want to clear, or erase, all of the rows of the table, select 
Options > Clear log window (Figure 48). The complete table disappears 
from the Logging page, which is now totally gray.

Modifying image resolutions

To modify the resolutions in an image

1 Open an image.

2 Select Image > Attributes > Edit attributes in the MIPAV window. The 
Image Attributes dialog box (Figure 49) opens.

3 Click Resolutions. The Resolution page (Figure 50) appears.

4 Modify the resolutions.

Figure 48.  Options menu showing the Clear Log Window command

Figure 49.  Image Attributions dialog box
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5 Click Apply. 

6 Click OK or Close when complete. The window closes.

Generating graphs (intensity profiles)

MIPAV can generate a graph of the intensity values of a region bound by a 
VOI. You can then save this graph, or intensity profile, to a file for future 
reference. 

Generating new graphs
You can generate an intensity profile for any VOI. 

To generate a graph of a VOI

1 Select a VOI in an image window.

2 In the MIPAV window, select one of the following:
 

• VOI > Graph > Boundary intensity
• VOI > Graph > 2.5D total intensity
• VOI > Graph > 2.5D average intensity

Figure 50.  Resolutions page in the Image Attributes dialog box
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Tip: You can also select these same commands by right-clicking inside the VOI in 
the image window and selecting Graph and the appropriate command 
(Figure 51).

Either the Contour VOI Graph window (Figure 52) or the Intensity Graph 
window (Figure 53) appears.

Each function on the graph represents the intensity levels within each channel.

3 Close the graph by either selecting File > Close graph or pressing Ctrl X.

Figure 51.  Right-clicking on selected VOI
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.

Figure 52.  Contour VOI Graph window

Figure 53.  Intensity Graph window
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Saving graphs to a file

To save a graph

1 Select File > Save graph in the Intensity Graph window (Figure 53) or 
the Contour VOI Graph window (Figure 53), or press Ctrl S. 

The Save dialog box (Figure 54) appears.
 

2 Type a name for the graph in File name. 

3 Make sure that Graphs (.plt) appears in Files of type.

4 Click Save. MIPAV saves the file under the specified name.

Figure 54.  Save dialog box
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Printing images or graphs

To print images and graphs 

1 Do one of the following:

• Click Print  in the MIPAV window.

• Select File > Print image in the MIPAV window.

• Select File > Print graph in the Graph window. 

The Print dialog box (Figure 55) appears. 

2 Adjust the print options if necessary.

3 Click OK to print the graph or image on your default printer.

Figure 55.  Print dialog box
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Saving images

This section explains how to save images in the same format (as when 
opened) or in a different one. It also explains how to save an image as a 
TIFF file.

Note: If you prefer for MIPAV to use the style of Open and Save dialog boxes 
that are used by the operating system (e.g., Microsoft Windows, Unix, or Apple) 
on your computer, read the section on “Using platform-specific Open and Save 
dialog boxes” on page 81.

Saving images in the same format

To save an image file in the same format (as when 
opened)

1 Do one of the following in the MIPAV window:
• Click Save Image.
• Select File > Save Image.

The Save dialog box appears (Figure 56).

Figure 56.  Save dialog box
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2 Type the name of the file in File name. 

3 Click Save.

Saving images as RGB TIFF files
An image can be saved as an RGB TIFF file. 

To save images as RGB TIFF files

1 Select File > Save as in the MIPAV window.

The Save dialog box (Figure 56) appears.

2 Type the name of the image in File name. Make sure you add .tiff as the 
extension.

3 Click Save. MIPAV saves the file as a TIFF file under the name you 
specified.

Saving images to MINC format

To save images to MINC format

1 Select File > Save As.

The Save dialog box (Figure 56) appears. 

2 Type the name of the file. Make sure the extension is .mnc.

Note: MIPAV uses the file extension to save image into various formats. Thus 
saving an image with the extension of .tiff causes the image to be saved as a 
TIFF  image. Saving an image with the extension of .img causes the image to be 
saved as a Analyze image. See Table 1 for file extensions supported by MIPAV. 

The Attributes to Save dialog box (Figure 57) appears. 

3 Complete the text boxes with the appropriate information. Note that the 
x, y, and z values differ from DICOM.

4 Click OK to save the file.
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Figure 57.  Attributes to Save (MINC) dialog box

Figure 58.  Comparison of MINC and DICOM image orientation
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Saving images to another format or renaming images

To save images to a different format from the 
original file or to rename images

1 Select File > Save as. 

The Save dialog box (Figure 56) appears. 

2 Type the new name in File name. To save the file in a different format, 
change the file extension. A list of extensions appears in Table 1 on 
page 22.

3 Click Save. MIPAV saves the file under the name and extension you 
specified.

Customizing MIPAV

You can set the following MIPAV configuration options:

• Show or hide splash screen 

• Using platform-specific Open and Save dialog boxes

• Show or hide toolbars

• Place MIPAV in log mode

• Place MIPAV in debug mode

• Manage memory resources

• Develop and use plug-in programs

Showing or hiding the splash screen on MIPAV start-
up

The splash screen is the window that first appears briefly when you start 
MIPAV. It appears immediately before the MIPAV window and the Output 
window open. The splash screen displays the name of the program and the 
MIPAV logo.

By default, MIPAV always displays the splash screen on start-up unless you 
decide to hide it. To do so, you need to change the option in the MIPAV 
Options dialog box.
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To hide the splash screen or prevent it from 
appearing on start-up 

1 Select File > Help > MIPAV Options. The MIPAV Options dialog box 
(Figure 59) opens.

2 Clear the Display Splash Screen check box.

3 Click Apply. 

4 Click Close. The MIPAV Options dialog box closes. The next time you 
start MIPAV, the splash screen does not appear.

To show the splash screen

After hiding the splash screen, you may later decide to display it.

1 Select File > Help > MIPAV Options. The MIPAV Options dialog box 
(Figure 59) opens.

2 Mark the Display Splash Screen check box.

Figure 59.  MIPAV Options dialog box
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3 Click Apply. 

4 Click Close. 

After you quit MIPAV and then start it again, the splash screen appears.

Using platform-specific Open and Save dialog boxes
By default, MIPAV uses its own version of Open and Save dialog boxes, 
which provide you with the ability to assign aliases, or shortcuts, to 
frequently used images. Aliases make it easy to locate images, a feature that 
may be attractive if you work with the same images for a period of time. 
However, you may prefer instead to use the style of Open and Save dialog 
boxes that are provided with the operating system of your computer. To do 
so, you need to select the Use platform-style File dialog boxes check box in 
the MIPAV Options dialog box (Figure 60).

If this check box is selected and your computer is running Microsoft 
Windows, MIPAV displays the Windows style of Open and Save dialog 
boxes. If you use a Sun terminal, when this check box is selected, MIPAV 
displays the standard Unix-style Open and Save dialog boxes. On Apple 
MacIntosh computers, MIPAV displays dialog boxes that are standard with 
that operating system.

To use platform-specific dialog boxes

1 Select File > Help > MIPAV Options. The MIPAV Options dialog box 
opens.

2 Select the Use platform-style File dialog boxes check box.

3 Click Apply.

4 Click Close. The dialog box closes.
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Showing and hiding toolbars
After you open an image in MIPAV and the MIPAV window expands to 
display all of its menus, you can decide which toolbars should appear. By 
default, the window displays the VOI, Scripting, and Image toolbars.

The Toolbars menu contains check boxes for each of the four toolbars:

• VOI toolbar. Volume of interest toolbar (Figure 61). The VOI toolbar 
contains tools that help you in selecting the specific area of interest on 
the image.

• Paint. The Paint toolbar (Figure 62) includes tools that allow you to 
add, adjust, or remove colors and color intensity, erase paint, and 
adjust the opacity level of the paint.

Figure 60.  MIPAV Options dialog box
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• Scripting. The Scripting toolbar allows you to locate and run 
previously recorded scripts, or macros, that contain two or more 
algorithms on images.

• Image. The Image toolbar (Figure 64) includes tools for opening, 
printing, saving, maximizing, and minimizing an image; converting an 
image from gray scale to color or from color to gray scale; and adding 
to and removing slices from an image or changing their order; and 
rotating, cropping, and flipping an image.

Figure 61.  VOI toolbar

Figure 62.  Paint toolbar
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By marking or clearing these check boxes, you can choose which toolbars to 
display and which to hide. For example, suppose you just started MIPAV a 
moment ago. You then open an image. The MIPAV window expanded in 
size and displayed its full complement of menus. Although it displays the 
VOI, Scripting, and Image toolbars, you want to work with the Paint toolbar 
as well as the Image toolbars. However, you don’t need to use the VOI and 
Scripting toolbars.

Figure 63.  Scripting toolbar 

Figure 64.  Image toolbar
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To hide the VOI and Scripting toolbars and display 
the Paint toolbar

1 Select Toolbars > VOI to hide the VOI toolbar. MIPAV removes the 
check mark from the check box and removes the VOI toolbar from the 
MIPAV window.

2 Select Toolbars > Scripting to hide the Scripting toolbar. MIPAV 
removes the check mark from the check box and removes the Scripting 
toolbar from the MIPAV window.

3 Select Toolbars > Paint to display the Paint toolbar. The program marks 
the check box and displays the Paint toolbar in the MIPAV window. 

Because the Image toolbar is already displayed, you do not need to do 
anything.

Turning the log mode on or off
MIPAV provides a log mode that records the algorithms applied to an 
image. The log records the algorithms applied, the parameters entered, and 
whether the algorithm completed successfully. By default, the log mode is 
on when you first start MIPAV.

To turn the log mode on

Because the log mode is on by default in MIPAV, the only reason for turning 
it on is if you previously turned it off. 

1 Select Help > MIPAV Options. The MIPAV Options dialog box 
(Figure 59) opens. Note that the check box for Log mode is blank.

2 Select Log mode. A check mark appears in the check box.

Figure 65.  Toolbars menu in the MIPAV window
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3 Click Apply. 

4 Click Close. When the Log mode is on, the log trail appears in the 
Output window (Figure 66) whenever you use an algorithm on an 
image.

To turn the log mode off

1 Select Help > MIPAV Options. The MIPAV Options dialog box 
(Figure 59) opens. 

2 Notice that a check mark appears in the Log mode check box.

3 Select Log mode. The check mark disappears, and the check box is 
blank.

4 Click Apply. 

5 Click Close.

Until you turn the log mode on again, the log trail does not appear in the 
Output window.

Placing or removing MIPAV from debug mode
You can track debugging information and error messages generated by 
MIPAV during a session by placing it in debug mode. If errors occur during 

Figure 66.  Output window showing the Log page
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the session, the program displays any error messages in the Output window 
on the Debug page. By default, the debug mode is off when you start the 
program.

Recommendation: The debugging information is primarily intended for 

MIPAV developers and not for users. The best course for users is to leave the 

debug mode Off.

PLACING MIPAV IN DEBUG MODE

To turn the log mode on

1 Select Help > MIPAV Options. The MIPAV Options dialog box 
(Figure 59) opens. Note that the initial value for Debugging output is 
Off.

2 Select the arrow in Debugging output to display the list of debugging 
modes and then select one of the five levels of severity for the debug 
mode. 

Note: The five debugging levels correlate to the amount of debugging 
information provided on the Debug page and the amount of computer memory 
used. Level 1 provides the least amount of debugging information, and level 5 
provides highest level of the debugging information. 

3 Click Apply.

4 Click Close. From this point on, MIPAV places debugging data on the 
Debug page in the Output window
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To turn the log mode off (remove MIPAV from debug 
mode)

1 Select Help > MIPAV Options. The MIPAV Options dialog box 
(Figure 59) opens. Note that the value for Debugging output may be 1, 2, 
3, 4, 5, or Off.

2 Select the arrow in Debugging output to display the list of options. 
Select Off. 

3 Click Apply.

4 Click Close.

When the debug mode is off, no error messages display on the Debug page 
in the Output window.

Managing memory resourcesMIPAV requires at least 35 Mb of random access memory (RAM). 
Additional memory is needed to correctly display image files and to quantify 
the data. To determine the amount of additional memory needed, multiply 
the size of the image file that you want to display by 10. Thus, if an image file 
is 2 Mb, you must allocate an additional 20 Mb of RAM (in addition to the 
base of 35 Mb) for it to display correctly. Because memory requirements 
fluctuate depending on the size and number of image files open, it may be 
necessary to allocate more memory during a session. 

Figure 67.  Output window showing the Debug page 
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As Java-based programs run, they often leave old variables, objects, or 
constructors in memory. For instance, if you delineate a VOI, the 
coordinates of the contours may remain in memory even after you close the 
image. Java provides a method called the garbage collector that clears all 
unnecessarily reserved memory. Generally, the software does this 
automatically when free memory becomes very limited. However, you can 
run the garbage collector at any time to free memory by clicking on the Free 
Memory button.

The first step is to view how much memory is currently being used and to 
free unnecessarily reserved memory. Then, if necessary, you may need to 
allocate additional memory.

To determine how much memory is currently being 
used by MIPAV

1 Select Help > Memory Usage in the MIPAV window. The Memory 
Monitor dialog box appears (Figure 68). 

When MIPAV performs a function, such as visualizing an image file, it 
uses memory. When the function completes (i.e., the visualized image 
closed), you manually free the memory so it can be used for another 
function.

The Memory Monitor dialog box shows how much memory is allocated 
and how much memory has been used. The vertical bar on the right of 
the window displays a pictorial representation of the ratio of allocated 
memory or amount of memory used. The chart shows the memory usage 
for the past 3 minutes and 45 seconds. The chart is updated every 
second.

If you want to constantly monitor your memory resources, you can leave 
the Memory Monitor dialog box open on your desktop. Otherwise, close 
it by clicking Close. 

2 Click Free memory to free memory.
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To allocate more memory

If you need to need more memory, you can allocate virtual memory or disk 
swap space if there is free space on your hard drive. For instructions on how 
to do this, refer to the documentation for your system. If you cannot assign 
more virtual memory or disk swap space, you may need to install additional 
memory.

If more than 100 Mb of physical memory, virtual memory, or disk swap 
space were allocated, then you must indicate the amount so that MIPAV can 
take full advantage of the additional memory. 

1 Select Help > Memory allocation in the MIPAV window. The Change 
Java.Runtime Memory Allocation dialog box (Figure 69) opens.

2 Change the maximum heap size number so that is reflects the maximum 
amount of memory that should be allocated. 

In a Microsoft Windows system, you can specify a maximum to 1.2 or 1.3 
Gb.  If additional memory is needed, MIPAV allocates it until the 
memory reaches the maximum heap size that you specify.

3 Click OK to close the dialog box.

Figure 68.  Memory Monitor dialog box
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Note: You must restart of MIPAV for the changes to take effect. To do this, select 
File > Exit - MIPAV in the MIPAV window to quit MIPAV. Then, restart MIPAV.

Developing and using plug-in programs
A plug-in program allows you to add customized functionality to MIPAV. 
Before you create a plug-in, you should have a strong understanding of the 
underlying structure of MIPAV’s software design and data structure. 
Because plug-ins are written in Java, you should also have a basic 
understanding of that programming language. After you create the plug-in, 
you must then install it. Once it is installed, you can access it from the Plug-
Ins menu in the MIPAV window. Plug-ins are addressed in Chapter 11 in the 
MIPAV User’s Guide.

Quitting MIPAV

To end a MIPAV session 

1 Select File > Exit-MIPAV. The MIPAV-Exit dialog box (Figure 70) 
appears asking if you really want to exit the program. 

2 Click Yes to end the session.

Figure 69.  Change Java-Runtime Memory Allocation dialog box
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Tip: You can also exit MIPAV by clicking on Close  at the top right of the MIPAV 
window.

Figure 70.  Exit Confirmation dialog box
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4 Understanding Image Basics
This chapter provides basic information about image file formats. 
Specifically, this chapter provides:

• An overview of graphic file formats and the formats that MIPAV 
supports (refer to “Supported graphic file formats” on page 93) 

• An explanation of the dimensionality and coordinate system used by 
MIPAV (refer to “Understanding the MIPAV dimensionality  
and coordinate system” on page 103) 

• The data types supported by MIPAV (refer to “Data types” on 
page 104) 

• An explanation of header offset information (refer to “Headers” on 
page 105)

• An explanation of endianness (refer to “Endianness” on page 105)

• Instructions on how to view and edit image attributes (refer to “Editing 
image attributes” on page 107)

Supported graphic file formats

MIPAV supports three categories of graphic file formats: vector (i.e., 
volume of interest, or VOI), bitmap (i.e., 2D to 5D grayscale or RGB 
images), and 3D images.
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Vector file formats 
Vector file formats are usually used to store line-based elements. These 
elements can be geometric shapes, such as polygons, curves, or splines. The 
data portion of the vector file contains a mathematical description of 
elements of an image with specific key points identified. A key point can be 
thought of as a node or vertex; it marks the place where the line changes 
direction. For example, a square may contain four key points while a circle 
may contain many more. 

In addition to key points, the vector file usually indicates the line segment’s 
starting point, direction, and length. In MIPAV you can create geometrically 
shaped contours to indicate VOIs. You can then store the VOIs in a vector 
formatted file. MIPAV can read and generate several vector-formatted file 
types including the MIPAV lookup table (LUT), MTX, Graphics Plot (PLT), 
and VOI.

Bitmap file formats
Bitmap file formats are usually used to store real-world graphics data, such 
as photographs or medical images such as CT scans. The data portion of 
bitmap files contains numerical data that indicates the color of each pixel or 
voxel in the image. The bitmap file may also indicate the bit depth, which 
indicates the number of colors that a pixel or voxel can represent. Typically, 
the bit depth can be 1, 2, 4, 8, 15, 16, 24, or 32. The number of colors 
represented is the square of the bit depth. Thus, a 4-bit image can contain 
16 colors; an 8-bit image can contain 64 colors; and so on. MIPAV can read 
and generate a number of bitmap formatted file types, such as Adobe 
Photoshop (PSD), Graphics Interchange File (GIF), Sun Raster (RS), 
Tagged Image File Format (TIFF), and Truevision Graphics Adapter (TGA).

Three-dimensional (3D) graphic file formats
MIPAV uses 3D graphic formatted files to store descriptions of the color 
and shape of 3D models of real-world and imaginary objects.
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Supported file formats

To support the wide range of image-processing needs of the NIH intramural 
research community, MIPAV reads and writes the image file types indicated 
in Table 2 on page 95. This table shows the formal name of the file format, 
the file extensions associated with the format, the numerical format, and 
whether MIPAV supports the encoding or decoding of the format. 

Table 2. Graphics file formats supported by MIPAV 

File format and 
extensions E D Supports Does not support

Adobe Photoshop 
(PSD)

Y Y Encoding of bitmap, grayscale, RGB, and index 
mode images. Also supports the encoding of RLE 
compression for all image variants.

Decoding of Adobe Photoshop v 2.5 images (and 
above) with the following modes: bitmap, 
grayscale, palette, and RGB. 

Alpha saving

Analyze Y Y TBD TBD

Audio Video 
Interleave (AVI)

Y Y Uncompressed

RLE8

TBD

Cheschire (IMG 
or IMC)

N Y TBD TBD

DICOM Y Y TBD TBD

Graphics 
Interchange File 
(GIF)

N Y Decoding of interlaced images and images with a 
transparency information set. 

Encoding of a GIF file

Decoding of 
multiframe GIFs using 
the multiframe load 
mechanism

Joint 
Photographics 
Experts Group 
(JPEG, JFIF, JFI, 
JPG)

Y Y TBD TBD

Medical Image 
NetCDF (MINC)

Y Y TBD TBD

MIPAV LUT Y Y TBD TBD

MIPAV MTX Y Y TBD TBD

MIPAV PLT Y Y TBD TBD

MIPAV VOI Y Y TBD TBD
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Microsoft 
Windows Bitmap 
(BMP, DIB)

Y Y Encoding of IndexColorModel images as 
uncompressed BMP palette formats. Other 
ColorModel images are encoded as 
uncompressed 24-bit BMP formatted files.

Decoding of BMP version 2.x through 4.x files. 
Also supports the encoding of OS/2 variant files. 
Supports the encoding of true color and palette 
images, as well as Run-Length Encoding 8 
(RLE8) and RLE4 images.

Decoding of old 
versions of BMP files 
(prior to version 2.x)

PC Paintbrush 
File Format (PCX, 
DCX, PCC)

Y Y Encoding of PCX files including uncompressed 
and RLE-compressed support.

Full support for decoding of PCX files.

N/A

PICT Y Y Encoding of black and white images as bitmap 
mode PICTs. Encodes grayscale images from 2 to 
8-bits as palette mode (PICT format does not 
have grayscale mode). Encodes palette images 
as palette mode PICTS, encodes other images as 
a 24-bit 3 component directed bits PICT.

Decoding of black and white and up to (and 
including) 32-bit color PICT images. Also 
supports the decoding of compressed PICT 
images.

N/A

Portable Network 
Graphic Format 
(PNG)

Y Y Encodes index images as palette PNG images. 
Also encodes grayscale formatted images (which 
include grayscale and direct color) with bit 
masks saved in grayscale file format. Direct color 
and RGB are encoded as RGB images with an 
alpha mask (if mask is available from the 
image). 16-bit depth images are truncated to 8-
bit depth when the image is loaded.

Decoding of palette, grayscale, and true color 
images. Also supports the transparency chunk 
for palette based images. 

Some extension 
chunks (such as 
ALPHA) 

Quick Time (QT) Y Y TBD TBD

RAW Y Y TBD TBD

Sun Raster (RS, 
RAS)

Y Y Encodes 8-bit index color images with or without 
RLE compression or RGB format for other color 
models.

Decoding of 4, 8, 16, 24, and 32-bit images. 
Supports the decoding of the old, standard, byte 
encoded, RGB, TIFF, and IFF format type.

Decoding of RAW 
colormap or 
experimental type 
images

Tag Image File 
Format (TIFF)

Y Y TBD Tiled

Table 2. Graphics file formats supported by MIPAV  (continued)

File format and 
extensions E D Supports Does not support
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Adobe Photoshop (PSD) files
PSD is a bitmap file format created by Adobe. It can accommodate images 
with an unlimited amount of colors. PSD files are not multiple image files; 
the maximum image size is 30K x 30K pixels or voxels. PSD files are 
generally used to store images that were altered or manipulated by the 
Adobe Photoshop software. The header is embedded in the file and is 26 
bytes in length. It contains information such as the height and width of the 
image and the color mode.

Analyze files
Analyze formatted files are generated by a UNIX-based, image-processing 
application developed at the Mayo Clinic. Analyze file format supports: 

• 1 bit (packed binary)

• 8 bit (8 bits per pixel or voxel [unsigned byte])

• 16 bit (16 bits per pixel or voxel [signed short])

• 32 bit (32 bits per pixel or voxel [signed integers, or floating point])

• 64 bit (64 bits per pixel or voxel [doubles, or complex])

• 24 bit (RGB, 8 bits per channel red, green, blue)
 

Truevision 
Graphics Adapter 
(TGA, VST, VDA, 
ICB, TPIC)

Y Y Encodes index color images in an uncompressed 
TGA palette format; encodes other images in an 
uncompressed 24-bit TGA format.

Decodes black and white, palette, true color 
uncompressed images. Decodes 16-bit, 24-bit, 
and 32-bit true color variants (can include 
loading of alpha channel).

N/A

X BitMap (XBM) Y Y Encoding of 2-color XBM images.

Fully supports the decoding of XBM formatted 
files.

N/A

X PixMap (XPM) Y Y Encoding of XPM palette images.

Fully supports the decoding of XPM formatted 
files.

Decoding of image 
files with 3 or more 
characters per pixel/
voxel

Table 2. Graphics file formats supported by MIPAV  (continued)

File format and 
extensions E D Supports Does not support
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Analyze images are formed from two files: 

• Header file—This file describes the image type, size, and other 
important image attributes.

• File Containing the Actual Image Data—This file can be interpreted as 
a raw file since it does not have any header information within the file.

These files have the same name and are distinguished by the extensions 
.hdr for the header file and .img for image file. For example, brain.hdr is the 
header file that describes the image file and brain.img is the file that 
contains the image data. In support of some NIH intramural researchers 
who have used Analyze in the past and have generated a large number of 
legacy datasets, MIPAV reads and writes Analyze formatted images.

Audio Video Interleave (AVI) files
AVI is the Microsoft Video for Windows standard. AVI is a form of the 
Resource Interchange File Format (RIFF). In this file format, video and 
audio data are stored consecutively in an AVI file. The AVI file contains a 4-
byte file header, followed by list information and then alternating video and 
audio streams. 

Digital Imaging and Communications in  
Medicine (DICOM) files

The DICOM format is a standard that defines a standard method of 
communication between two devices, such as computers, servers, or 
imaging devices. DICOM not only prescribes how to communicate with 
other imaging equipment and databases but also specifies how images are 
stored. Each image has accompanying header information describing the 
image format (i.e., height, width, etc.) as well as information that indirectly 
relates to the image (i.e., patient information, image equipment setup 
parameters).

Graphics Interchange Format (GIF) files
The Graphics Interchange Format (GIF) is a bitmap file format that was 
created by CompuServe. GIF is primarily an exchange and storage file 
format; GIFs can be used to store one or several bitmap images in one file. 
GIFs support pixel or voxel depths of 1 to 8 bits. The maximum image size is 
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64K x 64K pixel or voxels. There are two major revisions of the GIF format 
specification: GIF87a and GIF89a. Both formats begin with a 6-byte header 
that identifies the file format as GIF.

Joint Photographic Experts Group (JPEG/JFIF) files
The JPEG File Interchange Format (JFIF) allows files containing JPEG-
encoded data streams to be exchanged. Technically, JPEG refers to the 
compression type and the Joint Photographic Experts Group standards 
organization. However, the term JPEG is usually used to indicate the file 
format. JPEG file formats are bitmap files that are primarily used in image 
and graphics manipulation programs. Created by C-Cube Microsystems, the 
JPEG or JFIF file format does not accommodate multiple images per file 
and the maximum image size allowed is 64K by 64K pixel or voxels. JPEG 
files can accommodate 24-bit color images. Generally, JPEG header 
information appears between the Start of Image (SOI) and Application 
(APP0) markers.

Microsoft Windows Bitmap (BMP) files
BMP is a native bitmap format for the Microsoft Windows and OS/2 
platforms. Developed by the Microsoft Corporation, it can be read on Intel 
machines running Microsoft Windows, Windows XP, Windows NT, 
Windows 95, OS/2, and MS-DOS. It is an uncompressed file format with a 
maximum image size of 32K x 32K or 2G x 2G pixels or voxels (depending 
on the version of BMP). 

Depending on the version of BMP, for OS/2 the maximum image size is 
larger, 64K x 64K or 4G x 4G pixels or voxels. There are several versions of 
BMP for Microsoft Windows and OS/2. MIPAV supports Microsoft Window 
BMP versions 2.x and above and all OS/2 versions of the BMP file format. 
BMP version 2.x is designed for use with the Microsoft Windows 2.x 
platform. It has a 14-byte header (as does the OS/2 1.x bitmap header). It 
can accommodate images with 1-, 4-, 8-, or 24-bit colors. Version 3.x is 
designed for use with the Microsoft Windows 3.x and Windows NT 
platforms. Like version 2.x, it contains a 14-byte header. It also contains an 
additional bitmap header that is 40 bytes in size. The Microsoft Windows 
3.x platform version accommodates images with 1-, 4-, 8- or 24-bit colors. 
Windows NT and Windows XP accommodate 16- and 32-bit images. 
Version 4.x was designed for use with Microsoft Windows 95. It contains 
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the 14-byte header, and an additional 108-byte bitmap header. It can 
accommodate images of 1, 4, 8, 16, and 32 bits.

Medical Image NetCDF (MINC) files
MINC is a medical-imaging file format that is based on the Network 
Common Data Form (NetCDF) file format. NetCDF is a platform-
independent software interface that provides a means for storing named, 
multidimensional variables.   Each multidimensional variable is defined by 
a name, dimensions, and attributes. For example, cardio (name) [256, 256] 
(dimensions), and "long_name" where this attribute is a string that 
describes the content of the image. MINC provides a standard for 
dimension, variable, and attribute names suitable for medical imaging. 
MINC also provides convenience functions to complement the NetCDF 
interface and convenience functions for using MINC files.

MIPAV (LUT) files
LUT is a vector file format that is used to store lookup table data. A sample 
file appears in Appendix C.

MIPAV (MTX) files
A sample MTX file appears in Appendix C.

MIPAV (PLT) files
PLT is a vector file format that is used to store graphics data. A sample file 
appears in Appendix C.

MIPAV (VOI) files
VOI is a vector file format that is used to store volume of interest contouring 
information. A sample file appears in Appendix C.

PC Paintbrush (PCX) files
PC Paintbrush is a bitmap file format that is used primarily in Microsoft 
Windows and other Windows-based products. PCX is mainly used as an 
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exchange and storage format. Created by ZSoft and packaged with 
Microsoft Windows, PCX can accommodate 1-, 4-, 8-, and 24-bit color 
images. It is uncompressed; the maximum image size is 64K x 64K pixel/
voxels. Header information is embedded in the file; the first 128 pixel/
voxels in the file contain information such as the PCX ID number, the bits 
per pixel/voxel, and the palette type.

PICT: TBD files

Portable Network Graphic Format (PNG) files
PNG is a bitmap file format that is generally used to transmit and store 
network image data. The PNG format can store images with up to 16-bits 
(grayscale) or 48-bits (truecolor) per pixel/voxel. The maximum image size 
is 2G x 2G pixel/voxels. PNG is a compressed format. Multiple images 
cannot be stored in PNG. An 8-byte identification signature is followed by a 
header chunk, which contains basic information about the image data. The 
header chunk data area is 13 bytes in length.

Raw data files 
MIPAV supports reading and writing Raw image data of all the basic 
programming types (i.e., boolean, byte, short, etc.). Raw images have no 
header or a header of known length and unknown content at a fixed location 
at the beginning of the file. You must specify basic information about the 
Raw image before it is loaded in MIPAV. When loading a RAW data set, you 
must specify the image type, dimension and resolution, units, and header 
offset.

Sun Raster (RS) files
RS files is the native bitmap format for Sun Microsystems UNIX platforms 
that run the SunOS operating system. This format stores bitmapped data 
(color, grayscale, black and white) of any pixel/voxel depth. RS files can be 
of any size; however, multiple images per file are not supported. The header 
is embedded in the file; it is 32 bytes in the length and contains typical 
header information such as the width and height of the image and the type 
of color map used.
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Tag Image File Format (TIFF) files
TIFF is a bitmap file format that is generally used to provide a portable, 
image-storage mechanism that describes image data. Multiple images can 
be stored in one file. TIFF files can accommodate a maximum image size of 

232 –1 pixel/voxels. It is widely used and is a standard file format used in 
many desktop publishing, imaging, and paint programs. MIPAV supports 
most TIFF 6.0 formatted files used commonly in the image research 
community including 2D and 3D monochrome 8-bit, signed and unsigned 
16-bit, and signed 32-bit images. Future support of 24-bit color and 
compressed images is planned. The TIFF Image File Header (IFH) is 8 
bytes in length and contains 3 fields of information. If multiple images are 
in a file, an IFH is present for each image in the file.

Truevision Graphics Adapter (TGA) files
TGA is a bitmap file format that is often used in graphics, imaging, and 
paint applications that store up to 32-bit color images (8-, 16-, 24-, and 32-
bit colors are supported). Created by Truevision, Incorporated, it is an 
uncompressed file format that does not support multiple images per file. 
The maximum image size however, is unlimited. TGA’s header is 18 bytes in 
length and contains traditional header information including the depth of 
the color map entries.

X BitMap (XBM) files
XBM is a monochrome bitmap file format that is used primarily for the 
storage of icon and cursor bitmaps in X Windows. It was developed by X 
Consortium. Because this format was developed for small amounts of data, 
the bitmapped images are composed of collections of ASCII data rather 
than binary data. (XBM bitmap data is often found in C source header files.) 
Multiple images can be stored on a file; there is no limit to the image size. 
XBM has no header file, nor is a formal header embedded in the program; 
rather header information consists of four lines that begin with #define. 
The four lines of code indicate the height and width of the image and the 
coordinate of the hotspot (if any).
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X PixMap (XPM) files
XPM is a bitmap file format developed by Groupe Bull. It is used primarily 
to store X Windows pixmap information. XPM can store black and white, 
grayscale or color image data of unlimited colors. Like XBM, there is no 
limit for the image size and there can be multiple images per file. In 
addition, like XBM, XPM is written in ASCII. It can contain a section, 
<Values>, that contains header information, such as the height and width of 
the pixmap and the number of characters per pixel or voxel.

Understanding the MIPAV dimensionality  
and coordinate system

Internally, MIPAV is designed to store images of any dimensionality and 
thus is n dimensional. Figure 71 is a model of an example 3D-image where 
each position within the grid represents a voxel.

voxel—The smallest distinguishable cube-shaped part of a 3D-image. 

The voxel in the upper left-most position is considered the origin of the 
dataset. (A volumetric dataset is a set of cross-sectional images). Ideally, 
each voxel would be isotropic (i.e., cubic), but clinical datasets are often 
acquired in such a manner that the resolution in the x and y dimensions is 
greater than the resolution in the z dimension, thus producing rectangular 
voxels (elongated in the z direction). This voxel anisotropy is taken into 
account in the execution of the algorithms found in MIPAV.

Because MIPAV’s image storage buffer is n-dimensional, it can store 2D, 
3D, and 4D+ medical images. CT and MRI are examples of 3D medical 
images where the three dimensions (x, y, and z) are spatial dimensions. 
Other 3D datasets include fluoroscopy volumes, where the first two 
dimensions are spatial and the third dimension is time.
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Data types

A data type is the classification of a particular type of information. For 
example, a floating point data type indicates a number with a decimal point. 
Data read from image files are stored in MIPAV's data structures. MIPAV 
supports all the basic data types shown in Table 3and may in the future 
support more composite data types including color and complex numbers. 
The image data read from the file is stored in a data buffer of the same basic 
data type, preventing the reduction of image information that results from 
conversion into a fixed data type.

Figure 71.  Example of 3D image (origin at top left)
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Headers

If you attempt to open a raw image, you may need to supply MIPAV with the 
header offset. The header offset indicates the size of the space reserved at 
the beginning of the file where specific types of information is kept. This 
space, which is called the header, precedes the image data. If you know the 
length of the header, enter it in the header offset text box. When MIPAV 
accesses the file, it skips the header offset and begins to read the image data. 

Note: Not all image file formats have a header.

Endianness

Endianness refers to the byte ordering of the data. Some computers order 
the data with the least significant byte (LSB) first followed by the most 
significant byte (MSB). This byte order is referred as "little endian" or Intel 
byte ordering. machines that use little-endian byte ordering are VAXes, 
Intel x86, and Pentium. The reverse is MSB then LSB, which is referred as 
"big endian" or Motorola byte ordering. Machines that use big-endian byte 

Table 3. Data types supported by MIPAV

Data type Description

Boolean 1 bit per pixel/voxel (1 on, 0 off)

Signed byte 1 byte per pixel/voxel (-128, 127)

Unsigned byte 1 byte per pixel/voxel (0, 255)

Signed short 2 bytes per pixel/voxel (-32768, 32767)

Unsigned short 2 bytes per pixel/voxel (0, 65535)

Integer 4 bytes per pixel/voxel (-231, 231-1)

Long 8 bytes per pixel/voxel (-9.22E18, 9.22E18)

Float 4 bytes per pixel/voxel (-3.4E38, 3.4E38)

Double 8 bytes per pixel/voxel (-1.8E308, 1.8E308)

Color 32 3 bytes per pixel/voxel, plus 1 byte; 8 bits per color 
channel (alpha, red, green, and blue)
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ordering are IBM System 3D, RISC, and a Motorola 680x0. MIPAV is 
biendian; that is, it supports both big- and little-endian byte-ordering 
formats.

Viewing and editing image attributes

Information about the image appears in the Image Information dialog box 
and in the Image Attributes dialog box. 

The Image Attributes window displays the name of the image file and 
information about the resolution of the image. The About Image window 
displays more detailed information about the image, such as the orientation 
of the image or the number of bits per pixel or voxel. 

Viewing image attributes
To view the attributes of an image, select Image > Attributes > View Header 
in the MIPAV window. For DICOM datasets, the Image Information dialog 
box similar to the one shown in Figure 72a appears. For non-DICOM 
datasets, an Image Information dialog box similar to the one in Figure 72b 
appears.
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Editing image attributes
You can edit some of the image attributes for both DICOM datasets and 
non-DICOM datasets in the Image Attributes dialog box (Figure 73). The 

Figure 72.  Info dialog boxes for both DICOM and nonDICOM images
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Image Attributes dialog box includes five tabbed pages, which are the 
following:

• Name page—Displays the name of the image (without its extension, 
or suffix) and lists the image modality

• Resolutions page—Indicates the unit of measure for each dimension

• Orientations page—Lists the image orientations

• Dataset Origin—Lists the origin for the first image slice

• Transform Matrix—Displays and lists the values for the transform 
matrix

By default, the Name page always appears first when the Image Attributes 
opens. 

To modify the name of the image dataset

1 Open either a DICOM or nonDICOM image dataset.

2 Select Image > Attributes > Edit Attributes in the MIPAV window. The 
Image Attributes dialog box opens.

3 Select the name of the image in the Image name (without suffix) box.

4 Type a new name of the image. 

5 Click either Apply or OK. The new image name appears in the header on 
the image window.

Figure 73.  The Name page in the Image Attributes window
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To edit the dimensions and units of measure

1 Open either a DICOM or nonDICOM image dataset.

2 Select Image > Attributes > Edit Attributes in the MIPAV window. The 
Image Attributes dialog box opens.

3 Click Resolutions. The Resolutions page in the Image Attributes dialog 
box appears.

4 Type the changed values in the dimension text boxes on the left and 
then select the appropriate value in the Unit of measure boxes on the 
right.

5 Click either Apply or OK.
 

What’s the Difference Between
Clicking Apply or Clicking OK?

Click Apply when you want the dialog box or window to remain open after it 
makes the change so that you can make further modifications. If instead you 
click OK, the dialog box or window closes immediately after making the 
current change.

Figure 74.  The Resolutions page in the Image Attributes dialog box
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To edit the x, y, and z orientations of image datasets

1 Open either a DICOM or nonDICOM image dataset.

2 Select Image > Attributes > Edit Attributes in the MIPAV window. The 
Image Attributes dialog box opens.

3 Click Orientations. The Orientations page (Figure 75) in the Image 
Attributes dialog box opens.

4 Select the appropriate values in the boxes on the right.

5 Click Apply or OK.

To change the origin for the first image slice 

1 Open either a DICOM or nonDICOM image dataset.

2 Select Image > Attributes > Edit Attributes in the MIPAV window. The 
Image Attributes dialog box opens.

3 Click Dataset Origin. The Dataset Origin page (Figure 76) in the Image 
Attributes dialog box appears.

Figure 75.  Orientations page in the Image Attributes dialog box 
MIPAV User’s Guide, Volume 1, Basics 110

9/20/04 



M   I   P   A   V
M e d i c a l   I m a g e   P r o c e s s i n g, A n a l y s i s,   &   V i s u a l i z a t i o n

Chapter 4,  Understanding Image Basics
4 Type the appropriate values in the dimension boxes.

5 Click Apply or OK.

To change the transform matrix 

1 Open either a DICOM or nonDICOM image dataset.

2 Select Image > Attributes > Edit Attributes in the MIPAV window. The 
Image Attributes dialog box opens.

3 Click Transform Matrix. The Transform Matrix page (Figure 77) in the 
Image Attributes dialog box appears.

Figure 76.  Dataset Origin page in the Image Attributes dialog box
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4 Select the appropriate transform ID in the Transform ID box.

5 Load and save transform matrices.

6 Click Apply or OK.

Figure 77.  Transform Matrix page in the Image Attributes dialog box
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5 Working with DICOM Images
Digital Image Communication in Medicine (DICOM) defines a standard 
method of transmitting digital medical-image information between devices, 
such as computers, servers, or imaging equipment. The standard not only 
prescribes how to communicate with other imaging equipment and 
databases, but also how to store images.

This chapter discusses how MIPAV works with DICOM images and explains 
how to:

• Browsing DICOM images (“Browsing DICOM images” on page 115)

• Send and retrieve DICOM images (“Sending and retrieving DICOM 
images” on page 122), which includes the following tasks:

• Setting up a hosts table to indicate where you want to send images 
(“Setting up the hosts table” on page 125)

• Testing server connections (“Testing the connection” on page 135) 

• Posing queries and retrieving DICOM images (“Posing queries and 
retrieving images” on page 137 and “Receiving and sending image 
files” on page 141)

• Sending DICOM images to another device (“To send image files” on 
page 142)

• Edit DICOM tags (“Displaying and editing DICOM tag information” on 
page 144)
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• Protect patient privacy by removing DICOM tag information from 
images (“Displaying and editing DICOM tag information” on page 144)

• Convert image formats, such as Analyze or TIFF, to DICOM format 
(“Converting non-DICOM image files to DICOM format” on page 161)

Understanding how MIPAV works with DICOM 
images

You can use MIPAV to access images and information that were generated 
by DICOM-compatible imaging equipment. Some researchers at NIH use 
MIPAV to access DICOM-compatible archive systems, such as the Kodak 
Cemax-Icon Picture Archiving and Communication System (PACS), which 
includes the AutoRad devices located in the NIH clinical center. The PACS 
system consists of software, hardware, and networks. PACS provides the 
means for medical specialists to digitally acquire images, transmit the 
images and image-related data using a communications network, display 
and interpret images, and store and retrieve images. PACS also provides an 
interface to other systems that contain patient data.

Note: The DICOM standard is detailed in the 16-part documentation set Digital 
Imaging and Communications in Medicine (DICOM) Standard (refer to Appendix 
B, DICOM Conformance Statement.) MIPAV is DICOM version 3.0 compliant. 
Compliance information appears in Appendix B of this document.

Figure 78 diagrams the communication pathways between MIPAV, the 
internet, a DICOM-compatible server, a patient database, an imaging 
device, and a remote MIPAV workstation.

Digital images are acquired on a medical imaging device, such as a 
Computed Tomography (CT) scanner. The image can remain on the device 
or be transferred via a DICOM-compatible server to a patient database or 
other archive media. Once the image is acquired and stored, you can then 
use MIPAV to query and retrieve, receive, or send DICOM image files.
MIPAV User’s Guide, Volume 1, Basics 114

9/20/04 



M   I   P   A   V
M e d i c a l   I m a g e   P r o c e s s i n g, A n a l y s i s,   &   V i s u a l i z a t i o n

Chapter 5,  Working with DICOM Images
Browsing DICOM images

MIPAV includes a browser that is specifically designed for examining 
DICOM images. The DICOM browser allows you to view a list of all of the  
images in a dataset and quickly display each one individually. The browser 
provides a fast way of locating and selecting specific image slices.

Tip: You can open a DICOM browser at any time after starting MIPAV; and, 
depending on your computer’s memory resources, you can open more than one 
DICOM browser.

Figure 78.  Communication pathways between MIPAV and DICOM

Image
processing
and 
visualization

Image

Quer

Send

Receive

Imaging Workstation 
(MIPAV)

Image
processing
and 
visualization

Image

Quer

Send

Receive

Imaging Workstation 
(MIPAV)

Interne

DICOM Server

Image
Patient
databas

Images

Query

Send

Receive

Imaging Workstation 
(MIPAV)

Images

Query

Send

Receive

Imaging Workstation 
(MIPAV)

Internet

Images
Patient
database

Imaging device
MIPAV User’s Guide, Volume 1, Basics 115

9/20/04 



M   I   P   A   V
M e d i c a l   I m a g e   P r o c e s s i n g, A n a l y s i s,   &   V i s u a l i z a t i o n

Chapter 5,  Working with DICOM Images
To display an image dataset in the DICOM browser

1 Select File > DICOM browser (Figure 79). The Choose Directory dialog 
box (Figure 79) opens.

2 Select the directory in which the DICOM image datasets are stored.

3 Click Open. The DICOM browser (Figure 80) appears showing the 
directory tree in the panel on the upper left of the window.

4 Navigate, if necessary, to the correct subdirectory and select it.

5 Select Parse directory, . Information appears in the three panels on 
the right side of the window (Figure 81):  patient and study information 
at the top, dataset information in the middle, and image information at 
the bottom.

6 Select one of the images listed in the image information panel. The 
image appears in the panel on the left side of the window below the tree 
structure (Figure 81). 

Figure 79.  DICOM Browser command on the File menu (left) brings up 
the Choose Directory dialog box (right)
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Figure 80.  DICOM browser as it appears before parsing a directory
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Figure 81.  DICOM browser after parsing a directory and selecting an image to display
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Tip: You can select consecutive images by clicking the first image, pressing and 
holding down Shift, and then clicking the last image. To select nonconsecutive 
images, press and hold down Ctrl and then click each image

You can now continue to browse the images, or you can perform one or 
more of the following tasks:

• Adjust the image contrast and brightness

• Open selected images

• View another image dataset

• Create a movie from the image dataset

To adjust image contrast and brightness in the 
DICOM browser

The Window and Level sliders that appear in the left bottom panel of the 
DICOM browser allow you to adjust both the contrast and brightness in the 
image being displayed.

1 Select an image from the image listing in the DICOM browser.

2 Move the Window slider to the right to lessen contrast or to the left to  
intensify contrast.

3 Move the Level slider to the right to increase brightness or to the left to 
decrease brightness.

To open selected images in the image dataset in the 
DICOM browser

One of the advantages of using the DICOM browser is that you can quickly 
identify which images in the dataset you want to work with. Once you’ve 
determined the required images, you can open just the slices you selected.

1 Display an image dataset in the DICOM browser.

2 Browse through all of the images in the dataset to identify the slice 
numbers of the images.
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3 Select each of the appropriate slice numbers.

4 Select  , the Open selected images icon. MIPAV opens all of the slices  
in an image window. You can now use the Image Slice slider in the 
MIPAV window to view and work with each slice.

To view another image dataset in the DICOM browser

1 Click  , the New top directory icon. The Choose Directory dialog box 
opens.

2 Select the directory in which the other DICOM image dataset is stored.

3 Click Open. The DICOM browser appears showing the directory tree in 
the panel on the upper left of the window.

4 Navigate, if necessary, to the correct subdirectory and select it.

5 Select Parse directory, . Information about the new image dataset 
replaces the information about the previous dataset in the three panels 
on the right of the window.

To create a movie from the image dataset

1 Obtain and install, if you have not already done so, the following file 
from the Sun Java web site: 

 jmf-2_1_1e-windows-i586.exe 

Double-click the file to install it on your computer. This file installs the 
necessary file formats for creating movies.

2 Display an image dataset in the DICOM browser.

3 Browse through all of the images in the dataset to identify the slice 
numbers of the images you want to appear in the movie.

4 Select each of the appropriate slice numbers.

5 Select , the Extract image to AVI movies icon. The Set AVI Options 
dialog box (Figure 82) opens.

6 Specify whether to subsample the image by 1, 2, 3, or 4.
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7 Click OK. The Save dialog box opens.

8 Type a name for the movie in File Name.

9 Click Save. The Choose Type of AVI File dialog box (Figure 83) opens.

10 Select one of the methods of writing the file.

Subsample 
image

Subsamples each image dimension by a factor 
of 1, 2, 3, or 4.

Frame rate Specifies how many frames, or slices, should 
appear in 1 second.

OK Applies the parameters that you specified.

Cancel Disregards any changes you made in this dialog 
box, closes the dialog box, and does not save 
the file.

Help Displays online help for this dialog box.

Figure 82.  Set AVI Options dialog box  

Write file as Specifies the file format in which to save the 
movie. Choose one of the following:

• 24-bit uncompressed RGB
• 8-bit RLE with LUT
• Quicktime movie
• M-JPEG
• IR32
• IR41
• Indeo Video 5
• MS-MPEG4 V1

M-JPEG quality 
(0.1 - 1.0)

Specifies the level of quality, which may be from 0.1 to 1.0, in the M-JPEG file 
type. This box is only available if you selected M-JPEG in the Write file as box.

OK Applies the parameters that you specified.

Cancel Disregards any changes you made in this dialog box, closes the dialog box, and 
does not save the file.

Help Displays online help for this dialog box.

Figure 83.  Choose Type of AVI File dialog box
MIPAV User’s Guide, Volume 1, Basics 121

9/20/04 



M   I   P   A   V
M e d i c a l   I m a g e   P r o c e s s i n g, A n a l y s i s,   &   V i s u a l i z a t i o n

Chapter 5,  Working with DICOM Images
11 Type the value for the M-JPEG quality if you selected M-JPEG as the 
writing method.

12 Click OK. A pop-up window appears with the status. 

When the algorithm finishes running, the pop-up window closes. The 
movie is saved in the directory you specified, and, depending on the file 
format, the movie may appear in a new window. 

Sending and retrieving DICOM images

You can use MIPAV to query a DICOM-compatible archive or an imaging 
device that has, or is connected to, a DICOM server. A DICOM server is an 
application that processes DICOM query and retrieve requests. Because 
MIPAV is not equipped with a server, you cannot use this process to obtain 
DICOM files from another researcher who is also using MIPAV. You must 
use the receive process outlined in “Receiving and sending image files” on 
page 141 instead. You can then select images from the query results and 
store them on your hard drive or another destination.

Figure 84.  Quicktime movie—one of the eight file formats for making 
movies from DICOM images
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The tasks involved in sending and retrieving DICOM images include the 
following:

• Setting up the hosts table

• Testing server connections

• Posing queries and retrieving images

• Receiving and sending image files

To set up the hosts table and to query, retrieve, receive, and send DICOM 
files, you use the DICOM Communication Panel dialog box. To view this 
dialog box, select File > DICOM Database Access in the MIPAV window. 
The DICOM Communication Panel dialog box (Figure 85) opens.

This dialog box includes four tabbed pages:

• QR Client, which appears by default when the dialog box is first 
opened. Use this page to search for an image for a particular patient, 
physician, and time period.

• Send, which allows you to select the files to be sent to the DICOM 
imaging device, to select the specific imaging device from a list of 
available devices to which you want to send the files, and to send the 
files. This page also allows you to test the connection to the device that 
you selected.

• Hosts, which allows you to create a servers to which you are 
connected, edit the settings for servers, delete servers, and set the 
default server. It also allows you to create, edit, or delete storage 
destinations and set the default storage destination.

• Help, which provides instructions for setting up the hosts table and 
for sending and receiving images.

The following sections discuss these pages and explain in detail the contents 
of each page and how to use them.
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Figure 85.  The four pages in the DICOM Communication Panel dialog box
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Setting up the hosts table
Before creating queries or receiving and sending images, you must set up 
the hosts table, which is on the Hosts page (Figure 86) in the DICOM 
Communication Panel dialog box. The hosts table stores information 
(application entity [AE] title, alias, IP address, and port number) about the 
devices to which you want to connect. Conversely, your computer's 
connection information must be stored in the hosts table of the devices to 
which you want to connect.  Note that the title bar for the DICOM 
Communication Panel dialog box contains the internet protocol (IP) 
address for your workstation. 

internet protocol (IP) address: A numeric ID that is used to identify your 
computer on a Transmission Control Protocol/Internet Protocol (TCP/IP) network. 
An example of a TCP/IP network is the internet.

To display the Hosts page, select the Hosts tab in the dialog box. The Hosts 
page, shown in Figure 86, appears.

The Servers panel on the Hosts page includes fields that contain identifying 
information for the devices to which you want to connect. (Although the 
panel is named Server, you should create an entry for any type of device to 
which you want to connect.) The Storage Destination panel holds entries 
that indicate where you want images to stored once you retrieve or receive 
them.

The following sections explain how to:

• Create, edit, or delete entries in the Servers panel 

• Create, edit, or delete entries in the Storage Destination panel

CREATING, EDITING, AND DELETING SERVERS

You can create, edit, and delete entries in the Servers panel on the Hosts 
page (Figure 86). You must create an entry if you want to use MIPAV to 
query a server.
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Servers Default—Indicates that the device is the default. When you pose a query, data is 
sent to the default device.

AE Title—Lists the title of the device's DICOM application entity. The AE Title is 
often set by the device's system administrator. The hosts table associates the AE 
Title with the IP address. The AE Title can be 16 alphanumeric characters or less. 
Note that the AE Title is case sensitive.

Alias—Specifies the alternative name for the device. The alternative name can be 
up to 16 alphanumeric characters.

IP Address—Specifies the internet protocol address for the device. An IP address 
identifies a device on a Transmission Control Protocol/Internet Protocol (TCP/IP) 
network. (An example of a TCP/IP network is the internet.) The hosts table 
associates the IP address with the AE Title. IP addresses are written as four 
numbers separated by periods.

Figure 86.  Hosts page in the DICOM Communication Panel dialog box
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Before you begin, obtain the AE title, alias, IP address, and port number of 
the device to which you want to connect. The connection information for the 

Port—Identifies the port for the device's application program that you query, 
retrieve, receive, and send image files. A port is a logical connection endpoint that 
is the means that a program uses to identify a specific program running on a 
computer on a network (such as TCP/IP). 

Create Allows you to add a new DICOM server. When you click Create, the Create Server 
dialog box opens.

Edit Allows you to edit a currently listed DICOM server. When you select the server you 
want to modify and click this button, the Edit Server dialog box appears.

Delete Deletes the DICOM server from the list of servers. To delete a server, select the 
server and then click this button. A message appears asking you to confirm the 
deletion.

Set as default Allows you to select the server to be used as the default server. Select a server 
and then click this button. The check mark moves to the Default check box beside 
the server you selected.

Storage 
destination 

Default—Indicates, when selected, the default storage destination. When you 
retrieve or receive image data, it is stored in the default storage destination. 

AE Title—Lists the title of the DICOM application entity. If the storage destination 
is on your machine, the AE title is typically preceded by MIPAV_. An example of a 
valid AE title is MIPAVSMITH23. The AE Title can be 16 alphanumeric characters or 
less. Note that the AE Title is case sensitive. 

Alias—Specifies an alternative name for the storage destination. Alphanumeric 
characters are accepted.

Directory—Shows the full path name of the directory where images are stored. 
Alphanumeric characters are accepted.

Port—Identifies the port that your computer uses to receive images. By default, 
the port number is 3100.

Create Allows you to add a new storage location. When you click Create, the Create 
Storage Destination dialog box appears.

Edit Lets you modify a listed storage location. Select the location you want to modify 
and click this button. The Edit Storage Destination dialog box opens.

Delete Allow you to delete a listed storage location. To delete a storage location, select 
the location and then click this button. 

Set as default Allows you to select the storage location that is used by default. Select the 
location and click this button. The check mark moves from the current default 
location to the Default check box beside the location you selected.

Figure 86.  Hosts page in the DICOM Communication Panel dialog box (continued)
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NIH Kodak Cemax-Icon PACS appears when you click the Help tab. The 
Help page appears (Figure 87). You must also contact the administrator of 
the device (including the NIH Kodak Cemax-Icon PACS) so that your 
connection information can be stored in their hosts table as well. Once you 
have all of the information, you can create an entry in the hosts table entry.

Figure 87.  The Help page in the DICOM Communications Panel dialog 
box 
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To create servers in the Server panel

1 Click Create in the Servers panel on the Hosts page in the DICOM 
Communications Panel dialog box. The Create Server dialog box opens 
(Figure 88).

2 Type the required information in AE Title, Alias, IP Address, and Port 
(refer to Figure 86 for information on these fields).

3 Click OK when complete. The Create Server dialog box closes and the 
entry appears in the Servers panel.

To edit servers in the Servers panel

1 Select the server in the Servers panel that you want to edit.

2 Click Edit. The Edit Server dialog box opens. 

AE title Lists the title of the device's DICOM 
application entity. The AE Title is often set by 
the device's system administrator. The hosts 
table associates the AE Title with the IP 
address. The AE Title can be 16 alphanumeric 
characters or less. Note that the AE Title is 
case sensitive.

Alias Specifies the alternative name for the device. 
The alternative name can be up to 16 
alphanumeric characters.

Address Specifies the internet protocol (IP) address for the device. An IP address identifies a 
device on a Transmission Control Protocol/Internet Protocol (TCP/IP) network. (An 
example of a TCP/IP network is the internet.) The hosts table associates the IP address 
with the AE Title. IP addresses are written as four numbers separated by periods.

Port Identifies the port for the device's application program that you query, retrieve, receive, 
and send image files. A port is a logical connection endpoint that is the means that a 
program uses to identify a specific program running on a computer on a network (such 
as TCP/IP). 

OK Applies the parameters that you specified and creates a new server.

Cancel Disregards any changes you made in this dialog box, closes the dialog box, and does not 
create a server.

Help Displays online help for this dialog box.

Figure 88.  Create Server dialog box
MIPAV User’s Guide, Volume 1, Basics 129

9/20/04 



M   I   P   A   V
M e d i c a l   I m a g e   P r o c e s s i n g, A n a l y s i s,   &   V i s u a l i z a t i o n

Chapter 5,  Working with DICOM Images
3 Modify the information in AE Title, Alias, IP Address, and Port as 
required.

4 Click OK. The Edit Server dialog box closes, and the changed entry 
appears in the Server panel.

To delete servers

1 Select the server in the Servers panel that you want to delete.

2 Click Delete. The Confirm Delete message (Figure 90) opens.

3 Click Yes. MIPAV deletes the server from the Servers panel.

To select a default server

A default server is the server that is automatically selected when you first 
display the Hosts page of the DICOM Communications Panel dialog box. 
Unless you select another server as the default, it is the server to which 
MIPAV automatically sends images.

Figure 89.  Edit Server dialog box 

Figure 90.  Confirm Delete message
MIPAV User’s Guide, Volume 1, Basics 130

9/20/04 



M   I   P   A   V
M e d i c a l   I m a g e   P r o c e s s i n g, A n a l y s i s,   &   V i s u a l i z a t i o n

Chapter 5,  Working with DICOM Images
You can select the default server in either of the following ways: 

• Double-click the server that you want as the default server in the 
Server panel. 

• Select the server in the Servers panel that you want as the default 
server. The server is highlighted. Click Default.

A check mark moves from the check box for the previous default server to 
the Default check box beside the server you selected. 

CREATING, EDITING, AND DELETING STORAGE 
DESTINATION ENTRIES

You can create, edit, and delete storage destination entries in the Storage 
Destination panel of the Hosts tabbed window (Figure 92). The storage 
destination indicates where to store the image files you retrieve or receive. 
You must create at least one storage destination.

Figure 91.  Default server in the Servers panel on the Hosts page
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To create storage destinations

1 Click Create in the Storage Destination panel on the Hosts page in the 
DICOM Communications Panel dialog box. The Create Storage 
Destination window opens (Figure 93).

2 Type the required information in AE Title, Alias, Directory, and Port 
(refer to Figure 93 for information about these fields).

3 Click OK when complete. The Create Storage Destination dialog box 
closes. The new entry appears in the Storage Destination panel.

Figure 92.  Storage Destination panel

AE title Lists the title of the device's DICOM 
application entity. The AE Title is often set by 
the device's system administrator. The hosts 
table associates the AE Title with the IP 
address. The AE Title can be 16 alphanumeric 
characters or less. Note that the AE Title is 
case sensitive.

Alias Specifies the alternative name for the device. 
The alternative name can be up to 16 
alphanumeric characters.

Directory Shows the full path name of the directory where images are stored. Alphanumeric 
characters are accepted.

Figure 93.  Create Storage Destination dialog box
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To edit storage destinations

1 Select the storage destination in the Storage Destination panel that you 
want to change.

2 Click Edit. The Edit Storage Destination dialog box (Figure 94) opens.

3 Modify the information in AE Title, Alias, Directory, and Port as 
required.

4 Click OK when complete. The Edit Storage Destination dialog box 
closes. The modified information appears in the Storage Destination 
panel.

Port Identifies the port for the device's application program that you query, retrieve, 
receive, and send image files. A port is a logical connection endpoint that is the means 
that a program uses to identify a specific program running on a computer on a network 
(such as TCP/IP). 

OK Applies the parameters that you specified and creates a new server.

Cancel Disregards any changes you made in this dialog box, closes the dialog box, and does 
not create a server.

Help Displays online help for this dialog box.

Figure 93.  Create Storage Destination dialog box (continued)

Figure 94.  Edit Storage Destination dialog box
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To delete storage destinations

1 Select the storage destination in the Storage Destination panel that you 
want to delete.

2 Click Delete. A Confirm Delete message opens (Figure 95).

3 Click Yes. MIPAV deletes the storage destination from the Storage 
Destination panel.

To select a default storage destination

A default storage destination is the one that is automatically selected when 
you initially display the Hosts page of the DICOM Communications Panel 
dialog box. Unless you select another storage destination as the default, 
MIPAV automatically stores images in this location. 

You can select the default storage destination in either of the following 
ways: 

• Double-click the entry that you want as the default storage destination 
in the Storage Destination panel. 

• Select the entry in the Storage Destination panel that you want as the 
default storage destination. The server is highlighted. Click Default.

A check mark moves from the check box for the previous default storage 
destination to the Default check box beside the storage destination you 
selected.

Figure 95.  Confirm Delete message
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Testing the connection

Before querying, retrieving, or sending images, you may want to test the 
connection between your machine and the device that you want to receive 
the images. 

To test the connection

1 Click Send in the DICOM Communication Panel dialog box. The Send 
page (Figure 85 and Figure 96) appears.

2 Select the pathway you want to test by selecting the destination from the 
drop-down list near the center of the Send tabbed window. The 
destinations are the entries from the Servers panel in the Hosts tabbed 
window.

3 Click Test connection.

4 If there is a problem, connection failure messages appear in the Send 
status panel as shown in Figure 96.

To resolve connection errors

Do the following:

• Make sure the AE Title, Alias, IP Address, and Port number for the 
device are entered correctly in your hosts table.

• Contact your system administrator for the device to which you want to 
send the images. Make sure your AE Title, Alias, IP Address, and Port 
number was correctly added to the hosts table for that device.

• If you are attempting to send images to another MIPAV machine, make 
sure that the receiver in the other MIPAV application is turned on. To 
turn on the receiver, ask them to select File > DICOM Receiver On/Off 
in the MIPAV window.
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Figure 96.  Error message in the Send status panel on the Send page
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Posing queries and retrieving images

Use the QR Client page (Figure 97) in the DICOM Communication Panel 
dialog box to query a DICOM-compatible server, or device, and then 
retrieve files from the query results.

Note: Before you begin, make sure your hosts table has the name of the device 
you want to query or from which you want to receive images. Conversely, your 
computer's connection information should also be in the other device's hosts 
table. For more information on setting up a hosts table, see “Setting up the hosts 
table” on page 125

To pose queries

1 Click QR Client in the DICOM Communication Panel dialog box. The 
QR Client page appears (Figure 97).

2 Construct your query by completing the fields in the Patient Query 
Information and Query Duration panels. As you fill in the information, 
keep the following in mind:

• You must specify at least one of the following: patient name, patient 
ID, study number, or physician.

• If the exact name, ID, or study number is not known, you can use the 
asterisk as a wildcard character. For example, if you type *o*ston in 
the patient name field, all names that match this pattern, such as 
Houston or Johnston, appear in the result.

3 Click Send Query.

The query result appears in the Query Result panel. To retrieve images, 
go to “To retrieve images” on page 140.

To erase the query

To erase the query and start again, click Clear in the Patient Query 
Information panel.
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Patient Query Information

Patient Name Indicates the full name of the patient. Alphanumeric characters are 
accepted. You can use an asterisk as a wild card character.

Patient ID Indicates the primary hospital identification number or code for the 
patient. Numeric characters are accepted.

Study Number Displays the user- or equipment-generated study identifier.

Physician Indicates the physician(s) responsible for patient care at the time of 
the study.

Query Duration

Query Duration Displays the time period the query covers.

Start Date Indicates the date when medical specialist began acquiring study 
information.

Figure 97.  QR Client page in the DICOM Communication Panel dialog box
MIPAV User’s Guide, Volume 1, Basics 138

9/20/04 



M   I   P   A   V
M e d i c a l   I m a g e   P r o c e s s i n g, A n a l y s i s,   &   V i s u a l i z a t i o n

Chapter 5,  Working with DICOM Images
To view information at different levels

You can view information at the patient, study, series, or image level. To go 
up or down a level, click Up or Down. Note that the level that is currently 
displayed appears at the left of the Up and Down buttons.

To sort the query result list

Click Pat (patient), Pat ID (patient ID), or Referring Physician in the Query 
Result panel. The query result list is sorted in ascending order based on the 
column you chose. 

If you click the column title a second time, the list is resorted, this time in 
descending order, but again based on the title you chose.

End Date Indicates the date when medical specialist completed the acquisition 
of study information.

Today’s Date Displays the current date.

Query Result

Pat. Name Patient Name. Indicates the full name of the patient. You cannot edit 
this field; it is read-only.

Pat. ID Patient Identification. Displays the primary hospital identification 
number or code for the patient. You cannot edit this field; it is read-
only.

Referring Physician Indicates the name of the physician who referred the patient. You 
cannot edit this field; it is read-only.

Query Retrieval Information

Status Provides an update of the query retrieval process. 

# Indicates the image number that is currently being retrieved.

Source Indicates the DICOM server from which the images are being 
retrieved.

Destination Indicates where the image is stored (storage destination).

Error Indicates whether an error has occurred.

ID Displays the unique ID that is assigned to each query.

Figure 97.  QR Client page in the DICOM Communication Panel dialog box (continued)
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To retrieve images

After you pose a query and receive the results, you can select the files that 
you want to retrieve from the list of query results. 

1 Turn on the DICOM receiver if you have not already done so. 

To turn on the receiver, click File > DICOM Receiver On/Off in the 
MIPAV window. A check mark appears next to the option.

2 Select the images you want to copy from the Query Result panel on the 
QR Client page.

3 Click Retrieve Image in the Patient Query Information panel to copy the 
images to the default storage destination indicated in the hosts table. 

If you need to check the default storage destination: 

a Click Hosts to display the Hosts page

b View the storage destinations in the Storage Destination panel

c Click QR Client to return to the QR Client page.

As the images are copied, status information appears in the Query 
Retrieval Information panel. 

Note: If you have problems connecting to the device, you may want to test the 
connection. See Section “Testing the connection” on page 135 for details.

To sort the query retrieval information

To sort the information in the Query Retrieval Information panel, you can 
click Status, #, Source, Destination, Error, or ID.

To cancel the retrieval

Click Cancel in the Query Retrieval Information panel.
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Receiving and sending image files

When you receive image files, you do not pose a query or retrieve files from 
a list; you passively receive the images that are sent to you from another 
device. You can receive images from any device, including a computer 
running another copy of MIPAV, if your DICOM Receiver is turned on and 
the appropriate connection information was entered in the hosts table.

You can send DICOM images to DICOM-compatible servers, imaging 
equipment, or to other MIPAV applications that are up and running. Only a 
copy of the image files are sent. the original files remain in your source 
directory.

To receive image files

1 Turn on the DICOM receiver if you have not already done so. 

To turn on the receiver, click File > DICOM Receiver On/Off in the 
MIPAV window. A check mark appears next to the command.

2 Click Hosts. The Hosts page appears.

3 Make sure that the device that is sending the images has an entry in the 
Servers panel. (Conversely, your connection information should be in 
their hosts table.)

4 Make sure that the default storage destination in the Storage 
Destination panel is the location where you want to store the images.

5 Wait until the images are sent to you. After the images are sent, you can 
turn off the DICOM receiver by clicking File > DICOM Receiver On/Off 
in the MIPAV window. 

Figure 98.  DICOM Receiver On/Off command on the File menu in 
the MIPAV window 
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To send image files

1 Click Send. The Send page (Figure 99) appears. 

2 Verify that the directory listed in Source directory is the directory in 
which the image files you want to send are located.

If it is the correct directory, the image files that you want to send 
appear in the Listing panel.

If it is not the correct directory, do either of the following:

• Click Browse to navigate to the correct directory. 

• Type the full path of the directory in Source directory. Click Up 
Directory to view the parent directory.

Figure 99.  Send page in the DICOM Communications Panel dialog box  
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3 Select the destination to which you want to send the image files in 
Destination.

Note: The destinations reflect the entries in the Server panel on the Hosts page. 
If the destination does not appear in Destination, you need to create a new 
server in the Server panel on the Hosts page. For instructions, refer to “Setting 
up the hosts table” on page 125.

4 Select the images you want to send in the Listing panel.

Tip: To select more than one image file, hold down the <CTRL> or <SHIFT> 
key while you click the files you want to send.

5 Click Send Images to transmit copies of the selected images. Status 
messages that appraise you of the status of the send process appear in 
the Send status panel.

Source directory Indicates the full path name for the directory where the image files you want to 
send are kept. To change the source directory, use Browse or Up directory. 

Browse Allows you to navigate to the directory for the images you want to send. When 
you click this button, the Open dialog box appears.

Up directory Moves to the parent directory of the directory shown in Source Directory.

Refresh dir. Updates the image files shown in the Listing panel 

Listing panel Displays a read-only list of the image files in the source directory. 

Destination Indicates where the image files should be sent. Destinations in the drop down 
menu are the same as those listed in the hosts table (Server panel).

Send Images Transmits copies of the selected image files to the destination indicated in 
Destination.

Test connection Tests the connection between your server, or device, and the receiving or 
sending device.

Send status Displays messages about the send process, such as whether it was completed 
successfully.

Clear Erases all messages from the Send status panel.

Figure 99.  Send page in the DICOM Communications Panel dialog box (continued) 
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Displaying and editing DICOM tag information

Once an image file is copied to the storage destination (usually your hard 
drive or a local device such as a zip drive), you can view and edit the 
information stored in the DICOM tags. As an option, you can display any of 
the DICOM tags as an overlay on the image, selecting the specific tags to 
display.

You can also use MIPAV’s anonymize feature to protect patient 
confidentiality. The anonymize feature allows you to delete information 
from selected DICOM tags in a single step from one image or from a whole 
directory of images.

To display the DICOM tags in an overlay over the 
image

1 Open a DICOM image in an image window.

Note: You can open a DICOM image file as you would any other image file. Refer 
to Chapter 3 for more details.

2 Select Image > Show Image/DICOM Overlay (if it is not already 
selected) in the MIPAV window. The image window opens with the 
DICOM information overlaying the image (Figure 100).

I

Figure 100.  Image with DICOM overlay
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To choose which DICOM tags appear in the overlay

You may want only particular DICOM tags to appear in the overlay and at a 
specific spot in the overlay.

1 Open a DICOM image in an image window.

2 Select Image > Show Image/DICOM Overlay (if it is not already 
selected) in the MIPAV window. The image window opens with the 
DICOM information overlaying the image.

3 Select Image > DICOM Overlay Options. The DICOM Overlay Options 
dialog box (Figure 101) opens.

4 Decide where you want to display the DICOM tags—in the upper left 
corner, lower left corner, upper right corner, or lower right corner of the 
image.

 

Upper left 
corner buttons

Specifies the DICOM tags you want to display in the 
upper left corner of the image. You can display from 
1 to 4 DICOM tags.

Figure 101.  DICOM Overlay Options dialog box
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5 Select a button under the Upper left corner, Lower left corner, Upper 
right corner, or Lower right corner panel as appropriate. The Select 
DICOM Tag for Overlay dialog box (Figure 102) opens.

Lower left 
corner buttons

Specifies the DICOM tags you want to display in the 
lower left corner of the image. You can display from 
1 to 4 DICOM tags.

Upper right 
corner buttons

Specifies the DICOM tags you want to display in the 
upper right corner of the image. You can display 
from 1 to 4 DICOM tags.

Lower right 
corner buttons

Specifies the DICOM tags you want to display in the 
lower right corner of the image. You can display 
from 1 to 4 DICOM tags.

OK Displays the tag you selected on the button in the 
DICOM Overlay Options dialog box.

Cancel Disregards any changes that you made in this dialog 
box and closes the dialog box.

Help Displays online help for this dialog box.

Figure 101.  DICOM Overlay Options dialog box (continued)
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6 Select the DICOM tag that you want to display in the overlay.

7 Click OK. The Select DICOM Tag for Overlay dialog box closes, and the 
selected DICOM tags and names appears on the buttons in the panel on 
the DICOM Overlay Options dialog box (Figure 103).

Tag Lists each DICOM tag beside its name.

Name Lists each DICOM name for the tag.

OK Displays the tag you selected on the button in the DICOM 
Overlay Options dialog box.

Cancel Disregards any changes that you made in this dialog box and 
closes the dialog box.

Help Displays online help for this dialog box.

Figure 102.  Select DICOM Tag for Overlay dialog box  
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8 Click OK. The DICOM Overlay Options dialog box closes. The tags you 
selected appear on the overlay on the image.

Tip: If you decide that you do not want the tag to display on the overlay, 
simply select the button in the DICOM Overlay Options dialog box and select 
[Blank Overlay] at the top of the Select DICOM Tag for Overlay dialog box.

To remove the DICOM tag overlay from the image

Show Image/DICOM Overlay is a toggle command. You click the command 
to turn it on or to turn if off. A check mark appears in the check box beside 
the command if it is on. To remove the DICOM tag overlay from the image, 
simply select Image > Show Image/DICOM Overlay to turn it off.

To edit DICOM tag information

You can edit the information contained in the DICOM tags.

1 Open a DICOM image.

2  Click Image > Attributes > View Header. 

Figure 103.  Selected DICOM tags on buttons in the panel you chose
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The Info dialog box opens   (Figure 105).

Figure 104.  Attributes > View header commands on the Image menu in 
the MIPAV window

Tag column Lists the DICOM tags.

Name column Lists the name of the DICOM tags.

Value column Lists the value assigned to each DICOM tag.

Show private tags

Close Closes the dialog box.

Save tags Saves the values of the tags that were changed.

Edit tag Allows you to make changes to the values for the tags.

Anonymize Anonymizes the image. 

Figure 105.  Info dialog box (DICOM)
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3 Click Edit Tag. The Edit Tag dialog box appears (Figure 106).

4 Type the new value for the tag in New tag value.

Note: You cannot edit the following tags in the Info window: Dimension, Type, 
Min, Max, Orientation, Pixel Resolution, Unit of Measure, and Transformation 
Matrix. The Dimension and Unit of Measure tags are edited in the Image 
Attributes window.

To apply the new tag value to all of the slices in the image dataset, click 
Apply this change to all slices in image.

5 Click OK. The tag information is changed.

Protecting patient privacy using Anonymize

MIPAV’s anonymize feature allows you to remove information from a 
selected subset of DICOM tags. The tags in this subset are those indicated in 
DICOM Supplement 55: Attribute Level Confidentiality. These tags 
include, but are not limited to, the patient's name, ID, birth date, sex, ethnic 
group, referring physician, age, size, weight, and occupation.

To anonymize the current DICOM image

1 Open a DICOM image.

2 Click Image > Attributes > View Header in the MIPAV window. The Info 
dialog box opens.

Figure 106.  Edit Tag dialog box for MR acquisition type tag
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3 Click Anonymize.  

The Anonymize Sensitive Info window appears (Figure 107).

4 Select the tags you want to anonymize. 

• To select all of the tags, click Select all. 

• To remove all of the check marks from the check boxes, click Clear.

The tags that are dimmed (appear grayed) are not included in the 
DICOM image file.

Figure 107.  Anonymize sensitive info dialog box
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5 Click OK. A confirmation message appears (Figure 108).

6 Click OK. 

The information in each specified tag is deleted from the image file. 
Although the information in these tags are cleared, the tags remain in 
the image file.

Note: The lists of tags in the Info dialog box does not update right away. Also, 
the name of the displayed image on the title bar is not saved into the file.

To anonymize any image dataset

You can use the Anonymize command to anonymize several image series at 
one time.

1 Select File > Anonymize DICOM directory. The Choose Directory dialog 
box opens.

 

2 Select a starting or root directory, which is a starting point for the 
selection. You can then select the image directories to anonymize.

Figure 108.  Confirm for Anonymize message 

Figure 109.  Anonymize DICOM Directory command on the File menu in 
the MIPAV window
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Note: This function can recursively anonymize images in subdirectories of the 
root directory.

3 Click Open. The Anonymize DICOM Directory window opens.

File New directory—Allows you to select a new root directory to anonymize.

Renew list—Refreshes the file listing in Image source directory.

Dialog Entries Clear Log Window—Removes all of the log messages from the Logging 
page. 

Image source 
directory

Specifies the root directory to be anonymized.

Image destination 
directory

Specifies the root directory where the anonymized images should be stored.

Browse Allows you to select a new image destination directory.

Translation/key 
file destination 
directory

Specifies the directory where the translation file is kept. The key file 
“patient.key.doc” is a text-formatted file that contains the name of the old 
file and its new name.

Browse Allows you to select a new translation file directory.

Figure 110.  Directory page in the Anonymize DICOM Directory window
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4 Click Open. The Anonymize DICOM Directory window opens.

The Anonymize DICOM window includes three tabbed pages: 

• Directory page—Allows you to select which images to process and 
where to place the output. This page is the page that is displayed 
when this window opens.

• Tag Options page—Allows you to select DICOM tags to remove 
from images and how to name anonymized images, which becomes 
a name tag. 

• Logging page—Displays the current progress of the 
anonymization.

5 Click File > New Directory (Figure 111).

The Choose Directory dialog box opens.

Recursive 
anonymization

Processes images in the selected directory as well as any DICOM images in 
any subdirectories.

Directory name 
anonymization

Selected directory—Anonymizes the name of only the selected directory on 
the top level.

Subdirectory—Anonymizes the name of only the subdirectories.

No directory name change—Does not change the name of the directories.

Run Starts the process of anonymizing the images. Status messages appear on 
the Logging page.

Close Closes this dialog box.

Stop Stop the process of anonymizing the images.

Help Displays online help for this dialog box.

Figure 110.  Directory page in the Anonymize DICOM Directory window (continued)

Figure 111.  New directory command on the File menu in the Anonymize 
DICOM window
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6 Select one or more source directories to anonymize.

The directories may be as deeply nested as needed. You may select 
directories on different levels; however, do not select a directory nested 
within another selected directory.

7 Click Open. The directory listed in Image source directory changes to 
the display the directory or directories you chose. 

8 Select Recursive anonymization if you want to process directories 
recursively. 

Note: When this check box is selected, MIPAV processes images in the selected 
directory as well any DICOM images in any subdirectories. When this check box 
is clear, MIPAV only processes the images in the directory that is selected, 
regardless of any subdirectories.

9 Select one of the following:

• Selected directory

• Subdirectory

• No directory name change

Figure 112.  Choose Directory dialog box
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10 Click Browse beside Image destination directory. The Select Destination 
Directory dialog box opens.

11 Select a destination directory.

Example: The number of image directories chosen affect precisely where the 
processed images are stored. When one directory is chosen as the source in 
step 6, all anonymized DICOM files are placed directly in the chosen destination 
directory. However, selecting more than one source directory in step 6, the 
anonymized DICOM files are placed into subdirectories of the Destination 
directory (refer to the following table). 

Note: The name of the anonymized files depend on the anonymous name, which 
is set later.

12 Click Select. The directory you selected appears in the Image destination 
directory box. It also replaces the name in the Translation/Key file 
destination directory box.

13 Decide where to store the translation/key file.

translation/key file—Records the original names in the files and correlates 
them to the new anonymous names. The name of the key file is patient.key.doc.

By default, the translation/key file is kept in the same directory as the 
images; however, if this is undesirable, you may choose a new location 
for the file. If you decide to change the location, go to the next step. If 
you decide against changing the location, go to step 17.

14 Click Browse beside Translation/Key file destination directory if you 
want to select another destination for the translation/key file. The Select 
Destination Directory dialog box (Figure 113) opens.

15 Select a directory.

If you select . . . Then files are placed in . . .

Source directories /images/a 

/images/b

/destination/a

/destination/b

Destination directory /destination
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16 Click Select. The new destination appears in the Translation/Key File 
destination directory box.

17 Click Tag Options to display the Tag Options page (Figure 114).

The directory selection process on the Directory page provides the 
images to anonymize and the location of where to put them when done. 
However, it does not select what to remove from the images or what 
information to call the images when done. This is the goal of the Tag 
Options page. It allows you to choose the tags to remove from the 
images being processed and it gives you the opportunity to give an easily 
remembered name to the destination images.

Figure 113.  Select Destination Directory dialog box
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18 Select the DICOM tags you want to anonymize. 

Check the fields to 
anonymize

Allows you to anonymize only the specific tags that you select. You can select 
only one tag or as many as needed.

Select all Specifies that you want to anonymize all of the tags listed. When you select 
this button, MIPAV places a check mark in each of the check boxes.

Clear Removes the check marks from all of the check boxes.

Anonymized 
names

Anonymous name—Specifies a first part of the name assigned to the image 
files. MIPAV uses a combination of this name and the sequence number 
specified in Sequence beginning.

Sequence beginning—Indicates the starting number for the series of image 
files. The default number is 0.

Run Starts the process of anonymizing the images. Status messages appear on 
the Logging page.

Close Closes this dialog box.

Stop Stop the process of anonymizing the images.

Help Displays online help for this dialog box.

Figure 114.  Tag Options page in the Anonymize DICOM Directory window
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To select all of the tags, click Select all. 

To remove all of the tags, click Clear.
T

19 Type the anonymous name for the image files in Anonymous name. 

By default, a preset random value appears in Anonymous name, but you 
can replace this value with a more familiar name.

20 Type a value in Sequence beginning. 

When more than one image source directory is chosen, the sequence 
beginning number affects the name of the image file. The first image set 
is given the sequence number; the next image is given a number one 
higher. 

Example: The first image set is titled d0884_0. The second image set was 
chosen to be anonymized at the same time, it would be saved d0884_1.

21 Click Directory to return to the Directory page.

22 Select the directories in the Image source directory table that you want 
to anonymize.

23 Click Run. MIPAV displays the Logging page (Figure 115), where it 
displays messages about each of the images being processed until they 
are all processed.

To stop the process, click Stop.

To close the Anonymize DICOM Directory window after all images are 
processed, click Close.
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Figure 115.  The Logging page in the Anonymize DICOM Directory window 
listing processing messages and MIPAV removes tags
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Converting non-DICOM image files to DICOM 
format

You can convert a non-DICOM file, such as a TIFF or Analyze file, to 
DICOM format.

To convert a non-DICOM image file to DICOM

1 Open a non-DICOM image.

2 Click File > Save Image As in the MIPAV window. The Save window 
appears.

3 Select the directory where you want to store the dataset. 

Tip: If you are converting an image dataset that has more than one file, you 
may want to save the files to a new folder. To do this, select Create New 
Folder at the top right of the dialog box.

4 Type the name of the file, including the file extension of .dcm in File 
Name.

5 Click Save. The Attributes to Save dialog box appears. 

You need to enter DICOM tag information in this dialog box, which has 
the following four pages:

• Required page (Figure 116)

• Patient page (Figure 117)

• Study page (Figure 118)

• Series page (Figure 119)

6 Enter the required information on the Required page (Figure 116).

Although the fields on the Patient, Study, and Series pages are optional, 
you must furnish all of the information on the Required page before you 
can convert the file.

7 Enter the information, if desired, on the Patient, Study, and Series pages 
(Figure 117, Figure 118, and Figure 119).
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Study Instance UID 
(0020,000D)

Unique identifier for the study. Only numeric characters with 
optional periods are allowed.

Modality (0008,0060) Type of equipment that was used to acquire the data used to 
create the images in the dataset. Options are: Biomagnetic 
Imaging, Color Flow Doppler, Computed Tomography, Duplex 
Doppler, Computed Radiography, Diaphanography, Digital 
Radiography, Endoscopy, General Microscopy, Hard Copy, 
Intraoral Radiography, Laser Surface Scan, MR Angiography, 
Mammography, Magnetic Resonance, MR Spectroscopy, 
Nuclear Medicine, Other, PET, Panoramic X Ray, Radio 
Fluoroscopy, Radiographic Imaging, Radiotherapy Dose, 
Radiotherapy Image, Radiotherapy Record, Radiotherapy 
Structure, Slide Microscopy, SPECT, Thermography, 
Ultrasound, X Ray Angiography, and External Photography.

Series Instance UID 
(0020,000E)

Unique identifier for the study. Only numeric characters (with 
optional periods) are allowed.

OK Applies the tags that you specified and closes this dialog box.

Cancel Disregards any changes you made in this dialog box, closes 
the dialog box, and does not apply any of the tags.

Help Displays online help for this dialog box.

Fill tags Allows you to specify a file that contains the DICOM tags. 
When you select this button, the Open Tags File dialog box 
appears.

Figure 116.  Required page in the Attributes to Save dialog box
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Patient’s Name (0010,0010) Patient's full name.

Patient’s Birth Date 
(0010,0030)

Date of patient's birth.

Patient’s Birth Time 
(0010,0032)

Time of patient's birth.

Other Patient Names 
(0010,1001)

Other names used to identify the patient.

Patient Comments (0010,4000) User-defined comments about the patient.

Patient ID (0010,0020) Primary hospital identification number or code used to identify 
the patient.

Patient’s Sex (0010,0040) Gender of the patient. Options are: Unknown, Male, Female, 
and Other.

Other Patient IDs (0010,1000) Other IDs used to identify the patient.

Ethnic Group (0010,2160) Ethnic group or race of the patient.

Patient Orientation 
(0020,0020)

Patient direction of the rows and columns of the image. 

OK Applies the tags that you specified and closes this dialog box.

Cancel Disregards any changes you made in this dialog box, closes the 
dialog box, and does not apply any of the tags.

Help Displays online help for this dialog box.

Fill tags Allows you to specify a file that contains the DICOM tags. When 
you select this button, the Open Tags File dialog box appears.

Figure 117.  Patient page in the Attributes to Save dialog box 
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Study ID (0020,0010) User- or equipment-generated study identifier. 

Study Time (0008,0030) Time the study started.

Study Description 
(0008,1030)

Institute-generated description or classification of the study 
(component) performed.

Physician(s) of Record 
(0008,1048)

Physician responsible for the overall patient care at the time of 
the study.

Admitting Diagnoses 
Description (0008,1080)

Description of the admitting diagnoses.

Patient's Size (0010,1020) Length or size of the patient in meters.

Occupation (0010,2180) Occupation of the patient.

Study Date (0008,0020) Date the study started.

Accession Number 
(0008,0050)

An RIS-generated number which identifies the order for the 
study.

Referring Physician's Name 
(0008,0090)

Patient's referring physician.

Physician(s) Reading Study 
(0008,1060)

Physician(s) reading the study.

Patient's Age (0010,1010) Age of the patient.

Patient's Weight (0010,1030) Weight of the patient, in kilograms.

Additional Patient's History 
(0010,21B0)

Additional information about the patient's history.

Figure 118.  Study page in the Attributes to Save dialog box
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OK Applies the tags that you specified and closes this dialog box.

Cancel Disregards any changes you made in this dialog box, closes the 
dialog box, and does not apply any of the tags.

Help Displays online help for this dialog box.

Fill tags Allows you to specify a file that contains the DICOM tags. When 
you select this button, the Open Tags File dialog box appears.

Figure 118.  Study page in the Attributes to Save dialog box (continued)

Series Number (0020,0011) A number that identifies this series.

Performing Physicians' Name 
(0008,1050)

Name(s) of the physician(s) administering the series.

Series Description (0008,103E) User-provided description for the series.

Body Part Examined 
(00018,0015)

A text description of the body part that was examined. 
Options are: Unknown, Skull, CSpine, TSpine, LSpine, 
SSpine, Coccyx, Chest, Clavicle, Breast, Abdomen, Pelvis, 
Hip, Shoulder, Elbow, Knee, Ankle, Hand, Foot, Extremity, 
Head, Heart, Neck, Leg, Arm, and Jaw.

Smallest Pixel Value (0028,0108) Minimum value of all images in this series.

Procedure Step ID (0040,0253) Identification of that part of a procedures that was 
performed during this step.

Procedure Step Start Time 
(0040,0245)

Time when the procedure step started.

Figure 119.  Series page in the Attributes to Save dialog box
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8 Click OK. 

If you are converting a dataset that has more than one slice, the Save 
Range of Slices dialog box (Figure 120) appears.

9 Complete the dialog box.

Laterality (0020,0080) Options are: Unknown, Left, and Right.

Series Time (0008,0031) Time series started.

Protocol Name (0018,1030) User-defined description of the conditions under which the 
series was performed.

Operator's Name (0008,1070) Name(s) of the technologist(s) supporting the series.

Patient Position (0018,5100) Patient position relative to the imaging-equipment space. 
Options are: Unknown, Head-First Prone, Head-First 
Supine, Feet First-Prone, Feet First-Supine, HF-Decubitus 
Right, HF-Decubitus Left, FF-Decubitus Right, FF-Decubitus 
Left.

Largest Pixel Value (0028,0109) Maximum value of all images in this series.

Procedure Step Start Date 
(0040,0244)

Date when the procedure step started.

Procedure Step Description 
(0040,0254)

Institute-generated description or classification of the 
procedure step that was performed.

OK Applies the tags that you specified and closes this dialog 
box.

Cancel Disregards any changes you made in this dialog box, closes 
the dialog box, and does not apply any of the tags.

Help Displays online help for this dialog box.

Fill tags Allows you to specify a file that contains the DICOM tags. 
When you select this button, the Open Tags File dialog box 
appears.

Figure 119.  Series page in the Attributes to Save dialog box (continued)
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10 Click OK when complete.

The dataset is converted to DICOM format and saved in the directory 
you specified. 

If you are converting a dataset that has several images, each file is 
sequentially numbered. For example, doetumor001.dcm, 
doetumor002.dcm, doetumor003, and so on.

                          

Save image to 
separate files

Saves each image slice to a 
separate file.

First File Starting 
Number

Specifies the starting number 
for the first file.

File Name Number 
of Digits

Specifies the number of digits in 
the file name.

First slice Specifies the number of the first 
slice.

Last slice Specifies the number of the last 
slice.

First time period Specifies the first time period. 

Last time period Specifies the last time period.

Save with packed 
bits compression

Indicates to save the TIFF files 
with packed bits compression.

OK Applies the parameters you specified and closes this dialog box.

Cancel Disregards any changes you made in this dialog box, closes the dialog box, 
and does not apply any of the changes.

Help Displays online help for this dialog box.

Figure 120.  Save Range of Slices dialog box
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6 Visualizing Images
Visualization of image datasets is an important aspect of image analysis. 
Researchers must often visualize the orientation, locality, or progression 
(time) of structures in clinical and nonclinical datasets. This chapter 
explains how to use MIPAV to visualize medical images using views.

Views specify the way image datasets are displayed. Views indicate the 
number of images in a dataset that are displayed at one time and whether 
images in a dataset are manually or automatically advanced. 

In the default view, one image is displayed at a time. If a dataset contains 
more than one image, you can manually advance through the image stack. 
The default view can also display 2D through 5D datasets. For image 
datasets with more than two dimensions, additional views are available: 
animate, cine (movie), lightbox, link to another image, surface plotter, 
surface render, triplanar, and triplanar-dual. The lightbox view displays two 
or more images, or slices, at once. Others—animate and cine—automatically 
advance the images and display them in succession, much like a cinema 
film.

To gain access to views other than the default view, you use the Image > 
Views menu (Figure 121) in the MIPAV window. Figure 1 lists the types of 
views and the number of images each view displays at one time and 
indicates whether images are manually or automatically advanced in the 
view and the number of dimensions an image must have to be displayed in 
the specified view. 
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For example, you can view an image dataset that has three or more 
dimensions in cine view, which displays only one image at a time and 
advances images in the forward direction only.

View
Number of images 
displayed

Manual or automatic 
image advancement Dimensionality

Default 1 Manual All (2D, 3D, 4D, 5D)

Animate 1 Automatic (forward, 
reverse, continuous 
looping)

Images with more than 
two dimensions (2D)*

Cine (Movie) 1 Automatic (forward) Images with more than 
two dimensions

Lightbox All images in the 
dataset

Manual Images with more than 
two dimensions*

Link to 
another 
image

2 Manual Images with more than 
two dimensions*

Surface 
plotter

1 Manual Images with more than 
two dimensions*

*MIPAV can display a 4D dataset that overlays a 3D dataset in the views indicated. If the 4D dataset 
has dimensions that differ from the 3D dataset, the 4D dataset is automatically resampled and 
interpolated into the same dimension space as the 3D dataset.

Figure 121.  Types of views as shown on the Image > Views menu 
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Tip: You can display different views of the same dataset on the desktop at the 
same time.

Surface 
renderer

All images in the 
dataset

Manual 3D images*

Triplanar 2 Manual 3D and 4D images*

Triplanar-dual 2 images loaded 
together

Manual 3D and 4D images*

Volume 
render 
(shear)

In development

Volume 
renderer

In development

View
Number of images 
displayed

Manual or automatic 
image advancement Dimensionality

*MIPAV can display a 4D dataset that overlays a 3D dataset in the views indicated. If the 4D dataset 
has dimensions that differ from the 3D dataset, the 4D dataset is automatically resampled and 
interpolated into the same dimension space as the 3D dataset.

Figure 121.  Types of views as shown on the Image > Views menu  (continued)
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Displaying images using the default view

When you initially open or load an image dataset, it appears in the image 
window showing the default view (Figure 2).

If you display a 2D image dataset, the title bar only displays the name of the 
file and the magnification level only. If you open an image dataset that has 
more than two dimensions, the title bar displays the name of the file, the 
position of the image in the dataset, the total number of images in the 
dataset, and the magnification level.

Datasets with more than two dimensions typically contain many image 
slices. To manually advance through datasets that contain more than one 

image, you can use the image slice slider or , the Decrements image 

slice icon, or , the Increments image slice icons in the MIPAV window 
(Figure 4). You can also use the lightbox view to find and display a 
particular slice in the image dataset in the default view (refer to “Using the 
lightbox view to update the image slice displayed in the default view” on 
page 47).

Figure 122.  Image window showing the default view for a 2D image
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Magnifying and minifying images
In the default view you can magnify or minify, or reduce, displayed images. 
When you display an image, the magnification level is indicated on the title 
bar of the window. For example, M:4.0 indicates that the image was 
magnified by a factor of four times the original size. You can also use the 
magnifying glass to temporarily magnify or reduce a region of the image. 
You can magnify images to 32 times their original size, reduce them to one-
fourth their original size, or restore them to their original size.

Figure 123.  Image window showing (A) a 2D image, or slice, and (B) an image dataset that has 
more than two dimensions. 

Figure 124.  MIPAV window showing image slice slider and slice buttons and lightbox icon
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In the MIPAV window, there are three methods for magnifying or minifying 
images:

• Automatically using three preset commands on the Image > Zoom 
menu 

• Manually using the Custom command on the Image > Zoom menu, 
which allows you to create other magnification levels

• Automatically using the icons on the image toolbar

To set the magnification level automatically using the 
preset commands

1 Open an image. 

2 Select Image > Zoom.

3 Select one of the following commands on the Zoom menu:

•  0.5X—To reduce the image by one-half of its current size

•  1X—To restore the image to its original size

•  2X—To enlarge the image by twice its original size

The software immediately changes the magnification level of the image.

Figure 125.  Zoom commands on the Image menu
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To set the magnification manually using the Custom 
command

To manually adjust the magnification level to a specific level that is not 
available through the preset commands or the icons on the image toolbar, 
do the following:

1 Open an image.

2 Select Image > Zoom > Custom. The Custom Magnification dialog box 
(Figure 6) opens.

3 Slide the marker in the Magnification slider to the specific level of 
magnification that you want to apply.

4 Select the interpolation method if desired.

Interpolation is the addition of one or more voxels between two other voxels. 
The interpolation mode is particularly important when an image is magnified 
(and voxels are seen more easily). Three interpolation modes are available: 
nearest, bilinear, and cubic (refer to Figure 6 for more information).

5 Click Apply. MIPAV applies the magnification level and interpolation 
mode to the image.
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Magnification Slide the marker left to decrease the 
magnification or right to increase the 
magnification. You can reduce the image 
to one fourth of its current size or 
enlarge it up to 32 times its current size.

Notice that the number below the center 
of the slider changes as you slide the 
marker to indicate the magnification 
level.

Interpolation Select one of the following methods:

Nearest—Short for nearest neighbor. The replicated voxel is assigned the color of 
the closest voxel. This mode yields more accurate results because other modes 
because the original values are retained. However, if applied, the image may have a 
choppy “stair-step” effect. It is also possible that some data may be lost or 
duplicated.

Bilinear—In this mode, the average of the four nearest voxels (to the newly 
interpolated voxel) is weighted. The interpolated voxel is then assigned the 
resulting color. If this mode is applied, the “stair-step” effect is reduced. However, 
because the view of the data is altered, it is not as accurate as the nearest neighbor 
mode.

Cubic—Short for cubic convolution. This mode is similar to the bilinear mode, 
except that the weighted average of the nearest sixteen voxels is used instead of 
the nearest four. If this mode is applied, the stair-step effect is greatly reduced. 
However, because the view of the data is altered, it is not as accurate as the nearest 
neighbor or bilinear modes.

Apply Applies the magnification and interpolation you specified. 

Cancel Disregards any changes that you made in this dialog box and closes this dialog box.

Help Displays online help for this dialog box.

Figure 126.  Custom Magnification dialog box
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To set the magnification automatically using icons on 
the image toolbar

The three magnification icons on the image toolbar work the same way as 
the three preset commands on the Image > Zoom menu do. Do one or more 
of these tasks:

• To magnify an image, click , the Magnify image 2.0x icon. Each 
time you click Magnify, the image doubles in size. As the magnification 
level increases, it may be necessary to manually adjust the size of the 
window so you can see the entire image at one time. Scroll bars appear 
if the image is too big for the window.

• To minify an image, click , the Magnify image 0.5x icon. Each time 
you click this icon the image is reduced to half size.

• To return the image to the original level of magnification, click , the 
Magnify image 1.0x icon.

Tip: These icons appear on other windows beside the MIPAV window, and they 
work in the same way on each window.

WORKING WITH THE MAGNIFYING GLASS

The magnifying glass is much like a traditional, real-world magnifying glass. 
It allows you to view a portion of the image at a specific magnification level. 
You can select the magnification level, which can be anywhere from 1 to 32 
times the original image size. For example, an image may be the original 
size; however, to examine a specific area more closely, you may want to set 
the magnification level of the magnifying glass to 16 times the original size.

Conversely, if an image uses a high-level of magnification, you may want set 
the magnifying glass to a lower magnification level so that you can gain 
perspective on where a section fits with the whole image.
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To use the magnifying glass

1 Open an image.

2 Click , the Magnify Region icon, on the Image toolbar in the MIPAV 
window.

3 Move the cursor to the image. The cursor shape changes to the 
magnifying glass shape, a box outlined in red with the level of 
magnification in the lower left corner (Figure 7). The area inside the box 
is magnified.

You can move the magnifying glass to different places on the image. 
This allows different regions to be magnified without affecting 
magnification level of the entire image. When you want to return to 

normal magnification, click , the Default Mode icon.

To adjust magnifying glass settings

1 Do either of the following:

• Select Image > Magnifying Glass Settings. 

• Right-click on the image.

The Magnification Settings dialog box (Figure 8) appears.

Figure 127.  Magnified region
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2 Move the Magnification slider to select the level of magnification. The 
number in bold in the middle of the slider indicates the current level of 
magnification.

3 Specify the size of the magnifying region (box) in the Width text box. 
(The width and the length are the same.) Values are in voxels.

4 Select Display intensity values if you want to see the intensity values of 
the voxels in the magnifying glass (Figure 9). 

5 Click Apply. The new settings are applied to the magnifying glass.

Magnification Specifies the level 
of magnification in 
the magnified 
region. You can 
select a 
magnification from 
1 to 32 times the 
original size of the 
image.

Display 
intensity 
values

Shows the 
intensity values of 
the voxels in four 
areas in the 
magnified region. 
This check box is 
only available for 
magnifications 21 
to 32.

Width Indicates the size of the magnified region in voxels; in 
other words, of the magnifying glass.

Apply Applies the parameters in this dialog box to the 
magnifying glass. 

Close Disregards any changes that you made in this dialog 
box and closes this dialog box.

Help Displays online help for this dialog box.

Figure 128.  Magnification Settings dialog box
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Viewing two images together
When two separate image files are loaded into the same window (for 
directions on how to load an image, refer to Chapter 3, “Getting Started 
Quickly with MIPAV”), the window displays a blending of both images. 
MIPAV refers to the first image file as “Image A” and to the second image 
file as “Image B.” By default, Image A is active and Image B is inactive. To 
change which image is active, simply select, as appropriate, the Image A or 
Image B radio button. 

By default, Image A is active and Image B is inactive. Thus, even if two 
image files are loaded into the same image window, only Image A—which is 
the designation MIPAV assigns to the first image that was opened in the 
window—is displayed.

You can view the inactive image using one of the following methods: 

• Adjust the alphablending value so that you can see the inactive and 
active images simultaneously

• View the part of Image B that is directly under that portion of Image A 

by using , the Window region of Image B icon.

• View portions of the image using the checkerboard tool 

Figure 129.  Magnified region showing intensities
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COMPARING IMAGES USING ALPHABLENDING

Alphablending is a technique that adds transparency information to 
translucent objects. It is used to blend what is currently rendered on the 
display (i.e., Image A) with the contents of the frame buffer (i.e., Image B). 
Each colored voxel is assigned an alpha value, which represents 
transparency. The alpha value is used to blend the intensities, voxel by 
voxel. When two images share a window, you can adjust the alphablending 
settings so that you can see a blend of both images and can compare 
overlapping regions in two datasets.

To use the alphablending tool and Window Region 
tool

1 Open two images.

2 Load the second image into the image window of the first image. The 
Active Image and Alphablending slider appears at the bottom of the 
MIPAV window (Figure 11).

Figure 130.  MIPAV window showing Image A and Image B slider
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The level of translucency for one image is inversely proportional to the 
other. Thus, if Image A is 75 percent transparent and 25 percent 
opaque; Image B is 75 percent opaque and 25 percent transparent 
(“Alphablending: An Example” on page 20).

Note: In the MIPAV window, notice that an additional magnifying glass is now 

available: , the Window Region of Image B icon, which you use to view the 
portion of Image B that is directly under that portion of Image A.

3 Move the Active Image and Alphablending slider between the Image A 
and Image B radio buttons.
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Alphablending: An Example

For a very clear example of how alphablending 

works, open two images and then apply , the 
Hot Metal LUT icon, to one of the images before 
you load them together. After the images are 
loaded, move the Active Image and 
Alphablending slider from the left to the right. 
The following images show what you see at five 
points of the slider:

(A) The image on the far left shows 100 percent 
of Image A. It does not display a blending of the 
images.

However, for any of the images below, you can 

use the , Window Region of Image B icon, to 
inspect the portion of Image B that lies 
underneath that same portion of Image A.

(B) The next image displays a blending of 75 
percent Image A and 25 percent of Image B. 

Again, use  to see the portion of Image B 
beneath Image A.

(C) The middle image displays 50 percent 
blending of both Image A and Image B. You can 

use  to inspect Image B.

(D) The fourth image displays 75 percent of 
Image B and only 25 percent of Image A. You 

can use  still to inspect Image B.

(E) The final image on the right displays 100 
percent of Image B. Since all of Image B is 

shown, you no longer have a need to use .
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Depending on the direction in which you are moving the slider (that is, 
toward Image A or toward Image B), one image becomes more visible. 
To examine each image in more detail, you can use the magnifying 
glasses.

As you move the slider, the images in the image window are updated 
instantly. If not, release the mouse button to update the image.

Move the slider all the way to the right or to the left depending on which 
image you want to see. For example, to see Image B, move the slider to 
the far right. To see Image A, move the slider (Figure 10) to the far left. 
The closer the slider is to the middle, the more blended are the images.

To make images active or inactive

1 Open two images.

2 Load the second image into the first image window. The MIPAV window 
expands to include the Active Image and Alphablending slider 
(Figure 10).

3 Notice that Image A is currently the active image.

Figure 131.  MIPAV window showing Active image and
alphablending slider
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4 Select Image B in the Active Image and Alphablending slider to make 
Image B the active image.

5 Move the slider to the far right. As you are moving the slider, more of 
Image B appears in the image window. When the slider reaches the far 
right, all of Image B appears in the image window.

6 Click , the Default Mode icon.

If you want to take an action on one of the images—for example, adjusting 
the contrast or running an algorithm—make sure that it is the active image. 
If the inactive image is Image B, you also have the option of using the Image 
B region tool to view portions of the Image B. If the active image is currently 
Image A and you want to view Image B, simply select the Image B radio 
button. To make Image A the active image, select the Image A radio button.

VIEWING PORTIONS OF IMAGES USING THE 
CHECKERBOARD

The checkerboard tool displays both portions of both images in an 
alternating fashion, much like the squares on a checkerboard. A traditional 
checkerboard has a grid of alternating dark-colored and light-colored 
squares. Portions of Image A appear where the light-colored squares would 
appear on the checkerboard; portions of Image B appear in place of the 
dark-colored squares. You can adjust the number of rows and columns 
displayed.

To use the checkerboard tool

1 Open two images.

2 Load the second image into the first image window. The MIPAV window 
expands to include the Active Image and Alphablending slider.

Note: If you select another image—that is, an image that is not loaded into the 
same window as Image A and Image B, the Active Image and Alphablending 
slider disappears from the MIPAV window. The slider only appears when the 
selected image window contains two images.
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3 Click . The Checkerboard Pattern dialog box (Figure 12) appears.

4 Select Use checkerboarding if it is not already selected.
.

5 Adjust the Rows slider to indicate the number of rows that should be in 
the checkerboard pattern.

6 Click Apply when finished. The checkerboard pattern appears in the 
image window (Figure 13).

When the rows and columns intersect, a grid is created. Adjacent 
squares in the grid alternatively display the active and inactive images.

7 Click Close to close the Checkerboard Pattern dialog box.

To remove the checkerboard from the image

1 Click . The Checkerboard Pattern dialog box (Figure 12 on page 22) 
appears.

2 Clear Use checkerboarding.

3 Click Apply. MIPAV removes the checkerboard from the image.

4 Click Close.

Use 
checkerboarding

Specifies to use checkerboarding. 

Rows Indicates the number of rows you 
want to display in the checkerboard. 
You can display from 1 to 50 rows.

Columns Indicates the number of columns you 
want to display in the checkerboard. 
You can display from 1 to 50 
columns.

Apply Applies the parameters that you 
specified to the images.

Close Closes this dialog box.

Cancel Disregards any changes you made in this dialog box, closes the dialog box, and 
does not apply checker boarding.

Help Displays online help for this dialog box.

Figure 132.  Checkerboard Pattern dialog box
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Changing image brightness and contrast using LUTs
Generally, computer systems have brightness display values written in the 
display hardware. These values are known as the physical color map; they 
are hard coded in your monitor.

When you open an image, the image file contains data that indicates the 
intensity of each voxel in the image. These data are passed to the physical 
color map and displayed on the monitor. Additionally, MIPAV provides a 
logical color map, which allows you to remap the original intensities to 
other intensities. Although technically the term look-up table (LUT) can be 
used for the physical and logical color maps, in this guide look-up table 
refers to the logical color map only. You can apply predefined, pseudocolor 
or inverse LUTs, or you can manually manipulate the transfer function used 
to map the image data to the LUT. The LUT then translates the remapped 
values so that they can be interpreted by the physical color map and 
displayed on your monitor.

To adjust the look-up table using the Quick LUT 

Generally, to adjust the LUT, you open the Look-up Table window to modify 
the LUT’s values and transfer function. However, you can use the Quick 
LUT icon to modify the LUT without opening the Look-up Table window. 

Figure 133.  Examples of the checkerboard pattern applied to  
two loaded images
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Quick LUT allows you to easily choose the highest and lowest values for the 
intensity levels in a user- defined area. To do this, complete the following 
steps:

1 Open an image.

2 Click  (Quick LUT) in the MIPAV window. 

3 Move the cursor to the image window and draw a box around an area 
that has the highest and lowest intensities you want the image to 
display. These values are used to remap the image data to the LUT. The 
net effect is increased contrast in the area of interest (Figure 14).

To generate a histogram and look-up table

A histogram is a graphic representation of the intensity level distribution in 
an image or VOI region. It displays the number of voxels at each intensity 
level. The histogram and LUT appear in the Look-up Table window. 

To generate a histogram, and view the LUT, complete the following steps:

1 Open an image. The image appears in an image window.

2 Create a VOI on the image (optional step).

3 Do either of the following:
• Click Look-up Table.
• Select LUT > Histogram - LUT. 

Figure 134.  An image before and after applying Quick LUT
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If the image contains a VOI, the Histogram window appears (Figure 15). 
Go to the next step.

If there are no VOIs on the image, the Look-up Table window 
(Figure 16) appears.

4 Choose one of the following:

• Whole image—To generate a histogram for the whole image 

• VOI region(s)—To generate a histogram for the VOI region of the 
image

5 Click OK. A progress message appears briefly. After a few moments, the 
Look-up Table window appears (Figure 16).

Figure 135.  Histogram dialog box
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File Open LUT—Opens a 
previously saved LUT file. 
LUT files have a .LUT 
extension.

Save LUT—Saves the LUT 
displayed in this window in a 
LUT file.

Open Transfer Functions—
Opens a previously saved 
transfer function. Transfer 
function files have a .FUN 
extension.

Save Transfer Functions—
Saves the transfer function 
displayed in this window to a 
file.

Close LUT—Closes the LUT 
window.

Utilities Change number of colors—
Allows you to change the 
number of colors displayed in 
the image. 

Valid values are 2 to 256.

CT function—Allows you to select a preset LUT that is appropriate for the image 
content. Values are abdomen, head, lung, mediastinum, spine, and vertebrae.

Invert LUT—Creates a negative of the image.

Reset histogram and LUT A—Returns image A to its original values.

Reset histogram and LUT B—Returns image B to its original values. This command is 
only available if two images are open.

LUT toolbar Provides tools that allow you to manipulate the displayed image. Refer to Figure 19.

Update 
(real-time)

Changes the image as you make changes to the LUT, which allows you to see the 
effect of your changes immediately on the image.

Log scale 
(histogram)

Displays the image’s histogram count in log scale along the Y axis.

Interpolate 
image

Displays image using interpolation, which reduces pixillated image to appear more 
smooth.

Caution: Depending on the memory resources of your workstation, interpolation 
can be very lengthy.

Figure 136.  Look-up Table window
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The Look-up Table window consists of three sections: a menu bar, a toolbar, 
and one or more pages containing histograms. A tab appears for each image 
that is opened in the image window. For example, if only one image is in the 
image window, then only the Image A tab appears. If you generated the 
histogram for an image window that contains two images, a tab for Image A 
and a tab for Image B appear. Each of these tabbed pages contain a 
histogram for the applicable image. If you generated the histogram for a 
VOI, the window does not display a tab and only the applicable icons and 
buttons in the toolbar appear.

The toolbar allows you to manipulate the displayed image. You can apply 
pseudocolor LUTs, adjust the image contrast with the transfer function, and 
apply preset window and level settings for CT slices. You can also edit the 
red, blue, green, and alpha channels of a LUT.

look-up table (LUT)—Indicates the intensity of each voxel in the image and, in 
MIPAV, allows you to remap the original intensities to other intensities.

transfer function—Reflects the relationship between the original image 
intensity values and how they are mapped into the LUT. The line in the LUT 
represents the transfer function.

Note: You can generate a histogram for two image datasets that are loaded 
together. In this case, the Look-up Table window (Figure 17) shows two tabs—
one for Image A and one for Image B.

Number of 
colors

Allows you to change the number of colors displayed in the image. 

LUT Displays the image intensities.

Figure 136.  Look-up Table window (continued)
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To update images in real time

When you modify the LUT, be sure to select the Update (real time) check 
box. The image in the image window is then updated in real time. 

Figure 137.  Look-up Table window showing Image A and B histograms
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To change the number of intensities displayed in the 
LUT

You can change the number of intensities displayed in the LUT. To do this, 
do the following:

1 Select Utilities > Change Number of Colors in the LUT window. The 
Change Number of Colors dialog box opens.

2 Type the number of colors you want in the Number of colors box. You 
can specify any whole number between 2 and 256.

3 Select Apply to apply the changes. 

Notice that the Number of colors box in the LUT window now displays 
the number you specified and the histogram changes to display the new 
colors. 

4 Click Close or Cancel to close the dialog box. 

APPLYING PREDEFINED LUTS TO IMAGES

You can use MIPAV’s predefined LUTs to apply pseudocolor, create a 
negative of the image, and apply preset CT window and level settings to an 
image.

To apply pseudocolor LUTs to images

As you examine an image, you may need to observe small changes in 
intensity values or identify the same intensity values in different portions of 
an image. This can be difficult if the image is rendered in grayscale because 
the human eye can only see about 100 shades of gray. However, because 
varied colors are often easier to distinguish, MIPAV allows you to use 
various pseudocolor maps to elucidate objects of interest. Thus, MIPAV 
provides a variety of pseudocolor LUTs. If you apply a pseudocolor LUT, the 

Figure 138.  Change Number of Colors dialog box
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grayscale intensity values are remapped to color intensity values. Note that 
the original image data is not changed; only the displayed image file (hence 
the term pseudocolor).
de

To apply a pseudocolor LUT, click one of the following icons: 

•  Red LUT

•  Green LUT

•  Blue LUT

•  Gray blue/red LUT

•  Hot metal LUT

•  Spectrum LUT

•  Cool hot LUT

•  Striped LUT

•  Invert LUT

The grayscale intensity values in the image dataset are remapped to color 
intensity values.

Figure 139.  LUT toolbar
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To invert intensities

To invert the intensities so that a negative of the dataset appears, click , 
the Invert LUT icon. The Invert LUT icon is in both the Look-up Table 
window (Figure 16 on page 26) and the MIPAV window. Figure 19 on 
page 30 shows the location of this icon in the Look-up Table window.

To apply CT level presets to images

There are six CT window and level presets: abdomen, head, lung, 
mediastinum, spine, and vertebrae. To apply a preset level to the image, 
complete the following steps: 

1 Click , the CT Preset icon, in the LUT window. The CT Presets dialog 
box appears (Figure 20).

2 Select the desired CT preset. As you select the CT preset option, the 
colors in the image’s histogram or LUT change, and, if you chose to 
update images in real time, the image changes.

3 Click OK to save the change. 

Figure 140.  CT Presets dialog box
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ADJUSTING CONTRAST USING THE TRANSFER 
FUNCTION

The transfer function reflects the relationship between the original image 
intensity values and how they are mapped into the LUT. An example of how 
adjusting the transfer function affects the display of an image appears in 
Figure 16. In this example, the top image is generated by applying the linear 
transfer function (slope = 1) to produce display values that are evenly 
distributed over the range of the LUT (see Figure 141A). This results, in this 
case, in a low-contrast image (see Figure 141B). The contrast of the image 
can be improved by adjusting the transfer function in a manner shown in 
Figure 141A (e.g., changing a low-contrast image into a high-contrast 
image). The image scalar values between –175 and 275 are remapped as a 
function of the modified transfer function and distributed across the full 
LUT range. The values above 275 are remapped to white and the values 
below –175 are remapped to black. The effect can be readily seen in 
Figure 141B.

To modify transfer functions

1 Open an image. The image appears in the default image window.

2 Click , the Displays Look-up Table (LUT) icon. The Look-up Table 
dialog box opens.

3 Click the transfer function. A new node may appear.

4 Drag the node to the new location.

You can also adjust the transfer function for the alpha, red, green, and 
blue channels in an image. 

Example: You might want to use these icons to highlight certain intensities in a 
particular color. 

To do this, click the appropriate one of the following icons: 

• , the Edit Alpha icon

• , the Edit Red icon
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• , the Edit Green icon

• , the Edit Blue icon

When you click on one of these icons, the transfer function for that 
channel appears on the histogram and a node appears on that transfer 
function. Drag the node to the desired position. To adjust another 
channel, you must click on the icon and drag the node to the appropriate 
position.
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Figure 141.  An image before and after modifying the transfer function
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To save transfer functions

To save a transfer function to a file, complete the following steps:

1 Select File > Save Transfer Functions (Figure 142) in the Look-up Table 
window, or press Ctrl S. The Save dialog box (Figure 143) appears.

2 Type a name to the transfer function in the File Name box. Be sure to 
add the .fun extension to the file name.

3 Click Save. The program saves the transfer function under the name you 
specified.

Figure 142.  Open and Save commands in the File menu

Figure 143.  Save dialog box
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To apply previously saved transfer functions

To open a transfer function file and apply it to an image, complete the 
following steps:

1 Select File > Open Transfer Functions in the Look-up Table window. 
The Open dialog box appears.

2 Select the desired file. LUT files have a .fun extension. 

3 Click Open. The program applies the transfer functions file to the 
current image.

To save LUTs for later use

1 Select File > Save LUT in the Look-up Table window, or press Ctrl S. 
The Save dialog box (Figure 144) appears.

2 Type a name for the LUT in the File Name box. Be sure to add the .lut 
extension to the file name. 

3 Click Save. The program saves the LUT under the name you specified.

To open and apply previously saved LUTs to images

1 Select File > Open LUT in the Look-up Table window, or press Ctrl O. 
The Open dialog box (Figure 25) appears.

2 Select the desired file. LUT files have a .lut extension. 

Figure 144.  Save dialog box 
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3 Click Open. The program applies the LUT settings from the LUT file you 
specified to the current image file.

To open, save, and apply frequently used LUTs

For a LUT that you defined and expect to use frequently, MIPAV provides a 
simple method for saving, opening, and applying it without needing to use 
the commands on the File menu. You use two icons on the toolbar in the 
Look-up Table window:

• , the Save User-Defined LUT icon, allows you to save the LUT.

• , the Open User-Defined LUT icon, provides a very quick way of 
opening and applying the user-defined LUT

Recommendation: Because these icons only apply to one user-defined LUT, 

it is recommended that you select the LUT that is used most frequently.

Figure 145.  Open dialog box
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To reset original LUTs to images

Click , the Grayscale icon in the Look-up Table window (refer to 

Figure 16 and Figure 19). Alternatively, you can click , the Reset LUT icon, 
in the MIPAV window.

To adjust the threshold

1 Open an image. The image appears in the default image window.

2 Click , the Displays Look-up Table (LUT) icon. The Look-up Table 
dialog box opens.

3 Click , the Dual threshold function icon. The Threshold icon becomes 
active and the transfer function of the histogram changes.

4 Select Algorithms > Threshold. The Threshold dialog box  (Figure 26) 
opens.

Set lower limits 
between (1.0–
3774.0)

Threshold limit for the 
lowest image intensities.

Set threshold 
between 
(1258.3334–3774.0)

Threshold limit for the 
highest image intensities.

Produce binary image Produces a binary image 
(Boolean).

Set values outside of 
limits to

Specifies the intensity value 
to assign to values outside 
the threshold limits.

New image Shows the results of the 
algorithm in a new image 
window

Replace image Replaces the current active image with the results of the algorithm.

Whole image Applies the algorithm to the whole image.

VOI regions Applies the algorithm to the volumes (regions) delineated by the VOIs.

OK Applies the changes you made in this dialog box and closes the dialog 
box.

Figure 146.  Threshold dialog box
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5 Complete the dialog box.

Note: You can choose to generate a binary image (Boolean) by selecting the 
Produce binary Image check box. Alternatively, you can clear the binary option 
and enter a threshold value. If you still want to generate a Boolean image, select 
the check box again. Note that, if you generate a Boolean image, MIPAV does not 
allow you to reapply the threshold or to generate either a histogram or LUT for a 
Boolean image.

6 Click OK to apply the threshold.

Displaying images using the animate view

If you select the animate view, the software makes a copy of the image 
dataset and loads it into an image window showing the animate view. In 
animate view, like cine view, the software automatically advances through 
the entire image dataset. However, the animate view allows you to adjust 
the speed at which images are advanced. You can specify that images be 
displayed in forward or reverse order. You can also pause or stop the 
sequence.

To view an image dataset in animate view

1 Select Image > Views > Animate in the MIPAV window. The Animate 
Parameters dialog box (Figure 27) appears.

2 Type the scale factor that you want to use in the Scale factor box.

Cancel Disregards any changes you made in this dialog box, closes the dialog 
box, and does not change the threshold.

Help Displays online help for this dialog box.

Figure 146.  Threshold dialog box (continued)
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3 Select one of the three interpolation methods. 

4 Click OK. 

MIPAV transforms the dataset using the scale factor and interpolation 
method you indicated. A progress message (Figure 28) appears while 
the program constructs the animated file. It then loads a copy of the 
dataset in the Animate window.

.   

Scale factor Changes the size of the dataset by the factor 
specified. 

Unlike magnification, the number of voxels used 
to replicate the image may change. For 
example, if you scale a dataset by a factor of 2, 
the image becomes twice the original size, and 
the number of voxels is squared.

Interpolation Determines the intensity of the additional voxels using one of the three following 
methods:

Bilinear—Weighs the average of the four nearest voxels (to the newly interpolated 
voxel). The interpolated voxel is assigned the resulting intensity.

Bspline 3rd order—Weighs the average of the 27 nearest voxels (to the newly 
interpolated voxel).

Bspline 4th order—Weighs the average of the 64 nearest voxels (to the newly 
interpolated voxel).

OK Applies the scale factor and interpolation to the image dataset according to the 
specifications in this dialog box.

Cancel Disregards any changes that you made in this dialog box and closes this dialog box.

Help Displays online help for this dialog box.

Figure 147.  Animate Parameters dialog box

Figure 148.  Animate progress message
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File Save Image as .avi—Saves the dataset as an AVI, or digital video, file.

Close Animate—Closes the Animate window.

Options Show Z Slice Numbers—Displays, if selected, the slice number, or the frame 
number, on the lower left side of the image.

 Continuous 
reverse

Steps through all of the images in the dataset continuously in reverse without 
stopping at the speed specified in Desired frames per second.

 Reverse

Steps through all of the images in the dataset once in reverse at the speed 
specified in Desired frames per second. 

 Forward

Steps through all of the images in the dataset once in sequence at the speed 
specified in Desired frames per second. 

 Continuous 
forward

Steps through all of the images in the dataset continuously without stopping at 
the speed specified in Desired Frames per second.

 Backward 
and forward

Steps through all of the images in the dataset in sequence and then in reverse 
continuously without stopping at the speed specified in Desired Frames per 
second. 

Figure 149.  Image window shown in the Animate view
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ADJUSTING DATASET DISPLAY

You can magnify or reduce the display of your dataset using the 

magnification icons. Use , the Magnify image 2.0x icon, to enlarge the 
image to twice its current size.

 Pause

Pauses the animation at the frame currently shown. 

 Stop

Halts the animation and redisplays the first image in the dataset. 

 Magnify 
image 2.0X

Magnifies the image by 2. 

 Magnify 
image 0.5x

Magnifies the image by one-half.

 Set 
brightness/
contrast

Specifies the brightness and contrast of the image. When you select this icon, 
the Brightness/Contrast dialog box opens. To change the brightness, slide the 
Brightness slider to the level desired and then click Apply. To change the 
contrast, slide the Contrast slider to the level desired and click Apply.

 Delete 
current slice

Removes the slice currently shown in this window from the image dataset. 

Caution: The program does not allow you to undo slice deletion. Before you 
delete slices, you may want to have a backup of the complete image dataset to 
avoid losing images. 

Frame number Sets the first image slice shown to the frame, or slice, number that you specify. 
Notice that the frame number appears in the box to the right of the slider.

Desired frames 
per second

Specifies how many frames, or slices, should appear in 1 second. The read-only 
box to the right shows the actual number of frames per second your computer 
has achieved. The number of frames per second depends on the amount of 
memory accessible by the computer and CPU time.

Figure 149.  Image window shown in the Animate view (continued)
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ADJUSTING THE BRIGHTNESS AND CONTRAST 
IN IMAGES

To adjust the brightness and contrast in the image, do the following:

1 Click , the Brightness/Contrast icon, in the Animate window. The 
Brightness/Contrast dialog box (Figure 30) opens.

2 Move the Brightness slider to the position you want. Notice that the 
level of brightness changes on the image as you move the slider.

3 Move the Contrast slider to the desired contrast level. The contrast in 
the image changes as you move the slider.

4 Click Apply when you are finished. The image in the Animate window 
reflects the changes in brightness and contrast that you made.

5 Click , the close button at the top right of the dialog box, to close the 
dialog box.

REMOVING SLICES FROM IMAGE DATASETS

In the Animate window, you can also remove slices from the dataset. First, 
you need to find the slice that you want to delete. To find a slice number, do 
either of the following:

Brightness Specifies the level of brightness to apply to the 
image.

Contrast Specifies the level of contrast to apply to the image.

Apply Applies the brightness or contrast you specified to 
the image.

Cancel Disregards any changes that you made in this dialog 
box and closes this dialog box.

Help Displays online help for this dialog box.

Figure 150.  Brightness/Contrast dialog box
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• Select Options > Show Z Slice Numbers, which shows the slice number 
at the lower left of the image (refer to Figure 29 on page 40).

• Move the Frame Number slider to the slice that you want to delete. The 
number appears in the box on the right of the slider.

Once you locate the slice that you want to remove, click , the Delete icon. 
The slice is removed from the dataset.

Caution: The program does not allow you to undo slice deletion. Before 
you delete slices, you may want to have a backup of the complete image 
dataset to avoid losing images.

PLAYING A DATASET “FILM”

Using the icons and buttons on the toolbar in the Animate window 
(Figure 29 on page 40), you can produce and play a dataset “film.” To do so, 
complete the following steps:

1 Move the Frame number slider to the slice that you want to see first.

2 Move the Desired frames per second slider to indicate the speed at 
which images should be advanced or reversed.

3 Click the following buttons as appropriate:

Figure 151.  Slice number in the read-only box beside the Frame Number 
slider in the Animate window
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• Click , the Forward icon, to advance the image dataset forward 
through all of the images one time (one loop).

• Click , the Reverse icon, to advance the image dataset backward 
through all of the images one time (one loop).

• Click , the Continuous Forward icon, to advance the image dataset 
forward through all of the images multiple times. To stop image 

advancement, you must press , the Pause icon, or , the Stop 
icon.

• Click , the Continuous Reverse icon, to advance the image dataset 
backward through all of the images multiple times. You must press the 

press , the Pause icon, or , the Stop icon, to stop image reversal.

• Click , the Pause icon, to pause the image advancement or reversal.

• Click , the Stop icon, to stop the image advancement or reversal.

Note: As the images advance or reverse, you may notice that the desired frames 
per second and the actual frames per second differ. Although you can type any 
number in the desired frames per second, the actual speed at which the images 
advance depends primarily on your computer's processor speed.

4 Save the animate viewer file by selecting File > Save Image as .avi (AVI, 
or audio video interleaved, is a Microsoft multimedia format). The 
Choose Type of AVI File dialog box (Figure 32) opens.

5 Select a type of file.

6 Click OK. The program runs the animation sequence that you created, 
closes this dialog box, and then displays the Save dialog box.
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7 Specify a name for the animation sequence in the File Name box. 

8 Click OK. The dialog box closes and the Choose File Type dialog box 
(Figure 33) opens.

24-bit 
uncompressed 
RGB

An uncompressed RGB file, which uses 8 
bits per color (red, green, blue).

8-bit RLE 
compressed 

A run length encoded (RLE) file that is 
converted to 8 bits and is compressed.

Quicktime movie An Apple format.

Motion JPEG A format that consists of motion JPEGs.

Mpeg-4 version 2 Another compression format.

OK Plays back the animated sequence that you created and then displays the 
Save dialog box for you to save the sequence.

Cancel Disregards any changes that you made in this dialog box and closes this 
dialog box.

Help Displays online help for this dialog box.

Figure 152.  Choose Type of AVI File dialog box

Figure 153.  Choose File Type dialog box
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9 Select a file type.

10 Click OK. The Save Range of Slices dialog box (Figure 34) opens.

11 Close the Animate window by either selecting File > Close Animate or 
pressing Ctrl X. The Animate window closes.

Save image to 
separate files

Saves the animation to separate files. 
Selecting this check box makes the 
First file starting number text box and 
the File name number of digits text box 
become active. 

First file 
starting 
number

Indicates which frame, or slice, to 
begin the first file saved. To make this 
box active, you must first select Save 
image to separate files.

File name 
number of 
digits

Specifies how may digits you want used 
for the file name. To make this box 
active, you must first select Save image 
to separate files.

First slice Specifies the first slice that should 
appear in the animation file.

Last slice Specifies the last slice that should 
appear in the animation file.

First time 
period

Specifies the time period of the images that should start the file. This box only 
applies to 4D images.

Last time 
period

Specifies the time period of the images that should end the file. This box only 
applies to 4D images.

Save with 
packed bits 
compression

Indicates that the file should be saved as compressed TIFF files. This check box 
only applies to 4D images.

OK Saves the animation according to the specifications in this dialog box and closes 
the dialog box.

Cancel Disregards any changes that you made in this dialog box and closes this dialog 
box.

Help Displays online help for this dialog box.

Figure 154.  Save Range of Slices dialog box
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Displaying images using the cine (movie) view

The cine view, like the default view, displays images one at a time in the 
default image window. However, in cine view, the software automatically 
advances the images.

To display a 3D or 4D dataset in this view, select Image > Views > Cine 
(Movie). The images appear sequentially in the default image window. All 
images in the dataset are displayed only once. The cine view does not loop 
images, nor does it show images in reverse order.

Displaying images using the lightbox view

You can use the lightbox view to display datasets that have more than two 
dimensions (2D). Like its real-world counterpart, the lightbox view displays 
several images, or slices, in the dataset at one time in an image window. 
Through the lightbox settings, you can easily control the number of slices 
that appear.

To view an image dataset in lightbox view

1 Open an image dataset that has more than two dimensions. It appears in 
the image window in default view (Figure 35).

2 Select Image > Views > Lightbox in the MIPAV window. The image 
window for the lightbox view appears (Figure 35). The image number, 
or slice number, appears in the lower left corner of each image.

Notice that the image you originally opened in step 1 remains on your 
desktop. So you not only see the image dataset in the lightbox view, but 
you also see the image in the default view. 
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Using the lightbox view to update the image 
slice displayed in the default view

The MIPAV window allows you to step through all of the slices of an image 
dataset shown in the default view one at a time using the Image slice slider, 

, the Decrements image slice icon, and , the Increments image slice 
icon. However, the default view only shows one slice at a time, but the 
lightbox view can show two or more slices at one time depending on the 
lightbox settings (that is, you can control the number of image slices that 
appear in lightbox view; refer to “Adjusting the lightbox view” on page 50).

Suppose it is easier for you to find a particular slice in the dataset by viewing 
several slices at the same time in order to compare them against each other. 
To do so, you would open an image dataset in default view and then display 
the dataset in lightbox view. The lightbox view displays the number of image 
slices that you had already specified. 

At this point your desktop shows both the image dataset in default view and 
the dataset in lightbox view. The lightbox view allows you to quickly look 
through the entire dataset until you locate the correct slice. Once you find it, 
you may want to perform some actions, such as running algorithms, on that 
slice. To update the image in the default view to display the slice you located, 
first select and then right-click the image slice in the lightbox view. The 
default image window now shows the image slice you found.
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Edit Select All—Selects all of the slices in 
the dataset.

Select None—Deselects all of the 
selected slices.

Invert Selections—TBD.

Delete—Deletes the selected slices 
from the dataset.

Extract—Copies the selected slices 
to a separate image window, which 
you can save as a separate dataset.

 

View First Page—Displays the first set* of 
slices in the dataset.

Previous Page—Displays the 
previous set* of slices in the dataset. 

Next Page—Displays the next set* 
of slices in the dataset.

Last Page—Displays the last set* of 
slices in the dataset. 

Options Settings—Allows you to change 
settings for the number of rows and 
columns used to display images in 
the dataset, change the grid size and 
the size of the frame border, change 
the colors of the borders and frames, 
and the level of magnification.

Save Settings—Saves the settings 
currently set in the Lightbox Settings 
dialog box.

Continuous Update—Updates all of 
the displayed images when you make 
a change to one of the images.

 Default mode

Displays the images according to the standard settings used by MIPAV when 
it is initially installed.

 Magnify region

Magnifies a portion of the image from 1 to 32 times. To change the level of 
magnification or the size of the magnifier, right-click on the image, and the 
Magnification dialog box opens.

Figure 155.  Image window showing the lightbox view
*The set of slices depends on the number of slices currently being displayed. For example, if four slices are currently 
displayed, then View > Previous Page shows the previous set of four slices. If seven slices are currently displayed, then 
View > Previous Page displays the previous seven slices in the dataset. View > Next Page works similarly. It displays the 
next set of slices in the dataset.
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 Repaints 
images

Updates the images displayed in the lightbox reflecting the changes made 
to the lightbox settings and to the dataset.

 Delete selected 
slices

Removes the selected slices from the image dataset. 

 Extract 
selected slices to a 
new image

Makes a copy of the selected slices in the image dataset to a new image 
window. 

 First page

Displays the first set* of slices in the dataset.

 Previous page

Displays the previous set* of slices in the dataset. 

 Next page

Displays the next set* of slices in the dataset.

 Last page

Displays the last set* of slices in the dataset.

 Go to active 
slice

Displays the currently selected slice.

Go to slice Specifies which slice you want to display. Type a number in this box and 
then select Enter to display the slice. The slice then appears in the lightbox 
view.

Image window Displays an individual slice in the dataset. To select a slice, click once on the 
slice. A thin red line appears around the slice inside the border.

Border Outlines each slice. 

Background Provides the grid for the images in the window.

Figure 155.  Image window showing the lightbox view (continued)
*The set of slices depends on the number of slices currently being displayed. For example, if four slices are currently 
displayed, then View > Previous Page shows the previous set of four slices. If seven slices are currently displayed, then 
View > Previous Page displays the previous seven slices in the dataset. View > Next Page works similarly. It displays the 
next set of slices in the dataset.
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Adjusting the lightbox view
By default, the lightbox view shows only one column of images. Each image 
in the dataset is surrounded by frame borders and background (Figure 36). 
However, you can adjust the lightbox view so that you can see several 
columns and rows of images at a time (Figure 36) in a grid. You can also 
adjust the borders and the default magnification level of the images.

To change the grid configuration

1 Select Options > Settings in the image window for the lightbox view. The 
Lightbox Settings dialog box (Figure 37) appears.

Figure 156.  Lightbox view after increasing the number of rows and 
columns that appear in the window
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2 Select Row.

3 Type the number of rows you want to appear in No. rows.

4 Select Column.

5 Type the number of columns in No. columns.

6 Click Apply. Notice that the number of rows and columns in the lightbox 
view changed to the numbers you specified.

Row Selects the row settings.

Column Selects the column settings.

No. rows Specifies the number of rows that 
should exist in the lightbox view.

No. columns Specifies the number of columns 
that should exist in the lightbox 
view.

Grid size Indicates the spacing in pixels 
used for the grid size.

Frame border slice Indicates the spacing in pixels 
used in the grid.

Background color Allows you to choose the color of 
the background of the lightbox. 
When you select this icon, the 
Pick Background Color dialog box 
opens.

Border color Allows you to choose the color of the border that surrounds each image 
displayed in the lightbox. When you select this icon, the Pick Border Color 
dialog box opens.

Magnification Controls the level of magnification. 

Apply Applies the parameters that you specified to the lightbox view.

Reset Returns all of the parameters to their default values.

Close Closes this dialog box without making changes to the lightbox view. If you 
changed the parameters in this dialog box, you must first select Apply to put 
those changes into effect.

Help Displays online help for this dialog box.

Figure 157.  Lightbox Settings dialog box
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7 Continue to make changes to other lightbox settings. 

8 Click Close to close the Lightbox Settings dialog box. 

9 Click Options > Save Settings to save the settings as the default number 
of rows or columns for the next time you display the lightbox view.

To change the grid size

1 Select Options > Settings in the image window for the lightbox view. The 
Lightbox Settings dialog box (Figure 37) appears.

2 Type a number from 0 to 20 in Grid size (Figure 38). 

Note: On the right of the Grid size text box, Grid spacing shows the current grid 
size.

3 Click Apply. Notice that the grid size in the lightbox view changed to the 
size that you specified.

4 Continue to make changes to other lightbox settings, or click Close to 
close the Lightbox Settings dialog box. The image window for the 
lightbox view appears.

5 Click Options > Save Settings (Figure 39) to save the settings as the grid 
size for the next time you display the lightbox view.

Figure 158.  Grid size box 
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To change the border size

1 Select Options > Settings in the image window for the lightbox view. The 
Lightbox Settings dialog box (Figure 37 on page 51) appears.

2 Type a number from 0 to 10 in Frame border size (Figure 41). The unit 
of measurement for the number is in pixels.

Figure 159.  Save Settings command on the Options menu in the 
Lightbox Settings dialog box

Figure 160.  Grid and frame border
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3 Click Apply. On the right of Frame border size, Border size changed to 
the size you specified.

4 Continue to make changes to other lightbox settings, or click Close to 
close the Lightbox Settings dialog box. 

5 Click Options > Save Settings to save the settings as the default border 
size for the next time you display the lightbox view.

To change background and border colors

1 Select Options > Settings in the image window containing the lightbox 
view. The Lightbox Settings dialog box (Figure 37 on page 51) appears.

Notice that Background color displays the color of the current grid 
border, and Border Color shows the color of the current frame border.

2 Click the background color bar (Figure 42). 

The Pick Background Color dialog box (Figure 43) opens.

Figure 161.  Frame border size box

Figure 162.  Background color and border color bars 
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This dialog box includes three tabbed pages: 

• Swatches page (Figure 43), which, by default, is always displayed 
first

• HSB page (Figure 43)
• RGB page (Figure 43)

You can change the color of the background on any of these pages
.

3 Select a color from the Swatches, HSB, or RGB page. (For instructions 
on how to select colors, refer to “Manually creating a mask using paint” 
on page 279 in  Chapter 6, “Segmenting Images Using Contours and 
Masks”).

Figure 163.  Swatches page in the Pick Background Color dialog box
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4 Click OK to apply the color to the background or border. 

The Pick a Background Color dialog box closes, and the Lightbox 
Settings dialog box appears.

5 Click Apply. 

Notice that the color of the background or border colors in the lightbox 
view changed to the colors you specified.

Figure 164.  HSB page in the Pick Background Color dialog box

Figure 165.  RGB page in the Pick Background Color dialog box
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6 Continue to make changes to other lightbox settings, or click Close to 
close the Lightbox Settings dialog box. 

7  Click Options > Save Settings in the lightbox view to save the settings as 
the default background and border colors for the next time you display 
the lightbox view.

To change the default magnification level for one 
slice in the dataset

1 Click . 

2 Right-click on the image. The Magnification dialog box (Figure 46) 
opens.

3 Change the magnification level by sliding the marker on the 
Magnification slider to the level you want.

4 Select Display intensity values if you would prefer to see the intensity 
values in the magnified region rather than the magnified image.

5 Type a number from 64 to 390 to enlarge or reduce the size of the 
magnified region.

6 Click Apply. The settings specified in the Magnification dialog box take 
effect immediately and only for that one image, or slice.

Figure 166.  Magnification dialog box
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To enlarge or reduce the size of all images 

1 Select Options > Settings in the image window containing the lightbox 
view. The Lightbox Settings dialog box opens (Figure 37 on page 51).

2 Select the level of magnification by moving the slider right or left to the 
appropriate value.

3 Click Apply. Notice that the image magnification changed to the 
magnification you specified.

4 Continue to make changes to other lightbox settings, or click Close to 
close the Lightbox Settings dialog box. 

5 Click Options > Save Settings in the lightbox view to save the settings as 
the default magnification for the next time you display the lightbox 
view. 

Tip: To return to the original settings for the lightbox view, click Reset in the 
Lightbox Settings dialog box.

In the example shown in Figure 47, the researcher changed the original 
lightbox view (Figure 47A) in several ways. The number of rows was 
increased from two to four and the number of images in each row from two 
to three. The frame border color was changed from yellow to gray and the 
grid color from blue to black. Also the magnification level of the images was 
reduced to 38 percent of the original image size. Figure 47B shows the final 
lightbox view.

Repainting (updating) the lightbox
You can simultaneously display the same dataset in different views on your 
desktop. For example, you can display the dataset in default view and in 
lightbox view. If you perform an action on the dataset that is visualized in 
default view, such as contour a structure, you can update the dataset display 
so that the contours also appear in lightbox view. You can do this 
automatically or manually.

To automatically update the dataset in the image 
window

Select Options > Continuous Update in the lightbox view. The dataset is 
refreshed whenever a change occurs in the default image window. 
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Caution: Although this option is convenient, it may slow software 
response time if you are working with a large dataset.

To manually update the dataset in the image window

Click , the Repaint icon, from the toolbar in the lightbox view.

To close the Lightbox window

Click  in the upper right corner of the Lightbox window. A confirmation 
message (Figure 48) appears. To close the window, click Yes and the 
Lightbox window closes. If you change your mind about leaving the lightbox 
view, click No.
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.

Figure 167.  Some of the display options available in lightbox view: 
(A) original lightbox view (image on the left) and (B) changed lightbox view (image on the 
right).

Figure 168.  Lightbox Close message
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Displaying images using the link to another 
image view

At times you may want to compare two images slice by slice side by side. 
Linking one image to another allows you to make this type of detailed 
comparison.

To compare images side by side

1 Open the two images you want to compare.

2 Select one of the images. This image becomes known as Image A, and 
the second image becomes known as Image B.

3 Select Image > Views > Link to Another Image. The Image Frame 
Linker dialog box opens.

4 Select the name of the second image, or Image B, in the Image B box.

5 Click Link. MIPAV immediately connects the images.

6 Move the Image slice slider in the MIPAV window. Notice that the 
image slices change on both images so that Image B shows the exact 
same slice as shown on Image A.

Tip: Select Image B, and move the Image slice slider. Although the slices change 
in Image B, they do not change in Image A. The reason is that only Image A 
controls the simultaneous movement of slices for both images. Therefore, when 
you select an image to be Image A, make sure that the image is the one you 
want to control the movement of both images.

 

Image A Indicates the name of the Image A file. This field is a 
read-only field.

Image B Allows you to choose the open image that you want to 
use as Image B.

Link Links the two image files.

Cancel Disregards any changes you made in this dialog box, 
closes the dialog box, and does not link the images.

Help Displays online help for this dialog box.

Figure 169.  Image Frame Linker dialog box 
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Displaying images using the triplanar view

The triplanar view allows you to see three orthogonal planes of 3D or 4D 
datasets. The three orthogonal views enhance the visualization of important 
aspects of the anatomy and, in some cases, aids some manual segmentation 
processes.

Displaying image datasets in triplanar view
To view an image dataset in triplanar view, open an image and then select 
Image > View > Triplanar in the MIPAV window. The triplanar view 
(Figure 50 on page 62) appears in an image window.

The image window for the triplanar view includes a File menu, an Options 
menu, a toolbar, and three views of the dataset. The bottom right corner of 
the window displays the currently selected coordinate. Two guidelines 
(cross hairs) also intersect at the selected point. Additionally, the axis 
appears in the upper left corner in each view of the dataset.

You can use icons and buttons on the toolbar to change the magnification 
level, draw a point or line, apply paint, and apply a new intensity values to 
selected voxels in the image.

Designating new center points for image datasets
You can designate a new center point for the dataset. To do this, complete 
the following steps:

1 Click , the Volume Center icon, to display the center of a volume. The 
cross hairs intersect where the center of the volume has been calculated.

2 Drag the cross hairs to the point that you want to designate as the new 
center.

3 Release the mouse button.

4 Click Apply. The Apply Transformation Matrix dialog box (Figure 51 on 
page 65) opens.

5 Complete the dialog box.
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File Close frame—Closes this window.

Figure 170.  Image window showing the triplanar view
MIPAV User’s Guide, Volume 1, Basics 228

9/20/04 



M   I   P   A   V
M e d i c a l   I m a g e   P r o c e s s i n g, A n a l y s i s,   &   V i s u a l i z a t i o n

Chapter 6,  Visualizing Images
Options Show Axes—Displays the XY (top left), ZY (top right), and ZX (bottom 
left) axes on the images.

Show Cross Hairs—Displays cross-hair lines on the images. When you 
move these lines on one image, it also moves to the corresponding points 
on the other two images. Notice that the Absolute and Position values at 
the bottom right of the screen also change when you move the cross 
hairs.

Show Talairach Grid—Displays a Talairach (stereo tactic) grid on the 
images.

Show Talairach Position—Lists the Talairach position. 

Link to Another TriImage—Links this image to another image in 
triplanar view.

 Traverse image
Aligns two images. 

 Magnify

Magnifies the image. It might be necessary to manually resize the 
window and use scroll bars to view all of the image.

 Minify

Minifies the image (reduces the magnification level).

 Original                          
magnification

Displays image at the original magnification level.

 Volume center

Reassigns a new center to the dataset. The location that you select 
appears in the center of the image window.

 Alignment tool

Allows you to apply a transformation matrix to an image dataset.

 Apply

Applies the rotations and translations made to the image. 

 Point

Draws a point on an image.

 New Contour

Assigns the subsequently drawn contour to a new group. If this icon is 
not selected, all subsequent contours are assigned to the existing group.

 Delete

Deletes a single contour or a group of contours. 

Caution: When you select this icon, the contour is not copied to the 
clipboard. It is permanently deleted.

Figure 170.  Image window showing the triplanar view (continued)
MIPAV User’s Guide, Volume 1, Basics 229

9/20/04 



M   I   P   A   V
M e d i c a l   I m a g e   P r o c e s s i n g, A n a l y s i s,   &   V i s u a l i z a t i o n

Chapter 6,  Visualizing Images
 Crop Volume

Indicates the volume that should be cropped. 

 Crop

Crops the specified volume.

 Paint Brush

Selects paint brush tool. You can use the paint brush to fill specific voxels 
with color. 

 Eyedropper

Changes the default intensity to the one sampled by the eyedropper. 
Click this icon, then move the pointer to the image. The sampled 
intensity becomes the default intensity.

 Paint Grow

Applies the paint grow segmentation method. This method uses voxel 
aggregation to group voxels into larger regions. The effect is much like a 
fill operation; when you click a voxel, this algorithm is used to determine 
whether adjacent voxels should be filled with the default color or 
intensity.

 Erase

Deletes painted sections of the image. To delete, click the icon and move 
the pointer on painted areas of the image.

 Global Erase

Deletes all paint from the image.

 Small Tip

Used with the paint brush and erase icons. Click this icon to indicate the 
size of the eraser or the paint brush tip. Click this icon to paint or erase 
one voxel each time the mouse button is clicked.

 Medium Tip

Used with the paint brush and erase icons. Click this icon to indicate the 
size of the eraser or the paint brush tip. Click this icon to paint or erase 
16 voxels (4 x 4 square) each time the mouse button is clicked.

 Large Tip

Used with the paint brush and erase icons. Click this icon to indicate the 
size of the eraser or the paint brush tip. Click this icon to paint or erase 
100 voxels (10 x 10 square) each time the mouse button is clicked.

 Paint Intensity

Indicates the intensity value.

 Change Paint 
Color

Changes the color of the paint used. This icon is often used in conjunction 
with the Paint Brush and Paint Grow icons. Click this icon and select the 
desired color from the window that appears.

 Opacity

Indicates the opacity level of the paint. When this icon is clicked, a 
window appears that allows you to indicate the opacity of the paint: 0 is 
transparent, 1 is opaque. By default the paint is translucent (0.3), which 
allows you to see the original image under the paint.

Figure 170.  Image window showing the triplanar view (continued)
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6 Click Apply. A progress message appears as the image is transformed. In 
a fewmoments, the new image either appears in a new window or 
replaces the image in the current window depending on your choice. 

7 Select  again. Notice that the image center was moved to the center 
you designated.

 Commit

Permanently applies intensity level to the image.

Figure 170.  Image window showing the triplanar view (continued)

Interpolation Determines the intensity of the 
additional voxels using one of the three 
following methods:
Bilinear—Weighs the average of the 
four nearest voxels (to the newly 
interpolated voxel). The interpolated 
voxel is assigned the resulting intensity.

Bspline 3rd order—Weighs the 
average of the 27 nearest voxels (to the 
newly interpolated voxel).

Bspline 4th order—Weighs the 
average of the 64 nearest voxels (to the 
newly interpolated voxel).

New image Indicates where the results of the transformation appear. If you select this option, 
the transformed image appears in a new image window.

Replace image Indicates where the results of the transformation appear. If you select this option, 
the transformed image replaces the current active image. 

Apply Applies the transformation to the image dataset according to the specifications in 
this dialog box.

Cancel Disregards any changes that you made in this dialog box and closes this dialog 
box.

Help Displays online help for this dialog box.

Figure 171.  Apply Transformation dialog box showing choices in the Interpolation list
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Aligning image datasets

You can use , the Alignment Tool icon, to create a new transformation 
matrix for the dataset (refer to Figure 52). 

The following instructions explain how to use the alignment tool:

1 Click . A closed angle, which looks like a line that is slightly thicker 
on one end, appears on each of the three images displayed in triplanar 
view.

2 Click the angle. Arrows appear at the end of each ray. The measurement 
of the angle appears beneath the angle.

Figure 172.  Using the alignment tool in triplanar view
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3 Open the angle. The angle degree indicates the direction and distance to 
rotate the image. You can open the angle with or without constraints. (If 
an angle is opened with constraints, it only opens in 90-degree 
increments.) Do the following:

• To open the angle in 90-degree increments: Position the pointer 
over the shorter ray of the angle. The pointer changes to a cross-hair 
shape. (The cross-hair pointer looks much like a plus sign.) Drag the 
shorter ray to the desired location. The new angle measurement 
appears below the angle.

• To open an angle without constraints: Position the pointer over the 
longer ray of the angle. The pointer changes to a cross-hair shape. 
The cross-hair pointer looks much like a plus sign. Drag the longer 
ray to the desired location. The new angle measurement appears 
below the angle.

4 Click Apply. The Apply Transformation Matrix dialog box (Figure 51 on 
page 65) appears.

5 Complete the dialog box.

6 Click Apply. 

A progress message appears as the image is transformed. In a few 
moments, depending on your choice in the dialog box, the new image 
either appears in a new window or replaces the image in the current 
window.

7 Click , the Traverse Image icon, to return the cursor to normal mode.

Creating, modifying, and deleting point VOIs
You can create, modify, and delete a point VOI. For more information on 
how to do this, see Chapter 7.
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Cropping images
To crop an image, complete the following steps:

1 In an image window that is displaying the image dataset in triplanar 

view, click , the Crop Volume tool. 

2 Draw a rectangle around the area of the image that you want to remain. 
The area outside of the rectangle will be cropped.

3 Click . A confirmation box appears.

4 Click Apply. The cropped area appears in a separate window. 

Changing the intensity
For information on how to change the intensity of a portion of the image, 
refer to “To change the number of intensities displayed in the LUT” on 
page 29 and “To invert intensities” on page 31. In addition, refer to 
“Generating masks” on page 196 in Chapter 6.

Displaying images using the triplanar-dual view

The triplanar-dual view displays two image datasets (referred to as Image 
A and Image B) and a blended version of both Image A and Image B from 
three orthogonal planes.

To view image datasets using this view

1 Open two 3D or 4D images, which become known as Image A and Image 
B.

2 Load Image B into Image A.

3 Select Image > Views > Triplanar-Dual. The triplanar-dual view appears 
in an image window.
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The image window for the triplanar-dual view is quite similar to the image 
window for the triplanar view. The File and Options menus contain the 
same commands except for one command—the Options menu for the 
triplanar view contains the command Link to Another TriImage. Since the 
triplanar-dual view shows two datasets in the image window and allows you 
to manipulate them together, linking to another image is not necessary. 
Most of the icons and buttons on the toolbars for both views are the same 
with one primary difference: The triplanar-dual view allows you to create 
VOIs on the images; the triplanar view does not.

Like the triplanar view, you can use the icons and buttons on the toolbar to 
change magnification, draw, change colors, change opacity, and apply a new 
intensity to selected voxels in the images.

Figure 173.  Image A, Image B, and Image B loaded into Image A
MIPAV User’s Guide, Volume 1, Basics 235

9/20/04 



M   I   P   A   V
M e d i c a l   I m a g e   P r o c e s s i n g, A n a l y s i s,   &   V i s u a l i z a t i o n

Chapter 6,  Visualizing Images
Showing and hiding axes, cross hairs, and Talairach 
grid

By default, the triplanar-dual view automatically shows the axes and cross 
hairs on Image A, Image B, and the blended dataset. 

To show or hide axes on images

To hide the axes, select Options > Show Axes (Figure 54). The check mark 
disappears from the check box in front of the command on the menu, and 
the axes disappear from all of the images.

To display the cross hairs on the images again, simply select Options > 
Show Axes. The check mark reappears in the check box in front of the 
command.

To show or hide cross hairs

Showing or hiding cross hairs works just as showing or hiding axes. To hide 
the cross hairs, select Options > Show Cross Hairs. To show them, select 
Options > Show Cross Hairs again. 

To show or hide the Talairach grid

By default, the Talairach grid does not automatically display on the images 
unless you specifically select it to do so. To show the grid, select Options > 
Show Talairach Grid. The grid appears on all of the images shown in the 
triplanar-dual view. When you want to hide the grid, select Options > Show 
Talairach Grid again.

Figure 174.  Show Axes command on the Options menu in the Triplanar-
Dual window
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Creating VOIs on images
You can create point or line VOIs on the images.

To create point VOIs

1 Click .

2 Click in the image where you want to create a point.

3 Repeat steps 1 and 2 for all other desired points.

To draw line VOIs

1 Click .

2 Click in the image where the line should begin and drag the line to 
where it should end.

The numbers beneath the line indicate the length of the line in 
millimeters.

To change the line VOI, simply click on the VOI and then drag it to 
another position in the image.

Note: You can only create one line VOI per orthogonal plane, although you can 
create a line VOI in each one of the three orthogonal planes.

To delete line VOIs

You cannot delete a line VOI. However, you can remove the display of the 

line VOI on the image. To do so, click . The line VOI disappears.
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File Close Frame—Closes this window.

Options Show Axes—Displays the XY (top left), ZY (top right), and ZX 
(bottom left) axes on the images.

Show Cross Hairs—Displays the cross-hair lines on the images. 
When you move these lines on one image, it also moves to the 
corresponding points all of the other images.

Show Talairach Grid—Displays a Talairach (stereo tactic) grid on 
the images.

 Traverse image

Aligns two images. 

 Magnify image 2.0x
Enlarges the images to twice their current size. It might be 
necessary to manually resize the window and use scroll bars to view 
all of the images.

Figure 175.  Triplanar-Dual window 
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 Magnify image 0.5x

Reduces the images to half of their current size.

 Magnify image 1.0x

Restores the images to their original size.

 Draw line VOI

Draw a line VOI.

 Identify center of 
volume

Reassigns a new center to each dataset. The location that you 
select appears in the center of each image.

 Alignment tool

Allows you to apply a transformation matrix to an image dataset.

 Applies rotations and 
translations

Applies the rotations and translations made to the images.

 Add point

Draws a point on an image. This point is only on the image you 
select.

 Initiate new VOI

Indicates that the next VOI is a new VOI rather than a change to 
the currently existing VOI.

 Delete point VOI

Removes the point VOI from the image.

 Identify crop volume

Displays the bounding box, which is outlined in red, on each image.

 Crops image 
delineated by the bounding 
cube

Displays in a separate image window only the area enclosed by the 
bounding box. When you click this icon, the Crop Image dialog box 
opens.

 Draw using a brush
Allows you to draw with a brush on the image.

Figure 175.  Triplanar-Dual window  (continued)
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 Picks up a color from 
the image

Changes the color of the paint used to the color selected on the 
image.

 Fills an area with 
desired color

Allows you to fill an area with color. When you select this icon, the 
Paint Grow dialog box opens.

 Erases a portion of the 
image

Removes the paint from the specific spot that you select.

 Erase all paint

Removes all paint from all of the images.

 Draw using small size

Indicates the size of the paint brush tip. Click this icon to paint one 
voxel each time the mouse button is clicked.

 Draw using medium 
size

Indicates the size of the paint brush tip. Click this icon to paint 16 
voxels (4 x 4 square) each time the mouse button is clicked.

 Draw using large size

Indicates the size of the paint brush tip. Click this icon to pain 100 
voxels (10 x 10 square) each time the mouse button is clicked.

 Change intensity level 
of paint

Allows you to change the intensity value of the paint. When you 
click this icon, the Desired Paint Intensity dialog box opens.

You can specify an intensity between -32,768 and 32,767. After you 
type an intensity level, the icon displays the level you entered.

 Change paint color

Changes the color of the paint used. This icon is often used in 
conjunction with the Draw icons. When you click this icon, the Pick 
Paint Color dialog box opens. After you change the color, this icon 
displays the color.

Figure 175.  Triplanar-Dual window  (continued)
MIPAV User’s Guide, Volume 1, Basics 240

9/20/04 



M   I   P   A   V
M e d i c a l   I m a g e   P r o c e s s i n g, A n a l y s i s,   &   V i s u a l i z a t i o n

Chapter 6,  Visualizing Images
To delete point VOIs

1 Click the first point on the image aligning the middle of the cursor with 
the center of the point.

2 Click . The point disappears.

3 Repeat the first two steps for every point you want to delete.

 Opacity

Allows you to change the opacity of the paint. When you click this 
icon, the Paint Opacity dialog box opens.

 Changes image 
where painted

Permanently applies the intensity level to the images.

 Undo last region 
paint

Removes paint from the last area to which it was applied.

 Calculate volume of 
paint

Determines the volume, or number of pixels, in the painted area of 
the image.

 Image A
Performs the action only on Image A.

 Image B

Performs the action only on Image B.

 Both
Performs the action on both Image A and Image B.

Figure 175.  Triplanar-Dual window  (continued)
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Aligning the datasets

The Alignment Tool icon, , allows you to create a new transformation 
matrix for the dataset.

1 Click . 

A closed angle appears on each of the images in the triplanar-dual view. 
On Image A, the angle is red; on Image B, it’s yellow; on the blended 
image, the angle is green.

2 Move the cursor to the arrow on the thin line to the right, and align the 
cursor with the end of the arrow. At this time, the cursor should be a red 
cross.

3 Change the size of the angle by dragging the arrow on the thin line up or 
down depending on the type of angle you want to create. The exact 
number of degrees appear on the left below the angle.

4 Release the mouse button when you reach the desired number of 
degrees.

Figure 176.  Closed angle that appears on each of the images
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5 Click on the image or on any other area of the triplanar-dual view. The 
arrows disappear from the angle.

6 Click on the angle again to be able to change the angle again. The arrows 
reappear and you can repeat the previous steps.

Finding the center of image datasets

To find the center of the dataset, click . The center of each image 

dataset, shown as , appears in each image in the triplanar-dual view.

Erasing part or all of drawings
If you used the paint brush to draw on the image, you may at times find a 
need to erase a part of the drawing or the entire drawing.

Caution: Make sure that you want to erase a part of the drawing or the 
entire drawing. There is no undo.

Figure 177.  Changing the angle by dragging the arrow on the thin line
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To erase a part of the drawing

1 Select the image that contains the drawing you want to erase. In other 
words, select Image A, Image B, or Both.

2 Click .

3 Click on the part of the drawing that you want to erase.

4 Repeat step 3 for as long as needed.

To erase all of the drawing

1 Select the image that contains the drawing you want to erase. 
Specifically, select Image A, Image B, or Both.

2 Click . MIPAV removes all of the paint from the image.

Cropping images
MIPAV allows you to extract the crop volume as a separate image, which is 
helpful if you need to work with or use only that portion of the image. The 
first step in cropping images is to identify what portion of the image is in the 
crop volume. Then you need to use the bounding cube for cropping the 
image.

To select the crop volume

1 Click . A red box appears on each image in the triplanar-dual view. 

2 Align the cursor with one of the corner points of the box, and enlarge or 
reduce the size of the box.

3 Repeat the previous step on each corner point as required to enclose the 
portion of the image you want to be included in the cropped image. 

The numbers on the sides of the box indicate the length and width of the 
box in millimeters.

Note: The size of the box changes proportionally on all of the images shown in 
the triplanar-dual view.
MIPAV User’s Guide, Volume 1, Basics 244

9/20/04 



M   I   P   A   V
M e d i c a l   I m a g e   P r o c e s s i n g, A n a l y s i s,   &   V i s u a l i z a t i o n

Chapter 6,  Visualizing Images
4 Release the mouse button when you are finished making changes to the 
box.

To crop images

1 Select one of the following:

• Image A if you want only the cropped area in Image A

• Image B if you want only the cropped area in Image B

• Both if you want both the cropped area in Image A and the cropped 
area in Image B

2 Click . The Crop Image dialog box appears.

3 Click Apply.

The cropped area in the image you selected appears in a separate image 
window. So, if you selected Image A only or Image B only, one image 
appears. If you selected Both, two image windows appear: one for Image 
A and one for Image B.

After you generate the cropped images, you can run algorithms on the 

Apply Applies the transformation to the image dataset 
according to the specifications in this dialog box.

Cancel Disregards any changes that you made in this dialog 
box and closes this dialog box.

Help Displays online help for this dialog box.

Figure 178.  Crop Image dialog box

If you selected . . . Then . . .

Image A The cropped area appears in a separate 
window. 

Image B The cropped area appears in a separate 
window.

Both Two small windows—one displaying the 
cropped area of Image A and the other 
displaying the cropped area of Image B—
appear.
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images, apply a quick LUT on the images, or use any other image processing 
that’s available in the MIPAV window on them.

Magnifying or minifying images
Like the image toolbar on the MIPAV window, the Triplanar-Dual window 
includes the following magnification icons:

• , the Magnify image 2.0x icon—To magnify images to twice 
their current size

• , the Magnify image 0.5x icon—To reduce images to half their 
current size

• , the Magnify image 1.0x —To restore their original size 

For information on how to use these icons, refer to “magnify or reduce a 
region of the image. You can magnify images to 32 times their original size, 
reduce them to one-fourth their original size, or restore them to their 
original size.” on page 13.

Drawing on images
You draw on images in the triplanar-dual view in the same way as you do in 
the MIPAV window. However, any of the changes you make on the 
triplanar-dual view are also made on the original images.

For example, if you highlight a particular area in the image in the triplanar-
dual view, the same change is made on all of the images in the triplanar-
dual view, but also on the images in the default view.

To change the paint color

Click , the Change Paint Color icon. The Pick Paint Color dialog box 
(Figure 43 on page 54) opens. For instructions on how to use this dialog box 
to change the paint color, refer to “To change background and border 
colors” on page 54.
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To change paint opacity

1 Click . The Paint Opacity dialog box opens.

2 Move the Opacity slider to the level of opaqueness you want. For 
example, to make the paint color more opaque, or solid, move the slider 
to the right. To make the paint color more transparent, move the slider 
to the left. 

3 Click Close when you have finished. The Paint Opacity dialog box 
(Figure 60) closes.

Figure 179.  Painting an area on images in the triplanar-dual view affects 
images in the default image view
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To calculate the volume of paint

The software can calulate the volume of a painted area in the number of 
pixels. To do so, do the following:

1 Paint the area of the image in which you are interested.

2 Click  to discover the volume of paint. The software lists the 
number of pixels in each image and the volume in millimeters on the 
Data page of the Output window.

3 Amend and save, as an option, the information on the Data page.

Opacity Indicates the opacity of the 
paint. The further right you 
move the slider, the more 
opaque the paint color. The 
further left you move the 
slider, the more 
transparent the paint color.

Close Closes this dialog box.

Figure 180.  Paint Opacity dialog box

Figure 181.  Output window after calculating the volume of paint
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To fill an area with color

1 Click . The Paint Grow dialog box opens.

2 Complete the dialog box.

3 Click Close.

To erase an area of paint from images

1 Click .

2 Click the area of the paint that you want to remove.

3 Repeat the previous step for each area of paint to be removed.

Cursor position and 
voxel intensity

Indicates the location of the cursor 
and the intensity value at that point

Delta above selected 
voxel intensity

Indicates the range of paint beyond 

Delta below selected 
voxel intensity

Indicates the range of paint 

Unrestricted size Limits the total volume in 3D or 4D 
images or area in 2D images

Maximum size (null) In development.

Unrestricted 
distance

Limits the distance from the seed 
point

Maximum size (null) In development.

Fuzzy connectedness Applies the fuzzy algorithm 

Initial variance from 
selected VOI

In development.

Display fuzzy image In development.

Fuzzy threshold In development.

Close Applies the parameters you 
specified

Cancel Disregards any changes that you 
made in this dialog box and closes 
the dialog box

Help Displays online help for this dialog box

Figure 182.  Paint Grow dialog box
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4 Click  when done to return the cursor to the default state.

To erase all painting from images

Click . MIPAV removes all of the paint from all of the images.

Displaying images using the surface plotter view

The surface plotter view illustrates the intensity levels according to height. 
In other words, the higher the intensity, the higher the height of the plotted 
image. The lower the intensity, the shorter the height of the plotted image.

If you select the animate view, the software makes a copy of the image 
dataset and loads it in the animate image window. In animate view, like cine 
view, the software automatically advances through the image dataset. 
However, animate view allows you to adjust the speed at which images are 
advanced. You can specify that images be displayed in forward or reverse 
order. You can also pause or loop the sequence.

To view an image dataset in animate view

1 Select Image > Views > Surface Plotter in the MIPAV window. The 
Height Surface window (Figure 63) opens.

2 Hold down the left mouse button and drag the mouse to the left, right, 
top, and bottom. This allows you to move the image in all directions. If 
you release the mouse button and then hold it down again while you 
move, you can turn the image upside down.
MIPAV User’s Guide, Volume 1, Basics 250

9/20/04 



M   I   P   A   V
M e d i c a l   I m a g e   P r o c e s s i n g, A n a l y s i s,   &   V i s u a l i z a t i o n

Chapter 6,  Visualizing Images
3 Hold down the middle button on the mouse and push the mouse 
forward. This makes the image smaller as if seen from a distance 
(Figure 64A). 

4 Hold down the middle button and push the mouse toward you enlarges 
the image so that you can examine it closely (Figure 64B).

5 Slide the marker on the height slider to determine the highest intensity 
in the image (Figure 64B).

File Exit—Closes the Height Surface 
window.

Options View Mode—In development.

Mouse Recorder—In 
development.

Line Mode—Displays the image 
as lines.

Resample—Improves the speed 
in animating the image by forming 
the image with fewer triangles.

Display Options—Allows you to 
add a bounding box, change colors 
of the bounding box and 
background, show an orientation 
cube, and choose the projection 
type: perspective or orthographic.

Time (Z) Turns on the ability to calculate the height of the intensities. When this item is 
selected, the height slider is available. By default, this check box is selected.

Height slider Shows the height of the intensities in the image. Slide the marker to the left to 
show lower level intensities. Slide the marker to the right to increase the level of 
intensities. The read-only box on the right indicates the actual height of the 
marker.

Image area Displays the plotted image. 

Figure 183.  Height Surface window
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Example: One way of determining the highest intensity in the image is to use 
the mouse to drag the image to its side, enlarge it using the middle mouse 
button and pushing the mouse toward you, and then sliding the height marker to 
the top of the tallest intensity. The level of the intensity appears in the box to the 
right of the height slider.

Figure 184.  Manipulating the plotted image in the Height Surface window 
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Displaying images using the surface renderer 
view

In development.

Displaying images using the volume shear view

In development.

Displaying images using the volume renderer 
view

In development.
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7 Segmenting Images Using Contours

and Masks
Segmentation is the process of identifying selected regions of images as 
members of a common group. Physicians routinely segment structures in 
medical images to facilitate the treatment of patients. The quantification of 
important attributes, such as the volume of various tissue types, enables 
researchers to better understand, diagnose, monitor, and treat 
neurobehavioral disorders.

MIPAV provides several segmentation tools that allow you to delineate a 
volume of interest (VOI). You can indicate a VOI by drawing a contour or by 
creating a mask. You can also calculate predefined statistics on the 
indicated VOI.

Note: Once a VOI is segmented, you can also apply an algorithm to the volume 
bound by the contours. MIPAV provides a number of algorithms, such as 
Gaussian blur, Laplacian, threshold, and watershed. These algorithms and others 
are addressed in detail in volume 2 of the User’s Guide.

Understanding contours and masks

Before you indicate a volume of interest, it is helpful to determine whether 
to delineate the VOI by drawing a contour around a structure or to generate 
a mask. 
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A contour is an array of points. If the contour is a closed polygon, the area 
inside defines the VOI. Contours are scalar and can be grouped to form a 
single multicontoured VOI. Contours are particularly useful if you want to 
save a VOI that covers a large area because the resulting file is generally 
smaller than a comparable mask file.

A mask is a filter that selectively includes or excludes certain values. You 
can create a mask that includes the VOI areas and excludes all other areas. 
Masks are particularly helpful if you use other image analysis programs that 
require you to supply a mask. Masks are also helpful if you need to indicate 
a complex area of interest. MIPAV allows you to generate binary and short 
image type masks. Also, you can manually create masks using paint tools.

Using contours to segment a VOI

A VOI can consist of a single contour or several contoured structures that 
are assigned to a group. You can automatically, manually, or interactively 
draw contours on any image that is shown in the default view. You can 
modify the shape and size of a contour and trim anchor points. Once 
contours are drawn and modified, you can copy them to other slices in the 
dataset or save them to a separate file for future use.

The three overall tasks involved in using contours to segment a VOI are:

• Drawing contours (“Drawing contours” on page 255)

• Modifying contours (“Modifying contours” on page 265)

• Grouping and ordering contours (“Grouping and ordering contours” 
on page 270)

Drawing contours
You can draw contours using three different methods: manual, interactive, 
or automatic. With the manual method, you use the mouse to draw a 
contour. This method provides the greatest amount of freedom: you can 
choose one of MIPAV’s predefined shapes or create a freehand shape. 
However, the manual method can be time consuming, particularly if the 
structure to be contoured is intricate. With the interactive method, you 
must also manually contour the structure. However, in this case the 
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manually drawn contour need not be precise because you then apply an 
algorithm that generates a new contour based on both the manually drawn 
contour and the structure. With the automatic method, MIPAV generates 
contours as you move the mouse over different structures. The automatic 
method is generally accurate and quick; however, it does not provide the 
freedom of the manual method. 

Recommendation. If you are unsure about which contour method to use, it 

is recommended that you try the automatic method first.

CONTOURING STRUCTURES AUTOMATICALLY

In this method, you move the mouse pointer over a structure. MIPAV first 
analyzes the intensity values and then contours what it perceives to the 
contour boundary. 

Complete the following steps:

1 Select VOI > New VOI > Levelset in the MIPAV window.

2 Move the mouse pointer to the image.

The pointer changes to the cross-hair shape. As you move the pointer, 
MIPAV determines the level of intensity of the pixel under the cross-
hair pointer and uses the results from the Levelset algorithm to 
determine the probable boundary of the structure. Having determined 
the probable boundary, MIPAV generates a contour (Figure 185). 
Continue to move the pointer until the structure you wish to outline is 
contoured.
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3 Click the contour to apply it to the structure.

4 You can now do the following:

• Draw an additional contour 

• Modify the contour 

• Reassign an existing contour to a different group 

• Order the contours 

• Delete the contour 

CONTOURING STRUCTURES MANUALLY

You can contour structures in images by selecting one of MIPAV’s 
predefined shapes, such as a point, straight line, 2D or 3D rectangle, and 2D 
ellipse. Alternatively, you can use the polygon and polyline tools to draw 
freehand shapes. This section explains how to draw the following:

• Point VOIs

• VOIs with a straight line

• 2D rectangular VOIs

• 3D rectangular VOIs

• Ellipsoidal VOIs

• Polyline (segmented line) and closed polygon VOIs

Figure 185.  Automatically generated contour
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Tip: Before you begin, decide whether you want to draw more than one of the 
same contour in succession. If you do, hold down the Shift key as you select the 
contour button and draw the contours.

To draw point VOIs

1 Select , the Draw point VOI button, in the MIPAV window. 

2 Move the pointer to the image.

3 Click the area where you want the point to appear. A numbered point 
appears on the image. 

Note: For some algorithms, the sequence in which you draw the points is 
important (refer to volume 2 of the User’s Guide). 

To create VOIs with a straight line

1 Click , the Draw line VOI icon.

2 Click the area on the image where you want the line to begin.

3 Drag the pointer to the place where you want the line to end. As you 
drag the pointer, the line lengthens.

4 Release the mouse button. The line VOI appears on the image in red 
(Figure 186).
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To create 2D rectangular VOIs

1 Click , the Draw rectangle VOI icon.

2 Click the area on the image where you want a corner of the rectangle to 
appear.

3 Drag the pointer. As you drag the pointer, the rectangle changes in size.

4 Release the mouse button when the rectangle is the desired size.

     

Figure 186.  VOI with straight line
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Note: When you create a 2D rectangular VOI, the rectangles appear on only one 
slice in the dataset.

To create 3D rectangular VOIs

1 Click , the 3D rectangular VOI icon.

2 Click the area on the image where you want a corner of the rectangle to 
appear.

3 Drag the pointer. As you drag the pointer, the rectangle changes in size.

4 Release the mouse button when the rectangle is the desired size.

Note: Unlike 2D rectangular VOIs, 3D rectangular VOIs appear on all slices in 
the dataset.

To create ellipsoidal VOIs

1 Click , the Draw ellipse VOI icon.

2 Click the area of the image where you want an edge of the ellipse to 
appear.

3 Drag the pointer. As you drag the pointer, the ellipse changes in size.

Figure 187.  Example of a 3D rectangular VOI
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4 Release the mouse button when the ellipse is the desired size 
(Figure 188).

To create polyline (segmented line) VOIs or closed 
polygon VOIs

1 Click , the Draw polygon/polyline VOI icon.

2 Click the area of the image where the polyline VOI should begin.

3 Decide whether to draw either a straight or freehand line segment. Do 
one of the following: 

• To draw a straight line segment 

a Make sure that you have released the mouse button.

Move the pointer to the place where you want the segment to end. A 

straight line, which extends from the starting place to your pointer tip, 

appears. 

Click the mouse button to anchor the line segment.

• To draw a freehand line segment 

a Drag the mouse button and move the pointer to the place on the image 
where you want the segment to end. A line, which matches your mouse 
movements, extends from the starting place to your pointer tip. 

Click the mouse button to anchor the line segment.

Figure 188.  Ellipsoidal VOI
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4 Repeat drawing straight line segments or freehand lines until you finish 
drawing all of the segments needed to contour the structure. 

5 Decide whether to create a polyline VOI or a closed polygon VOI: 

• Polyline VOI: Go to the next step.

• Closed polygon VOI: Click the first anchor point to connect the last 
line segment to the first, thus forming a closed polygon. Then go to the 
next step.

6 Click , the Default icon, to return the pointer to the default mode.

Tip: Depending on which is more comfortable, you can switch between drawing 
straight line segments or drawing freehand lines at any time.   

7 Double-click the mouse button to complete the polyline VOI 
(Figure 189).
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Figure 189.  Polyline VOI (A) and closed polygon VOI (B)
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CONTOURING STRUCTURES INTERACTIVELY

In the interactive method, you first manually draw a contour that provides a 
general indication of the location and shape of the structure. You then select 
an algorithm that analyzes the manually drawn contour and generates a 
new one that more closely outlines the structure. 

To use the interactive method to contour structures, complete the following 
steps:

1 Draw a contour using one of the manual methods detailed in 
“Contouring structures manually” on page 257. The contour need not be 
precise, but it should indicate the general location and shape of the 
structure you want to delineate. 

2 Select the contour. White anchor points appear on the contour outline.

3 Select one of the following in the MIPAV window: 

• VOI > Evolve Boundary 2D > Active Contour. This algorithm 
determines the structure's boundary more quickly than the 2D 
Spline Active Contour algorithm. It is also more sensitive to noise 
present in the image. MIPAV applies a gradient magnitude filter to 
determine the structure's boundary. When complete, the MIPAV-
generated contour appears around the structure.

• VOI > Evolve Boundary 2D > Active GVF. [TBD]

• VOI > Evolve Boundary 2D > Spline active contour. This algorithm 
determines the structure's boundary less quickly than the Active 
Contour algorithm and is less sensitive to noise. This algorithm fits a 
spline to the data. When complete, the MIPAV-generated contour 
appears around the structure.

• VOI > Evolve Boundary 2D > Spline GVF. [TBD]

4 Select one of the following options:

• Draw an additional contour
• Modify the contour
• Delete the contour
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Modifying contours
Once contours are drawn, you can reposition, resize, or reshape them. You 
can also trim anchor points.

REPOSITIONING CONTOURS

You can reposition a single contour or a group of contours. Follow the 
instructions below.

To reposition a single contour 

Select the contour and drag it to the new location.

To reposition a group of contours

1 Hold down the Shift key as you click one of the contours in the group. 
All of the other contours in the group are also selected.

2 Continue to hold down the Shift key as you drag the contour group to 
the new location.

RESIZING CONTOURS

You cannot collectively resize a group that consists of multiple contours; 
each contour must be resized individually. Except for point VOIs, you can 
resize any contour shape. For lines, only the length can be changed; the 
width cannot.

Before you can resize them, all contour shapes except lines must be 
surrounded by a bounding box. Go to the following section ‘‘To turn the 
bounding box on’’.

To resize lines, go to ‘‘To resize contours’’.
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To turn the bounding box on

1 Do either of the following:

• Select the contour and then select VOI > Properties in the MIPAV 
window. 

• Right-click the contour. A menu appears. Select Properties.

The VOI Statistics dialog box (Figure 190) opens.

2 Select Show contour bounding box.

Figure 190.  VOI Statistics dialog box
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3 Change, if you want, any of the other information in the dialog box.

4 Click Apply. 

5 Click Cancel to close the dialog box.

To resize contours

1 Select the contour. The bounding box appears (Figure 191) around the 
shape. (For rectangle contours, the bounding box and rectangle legs 
may overlap.) 

2 Click Cancel to close the window.

3 Do one of the following:

• To resize lines: Click an edge or corner of the shape. Drag until the 
shape is the desired size.

• To size other shapes: Click one of the bounding box handles. Drag 
the handle until the shape is the desired size. 

4 Choose whether to continue showing the bounding box. 

Figure 191.  Examples of a bounding box
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Note: If you want to reposition or add an anchor point, turn the bounding box 
option off. 

To turn the bounding box off

1 Do one of the following:

• Right-click the contour. Select Properties from the pop-up menu.

• Left-click the contour. Select Properties from the VOI menu in the 
MIPAV window.

The VOI Statistics dialog box appears (Figure 190 on page 266). 

2 Clear Show Contour Bounding Box.

3 Click Apply. 

4 Click Cancel to close the window.

RESHAPING A CONTOUR

You reshape the contour by adding or repositioning anchor points. 
Instructions for adding and repositioning anchor points follow.

To add anchor points

1 Click the contour to select it. The anchor points become visible.

2 Click the place where you want to add the new anchor point. The new 
anchor point appears.

To reposition anchor points

You can reposition a single anchor point at a time. If you need to redraw a 
portion of the contour, MIPAV allows you to reposition several contiguous 
anchor points with one motion of the mouse.

1 Select the contour. The anchor points become visible. 

2 Position the pointer over the anchor point or points that you want to 
reposition. The pointer changes to the shape of a hand with the index 
finger extended.
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3 Do either of the following:

• To reposition a single anchor point: Drag the anchor point to the 
new location.

• To reposition several anchor points: Hold down the Alt key as you 
drag the anchor points in the counterclockwise direction to their 
new locations.

TRIMMING VOI ANCHOR POINTS

MIPAV can automatically trim anchor points from the contour. In the 
trimming process, unnecessary anchor points are pruned. For example, if 
three anchor points are on the same line, the middle anchor point is deleted. 
Since only two anchor points are needed to indicate a line, the middle 
anchor point is extraneous. The trim parameter defines what is meant by 
the same line. Setting this value to zero causes only unnecessary anchor 
points on a straight 180-degree line to be pruned. Setting a higher value 
prunes all but the sharpest corners of the contour. 

To trim anchor points

1 Select the contour you want to trim.

2 Select VOI > Trim Parameter in the MIPAV window. The VOI Trim 
Parameter dialog box (Figure 192) opens.

3 Move the slider to the desired number.

Trim parameter Specifies the number of anchor points 
you want the software to trim from the 
contour. 

Setting this value to zero causes only 
unnecessary anchor points on a straight 
180-degree line to be pruned. Setting a 
higher value prunes all but the sharpest 
corners of the contour.

Trim adjacent 
points 

Trims points that are adjacent.

Apply Applies the parameters that you specified.

Figure 192.  VOI trim parameter dialog box
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4 Click Apply. The software removes all unnecessary anchor points.

5 Click Close to close the dialog box.

Grouping and ordering contours
The final step in the segmentation process is to group and order contours. 
The group, which can be composed of one or more contours, is commonly 
referred to as a VOI. Grouping can be an important component of the 
segmentation process. 

Example: A researcher might contour several structures. The researcher might 
then assign each contour to the gray.voi (gray matter), white.voi (white matter), 
or cerebfl.voi (cerebrospinal fluid) group. If groups overlap, the researcher can 
indicate which group should appear in the foreground by reordering the groups.

GROUPING CONTOURS

A group may consist of one or more contours. A contour is assigned to only 
one group. When a contour is initially drawn or generated, MIPAV assigns it 
to a default group. MIPAV also assigns default group properties, such as 
color and name. Each contour inherits the properties of its assigned group. 
At any time, you can change the properties of a group or its members 
(contours).

To change the group with which a contour is 
affiliated

1 Right-click the contour you wish to modify. 

2 Select Properties. The VOI Statistics dialog box (Figure 190) opens. 

The name of the VOI appears in the Name of VOI text box. A colored box 
appears beside the text box.

Close Disregards any changes that you made in this dialog box and closes the 
dialog box.

Help Displays online help for this dialog box.

Figure 192.  VOI trim parameter dialog box
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To change group properties

1 Select the colored box on the VOI Statistics dialog box. The Pick VOI 
Color dialog box opens.

2 Click OK to apply the color to the grid/border. The Pick VOI color dialog 
box closes.

3 Click OK.

• To change the name of the VOI, modify the name in the text box next 
to the Name of VOI colored box.

• To adjust the opacity, move the slider in the Opacity panel. The 
number in the center indicates the current value; 0 is transparent 
and 1 is opaque.

ORDERING CONTOURS

If two or more contours overlap, MIPAV organizes them so that they appear 
one on top of the other, much like a stack of papers on a desk. This is often 
not readily apparent because by default, when contours are drawn, they are 
transparent and only the outlines are visible. Thus, if two contours overlap, 
all parts of each contour, except the areas where the outlines overlap, can be 
seen.

To fill contours

1 Right-click the contour.

2 Select Properties. The VOI Statistics dialog box opens. 

3 Clear the Boundary or Blended check box to remove the check mark.

4 Click Apply. 

5 Close the VOI Statistics dialog box. The contour is filled with the default 
paint color. To change the paint color, refer to “Manually creating a 
mask using paint” on page 279.
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To reorder contours

1 Click the contour to be reordered.

2 Select VOI > Order in the MIPAV window. Then select one of the 
following commands:

• Bring to Front: Moves the contour in front of all of the other 
contours.

• Send to Back: Moves the contour behind all other contours.

Figure 193.  Boundary or blended check box in the VOI Statistics dialog
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• Bring Forward: Moves the contour forward one position. For 
example, if you select this command and the contour is the third 
contour in a stack of five contours, the contour is moved to the 
second position in the stack.

• Send Backward: Moves the contour backward one position. For 
example, if you select this command and the contour is the third 
contour in a stack of five contours, the contour is moved to the 
fourth position in the stack.

The software reorders the contours according to the command.

Copying, Cutting, and Pasting VOIs
You can undo, cut, copy, and paste a VOI within the image, to another slice 
in the image dataset, or to another image dataset.

To undo a VOI

1 Select the VOI.

2 Select Edit > Undo VOI (Figure 194) in the MIPAV window. The 
software removes the VOI from the image.

To cut a VOI 

1 Select the VOI.

2 Select Edit > Cut VOI (Figure 194) in the MIPAV window. The software 
copies the VOI to the clipboard and deletes it from the window.

Tip: You can also remove a VOI by pressing the Del key after selecting the 
VOI.

To copy a VOI

1 Select the VOI.

2 Select Edit > Copy VOI (Figure 194). It is copied to the clipboard.
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To paste a VOI

1 Select the VOI that you want to paste.

2 Select Edit > Copy VOI to copy the VOI to the clipboard.

3 Do one of the following:

• Navigate to another slice in the dataset using either , the 

Increments image slice icon, or , the Decrements image slice 
icon.

• Open another image dataset.

4 Select Edit > Paste VOI (Figure 194). The program copies the VOI from 
the clipboard and pastes it into the image.

You can only copy and paste one, not multiple, VOIs into another slice using the 
Paste command. Also, note that the software pastes a copied VOI into the image 
at exactly the place from which it was copied.

Figure 194.  Undo VOI, Cut VOI, Copy VOI, and Paste VOI commands on 
the Edit menu in the MIPAV window
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To copy multiple VOIs to the next or previous slice in 
the dataset

1 Select all of the VOIs that you want to copy.

2 Do one of the following:

• Click , the Propagate VOI up icon, to copy the VOI to the next slice.

• Click , the Propagate VOI down icon, to copy the VOI to the 
previous slice.

• Click , the Propagate VOI to all slices icon, to copy it to every image 
in the dataset.

Deleting VOIs
You can easily delete a VOI or one of its contours. 

To delete a VOI

1 Select the VOI or one of its contours. 

To delete a VOI that consists of many contours, hold down the Shift key 
and then click one of the contours in the VOI group.

2 Do one of the following:

• Right-click on the VOI, and then select Edit > Delete (Figure 195).

• Select Edit > Delete VOI in the MIPAV window.

The software removes the VOI or contour. 
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Saving and opening VOI files
You can save a VOI to a text file. This file can then be opened and applied to 
the same dataset or a different one, or it can be manipulated using a word 
processor.

To save a single VOI as a text file

1 Select a contour or a VOI.

• To select a contour, click on it.

• To select a VOI, hold down the Shift key and select a contour. All 
contours that are part of the VOI are selected.

2 Do either of the following:

• If you want the software to automatically name the file, select VOI > 
Save VOI in the MIPAV window. The software saves the file with a 
.XML extension.

• If you want to assign the file name, select VOI > Save VOI as. The Save 
as dialog box appears.

a Type the name of the VOI file in the File Name box. Be sure to use 
either the .VOI extension or the .XML extension.

b Click Save. The software saves the file under the specified name.

Figure 195.  Delete command on the pop-up menu
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To save multiple VOIs

Do either of the following:

• To allow the software to automatically name the file, select VOI > Save 
All VOIs. 

• To assign a file name to the file, select VOI > Save All VOIs as.

a Type the name of the VOI file in the File Name box. Be sure to use 
either the .VOI extension or the .XML extension.

b Click Save. The software saves the file under the specified name.

To open saved VOI files

1 Select the image window of the dataset to which you want to apply the 
VOI.

2 Select VOI > Open VOI in the MIPAV window. The Open dialog box 
appears.

3 Select the file or files and then click Open. The VOI or VOIs appear in 
the image window.

Note: If you make a change to the VOI and want to make a change to the file, 
select VOI > Save VOI in the MIPAV window. The changes are saved to the VOI 
file.

Generating masks

A mask is a filter that selectively includes or excludes certain values. You 
can create a mask that includes the VOI areas and excludes all other areas. 
Masks are particularly helpful if you use other applications to further 
analyze images because those programs may require that you supply a 
mask. An example of a mask appears in Figure 196.
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You can create masks using a variety of methods:

• Use paint tools to manually create a mask

• Use Paint Grow Segmentation tool

• Use binary or short mask utilities

MIPAV also provides algorithms that you can use to generate masks. These 
algorithms are addressed in volume 2 of the User’s Guide.

Figure 196.  Image with (A) a painted region and (B) the resulting mask
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Manually creating a mask using paint
You can manually create a mask using the tools on the Paint toolbar, which 
is located in the MIPAV window. To create the mask, you first select the 
intensity level of the paint, along with the paint color and opacity value. 
Next, you paint on the image using the paint brush. You can adjust the size 
of the paint brush tip. When complete, you then commit the paint by 
choosing one of the following icons:

• , the Changes image where painted inside icon

• , the Changes image where painted outside icon

When you click one of these icons, it applies the intensity permanently to 
the image. You can then choose to save the image.

If the Paint toolbar does not appear in the MIPAV window, select Toolbars. 
The Toolbar menu lists four commands: VOI Toolbar, Paint Toolbar, 
Scripting Toolbar, and Image Toolbar. If a toolbar command has a check 
mark next to it, the toolbar is displayed; otherwise, it is hidden. To display 
the Paint toolbar, select Paint Toolbar.

Figure 197.  Paint toolbar
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Manually generating a mask includes the following four steps:

• Step 1, Selecting the paint intensity level

• Step 2, Selecting a paint color

• Step 3, Adjusting the opacity level of the paint

• Step 4, Applying the paint

STEP 1, SELECTING THE PAINT INTENSITY 
LEVEL

The first step in manually creating a mask is to select the intensity level of 
the masked area.You can select the intensity level by using the eyedropper 
tool to select an intensity value that is already present in an image or by 
typing a specific intensity value in the Desired Paint Intensity dialog box.

To select the intensity level using the Eyedropper 
tool

The Eyedropper tool allows you to copy an intensity level that is already 
present in the image. To use this tool, complete the following steps:

1 Click , the Eyedropper icon, on the paint toolbar in the MIPAV 
window.

2 Click the area of the image that has the intensity level you want to copy. 

The intensity level button, , changes to the intensity level in the part 
of the image you selected.

Example: Initially, the intensity level button shows a zero on the button, . 
However, when you click an area of the image, it displays the number that is 

associated with that part of the image, such as 250, .
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To select the intensity level using desired paint 
intensity

You can enter a specific intensity level value in the Desired Paint Intensity 
window. To do this, complete the following steps:

1 Click , the Intensity button.

Note: If you changed the intensity level using the eyedropper or this button 
previously in your current MIPAV session, the number on the Intensity button 
would have changed from 0 to the number representing that earlier intensity 
level.

The Desired Paint Intensity dialog box opens (Figure 198).

2 Notice that the minimum and maximum intensity values appear in 
parentheses. These values depend on the image type, or data type, of the 
image.

Tip: You can look at the exact intensity levels in the image using , the 
Magnify region icon.

3 Type the desired level of intensity.

4 Click Apply to apply the intensity level to the paint. Note that the 
number on the Intensity button changes to the number you entered.

5 Click  or Cancel to close the dialog box.

Intensity Specifies the intensity, or strength, of the paint.

Apply Applies the intensity that you specified to the 
image.

Cancel Disregards any changes that you made in this 
dialog box and closes the dialog box.

Help Displays online help for this dialog box.

Figure 198.  Desired Paint Intensity dialog box
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STEP 2, SELECTING A PAINT COLOR

After you select the intensity level, the next step is selecting the paint color. 
The program applies this color to the image so that you can easily see where 
you applied the new intensity. When you commit the changes to the image, 
the grayscale intensity level that you indicated in step 1 is permanently 
applied to the image.

To select a color, use , the Change Paint Color icon, to display the Pick 
Paint Color dialog box (Figure 200). This dialog box includes three tabbed 
pages: Swatches page, which is always displayed first; the HSB page; and 
the RGB page. You can select a color on any of the pages.

To select a color from one of the 310 color swatches

1 Click , the Change Paint Color icon. The Pick Paint Color dialog box 
(Figure 199) opens.

2 Stay on the Swatches page, or, if you moved to HSB or RGB pages, click 
Swatches to return to the Swatches page.

3 Click the desired color in the larger grid. The color appears in the Recent 
color grid on the right.

4 Click Close when done. The Pick Paint Color dialog box closes. The color 
you selected becomes the current paint color.
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To select a color using the HSB model

1 Click , the Change Paint Color icon. The Pick Paint Color dialog box 
opens.

2 Click HSB. The HSB page appears (Figure 200B).

Color grid Shows the available colors. Select one of these colors and it appears in the Recent grid 
on the right.

Recent grid Indicates colors that you have recently selected from the color grid on the left. MIPAV 
uses the last color that you selected from the color grid and that appears in this grid 
as the color of the background in the lightbox view once you select OK. 

OK Applies the parameters that you specified to crop the image.

Cancel Disregards any changes you made in this dialog box, closes the dialog box, and does 
not crop the image.

Reset Returns the color settings to their previous values.

Help Displays online help for this dialog box.

Figure 199.  Swatches page in the Pick Paint Color dialog box
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3 Specify a color by entering specific numbers for the hue, saturation, and 
brightness values, or select the color from the color graphic.

Color square Specifies a specific color to be used as the background color.

Color strip Specifies a specific color to be used as the background color.

H Specifies the number representing the hue of the color.

S Specifies the number representing the saturation of the color.

B Specifies the number representing the brightness of the color.

R Specifies the number for the color used for the red channel.

G Specifies the number for the color used for the green channel.

B Specifies the number for the color used for the blue channel.

OK Applies the parameters that you specified to crop the image.

Cancel Disregards any changes you made in this dialog box, closes the dialog box, and 
does not crop the image.

Reset Returns the color settings to their previous values.

Help Displays online help for this dialog box.

Figure 200.  The HSB page in the Pick Paint Color dialog box
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Using the Hue, Saturation, and Brightness Color Model

The HSB color model defines colors by a 
combination of their hue, saturation, and 
brightness. 

The hue is the wavelength of light transmitted 
through or reflected from an object. The hue is 
more commonly known as color (such as 
magenta or green).

Below is the Munsell color wheel. A color strip, 
which is derived from the color wheel, appears 
as well. Hues are represented by the degrees in 
the color wheel. (Since colors are graduated, the 
degrees in the figure are approximations and not 
necessarily absolute values. 

For example, yellow is approximately 45 
degrees; 50 degrees is a different shade of 
yellow. 

Primary colors (red, yellow, and blue) combine to 
create secondary colors (magenta, cyan, and 
green).Tertiary colors, such as orange, are also 
represented on the color wheel.

The color strip is simply a different 
representation of the color wheel. Degrees and 
corresponding hues were added to the figure.

Saturation is the strength or purity of the hue. To 
lessen the saturation, gray is added to the color. 
Thus, if pure orange is 70 percent saturated, the 
hue is a mixture of orange (70 percent) and gray 
(30 percent).

Brightness is the relative darkness and lightness 
of a color; 0% brightness is black; 100% 
brightness is white.

Figure 201.  Munsell color wheel (left) and color strip (right)
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• Enter specific values into the H, S, and B boxes:

• Type the hue value in H. The hue can be any number from 0 to 
359. The numbers correspond to the degree numbers on the color 
square (Figure 201). For example, to specify a shade of blue, enter 
a number from 255 to 270. The slider automatically moves the 
correct hue on the color strip.

• Type the saturation value in S. The level of saturation can be 
anywhere from 0 (gray) to 100 (full-strength hue). When you type 
a value into this box, a circle appears in the color square around 
the color with the specified saturation level. Colors to the left of 
the color graphic are circled if the saturation level is high. Lower 
saturated colors are found to the left of the color graphic.

• Type the brightness value in B. The level of brightness can be 
anywhere from 0 (dark) to 100 (light). In the color graphic, a 
circle appears around the color with the specified brightness level. 
Colors near the top of the color graphic are circled if the 
saturation level is high. Darker colors are found near the bottom 
of the color graphic.

• Select the hue, saturation, and brightness on the color square or 
color strip:

• Drag the slider to select the desired hue from the color strip.
• Select the shade you wish to use in the color square.

4 Click Close when done. The Pick Paint Color dialog box closes. The color 
you selected becomes the current paint color.

To select a color using the RGB model

1 Click , the Change Paint Color icon. The Pick Paint Color dialog box 
opens.

2 Click RGB. The RGB page (Figure 200C) appears.
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3 Specify the numbers for the three components (red, green, and blue), or 
use the sliders to select a color.

4 Click Close when done. The Pick Paint Color dialog box closes. The color 
you selected becomes the current paint color.

Red slider and 
list box

Specifies the number representing the red channel. Either use the slider, or select 
the number in the list box.

Green slider 
and list box 

Specifies the number representing the green channel. Either use the slider, or 
select the number in the list box.

Blue slider 
and list box

Specifies the number representing the blue channel. Either use the slider, or select 
the number in the list box.

OK Applies the parameters that you specified to crop the image.

Cancel Disregards any changes you made in this dialog box, closes the dialog box, and 
does not crop the image.

Reset Returns the color settings to their previous values.

Help Displays online help for this dialog box.

Figure 202.  RGB page in the Pick Paint Color dialog box 
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STEP 3, ADJUST THE OPACITY LEVEL OF THE 
PAINT

You can further refine the appearance of the paint selecting its opacity level. 
Opacity levels can range from 0.0 (transparent) to 1.0 (opaque). 

To change the opacity level

1 Click  on the Paint toolbar. The Paint Opacity window appears 
(Figure 203).

2 Drag the slider to the desired level of opacity. The current level appears 
in the bold print underneath the slider.

3 Click Close to apply the opacity level. The opacity level on the image 
changes according to your specifications.

STEP 4, APPLY PAINT

Having selected the intensity level, paint color, and opacity level, you are 
now ready to paint on the image with the paintbrush.

To paint on the image

1 Click , the Paintbrush icon, on the Paint toolbar in the MIPAV 
window.

2 Select one of the following sizes of the paintbrush tip:

Opacity Specifies the degree of 
transparency. To make the 
color more transparent, 
move the slider to left. To 
make it more opaque, move 
the slider to the right.

Close Closes this dialog box.

Figure 203.  Paint Opacity dialog box
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• A 1-pixel tip: Click , the Small size icon

• A 16-pixel (4 x 4 square) tip: Click , the Medium size icon

• A 100-pixel (10 x 10 square) tip: Click , the Large size icon

3 Click and drag the mouse button to paint on the drawing. You can select 
one pixel at a time, or drag the mouse button to draw paint strokes on 
the image. 

Tip: You may need to use the magnification buttons to adjust the 
magnification level of the image.

If you make a mistake, you can erase or undo the painted area.

To erase paint from a specific area

1 Click , the Erase icon.

2 Select the size of the eraser tip by clicking one of the following:

• A 1-pixel tip: Click , the Small size icon

• A 16-pixel (4 x 4 square) tip: Click , the Medium size icon

• A 100-pixel (10 x 10 square) tip: Click , the Large size icon

3 Use the mouse to begin erasing. You can select one pixel at a time, or 
you can drag the mouse. 

Tip: When erasing the paint, it may be easier to magnify the size of the image 
using the magnification icons.

To resume painting, click , the Paintbrush icon.
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To erase all paint on an image

1 Do one of the following as appropriate:

• Click , the Erase all paint icon, which removes all paint from the 
image.

• Click , the Undo last region paint icon, which allows you to undo 
the last paint stroke.

2 Click , the Default Mode icon, when you have finished painting the 
image.

STEP 5, COMMIT

When you visualize a dataset in MIPAV, a composite of several layers 
appears in the default image window. The image layer contains the original 
image. The next two layers contain the results of applied utilities, 
algorithms, and paint. The fourth layer contains VOI contour information. 

When you click the commit icons ( , the Changes image where painted 

inside, icon and the , the Changes image where painted outside, icon), 
the paint and utility/algorithm layers are merged with the image layer and 
saved as a new file.

To commit changes, select one of the following commit icons:

• , the Changes image where painted inside, icon: This icon shows 
the image without the area you painted (Figure 204A).

• , the Changes image where painted outside, icon: This icon 
removes the painted area from the image and shows only the 
removed area (Figure 204B).

The software redraws the dataset with the intensity levels indicated on the 
image. You may need to adjust the lookup table (LUT) to see the image 
more clearly. Instructions for adjusting the LUT appear in Chapter 5, 
“Visualizing Images.”
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Creating a mask using the paint grow  
segmentation method

You can create a mask using the paint grow segmentation method, which 
uses voxel aggregation to group voxels into larger regions. You begin by 
selecting a voxel to serve as the seed point, or starting point. The software 
applies paint color to all voxels touching the seed point that fall within the 
intensity range that you specify.

Note: You cannot apply the paint grow segmentation method to RGB images.

Figure 204.  Images produced from using the commit icons
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To create a mask using the Paint Grow button

1 Click , the Paint Grow button. The Paint Grow dialog box appears 
(Figure 205).

2 Select the seed point, which is used as a starting point for the paint grow 
operation. To do this, move the pointer to the image. As you move the 
cursor, the location and intensity of the voxel under the pointer tip 
appears in the Cursor position and voxel intensity text box. Click the 
voxel you want to designate as the seed point.

3 Adjust the delta values and parameters. 

4 Click Apply when complete to begin the paint grow method. The Paint 
Grow dialog box closes.

Cursor position 
and voxel intensity

Indicates the coordinates and 
intensity of the pixel under the mouse 
pointer tip. This pixel is the seed 
point.

Delta above 
selected voxel 
intensity

Once a seed point has been selected, 
MIPAV uses this value to determine 
whether to fill adjacent voxels with 
color. The voxels that are filled must 
have intensity levels that fall within 
the range of the seed point intensity 
minus the lower delta value and the 
upper delta value. For example, if 
seed point has an intensity of 100.0, 
and the Delta Above Selected Pixel 
Intensity value is 10 and the Delta 
Below Selected Pixel Intensity value 
is 15, MIPAV color-fills adjacent 
voxels whose intensities range from 
85.0 to 110.0.

Delta below 
selected voxel 
intensity

Once a seed point is, MIPAV uses this 
value to determine whether to fill 
adjacent voxels with color. The voxels 
that are filled must have intensity 
levels that fall within the range of the 
seed point intensity minus the lower 
delta value and the upper delta value.

Figure 205.  Paint Grow dialog box 
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To correct the mask

If the results are not what you want, do the following:

1 Click , the Paint Grow button. The Paint Grow dialog box appears 
(Figure 205).

2 Select the seed point, which is used as a starting point for the paint grow 
operation. To do this, move the pointer to the image. As you move the 
cursor, the location and intensity of the voxel under the pointer tip 
appears in the Cursor position and voxel intensity text box. Click the 
voxel you want to designate as the seed point.

Parameters Constrains the growth of the paint grow operation. Select the unrestricted 
size and unrestricted distance check boxes to allow the paint grow operation 
to be applied without restraint. If the Unrestricted size check box is not 
selected, type the maximum size (in cubic meters) of the paint grow region 
in the text box. If the Unrestricted Distance check box is not selected, type 
the maximum distance from the original seed point in the text box.

Unrestricted size TBD

Maximum size TBD

Unrestricted 
distance

TBD

Maximum distance TBD

Fuzzy 
connectedness

TBD

Initial variance 
from selected VOI

TBD

Display fuzzy 
image

TBD

Fuzzy threshold TBD

Close Closes this dialog box.

Cancel Disregards any changes that you made in this dialog box and closes the 
dialog box.

Help Displays online help for this dialog box.

Figure 205.  Paint Grow dialog box  (continued)
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3 Adjust the delta values and parameters. 

4 Click Apply when complete to begin the paint grow method. The Paint 
Grow dialog box closes.

If the results are not what you want, do either of the following:

• Click , the Undo last region paint icon, and start again.

• Click , the Erase icon, or click , the Erase all paint icon, to 
erase all paint.

5 Click one of the following commit buttons:

• , the Changes image where painted inside, icon: This icon shows 
the image without the area you painted (Figure 204A).

• , the Changes image where painted outside, icon: This icon 
removes the painted area from the image and shows only the 
removed area (Figure 204B).

Converting VOI contours to masks

You can convert a contoured VOI to a binary, short, or paint mask using the 
options found in the VOI menu in the MIPAV window.

To convert a contoured VOI to a binary mask

In a binary mask, the value 1 is assigned to the area inside the VOI; 0 is 
assigned to the area outside the VOI. Thus, typically, the area that 
represents the VOI is white, while the area outside the VOI is black. 

1 Select VOI > Mask > VOI(s) to Binary Mask. The binary mask appears in 
a separate image window.

2 Save the image (optional).
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To convert a contoured VOI to a short mask

In a short mask, the values 1 to 65,535 are assigned to the area inside the 
VOI; 0 is assigned to the area outside the VOI. Thus, typically, the area that 
represents the VOI is several shades of gray and the area outside is black. 

1 Select VOI > Mask > VOI(s) to short mask option. The short mask 
appears in a separate image window.

2 Save the image (optional).

To convert a contoured VOI to a paint mask

1 Contour the VOI. For instructions on how to contour VOIs, refer to 
“Using contours to segment a VOI” on page 255.

2 Select the color, opacity, and intensity level of the paint.

3 Select VOI > Mask > VOI(s) to Paint Mask. The contours are filled with 
the default paint color.

4 Delete the contours by right-clicking the VOI and selecting Edit > 
Delete.

5 Save the image (optional).

Converting masks to VOI contours

To convert a mask to an image with VOIs

1 Create a paint mask. For information on how to do this, refer to 
“Generating masks” on page 277.

2 Select the VOI > Mask-> VOI.

Contours replace the painted areas.
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8 Analyzing Images
You can use MIPAV to generate statistics on contoured volume of interest 
(VOI) regions and to calculate the volume of painted pixels and voxels. You 
can also use MIPAV’s algorithms to perform more sophisticated image 
analysis (for information about algorithms, refer to volume 2 of this User’s 
Guide).

Calculating statistics for contoured VOIs

Once you have contoured structures, you can generate statistics on the VOI.

To select the type of statistics to calculate

1 Open an image.

2 Contour a VOI. An example of a contoured VOI appears in Figure 206A.

3 Select the VOI.

4 Do one of the following:

• Select VOI > Properties.

• Right-click inside the VOI, which automatically selects it. Then 
select Properties on the menu (Figure 206B). 

The VOI Statistics dialog box (Figure 207) opens.
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5  Choose the types of statistics that you want the program to calculate by 
selecting the appropriate check boxes in the Statistics to calculate group. 

Refer to Figure 207 for information on each statistic you can select. 

6 Click Calculate. 

7 Select the Output window.

Figure 206.  Contoured VOI 
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w

Name of 
VOI

Indicates the color of the VOI outlines and the name of the VOI. To use this to group 
two contours, refer to Chapter 7 for more details.

Show 
bounding 
box

Indicates whether to show the bounding box. If this check box is selected, the 
bounding box appears around the VOI.

Additive or 
subtractive

TBD.

Include for 
processing

Indicates whether to include the VOI in the processing when running an algorithm. If 
selected, the VOI is included.

Boundary 
or blended

Indicates whether the contour is filled with color (blended) or transparent (only the 
boundary appears). If selected, the VOI is filled with color.

Figure 207.  VOI Statistics dialog box
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Opacity Indicates whether a VOI that is filled with color is transparent, translucent, and 
opaque: 0 is transparent, and 1 is opaque.

Statistics to 
calculate

No. of voxels—Indicates the number of voxels, including voxels that span frames in 
an image stack, that are enclosed in the VOI. 

Volume—Measures the amount of space occupied by a 3D VOI. To calculate the 
volume, the software multiplies the number of pixels by the resolution of each 
dimension.

Area—Measures the surface of the VOI. To calculate the area, the software multiples 
the number of pixels by the resolutions of the x and y dimensions.

Average voxel intensity—Calculates the average intensity of the voxels in the VOI 
by adding the intensity of all voxels in the VOI and dividing the result by the sum of 
the voxels.

Std. dev. of voxel intensity—Calculates the standard deviation of the intensity of 
the voxels in the VOI.

Center of mass—Indicates the point at which the whole mass of the VOI is 
concentrated. It is calculated as the sum of all x coordinates divided by the number 
of points and the sum of all y coordinates divided by the number of points.

Principal axis (only 2D)—Calculates the principal axis for 2D images only.

Eccentricity (only 2D)—Describes the geometric shape of the VOI as an ellipse, 
with 0 indicating a circle and 1 indicating a straight line.

Select all Selects all of the statistical measures in Statistics to calculate.

Clear Clears all of the statistical measures in Statistics to calculate.

Exclude 
intensity 
range

Excludes a specific range of intensity values, which you specify in the Range boxes, 
in the calculation. When this check box is selected, the Range boxes become 
available.

Range Specifies a particular range of intensities to exclude from the calculations. These 
boxes become available if the Exclude intensity range check box is selected.

Seed value 
(0-32K)

Indicates the watershed seed value.

Apply Applies the changes you made to this dialog box.

Cancel Disregards any changes you made in this dialog box and closes the dialog box.

Calculate Runs all selected statistics according to the specifications in this dialog box.   

Help Displays online help for this dialog box.

Figure 207.  VOI Statistics dialog box (continued)
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To view the statistics

1 Select the Output window.

2 Select the Data tab on the Output window to view the information. The 
Data page of the Output window (Figure 208) appears showing the 
results of the calculations.

To save the statistics

1 Select File > Save Messages in the Output window. 

The Save dialog box opens.

2 Specify a name for the messages file and select a location for storing it. 

3 Click Save. The software saves the file and places it in the specified 
location.

Tip: MIPAV provides you with the ability to type directly onto the Data page. 
So, for example, you could add a description of when the statistics were 
calculated or any other such meaningful information (Figure 208).

Figure 208.  Data page in the Output window showing statistics 
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Calculating statistics on VOI groups

The Statistics Generator command on the VOI menu in the MIPAV window 
opens the Calculate Statistics on VOI Groups window, which allows you to 
obtain statistics on one VOI or on multiple grouped VOIs. You can save the 
statistics to a tab-delimited file, which can then be incorporated into a 
database. 

The Calculate Statistics on VOI Groups window includes three pages:

• VOI Selection page—On this page you can select the VOIs on which to 
calculate the statistics. It also allows you to name and save the logging 
file at the path you choose.

• Statistics Options page—This page provides a choice of the types of 
statistics that may be calculated as well as the conditions under which 
they may be run. 

• Logging page—This page provides the results of the statistics in a 
tabular form. Depending on the number of VOIs included in the 
calculation, the results may include one or more lines of text.
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VOI groups list—left Lists all of the VOIs found on the image.

VOI groups list—right Lists the VOIs on which you plan to calculate statistics. 

 Send all left

Moves all of the VOIs that appear in the VOI groups list on the right to the 
VOI groups list on the left.

 Send selection 
left

Moves the selected VOI that appears in the VOI groups list on the right to 
the VOI groups list on the left.

 Delete selection

Deletes the selected VOI in either the VOI groups list on the left or the 
VOI groups list on the right.

 Send selection 
right

Moves the selected VOI in the VOI groups list on the left to the VOI groups 
list on the right on which you plan to calculate statistics.

 Send all right
Moves all of the VOIs, whether they are selected or not, in the VOI groups 
list on the left to the VOI groups list on the right on which you plan to 
calculate statistics. 

Figure 209.  VOI Selection page in the Calculate Statistics on VOI groups window
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To calculate statistics on VOIs

1 Open an image.

2 Delineate one or more VOIs on the image (Figure 210). 

3 Select one of the VOIs by clicking it.

4 Hold down the Shift key and select the next VOI.

5 Continue holding down the Shift key and selecting VOIs until all of the 
VOIs to be included in the calculation are selected.

6 Select VOI > Group VOIs.

7 Select VOI > Statistics Generator. The Calculate Statistics on VOI 
Groups window opens showing the VOI Selection page.

VOI statistics file 
destination

Specifies the file path, file name, and file extension to which you want to 
save the file.

Browse Allows you to navigate to the directory on your workstation or attached 
disks where you want to store the file.

Tab-delimited Saves the statistics in a comma-separated tab-delimited file. The 
extension for this file is .TABLE.

XML In development.

Calculate Runs all statistics that are selected on the Statistics Options page 
according to the options specified.

Close Closes this window.

Help Displays online help for this window.

Figure 209.  VOI Selection page in the Calculate Statistics on VOI groups window (continued)
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8 Select joinedVOI.voi, which appears in the left VOI groups list. 

9 Click , the Send selection right button. The group appears on the 
right VOI groups list (Figure 211).

10 Do one of the following:

• Accept the default path and file name for the logging file, where the 
statistics are stored, in VOI statistics file destination.

• Update the path and file name for the logging file. 

11 Select the format of the logging file in Output format.

12 Select Statistics Options. The Statistics Options page (Figure 212) 
appears.

13 Select the statistics you want to include in the calculation in the 
Statistics to calculate list by doing one of the following:

• Click on the individual check boxes for each specific statistic.

• Click Select all to run all of the statistics. 

Figure 210.  Joined VOIs
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Tip: If you, for example, clicked Select all and then decide that you don’t 
want the software to calculate all of the statistics, it may be faster to click 
Clear to remove the check marks from all of the check boxes. You can then 
select only the statistics you want to calculate.       

14 Select one of the following options in the Statistics options group:

• By contour & slice
• By slice only
• By total VOI

15 Select Show all totals if appropriate. 

16 Click Calculate. The Logging page (Figure 213) appears with the results 
of the statistics you selected.

17 Click Close when finished to close the Calculate Statistics on VOI 
Groups window.

Figure 211.  Sending the joined VOIs to the VOI group list on the right
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Statistics to calculate No. of voxels—Indicates the number of voxels—including voxels that 
span frames in an image stack—enclosed in the VOI. 

Volume—Measures the amount of space occupied by a 3D VOI. To 
calculate the volume, the software multiplies the number of pixels by the 
resolution of each dimension.

Area—Measures the surface of the VOI. To calculate the area, the 
software multiples the number of pixels by the resolutions of the x and y 
dimensions.

Average voxel intensity—Calculates the average intensity of the voxels 
in the VOI by adding the intensity of all voxels in the VOI and dividing the 
result by the sum of the voxels.

Std. dev. of voxel intensity—Calculates the standard deviation of the 
intensity of the voxels in the VOI.

Center of mass—Indicates the point at which the whole mass of the VOI 
is concentrated. It is calculated as the sum of all x coordinates divided by 
the number of points and the sum of all y coordinates divided by the 
number of points.

Figure 212.  Statistics Option page in the Calculate Statistics on VOI Groups window
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To exclude a range of pixels from the calculations

When you run statistics on VOIs in an image but want to exclude a specific 
range of pixels from the calculations, make sure that you do the following:

1 Select Exclude pixels from calculation on the Statistics Options page in 
the Calculate Statistics on VOI Groups window. The Exclude pixels list 
and the Pixels range boxes become available.

2 Select Between, Above, Below, or Outside in the Exclude pixels list.

3 Type a range of pixels in the Pixel range boxes. 

Principal axis (only 2D)—Calculates the principal axis for 2D images 
only.

Eccentricity (only 2D)—Describes the geometric shape of the VOI as an 
ellipse, with 0 indicating a circle and 1 indicating a straight line.

Statistics options By contour & slice—Runs the selected statistics on both the contour and 
slice.

By slice only—Runs the selected statistics on only the slice.

By total VOI—Runs the selected statistics on the entire VOI.

Show all totals—Specifies to display all of the totals for __________.

Pixel exclusion Exclude pixels from calculation—Indicates to exclude the pixels in the 
Pixel range boxes from the calculation. When you select this check box, 
the Exclude pixels button and the Pixel range boxes become available.

Exclude pixels—Indicates to exclude the pixels between, above, below, 
or outside the range shown in the Pixel range boxes.

Pixel range—Lists a specific range of pixels between, above, below, or 
outside that should be excluded in the calculations.

Select all Selects all of the statistics listed in the Statistics to calculate group.

Clear Clears all of the statistics listed in the Statistics to calculate group.

Calculate Runs all statistics that are selected on the Statistics Options page 
according to the options specified.

Close Closes this window.

Help Displays online help for this window.

Figure 212.  Statistics Option page in the Calculate Statistics on VOI Groups window (continued)
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4 Continue to select statistics and other options for the calculation.

5 Click Calculate.

Statistics table Lists all of the statistics that were calculated according to the selected 
statistics and the options specified on the Statistics Options page.

Calculate Runs all statistics that are selected according to the options specified on 
the Statistics Options page.

Close Closes the window.

Help Displays online help for this window.

Figure 213.  Logging page in the Calculate Statistics on VOI Groups window
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To save the calculations to a specific file

By default, the software saves the results of the calculations to the following 
path and file name:

 c:\Documents and Settings\[username]\voistatistics.table

However, you can easily change the file name by typing over the default file 
name in the VOI statistic file destination box on the VOI Selection page in 
the Calculate Statistics on VOI Groups window. To change the path, type 
over the current path, or click Browse to select another path. 

To use the calculations in a database application

Saving the statistics in a tab-delimited file allows you to import them into a 
database application. 

1 Make sure—before running the calculations—that you select the Tab-
delimited check box on the VOI Selection page in the Calculate Statistics 
on VOI Groups window. 

2 Change the path and file name, if necessary, in the VOI Statistics File 
Destination box on the VOI Selection page. 

3 Click Calculate. The resulting statistics appear on the Logging page and 
in the file you specified.

To rearrange the columns in the logging table

You can adjust the order in which the columns in the logging table appear as 
well as their width. To change the order, simply click on the title of a column 
and drag the column to the new position. To make a column wider, click on 
the line between it and the next column and drag it to the desired width. 

To compare statistics

If you calculate statistics on an image more than once in a MIPAV session, 
the Logging page shows the previously run calculations for the VOIs in that 
image. For example, suppose you calculate statistics on the VOIs in an 
image and then save the image and close it. Later, you reopen the image and 
decide to run additional statistics on the previous VOIs or on any new VOIs. 
As long as you did not exit MIPAV and are therefore in the same session, the 
Logging page in the Calculate Statistics on VOI Groups window still displays 
the results of the statistics you previously ran on the VOIs in the image. 
MIPAV User’s Guide, Volume 1, Basics 309

9/20/04 



M   I   P   A   V
M e d i c a l   I m a g e   P r o c e s s i n g, A n a l y s i s,   &   V i s u a l i z a t i o n

Chapter 8,  Analyzing Images
When you perform additional calculations on the same or new VOIs on that 
image or on VOIs in another image, the results of those calculations appear 
below the earlier run statistics. This allows you to compare the results of 
both.

To clear, or delete, all of the statistics on the Logging 
page

When you no longer need the statistics on the Logging page or after you 
saved them to a file, you can clear, or delete, all of the statistics on the 
Logging page. To do so, do one of the following:

• Select Options > Clear logging page in the Calculate Statistics on VOI 
Groups window.

• Press Alt C.

• Select Clear on the Statistics Options page.

The software deletes all of the statistics on the Logging page.

To overwrite logging files automatically

If you ran calculations previously in your current MIPAV session and then 
select Calculate in the Calculate Statistics on VOI Groups window, the File 
Exists message appears asking whether to overwrite the previously saved 
logging file or cancel the action. If you select Overwrite, the software 
replaces the previously saved file with the new statistics. Selecting Cancel 

means that MIPAV does not perform any calculations.

Figure 214.  File Exists message
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Recommendation: It is recommended that you decide in advance on a 

standard procedure for handling statistics files. That is, do you need to keep 

them for historical purposes? Do you need to keep statistics on individual 

images in separate files? If so, you may want to assign unique names to the 

statistics file for each image. If not, you may want to simply overwrite the 

statistics file each time you calculate statistics of VOI groups. 

If you do not want to keep the statistics in separate files, it may become 
tiring to always receive and need to respond to the File Exists message. To 
this end, the software offers an option for always overwriting the logging 
files. To use this option, simply select Options > Overwrite File 
Automatically (Figure 215) in the Calculate Statistics on VOI Groups 
window.

Tip: To turn the overwrite command on, press Alt O on the keyboard. To turn it 
off, press Alt O again. 

Calculating the volume of masks

You can calculate the volume of painted voxels, or mask, in an image and 
view the information about the volume on the Data page of the Output 
window.

To calculate the volume of masks

1 Open an image, and paint the voxels in a desired area of the image.

2 Follow the instructions for manually creating a mask in “Generating 
masks” on page 277 in Chapter 7, “Segmenting Images Using Contours 
and Masks” . 

Figure 215.  Overwrite file automatically command on the Options menu
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3 Do not commit the paint, which permanently merges the paint layer 
with the image layer.

4 Click , the Calculate Volume of Paint icon, in the Paint toolbar. 

The region grow information (how many voxels or pixels are painted) 
and the volume of all painted voxels appear on the Data page of the 
Output window (Figure 216).

To view the information

1 Select the Output window.

2 Select the Data tab on the Output window to view the information. The 
Data page of the Output window (Figure 216) appears.

Remember: You can type directly onto the Data page if you want to record 
such information as the date and time the calculations were run.

Figure 216.  Data page in the Output window (left) listing the region 
grow and volume information from the painted voxels in the image 
(right)
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To save the information

1 Select File > Save Messages in the Output window. 

The Save dialog box opens.

2 Specify a name for the messages file and select a location for storing it. 

3 Click Save. The software saves the file and places it in the specified 
location.

Generating graphs

MIPAV allows you to generate intensity profiles, or contour VOI graphs, for 
VOI contours. For delineated VOIs, you can generate 2D, 3D, or 4D 
intensity graphs. You can also generate a 3D intensity graph at a specific 
point across all slices in a dataset. For information on how to contour a VOI, 
refer to Chapter 7, “Segmenting Images Using Contours and Masks” on 
page 254.

Generating contour VOI graphs
Contour VOI graphs display the intensity values of the selected contour’s 
boundary in the Contour VOI Graph window (Figure 218). You can generate 
either 2D or 3D contour VOI graphs. 

To generate 2D contour VOI graphs

1 Open an image.

2 Delineate a 2D VOI on the image using one of the 2D icons in the 

MIPAV window: , , , or .

Figure 217.  Save messages command on the File menu in the  
Output window
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File Open Graph—Opens a PLT file that contains graph data. When you select this 
command or press Ctrl O on the keyboard, the Open Graph Data dialog box appears. 

Save Graph—Saves the graph data in a PLT file. When you select this command or 
when you press Ctrl S on the keyboard, the Save dialog box opens.

Print Graph—Allows you to print the graph. When you select this command or press 
Ctrl P, the Print dialog box opens.

Close Graph—Closes the Intensity Graph window. To close the window, you can also 
press Ctrl X on the keyboard.

Edit Delete Function—Allows you to delete a specific function. However, you cannot delete 
a function if it is the only function displayed in the window.

Copy Function—Copies a function that is currently displayed in the window.

Paste Function—Pastes a previously copied function into the window. The pasted 
function has a different color than the first function displayed in the window.

Views Modify Graph Features—Allows you to customize the appearance of the graph.

Reset Range to Default—[TBD]

Reset Graph to Original—[TBD]. 

Help Help Topics—Displays online help topics.

Figure 218.  Contour VOI Graph window
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3 Select the VOI. 

As an option, copy the VOI to other slices in the dataset by selecting VOI 
> Propagate and one of the following commands:

• To Next Slice
• To Previous Slice
• To All Slices

4 Do one of the following:

• Select VOI > Graph > Boundary Intensity in the MIPAV window. 
• Right click on the VOI and then select Graph > Boundary Intensity.

The Contour VOI Graph window (Figure 218) opens.

To generate 3D contour VOI graphs

1 Open an image.

2 Delineate a VOI on the image using , the 3D rectangular VOI icon, in 
the MIPAV window. 

3 Select the VOI. 

As an option, copy the VOI to other slices in the dataset by selecting VOI 
> Propagate and one of the following commands:

• To Next Slice
• To Previous Slice
• To All Slices

4 Do one of the following:

• Select VOI > Graph > Boundary Intensity in the MIPAV window.

• Right-click on the VOI and then select Graph > Boundary Intensity. 

The Contour VOI Graph window (Figure 218) opens. This window 
displays a graph of the intensity values of the selected contour’s 
boundary. 

Generating intensity graphs
Intensity profiles, or graphs, present information on the intensity values of 
the VOI region in an image. The intensity graph appears in the Intensity 
Graph window (Figure 219).
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To generate 2D intensity graphs

1 Open an image.

2 Delineate a 2D VOI on the image using one of the 2D icons in the 

MIPAV window: , , , or .

3 Select the VOI. 

As an option, copy the VOI to other slices in the dataset by selecting VOI 
> Propagate and one of the following commands:

• To Next Slice
• To Previous Slice
• To All Slices

4 Do one of the following:

• Select VOI > Graph in the MIPAV window and either of the 
following:

• 2.5D Total Intensity—To generate a graph of the sum of the 
intensity values of the VOI region. 

• 2.5D Average Intensity—To generate a graph of the average of the 
intensity values of the VOI region.

• Right-click on the VOI and then select Graph and one of the 
following commands:

• 2.5D Total Intensity—To generate a graph of the sum of the 
intensity values of the area delineated by the VOI per slice.

• 2.5D Average Intensity—To generate a graph of the average of the 
intensity values of the VOI region.

• 2.5D Total Intensity with Threshold—TBD. 

• 2.5D Average Intensity with Threshold—TBD.

The Intensity Graph window (Figure 219) opens.
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File Open Graph—Opens 
a PLT file that contains 
graph data.

When you select this 
command or press 
Ctrl O on the 
keyboard, the Open 
Graph Data dialog box 
appears. 

Save Graph—Saves 
the graph data in a 
PLT file. 

When you select this 
command or when 
you press Ctrl S on 
the keyboard, the 
Save dialog box 
opens.

Print Graph—Allows you to print the graph. When you select this command or press 
Ctrl P, the Print dialog box opens.

Close Graph—Closes the Intensity Graph window. To close the window, you can also 
press Ctrl X on the keyboard.

Edit Delete Function—Allows you to delete the function that you select. However, you cannot 
delete a function if it is the only function displayed in the window.

. 

Paste Function—Pastes a previously copied function into the window. The pasted 
function has a different color than the first function displayed in the window.

Views Modify Graph Features—Allows you to customize the appearance of the graph.

Reset Range to Default—TBD.

Reset Graph to Original—TBD.

Help Help Topics—Displays online help topics.

Figure 219.  Intensity Graph window
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To generate 3D intensity graphs of all slices in a 
dataset at a specific point

1 Open an image.

2 Draw a point VOI on the image (Figure 220).

3 Select the VOI.

4 Do one of the following:

• Select , the Propagate VOI to all slices icon.

• Select VOI > Propagate > To All Slices. 
• Right-click on the VOI, then select Propagate > To All Slices 

(Figure 220).

5 Right-click on the VOI and select Show VOI Graph (Figure 220).

The Intensity Graph window (Figure 219 on page 317) opens.

To generate 3D intensity graphs of specific areas

1 Open an image.

2 Delineate a VOI on the image using , the 3D rectangular VOI icon, in 
the MIPAV window.

3 Select the VOI.

Figure 220.  Point VOI
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4 Do one of the following:

a Select VOI > Graph and either of the following in the MIPAV 
window:

• 2.5D Total Intensity—To generate a graph of the sum of the 
intensity values of the area delineated by the VOI per slice.

• 2.5D Average Intensity—To generate a graph of the average of the 
intensity values of the VOI region.

b Right-click the VOI, and then select Graph and one of the following 
commands in the MIPAV window:

• 2.5D Total Intensity—To generate a graph of the sum of the 
intensity values of the area delineated by the VOI per slice.

• 2.5D Average Intensity—To generate a graph of the average of the 
intensity values of the VOI region.

• 2.5D Total Intensity with Threshold—TBD.

• 2.5D Average Intensity with Threshold—TBD.

The Intensity Graph window (Figure 219 on page 317) opens.

CUSTOMIZING THE APPEARANCE OF GRAPHS

You can adjust the appearance of graphs to interpret the information more 
clearly or easily. To customize graphs, you use the Modify Graph dialog box 
(Figure 221 on page 320), which is accessible through Views > Modify 
Graph Features in both the Contour VOI window (Figure 218 on page 314) 
and the Intensity Graph window (Figure 221 on page 320). The Modify 
Graph dialog box includes the following four tabbed pages: 

• Graph page (refer to Figure 221 on page 320), which allows you to 
show or hide the gridlines and tick marks, change the number of 
gridlines and background color of the graph, change the labels on the 
graph, and change the range values.

• Legends page (refer to Figure 229 on page 329), which lets you 
determine whether a legend should appear on the graph and allows 
you to assign a specific name to each function.
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• Functions page (refer to Figure 231 on page 331), which allows you to 
change the appearance of the functions in the graph. 

• Fitted Functions page (refer to Figure 233 on page 335), which allows 
you to modify the functions.

Gridlines 
visible

Displays, if 
selected, gridlines 
on the graph in the 
Intensity Graph 
window. 

Minor tick 
marks 
visible

Displays, if 
selected, the tick 
marks on the X and 
Y axes of the graph 
in the Intensity 
Graph window.

Number of 
X-axis 
gridlines

Indicates the 
number of gridlines 
that appear on the 
X axis of the graph. 
The default number 
of gridlines is 4. 
You can specify 
from 1 to 50 
gridlines. 

Number of 
Y-axis 
gridlines

Indicates the number of gridlines that display on the Y axis of the graph. The default 
number of gridlines is 4. You can specify from 1 to 50 gridlines.

Title Specifies the name of the graph. By default, the name is Intensity Graph. However, 
you can replace this name with any name you choose.

X axis label Specifies the name that appears for the X axis. By default, the name is Position on 
curve (mm).

Y axis label Specifies the name that appears for the Y axis. By default, the name is Intensity.

Change 
background 
color

Allows you to choose the color of the background of the graph. When you select this 
icon, the Pick Background Color dialog box opens. By default, the background color 
for graphs is light gray (the HSB values are 0 hue, 0 saturation, and 100 brightness 
and the RGB values are 255 red, green, and blue.

Auto shrink 
range

TBD.

Figure 221.  The Graph page of the Modify Graph dialog box
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To display or hide the points, or tick marks, on 
graphs

1 Open an image.

2 Delineate a VOI on the image.

3 Generate an intensity profile (refer to “Generating graphs” on page 313). 
Either the Contour VOI Graph window (Figure 218 on page 314) or the 
Intensity Graph window (Figure 219 on page 317) opens.

4 Select Views > Modify Graph Features in either the Contour VOI Graph 
window or the Intensity Graph window. The Graph page of the Modify 
Graph dialog box (Figure 221 on page 320) appears.

5 Do one of the following:

• If you want to make the points appear on the graph, select Minor 
tick marks visible. A check mark appears in the check box. 

• If you want to make the points invisible, clear Minor tick marks 
visible. 

Min. for 
range

TBD. The default minimum range is 207,437.0. If you specify another range, it must 
be less than the default range. 

Max for 
range

TBD. The default maximum range is 595,910.0. If you specify another range, it must 
be more than the default range.

Reset 
default 
range

Erases the current minimum and maximum ranges and replaces the values with the 
default minimum and maximum ranges. 

Apply Applies the changes you made in this dialog box. 

Cancel Disregards any changes you made in this dialog box, closes the dialog box, and does 
not change the threshold.

Help Displays online help for this dialog box.

Figure 221.  The Graph page of the Modify Graph dialog box (continued)
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6 Click Apply. 

• If you selected Minor tick marks visible, the tick marks along the X 
and Y axes in the graph appear.

• If you cleared Minor tick marks visible, the tick marks disappear 
from the graph.

7 Do one of the following:

• Click  to close the Modify Graph dialog box. 

• Keep the Modify Graph dialog box open to continue modifying the 
graph.

To display or hide the gridlines on graphs

1 Open an image.

2 Delineate a VOI on the image.

3 Generate an intensity profile (refer to “Generating graphs” on page 313). 
Either the Contour VOI Graph window (Figure 218 on page 314) or the 
Intensity Graph window (Figure 219 on page 317) opens.

4 Select Views > Modify Graph Features in either Contour VOI Graph 
window or the Intensity Graph window. The Graph page of the Modify 
Graph dialog box (Figure 221 on page 320) appears.

5 Do one of the following:

• To make the gridlines appear on the graph, select, if not already 
selected, Gridlines visible. A check mark appears in the check box.

• To make the gridlines disappear from the graph, clear Gridlines 
visible. The check box is empty.
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6 Click Apply.

• If you selected Gridlines visible, horizontal and vertical gridlines 
appear in the graph.

• If you cleared the check box, the gridlines disappear from the graph.

7 Do one of the following:

• Click  to close the Modify Graph dialog box. 

• Keep the Modify Graph dialog box open to continue modifying the 
graph.

To change the number of gridlines in graphs

1 Select Views > Modify Graph Features in either the Contour VOI Graph 
window (Figure 218 on page 314) or the Intensity Graph window 
(Figure 219 on page 317). The Graph page of the Modify Graph dialog 
box (Figure 221 on page 320) appears.

2 Change the number of X-axis gridlines in Number of X-axis gridlines 
(Figure 223) by specifying a value from 1 to 50. The default number of 
gridlines is 4. 

3 Change the number of Y-axis gridlines in Number of Y-axis gridlines 
(Figure 223) by specifying a value from 1 to 50. The default number of 
gridlines is 4.

Figure 222.  Displaying or hiding the gridlines and tick marks on the 
graph
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4 Click Apply. 

The number of horizontal and vertical gridlines that you specified 
appear in the graph in the Intensity Graph window.

Tip: If you specify many gridlines, to see the gridlines more clearly, resize the 
Modify Graph dialog box.

5 Do one of the following:

• Click  to close the Modify Graph dialog box. 

• Keep the Modify Graph dialog box open to continue modifying the 
graph.

To change the graph title and the labels on the X and 
Y axes 

1 Open an image.

2 Delineate a VOI on the image.

3 Generate an intensity profile (refer to “Generating graphs” on page 313). 
Either the Contour VOI Graph window (Figure 218 on page 314) or the 
Intensity Graph window (Figure 219 on page 317) opens.

4 Select Views > Modify Graph Features in Contour VOI Graph window or 
the Intensity Graph window. The Graph page of the Modify Graph 
dialog box (Figure 221 on page 320) appears.

5 Type the new title and axes labels in Title, X-axis label, and Y-axis label 
boxes (Figure 224).

Figure 223.  Number of X-axis and Y-axis gridlines
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6 Click Apply. 

The new title appears number of horizontal and vertical gridlines that 
you specified now appear in the graph (Figure 225).

Tip: If you specify many gridlines, you might want to resize the Modify Graph 
dialog box to see the gridlines more clearly.

7 Do one of the following:

• Click  to close the Modify Graph dialog box. 

• Keep the Modify Graph dialog box open to continue modifying the 
graph.

Figure 224.  Title, X-axis label, and Y-axis label boxes in the Modify 
Graph dialog box
MIPAV User’s Guide, Volume 1, Basics 325

9/20/04 



M   I   P   A   V
M e d i c a l   I m a g e   P r o c e s s i n g, A n a l y s i s,   &   V i s u a l i z a t i o n

Chapter 8,  Analyzing Images
To change the background color of graphs

1 Open an image.

2 Delineate a VOI on the image.

3 Generate an intensity profile (refer to “Generating graphs” on page 313). 
Either the Contour VOI Graph window (Figure 218 on page 314) or the 
Intensity Graph window (Figure 219 on page 317) opens.

4 Select Views > Modify Graph Features in either the Contour VOI Graph 
window or the Intensity Graph window. The Graph page of the Modify 
Graph dialog box (Figure 221 on page 320) appears.

5 Select Change background color (Figure 226).

The Pick Background Color dialog box (Figure 227) opens. 

Figure 225.  Changed title and axes labels in the Intensity Graph 
window

Figure 226.  Change background color button
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6 Select a color from one of the three pages in this dialog box. Refer to “To 
change background and border colors” on page 219 for information on 
how to select a color.

7 Click OK to apply the color to the graph background. The Pick 
Background Color dialog box closes, and the graph background 
(Figure 228) changes to the color you selected.

Figure 227.  Pick Background Color dialog box

Figure 228.  Changed background color for the graph
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To reset graphs to their original background colors

To return either the intensity graph or the contour VOI graph back to its 
default colors, select Views > Reset Graph to Original or press Ctrl Z in 
either the Contour VOI Graph window or Intensity Graph window as 
appropriate.

CHANGING THE LEGENDS FOR FUNCTIONS

The Legend page controls whether a legend appears on the contour VOI 
graph or intensity graph and allows you to assign a specific name to each 
function. By default, the legend does not appear on the graph; however, 
when you choose so, the legend appears in the upper right corner of the 
graph.

To display or hide legends

1 Open an image.

2 Delineate a VOI on the image.

3 Generate an intensity profile (refer to “Generating graphs” on page 313). 
Either the Contour VOI Graph window (Figure 218 on page 314) or the 
Intensity Graph window (Figure 219 on page 317) opens.

4 Select Views > Modify Graph Features in either the Contour VOI Graph 
window or the Intensity Graph window. The Modify Graph dialog box 
(Figure 221 on page 320) appears.

5 Select the Legend tab. The Legend page (Figure 229) appears. 

6 Do one of the following:

• To display the legend on the graph, select Show legend. A check 
mark appears in the check box.

• To hide the legend, clear Show legend. The check mark disappears 
from the check box.
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7 Click Apply.

• If you selected Show legend, the legend appears in the upper right of 
the graph (Figure 230).

• If you cleared Show legend, the legend disappears from the graph.

8 Do one of the following:

• Click  to close the Modify Graph dialog box. 

• Keep the Modify Graph dialog box open to continue modifying the 
graph.

Show 
legend

Displays, if selected, the 
legend on the upper right 
side on the graph in 
either the contour VOI 
graph or the Intensity 
Graph window.

Function 
N name

Specifies the name of the 
function. By default, the 
name is Function 1, but 
you can replace this 
name with any name you 
choose. 

This page allows you to 
specify up to five function 
names as long as those 
functions exist.

Apply Applies the parameters 
that you specified.

Cancel Disregards any changes that you made in this dialog box and closes the dialog box.

Help Displays online help for this dialog box.

Figure 229.  Legend page of the Modify Graph dialog box 
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Figure 230.  Legend at the upper right of the graph
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CHANGING THE APPEARANCE OF FUNCTIONS

The Functions page in the Modify Graph dialog box allows you to display or 
hide the points on functions, display or hide from one to five functions, and 
change the color of functions. 

To display or hide the points on functions

1 Open an image.

2 Delineate a VOI on the image.

3 Generate an intensity profile (refer to “Generating graphs” on page 313). 

Either the Contour VOI Graph window (Figure 218 on page 314) or the 
Intensity Graph window (Figure 219 on page 317) opens.

Points 
visible

Displays, if selected, all 
of the points on the 
functions. 

Function 
N visible

Displays, if selected, 
function N on the graph. 
You can display from one 
to five functions. 

This dialog box allows 
you to select only those 
functions that exist. 
Otherwise, they are 
dimmed.

Change 
function 
N color

Allows you to choose the 
color to use for displaying   
function N (listed on the 
left). When you select 
this icon, the Pick 
Background Color dialog 
box opens. 

Apply Applies the parameters that you specified.

Cancel Disregards any changes that you made in this dialog box and closes the dialog box.

Help Displays online help for this dialog box.

Figure 231.  Functions page in the Modify Graph window
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4 Select Views > Modify Graph Features in either the Contour VOI Graph 
window or the Intensity Graph window. 

The Modify Graph dialog box (Figure 221 on page 320) opens.

5 Select the Functions tab. The Functions page (Figure 231) appears. 

• To display the points, select Points visible. A check mark appears in 
the check box.

• To make the points invisible, clear Points visible. The check mark 
disappears from the check box.

6 Click Apply.

• If you selected Points visible, the points appear on the functions 
(Figure 232).

• If you cleared Points visible, the points disappear from the function.

7 Do one of the following:

• Click  to close the Modify Graph dialog box. 

• Keep the Modify Graph dialog box open to continue modifying the 
graph.

Figure 232.  Points displayed on a function whose color changed from 
red to blue
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To display or hide functions

1 Open an image.

2 Delineate a VOI on the image.

3 Generate an intensity profile (refer to “Generating graphs” on page 313). 

Either the Contour VOI Graph window (Figure 218 on page 314) or the 
Intensity Graph window (Figure 219 on page 317) opens.

4 Select Views > Modify Graph Features in either the Contour VOI Graph 
window or the Intensity Graph window. 

The Modify Graph dialog box (Figure 221 on page 320) opens.

5 Select the Functions tab. The Functions page (Figure 231) appears. 

6 Do one of the following:

• To display the function, select Function N visible. A check mark 
appears in the check box.

• To remove the function from the graph, clear Function N visible. 
The check mark disappears from the check box.

7 Click Apply.

• If you selected Function N visible, the function appears on the 
graph.

• If you cleared Function N visible, the function disappears from the 
graph.

8 Do one of the following:

• Click  to close the Modify Graph dialog box. 

• Keep the Modify Graph dialog box open to continue modifying the 
graph.

To change the color of functions

1 Open an image.

2 Delineate a VOI on the image.

3 Generate an intensity profile (refer to “Generating graphs” on page 313). 

Either the Contour VOI Graph window (Figure 218 on page 314) or the 
Intensity Graph window (Figure 219 on page 317) opens.
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4 Select Views > Modify Graph Features in either the Contour VOI Graph 
window or the Intensity Graph window. 

The Modify Graph dialog box (Figure 221 on page 320) opens.

5 Select the Functions tab. The Functions page (Figure 231) appears. 

6 Do one of the following:

• To change the color of the function, select Change Function N color. 
A check mark appears in the check box.

• To keep the color the same, clear Change Function N color. The 
check mark disappears from the check box.

7 Click Apply.

• If you selected Change Function N color, the function appears in the 
new color.

• If you cleared Change Function N color, the color of the function 
remains the current color.

8 Do one of the following:

• Click  to close the Modify Graph dialog box. 

• Keep the Modify Graph dialog box open to continue modifying the 
graph.

To reset functions to their original colors

To return the functions on either the intensity graph or the contour VOI 
graph back to their default colors, select Views > Reset Graph to Original or 
press Ctrl Z in the Intensity Graph window or the Contour VOI Graph 
window as appropriate.
MIPAV User’s Guide, Volume 1, Basics 334

9/20/04 



M   I   P   A   V
M e d i c a l   I m a g e   P r o c e s s i n g, A n a l y s i s,   &   V i s u a l i z a t i o n

Chapter 8,  Analyzing Images
MODIFYING FUNCTIONS ON GRAPHS

[TBD]

Opening, saving, printing, and closing graphs
The File menu in the Contour VOI Graph window and the Intensity Graph 
window allows you to open, save, print, and close graphs.

Fit linear TBD

Fit 
exponential 

TBD

None TBD

Fitted 
function N 
visible

TBD

Apply Applies the parameters that you specified.

Cancel Disregards any changes that you made in this dialog box and closes the dialog 
box.

Help Displays online help for this dialog box.

Figure 233.  Fitted Functions page in the Modify Graph dialog box
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To open previously saved graphs

1 Select File > Open Graph in either the Contour VOI Graph window or 
the Intensity Graph window, or press Ctrl C. The Open dialog box 
appears.

2 Navigate to the directory where the graph was stored.

3 Type or select the file name in File name.

4 Click Open. The graph opens.

To save contour VOI graphs or intensity graphs

1 Select File > Save Graph in either the Contour VOI Graph window or the 
Intensity Graph window, or press Ctrl S. The Save Graph dialog box 
(Figure 235) opens.

2 Navigate to the directory where the graph was saved.

3 Type or select the file name in File name. Use .PLT for the extension.

4 Click Save. The graph is saved in the specified directory.

Figure 234.  File menu in the graph windows showing the Open Graph, 
Save Graph, Print Graph, and Close Graph commands 
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To print contour VOI graphs or intensity graphs

1 Select File > Print Graph in the Contour VOI graph window or Intensity 
Graph window, or press Ctrl P. 

The Print dialog box opens.

2 Select the printer and number of copies you want to print.

3 Click OK.

The printer prints the graph.

To close graphs

Select File > Close Graph in either the Contour VOI Graph window or in the 
Intensity Graph window, or press Ctrl X. The graph closes.

Tip: You can also select  to close the graph window.

Figure 235.  Save dialog box for saving contour VOI graphs or 
intensity graphs 
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9 Changing Image Datasets Using

MIPAV Utilities
MIPAV provides a number of utilities that you can use to perform standard 
image-processing tasks such as converting image datasets to another image 
type, transforming images by copying, cropping, or rotating them, and 
changing image datasets by adding, removing, or reordering slices. To 
perform more complex tasks, MIPAV provides algorithms, which are 
covered in volume 2 of the User’s Guide. This chapter  explores the standard 
tasks.

To access the standard image-processing tasks, you use the commands 
(refer to Table 4) on the Utilities menu in the MIPAV window.

Table 4. Standard tasks provided through commands on the Utilities menu in the MIPAV window

Scalar* RGB

Task
Command 2D 3D 4D 2D 3D 4D

Adding image 
margins

Add Image Margins Y Y Y Y Y Y

Copying images Clone (copy) Y Y Y Y Y Y

Concatenating 
datasets

Concatenate Y Y Y Y Y Y

*Scalar includes the following image types: Boolean, byte, unsigned byte, short, unsigned short, 
integer, long, float, and double.
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Converting datasets 
to a different image 
type

Convert Type Y Y Y N N N

Converting 3D to 4D Convert 3D to 4D N Y N N Y N

Converting 4D to 3D Convert 4D to 3D N N Y N N Y

Correcting image 
spacing

Correct Image 
Spacing

N Y Y N N N

Cropping images Crop Y Y Y Y Y Y

Removing 3D 
information from 4D 
dataset 

Extract 3D Subset 
from 4D

N N Y N N Y

Flipping images 
horizontally

Flip > Horizontal Y Y Y Y Y Y

Flipping images 
vertically

Flip > Vertical Y Y Y Y Y Y

Converting datasets 
from grayscale to 
RGB

Grays -> RGB Y Y Y N N N

Adding slices to 
datasets

Insert Slice N Y Y N Y Y

Inverting the order 
of slices in datasets

Inverse Slice Order N Y Y N Y Y

Masking images Mask Y Y N Y Y N

Matching images Match Images Y Y N Y Y N

Adding noise to 
images

Noise Y Y N Y Y N

Randomizing the 
order of slices

Randomize Slice 
Order

N Y Y N Y Y

Table 4. Standard tasks provided through commands on the Utilities menu in the MIPAV window 

Scalar* RGB

Task
Command 2D 3D 4D 2D 3D 4D

*Scalar includes the following image types: Boolean, byte, unsigned byte, short, unsigned short, 
integer, long, float, and double.
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Keeping a log of utilities applied to image 
datasets

Before applying any of the utilities, you may want to place MIPAV in log 
mode. When placed in log modes, MIPAV automatically tracks the utilities 
applied to datasets during the current session. When the session ends, 
MIPAV clears the log.

Rotating images Rotate -> X axis +90 Y Y Y Y Y Y

Rotate -> X axis -90 Y Y Y Y Y Y

Rotate -> Y axis +90 Y Y Y Y Y Y

Rotate -> Y axis -90 Y Y Y Y Y Y

Rotate -> Z axis +90 Y Y Y Y Y Y

Rotate -> Z axis -90 Y Y Y Y Y Y

Removing slices from 
datasets

Remove Slices N Y Y N Y Y

Removing time slices 
from datasets

Remove time slices N N Y N N Y

Manually converting 
datasets from RGB 
to grayscale

RGB -> Gray N N N Y Y Y

Automatically 
converting datasets 
from RGB to 
grayscale

RGB -> Grays N N N Y Y Y

Subsampling images Subsample Y Y N Y Y N

Swapping the third 
and fourth 
dimensions

Swap DIMS 3 <-> 4 N N Y N N Y

Table 4. Standard tasks provided through commands on the Utilities menu in the MIPAV window 

Scalar* RGB

Task
Command 2D 3D 4D 2D 3D 4D

*Scalar includes the following image types: Boolean, byte, unsigned byte, short, unsigned short, 
integer, long, float, and double.
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The Output window displays the log on the Log page. Log entries generally, 
but not always, display the name of the utility and its parameters and 
whether the utility was applied successfully. If it was not applied 
successfully, error messges may also appear in the log. MIPAV maintains a 
separate log for each dataset.

To place MIPAV in log mode

1 Select Help > Program Options. The MIPAV Options dialog box 
(Figure 236) opens.

Note: For more information about the MIPAV Options dialog box, refer to  
“Customizing MIPAV” on page 79.

2 Select the Log mode check box.

3 Click Apply.

4 Click Close (the button at the top right of the dialog box). The MIPAV 
Options dialog box closes.

Figure 236.  MIPAV Options dialog box showing Log mode selected
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From this point on unless you clear the Log Mode check box on the 
MIPAV Options dialog box, the Log page of the Output window tracks 
and displays the utilities applied to images.

Tip: You can type directly onto the Log page of the Output window, letting you 
add comments to the log, which you can save and print as needed.

To turn the log mode off

1 Select Help > Program Options. The MIPAV Options dialog box opens.

2 Clear the Log mode check box. The check mark disappears from the 
check box.

3 Click Apply. 

4 Click Close. The MIPAV Options dialog box closes.

Adding image margins

The Add Image Margins command allows you to add a border of pixels or a 
specific intensity along the edges of an image dataset.

To add image margins

1 Open an image.

2 Select Utilities > Add Image Margins. The Add Image Borders dialog 
box (Figure 237) opens.

3 Enter the number of pixels to add on the left and right sides of the 
image, the top and bottom, and to the front and back of the image.

4 Enter the intensity value for the margins.

5 Select one of the following destinations:

• New image—The software applies the margins to another instance 
of the dataset in a new image window. 

• Replace image—The software adds the margins to the existing 
instance of the dataset.

6 Click OK. The image margins are applied to the dataset.
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Margins 
Around Image

Pixels on the left side: Specifies 
the number of pixels that should 
appear on the left side of the 
image.

Pixels on the right side: 
Specifies the number of pixels 
that should appear on the right 
side of the image.

Pixels on the top: Specifies the 
number of pixels that should 
appear on the top of the image.

Pixels on the bottom: Specifies 
the number of pixels that should 
appear at the bottom of the 
image.

Slices at the front of image: 
Specifies the number of slices that 
should appear at the front of the 
image.

Slices at the back of image: Specifies the number of slices that should appear 
at the back of the image.

Value for 
margins 
(image 
minimum is 
default)

Specifies the intensity of the border around the image. As a default, the intensity 
of the border is the same intensity as that for the image. 

New image Shows the image with the additional or adjusted margins in a new image window.

Replace 
image

Replaces the current active image with the results of the image to which margins 
were added or adjusted.

OK Applies the parameters that you specified to add margins to this image.

Cancel Disregards any changes you made in this dialog box, closes the dialog box, and 
does not add image margins.

Help Displays online help for this dialog box.

Figure 237.  Add Image Border dialog box
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Copying images using the Clone command

Suppose you need to copy an image dataset. To do so, you would use the 
Clone command on the Utility menu. This command generates a duplicate 
of the dataset and any information stored on the image, utility, algorithms, 
VOI, and paint layers.

Note: The Clone utility copies VOIs as well as the image, but it does not copy 
LUT information. Although we can observe its effects, it is not stored in an image 
layer.

If two datasets are loaded into one image window, only the active dataset is 
cloned. When the dataset is duplicated, the duplicate dataset appears in its 
own image window.

To copy an image dataset, you simply select Utility > Clone (copy) in the 
MIPAV window. In a moment or two, a duplicate of the dataset appears in a 
new image window.

Concatenating images

The Concatenate command on the Utilities menu provides you with a way to 
append, or add, two datasets together.

To concatenate image datasets

1 Open the two datasets that you want to join.

2 Select the dataset to which you want to append the other dataset.

3 Select Utilities > Concatenate. The Concatenate Images dialog box 
(Figure 238) opens.

4 Note that the dataset you selected appears in read-only form in the box 
labeled Image A.

5 Select Image B, which is the name of the dataset that you want to add to 
the end of Image A.
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6 Select the dimensionality that you want for the resulting dataset by 
selecting either 3D or 4D.

Note: If both datasets contain the same number of slices, you can select either 
3D or 4D. If the datasets contain a different number of slices, you can only select 
3D.

7 Click OK. The program adds the Image B dataset to the end of the Image 
A dataset and displays the resulting dataset in a new image window.

Image A Specifies the name of the dataset 
to which to append Image B. This 
dataset is the one you selected 
before using the Concatenate 
command.

Image B Specifies the name of the dataset 
that you want to append to the 
Image A dataset.

3D Indicates that the dataset that 
results from appending Image B 
to Image A is three dimensional.

4D Indicates that the dataset that 
results from appending Image B 
to Image A is four dimensional.

OK Applies the changes you made in this dialog box and closes the dialog box.

Cancel Disregards any changes you made in this dialog box, closes the dialog box, and 
does not append Image B to Image A.

Help Displays online help for this dialog box.

Figure 238.  Concatenate Images dialog box
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To verify that the datasets are joined

1 Select the new dataset that resulted from concatenating the Image A and 
Image B datasets.

2 Notice the following on the MIPAV window:

• If you selected 3D as the dimensionality of the resulting dataset in 
the Concatenate Images dialog box, the image slice slider 
(Figure 239A) lists twice as many slices as either the Image A and 
Image B datasets.

• If you selected 4D as the dimensionality of the resulting dataset, a 
time slice slider (Figure 239B) appears beneath the image slice 
slider and the image slice slider lists the same number of slices as 
the Image A and Image B datasets.

Figure 239.  The MIPAV window after concatenating datasets to generate 3D or 4D datasets
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Converting image datasets to different data 
types

In MIPAV you can convert image datasets to different data types. For 
example, you might want to convert a Boolean type dataset to an integer 
type dataset. MIPAV also allows you to simultaneously alter the input and 
output values. This utility is particularly helpful if you want to apply an 
algorithm to a dataset but cannot do so because the original images are the 
wrong image type.

data type—A set of values from which a variable, constant, function, or 
expression may takes its value. MIPAV automates the following data types: 
Boolean, signed byte, unsigned byte, signed short, unsigned short, integer, long, 
float, double, and color 24.

To convert a dataset to a different image type

1 Select Utilities > Convert type. The Convert Image Type dialog box 
(Figure 240) opens.

2 Select the desired image type in the Image Type group.

3 Indicate the start and end input ranges in the Range of input values 
group.

4 Indicate the start and end output ranges in the Range of output values 
group.

5 Specify either Little endian or Big endian in the Endianess group.

6 Click OK. The dataset is converted to the new image type.
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Image Type Specifies the data type. Select one of the following: 

Boolean Indicates whether a condition if true or false.

Byte Primitive 8-bit data type. Valid values range from -127 
to 128.

Unsigned byte Primitive 8-bit data type. Unsigned byte is a variation 
of the integer data type. The unsigned byte data type 
signifies that valid values must fall within a specified 
range of positive whole number values. Valid values 
range from 0 to 255. Negative values are not valid, 
hence the term unsigned byte.

Figure 240.  Convert Image Type dialog box
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Short Primitive 16-bit data type. Short is a variation of the 
integer data type. Short accommodates values that are 
whole numbers. Valid values range from 0 to +32,768.

Unsigned short Primitive 16-bit data type. Unsigned short is a variation 
of the integer data type. The unsigned short data type 
signifies that valid values must fall within a specified 
range of positive whole number values. Valid values 
range from 0 to 65,535. Note that negative values are 
not valid, hence the term unsigned byte.

Integer Primitive 32-bit data type. Integer is sometimes 
abbreviated as int. Integer accommodates values that 
are whole numbers. Valid values range from 
-2,147,483,648 to +2,147,483,648.

Unsigned integer Primitive 32-bit data type.

Long Primitive 64-bit data type. Long is a variation of the 
integer data type. Long accommodates values that are 
whole numbers. Valid values range from 
-9,223,372,036,854,775,808 to 
+9,223,372,036,854,775,808.

Float Primitive 32-bit data type. Float is a floating point data 
type that accommodates decimal values, up to 6 or 7 
significant digits of accuracy. Valid values can range 
from -3.4 x 1038 to 3.4 x 1038.

Double Primitive 64-bit data type. Double is a floating point 
data type that accommodates decimal values, up to 14 
or 15 significant digits of accuracy. Valid values can 
range from -1.7 x 10308 to 1.7 x 10308.

Destination New image Shows the converted dataset in a new image window. 

Replace image Replaces the current active dataset with the converted 
dataset.

Range of input 
values

Use entire image 
range

Converts all intensity values to the result image range 
when converting the image to a different type.

Use user-defined 
range

Converts only the intensity values in the user-defined 
range when converting the image to a different type.

Start input range Specifies the intensity value at the beginning of the 
input range. The default value is the image minimum.

End input range Specifies the intensity value at the end of the input 
range.

Figure 240.  Convert Image Type dialog box (continued)
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Converting 3D to 4D images or 4D to 3D images

To convert 3D images to 4D images

1 Open a 3D image or image dataset.

2 Select Utilities > Convert 3D to 4D. The Convert 3D to 4D dialog box 
opens.

3 Do either of the following in the Number of slices in the 3rd dimension, 
Resolutions: 3rd dimension, and Resolutions: 4th dimension boxes:

• Accept the default numbers.

• Enter different numbers.

4 Select in each of the Resolution units: 3rd dimension and Resolutions 
units: 4th dimension lists one of the following: millimeters (the default 
value), unknown, inches, centimeters, angstroms, nanometers, 
micrometers, milliliters, meters, kilometers, miles, nanoseconds, 
microseconds, milliseconds, seconds, minutes, hours, or Hz.

5 Click OK. The program applies all of the specification in this dialog box 
to the image or image dataset.

Range of 
output values

Starting range Specifies the intensity value at the beginning of the 
output range. The default value is the image minimum.

Ending range Specifies the intensity value at the end of the output 
range.

Endianess Data organization strategy. Refers to the way computer processors store data in 
memory.

Little endian Stores the least significant byte (LSB) first.

Big endian Stores the most significant byte (MSB) first.

OK Applies the parameters that you specified to convert the dataset.

Cancel Disregards any changes you made in this dialog box, closes the dialog box, and 
does not convert the dataset.

Help Displays online help for this dialog box.

Figure 240.  Convert Image Type dialog box (continued)
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To convert 4D to 3D images

1 Open a 4D image or image dataset.

2 Select Utilities > Convert 4D to 3D.

The program immediately begins processing the image.

Correcting image spacing

The Correct Image Spacing command on the Utilities menu corrects images 
in which slice thickness and slice spacing are unequal, which may distort 
images. To understand how this problem can occur, the following section 
presents some background information.

Number of slices in 
the 3rd dimension

Specifies how many 
slices are in the 3rd 
dimension. The 
default number is 2.

Resolutions:
3rd dimension

Indicates the 
resolution for the third 
dimension. The 
default number is 5.0. 

Resolutions:
4th dimension

Indicates the 
resolution for the 
fourth dimension. The 
default number is 1.0.

Resolution units:
3rd dimension

Indicates the voxel 
resolution in the 3rd 
dimension.

Resolution units:
4th dimension

Indicates the voxel resolution of the 4th dimension.

OK Applies the specified parameters to convert a 3D image to a 4D image. 

Cancel Disregards any changes you made in this dialog box, closes the dialog 
box, and does not convert the image.

Help Displays online help for this dialog box.

Figure 241.  Convert from 3D to 4D dialog box
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UNDERSTANDING THE EFFECT OF CONTIGUOUS 
PLANES ON IMAGE SCANNING

Image scanning is usually done in contiguous planes. For example, if the 
first slice is centered at position 5.0 and the slices are 2 mm thick, the 
second slice is centered at 7.0. In such a case, the slice thickness, 2, and the 
slice spacing, 2, are equal. There are, however, two scenarios when the slice 
spacing does not equal the slice thickness:

• Slice spacing is less than the slice thickness—In this case, 
although the images are, for example, 2 mm thick, they are spaced only 
1 mm apart (Figure 242). This scenario arises when the ZIP x 2 feature 
is used during MRI scanning, which enables the acquisition of slices 
only 1 mm apart but uses signals from a 2-mm slab to increase the 
signal-to-noise ratio.

• Slice spacing is greater than the slice thickness—This scenario 
(Figure 242), which is more common than the first, occurs when the 
operator chooses to acquire images at intervals greater than the slice 
thickness (i.e., there is a gap between successive image slices) in order 
to cover a deeper field of view.

MIPAV assumes that successive images are contiguous. So, for example, if 
users chose the triplanar view to display an image that had slice spacing 
larger than slice thickness, the image would appear shortened in the out-of-
plane direction. The Correct Image Spacing utility corrects both situations 
in which the slice thickness and spacing are not equal. Once the correction 
is applied, the slice thickness and slice spacing for the given image dataset 
are the same.

UNDERSTANDING HOW MIPAV SOLVES THIS 
PROBLEM

When the spacing between slices is less than the slice thickness, the Correct 
Image Spacing utility assigns the slice spacing to the slice thickness (refer to 
Figure 242 on page 355 for triplanar views before and after correction). 
When the slice spacing is larger than the slice thickness (refer to Figure 242 
on page 355 for triplanar views before and after correction), the utility 
inserts blank slices between the existing images. 
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Since all slices within an image volume must have the same slice thickness, 
in many cases more than one slice must be inserted and the original images 
must be repeated so that a new value can be found for the slice thickness 
that fits evenly into the original slice spacing. Since there are an infinite 
number of combinations of slice spacing and thickness, not all could be 
handled. Table 5 displays the most common combinations and the 
algorithms MIPAV uses for handling them.

T = Original slice thickness

S = Original space between slices

G = Gap = S - T

M = Number of original images

O = Original image set origin

N = New slice thickness

To use the Correct Image Spacing utility, DICOM images must first be saved 
in XML format. The following DICOM tags (Figure 242 on page 355) are 
used:

• (0018, 0050) Slice Thickness

• (0018, 0088) Spacing Between Slices

You can also find this information listed in the Essential Image Information 
section of the image header (Figure 242 on page 355) as Pixel resolution 2 
(i.e., slice thickness) and Slice Spacing.

To view image attributes

1 Open an image.

2 Select Image > Attributes > View Header. The Header dialog box 
(Figure 242) opens.

3 Find the tags under Essential Image Information to find the values for 
Pixel resolution 2 and Slice Spacing, or find the values of the DICOM 
tags Slice Thickness and Spacing Between Slices.
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.

Table 5. Solutions for correct image spacing

Case

New slice 
thickness

(N)

Number 
of images 
in new set 
for each 
original 
image

Number 
of blanks 
inserted 
for each 
original 
image

Total 
images in 
set now

New image 
set origin 

 

 and 

 and 

 and 2

 and 

 and 

 and 

else don't handle, give message

Legend: 

T = Original slice thickness
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Figure 242.  Views of the Header dialog box showing the tags listed under (A) Essential Image 
Information and (B) the DICOM tags in a later section of the header. 
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To save images as XML files

The Correct Image Spacing utility works only on XML files.

1 Open the image that has spacing problems if you have not already done 
so.

2 Select File > Save Image as in the MIPAV window. The Open dialog box 
appears.

3 Type the name for the file including the XML extension in File Name.

4 Select Medical, which includes XML files, in Files of Type. The Choose 
File Type dialog box (Figure 243) opens.

5 Scroll down and select XML.

6 Click OK. The program saves the image as an XML file.

Figure 243.  Choose File Type dialog box
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To correct image spacing

1 Open the image that contains spacing problems. 

Tip: To determine whether images contain spacing problems, remember to view 
them using the triplanar view or to view the header file.

2 Save the image as an XML file.

3 Select Utility > Correct Image Spacing. 

If the image file does have spacing problems, then the program runs the 
utility. 

If the image spacing is correct, the program displays a message 
(Figure 244) indicating that the spacing is correct.

Cropping images

You can use the Crop command on the Utilities menu to trim an image so 
that only the selected portion of the image remains. 

To crop an image

1 Open an image.

2 Draw one or more contours on the image on the area that you want to 
remain in the image. When the utility is run, the area inside the 
contours remains and the areas outside the contour are discarded from 
the new dataset.

Figure 244.  Message received when image spacing is already correct
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3 Select the VOI or one or more of the contours. 

4 Select Utilities > Crop. The Crop dialog box (Figure 246) appears.

5 Type the number of pixels that you want to use for the border size in 
Border size box. Specify a number from 0 to 50.

6 Select either the New image or the Replace image check box to indicate 
whether the program should display the cropped image in a new image 
window or replace the original image with the cropped image.

7 Click OK. After a moment, the new image appears.

Figure 245.  Contouring the area that should remain in the cropped image
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Border size of VOI: 

Border size (0 - 50)

Indicates the width of a strip of voxels that surround (border) the 
contours. When you crop an image, the area inside the contours and the 
border remain. All other voxels are trimmed from the image.

Coordinates of VOI Displays the coordinates for the X, Y, and Z axes of the VOI.

New image Shows the cropped image in a new image window. 

Replace image Replaces the current active image with the cropped image.

OK Applies the parameters that you specified to crop the image.

Cancel Disregards any changes you made in this dialog box, closes the dialog 
box, and does not crop the image.

Help Displays online help for this dialog box.

Figure 246.  Crop dialog box 
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Removing 3D subset from 4D

This utility allows you to remove one of the x, y, z, or t dimensions from 4D 
images to produce a 3D image.

To remove an X dimension slice

1 Open a 4D image.

2 Select Utilities > Extract 3D Subset from 4D. The Extract 3D Subset 
dialog box (Figure 247) opens.

3 Select X.

4 Type the index number of the slice you want to extract in the Select 
index from. <N> to <N> box.

5 Click Remove. The program removes the slice you specified from the 
dataset.

To remove a Y dimension slice

1 Open a 4D image.

2 Select Utilities > Extract 3D Subset from 4D. The Extract 3D Subset 
dialog box (Figure 247) opens.

3 Select Y.

4 Type the index number of the slice you want to extract in the Select 
index from. <N> to <N> box.

5 Type the index number of the slice you want to extract in the Select 
index from. <N> to <N> box.

6 Click Remove. The program removes the slice you specified from the 
dataset.

To remove a Z dimension slice

1 Open a 4D image.

2 Select Utilities > Extract 3D Subset from 4D. The Extract 3D Subset 
dialog box (Figure 247) opens.
MIPAV User’s Guide, Volume 1, Basics 360

9/20/04 



M   I   P   A   V
M e d i c a l   I m a g e   P r o c e s s i n g, A n a l y s i s,   &   V i s u a l i z a t i o n

Chapter 9,  Changing Image Datasets Using MIPAV Utilities
3 Select Z. 

4 Type the index number of the slice you want to extract in the Select 
index from. <N> to <N> box.

5 Click Remove. The program removes the slice you specified from the 
dataset.

To remove the T dimension

1 Open a 4D image.

2 Select Utilities > Extract 3D Subset from 4D. The Extract 3D Subset 
dialog box  (Figure 247) opens.

3 Select T. 

4 Type the index number of the slice you want to extract in the Select 
index from. <N> to <N> box.

5 Click Remove. The program removes the slice you specified from the 
dataset.

.

X Specifies that the algorithm 
should remove the X (width) 
dimension.

Y Specifies that the algorithm 
should remove the Y (height, or 
length) dimension.

Z Specifies that the algorithm 
should remove the Z (depth) 
dimension.

T Specifies that the T (time) 
dimension should be removed.

Index from 
<N> to <N>

Specifies the index number of the volume or slice that you want to extract from the  
dataset.

Remove Removes the specified dimension.

Cancel Disregards any changes you made in this dialog box, closes the dialog box, and 
does not remove any dimensions.

Help Displays online help for this dialog box.

Figure 247.  Extract 3D Subset dialog box
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Flipping images horizontally or vertically

MIPAV allows you to flip images either horizontally or vertically. To flip an 
image, select either Utilities > Flip > Horizontal or Utilities > Flip > 
Vertical. After a few moments, the flopped image replaces the original 
image in the same image window.

Figure 248.  Original image and image flipped horizontally and vertically
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Converting grayscale images to RGB images

You can convert grayscale image datasets to RGB. RGB images have three 
channels (red, green, and blue) that contain image data.If you open two 
datasets in one image window, you can create a composite image that 
contains a mixture of the red, green, and blue channels.

To convert grayscale images to RGB images

1 Open an image.

2 Select Utilities > Grays -> RGB. The Concatenate -> RGB dialog box 
opens.

3 Select the image to which you want to apply the red channel in the 
Image (red) list. If you loaded two images into the image window, two 
file names should appear.

4 Do the same for the Image (green) list and the Image (blue) list.

5 Indicate whether you want to remap to current intensity values to the 
full standard 0–255 RGB values.

Note: Generally, each color is defined as one of the 256 intensities. If you remap 
the grayscale intensities and select Remap data, the system defines the 
intensities as one of the 256 values. If one or all of the input images have values 
that exceed 255 and you do not select Remap data, then data truncates to 255 
since a color channel can only represent values 0–255.

6 Click OK. A status message appears. When filtering is complete, the new 
RGB image appears in a separate image window.
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Inserting slices into image datasets

When you change an image dataset, you are inserting or removing slices in 
the dataset or changing their order.

You can use the Insert Slice command on the Utilities menu to insert a slice 
into an image dataset. Although you cannot insert a slice from another file, 
you can insert either a blank slice or a new slice that is an average of two 
adjacent slices in the dataset.

To insert slices into image datasets

1 Select Utilities > Insert Slice. The Insert Slice dialog box appears.

2 Enter the number of the new slice position in the Insert before slice (1-
124) or enter 125 for new last slice box.

Image (red) Identifies the image to be added 
to the red channel of the resulting 
image.

Image 
(green)

Identifies the image to be added 
to the green channel of the 
resulting image.

Image (blue) Identifies the image to be added 
to the blue channel of the 
resulting image.

Remap data 
(0-255)

Indicates, when selected, that 
you want image intensities to be 
remapped to values 0-255, which 
is the standard for RGB images. 

OK Applies the parameters that you specified to create an RGB image. 

Cancel Disregards any changes you made in this dialog box, closes the dialog box, and 
does not create an RGB image.

Help Displays online help for this dialog box.

Figure 249.  Concatenate -> RGB dialog box
MIPAV User’s Guide, Volume 1, Basics 364

9/20/04 



M   I   P   A   V
M e d i c a l   I m a g e   P r o c e s s i n g, A n a l y s i s,   &   V i s u a l i z a t i o n

Chapter 9,  Changing Image Datasets Using MIPAV Utilities
3 Select either the Average or Blank radio button. If you select Average, 
MIPAV analyzes the slices immediately before and after the new slice in 
the dataset. The software then generates an intermediary composite by 
morphing the two slices. This composite becomes the new slice. If you 
select Blank, MIPAV inserts a blank slice in the dataset.

4 Click OK. MIPAV inserts the new slice into the dataset and opens the 
new dataset in a new image window.

Insert before 
slice (1-124) 
or enter 125 
for new last 
slice

Specifies the position of the 
new slice.

Average Inserts a slice that is the 
average the adjacent slices.

Copy previous 
adjacent

Insert a slice that is a copy of 
the preceding slice.

Copy next 
adjacent

Inserts a slice that is a copy 
of the following slice.

Blank Inserts a blank slice.

Original Inserts an image from the 
original dataset. 

OK Applies the parameters that you specified to insert the slice in the image dataset. 

Cancel Disregards any changes you made in this dialog box, closes the dialog box, and 
does not insert the slice into the image dataset.

Help Displays online help for this dialog box.

Figure 250.  Insert Slice dialog box
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Inverting the order of images (slices) in 
datasets

As its name implies, the Inverse Slice Order command on the Utilities menu 
reverses the order of the slices in a dataset. 

To invert the order of images in datasets

1 Open an image that contains slices.

2 Use the image slider in the MIPAV window to locate slices that you want 
to inverse.

3 Select Utilities > Inverse Slice Order.

A status message appears and indicates that the software is reordering 
the slices in the dataset. In a moment or two the MIPAV window 
refreshes, and the image window in which the original dataset appeared 
displays the reordered slices.

Masking images

Masks allow you to remove portions of images and display only those 
portions as separate image files. For example, you may only be interested in 
a section of an image and only want to display and work with that section.

To create a mask, you first need to create one or more VOIs on the image. 
Depending on the type of mask you want to create, the VOIs should do 
either of the following:

• Enclose the image areas you want to preserve

• Enclose the image areas you do not want to preserve

If the VOIs indicate the areas of the image that should be deleted from the 
image, you need to create an interior mask and specify the number of pixels 
the program should use to hide the image inside the VOIs, or interior 
(Figure 251B).

To preserve the image inside the VOIs, however, you need to create an 
exterior mask. An exterior mask fills the image outside of the VOIs with the 
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number of pixels you specify. This filling hides the portions of the image 
outside the VOIs, or exterior (Figure 251C).

To create an interior mask

1 Open an image.

2 Create one or more VOIs that enclose the portions of the image that 
interest you.

3 Select Utilities > Mask. The Mask dialog box (Figure 252) opens.

4 Type the number of pixels to fill the interior of the VOIs.

5 Select Interior fill.

Figure 251.  Interior and exterior masks
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6 Select either New Image or Replace Image depending on which you 
prefer.

7 Click OK. The program either displays a new image or replaces the 
current image with an image that hides the portions of the image that 
are inside the VOIs (Figure 251B). 

To create an exterior mask

1 Open an image.

2 Create one or more VOIs that enclose the portions of the image that 
interest you.

3 Select Utilities > Mask. The Mask dialog box (Figure 252) opens.

4 Type the number of pixels to fill the interior of the VOIs.

5 Select Exterior fill.

6 Select either New Image or Replace Image depending on which you 
prefer.

7 Click OK. The program either displays a new image or replaces the 
current image with an image that hides the exterior of the image outside 
the VOIs (Figure 251C).

Parameters Specifies the value in pixels to 
fill the VOI.

Interior fill Applies the value to the interior 
of the VOI.

Exterior fill Applies the value to the exterior 
of the VOI.

New image Shows the cropped image in a 
new image window. 

Replace image Replaces the current active 
image with the cropped image.

OK Applies the parameters that you specified to mask the image.

Cancel Disregards any changes you made in this dialog box, closes the dialog box, 
and does not mask the image.

Help Displays online help for this dialog box.

Figure 252.  Mask Image dialog box
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Matching images

The Match Images command on the Utilities menu assists in any 
comparison of two images. To use this utility, you need to first open two 
images: image A, which has the desired characteristics, and image B, whose 
characteristics need to match those of Image A. The Match Images dialog 
box presents the following four ways in which you can match the images:

• Match image orientation—Rotates Image B so that its orientation 
is the same as the orientation of image A.

• Match resolutions—Subsamples the image for each dimension with 
lower resolution (i.e., larger pixel size) so that both images have the 
same resolution. To ensure that the fields of view remain the same, the 
program adds extra pixels to the image.

• Match origins—Adds margins to one of the images for each 
dimension if the origins (i.e., the starting location) of the two images 
are not the same. The program also adds pixels to the left, top, or front 
of the image.

• Match image dimensions—Adds pixels to the right, bottom, or 
back of either image so that they have the same dimensions.

You can select one or more of these choices in the dialog box. Before actually 
performing any selected comparison, MIPAV first checks to see whether the 
images do not already match in that regard. If they do, the given match is 
not performed.

To match image orientation

1 Open two images.

2 Select Utilities > Match images. The Match Images dialog box 
(Figure 253) opens.

3 Select one of the open images as image A, and select the other image as 
image B.

4 Select Match image orientations (based on imaging orientation).
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5 Select any or all of the other check boxes to also, if desired, match image 
resolutions, origins, or dimensions.

6 Click OK. If the orientations of the images differ, the program changes 
the orientation of Image B to match that of image A.

To match image resolutions

1 Open two images.

2 Select Utilities > Match images. The Match Images dialog box 
(Figure 253) opens.

3 Select one of the open images as image A, and select the other image as 
image B.

4 Select Match image orientations (based on imaging orientation).

5 Select any or all of the other check boxes to also, if desired, match image 
resolutions, origins, or dimensions.

6 Click OK. If the resolutions of the images differ, the program changes 
the resolution of Image B to match that of image A.

To match image origins

1 Open two images.

2 Select Utilities > Match images. The Match Images dialog box 
(Figure 253) opens.

3 Select one of the open images as image A, and select the other image as 
image B.

4 Select Match image origins (by adding margins where necessary).

5 Select any or all of the other check boxes to also, if desired, match image 
orientations, resolutions, or dimensions.

6 Click OK. If the origins of the images differ, the program changes the 
origin of Image B to match that of image A.

To match image dimensions

1 Open two images.

2 Select Utilities > Match images. The Match Images dialog box 
(Figure 253) opens.
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3 Select one of the open images as image A, and select the other image as 
image B.

4 Select Match image dimensions.

5 Select any or all of the other check boxes to also, if desired, match image 
orientations, resolutions, or origins.

6 Click OK. If the dimensions of the images differ, the program changes 
the dimension of Image B to match that of image A.

Image A Specifies the image that contains the orientation, resolution, 
origins, or dimensions with which Image B needs to match.

Image B Specifies the image on which to perform the image matching.

Match image orientations 
(based on imaging 
orientation)

Applies the image orientations (based on image orientation) used 
in Image A to Image B.

Match image resolutions, 
axis by axis (subsampling 
image with lower resolution)

Matches the image resolutions in Image A to Image B. Note that 
this subsamples Image A with a lower resolution if necessary.

Match image origins (by 
adding margins where 
necessary)

Matches the image origins used in Image A to Image B. Note that, 
if necessary, this adds margins to Image B.

Match image dimensions Applies the image dimensions used in Image A to Image B.

OK Applies the parameters that you specified to add margins to this 
image.

Figure 253.  Match Images dialog box
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Adding noise to images

Adding noise to images allows you to test the robustness and performance 
of an algorithm in the presence of known amounts of noise. When you select 
Utilities > Noise, the program clamps either Gaussian or uniform noise to 
the lowest or highest value in the source image type..

This class relies heavily on the Java Random class and is used to generate a 
stream of pseudorandom numbers. The class uses a 48-bit seed, which is 
modified using a linear congruential formula (refer to Donald Knuth, The 
Art of Computer Programming, Volume 2, Section 3.2.1.).

To add noise to images

1 Open an image on which you want to test the effectiveness of an 
algorithm.

2 Select Utilities > Noise in the MIPAV window. The program displays the 
Additive Noise dialog box (Figure 254).

3 Type the level of noise that you want to add to the image in the Noise 
level box. You can specify a value from 10 to 32,768.

Cancel Disregards any changes you made in this dialog box, closes the 
dialog box, and does not perform image matching.

Help Displays online help for this dialog box.

Figure 253.  Match Images dialog box (continued)

Noise level (0-32768) Specifies the level of noise to 
add to the image. 

The default value is 10.

Gaussian Adds Gaussian or uniform 
noise to the image.

Uniform Adds Uniform noise to the 
image.

New image Shows the cropped image in a 
new image window. 

Figure 254.  Additive Noise dialog box
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4 Type the level of noise that you want to add to the image in the Noise 
level box. You can specify a value from 10 to 32,768.

5 Select either of the following:

• Gaussian—To add Gaussian noise to the image

• Uniform—To add Uniform noise to the image

6 Select either of the following:

• New image—To generate the resulting image in a new image window

• Replace image—To replace the current image with the resulting image

7 Click OK. The program adds the Gaussian or Uniform noise to the image 
and displays either a new image or replaces the current image with the 
one to which noise was added.

8 Select the algorithm in the Algorithms menu to test its effectiveness on 
the image.

Example. In the following example (Figure 255), the original image appears at 
the top of the figure. The next row shows the image on the left that results from 
adding Gaussian noise of 100. To its right is the image after running the Median 
algorithm. The image on the left on the last row results from adding Uniform 
noise of 100 to the orginal image. Running the Median algorithm on that image 
produces the image on its right. In this example, the Median algorithm performs 
better on an image containing Gaussian noise.

Replace image Replaces the current active image with the cropped image.

OK Applies the parameters that you specified for adding noise to this image.

Cancel Disregards any changes you made in this dialog box, closes the dialog 
box, and does not add noise to this image.

Help Displays online help for this dialog box.

Figure 254.  Additive Noise dialog box (continued)
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Figure 255.  Examples of adding noise to an image and using it to test an 
algorithm’s effectiveness in removing the noise
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Randomizing image (slice) order

To randomize the order of slices in the image dataset, do the following:

1 Open an image that contains slices.

2 Use the image slider in the MIPAV window to locate slices that you want 
to remove. 

3 Write the slice numbers on a piece of paper.

4 Select Utilities > Randomize Slice Order. A status message appears, and 
the system arbitrarily reorganizes the slices.

A status message appears. Then the MIPAV window refreshes and, 
depending on your selection, the new dataset appears in either a new 
image window or in the same image window as the original dataset.

Rotating images

You can rotate images about the x, y, and z axes. For example, suppose that 
you opened the following image:

Figure 256.  Original image to be rotated
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To rotate images

1 Select Utilities > Rotate in the MIPAV window.

2 Select one of the following:

• X Axis +90: To rotate the image about the x axis by +90 degrees.

• X Axis -90: To rotate the image about the x axis by -90 degrees.

• Y Axis +90: To rotate the image about the y axis by +90 degrees.

• Y Axis -90: To rotate the image about the y axis by -90 degrees.

• Z Axis +90: To rotate the image about the z axis by +90 degrees.

• Z Axis -90: To rotate the image about the z axis by -90 degrees.

A status message appears. When rotation is complete, the status window 
closes, and MIPAV replaces the original image in the image window with 
the rotated image.

Figure 257.  Rotation
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Figure 258.  Examples of rotated images

This figure shows the image in Figure 256 at the six different types of x, y, and z 
rotation.
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Removing images (slices) from datasets

MIPAV allows you to remove one, several, or all slices from an image 
dataset. In addition, you can specify one or more ranges of slices to remove, 
or slice removal can include only the even-numbered or only the odd-
numbered slices.

To remove slices from datasets

1 Select Utilities > Remove slices. The Remove Slices dialog box opens.

2 Use the image slider in the MIPAV window to locate slices that you want 
to remove.

3 Decide whether to remove:

• One or more slices

• Most of the slices

• One or more ranges of slices

• All even-numbered slices

• All odd-numbered slices

Tip: Use the image slider on the MIPAV window to look at specific slices to decide 
which slices to remove.

4 Select one of the following:

• New image—If the new image dataset should appear in its own image 
window

• Replace image—If the dataset should overwrite the original dataset 
and appear in the original image window

5  Select Remove. A status message appears. Then the MIPAV window 
refreshes and, depending on your selection, the new dataset appears in 
either a new image window or in the same image window as the original 
dataset.
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Slices Indicates the slices that you want 
to remove from the dataset. You 
can scroll through the list to 
select one or more slices.

Select all Selects all of the slices in the 
dataset.

Clear Clears all of the slices that are 
currently selected.

Check even Selects all of the even-numbered 
slices.

Check odd Selects all of the odd-numbered 
slices.

Specify range 
of slices

Indicates that you want to 
remove one or more slices or a 
range of slices from the dataset. 

If you select this check box, you 
must specify the slices or ranges 
of slices you want to remove. in 
the Slice number or range of 
slices box below. 

Slice number or 
range of slices

Indicates the specific slices and range of slices that you want to remove.

New image Shows the results of the slice removal in a new image window.

Replace image Replaces the current active dataset with the dataset resulting from the slice 
removal in the same image window.

Remove Removes the slices that you indicated in this dialog box. 

Cancel Disregards any changes that you made in this dialog box and closes the dialog 
box.

Help Displays online help for this dialog box.

Figure 259.  Remove Slices dialog box
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Removing time volumes

If an image dataset contains blank images or unusable images, which might 
be caused by patients blinking their eyes during tests, the Remove Time 
Volumes command on the Utility menu in the MIPAV window allows you to 
remove unusable images from the dataset.

To remove time volumes

1 Open an image dataset that contains time volumes.

Note: The Remove Time Volumes command only becomes active for 4D image 
datasets.

2 Use the image slider to look through the dataset one time volume, or 
image, at a time (Figure 260). If you find an unusable volume—one that 
is blank, or totally black, or that contains unusable information—stop 
moving the slider on that volume.

Note: The volume number appears in the title bar of the MIPAV window and 
correlates to the slice indicated by the image slider.

3 Select Utilities > Remove time volumes. The Remove Time Volumes  
dialog box (Figure 259 on page 379) opens.

4 Select the volume or volumes that you want to remove in the list at the 
top of the dialog box, or type the number of the slice or range of volumes 
in the Check the time slices to remove group box.
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5 Do either of the following:

• Click Select all to remove all of the slices.

• Click Remove to remove the slices you selected. 

A status message appears. Then the MIPAV window refreshes.

6 Use the image slider again, if you’d like, to look through the slices in the 
dataset to verify that the appropriate slices were removed.

Figure 260.  Using the image slider to look through an image dataset
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Converting RGB datasets to grayscale datasets

On the Utilities menu in the MIPAV window, the RGB conversion utility 
offers both a manual and an automatic method of converting RGB datasets 
to grayscale RGB images.

• Manual conversion—In the manual method of conversion, you 
select Utilities > RGB > RGB -> Gray to display the RGB -> Gray dialog 
box (Figure 262). The dialog box provides three weighting methods:

• Equal weights—This method assigns equal weights to each of the 
three color channels. When you select this option, you can also select 
the Only average RGB values greater than check box and specify a 
threshold value. For example, if you specify a threshold value of 50, 
the program ignores any pixel in that channel that contains a value 
over 50.

Note: You can only specify a threshold when you choose to use the equal 
weights method of conversion.

• Computer graphics weights—This method assigns the weights to 
each channel that are typically used to display computer graphics.

• User-specified weights—In this method, you enter the specific 
weights for each color channel.

• Automatic conversion—If, instead, you select Utilities > RGB > 
RGB -> Grays, the program automatically converts the RGB image to 
three grayscale images: one each for the red, blue, and green channels.
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RGB datasets have four channels: red, green, and blue. When you convert 
RGB datasets to grayscale. RGB images, the intensities are combined to 
form a single grayscale value. For example::

where 

N = New grayscale pixel

R = Red channel

G = Green channel

B = Blue channel

RW = Weight assigned to the red channel

GW = Weight assigned to the green channel

BW = Weight assigned to the blue channel

Figure 261.  The Utilities > RGB menu

N R RW G GW B BW×+×+×=
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Equal weights Assigns the same 
weight (0.3333) to 
each channel in the 
image. When you 
select this option, the 
Only average RGB 
values great than 
becomes available.

Computer 
graphics

Assigns the weighting 
factors typically used 
in computer graphics 
to each channel in the 
image: 

• Red, 0.299
• Green, 0.587
• Blue, 0.114

User specified Specifies a weight that you determine for each channel. When you select this 
check box, you must type a specific weight for each channel in the Red, Green, 
and Blue boxes.

Red Specifies the weight assigned to the red channel in the image. You can only specify 
a weight in this box if you selected the User specified option.

Green Specifies the weight assigned to the green channel in the image. You can only 
specify a weight in this box if you selected the User specified option.

Blue Specifies the weight assigned to the blue channel in the image. You can only 
specify a weight in this box if you selected the User specified option.

Only average 
RGB values 
greater than

Excludes any voxel in the image over the threshold value that you specify in this 
box. This check box is only available when you select the Equal Weights option.

OK Applies the parameters that you specified to create a grayscale image. 

Cancel Disregards any changes you made in this dialog box, closes the dialog box, and 
does not create a grayscale image.

Help Displays online help for this dialog box.

Figure 262.  RGB -> Gray dialog box
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To manually convert RGB datasets to grayscale

1 Select Utilities > RGB > RGB -> Gray: The RGB -> Gray dialog box 
(Figure 262) opens. 

2 Select one of the following weighting methods: equal weights, computer 
graphics, or user specified.

• If you selected Equal Weights, decide whether to apply a threshold 
to the RGB channels. If you want to apply a threshold, select Only 
average RGB values greater than and enter the threshold value. 
Then go to the next step.

• If you selected Computer graphics or User specified, go to the next 
step.

3 Click OK. A status message appears. In a few moments, the image is 
replaced by the new grayscale dataset.
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To automatically convert RGB datasets to grayscale 
image

Select Utilities > RGB > RGB -> Grays. The program briefly displays a 
status message during the conversion and then generates three new 
grayscale datasets, one for each channel.

Figure 263.  Manually converting RGB datasets to grayscale
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Subsampling images

The subsample utility in MIPAV allows you to reduce an image in size by a 
factor of 2, 4, or 8 times. Each pixel of the subsampled image is a Gaussian-
weighted average of the original image’s 8 neighboring pixels for 2D images 
or 26 neighboring voxels for 3D images. For example, subsampling a 3D 
image with the x, y, and z dimensions of 256 x 256 x 32, respectively, by a 
factor of 2 produces a new image with x, y, and z dimensions of 128 x 128 x 
16, respectively.

Figure 264.  Example of three grayscale datasets generated 
automatically from an RGB dataset
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To subsample images

1 Open an image (Figure 265).

2 Select Utilities > Subsample. The Subsample dialog box (Figure 266) 
opens.

.

3 Select one of the following:

• Subsample by 2

• Subsample by 4

• Subsample by 8

Figure 265.  Original image before subsampling
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4 Select, as an option for 2.5D images only, the Process each slice 
independently (2.5D) check box.

Tip:  If you are not working with 2.5D images, the Process each slice 
independently (2.5D) check box does not appear in the Subsample dialog box.

5 Click OK. A status message appears briefly while the program generates 
the subsampled image in a new image window.

Subsample by 2 Subsamples each 
image dimension by a 
factor of 2.

Subsample by 4 Subsamples each 
image dimension by a 
factor of 4.

Subsample by 8 Subsamples each 
image dimension by a 
factor of 8.

Process each slice 
independently 
(2.5D)

Filters each slice of the dataset independently of adjacent slices.

OK Applies the parameters that you specified to subsample the image.

Cancel Disregards any changes you made in this dialog box, closes the dialog box, 
and does not subsample the image.

Help Displays online help for this dialog box.

Figure 266.  Subsample dialog box
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Swapping the third and fourth dimensions

Swapping the third and fourth dimensions refers to how image datasets are 
stored. Datasets may be stored using the following two methods:

• xytz (horizontal, vertical, time, third dimension)

• xyzt (horizontal, vertical, third dimension, time)

Because MIPAV requires that datasets be stored using the xyzt method, it 
provides the Swap Dims 3 <-> 4 command for those users whose datasets 
may be stored using the xytz method.

Figure 267.  An image subsampled by 2, by 4, and then by 8
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To swap the third and fourth dimensions

1 Open an image that is stored using the xytz method.

2 Select Utilities > Swap Dims 3 <-> 4. A progress message (Figure 268) 
appears briefly while the program changes the storage method of the 
image and replaces the image with one that is stored using the xyzt 
method.

Figure 268.  Progress message for swapping the third and fourth 
dimension
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10 Using Scripts (Macros) in MIPAV
MIPAV provides three different methods of customizing the program. The 
first method involves developing scripts, which you use directly within the 
program. In the second method, you also develop scripts but you initiate, or 
call, them from another program. Developing scripts does not require 
programming skills or learning a new script language, and calling them 
from another program may require, depending on the program, only 
minimal programming knowledge. This chapter discusses developing and 
using scripts.

The third method of customizing MIPAV—developing plug-in programs—
does require Java programming skills. For more information about this 
method, refer to Chapter 11, “Developing Plug-in Programs,” for more 
information.

Using scripts

Scripts, sometimes referred to as macros in other programs, record a series 
of commands or actions on specific images or groups of images that you can 
run with a single command. Using scripts can increase productivity and 
improve efficiency in performing commonly repeated actions or a series of 
actions. Most important, you can use scripts to process a large set of user-
defined images.
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Displaying the scripting toolbar
To display the scripting toolbar, select Toolbar > Scripting in the MIPAV 
window. The scripting toolbar immediately appears beneath the VOI 
toolbar or, if you choose to also display the Paint toolbar, immediately 
below that.

Remember: Select Help > Program Options in the main MIPAV window and 
then select Show Scripting toolbar in the MIPAV Options dialog box to always 
display the scripting toolbar.

Creating scripts
The scripts home is the directory in which you store scripts and from which 
you run them. After you select a scripts home, the name of one of the scripts 
(which are ordered alphabetically) in that directory appears after Current 
Script on the scripting toolbar (Figure 270). If there are several scripts in 

Figure 269.  MIPAV Options dialog box with Show scripting  
toolbar selected
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the directory, Current Script becomes a list box from which you can select 
the script you want to run.

Recommendation: Although you can select or change the scripts home at 

any time, you might want to do so before creating any scripts to complete the 

setup of your system.

Figure 270.  The MIPAV window (A) before selecting a scripts home and 
(B) after selecting a scripts home and running the first script
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Before creating scripts, it is helpful to understand that there are two 
methods for creating them:

• Active mode—In active mode one or more images are already open 
when you create the script. Because images are open, MIPAV assumes 
that the script applies to the active image. The active image is the 
image that is currently selected (Figure 271). To create a script in active 

mode, you simply click , the Start Recording Script icon, on the 
scripting toolbar.

• Group mode—In group mode no images are open when you begin 
creating the script, and the MIPAV window appears in its initial small 
size, which only displays some of the menus. Generally, you use the 
group mode to create scripts that apply to multiple image files. To 
create a script in group mode, click File > Scripts > Record Script.

It’s also important to understand which actions you can record in a script. 
For example, scripts do not record views, such as lightbox, triplanar, and 
volume renderer nor do they record other visualization commands, such as 
those that adjust the lookup table. Actions that you can record in a script 
include all of the algorithms and utility commands and the creation of VOIs.

Figure 271.  An (A) active image, whose title bar is highlighted, and 
(B) inactive image, whose title bar is dimmed
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This section explains the following tasks:

• Selecting a scripts home (see “To select a scripts home” on page 396)

• Creating scripts in active mode (see “To create scripts using the active 
mode” on page 397)

• Creating scripts in group mode (“To create scripts using the group 
mode” on page 400)

• Stop recording scripts during creation (“To stop recording scripts 
during creation” on page 402)

To select a scripts home

1 Start MIPAV. The initial MIPAV window opens.

2 Open an image. The expanded MIPAV window appears.

3 Select Toolbars > Scripting if the scripting toolbar is not displayed. The 
scripting toolbar appears (Figure 272A).

Note: Notice that a dimmed rectangle appears immediately following the words 
Current Script in the scripting toolbar. After you select a scripts home and run a 
script for the first time, Current Script becomes a list box that shows the name of 
a script in the scripts home directory (Figure 272B).

4 Select Scripts Home. The Choose Directory dialog box (Figure 273) 
appears. 

Note: The Choose Directory dialog box only shows directories, not individual 
files.

Figure 272.  A comparison of (A) the initial scripting toolbar and (B) the  
toolbar as it looks after you identify a scripts home and run your first 
script
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5 Select a directory in which to store your scripts.

6 Click Open. The Choose Directory dialog box closes.

To create scripts using the active mode

1 Start MIPAV. The initial MIPAV window and the Output window open.

2 Open the image on which you want to run the script. The MIPAV 
window expands.

3 Click , the Start recording script icon, on the scripting toolbar to 
create a script in active mode.

Note: The icon turns red ( ) to indicate that MIPAV is now recording a script.

The Record New Script dialog box (Figure 275) opens. The following 
appears at the top of the dialog box: “The script is now recording. Your 
actions will be recorded below.”

Figure 273.  Choose Directory dialog box
MIPAV User’s Guide, Volume 1, Basics 397

9/20/04 



M   I   P   A   V
M e d i c a l   I m a g e   P r o c e s s i n g, A n a l y s i s,   &   V i s u a l i z a t i o n

Chapter 10,  Using Scripts (Macros) in MIPAV
4 Delineate VOIs and perform as many actions (algorithms and utilities) 
as you want on the image. VOI commands do not appear on the 
scripting box on the Record New Script dialog box. To run the script 
later, you need to save the VOIs.   

If you need to create a VOI to perform an action, save the VOI by 
selecting VOI > Save VOI. The program saves the VOI to the Scripts 
Home directory under the name AreaN.voi where N is a number that is 
assigned sequentially. The name of the first VOI that you save is 
Area1.voi; the second is Area2.voi; and so on. Make sure you type the 
.voi extension to the file.

If you want to specify a different name for the VOI,  select VOI > Save 
VOI as. The Save VOI as dialog box opens. Type a name for the VOI in 
File name, and click Save. The program saves the file under the name 
you specified.

File Open—Opens a previously saved script. 
When you select this command, the Open 
dialog box appears.

Save—Saves the script under the name 
you specify. When you select this 
command, the Save dialog box appears.

Exit—Closes this dialog box without 
saving the script.

Pause Stops recording the script. When you 
select this button, the name of the button 
changes to “Resume.”

Resume Activates the recording process. When you 
select this button, the name changes to 
“Pause.” 

Scripting 
box

Displays the actions in the script as a 
series of commands.

Enable 
Edit

Allows you to make changes or corrections to the script. When you select this button, 
the scripting box turns from gray to white to indicate that you can now type, copy, or 
past information into it or delete information from it.

Disable 
Edit

Prevents any changes or corrections being made to the existing script. When you select 
this button, the scripting box turns from white to gray and the button name changes to 
“Enable Edit.”

Figure 274.  Record New Script dialog box
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Note: When you are creating a script in active mode, the word $active appears 
in commands on the Record New Script dialog box. For example, if you flip the 
image horizontally, the program adds “Flip $active1 Y” (refer to the following 
example).

5 Save and close the image.

6 Select File > Save in the Record New Script dialog box when you are 
finished creating the script. The Save dialog box opens.

7 Type a name for the script in File name.

Tip: The file name extension for script files is .sct. Make sure that you type the 
extension at the end of the file name.

8 Click Save. The program saves the script in the scripts home directory.

9 Click File > Exit to close the Record New Script dialog box. The dialog 
box closes. You should now be able to select the script in Current Script.

An Example:
Recording a Script in Active Mode

In this example, the user wanted to flip the image, delineate a VOI on the 
image, crop the image based on that VOI, and use the gradient magnitude 
algorithm on the cropped image. Notice the word active. The last two 
commands are closing the images. 
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To create scripts using the group mode

1 Start MIPAV. The initial MIPAV window and the Output window open.

Select File > Scripts > Record Script. The Record New Script dialog box 
(Figure 275A) opens. The following appears at the top of the dialog box: 
“The script is now recording. Your actions will be recorded below.”

2 Open an image on which you want to run the script. The MIPAV window 
expands. 

The command OpenImage $image1 now appears in the scripting box 
(Figure 275B) in the Record New Script dialog box. If you continue to 
open images, the $imageN attribute is sequentially ordered. That is, the 
command to open the second image is OpenImage $image2; the 
command to open the third image is OpenImage $image3; and so on.

Note: Just as when you’re creating a script in active mode, the Start recording 

script icon is red ( ) to indicate that MIPAV is now recording a script.

3 Delineate VOIs and perform as many actions (algorithms and utilities) 
as you want on the image. 

Figure 275.  The (A) Record New Script dialog box and (B) the scripting dialog box after opening 
an image in group mode
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VOI commands do not appear on the scripting box on the Record New 
Script dialog box. To run the script later, you need to save the VOIs.   

If you need to create a VOI to perform an action, save the VOI by 
selecting VOI > Save VOI. The program saves the VOI to the Scripts 
Home directory under the name AreaN.voi where N is a number that is 
assigned sequentially. The name of the first VOI that you save is 
Area1.voi; the second is Area2.voi; and so on. Make sure you type the 
.voi extension to the file.

If you want to specify a different name for the VOI, select VOI > Save 
VOI as. The Save VOI as dialog box opens. Type a name for the VOI in 
File name, and click Save. The program saves the file under the name 
you specified.

4 Close the images.

5 Select File > Save in the Record New Script dialog box when you are 
finished creating the script. The Save dialog box opens.

6 Type a name for the script in File name.

Tip: The file name extension for script files is .sct. Make sure that you type the 
extension at the end of the file name.

7 Click Save. The program saves the script in the scripts home directory.

8 Click File > Exit to close the Record New Script dialog box. The dialog 
box closes. You should now be able to select the script in Current Script.
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To stop recording scripts during creation

If you are interrupted or need to take a break while you are recording a 

script, the Pause button, , allows you to stop recording the script. 
When you click Pause, the following message appears at the top of the 
Record New Script dialog box: “The script is now paused. Press Resume to 
resume recording.” Notice that the Pause button changed to Resume, 

. When you can return to recording the script, click Resume.

Running scripts
Depending on your preference, you can run an active script that you just 
created from the scripting toolbar in the MIPAV window. You can also run 
scripts on multiple images from the File menu in group mode.

An Example:
Recording a Script in Group Mode

In this example, the user wanted to open three images, run the gradient 
magnitude algorithm on them, add margins on each image, and then close 
the images.   
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To run scripts from the scripting toolbar (active 
mode)

1 Select a script from Current Script in the scripting toolbar.

Note: Current Script lists all of the scripts in the scripts home directory 
alphabetically.

2 Click , the Run the selected script icon, on the scripting toolbar in 
the MIPAV window.

MIPAV automatically performs all of the actions in the script on the 
images indicated in the script.

To run scripts from the File menu (group mode)

1 Select File > Scripts > Run Script in the MIPAV window.

The Run Script on Multiple Images dialog box (Figure 276) opens.

2 Click Load Scripts. The Open dialog box appears showing all of the 
scripts in the scripts home directory.

3 Select a script.

4 Click Open.

5 Type, as an option, the prefix that should appear in front of the file 
name.
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6 Type, as an option, the suffix that should appear at the end of every file 
name.

7 Click Next. The Run Script on Multiple Images dialog box that allows 
you to select images and VOIs appears.

8 Click Add under Images to add the images that you want to run the 
script on. The Open dialog box appears.

Load script Allows you to select the 
script that you want to 
run from the scripts 
home directory. When 
you select this button, 
the Open dialog box 
appears.

Add prefix 
to saved 
image file 
name

Specifies an   
alphanumeric prefix 
that you want to apply 
to the images produced 
by the script. 

Add suffix 
to saved 
image file 
name

Specifies an   
alphanumeric suffix 
that you want to apply 
to the images produced 
by the script.

Cancel Disregards any changes that you made in the dialog box and closes this dialog box.

Back Returns to the previous dialog box without running the script. 

Next Proceeds to the next step in running the script.

Finish Begins running the script.

Figure 276.  Run Script on Multiple Images dialog box
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9 Select one or more images, and click Open. The selected images appear 
in the Images box.

10 Select Add under VOIs to add one or more VOIs. The Open dialog box 
appears.

11 Select one or more VOIs, and click Open. The selected VOIs appear in 
the VOIs box.

12 Click Finish.

MIPAV automatically performs all of the actions in the script on the 
images indicated in the script.

Images Lists the images that 
appear in the script.

Add Allows you to add one or 
more images on which to 
run the script.

Remove Allows you to remove one 
or more images from 
those on which you plan to 
run the script.

VOIs Lists any saved VOIs that 
are necessary when you 
run the script.

Add Allows you to add one or 
more VOIs that the script 
needs to run correctly.

Remove Allows you to remove one or more VOIs from use with the script.

Cancel Disregards any changes that you made in the dialog box and closes this dialog box.

Back Returns to the previous dialog box without running the script. 

Next Proceeds to the next step in running the script.

Finish Begins running the script.

Figure 277.  Run Script on Multiple Images dialog box (image and VOI selection)
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Editing and deleting scripts
Editing scripts is very easy. You can either edit the script while you are 
creating it, or you can edit a previously saved script. MIPAV saves the script 
in text format so that any text editor, such as Microsoft WordPad or 
NotePad, can modify the file.

To edit scripts during creation

Suppose you make an error while you are recording a script, or perhaps you 
change your mind about performing a specific action. It’s more practical to 
correct the problem right away.

To correct errors or make changes to scripts, simply click , the 
Enable Edit button, in the Record New Script dialog box (Figure 278). Two 
things occur: (1) the list box in the dialog box turns from gray to white to 
indicate that you can now type, copy, or paste information into it and delete 

information from it and (2) the Enable Edit button changes to , 
the Disable Edit button. If the box contains actions that you want to erase, 
select the actions and delete them. If you want to add new actions, you can 
either type them into the box directly, or you can record them after you 
finish editing the script.
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When you are finished changing the script, click Disable Edit. The list box 
turns gray and the Disable Edit button becomes the Enable Edit button. 

To edit previously created scripts 

1 Click , the Start Recording Script icon, on the scripting toolbar. The 
icon turns red, and the Record New Script dialog box opens.

2 Select File > Open. The Open dialog box (Figure 279) appears.

3 Select the script that you want to edit. The script appears in the Record 
New Script dialog box.

4 Click Enable Edit. The actions box turns from gray to white.

5 Select any of the actions and copy, rearrange or delete actions from the 
box or you can type new actions directly into the box.

6 Click Disable Edit when you are satisfied with the script. The actions box 
returns to gray.

7 Click File > Save if you are satisfied with the script. The Save dialog box 
opens.

Figure 278.  Record New Script dialog box (A) before and (B) after 
clicking Enable Edit
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8 Type the name of the script in the File Name box.

9 Click Save. MIPAV saves the script under the name you specified.

To delete scripts

If you decide at some point that you want to delete a script, go to Windows 
Explorer and navigate to the scripts home directory.

1 Right-click Start on the Windows desktop.

2 Select Explore. The Windows explorer window opens.

3 Navigate to the scripts home directory.

4 Select the script or scripts that you want to delete.

5 Right click.

6 Click Delete. Windows deletes the scripts you selected and places them 
in the Recycle Bin where they stay until you empty the bin. 

Figure 279.  Open dialog box showing scripts in the scripts 
home directory
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Combining scripts and other programs

To increase productivity and efficiency, you can integrate MIPAV functions 
into your normal workflow by calling the scripts you’ve created. A simple 
example is creating a DOS batch file that opens and runs MIPAV scripts.

Using the mipav command
To call scripts from other programs, you use the mipav command in the 
Command Prompt dialog box. The correct syntax of this command follows.

Syntax of the mipav command

mipav [-hH] [-iI] imageFileName [-sS] ScriptFileName [-vV] voiFileName [-hideHide]

Parameters Purpose

[-h][-H] Displays help for the mipav command in a Command Prompt window

[-hide][-HIDE] Hides application frame

[-i][-I] Image file name

[-s][-S] Script file name

[-x][-X] XML script file name

[-v][-V] VOI file name

Examples

> mipav

> mipav imageFileName

> mipav -i imageFileName -s scriptFileName -hide

> mipav -s scriptFileName -i imageFileName1-v voiName1 -v voiName2 -i 
imageFileName2 -v voiName3
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To display help for using the mipav command 

1 Navigate to the mipav directory on your computer.

2 Select Start > All Programs > Accessories > Command Prompt. The 
Command Prompt dialog box opens.

3 Type mipav -H (refer to Figure 280).

4 Press Enter. The Command Line Help dialog box (Figure 281) opens.

Figure 280.  Command Prompt dialog box showing command to open Command Line Help dialog 
box

Figure 281.  Command Line Help dialog box, which shows the syntax of the mipav command as 
well as examples
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To open a DICOM image dataset 

Suppose you want to open a single DICOM image from a collection of 
experiments made in 2004 named exp2004. You would type the following 
command in the Command Prompt dialog box in Microsoft Windows XP:

To open VOIs into that image

You can open VOIs as well as the image from the command line. In 
Windows XP, it would be the following:
 

In a UNIX BASH shell, this command looks like: 

To open multiple images using compound commands

Suppose you know that there were multiple DICOM datasets in exp2004. 
To open every DICOM image on the Windows computer, you would type:

In this case, you must know something of the file structure of that dataset—
you assumed that all image datasets had only one image ending in 01. 
However, the disadvantages of this format is the possibility of not opening 
all of the images at the same time.

A similar loop to open image sets on a UNIX BASH command line looks 
like: 

There are three significant differences between the BASH command and the 
Windows command (beside from how a directory is specified): 

C:\ mipav -i i:\images\DICOM\exp2004\I04301.dcm

C> mipav -i i:\images\DICOM\exp2004\I04301.dcm -v i:\VOIs\exp2004\levelset1.xml

$ mipav -i ~/images/DICOM/exp2004/I043401.dcm -v ~/VOIs/exp2004/levelset1.xml

C> for %f in (i:\images\DICOM\exp2004\*01.dcm) do mipav -i %f

$ for FI in `ls ~/images/DICOM/exp200?/*01.dcm`; do ./mipav -i $FI &; done
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• The use of the ls command when listing the directory—The 
reason you must list the ls is due to the way a for loop works in BASH. 
The for requires a command and uses that command's return value as 
the boolean test to continue repeating the interior list of commands. By 
contrast, the Windows command shell expects a list of files. So long as 
the file listing has more results to list, BASH continues to repeat the 
mipav command.

• The use of a wildcard when listing the directory—BASH allows 
the directory list to use wildcard characters in more than one location, 
which permits searching for the images in any seven-character 
directory beginning with exp200 as well as all files ending in 01.dcm. 
This means that MIPAV starts with images from the exp2004 
directory, as well as exp2003 or should it exist, exp200M, since the ?   
matches any character, not just a number. This is an example of a 
feature of the shell being used to expand the results. Windows 
command shell does not support this feature.

• Sending the mipav command to operate in the background—
BASH is a shell that allows job control. Using this feature allows you to 
start MIPAV and continue it asynchronously, permitting BASH to 
retain control. BASH can then continue processing the loop and 
starting MIPAV with the next matching file. Each MIPAV runs 
concurrently and allows you to manipulate each image with MIPAV at 
will. Although this allows you to see the images at the same time, the 
disadvantage is that the various windows begin to clutter the screen 
causing operator confusion. 

When there is more than one MIPAV application window running, it’s 
possible to close the wrong image by closing the wrong MIPAV application. 
In addition, operations that can occur between windows when running a 
single MIPAV may not be transferable between images being run by 
separate MIPAV windows. 

While starting more than one MIPAV to display a set of images may be fine 
in limited applications, it causes needless overhead within in the operating 
system wasting system resources. 

Using Shell scripting to lessen typing
Using shell scripts to reduce the amount of repetitive work is a common 
reason for writing a script. When best used, several small scripts that work 
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in concert can reduce the amount of typing required and the amount of time 
needed and can automate tasks. 

The following example uses a Windows command shell to illustrate how you 
can shorten the number of keystrokes required. In this case, you would 
write a batch file to load a levelset VOI into an image. 

More efficient and more useful, starting MIPAV with multiple images is 
easily done in a simple script. Here is how it is done in BASH: 

Although this script doesn’t include the line ./mipav $MIPARGS with a “&” 
to run MIPAV in the background, it could have. This would have the effect 
of exiting the script with MIPAV in the background; as it is, the script does 
not exit—and return control to you at the command line—until MIPAV 
exits.   

@echo off
rem -- %1 is the full path to the image file, though not 
rem -- the file itself; we assume there to be a *01.dcm
rem -- file to exist in this directory.

rem -- VOI is assumed to be in the same directory with name 
rem -- levelset1.xml

./mipav -i %1\*01.dcm -v %1\levelset1.xml

#! /bin/bash
# argument 1 is the file (with wild-cards) we want to open
# arg 1 must be escaped (with quotes) to allow the shell to send 
# the wildcards unmolested to the script. Otherwise, the shell 
# will try to expand the shorthand. This has a different effect.

LISTING=`ls $1`  # Generate the file listing
MIPARGS=
  # For each file in the listing, prepend it with '-i' and 
  # the filename, then follow it with all the previous 
  # files.
for FS in $LISTING;
  do
 MIPARGS=" -i $FS $MIPARGS";
done

  # start MIPAV:
./mipav $MIPARGS 
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11 Developing Plug-in Programs
[This chapter currently being revised and updated.]
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APPENDIX
 A

<A+> DICOM Conformance Statement
The purpose of this conformance statement is to facilitate communications 
and interoperations with the National Institutes of Health (NIH) Medical 
Image Processing, Analysis, and Visualization program (MIPAV).

This introduction describes the MIPAV application and briefly summarizes 
the Digital Imaging and Communications in Medicine (DICOM) standard 
services employed by MIPAV.

MIPAV

MIPAV is an n-dimensional, general purpose image-processing program 
designed to assist the NIH research and clinical communities in extracting 
quantitative information from various medical imaging modalities to better 
understand, diagnose, monitor, and treat medical disorders.

MIPAV, which is written in Java, takes advantage of the programming 
language's intrinsic object-oriented capabilities to improve code reuse, 
functionality, and portability. MIPAV is available on any Java-capable 
operating system, such as Windows, Macintosh, Irix, and Solaris.

Although this is a general purpose image-processing platform, 
Dr. McAuliffe presently uses this platform to develop specific and unique 
image processing techniques to meet the requirements of his collaborators.
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MIPAV DICOM communications interface

The MIPAV DICOM communications interface automates the process of 
querying and retrieving DICOM standard formatted files. The transfer of 
images can be clumsy and time consuming when studies are manually 
transferred to removable media or even to File Transfer Protocol (FTP) 
access, which does not ensure file format compatibility. MIPAV allows you 
to  transfer DICOM standard formatted images over the network using the 
DICOM communications protocol that runs over the Transmission Control 
Protocol/Internet Protocol (TCP/IP) stack.

The MIPAVapplication starts a DICOM image receiver that runs in the 
background and listens on a given port for incoming DICOM-store requests.  
When a store request is received by the DICOM receiver, the DICOM-
formatted images are saved to the local system disk in the user-designated 
images directory. Once stored, you can use MIPAV to access, visualize, and 
analyze images.

MIPAV can also send selected images that are on the local disk to a remote 
destination by implementing the composite storage (C-STORE) service 
class as a service class user (SCU).

Finally, and most important, MIPAV has a query and retrieve capability that 
allows you to query a remote DICOM query server for patient, study, series, 
and image information. You can select from the responses to the query the 
set of images to be retrieved (moved) to the local disk for visualization and 
analysis.

Implementation model

This section describes the application entities (AEs) in the MIPAV DICOM 
communications interface and how they relate to both local and remote 
real-world activities.  The implementation model consists of an application 
data flow diagram and functional definitions of all DICOM processes 
handled by the MIPAV AE.

The MIPAV DICOM receiver conforms to the DICOM standard as a service 
class provider (SCP) of most C-STORE service object pair (SOP) classes.  
The MIPAV query/retrieve process conforms to the DICOM standard as a 
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SCU for DICOM C-FIND and C-MOVE services.  In addition, the MIPAV  
DICOM sender conforms to the DICOM standard as a SCU for most DICOM 
C-STORE SOP classes.

Application data flow diagram
Figure 282 shows the relationship between the MIPAV AE and its DICOM  
processes and the remote AE and its DICOM processes.  The remote AE 
could be any DICOM-compliant system that acts as a query/retrieve server 
and a DICOM image file receiver and sender, such as a DICOM image 
archive.

Figure 282.  MIPAV dataflow diagram
MIPAV User’s Guide, Volume 1, Basics 417

9/20/04 



M   I   P   A   V
M e d i c a l   I m a g e   P r o c e s s i n g, A n a l y s i s,   &   V i s u a l i z a t i o n

Appendix A,  DICOM Conformance Statement
Functional definitions of AEs 

This section describes the image verification, query, and transfer functions 
to be performed by the MIPAV AE and the DICOM services used to 
accomplish these functions.

Verification
The MIPAV DICOM communications interface verifies application-level 
communication with a remote DICOM AE with the C-ECHO (Verification) 
SOP class in the SCP role.  A remote DICOM AE supporting the Verification 
SOP class SCU role shall send a C-ECHO request to the MIPAV application.  
The MIPAV AE then sends a response of SUCCESS to confirm DICOM 
communications between the two AEs.

DICOM RECEIVER (C-STORE SCP)

The DICOM image receiver is initialized as a standalone resident program 
when the MIPAV application is started.  The DICOM receiver waits for a 
remote AE to request a connection at the presentation address configured 
for its AE Title.  The presentation address of the DICOM receiver consists of 
the system IP address, AE Title, and communications port.  The AE Title 
and communications port for the DICOM receiver are user configurable in 
the preferences file mipav.preferences.

The DICOM receiver accepts associations with Presentation Contexts for 
the SOP Classes of the Storage Service Class.  Thus, the DICOM receiver 
accepts storage requests for Computed Tomography (CT), Magnetic 
Resonance (MR), Ultrasound (US), Nuclear Medicine (NM), Computed 
Radiography (CR), and most other modalities.  It receives the images and 
writes them to files in the format specified in Digital Imaging and 
Communications In Medicine (DICOM) Part 10: Media Storage and File 
Format for Media Interchange (see Appendix E for a full citation.)
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DICOM QUERY (C-FIND SCU)

The MIPAV application supports the DICOM C-FIND query class as a SCU 
by allowing you to query a remote DICOM query server (C-FIND SCP) for 
patient, study, series, and image information.  MIPAV employs the Study 
Root Query/Retrieve Information Model based on the three-level hierarchy: 

• Study—Study is the top level. It contains attributes associated with the  
study and patient information entity’s (IE).   

• Series—The series level, which is below the study level, contains  
attributes associated with the series, frame of reference, and 
equipment IEs.

• Image—Image is the lowest level.  It contains attributes associated 
with the Image IE.

You can use a Study Root Study Level C-FIND request message, with search 
key attributes of patient name or patient ID and study date range, to query 
the SCP for a patient list or for demographic information about a given 
patient.  A Study Root Study Level query, with a known search key attribute 
of patient ID, can be sent to the Query SCP for the study list corresponding 
to the given patient ID.  Once the desired study is queried, then MIPAV can 
send a Study Root Series Level query with the known Unique Key Attributes 
of Patient ID and Study Instance UID to the query server for the list of series 
corresponding to the given study.  Finally, once the desired series is located, 
you can query at the Study Root Image Level with known Key Attributes of 
Patient ID, Study Instance UID, and Series Instance UID to get the list of 
images corresponding to the selected series.

The MIPAV query routine interprets all PENDING status responses from 
the C-FIND SCP as matches to the key attributes in the query request.  A 
status equal to SUCCESS, FAILED or REFUSED conveys the end of query 
request.

To cancel the C-FIND service, the MIPAV AE issues a C-FIND-CANCEL 
request at any time during the processing of the C-FIND query.  The MIPAV 
query routine that issued the C-FIND request recognizes a status of 
CANCELED to indicate that the C-FIND-CANCEL was successful.  
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DICOM RETRIEVE (C-MOVE SCU)

MIPAV supports the DICOM C-MOVE SOP class as a SCU.  You can request 
the transfer of images from a remote AE to the local system or to a desired 
remote destination with a DICOM C-MOVE service request.  The 
destination for the move, whether it is the local disk or a remote system, 
may be configured and selected from a host table from within the MIPAV 
DICOM Communication Panel window.  The Move Destination is specified 
by the parameters of AE Title, IP Address, and Communications Port 
number in the Hosts table.  To review or modify the configuration of the 
Hosts table, the user selects the Hosts tab from the DICOM Communication 
Panel window.

The DICOM C-MOVE class employs, like the DICOM Query, the Study Root 
Query/Retrieve Information Model based on the three-level hierarchy: 

• Study—A C-MOVE request at the study level transfers all images 
related to a study to the designated move destination. 

• Series—A C-MOVE request at the series level transfers all images 
related to a series.

• Image—A C-MOVE request at the image level transfers all selected 
individual images.

The MIPAV retrieve routine supplies unique key values to identify an entity 
at the level of retrieval to the C-MOVE SCP.  The SCP executes C-STORE 
suboperations for the corresponding storage SOP instances identified by the 
unique key values in the C-MOVE request.  The MIPAV retrieve routine 
interprets all PENDING status responses from the C-MOVE SCP as matches 
to the key attributes in the retrieve request.  A status equal to SUCCESS, 
FAILED, or REFUSED conveys the end of the retrieve request.  

The MIPAV AE may cancel the C-MOVE service request by issuing a C-
MOVE-CANCEL request at any time during the processing of the C-MOVE 
request.  The MIPAV retrieve routine that issued the C-MOVE request 
recognizes a status of CANCELED to indicate that the C-MOVE-CANCEL 
was successful.  
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DICOM SENDER (C-STORE SCU)

MIPAV provides the DICOM C-STORE SOP class as a SCU.  

To access the DICOM send option

1 Select File > DICOM Database Access in the MIPAV window. The 
DICOM Communication Panel window opens.

2 Select Send to view the Send page.

3 Select a patient, study, series, or image to send to a designated 
destination.  The store destination is specified by the parameters of AE 
Title, IP Address, and Communications Port number in the hosts table.  

To review or modify the configuration of the hosts 
table

1 Select Hosts in the DICOM Communication Panel window. The Hosts 
page opens.

2 Select the desired image data and the storage destination. 

3 Click OK. The MIPAV sender routine establishes an association with the 
selected destination and transfers the image data.

SEQUENCING OF REAL-WORLD ACTIVITIES

Not applicable.

AE specifications
This section provides detailed specifications of the MIPAV DICOM 
communications interface.  It lists the SOP classes supported and outlines 
the policies with which MIPAV initiates or accepts associations.  A 
description of proposed (for association initiation) and acceptable (for 
association acceptance) Presentation contexts is also provided.

Note that a Presentation Context consists of an Abstract Syntax and a list of 
acceptable Transfer Syntaxes.  The Abstract Syntax identifies one SOP Class 
or Meta SOP Class.  By listing the AEs with their proposed and accepted 
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Presentation Contexts, this Conformance Statement identifies the set of 
Information Objects and Service classes recognized by MIPAV.

For each SOP Class related to an Abstract Syntax, a list is given of any 
supported SOP options. 

MIPAV AE SPECIFICATION

This section summarizes the SOP classes that are supported by the MIPAV 
DICOM Communications interface. The supported SOP classes are listed in 
two categories:  

• SOP classes supported by MIPAV as a SCU

• SOP classes supported by MIPAV as a SCP

MIPAV provides Standard Conformance to the DICOM V3.0 SOP Classes 
shown in Table 6 as a SCU.

Table 6. DICOM query, retrieve, and sender classes supported by MIPAV

SOP class name SOP class UID

DICOM query

Study Root Query/Retrieve 
Information Model, C-FIND

1.2.840.10008.5.1.4.1.2.2.1

DICOM retrieve

Study Root Query/Retrieve 
Information Model, C-MOVE

1.2.840.10008.5.1.4.1.2.2.2

DICOM sender

CR Image Storage 1.2.840.10008.5.1.4.1.1.1

CR Image Storage 1.2.840.10008.5.1.4.1.1.2

MR Image Storage 1.2.840.10008.5.1.4.1.1.4

NM Image Storage 1.2.840.10008.5.1.4.1.1.20

US Image Storage 1.2.840.10008.5.1.4.1.1.6

Secondary Capture Image Storage 1.2.840.10008.5.1.4.1.1.7
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MIPAV provides Standard Conformance to the DICOM version 3.0 SOP 
Classes shown in Table 7 as a SCP.

DICOM QUERY (C-FIND SCU) AE 
SPECIFICATION

MIPAV provides standard conformance to the DICOM 3.0 Query/Retrieve 
SOP class listed in Table 8.

Association establishment policies

General
The MIPAV query routine initiates an association with a remote DICOM 
query server. Extended negotiation is not provided.

The maximum Protocol Data Unit (PDU) size in an association request 
defaults to 16 kilobytes.

Table 7. Verification and DICOM receiver classes supported by MIPAV

SOP class name SOP class UID

Verification

Verification SOP Class 1.2.840.10008.1.1

DICOM receiver

CR Image Storage 1.2.840.10008.5.1.4.1.1.1

CT Image Storage 1.2.840.10008.5.1.4.1.1.2

MR Image Storage 1.2.840.10008.5.1.4.1.1.4

NM Image Storage 1.2.840.10008.5.1.4.1.1.20

US Image Storage 1.2.840.10008.5.1.4.1.1.6

Table 8. Supported C-FIND SOP class

SOP class name SOP class UID

Study Root Query/Retrieve 
Information Model

C-FIND

1.2.840.10008.5.1.4.1.2.2.1
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Number of associations
Each query request within MIPAV initiates an association with a remote 
DICOM query server. Thus, multiple associations can be opened and 
processed by MIPAV in one working session.

Asynchronous nature
The DICOM Query routine only allows a single outstanding operation on an 
Association. Thus, there is no asynchronous activity in this implementation.

Implementation identifying information
(TBD.  Need information on the Implementation Class Unique Identifier 
(UID) for the MIPAV query routine. Note that this may be the same for all 
applications, one implementation UID for a DICOM application. For 
information, contact Richard Eaton at NEMA at 703/841-3248 or e-mail at  
ric_eaton@nema.org).

Association initiation by real-world activity

To initiate an association from MIPAV to a remote query server (C-FIND 
SCU), select the Send Query button in the DICOM Communication Panel 
window.

Query request
After you insert the search keys and set the study date range in the DICOM 
Communication Panel window, you can then select the Send Query button 
to transfer the C-FIND request to the remote DICOM query server. Each 
query opens an association with the query server. Select Cancel at the 
bottom of the DICOM Communication Panel window to cancel the C-FIND 
request. The C-FIND-CANCEL request is sent over the same association as 
the originating C-FIND request.

Associated real-world activity. The initiation of a C-FIND request is the 
associated real-world activity.

Proposed Presentation Contexts. When MIPAV initiates a C-FIND request, a 
presentation context is proposed for the Study Root Query/Retrieve C-
FIND supported SOP Class. No extended negotiation is supported.
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SOP specific conformance statement for SOP class 
study root query/retrieve information model C-FIND

The attributes listed in Table 10 comprise the Study Root Query/Retrieve C-
FIND identifier that is sent in the DICOM query message. The level column 
indicates the query level at which the attributes can be included.

Table 9. Presentation context proposed by MIPAV as a result of real-world 
activity query request to an external query server

Presentation context table

Abstract syntax Transfer syntax

Role
Extended 
negotiationName UID Name list UID list

Study Root 
Q/R C-FIND

1.2.840.10008.5.1.4.1.
2.2.1

Implicit VR 
Little Endian

1.2.840.10008.1.2 SCU None

Table 10. DICOM data elements supported for SOP 
class study root query/retrieve information model C-FIND SCU”

Level Description Tag Type

Study
Study Study Date (0008,0020) R

Study Study Time (0008,0030) R

Study Study ID (0020,0010) R

Study Patient's Name (0010,0010) R

Study Patient ID (0010,0020) R

Study Study Instance UID (0020,000D) U

Study Referring Physician's Name (0008,0090) O

Series
Series Modality (0008,0060) R

Series Series Number (0020,0011) R

Series Series Instance UID (0020,000E) U

Series Series Date (0008,0021) O

Series Series Description (0008,103E) O

Series Body Part Examined (0018,0015) O

Image
Image Image Number (0020,0013) R

Image SOP Instance UID (0008,0018) U

Image Image Date (0008,0023) O

Image Image Time (0008,0033) O
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Association acceptance policy

Not applicable.

DICOM RETRIEVE (C-MOVE SCU) AE 
SPECIFICATION

MIPAV provides standard conformance to the DICOM 3.0 Query/Retrieve 
SOP class.

Association establishment policies

General

The MIPAV retrieve routine initiates an association with a remote DICOM 
query/retrieve server.  Extended negotiation is not provided.

The maximum PDU size in an association request defaults to 16 kilobytes.

Number of associations

Each retrieve (C-MOVE) request within the MIPAV application initiates an 
association with a remote DICOM query/retrieve server.  Thus, multiple 
associations for the C-MOVE SOP class can be opened and processed by 
MIPAV in one working session.

Asynchronous nature. The DICOM Receiver only allows a single outstanding 
operation on an association. Thus, there is no asynchronous activity in this 
implementation.

Implementation identifying information. (TBD.  Need the Implementation 
Class Unique Identifier (UID) for the MIPAV move request routine. Note 
that this may be the same for all applications—one implementation UID for 
a DICOM application. For information, contact Richard Eaton at NEMA at  
703/841-3248 or e-mail at ric_eaton@nema.org.

Table 11. Supported image storage service

SOP class name SOP class UID
Study Root Query/Retrieve 
Information Model

C-MOVE

1.2.840.10008.5.1.4.1.2.2.2
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Association initiation by real-world activity

To initiate an association from MIPAV to a remote query/retrieve server (C-
MOVE SCP), select Q/R Client in the DICOM Communication Panel 
window.  Then complete the appropriate parameters in the Q/R Client page.    
Initially run a query from the Q/R Client page. You can then select an entry 
from the query responses that indicates the desired patient, study, series, or 
image to be moved to the set destination. The destination to be moved to 
with the C-MOVE request is user configurable in the Hosts page, which is in 
the DICOM Query Panel window.

Retrieve request

After you successfully query the remote query/retrieve server and locate  
the set of images to move to the local system, you can then send a C-MOVE 
request to move the desired images to the local system. To initiate the C-
MOVE request, click Move Image in the DICOM Communication Panel 
window, which then opens an association to the remote query/retrieve 
server.  The remote server then responds to the C-MOVE request by 
initiating a C-STORE request on a new association to the C-STORE SCU 
process in the MIPAV application.

Associated real-world activity. The initiation of a C-MOVE request is the 
associated real-world activity.

Proposed presentation contexts. When MIPAV initiates a C-MOVE request, a 
presentation context is proposed for the Study Root Query/Retrieve C-
MOVE supported SOP Class. No extended negotiation is supported.

SOP specific conformance statement for SOP Class Study Root Query/Retrieve 
Information Model C-MOVE.  The attributes listed in Table 13 comprise the 
Study Root Query/Retrieve C-MOVE identifier that is sent in the DICOM 
retrieve message. The level column indicates the query level at which the 

Table 12. Presentation context proposed by MIPAV as a result of 
real-world activity “MOVE Request to an External Query Server”

Presentation context table

Abstract syntax Transfer syntax

Role
Extended 
negotiationName UID Name list UID list

Study Root 
Q/R C-MOVE

1.2.840.10008.5.1.4.1.
2.2.2

Implicit VR 
Little Endian

1.2.840.10008.1.2 SCU 1.2.840.1
0008.1.2
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attributes can be included.  Note that the table of attributes below is 
identical to those for the Study Root Query/Retrieve C-FIND identifier in 
Table 13

Association acceptance policy

Not applicable.

DICOM SENDER (STORAGE SCU) AE 
SPECIFICATION

MIPAV provides standard conformance to the DICOM 3.0 Storage SOP 
classes listed in Table 14

Table 13. DICOM data elements supported for SOP Class 
Study Root Query/Retrieve Information Model C-MOVE SCU

Level Description Tag Type

Study
Study Study Date (0008,0020) R

Study Study Time (0008,0030) R

Study Study ID (0020,0010) R

Study Patient's Name (0010,0010) R

Study Patient ID (0010,0020) R

Study Study Instance UID (0020,000D) U

Study Referring Physician's Name (0008,0090) O

Series
Series Modality (0008,0060) R

Series Series Number (0020,0011) R

Series Series Instance UID (0020,000E) U

Series Series Date (0008,0021) O

Series Series Description (0008,103E) O

Series Body Part Examined (0018,0015) O

Image
Image Image Number (0020,0013) R

Image SOP Instance UID (0008,0018) U

Image Image Date (0008,0023) O

Image Image Time (0008,0033) O
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Association establishment policies

General
The MIPAV DICOM image sender initiates an association with a remote 
DICOM image receiver.  Extended negotiation is not supported.

The maximum PDU size in an association request defaults to 16 kilobytes.

Number of associations
Each send (C-STORE) request within the MIPAV application initiates an 
association with a remote DICOM image receiver.  Thus, multiple 
associations for the C-STORE SOP class can be opened and processed by 
MIPAV in one working session.

Asynchronous nature. The DICOM Sender only allows a single outstanding 
operation on an Association.  Thus, there is no asynchronous activity in this 
implementation.

Implementation identifying information
(TBD.  Need the Implementation Class Unique Identifier (UID) for the 
MIPAV DICOM Sender.  Note that this may be the same for all applications- 
one implementation UID for a DICOM application. For information, 
contact Richard Eaton at NEMA at 703/841-3248 or through e-mail at  
ric_eaton@nema.org.

Association initiation by real-world activity

To initiate an association from MIPAV to a remote image receiver (C-
STORE SCP), select Send in the DICOM Query Panel window. When you  
select File > DICOM Database Access in the MIPAV window, the DICOM 
Communication Panel window opens.

Table 14. Supported C-STORE SOP classes

SOP class name SOP class UID
Computed Radiography Image 
Storage

1.2.840.10008.5.1.4.1.1.1

CT Image Storage 1.2.840.10008.5.1.4.1.1.2

MR Image Storage 1.2.840.10008.5.1.4.1.1.4

Nuclear Medicine Image Storage 1.2.840.10008.5.1.4.1.1.20

Ultrasound Image Storage 1.2.840.10008.5.1.4.1.1.6

Secondary Capture Image Storage 1.2.840.10008.5.1.4.1.1.7
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DICOM send request

Associated real-world activity.  The initiation of a Send image request is the 
associated real-world activity.

Proposed presentation contexts. When MIPAV initiates a C-STORE request, a 
different presentation context is proposed for each of the different 
supported C-STORE SOP Classes. No extended negotiation is supported.

SOP specific conformance statement for supported storage SOP classes. The 
following overview summarizes the behavior of the MIPAV DICOM Sender 
routine depending on the responses to the C-STORE request:

• Successful C-STORE response: In the case of a response of 
SUCCESS for the C-STORE request, the MIPAV Send status panel in 
the Send page in the DICOM Communication Panel window displays a 
status of SUCCESS.  This indicates that the images were properly  
received by the image receiver (C-STORE SCU).

• Unsuccessful C-STORE response: In the case of a response of 
REFUSED, CANCEL, or FAILED, for the C-STORE request, the 
DICOM sender routine aborts the association. The MIPAV Send status 
panel in the Send page in the DICOM Communication Panel window  

Table 15. Presentation contexts proposed by MIPAV as a result of real-
world activity “store request to an external query server

Presentation context table

Abstract syntax Transfer syntax

Role
Extended 
negotiationName UID Name list UID list

CR Image 
Storage

1.2.840.10008.5.1.4.1.
1.1

Implicit VR 
Little Endian

1.2.840.10008.1.2 SCU None

CT Image 
Storage

1.2.840.10008.5.1.4.1.
1.2

Implicit VR 
Little Endian

1.2.840.10008.1.2 SCU None

MR Image 
Storage

1.2.840.10008.5.1.4.1.
1.4

Implicit VR 
Little Endian

1.2.840.10008.1.2 SCU None

US Image 
Storage

1.2.840.10008.5.1.4.1.
1.6

Implicit VR 
Little Endian

1.2.840.10008.1.2 SCU None

Secondary 
Capture 
Image 
Storage

1.2.840.10008.5.1.4.1.
1.7

Implicit VR 
Little Endian

1.2.840.10008.1.2 SCU None
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displays a status of FAILED.  The software makes no further attempts 
to retry the transfer of the aborted images.

• Warning status in C-STORE response: In the case of a response 
of Warning for the C-STORE request, the MIPAV DICOM sender 
routine behaves the same as if a response of SUCCESS was received.

The DICOM Sender does not attempt any extended negotiation.

The DICOM Sender supports all type 1, type 2, and type 3 attributes defined 
in the Information Object Definition (IOD) associated with the SOP class. No 
attributes are discarded or coerced by the DICOM Sender. The originally 
saved DICOM file is read from disk and forwarded to the desired remote 
system. Note that the DICOM Sender does not validate that the attributes of 
the SOP instance for the outgoing C-STORE message request meet the 
requirements of the IOD. It is assumed that the saved DICOM image file is 
stored in a valid DICOM file format.

The SOP Instance UID (group 0x0008, element 0x0018), Study Instance UID 
(group 0x0020, element 0x000D), and Series Instance UID (group 0x0020, 
element 0x000E) consist of a root and suffix.  The root consists of the date 
and time of transaction.  The suffix is conforms to the DICOM standard.

Association acceptance policy

Not applicable.

VERIFICATION (C-ECHO SCP) AE 
SPECIFICATION

MIPAV provides standard conformance to the DICOM 3.0 Verification SOP 
class listed in Table 16.

Table 16. Supported verification SOP class

SOP class name SOP class UID
Verification SOP Class 1.2.840.10008.1.1
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Association establishment policies

General
The MIPAV DICOM Verification routine responds to a verification of 
communication request from a remote DICOM AE by sending a C-Echo 
response of a status of SUCCESS.

The maximum PDU size in an association request defaults to 16 kilobytes.

Number of associations
Each verification (C-Echo) request sent to the MIPAV application is 
responded to on an association opened by the remote AE.  Multiple 
associations for the C-ECHO SOP class can be accepted and processed by 
MIPAV in one working session.

Asynchronous nature
The DICOM verification routine only allows a single outstanding operation 
on an Association.  Thus, there is no asynchronous activity in this 
implementation.

Implementation Identifying Information
(TBD.  Need the Implementation Class Unique Identifier (UID) for the 
MIPAV DICOM verification routine.  Note that this may be the same for all 
applications- one implementation UID for a DICOM application.  For 
information contact Richard Eaton at NEMA- (703) 841-3248, email- 
ric_eaton@nema.org)

Association initiation by real-world activity

Not applicable.

Association Acceptance Policy

MIPAV accepts all associations for C-ECHO requests initiated by remote 
systems.

DICOM Verification Request

Associated Real-World Activity. The arrival of a verification, or C-Echo, 
request is the associated real-world activity.

Proposed Presentation Contexts. When the MIPAV Message Receiver gets a 
verification request, the presentation context accepted for the C-ECHO SOP 
class is listed in Table 17. No extended negotiation is supported.
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SOP Specific Conformance Statement for Verification SOP Class. The 
Verification AE follows the DICOM 3.0 standard for handling of C-ECHO 
requests.  A status of SUCCESS is returned to a valid C-ECHO verification 
request.

DICOM IMAGE RECEIVER (STORAGE SCP) 
AE SPECIFICATION

MIPAV provides standard conformance to the DICOM 3.0 Storage SOP 
classes listed in Table 18

Association Establishment Policies

General
The MIPAV DICOM image receiver opens a node at the port specified in the 
mipav.preferences file and waits for an association from a DICOM 
application at the specified port.  MIPAV accepts an association from a 
remote DICOM image sender.  Extended negotiation is not supported.

The maximum PDU size in an association request defaults to 16 kilobytes.

Table 17. Presentation contexts accepted by MIPAV as a result of real-
world activity “verification” equest

Presentation context table

Abstract syntax Transfer syntax

Role
Extended 
negotiationName UID Name list UID list

Verification 1.2.840.10008.5.1.4.1.
1.1

Implicit VR 
Little Endian

1.2.840.10008.1.1 SCP None

Table 18. Supported C-STORE SOP classes

SOP class name SOP class UID
CR Image Storage 1.2.840.10008.5.1.4.1.1.1

CT Image Storage 1.2.840.10008.5.1.4.1.1.2

MR Image Storage 1.2.840.10008.5.1.4.1.1.4

NM Image Storage 1.2.840.10008.5.1.4.1.1.20

US Image Storage 1.2.840.10008.5.1.4.1.1.6

Secondary Capture Image Storage 1.2.840.10008.5.1.4.1.1.7
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Number of Associations
The DICOM Image Receiver initiates a new process for each connection 
request it receives.  Thus, the image receiver can have multiple 
simultaneous connections and there are no inherent limitations on the total 
number of simultaneous associations that the image receiver can maintain.

Asynchronous Nature
The DICOM Image Receiver only allows a single outstanding operation on 
an Association.  Thus, there is no asynchronous activity in this 
implementation.

Implementation Identifying Information
(TBD.  Need the Implementation Class Unique Identifier (UID) for the 
MIPAV DICOM Receiver.  Note that this may be the same for all 
applications- one implementation UID for a DICOM application.  For 
information contact Richard Eaton at NEMA- (703) 841-3248, email- 
ric_eaton@nema.org)

Association Initiation by Real-World Activity

Not applicable.  The DICOM Image Receiver never initiates an association.

Association Acceptance Policy

When the MIPAV Image Receiver accepts an association, it receives any 
images transferred on that association and stores the images on the local 
disk in the native machine file system, in the format specified in Digital 
Imaging and Communications In Medicine (DICOM) Part 10: Media 
Storage and File Format for Media Interchange (see Appendix E for a full 
citation.)  The Image Receiver places no limitation on who may connect to 
it, or the number of simultaneous connections it can support.

DICOM image receiver 

Associated real-world activity. The storage of an image on the disk of the local 
system is the associated real-world activity for the Image Receiver.

Proposed presentation contexts. The presentation contexts accepted by the 
MIPAV Image Receiver are listed in Table 19. No extended negotiation is 
supported.
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SOP Specific Conformance Statement for Supported Storage SOP Classes. The 
MIPAV Image Receiver conforms to the Storage SOP Classes as a SCP at 
Level 2 (Full). No elements are discarded or coerced by the MIPAV Image 
Receiver. In the event of a successful C-STORE operation, the DICOM  
image file is successfully written to the local disk with a standard path and 
file name format. The default path for the image data is /images. The 
default path can be customized in the mipav.preferences file.  The image 
receiver does not support any extended negotiation.

Communications profiles

OVERVIEW

This section lists all communication protocols supported by MIPAV.

Table 19. Presentation contexts proposed by MIPAV as a result of real-
world activity “receive and store images”

Presentation context table

Abstract syntax Transfer syntax

Role
Extended 
negotiationName UID Name list UID list

CR Image 
Storage

1.2.840.10008.5.1.4.1.1.1 Implicit VR Little Endian 1.2.840.1
0008.1.2

CT Image 
Storage

1.2.840.10008.5.1.4.1.1.2 Implicit VR Little Endian 1.2.840.1
0008.1.2

MR Image 
Storage

1.2.840.10008.5.1.4.1.1.4 Implicit VR Little Endian 1.2.840.1
0008.1.2

NM Image 
Storage

1.2.840.10008.5.1.4.1.1.20 Implicit VR Little Endian 1.2.840.1
0008.1.2

US Image 
Storage

1.2.840.10008.5.1.4.1.1.6 Implicit VR Little Endian 1.2.840.1
0008.1.2

Secondary 
Capture 
Image 
Storage

1.2.840.10008.5.1.4.1.1.7 Implicit VR Little Endian 1.2.840.1
0008.1.2
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SUPPORTED COMMUNICATIONS STACKS

TCP/IP

The MIPAV DICOM routines run over the TCP/IP stack.

Application Programmer’s Interface (API)
The MIPAV DICOM routines are implemented using the Berkeley Sockets 
interface to TCP/IP services.

Physical Media Supported

The MIPAV DICOM routines run on any physical media supported by the 
TCP/IP stack that is run on the host machine.

Extensions, Specializations, and Privatizations

OVERVIEW

This section lists all DICOM Standard extended, specialized, or private SOP 
Class implementations.

MIPAV AE DICOM SERVICES

No extended, specialized, or private SOPs are specified.

DICOM Configuration Details

OVERVIEW

This section addresses the method of setting configurable parameters for 
the DICOM routines.

For the MIPAV DICOM Receiver, the port number and AE Title are 
configurable in the mipav.preferences file.
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The MIPAV Query/Retrieve process also uses the AE Title, IP Address, and 
port number settings for the host machine and the remote query server. You 
can change the values for these settings on the Hosts page in the DICOM 
Communication Panel window. The settings can also be configured in the 
mipav.preferences file.

AE TITLE/PRESENTATION MAPPING

The MIPAV DICOM routines map the AE title to a presentation address (IP 
address and port number) by accessing information on the Hosts page in 
the DICOM Communication Panel window. This is then written and saved 
in the mipav.preferences file.

Support of Extended Character Sets

OVERVIEW

Any support for extended character sets, such as multibyte characters, are 
described in this section.

MIPAV ICOM AE

MIPAV does not support extended character sets.
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Table 20. DICOM tags

Field Description

Study Instance UID (0020,000D) Unique identifier for the study. Only numeric characters with 
optional periods are allowed.

Modality (0008,0060) Type of equipment that was used to acquire the data used to 
create the images in the dataset. Options are: Biomagnetic 
Imaging, Color Flow Doppler, Computed Tomography, Duplex 
Doppler, Computed Radiography, Diaphanography, Digital 
Radiography, Endoscopy, General Microscopy, Hard Copy, 
Intraoral Radiography, Laser Surface Scan, MR Angiography, 
Mammography, Magnetic Resonance, MR Spectroscopy, 
Nuclear Medicine, Other, PET, Panoramic XRay, Radio 
Fluoroscopy, Radiographic Imaging, Radiotherapy Dose, 
Radiotherapy Image, Radiotherapy Record, Radiotherapy 
Structure, Slide Microscopy, SPECT, Thermography, 
Ultrasound, XRay Angiography, and External Photography.

Series Instance UID (0020,000E) Unique identifier for the study. Only numeric characters (with 
optional periods) are allowed.

Patient

Patient's Name (0010,0010) Patient's full name.

Patient's Birth Date (0010,0030) Date of patient's birth.

Patient's Birth Time (0010,0032) Time of patient's birth.

Other Patient Names (0010,1001) Other names used to identify the patient.

Patient Comments (0010,4000) User-defined comments about the patient.

Patient ID (0010,0020) Primary hospital identification number or code used to identify 
the patient.

Patient's Sex (0010,0040) Gender of the patient. Options are: Unknown, Male, Female, 
and Other.

Other Patient IDs (0010,1000) Other IDs used to identify the patient.

Ethnic Group (0010,2160) Ethnic group or race of the patient.

Patient Orientation (0020,0020) Patient direction of the rows and columns of the image. 

Study

Study ID (0020,0010) User- or equipment-generated study identifier. 

Study Time (0008,0030) Time the study started.
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Study Description (0008,1030) Institute-generated description or classification of the study 
(component) performed.

Physician(s) of Record (0008,1048) Physician responsible for the overall patient care at the time of 
the study.

Admitting Diagnoses Description 
(0008,1080)

Description of the admitting diagnoses.

Patient's Size (0010,1020) Length or size of the patient in meters.

Occupation (0010,2180) Occupation of the patient.

Study Date (0008,0020) Date the study started.

Accession Number (0008,0050) An RIS-generated number which identifies the order for the 
study.

Referring Physician's Name 
(0008,0090)

Patient's referring physician.

Physician(s) Reading Study 
(0008,1060)

Physician(s) reading the study.

Patient's Age (0010,1010) Age of the patient.

Patient's Weight (0010,1030) Weight of the patient, in kilograms.

Additional Patient's History 
(0010,21B0)

Additional information about the patient's history.

Series

Series Number (0020,0011) A number that identifies this series.

Performing Physicians' Name 
(0008,1050)

Name(s) of the physician(s) administering the series.

Series Description (0008,103E) User-provided description for the series.

Body Part Examined (00018,0015) A text description of the body part that was examined. Options 
are: Unknown, Skull, CSpine, TSpine, LSpine, SSpine, Coccyx, 
Chest, Clavicle, Breast, Abdomen, Pelvis, Hip, Shoulder, Elbow, 
Knee, Ankle, Hand, Foot, Extremity, Head, Heart, Neck, Leg, 
Arm, and Jaw.

Smallest Pixel Value (0028,0108) Minimum value of all images in this series.

Procedure Step ID (0040,0253) Identification of that part of a procedures that was performed 
during this step.

Table 20. DICOM tags (continued)

Field Description
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Procedure Step Start Time 
(0040,0245)

Time when the procedure step started.

Laterality (0020,0080) Options are: Unknown, Left, and Right.

Series Time (0008,0031) Time series started.

Protocol Name (0018,1030) User-defined description of the conditions under which the 
series was performed.

Operator's Name (0008,1070) Name(s) of the technologist(s) supporting the series.

Patient Position (0018,5100) Patient position relative to the imaging-equipment space. 
Options are: Unknown, Head-First Prone, Head-First Supine, 
Feet First-Prone, Feet First-Supine, HF-Decubitus Right, HF-
Decubitus Left, FF-Decubitus Right, FF-Decubitus Left.

Largest Pixel Value (0028,0109) Maximum value of all images in this series.

Procedure Step Start Date 
(0040,0244)

Date when the procedure step started.

Procedure Step Description 
(0040,0254)

Institute-generated description or classification of the 
procedure step that was performed.

Table 20. DICOM tags (continued)

Field Description
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<A+> Technical Information
[This chapter currently being revised and updated.]
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Glossary
This glossary defines all acronyms and selected terms used in this guide. 

Numerics

2D. Two dimensional.

3D. Three dimensional.

4D. Four dimensional.

5D. Five dimensional.

A

ACR. American College of Radiology. The ACR, in conjunction with 
National Electrical Manufacturers Association, developed the Digital 
Image Communication in Medicine standard.

AE. Application entity.

Analyze. Unix-based medical-imaging display and analysis software 
developed by the Mayo Foundation. MIPAV allows researchers to 
process, analyze, and visualize Analyze-formatted image files on virtually 
any platform.
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API. Application program interface. Pieces of code that are used to 
perform common tasks, such as generate a standard window frame. 
Software developers often incorporate these pieces of code into their 
programs. An API is analogous to a package of form letters; APIs reduce 
programming time because common functions have already been written.

B

BMP. Extension for Windows Bitmap formatted files. BMP is the 
standard bitmap graphics file format that is used in the MS Windows 
environment.

boolean. This data type refers to data that represents symbolic 
relationships between entities, such as those implied by the logical 
operators AND, NOT, and OR. Examples of valid boolean values are 
TRUE and FALSE.

bytecode. Compiled format for Java code. Bytecode is analogous to 
object code. When the Java program is written and compiled, the 
compiled program is written in bytecode. When you execute the bytecode 
program, it is interpreted by the platform-specific Java Virtual Machine, 
which serves as an interface between your platform and the platform-
independent bytecode. Java bytecode can be ported to almost any 
platform and executed, provided the correct Java Virtual Machine has 
been installed.

C

CIT. Center for Information Technology. CIT provides, coordinates, and 
manages information technology so that computational science at the 
National Institutes of Health is advanced.

color 24. Color 24 is commonly referred to as 24-bit color images. Full 
RGB color requires that the intensities of three color components be 
specified for each and every pixel. It is common for each component 
intensity to be stored as an 8-bit integer, and so each pixel requires 24 
bits to completely and accurately specify its color. Image formats that 
store a full 24 bits to describe the color of each and every pixel are 
therefore known as 24-bit color images. 

CR. Computed radiography.
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C-STORE. Composite Storage. 

CT. Computed Tomography.

D

data type. A set of values from which a variable, constant, function, or 
expression may take its value. MIPAV accommodates the following data 
types: Boolean, Signed Byte, Unsigned Byte, Signed Short, Unsigned 
Short, Integer, Long, Float, Double, and Color 24. 

DCB. Division of Computational Bioscience. DCB is a research and 
development organization that provides engineering and computer 
science expertise to support biomedical research activities at the National 
Institutes of Health (NIH). DCB applies image processing and medical 
imaging technologies, high-performance parallel computing, high-speed 
networking, signal processing, state-of-the-art optical and electronic 
devices, bioinformatics, database technology, mathematical and 
statistical techniques, and modern hardware and software engineering 
principles to help solve biomedical research problems at NIH. 

DICOM. Digital Image Communication in Medicine. Standard protocol 
developed by the American College of Radiology (ACR) and National 
Electrical Manufacturers Association (NEMA). Specifies a standard 
method of communication between two devices. 

Double. Primitive, 64-bit, data type. Double is a floating point data type 
that accommodates decimal values, up to 14 or 15 significant digits of 

accuracy. Valid values can range from -1.7 x 10308 to 1.7 x 10308.

E

Endian. Data organization strategy. Refers to the way computer 
processors store data in memory. Big-endian format stores the most 
significant byte (MSB) first. Little-endian format stores the least 
significant byte (LSB) first.
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F

FF. Feet first.

Float. Primitive, 32-bit, data type. Float is a floating point data type that 
accommodates decimal values, up to 6 or 7 significant digits of accuracy. 

Valid values can range from -3.4 x 1038 to 3.4 x 1038.

FTP. File Transfer Protocol.

G

GIF. Graphic Interchange Format. A compressed, bit mapped, graphics 
file format that supports color and various resolutions.

GUI. Graphical user interface. A user interface that is based on graphics 
rather than text.

H

header offset. Space reserved at the beginning of some graphic files 
that contain non-image data.

HF. Head First

HP. Hewlett-Packard.

HSB. Hue Saturation Brightness. In this color model, hue is the color, 
saturation is the purity of the color; and brightness indicates the 
brightness or darkness of the color.

I

ID. Identifier.

IE. Information Entity. 

integer. Primitive, 32-bit, data type. Integer is sometimes abbreviated 
as int. Integer accommodates values that are whole numbers. Valid 
values range from -2,147,483,648 to +2,147,483,648.
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interlaced. A display technique that increases resolution. Half of the 
horizontal lines are drawn on the monitor during the first pass; the other 
half are drawn during the second pass. For example, the odd numbered 
lines may be drawn during the first pass and the even numbered lines 
during the second pass.

interpolation. The generation of intermediate values based on known 
values.

IOD. Information Object Definition

IOD. Information Object Definition. Provides an abstract definition of 
real-world objects applicable to the communication of digital medical 
information.

IP. Internet Protocol.

J

Java. High-level, object-oriented, platform-independent programming 
language developed by Sun Microsystems.

Java VM. Java Virtual Machine. 

JIT. Just-In-Time compiler. The JIT converts Java bytecode into 
machine language instructions. 

JPEG. Extension for Joint Photographics Experts Group formatted files. 
Also refers to a compression type.

K

L

Linux. An operating system that is an open source implementation of 
UNIX. 

Long. Primitive, 64-bit data type. Long is a variation of the integer data 
type. Long accommodates values that are whole numbers. Valid values 
range from -9,223,372,036,854,775,808 to +9,223,372,036,854,775,808.

LSB. Least Significant Byte. Also see endian.
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LUT. Lookup Table.

M

Mac OS. Macintosh Operating System

MB. Megabyte

MIPAV. Medical Image Processing, Analysis, and Visualization 
program. MIPAV is an n-dimensional, general-purpose, extensive image 
processing, and visualization program. It is platform-independent and 
assists researchers with extracting quantitative information from various 
medical imaging modalities.

MR. Magnetic Resonance.

MSB. Most Significant Byte. See endian for more details.

MSEE. Master of Science in Electrical Engineering

MTX. Extension for MIPAV's transform matrix files.

N

NEMA. National Electrical Manufacturers Association. 

NIH. National Institutes of Health.

NM. Nuclear medicine.

O

OS. Operating system

P

PACS. Picture Archiving System.

PCX. Extension for PC Paintbrush formatted graphic files.

PDU. Protocol Data Unit.
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PET. Positron Emission Tomography.

PICT. Extension for Macintosh formatted graphic files.

PLT. Extension for MIPAV’s graphics files.

PNG. Extension for Portable Network Graphic formatted graphic files.

PSD. Extension for Adobe Photoshop formatted graphic files.

Q

R

RAM. Random Access Memory

Raster. Bitmap file type. 

Raw. File type.

resolution. The sharpness and clarity of an image. 

RGB. Red Green Blue.

RIS. TBD.

RLE (Run Length Encoding). The file extension for graphics that 
have been reduced using run-length encoding. RLE is a compression 
method that converts consecutive identical characters into a code 
consisting of the character and the number marking the length of the run.

ROI. Region of Interest.

RS. Extension for Sun Raster formatted graphics files.

S

SCP. Service Class Provider.

SCU. Service Class User.

SGI. Silicon Graphics Incorporated.
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short. Primitive, 16-bit data type. Short is a variation of the integer data 
type. Short accommodates values that are whole numbers. Valid values 
range from 0 to +32,767.

signed byte. Primitive, 8-bit, data type. Signed byte is a variation of the 
integer data type. The signed byte data type signifies that valid values fall 
within a range of whole numbers. Valid values range from -128 to +128. 
Negative values (indicated by the negative sign) are permitted, hence the 
term, signed byte.

signed short. Primitive, 16-bit data type. Signed short is a variation of 
the integer data type. The signed short data type signifies that valid 
values fall within a range of whole numbers. Valid values range from -
32,768 to +32,767. Negative values (indicated by the negative sign) are 
permitted, hence the term, signed short.

Solaris. Unix-based operating environment that was developed by Sun 
Microsystems. Solaris consists of the Sun operating system and a 
windowing system.

SOP. Service Object Pair

SOP. Service Object Pair.

SPECT. TBD.

T

TCP/IP. Transmission Control Protocol/Internet Protocol. The suite of 
communications protocols used to connect hosts on the Internet.

TGA. Extension for Truevision Graphics Adapter formatted graphics 
files.

TIFF. Extension for Tag Image File Format formatted graphics files.

U

UID. Unique Identifier.

UNIX. Multi-tasking, multi-user operating system developed by Bell 
Labs. Many versions of UNIX abound, including Linux. 
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unsigned byte. Primitive, 8-bit, data type. Unsigned byte is a variation 
of the integer data type. The unsigned byte data type signifies that valid 
values must fall within a specified range of positive, whole-number 
values. Valid values range from 0 to +128. Negative values (indicated by 
the negative sign) are not valid, hence the term, unsigned byte.

unsigned short. Primitive, 16-bit data type. Unsigned short is a 
variation of the integer data type. The unsigned short data type signifies 
that valid values must fall within a specified range of positive, whole-
number values. Valid values range from 0 to +32,767. Note that negative 
values (indicated by the negative sign) are not valid, hence the term, 
unsigned byte.

US. Ultrasound

V

VM. Virtual Machine.

VOI. Volume of interest (used interchangeably with ROI).

voxel. Smallest distinguishable cube-shaped part of a 3D image.

W

X

XBM. X BitMap file format.

XPM. X PixMap file format.

Y

Z
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